SAS Studio: Accessibility Features

Overview

SAS is committed to providing accessible software, documentation, training and support materials through the ongoing evolution of our products and internal processes.

SAS adopted the Web Content Accessibility Guidelines (WCAG) version 2.1 level AA as our internal accessibility standard for all software, documentation, training and support materials. We have appointed a Director of Accessibility and established a centralized accessibility team that is charged with implementing the internal accessibility standard. The centralized accessibility team includes accessibility subject matter experts from a variety of disciplines including user experience design, visual design, computer science, quality assurance, and project management. Several members of the team have disabilities.

For detailed information about the accessibility of this product, email accessibility@sas.com or call SAS Technical Support.

Recommended Configuration

This product works with a variety of operating systems, browsers, and screen readers. However, SAS recommends the following software for a better experience using our product with a screen reader:

  • Use Google Chrome as your browser.
  • On Microsoft Windows, use the latest version of JAWS.
  • Use of VoiceOver on iOS.

SAS Graphics Accelerator

SAS Graphics Accelerator is a free Google Chrome extension that enables users with visual impairments or blindness to explore data visualizations. SAS Graphics Accelerator supports alternative presentations of data visualizations that include enhanced visual rendering, text descriptions, tabular data, and interactive sonification. Sonification uses non-speech audio to convey important information about the graph.

For more information about installing SAS Graphics Accelerator, see http://support.sas.com/software/products/graphics-accelerator/index.html.

To view an object with SAS Graphics Accelerator, select the object, and then select View with SAS Graphics Accelerator. SAS Graphics Accelerator displays the object on a new Google Chrome tab.

For more information, see SAS Graphics Accelerator: User’s Guide

Limited Vision

Selecting the High Contrast Theme

In SAS Studio, you can change the appearance of the web applications by using the Theme setting. The theme specifies the collection of colors, graphics, and fonts that appear in the application. SAS recommends trying the High Contrast theme. This theme uses a black background with bright foreground colors to achieve high contrast.

To change to the High Contrast theme:

  1. Click the user button on the application toolbar to access the application options menu.
  2. Click Settings.
  3. Navigate to the General page, which is in the Global section.
  4. For the Theme option, select Choose a theme.
  5. Select the High Contrast theme.
Note: The theme change takes effect after you close the Settings window.

Accessibility Setting for Limited Vision

There are several settings in the Accessibility section that can also be used to improve your experience.

To change these settings:

  1. Click the user button on the application toolbar to access the application options menu.
  2. Click Settings.
  3. Navigate to the Accessibility page, which is in the Global section.
  4. Update the settings that you are interested in.

The following settings for limited vision are available from this page:

  • To turn off animation, deselect Enable visual effects. Turning off this setting suppresses the subtle movement and animation that are used to emphasize changes in state in the interface.
  • Select Adjust the display duration for pop-up notifications to specify how long temporary pop-up notification messages are displayed. Increasing the amount of time that notifications are displayed can help users discover and read messages that disappear automatically.
  • Select Invert application colors to make the user interface easier to see for users with sensitivity to certain bright colors (for example, a black-on-white display). You can also use the Ctrl+` (Ctrl+back quotation mark) keyboard shortcut to invert the application colors.
  • Select Display tooltips when using the keyboard to navigate to specify the location where the tooltips appear in the browser window.

    Sometimes, the text for a heading is truncated in the user interface. To enable the display of the complete headings in tooltips, select Make truncated headings focusable.

  • The focus indicator is an outline that indicates which user interface component is active. You can make the focus indicator easier to see by selecting Customize the focus indicator settings and adjusting the color, thickness, and opacity.

Preferences in SAS Studio for Limited Vision

You can customize SAS Studio by using the Preferences window. To open the Preferences window, press Tab until you move focus to the Options button on the main menu. Press Spacebar to open the menu, and then select Preferences.

The Preferences window contains many tabs, including General, SAS Programs, Editors, and so on. The following preferences are recommended for limited vision:

  1. Open the Editors tab and click Editor Options. The Code Editor Settings window appears.
    • In the Behavior and Appearance pane, deselect the Show autocomplete list check box. Autocomplete can interfere with the proper function of the code editor.
    • In the navigation pane, select Colors and Fonts for SAS. Deselect the Enable syntax highlighting check box. Select a font size, if applicable. Repeat for the Color and Fonts for XML pane.
  2. To create accessible output, open the SAS Programthen selectResults tab.
    • Select the Generate HTML graphs as SVG check box. Select this option so that graphs maintain clarity when you zoom in and out.
    • Select the Enable accessible graph option so that you can take advantage of new graph accessibility features in SAS Studio.
    • The default theme for SAS Studio is minimum contrast (4.5:1). In preferences, you can select a high contrast (7:1 ratio). SAS recommends that you use the themes that are shipped with SAS software. Do not use themes that are provided by your operating system or Chrome extensions.

    For more information, see Configure SAS Studio for Accessible Output.

Changes to Application Themes

  • The Inspire application theme has been removed. If a user previously selected the Inspire theme, the default application theme is displayed the next time they sign in to the SAS Viya platform.
  • The following application themes have been renamed:
    • The Illuminate theme is now called the Light theme.
    • The Ignite theme is now called the Dark theme.

Without Vision

Description of User Interface

The SAS Studio application window contains three sections:

  • The top of the window contains the application name and application buttons.
  • The left side of the window has application buttons that you can use to open these sections in the navigation pane:
    • the Open Files section, which lists any files that are currently open in SAS Studio.
    • the Explorer section, which lists shortcuts to folders that you specify and enables you to access your content.
    • the Steps section, which lists the predefined steps that ship with SAS Studio and enables you to access the custom step interface that you can use to create steps for your site.
    • the Tasks section, which lists your custom tasks and SAS tasks that are shipped with SAS Studio.
    • the Snippets section, which lists your custom snippets and the SAS snippets that are shipped with SAS Studio.
    • the Libraries section, which lists libraries and tables.
    • the File References section, which lists any file references. This section is hidden by default.
    • the Git Repositories section, which enables you to access the basic Git features from within SAS Studio, including cloning repositories, committing and stashing file changes, pulling and pushing files, viewing your repository history, creating and merging branches, rebasing a branch, and performing a basic differentiation between files in your local repository.

    Only one section can be displayed at a time. Each section has its own toolbar.

  • The right side of the window (the work area) has primary tabs that can display SAS tables, text files (for example, SAS program files), flows, and tasks.
    • Tabs that display SAS program files contain a code editor with four secondary tabs: Code, Log, Results, and Output Data. The Results and Output Data tabs appear only when the submitted code generates results and output data. Each of the secondary tabs has its own toolbar.
    • Tabs that display SAS tables contain a toolbar for navigating through the rows of the table. Click the More options button to select the columns to display, generate code, open the data in a task, export the data, show labels or names, filter, specify the value for row paging, print the data, refresh the data, or view the table properties.
    • Tabs that display a flow include a work area for the flow and contain these secondary tabs: Generated Code and Submission.
    • Tabs that display a task's XML code contain a code editor with its own toolbar.
    • Tabs that display the user interface for tasks contain the task's user interface pane on the left and the three-tab code editor on the right (which displays the SAS code that is generated as you select options from the task's user interface). The user interface pane for the task can contain multiple tabs.

Understanding the Log Viewer

The Log Viewer is a feature that can be difficult for screen readers. At the top is a summary of the messages that appear in the entire log. Use the buttons to filter the messages by errors, notes, and warnings. When you select a message, SAS Studio highlights the message in the full log, which is read-only and presented in a text area control.

Accessibility Settings to Optimize Screen Reader Usage

In the Accessibility section, you can use the Enable sounds option to improve your experience.

  1. Click the user button on the application toolbar to access the application options menu.
  2. Click Settings.
  3. Navigate to the Accessibility page, which is in the Global section.
  4. Select Enable sounds to enable audio indicators for events that occur within the user interface. For example, you hear “tick, tick” for the loading screen.
    Note: Changes take effect after you sign out and sign back in.

Preferences to Optimize Screen Reader Usage

You can customize SAS Studio by using the Preferences window. To open the Preferences window, press Tab until you move focus to the Options button on the main menu. Press Spacebar to open the menu, and then select Preferences.

The Preferences window contains many tabs, including General, SAS Programs, Editors, and so on. The following preferences are recommended for screen reader users:

  1. Open the Editors, and click Editor Options. The Code Editor Settings window appears.
  2. In the Behavior and Appearance pane, deselect the Show autocomplete list check box. Autocomplete can interfere with the proper function of the code editor.
  3. To create accessible output, open the SAS Programthen selectResults tab.
  4. Select the Enable accessible graph option so that SAS Studio adds accessibility metadata to the graphs that are created by ODS Graphics. Users with disabilities access the accessibility metadata using SAS Graphics Accelerator.

Disabling the JAWS Virtual PC Cursor

SAS Studio is a Rich Internet Application that contains many highly interactive widgets. JAWS users should press Insert+Z to turn off the JAWS Virtual PC cursor by default. This strategy enables JAWS users to quickly use keyboard shortcuts to move focus around the SAS Studio application window, edit code, complete forms within tasks, and so on. Turning off the JAWS Virtual PC cursor also helps JAWS users avoid potential confusion that can occur when trying to access complex HTML5 widgets.

Note: JAWS users might need to temporarily turn on the JAWS Virtual PC cursor in order to access noninteractive HTML content within SAS Studio, such as the Log and Results tabs.

When using SAS Studio with the JAWS Virtual PC cursor disabled, JAWS users can quickly perform these actions:

  • Press Alt+1 (or Option+1 on Mac OS X) to move focus to the active tab in the navigation pane. Use the arrow keys to navigate among the tabs. JAWS reads the label of each section of the navigation pane. To toggle between showing and hiding the contents of that section visually on the screen, press Spacebar or Enter. Press Tab twice to move focus to the toolbar. Press Tab again to move to the next logical tab stop.
  • Press Alt+2 (or Option+2 on Mac OS X) to move focus to the label for the secondary tab that is currently displayed. Secondary tabs contain source code of a SAS program, log output from a SAS program, results, or output data from a SAS program. In a single tab layout, press the right arrow or left arrow to move focus to labels for other secondary tabs for programs. The contents of the tab are updated when you select the tab.
  • Press Alt+3 (or Option+3 on Mac OS X) to move focus to the label for the primary tab that is currently displayed. Primary tabs can contain SAS programs, tasks, tables, and so on. Press the right arrow or left arrow to move focus to the labels for other primary tabs. You must select the contents using Spacebar or Enter to display contents of that tab on the screen. Press Shift+F10 to open the pop-up menu for the tab.
  • Press Alt+4 to move focus to the code editor that is currently displayed.
  • Press F3 to run the SAS program that is currently displayed. The Results tab opens if the SAS program ran without error. If errors were encountered, the Log tab opens. Press Insert+Z to turn on the JAWS Virtual PC cursor so that you can read the noninteractive HTML content within the Log and Results tabs. You might need to press Insert+Escape to force JAWS to refresh the virtual buffer.

    You can also press F3 to run the flow that is currently displayed.

For more information about the accessibility of SAS Studio and the SAS programming language, see the accessibility forum on http://communities.sas.com.

Mobility

Accessibility Setting for Mobility

There are several settings in the Accessibility section that can also be used to improve your experience.

To change these settings:

  1. Click on the user button in the application toolbar to access the application options menu.
  2. Click Settings.
  3. Navigate to the Accessibility page, which is in the Global section.
  4. Update the settings that you are interested in.

The following settings for mobility are available from this page:

  • Select Display tooltips when using the keyboard to navigate to enable keyboard users to access tooltips. When this option is selected, putting keyboard focus on a control also displays the tooltip on the screen. You can also select the location in the browser window to display the tooltip. By default, the tooltip is displayed in the bottom right corner of the browser window.
  • The focus indicator is an outline that indicates which user interface component is active. You can make the focus indicator easier to see by selecting Customize the focus indicator settings and adjusting the color, thickness, and opacity.
  • Sometimes, the text for a heading is truncated in the user interface. To enable the display of the complete headings in tooltips, select the Display tooltips when using the keyboard to navigate and Make truncated headings focusable options.

Accessing Product-Specific Landmarks

This product provides custom landmarks that you can use to navigate. To access the product-specific landmarks, use Ctrl+F6 in Microsoft Windows and Command+F6 in Mac OS X.

The available landmarks depend on your location in the application.

For example, a page in your product might have these landmarks:

  • Application Bar moves focus to the banner that runs along the top of the product.
  • Search moves focus to the search.
  • Main Content Area moves focus to the area of SAS Studio where you select and work with items.
  • Navigation Area moves focus to the first item in the navigation area of the product.

Keyboard Shortcuts

Note: Some keyboard shortcuts might not work in flows.

SAS Studio Workspace

The following table contains the keyboard shortcuts for the application. Some keyboard shortcuts can be modified for your site. For more information, see Managing Keyboard Shortcuts in SAS Studio: User’s Guide.

Keyboard Shortcuts for SAS Studio Workspace

Action

Keyboard Shortcut for Microsoft Windows

Keyboard Shortcut for Mac OS X

Zoom in.

Note: When you zoom in to SAS Studio, no scroll bars are displayed for the browser window.

Ctrl+plus sign

Command+plus sign

Zoom out.

Ctrl+minus sign

Command+minus sign

Reset the zoom state.

Ctrl+0 (zero)

Command+0 (zero)

Open the SAS Studio Open window.

Ctrl+O (capital letter O)

Control+O (capital letter O)

Toggle the full screen view on and off.

Alt+F11

Fn+Option+F11

Toggle the Console window on and off.

Alt+C

Option+C

Open a pop-up menu in the navigation pane.

Select an item, and press Shift+F10.

Select an item, and press Fn+Shift+F10.

Navigate to the top node at the current level in the navigation pane.

Home

Fn+left arrow

Navigate to the top node in the current section of the navigation pane.

Ctrl+Home

Control+Fn+left arrow

Navigate to the bottom node at the current level in the navigation pane.

End

Control+Fn+right arrow

Navigate to the bottom node in the current section of the navigation pane.

Ctrl+End

Fn+left arrow

Create a SAS program.

F4

Fn+F4

Save the SAS program.

Ensure that the Code tab for a SAS program is displayed, and then press Ctrl+S.

Ensure that the Code tab for a SAS program is displayed, and then press Command+S.

Run the code.

Ensure that a Code tab is displayed, and then press F3 or F8. F3 runs any selected code or all the code if no code is selected. F8 always runs all the code.

Note: In JAWS, F3 is the keyboard shortcut for the find functionality. Therefore, to run SAS code, you first must press Insert+3, and then press F3. Alternatively, turn off the JAWS virtual PC cursor by pressing Insert+Z.

Ensure that a Code tab is displayed, and then press F3 or F8.

Reset the SAS session.

Note: When you reset the SAS session, all libraries and file shortcuts that you created during the current session are deleted.

F9

Fn+F9

Save the log or results file.

Ensure that the Log or Results tab is displayed, and then press Ctrl+S.

Ensure that the Log or Results tab is displayed, and then press Command+S.

Print the SAS program.

Ctrl+P

Command+P to open the content on a new tab. Then press Command+P again to print the content.

Close the selected primary tab.

Note: You cannot close the Code, Log, and Results tabs.

Ensure that the focus is on the tab label (press Alt+3 if necessary), and then press Alt+W.

Ensure that the focus is on the tab label (press Option+3 if necessary), and then press Option+W.

Move the focus to the active tab of the navigation pane. Use arrow keys to navigate among the tabs, and then press Spacebar or Enter to toggle between showing and hiding the contents of the active tab.

Alt+1

Option+1

Move the focus to the label for the secondary tab that is currently displayed.

Alt+2

Option+2

Move the focus to the next primary tab in the work area.

Alt+3

Option+3

Open the pop-up menu for the tab.

Shift+F10

Fn+Shift+F10

Move the focus to the body of the Code tab on the currently displayed primary tab.

Alt+4

Option+4

Move the focus to the selected item on the Log tab of the currently displayed primary tab.

Alt+5

Option+5

Move the focus to the Results tab.

Alt+6

Option+6

Move the focus to the Output Data tab, if one exists, on the currently displayed primary tab.

Alt+8

Option+8

Move the focus to the first button on the toolbar of the currently displayed tab.

Ctrl+Alt+1

Command+Option+1

Navigate between the navigation pane and the items in the SAS Studio workspace.

Tab, Shift+Tab

Tab, Shift+Tab

Navigate among the icons on the navigation pane.

Up and down arrow keys

Up and down arrow keys

Move the active tab with focus to the previous position.

Ctrl+Shift+left arrow

Control+Shift+left arrow

Move the active tab with focus to the next position.

Ctrl+Shift+right arrow

Control+Shift+right arrow

Move the focus to the Libraries tab of the navigation pane. Press Spacebar or Enter to toggle between showing and hiding the contents of the Libraries tab.

Ctrl+Shift+L

Command+Shift+L

Open or close the Submission Status window.

Alt+U

Control+U

Upload a file.

Ctrl+Shift+Page Up

Command+Shift+Page Up

Clear log.

Alt+L

Option+L

Recall in Interactive Perspective.

Alt+R

Control+R

Code Editor

The following table contains keyboard shortcuts for the code editor in SAS Studio.

Keyboard Shortcuts for Code Editor

Action

Keyboard Shortcut for Microsoft Windows

Keyboard Shortcut for Mac OS X

Open a pop-up menu in the code editor.

Shift+F10

Fn+Shift+F10

Create a snippet from SAS code.

Note: The snippet is saved to your My Snippets folder.

In the code editor, select the code and press Alt+A.

Note: If no code is selected, all the code is added to the snippet.

In the code editor, select the code and press Option+Shift+A.

Note: If no code is selected, all the code is added to the snippet.

Insert an existing snippet.

Alt+I

Option+Shift+I

Add or remove comment tags for SAS code in the code editor.

Ctrl+/

Command+/

In the code editor, display the currently applicable list of SAS keywords (autocomplete feature).

Ctrl+Spacebar (This shortcut also navigates to the next list if more than one list is available.)

Ctrl+Shift+Spacebar (This shortcut also navigates to the previous list if more than one list is available.)

Note: These shortcuts do not work when JAWS is on.

Note: If you use Ctrl+Spacebar to switch the input method editor (IME) in Windows, complete these steps to use a different shortcut for switching the IME:

  • First, in the region and language options of the Control Panel, select the option for changing your keyboard or input method.
  • Next, select the option or button for changing your keyboard.
  • Then, in the advanced key settings section, select the row that contains the Ctrl+Spacebar key sequence and change it to use a different shortcut.
  • Finally, restart any application that needs to use the new shortcut. (You might need to also restart your computer.)

Control+Spacebar (This shortcut also navigates to the next list if more than one list is available.)

Control+Shift+Spacebar (This shortcut also navigates to the previous list if more than one list is available.)

Navigate between an autocomplete list and its associated Help pop-up window in the code editor.

Tab, Shift+Tab

Tab, Shift+Tab

Select all text in the code editor.

Ctrl+A

Command+A

Copy text in the code editor.

Ctrl+C

Command+C

Cut text in the code editor.

Ctrl+X

Command+X

Paste text in the code editor.

Ctrl+V

Command+V

Undo an action in the code editor.

Ctrl+Z

Command+Z

Redo an action in the code editor.

Ctrl+Y

Command+Shift+Z

Find text in the code editor.

Ensure that the focus is in the body of the code editor, and then press Ctrl+F.

Ensure that the focus is in the body of the code editor, and then press Command+F.

Find and replace text in the code editor.

Ensure that the focus is in the body of the code editor, and then press Ctrl+H.

Ensure that the focus is in the body of the code editor, and then press Control+Command+H.

Fold the current region of code.

Ctrl+numeric keypad minus sign

Command+numeric keypad minus sign

Unfold the current region of code.

Ctrl+numeric keypad plus sign

Command+numeric keypad plus sign

Fold all regions of code.

Alt+numeric keypad minus sign

Option+numeric keypad minus sign

Unfold all regions of code.

Alt+numeric keypad plus sign

Option+numeric keypad plus sign

Move the cursor to the beginning of the word to the left of the cursor.

Ctrl+left arrow

Option+left arrow

Move the cursor to the beginning of the word to the right of the cursor.

Ctrl+right arrow

Option+right arrow

Move the cursor to the beginning of the previous paragraph.

Ctrl+up arrow

Option+up arrow

Move the cursor to the beginning of the next paragraph.

Ctrl+down arrow

Option+down arrow

Go to a specified line.

Ctrl+G

Control+G

Scrolls the editor. (If you are using a browser other than Microsoft Edge, the cursor does not move.)

Press Ctrl+up arrow or Ctrl+down arrow to move up or down one item in the list. To scroll, hold down the Ctrl+up arrow or Ctrl+down arrow key.

Scrolls a page down or up (moves cursor).

Page Down, Page Up

Page Down, Page Up

Note: If you are not using the full extension keyboard, use Fn+down and Fn+up to page down and page up.

Move the cursor to the end of the line.

End

Command+right arrow

Move the cursor to the beginning of the line.

Home

Command+left arrow

Move the cursor to the top of the document.

Ctrl+Home

Command+up arrow

Move the cursor to the bottom of the document.

Ctrl+End

Command+down arrow

Select (highlight) text to the left of the cursor character-by-character.

Shift+left arrow

Shift+left arrow

Select (highlight) text to the right of the cursor character-by-character.

Shift+right arrow

Shift+right arrow

Select (highlight) text from the cursor to the same location on the previous line.

Shift+up arrow

Shift+up arrow

Select (highlight) text from the cursor to the same location on the next line.

Shift+down arrow

Shift+down arrow

Delete the word to the left of the cursor.

Ctrl+Backspace

Option+Delete (backward)

Note: If your keyboard does not contain a key for deleting backward, then press Fn+Delete.

Delete the word to the right of the cursor.

Ctrl+Delete

Fn+Option+Delete (forward)

Note: If your keyboard does not contain a key for deleting forward, then press Fn+Delete.

Delete the current line.

Command+Delete (backward)

Note: If your keyboard does not contain a key for deleting backward, then press Fn+Delete.

Select (highlight) the word to the left of the cursor.

Ctrl+Shift+left arrow

Option+Shift+left arrow

Select (highlight) the word to the right of the cursor.

Ctrl+Shift+right arrow

Option+Shift+right arrow

Select (highlight) text from the cursor to the beginning of the document.

Command+Shift+up arrow

Select (highlight) text from the cursor to the end of the document.

Command+Shift+down arrow

Select a column or vertical block of text.

Alt+left mouse button. Then drag the mouse pointer to select the text.

Option+left mouse button. Then drag the mouse pointer to select the text.

Edit multiple lines of code at one time.

Ctrl+left mouse button. Click each location that you want to edit.

Command+left mouse button. Click each location that you want to edit.

Change the case of the selected text.

Ctrl+Shift+U cycles among initial capital, uppercase, and lowercase text.

Command+Shift+U cycles among initial capital, uppercase, and lowercase text.

Expression Builder

This table contains keyboard shortcuts for the expression builder in the Filter Table Rows window.

Keyboard Shortcuts for Expression Builder in Filter Table Rows Window

Action

Keyboard Shortcut for Microsoft Windows

Keyboard Shortcut for Mac OS X

Move the focus to the first button on the expression editor toolbar.

Ctrl+Alt+T

Command+Option+T

Move the focus to the Values tab.

Ctrl+Alt+V

Command+Option+V

Move the focus to the Log tab.

Ctrl+Alt+L

Command+Option+L

DATA Step Debugger

Keyboard Shortcuts for DATA Step Debugger

Action

Keyboard Shortcut for Microsoft Windows

Keyboard Shortcut for Mac OS X

Open the currently selected DATA step in the DATA Step Debugger.

Ctrl+Shift+D

Control+Shift+D

Start or continue execution of the program.

F5

F5

Execute the statement starting at the point at which execution was suspended. Only one statement is executed at a time.

Alt+F10

Control+F10

Turn breakpoint on and off on the current line.

Alt+Shift+B

Option+Shift+B

Clear all breakpoints.

Shift+F9

Shift+F9

Command Line

Keyboard Shortcuts for Command Line

Action

Keyboard Shortcut for Microsoft Windows

Keyboard Shortcut for Mac OS X

Open the command line.

Alt+M

Option+M

Put focus in the command line.

Ctrl+Alt+I

Command+Option+I

Abort execution of commands.

Ctrl+Shift+X

Command+Shift+X

Step Designer

In Step Designer, you can copy any control, including the page control. When you copy a page or a section, all controls are also copied.

To select a control, use the keyboard to give the control focus.

Keyboard Shortcuts for Step Designer

Action

Keyboard Shortcut for Microsoft Windows

Keyboard Shortcut for Mac OS X

Cut the selected control.

Ctrl+X

Command+X

Copy the selected control to the clipboard.

Ctrl+C

Command+C

Paste the copied control from the clipboard to the current page.

Ctrl+V

Command+V

Delete the selected content.

Delete

Fn+Delete

Undo

Ctrl+Z

Command+Z

Redo

Ctrl+Y

Command+Shift+Z

Troubleshooting Keyboard Shortcuts

Your shortcut keys might not work as expected due to the following reasons:

  • The keyboard shortcut might be reserved for use by your browser.
  • Your keyboard is not a standard U.S. keyboard and therefore some of the keyboard shortcuts are not supported.
  • Your web browser is not supported or needs to be upgraded.
  • Some shortcut keys might conflict with the shortcut keys of the Input Method Editor (IME). You can modify the IME shortcut.
Note: Some keyboard shortcuts might not work in flows.

Hearing

All short-form English language external SAS videos are captioned as part of the standard video publishing process along with select longer-form videos. This includes both technical and marketing videos that are published to the SAS Software and SAS Users channel on YouTube and to SAS web properties. Longer-form videos that are not captioned as part of the standard process can be captioned upon request.

Contact Us

Email us at accessibility@sas.com if you need this document in an alternative digital format. For more information about the accessibility of SAS products, visit Accessibility at SAS.

Last updated: June 20, 2024