SAS Studio 5.2: Accessibility Features

Overview

SAS Studio 5.2 has been tested against the accessibility standards for electronic information technology that were adopted by the U.S. Government under Section 508 of the U.S. Rehabilitation Act of 1973. Applications are also tested against Web Content Accessibility Guidelines (WCAG) 2.0, part of the Web Accessibility Initiative (WAI) of the Worldwide Web Consortium (W3C). For detailed information about the accessibility of this product, email accessibility@sas.com or call SAS Technical Support.

High-Contrast Theme

In SAS Studio Enterprise, you can change the appearance of web applications by using the Theme setting. The default theme is set by the system administrator, though you can choose to use a high-contrast theme instead. The high-contrast theme presents a dark background with high-contrast foreground elements.

Note: Changing the theme does not impact other users.
  1. Click your name on the application bar and select Settings.
  2. Navigate to the General section.
  3. Select Choose a theme, and then select High Contrast.
Note: Themes are not available in SAS Studio Basic.

User Interface Layout

The SAS Studio application window contains three sections:

  • The top of the window contains the application name and application buttons.
  • The left side of the window has application buttons that you can use to open these sections in the navigation pane:
    • the Open Files section, which lists any files that are currently open in SAS Studio.
    • the Explorer section, which lists shortcuts to folders that you specify and enables you to access your content.
    • the Tasks section, which lists your custom tasks and SAS tasks that are shipped with SAS Studio.
    • the Snippets section, which lists your custom snippets and the SAS snippets that are shipped with SAS Studio.
    • the Libraries section, which lists libraries and tables.
    • the File References section, which lists any file references. This section is hidden by default.
    • the Git Repositories section, which enables you to access the basic Git features from within SAS Studio, including cloning repositories, committing and stashing file changes, pulling and pushing files, viewing your repository history, creating and merging branches, rebasing a branch, and performing a basic differentiation between files in your local repository.

    Only one section can be displayed at a time. Each section has its own toolbar.

  • The right side of the window (the work area) has primary tabs that can display SAS tables, text files (for example, SAS program files), and tasks.
    • Tabs that display SAS program files contain a code editor with four secondary tabs: Code, Log, Results, and Output Data. The Results and Output Data tabs appear only when the submitted code generates results and output data. Each of the secondary tabs has its own toolbar.
    • Tabs that display SAS tables contain a toolbar for navigating through the rows of the table. Click the More options button to select the columns to display, generate code, open the data in a task, export the data, show labels or names, filter, specify the value for row paging, print the data, refresh the data, or view the table properties.
    • Tabs that display a task's XML code contain a code editor with its own toolbar.
    • Tabs that display the user interface for tasks contain the task's user interface pane on the left and the three-tab code editor on the right (which displays the SAS code that is generated as you select options from the task's user interface). The user interface pane for the task can contain multiple tabs.

Tips for Screen Reader Users

Recommended Configuration

SAS Studio 5.2 works with a variety of operating systems, browsers, and screen readers. The recommended configuration is JAWS and Google Chrome.

Preferences

You can customize SAS Studio by using the Preferences window. To open the Preferences window, press Tab until you move focus to the Options button on the main menu. Press Spacebar to open the menu, and then select Preferences.

The Preferences dialog box contains many tabs, including General, SAS Programs, Editors, and so on. The following preferences are recommended for screen reader users:

  1. Open the Editors tab. Click the Editor Options button. The Code Editor Settings window appears.
    • In the Behavior and Appearance pane, deselect the Show autocomplete list check box. Autocomplete can interfere with the proper function of the code editor.
    • In the navigation pane, select Colors and Fonts for SAS. Deselect the Enable syntax highlighting check box. Select a font size, if applicable. Repeat for the Color and Fonts for XML pane.
  2. Open the SAS Programsthen selectResults tab.
    • Select the Generate HTML graphs as SVG check box. Select this option so that graphs maintain clarity when you zoom in and out.
    • Select the Enable accessible graph option check box so that you can take advantage of new graph accessibility features in SAS Studio.
    • The default theme for SAS Studio is minimum contrast (4.5:1). In preferences, you can select a high contrast (7:1 ratio). SAS recommends that you use the themes that are shipped with the SAS software. Do not use themes that are provided by your operating system or Chrome extensions.

SAS Graphics Accelerator

SAS Graphics Accelerator is a free Google Chrome extension that enables users with visual impairments or blindness to explore data visualizations. It supports alternative presentations of data visualizations that include enhanced visual rendering, text descriptions, tabular data, and interactive sonification. Sonification uses non-speech audio to convey important information about the graph.

For more information about installing SAS Graphics Accelerator, see http://support.sas.com/software/products/graphics-accelerator/index.html.

To view an object with SAS Graphics Accelerator, select More optionsfor the object, and then select View with SAS Graphics Accelerator.

SAS Graphics Accelerator displays the object in a new Google Chrome tab.

For more information, see SAS Graphics Accelerator: User’s Guide.

Usage

SAS Studio is a Rich Internet Application that contains many highly interactive widgets. JAWS users should press Insert+Z to turn off the JAWS Virtual PC cursor by default. This strategy enables JAWS users to quickly use keyboard shortcuts to move focus around the SAS Studio application window, edit code, complete forms within tasks, and so on. Turning off the JAWS Virtual PC cursor also helps JAWS users avoid potential confusion that can occur when trying to access complex HTML5 widgets.

Note: JAWS users might need to temporarily turn on the JAWS Virtual PC cursor in order to access noninteractive HTML content within SAS Studio, such as the Log and Results tabs.

When using SAS Studio with the JAWS Virtual PC cursor disabled, JAWS users can quickly perform these actions:

  • Press Alt+1 (or Option+1 on Mac OS X) to move focus to the label for the Open Files section in the navigation pane. The Open Files section is the first section in a collapsible navigation pane. Press the right arrow or left arrow to navigate to other sections such as Explorer, Tasks, Snippets, and Libraries. JAWS reads the label of each section in the navigation pane. To display the contents of that section visually on the screen, press Spacebar. Press Tab twice to move focus to the toolbar. Press Tab again to move to the next logical tab stop.
  • Press Alt+2 (or Option+2 on Mac OS X) to move focus to the label for the secondary tab that is currently displayed. Secondary tabs contain source code of a SAS program, log output from a SAS program, results, or output data from a SAS program. In a single tab layout, press the right arrow or left arrow to move focus to labels for other secondary tabs for programs. The contents of the tab are updated when you select the tab.
  • Press Alt+3 (or Option+3 on Mac OS X) to move focus to the label for the primary tab that is currently displayed. Primary tabs can contain SAS programs, tasks, tables, and so on. Press the right arrow or left arrow to move focus to the labels for other primary tabs. You must select the contents using Spacebar or Enter to display contents of that tab on the screen. Press Shift+F10 to open the context menu for the tab.
  • Press Alt+4 to move focus to the code editor that is currently displayed.
  • Press F3 to run the SAS program that is currently displayed. The Results tab opens if the SAS program ran without error. If errors were encountered, the Log tab opens. Press Insert+Z to turn on the JAWS Virtual PC cursor so that you can read the noninteractive HTML content within the Log and Results tabs. You might need to press Insert+Escape to force JAWS to refresh the virtual buffer.

For more information about the accessibility of SAS Studio and the SAS programming language, see the accessibility forum on http://communities.sas.com.

Keyboard Shortcuts

SAS Studio Workspace

The following table contains the keyboard shortcuts for the application. Some keyboard shortcuts can be modified for your site. For more information, see Managing Keyboard Shortcuts in SAS Studio: User’s Guide.

Keyboard Shortcuts for SAS Studio Workspace

Action

Keyboard Shortcut for Microsoft Windows

Keyboard Shortcut for Mac OS X

Zoom in.

Note: When you zoom in to SAS Studio, no scroll bars are displayed for the browser window.

Ctrl+plus sign

Command+plus sign

Zoom out.

Ctrl+minus sign

Command+minus sign

Reset the zoom state.

Ctrl+0 (zero)

Command+0 (zero)

Open the SAS Studio Open window.

Ctrl+O (capital letter O)

Control+O (capital letter O)

Toggle the full screen view on and off.

Alt+F11

Fn+Option+F11

Toggle the Console window on and off.

Alt+C

Option+C

Open a pop-up menu in the navigation pane.

Select an item, and press Shift+F10.

Select an item, and press Fn+Shift+F10.

Navigate to the top node at the current level in the navigation pane.

Home

Fn+left arrow

Navigate to the top node in the current section of the navigation pane.

Ctrl+Home

Control+Fn+left arrow

Navigate to the bottom node at the current level in the navigation pane.

End

Control+Fn+right arrow

Navigate to the bottom node in the current section of the navigation pane.

Ctrl+End

Fn+left arrow

Create a SAS program.

F4

Fn+F4

Save the SAS program.

Ensure that the Code tab for a SAS program is displayed, and then press Ctrl+S.

Ensure that the Code tab for a SAS program is displayed, and then press Command+S.

Run the code.

Ensure that a Code tab is displayed, and then press F3 or F8. F3 runs any selected code or all the code if no code is selected. F8 always runs all the code.

Note: In JAWS, F3 is the keyboard shortcut for the find functionality. Therefore, to run SAS code, you first must press Insert+3, and then press F3. Alternatively, turn off the JAWS virtual PC cursor by pressing Insert+Z.

Ensure that a Code tab is displayed, and then press F3 or F8.

Reset the SAS session.

Note: When you reset the SAS session, all libraries and file shortcuts that you created during the current session are deleted.

F9

Fn+F9

Save the log or results file.

Ensure that the Log or Results tab is displayed, and then press Ctrl+S.

Ensure that the Log or Results tab is displayed, and then press Command+S.

Print the SAS program.

Ctrl+P

Command+P to open the content on a new tab. Then press Command+P again to print the content.

Close the selected primary tab.

Note: You cannot close the Code, Log, and Results tabs.

Ensure that the focus is on the tab label (press Alt+3 if necessary), and then press Alt+W.

Ensure that the focus is on the tab label (press Option+3 if necessary), and then press Option+W.

Move the focus to the button for the active section of the navigation pane. Use Tab and Shift+Tab to navigate among the buttons, and then press Enter to open the selected section.

Alt+1

Option+1

Move the focus to the label for the secondary tab that is currently displayed.

Alt+2

Option+2

Move the focus to the next primary tab in the work area.

Alt+3

Option+3

Open the context menu for the tab.

Shift+F10

Fn+Shift+F10

Move the focus to the body of the Code tab on the currently displayed primary tab.

Alt+4

Option+4

Move the focus to the selected item on the Log tab of the currently displayed primary tab.

Alt+5

Option+5

Move the focus to the Results tab.

Alt+6

Option+6

Move the focus to the Output Data tab, if one exists, on the currently displayed primary tab.

Alt+7

Option+7

Move the focus to the first button on the toolbar of the currently displayed tab.

Ctrl+Alt+1

Command+Option+1

Navigate through items in the navigation pane and the SAS Studio workspace.

Tab, Shift+Tab

Tab, Shift+Tab

Move the active tab with focus to the previous position.

Ctrl+Shift+left arrow

Control+Shift+left arrow

Move the active tab with focus to the next position.

Ctrl+Shift+right arrow

Control+Shift+right arrow

Open or close the Submission Status window.

Alt+U

Control+U

Upload a file.

Ctrl+Shift+Page Up

Command+Shift+Page Up

Clear log.

Alt+L

Option+L

Recall in Interactive Perspective.

Alt+R

Control+R

Code Editor

The following table contains keyboard shortcuts for the code editor in SAS Studio.

Keyboard Shortcuts for Code Editor

Action

Keyboard Shortcut for Microsoft Windows

Keyboard Shortcut for Mac OS X

Open a pop-up menu in the code editor.

Shift+F10

Fn+Shift+F10

Create a snippet from SAS code.

Note: The snippet is saved to your My Snippets folder.

In the code editor, select the code and press Alt+A.

Note: If no code is selected, all the code is added to the snippet.

In the code editor, select the code and press Option+Shift+A.

Note: If no code is selected, all the code is added to the snippet.

Insert an existing snippet.

Alt+I

Option+Shift+I

Add or remove comment tags for SAS code in the code editor.

Ctrl+/

Command+/

In the code editor, display the currently applicable list of SAS keywords (autocomplete feature).

Ctrl+Spacebar (This shortcut also navigates to the next list if more than one list is available.)

Ctrl+Shift+Spacebar (This shortcut also navigates to the previous list if more than one list is available.)

Note: These shortcuts do not work when JAWS is on.

Note: If you use Ctrl+Spacebar to switch the input method editor (IME) in Windows, complete these steps to use a different shortcut for switching the IME:

  • First, in the region and language options of the Control Panel, select the option for changing your keyboard or input method.
  • Next, select the option or button for changing your keyboard.
  • Then, in the advanced key settings section, select the row that contains the Ctrl+Spacebar key sequence and change it to use a different shortcut.
  • Finally, restart any application that needs to use the new shortcut. (You might need to also restart your computer.)

Control+Spacebar (This shortcut also navigates to the next list if more than one list is available.)

Control+Shift+Spacebar (This shortcut also navigates to the previous list if more than one list is available.)

Navigate between an autocomplete list and its associated Help pop-up window in the code editor.

Tab, Shift+Tab

Tab, Shift+Tab

Select all text in the code editor.

Ctrl+A

Command+A

Copy text in the code editor.

Ctrl+C

Command+C

Cut text in the code editor.

Ctrl+X

Command+X

Paste text in the code editor.

Ctrl+V

Command+V

Undo an action in the code editor.

Ctrl+Z

Command+Z

Redo an action in the code editor.

Ctrl+Y

Command+Shift+Z

Find text in the code editor.

Ensure that the focus is in the body of the code editor, and then press Ctrl+F.

Ensure that the focus is in the body of the code editor, and then press Command+F.

Find and replace text in the code editor.

Ensure that the focus is in the body of the code editor, and then press Ctrl+H.

Ensure that the focus is in the body of the code editor, and then press Control+Command+H.

Move the cursor to the beginning of the word to the left of the cursor.

Ctrl+left arrow

Option+left arrow

Move the cursor to the beginning of the word to the right of the cursor.

Ctrl+right arrow

Option+right arrow

Move the cursor to the beginning of the previous paragraph.

Ctrl+up arrow

Option+up arrow

Move the cursor to the beginning of the next paragraph.

Ctrl+down arrow

Option+down arrow

Go to a specified line.

Ctrl+G

Control+G

Scrolls the editor. (If you are using a browser other than Microsoft Edge, the cursor does not move.)

Press Ctrl+up arrow or Ctrl+down arrow to move up or down one item in the list. To scroll, hold down the Ctrl+up arrow or Ctrl+down arrow key.

Scrolls a page down or up (moves cursor).

Page Down, Page Up

Page Down, Page Up

Note: If you are not using the full extension keyboard, use Fn+down and Fn+up to page down and page up.

Move the cursor to the end of the line.

End

Command+right arrow

Move the cursor to the beginning of the line.

Home

Command+left arrow

Move the cursor to the top of the document.

Ctrl+Home

Command+up arrow

Move the cursor to the bottom of the document.

Ctrl+End

Command+down arrow

Select (highlight) text to the left of the cursor character-by-character.

Shift+left arrow

Shift+left arrow

Select (highlight) text to the right of the cursor character-by-character.

Shift+right arrow

Shift+right arrow

Select (highlight) text from the cursor to the same location on the previous line.

Shift+up arrow

Shift+up arrow

Select (highlight) text from the cursor to the same location on the next line.

Shift+down arrow

Shift+down arrow

Delete the word to the left of the cursor.

Ctrl+Backspace

Option+Delete (backward)

Note: If your keyboard does not contain a key for deleting backward, then press Fn+Delete.

Delete the word to the right of the cursor.

Ctrl+Delete

Fn+Option+Delete (forward)

Note: If your keyboard does not contain a key for deleting forward, then press Fn+Delete.

Delete the current line.

Command+Delete (backward)

Note: If your keyboard does not contain a key for deleting backward, then press Fn+Delete.

Select (highlight) the word to the left of the cursor.

Ctrl+Shift+left arrow

Option+Shift+left arrow

Select (highlight) the word to the right of the cursor.

Ctrl+Shift+right arrow

Option+Shift+right arrow

Select (highlight) text from the cursor to the beginning of the document.

Command+Shift+up arrow

Select (highlight) text from the cursor to the end of the document.

Command+Shift+down arrow

Select a column or vertical block of text.

Alt+left mouse button. Then drag the mouse pointer to select the text.

Option+left mouse button. Then drag the mouse pointer to select the text.

Edit multiple lines of code at one time.

Ctrl+left mouse button. Click each location that you want to edit.

Command+left mouse button. Click each location that you want to edit.

Change the case of the selected text.

Ctrl+Shift+U cycles among initial capital, uppercase, and lowercase text.

Command+Shift+U cycles among initial capital, uppercase, and lowercase text.

Expression Builder

This table contains keyboard shortcuts for the expression builder in the Filter Table Rows window.

Keyboard Shortcuts for Expression Builder in Filter Table Rows Window

Action

Keyboard Shortcut for Microsoft Windows

Keyboard Shortcut for Mac OS X

Move the focus to the first button on the expression editor toolbar.

Ctrl+Alt+T

Command+Option+T

Move the focus to the Values tab.

Ctrl+Alt+V

Command+Option+V

Move the focus to the Log tab.

Ctrl+Alt+L

Command+Option+L

DATA Step Debugger

Keyboard Shortcuts for DATA Step Debugger

Action

Keyboard Shortcut for Microsoft Windows

Keyboard Shortcut for Mac OS X

Open the currently selected DATA step in the DATA Step Debugger.

Ctrl+Shift+D

Control+Shift+D

Start or continue execution of the program.

F5

F5

Execute the statement starting at the point at which execution was suspended. Only one statement is executed at a time.

Alt+F10

Control+F10

Turn breakpoint on and off on the current line.

Alt+Shift+B

Option+Shift+B

Clear all breakpoints.

Shift+F9

Shift+F9

Command Line

Keyboard Shortcuts for Expression Builder in Filter Table Rows Window

Action

Keyboard Shortcut for Microsoft Windows

Keyboard Shortcut for Mac OS X

Open the command line.

Alt+M

Option+M

Show the command line if hidden.

Ctrl+Alt+I

Command+Option+I

Abort execution of commands.

Ctrl+Shift+X

Command+Shift+X

Exceptions to Accessibility Standards

Code Editor

Known Accessibility Limitations for Code Editor

Accessibility Issue

Workaround

Code folding does not have screen reader support. The screen reader might not recognize code that is in a collapsed section.

In the code editor settings, deselect Enable code folding.

Using Chrome, JAWS does not correctly read the contents of the code editor when navigating with the arrow keys. For example, JAWS does not correctly read the contents when you use the up and down arrows to navigate by line.

Use Mozilla Firefox when working with the code editor.

Tables

Known Accessibility Limitations for Tables

Accessibility Issue

Workaround

Tables are not fully supported for keyboard users. Columns cannot be resized using only the keyboard.

No workaround is available.

Tables are not fully supported with screen readers. Limitations include the following:

  • Screen readers cannot reliably announce whether a column is sorted.
  • NVDA incorrectly announces that rows are selected when they are not selected.

No workaround is available.

Last updated: July 16, 2021