# Contents

*What’s New in SAS 9.4 ODS Graphics Editor* ........................................... ix  
*Accessibility Notice* ............................................................................. xiii

## PART 1  Introduction to the ODS Graphics Editor  

### Chapter 1  /  Overview of the ODS Graphics Editor  

- About the ODS Graphics Editor .................................................. 3  
- Why Use the ODS Graphics Editor? ........................................... 4  
- Key Features of the ODS Graphics Editor ................................. 5  
- Types of Files That Can Be Edited .............................................. 5  
- Components of a Graph ............................................................... 6  
- General Editing and Annotation Concepts .............................. 7  
- Use of Locale .............................................................................. 8

### Chapter 2  /  Getting Started with the ODS Graphics Editor  

- Using a Stand-Alone ODS Graphics Editor .......................... 9  
- Creating Editable Graphics .......................................................... 10  
- Start the ODS Graphics Editor ................................................... 11  
- Open an ODS Graph for Editing .............................................. 13  
- About SGE Files Generated on z/OS Systems ....................... 13  
- About the Graph Toolbar ............................................................ 14  
- Save Graph Output ..................................................................... 15  
- Print Graph Output ..................................................................... 17  
- Copy and Paste a Graph ............................................................. 18  
- Create a New Blank Window ..................................................... 19
PART 2 Editing Graphs 21

Chapter 3 / Modifying General Graph Properties 23

- Specify a Style for a Graph 23
- Resize a Graph 25
- Change the Background Color of a Graph 27
- Change Group Attributes 28
- Understanding Attribute Priority 31

Chapter 4 / Working with Titles and Footnotes 33

- About Titles and Footnotes 33
- Add a Title or Footnote to a Graph 34
- Edit or Format a Title or Footnote 35
- Using the Formatting Toolbar 36
- Using the Color List Box 37
- Aligning a Title or Footnote in a Graph 39
- Move a Title or Footnote in a Graph 41
- Delete a Title or Footnote from a Graph 41
- Use of Alternate Short Text in Graph Elements 42

Chapter 5 / Working with Legends 43

- About Legends 43
- Add or Edit a Legend Title 44
- Change the Outline and Background Color of a Legend 44
- Move a Legend Inside or Outside a Plot 45

Chapter 6 / Modifying Plot and Axis Properties 49

- Working with Plot Properties 49
- Working with Axis Properties 59
- Working with Axis Labels 60
- Edit an Existing Axis Label 61
- Add an Axis Label 61
- Show or Hide an Axis Label 62
- Delete an Axis Label 63
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add an Arrow to a Graph</td>
<td>117</td>
</tr>
<tr>
<td>About Ovals and Rectangles</td>
<td>118</td>
</tr>
<tr>
<td>Add an Oval to a Graph</td>
<td>119</td>
</tr>
<tr>
<td>Add a Rectangle to a Graph</td>
<td>119</td>
</tr>
<tr>
<td>About Markers</td>
<td>120</td>
</tr>
<tr>
<td>Add a Marker to a Graph</td>
<td>121</td>
</tr>
<tr>
<td>About Images</td>
<td>121</td>
</tr>
<tr>
<td>Add and Position an Image in a Graph</td>
<td>122</td>
</tr>
<tr>
<td><strong>Chapter 12 / Changing the Visual Properties of Annotations</strong></td>
<td>123</td>
</tr>
<tr>
<td>Format a Text Annotation</td>
<td>123</td>
</tr>
<tr>
<td>Change the Color, Pattern, and Thickness of a Line or Arrow</td>
<td>124</td>
</tr>
<tr>
<td>Change the Color, Transparency, and Outline</td>
<td>125</td>
</tr>
<tr>
<td>Change the Color, Symbol, and Size of a Marker</td>
<td>127</td>
</tr>
<tr>
<td>Format an Outline around an Image</td>
<td>128</td>
</tr>
<tr>
<td><strong>Chapter 13 / Adding Text to Annotations</strong></td>
<td>131</td>
</tr>
<tr>
<td>Overview of Adding Text to Annotations</td>
<td>131</td>
</tr>
<tr>
<td>Add Text to an Annotation</td>
<td>132</td>
</tr>
<tr>
<td>Edit Text That Has Been Added to an Annotation</td>
<td>133</td>
</tr>
<tr>
<td>Format Text That Has Been Added to an Annotation</td>
<td>133</td>
</tr>
<tr>
<td>Move Text That Has Been Added to an Annotation</td>
<td>134</td>
</tr>
<tr>
<td><strong>Chapter 14 / Modifying Annotations</strong></td>
<td>135</td>
</tr>
<tr>
<td>Resize an Annotation</td>
<td>135</td>
</tr>
<tr>
<td>Rotate an Annotation</td>
<td>139</td>
</tr>
<tr>
<td>Move an Annotation</td>
<td>141</td>
</tr>
<tr>
<td>Copy and Paste an Annotation Object</td>
<td>142</td>
</tr>
<tr>
<td>Delete an Annotation</td>
<td>142</td>
</tr>
<tr>
<td>Working with Groups of Annotation Objects</td>
<td>143</td>
</tr>
<tr>
<td>Change the Order of Annotation Objects</td>
<td>143</td>
</tr>
<tr>
<td>Align Multiple Annotation Objects</td>
<td>144</td>
</tr>
</tbody>
</table>
## PART 4  Examples  147

### Chapter 15 / Editing and Annotating a Simple Graph by Example  149
- About the Simple Graph  149
- Code for the Simple Graph Example  150
- Editing the Graph  151
- Annotating the Graph  154

### Chapter 16 / Showing and Hiding Labels by Example  159
- About the Linear Regression for Sports Cars Example  159
- Code for the Linear Regression Example  160
- Show and Hide Labels  162

### Chapter 17 / Modifying a Multi-Cell Graph by Example  165
- About the Classification Panel Example  165
- Code for the Classification Panel Example  166
- Editing a Multi-Cell Graph That Uses a Single Data Set  167
- Modifying Individual Plots in a Diagnostic Panel  169

### Chapter 18 / Editing and Annotating a SAS/STAT Graph by Example  175
- About the Economy Growth Example  176
- Code for the Economy Example  177
- Editing the Graph  179
- Adding Annotations to Highlight Outlier Data  181
- Preparing the Graph for Presentation  183
- Viewing and Saving the Results of Your Changes  185

### Glossary  187

### Index  191
What's New

What's New in SAS 9.4 ODS Graphics Editor

Overview

The ODS Graphics Editor has the following changes and enhancements:

- general updates
- appearance updates

General Updates

In the SAS windowing environment, you can now start the ODS Graphics Editor from the SAS Tools menu. (You cannot open the editor on z/OS systems.)
Appearance Updates

The following appearance enhancements have been added to graphs:

- Four new ODS styles have been added to the ODS Graphics Editor: HTMLBlue, Dove, Pearl, and Raven.

- When you group the data in your graph, by default the ODS Graphics Editor rotates through the GraphData style elements for the presentation of each unique group value. To change the default appearance, you can specify attributes for group values. For example, you can specify fill colors, line patterns, and marker symbols. You can also change the number of attributes that are rotated.

  These changes are made in the Graph Properties dialog box for the graph.

- In the Graph Properties dialog box, you can change the attribute priority that determines the rotation pattern used for group values.

Enhancements for SAS 9.4M1

The following enhancements have been added to SAS 9.4M1:

- You can modify several attributes and properties of a PATHDIAGRAM plot’s graphical elements.
  
  - Move the nodes and links separately or as a unit.
  
  - Change several properties of a node title’s font, including color, family, size, or style.
  
  - Change the links that connect nodes from curved to straight, or vice versa.
  
  - Align selected nodes either horizontally or vertically. As you align the nodes, any links connected with the nodes move in unison.
You can change all of the plot and axes attributes and properties of a LINECHART plot. These are accessed through the Plot Properties dialog box. In prior releases, you could edit only the general properties.

Enhancements for SAS 9.4M2

Starting with SAS 9.4M2, the following options are replaced and considered deprecated:

- MARKERCOLORGRADIENT= and SURFACECOLORGRADIENT= are replaced with COLORRESPONSE=.
- MARKERSIZERESPONSE= is replaced with SIZERESPONSE=.

The syntax and functionality are the same between the replacement options and the deprecated options. The deprecated options are still honored, but the replacement options are the preferred options. These option changes affect the SCATTERPLOT, SCATTERPLOTMATRIX, and SURFACEPLOT statements. These new options are more consistent with the options used with the other plot statements.

Enhancements for SAS 9.4M3

Starting with SAS 9.4M3, the ODS Graphics Editor has the following enhancements:

- You can change the plot fill and outline color attributes of the group variable in both a HISTOGRAM plot and a DENSITY plot.
- Subpixel rendering has been implemented, resulting in clearer images. Subpixel rendering generates smoother curves and more precise bar spacing.
- You can edit fill and outline attributes and plot properties for text plots, polygon plots, and decision tree diagrams.
- You can realign a self-link around its parent node. The parent node is both the originating point and the ending point for the self-link connected to it. A parent node has four sides and four corners. A self-link can be aligned to any one of these eight positions around the node.
You can edit graphs created by the SAS/QC procedures. However, the editor is limited to annotating the graph and editing the title, footnote, and graph properties. General graph properties such as background fill and outline and the size of the graph are editable.

The Viewport function allows the editor to support the adjustment of the viewing area of a graph with a single or 3-D layout overlay. Examples of such graphs are histograms, density, surface, and fringe plots.

**Note:** Exceptions to this support include log axis and broken axis graphs with their data skin specifications.
Accessibility Notice

For information about the accessibility of this product, see Accessibility Features of SAS 9.4 ODS Graphics Editor at support.sas.com.
Part 1

Introduction to the ODS Graphics Editor

Chapter 1
*Overview of the ODS Graphics Editor* ..................... 3

Chapter 2
*Getting Started with the ODS Graphics Editor* ............. 9
Overview of the ODS Graphics Editor

About the ODS Graphics Editor .......................................................... 3
  Important Information Related to SAS Viya and CAS Data .............. 3
  What Is the SAS ODS Graphics Editor? ........................................ 4

Why Use the ODS Graphics Editor? .................................................. 4

Key Features of the ODS Graphics Editor ......................................... 5

Types of Files That Can Be Edited .................................................... 5

Components of a Graph .................................................................... 6

General Editing and Annotation Concepts ....................................... 7

Use of Locale .................................................................................... 8

About the ODS Graphics Editor

Important Information Related to SAS Viya and CAS Data

The ODS Graphics Editor is not included in SAS Viya. In addition, the ODS Graphics Editor cannot access SAS CAS in-memory tables.
What Is the SAS ODS Graphics Editor?

The SAS ODS Graphics Editor is a tool that complements other tools in the ODS Graphics system. You can use the tool to edit and annotate ODS Graphics that are created by a wide variety of SAS procedures. You can save the results as an image for inclusion in a report or as an SGE file that you can edit in the future. The editor can also edit PNG files.

Note: SGE files can be rendered to any ODS destination on any platform using the SGRENDER procedure. For more information, see *SAS ODS Graphics: Procedures Guide*.

You can launch the editor from a SAS session in the SAS Windowing environment. The editor is not available from the SAS Studio client in SAS Viya. When you edit a graph from the Results window in SAS, changes that you make do not affect the original graph in the Results window.

On Windows and Linux operating systems, you can also download a stand-alone version of the ODS Graphics Editor that runs apart from SAS.

Why Use the ODS Graphics Editor?

Many SAS analytical procedures now produce graphical output automatically using the ODS Graphics system. These graphics are produced using predefined templates that are shipped with SAS. The templates define the structure of the graph, including the plots, titles, footnotes, legends, and other attributes of the graph. You can customize the output graphs by editing the predefined template. However, such customization requires detailed knowledge of the TEMPLATE procedure and the Graph Template Language (GTL).

You might want to make small changes to a graph without having to work with templates and GTL. For example, you might want to add, edit, or remove a title or a footnote. Or, you might want to change the size, shape, and color of graphical elements such as the markers and lines. The ODS Graphics Editor provides a graphical user interface for making these changes easily without knowing the details of templates and GTL.
The ODS Graphics Editor enables you to edit the various elements in the output graph while keeping the underlying data unchanged. In addition, you can annotate a graph by inserting text, lines, arrows, images, and other items in a layer above the graph. You can save the results of your customization as an ODS Graphics Editor (SGE) file and make incremental changes to the file. You can also save the results as a Portable Network Graphics (PNG) image file for inclusion in other documents.

**Key Features of the ODS Graphics Editor**

Here are some of the tasks that you can perform with the ODS Graphics Editor:

- add, delete, or modify title and footnotes. You can add special symbols, superscripts, and subscripts to titles and footnotes.
- change the visual appearance of the entire graph by changing the applied style.
- edit axis labels and legend titles.
- resize the graph.
- change the appearance of individual plot elements such as markers and lines.
- show or hide data labels for selected data points in order to reduce clutter.
- move nodes, links, and link break points in simple plots.
- add annotation such as text, lines, circles, images, and markers.
- copy the resulting graph to the system clipboard.

**Types of Files That Can Be Edited**

You can edit the following types of files:
- ODS Graphics Editor (SGE) files. You can edit SGE files from the SAS Results window or by opening the SGE file in the editor.

  In this file format, all of the graphical elements (titles, footnotes, and so on) are available for individual editing. You can edit any GTL annotations (DRAW statements) that are part of the graph as well as annotations that were created with the ODS Graphics procedures or the SAS/QC procedures. Finally, you can add annotations on top of the graph.

  **Note:** The editor does not allow editing of any content inside an SGE file created from SAS/QC procedures. Editing is limited to the graphical elements as mentioned above, and the ability to set a Zoom value. You can also save your file with edited graphical elements to either a PNG file or an SGE file.

- Image files in PNG format.

  In this file format, all of the graph elements, including annotations, are flattened into an image and cannot be edited. However, you can add new annotations on top of the image.

See Also

- “Open an ODS Graph for Editing” on page 13
- “Creating Editable Graphics ” on page 11
- “About SGE Files Generated on z/OS Systems” on page 14

---

**Components of a Graph**

The ODS Graphics output is called a graph. In general, a graph is made of up of the following parts:

- titles and footnotes
- one or more cells that contain a composite of one or more plots
- legends, which can reside inside or outside the cell or plot
The following figure shows the different parts of a graph:

*Figure 1.1 Components of a Graph*

General Editing and Annotation Concepts

You can edit and annotate graphs. Editing and annotating tasks differ from each other in the following ways:

- When you edit a graph, you edit elements of the graph such as the title, footnote, or legend.
You can also change the visual characteristics of the plots, such as the colors of markers and lines. You can change the style applied to a graph, and you can resize the graph.

Some of these edits can cause the layout of the graph to change.

- When you annotate a graph, you add objects on top of the original graph. You can add text, lines, arrows, ovals, rectangles, images, and markers. Annotation objects are rendered in a separate layer on top of the graphical elements and do not cause any changes to the layout of the graph.

  Annotation objects can be attached to graph data so that, if the graph is resized, the annotations move with the data. For more information, “Understanding Annotation Objects and Data” on page 94.

- You can edit Graph Template Language (GTL) annotations (DRAW statements) that are part of the original graph, as well as annotations that were created with the ODS Graphics procedures. These edits do not cause any changes to the layout of the graph.

---

### Use of Locale

The ODS Graphics Editor uses the system locale, but the graph itself uses the SAS locale. For example, if the axis label is present, the label is shown in the language that SAS uses.
# Getting Started with the ODS Graphics Editor

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using a Stand-Alone ODS Graphics Editor</td>
<td>10</td>
</tr>
<tr>
<td>Download and Install the Stand-Alone ODS Graphics Editor</td>
<td>10</td>
</tr>
<tr>
<td>Start the Stand-Alone ODS Graphics Editor</td>
<td>11</td>
</tr>
<tr>
<td>Creating Editable Graphics</td>
<td>11</td>
</tr>
<tr>
<td>Start the ODS Graphics Editor</td>
<td>13</td>
</tr>
<tr>
<td>Open an ODS Graph for Editing</td>
<td>13</td>
</tr>
<tr>
<td>About SGE Files Generated on z/OS Systems</td>
<td>14</td>
</tr>
<tr>
<td>About the Graph Toolbar</td>
<td>15</td>
</tr>
<tr>
<td>Save Graph Output</td>
<td>17</td>
</tr>
<tr>
<td>Print Graph Output</td>
<td>18</td>
</tr>
<tr>
<td>Copy and Paste a Graph</td>
<td>18</td>
</tr>
<tr>
<td>Create a New Blank Window</td>
<td>19</td>
</tr>
</tbody>
</table>
Using a Stand-Alone ODS Graphics Editor

Download and Install the Stand-Alone ODS Graphics Editor

On Windows and Linux operating systems, you can run the ODS Graphics Editor as a stand-alone product without invoking SAS. You can download the stand-alone editor for free from SAS.

To download the stand-alone ODS Graphics Editor:

1. Go to the Base SAS download site:
   

2. If necessary, click **Base SAS Software** to open the Base SAS download page.

3. Click **ODS Graphics Editor** from the list. The ODS Graphics Editor Download Packages page appears.

4. View the README file for the appropriate platform. You might print the file so that you can refer to it later.

   **Note:** Verify that the correct Java Runtime Environment is installed, as specified in the README file.

5. Select **Request Download**.

6. Read the license agreement and then click **I Accept**. The Download page appears.

7. Click the **Download** button next to the file that you want to download. The compressed file is downloaded to your system.

8. Follow the instructions in the README file to unpack the files, start the SAS Deployment Wizard, and install the editor.
Start the Stand-Alone ODS Graphics Editor

On a Windows system, start the editor from the Windows Start menu.

To start the editor on Linux systems, follow the instructions in the editor's README file.

After you start the editor, you can select File ➤ Open from the main menu and select an SGE file that you want to edit.

Creating Editable Graphics

You must create editable graph output before you can use the ODS Graphics Editor to edit the graph output. You can create editable graph output with a wide variety of SAS procedures.

To enable the creation of an editable graph, do the following in your SAS program:

- Make sure either the LISTING or the HTML ODS destination is open. If both are closed, no editable graph can be produced. Both can be open. Other destinations can be open as well.

- Add the SGE=ON option to the ODS destination statement.

  Here is the general form of the SGE option:

  \[ \text{sge} = \text{on}|\text{off}|\text{yes}|\text{no} \]

  Here is an example of its usage in an ODS LISTING statement:

  \[ \text{ods listing sge = on;} \]

- If needed, activate the ODS Graphics environment with the ODS GRAPHICS ON statement. This is not required for the SAS ODS Graphics procedures (SGDESIGN, SGPLOT, SGPANEL, SGSCATTER, or SGRENDER). In addition, SAS procedures that support ODS produce ODS Graphics output by default when they are executed in the SAS Windowing Environment.
For more information, see “Procedures That Support ODS Graphics” in *SAS/STAT 9.3 User’s Guide*.

When you execute the SAS program, SAS creates an ODS Graphics Editor (SGE) file along with the graph image file. You can then open the SGE file from the Results window. For details, see “Open an ODS Graph for Editing” on page 13.

**Note:** You cannot open an SGE file on z/OS systems. For more information, see “About SGE Files Generated on z/OS Systems” on page 14.

**Note:** Starting with SAS 9.4M5, you can generate map output using the SGMAP procedure. SGE files that contain map content from SGMAP are generated with a different rendering technology and are not supported by the ODS Graphics Editor. However, it is possible to load the image output into the ODS Graphics Editor to interactively add annotations on top of the image.

**Note:** Starting with SAS 9.4M6, SGE files that contain graph content from the SGPIE procedure are generated with a different rendering technology and might not be produced (for example, donut charts). Pie charts are rendered, but editing that chart might produce results that are different from what was displayed in the original output.

If you later change and rerun the SAS program, SAS creates a new SGE file. The original SGE file remains in the SAS Results window.

You can create editable graphs for multiple ODS destinations. Each editable graph has a unique name that is based on the name of the corresponding PNG file. For example, if you specify SGE=ON for the LISTING, PDF, and HTML destinations, your editable graphs would have names such as SGPlot.sge, SGPlot_PDF.sge, and SGPlot_HTML.sge.

To disable the creation of editable graphs, add the SGE=OFF option to the ODS destination. For example, you might submit the following code in your program:

```
ods listing sge = off;
```

Alternatively, you can close and then reopen the ODS destination.
Start the ODS Graphics Editor

You can start the ODS Graphics Editor from the SAS menu or you can “Open an ODS Graph for Editing”.

Note: You cannot open the editor on z/OS systems.

To start the ODS Graphics Editor:

1 Start a SAS session.

2 In the SAS windowing environment, select Tools ▶️ ODS Graphics Editor.

Once the ODS Graphics Editor is open, you can open an editable graph by selecting File ▶️ Open from the main menu.

You can open and edit any SGE graph file. See “Types of Files That Can Be Edited” on page 5. This includes SGE files that were created on z/OS systems, which do not support running the ODS Graphics Editor. For more information, see “About SGE Files Generated on z/OS Systems” on page 14.

You can also select File ▶️ New to create a blank window. You can then add annotations to the window.

Open an ODS Graph for Editing

From the SAS Results window, you can open an editable graph that has been created from a SAS program. For more information about editable graphs, see “Creating Editable Graphics ” on page 11.

Note: You cannot edit an ODS graph on z/OS systems.

Note: Starting with SAS 9.4M5, you can generate map output using the SGMAP procedure. SGE files that contain map content from SGMAP are generated with a different rendering technology and are not supported by the ODS Graphics Editor.
However, it is possible to load the image output into the ODS Graphics Editor to interactively add annotations on top of the image.

Note: Starting with SAS 9.4M6, SGE files that contain graph content from the SGPIE procedure are generated with a different rendering technology and might not be produced (for example, donut charts). Pie charts are rendered, but editing that chart might produce results that are different from what was displayed in the original output.

To open an editable graph from the SAS Results window:

1. Click the expansion icon in the SAS Results window to expand the list of graphs that you created.

2. Double-click the SGE file, which is identified by the 📷 icon.

   The ODS Graphics Editor opens and displays the graph for editing. You can now edit the graph using the various interactive tools.

Once the ODS Graphics Editor is open, you can open an editable graph by selecting File ➤ Open from the main menu.

You can open and edit any SGE graph file. See “Types of Files That Can Be Edited” on page 5. This includes SGE files that were created on z/OS systems, which do not support running the ODS Graphics Editor. For more information, see “About SGE Files Generated on z/OS Systems” on page 14.

You can also select File ➤ New to create a blank window. You can then add annotations to the window.

---

**About SGE Files Generated on z/OS Systems**

The ODS Graphics Editor is a graphical application and therefore does not run on z/OS systems. You cannot edit graphs on z/OS, either from the SAS Results window or in the stand-alone editor. However, you can generate SGE files on z/OS, and then move the files to another system on which you can run the editor (Windows, Linux, or UNIX).
Then you can start the editor and edit the SGE files that you moved. For more information about generating SGE files, see “Creating Editable Graphics” on page 11.

When you generate SGE files on z/OS, SAS always writes the SGE files to the UNIX file system (UFS). The z/OS FILESYSTEM= setting is ignored for writing SGE files. You must be authorized to create UFS files in your environment in order to generate the SGE files.

Note: SGE files can be rendered on z/OS systems using the SGRENDER procedure. For more information, see SAS ODS Graphics: Procedures Guide.

---

About the Graph Toolbar

In addition to the Standard and Formatting toolbars that are commonly used in applications, the ODS Graphics Editor has a Graph toolbar. The Graph toolbar contains icons that you can click to select graph objects or to insert items into a graph. (In addition to using the toolbar, you can also insert items by selecting them from the Insert menu.)

The following display shows the Graph toolbar:

![Graph toolbar icons]

To display the Graph toolbar, select View ➤ Toolbars ➤ Graph from the main menu. Be sure Graph is checked.

You can use the following editing icons to edit your graph:

- ![Title icon](attachment:image.png)
  - adds a title field to an ODS graph in which you can enter a title. Selecting this icon again adds another title field.

- ![Footnote icon](attachment:image.png)
  - adds a footnote field to an ODS graph in which you can enter a footnote. Selecting this icon again adds another footnote field.
You can use the following Viewport icons:

enables adjustment of the viewport rectangle on an ODS graph.

resets whatever adjustment of the viewport rectangle that you have made.

You can use the following selection icons:

enables you to select data and then show or hide labels for the selected data. When you are editing a PATHDIAGRAM plot, this icon enables you to move the nodes and links. This icon is available only when the graph contains labels or with a PATHDIAGRAM plot.

enables you to select an object on your graph for editing.

You can use the following annotation icons to annotate your graph:

enables you to draw a text box on your graph, in which you can enter text.

enables you to draw a line on your graph.

enables you to draw an arrow on your graph.

enables you to draw a rectangle or a square on your graph.

enables you to draw an oval or a circle on your graph.

enables you to select an image to insert into the graph.
places a marker at a place that you select on your graph. As shown here, the current marker setting is displayed as a star. The icon in your operating environment might be different.

---

**Save Graph Output**

To save graph output:

1. Select **File** ➤ **Save As** from the menu.

2. Select the directory where you want the graph to be saved. The default location is the current directory for the SAS program that generated the SGE file.

3. Select the type of file to save.
   - If you save the file in SGE format, then you can later reopen and edit the file.
   - If you save the file in PNG format, then the graph is saved as a flat image. The graph in this format cannot be edited, though it can be annotated.

   **Note:** If you open a PNG file and annotate that file, save the annotated graph using a different filename. If you save the file using the existing name, your annotation might not be preserved.

   You can change the resolution by modifying the dots per inches (DPI). Changing the DPI affects only the image. The actual graph continues to display with 100 DPI.

   If you specify a DPI larger than 100, the graph image is resized. Any annotation that is not attached to the data retains its original position after the layout changes. For an example that illustrates this behavior, see “Example: Annotation Positioned over a Legend in a Graph That Is Resized” on page 106. (For more information about attachment to data, see “Understanding Annotation Objects and Data” on page 94.)
The maximum value that you can specify is 300 DPI. If you want to obtain a higher resolution, you can render the SGE file using the SGRENDER procedure and specify a DPI value in an ODS statement. For more information about the SGRENDER procedure, see *SAS ODS Graphics: Procedures Guide*.

4 Enter the name of the graph in the **File name** field.

5 Click **Save**.
   
   For subsequent changes to the file, you can use the **File ➤ Save** menu option.

The Save operation does not affect the graph output in the Results window in SAS.

---

**Print Graph Output**

You can print SGE and PNG files from the ODS Graphics Editor. You can also include a PNG file in a PDF document and then print the PDF document.

To print a graph from the ODS Graphics Editor:

1 Select **File ➤ Print** from the menu.

2 Select print options from the Print window.

3 Click **OK**.

You can select **File ➤ Print Preview** to preview your graph before you print it.

---

**Copy and Paste a Graph**

Graph output can be copied to the system clipboard to use in another document.

To copy and paste a graph:
1. Open the graph that you want to copy.

2. Select Edit ▶ Copy View from the main menu.

You can paste the graph into the target application using that application’s paste command.

---

Create a New Blank Window

You can select File ▶ New to create a blank window. You can then add annotations to the window.
Part 2

Editing Graphs

Chapter 3
  *Modifying General Graph Properties* .......................................................... 23

Chapter 4
  *Working with Titles and Footnotes* ............................................................... 33

Chapter 5
  *Working with Legends* ................................................................................. 43

Chapter 6
  *Modifying Plot and Axis Properties* .............................................................. 49

Chapter 7
  *Working with Data Labels and Multi-Cell Graphs* ....................................... 65
Chapter 8
*Working with Nodes and Links* ........................................... 71

Chapter 9
*Adjusting the View of a Graph* ........................................... 85
Modifying General Graph Properties

Specify a Style for a Graph ....................................................... 23
Resize a Graph ........................................................................ 25
Change the Background Color of a Graph .................................. 27
Change Group Attributes ........................................................... 28
Understanding Attribute Priority ............................................... 31

Specify a Style for a Graph

Styles control the overall visual appearance of graphs. Styles specify colors, fonts, line styles, fill patterns, and other attributes of graph elements. You can change the appearance of your graph by selecting one of the styles that are provided. For example, you can change the style of a graph from the Default style to the Journal style if the graph is intended for gray-scale publications.

By default, graph SGE files use the active ODS destination style that is specified in the SAS program. For example, you can specify the Analysis style using the following statement in the program:

```ods listing sge=on style=Analysis;```

To select a style:
With your graph displayed, select **Format ▶ Style** from the main menu.

From the cascading menu, select a graph style.

You can select one of the following styles:

**Analysis**

is a color style recommended for output in web pages or for color print media. This style might not work well in gray-scale output.

**Default**

is a color style intended for general-purpose work. This style is designed to discriminate among groups in both color and gray-scale output.

**HTMLBlue, Dove, and Pearl**

are color styles recommended for output in web pages or for color print media. These styles have a white background and have been optimized for HTML output.

*Note:* The HTMLBlueCML style is the same as HTMLBlue, but has an attribute priority of NONE. HTMLBlueCML has been preserved for historical reasons only, and will be eliminated in a future release. (See “Understanding Attribute Priority” on page 31.)

**Journal**

is a gray-scale style recommended for journal articles and other publications that are printed in gray scale.

**Listing**

is similar to Default but has a white background. This style is used by SAS for listing output.

**Raven**

is a dark color scheme with a black background.

**Statistical**

is a color style recommended for output in web pages or for color print media. This style might not work well on devices that produce gray-scale output.
StatGraphScheme

is the default style for all SGE files. This style inherits attributes from the style that was used when the graph was created.

Various elements of the graph derive their visual attributes, such as color, from specific style elements. Individual property settings override the style elements. For example, if you have assigned an overriding color to an object in the graph, then selecting a different style retains the overriding value that has been assigned.

---

Resize a Graph

When you resize a graph, you can then print or save the graph in its new size.

If you resize a graph and there is not enough space to display entire titles, footnotes, or axis labels, then an alternate short label is displayed. For details, see “Use of Alternate Short Text in Graph Elements ” on page 42.

To resize a graph:

1. Select Format ➤ Graph Properties. The Graph Properties dialog box appears.
You can also right-click anywhere in the graph and select **Graph Properties** from the menu.

2 In the **Size** section of the dialog box, enter numerical values between 2.00 and 99.00 in the **Width** and **Height** fields. Starting with **SAS 9.4M3**, the width and height are measured in inches instead of pixels. Even though you can enter large numerical values, the maximum recommended resolution for a graph is a width of 16.0 and a height of 12.0 in inches. Your graph becomes larger or smaller depending on which values you select. Larger values yield a larger graph.

**Note:** To resize the graph proportionally, make sure the **Keep Aspect Ratio** check box is checked. If you want to specify the width and height independently without retaining the current aspect ratio, then clear the check box.

3 Click **OK**.
Note: You can also enlarge or reduce the view of a graph by using the Zoom tool. The Zoom tool does not resize the graph. To zoom in or out, select View ➤ Zoom from the menu, and then select the zoom value that you want.

Change the Background Color of a Graph

To change the background color of a graph:

1. Select Format ➤ Graph Properties. The Graph Properties dialog box appears.

You can also right-click anywhere in the graph and select Graph Properties from the menu.
2 In the Background section, select a color from the Fill list box. For details about setting the color, see “Using the Color List Box” on page 37.

The outside of the plot area changes to the color that you selected.

Note: The value of Auto indicates that the background color is from the original graph.

3 Check or clear the Outline check box to turn the graph border on or off.

4 Click OK.

---

**Change Group Attributes**

When you apply a group role to your graph, by default the editor rotates through the GraphData style elements for the presentation of each unique group value.

To change the default appearance, you can specify attributes for group values. You can also change the number of attributes that are rotated.

You can change the following attributes:

- **colors**: specify the fill colors for the graphics elements.
- **contrast colors**: specify the contrast colors for the graphics elements, such as lines and markers.
- **line patterns**: specify the line patterns for the graph data lines.
- **marker symbols**: specify the marker symbol for the graph data.

These changes override the corresponding defaults from the current style. The appearance options affect only the graph that you are modifying.

You can also change the attribute priority that determines the rotation pattern.
To change the group attributes of a graph:

1. Right-click the graph and select **Graph Properties**. The Graph Properties dialog box appears.

2. Click the **Group Attributes** tab.

3. To change the attribute priority attribute, select the attribute from the **Attr Priority** list box.

   For more information, see “Understanding Attribute Priority” on page 31.

4. Select the graphics element that you want to modify from the **Type** list box.

5. Do any of the following:
   - Click **From Style**. A list of attributes from the current style is displayed. These are the default attributes that you want to change.
For example, if you are changing group attributes for fill colors, the list resembles the display here.

Every item in the list corresponds to a GraphData style attribute. You are not limited to the number of attributes that are displayed. You can remove or add attributes to obtain the desired rotation pattern.

- To change any attribute listed, select the value that you want from the list box.
- To add an attribute, click ✪. A new attribute is added at the bottom of the list. You can change this attribute by selecting a different value from the list box.
- To delete an attribute, select the attribute and click ✗.
  
  To delete all of the attributes, click **Delete All**.
- To change the order in which the attributes are applied, select an attribute and click the ↑ or ↓ arrow to move the attribute up or down in the list.

6 Repeat steps 4 and 5 for every graphics element that you want to modify.

7 Click **OK**.
Understanding Attribute Priority

When you apply a group role to your graph, by default the editor rotates through the GraphData style elements for the presentation of each unique group value. You can change the attributes that are applied to your group values.

When the graph is rendered, the attributes for colors, line patterns, and marker symbols are cycled for the values in your group. Whether you change the attributes or keep the defaults, the manner in which the graphics elements are combined is determined by the attribute priority.

Note: You can change the attribute priority for a graph in the graph’s Properties dialog box.

You have three options for the attribute priority:

- **Color** marker symbols and line patterns are held constant while each color in the list is applied to the marker symbol or line.
- **None** each attribute cycles through its own list to generate a unique combination for each group.
- **Auto** the attribute priority is determined by the active ODS style.

For example, suppose that you specify three contrast colors for markers and two line patterns. The colors are red, green, and blue (in that order). The line patterns are dotted and solid.

First, you specify **Color** for the attribute priority. The dotted-line pattern is held constant while the procedure applies red, green, and blue colors to the dotted lines for the consecutive group values. If there are more group values, the options apply the red, green, and blue colors to solid lines.

The following figure shows an example rotation for an age grouping.
To change the rotation pattern in the previous example, specify **None** for the attribute priority. Now, the contrast colors and line patterns are cycled at the same time.

A red, dotted-line pattern is applied for the first group crossing, a green, solid-line pattern is applied for the second, a blue, dotted-line pattern is applied for the third, and so on.

The following figure shows the rotation for the age grouping with no priority rotation.

![Student Age Rotation](image)
About Titles and Footnotes

You can add multiple titles and footnotes to a graph. The limit to the number of titles or footnotes that you can add depends on the size of your graph. As you add more titles or footnotes, the Y axis of the graph shrinks proportionally to the point where the graph is no longer visible.
When you add a long title or footnote to a graph, the text automatically wraps to the next line. If you move a title or footnote to a different location in the graph, all of the lines of a single title or footnote move as one unit.

Both titles and footnotes support rich text editing.

**Note:** If a graph was created with titles or footnotes, those titles and footnotes might be centered over the data area of the graph. However, the titles and footnotes that you add in the editor are always centered over the graph area.

**Note:** In addition to titles and footnotes, some graphs might have been created with other text entries. You can edit any text entry that was defined as editable in the graph.

## Add a Title or Footnote to a Graph

To add a title or footnote to a graph:

1. Select one of the following options:
   - To add a title, select **Insert ▶ Title**. Alternatively, click the Title icon ![Title icon](image) in the Graph toolbar. The **Insert Title** text box is displayed at the top of the graph.
   - To add a footnote, select **Insert ▶ Footnote**. Alternatively, click the Footnote icon ![Footnote icon](image) in the Graph toolbar. The **Insert Footnote** text box is displayed at the bottom of the graph.

2. Enter your text in the text box. A title or footnote cannot exceed 256 characters.

3. (Optional) Repeat the previous steps to add another title or footnote. For more information about adding multiple titles and footnotes, see “About Titles and Footnotes” on page 33.

To format the text, see “Edit or Format a Title or Footnote” on page 35.
Edit or Format a Title or Footnote

When you edit a title or footnote, you can change the text properties and the font properties. You can also use subscript or superscript values, and you can enter Unicode characters.

Note: Once you edit a title or footnote, the alternate short text is not used. See “Use of Alternate Short Text in Graph Elements” on page 42.

To change a title or footnote:

1 Right-click the title or footnote that you want to change.

2 Select Compose Rich Text from the menu. The Compose Rich Text dialog box appears.

3 Select all or part of the text in the Text box and enter your changes.
4 You can format the selected text in the following ways:

- Select a different font from the font list box.
- Select a different font size from the size list box.
- Click a button to make the text boldface or italic.
- Select a different font color from the color list box. For details, see “Using the Color List Box” on page 37.
- Click a button to change the text to superscript or subscript.
- In the Insert Characters From section of the dialog box, select a character to insert it in your text. You can change the displayed characters by selecting a different character group from the list box.

5 Click OK.

As an alternative to this procedure, you can double-click the title or footnote and enter the new text. You can also change the font characteristics by using the Formatting toolbar. For details, see “Using the Formatting Toolbar” on page 36.

---

Using the Formatting Toolbar

The Formatting toolbar is active only if text is selected in your graph. The text element that you select might be a title, footnote, an axis label, an annotation object, or a legend.

The following display shows the Formatting toolbar:

As an alternative to this procedure, you can double-click the title or footnote and enter the new text. You can also change the font characteristics by using the Formatting toolbar. For details, see “Using the Formatting Toolbar” on page 36.

The Formatting toolbar enables you to format the text in the following ways:
- Select a different font from the font list box Arial.
- Select a different font size from the size list box 10.
- Click a button **bold** / *italic* to make the text boldface or italic.
- Click an alignment button ◦ ◤ ◢ to change the text alignment (left-aligned, centered, right-aligned).
- Select a different font color from the color list box . For details, see “Using the Color List Box” on page 37.

### Using the Color List Box

When you specify different graph, plot, or annotation properties, you might have the option to select a color from a color list box. The color list box contains predefined colors to choose from and the option to define your own color. You can also select an existing color from the graph.
The color list box contains the following items:

Auto
   Restore the default color. This field is useful when you have changed a color and want to restore the original color.

Palette of colors
   Select a predefined color from the palette.

Row of recently used custom colors
   Select a custom color. This row is populated with colors that you choose by using either the More Colors or the Pick color from graph option.

More colors
   Locate a custom color. This option opens the More Colors dialog box, which contains two tabs:
In the Swatches tab, select a color from the palette.

In the Custom tab, choose a color by dragging the slider and then clicking a point in the color preview box. Alternatively, you can specify the HSB, RBG, or hexadecimal color value.

Pick color from graph
After you click this link, the color list box closes. You can then select any of the colors currently displayed in the graph by clicking the desired color.

Aligning a Title or Footnote in a Graph

Alignment of Titles and Footnotes
You can left-align, right-align, or center titles or footnotes in a graph. If you have multiple titles or footnotes in a graph, each title or footnote can have a different alignment.
Titles and footnotes can have multiple lines. When this occurs, the text wraps to the next line. If you change the alignment for this type of title or footnote, all of the lines that belong to the title or footnote move together as a whole.

Graphs that SAS produces can have one-part, two-part, or three-part titles or footnotes. Each part can occupy one of the alignment positions in the graph. You can change the alignment of a one-part title or footnote. For a two-part title or footnote, you can change either of the parts, one at a time. A three-part title or footnote occupies all three alignment positions in the graph, and no alignment changes are possible.

The following figure contains a three-part title.

Align a Title or Footnote

To change the alignment of a title or footnote:

1. Right-click the title or footnote that you want to align. For a two-part title or footnote, right-click the part that you want to align.

2. Select Align from the pop-up menu, and then select an alignment option.
The title or footnote immediately moves to the area that you selected.

Alternatively, you can click the title or footnote that you want to align (or a part of a two-part title or footnote). Then select one of the alignment buttons in the Formatting toolbar.

---

**Move a Title or Footnote in a Graph**

If you have multiple titles or footnotes in a graph, you can move a title or footnote up or down to reposition it. For example, the second title can be moved to become the first title, or the fifth footnote can be moved to become the second footnote.

If you have a single title or footnote, the alignment choices are dimmed.

To move a title or footnote in a graph:

1. Right-click the title or footnote that you want to move.
2. Select *Move* from the pop-up menu, and then choose *Up*, *Down*, *To Top*, or *To Bottom*.

You can also select *Arrange ➤ Move* from the main menu, and then specify how you want the item moved.

Titles and footnotes can have up to three parts, one for each alignment position (left, center, right). You cannot move the individual part of multi-part title or footnote. The whole title or footnote moves together. (For more information about alignment, see “Aligning a Title or Footnote in a Graph” on page 39.)

---

**Delete a Title or Footnote from a Graph**

To delete a title or footnote in a graph:

1. Right-click the title or footnote that you want to delete.
2. Select *Delete* from the pop-up menu.
Note: To undo the change, select Edit ► Undo from the menu.

For multi-part titles and footnotes, you can delete one part at a time.

---

Use of Alternate Short Text in Graph Elements

In addition to the standard text that is displayed, titles, footnotes, and axis labels have alternate short text. This short text is specified as a GTL option in the SAS program that defines the graph.

If there is not enough space to display the standard text, then the short text is displayed. For example, if you resize a graph and there is not enough space to display the whole axis label, then the short axis label is displayed. If you later enlarge the graph so that enough space is made available, then the long label is displayed.

You can override the short text by changing the text of the title, footnote, or axis label. Once you change the text, only the new modified text is displayed regardless of the size of the graph.
About Legends

The editor always displays a global or discrete legend when the original SGE file can display the legend in the SGRENDER procedure. The editor prevents any action that would cause the legend to disappear.

An original SGE file might contain a legend that cannot be displayed due to size constraints. If the SGRENDER procedure cannot render the legend, no legend appears in the editor. No editor action can make the legend reappear. If you try, the editor issues a message that your action is ignored.

Note: Most of the time the output from the SGRENDER procedure matches the editor output. However, occasionally a change of style or another edit causes the editor to reuse the graphic area held by the SGRENDER procedure for the non-displaying legend.
You can change the appearance of a graph by adding or changing a legend's title. You can also change a legend's appearance, such as its fill color and outline. For instructions on working with legends, see the following topics:

- “Add or Edit a Legend Title” on page 44
- “Change the Outline and Background Color of a Legend” on page 44
- “Move a Legend Inside or Outside a Plot” on page 45

### Add or Edit a Legend Title

You cannot add or delete a legend. You also cannot edit the labels in the legend. However, you can add or edit the title of the legend.

To add or edit a legend title:

1. Right-click the legend and select **Add (Edit) Title** from the pop-up menu. A **Legend** text box appears next to the legend.

2. In the text box, enter the text that you want for the title. The title cannot exceed 256 characters.

3. To change the font characteristics, select the title text and use the Formatting toolbar. For details, see “Using the Formatting Toolbar” on page 36.

### Change the Outline and Background Color of a Legend

To change the outline and fill color of a legend:

1. Right-click the legend and select **Legend Properties** from the pop-up menu. The Legend Properties dialog box appears.
2 To change the background color, select the Fill check box. Then click the down arrow in the fill color list box to select a color. For details about setting the color, see “Using the Color List Box” on page 37.

Note: If Auto appears in the list box, then the color of the legend is the same as the color selected when the graph was created. If you select another color, you can always go back to the original color by selecting the Fill check box and selecting Auto.

3 To change the outline color of the legend, select the Outline check box. Then use the down arrow to select an outline color.

4 Click OK.

---

Move a Legend Inside or Outside a Plot

You can move a legend to the inside or outside of a plot. You can also position the legend in different areas inside our outside of the plot.

To move a legend:
1 Right-click the legend and select **Legend Properties** from the pop-up menu. The Legend Properties dialog box appears.

![Legend Properties dialog box](image)

2 To move the legend inside the plot area, complete these steps:
   
a. Select the **Inside Plot Area** radio button.
   
b. Select the new position from the list box. You can position the legend along an edge, in a corner, or in the center of the plot.

   The list box has the following options:

<table>
<thead>
<tr>
<th>Left</th>
<th>Center</th>
<th>Right</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top</td>
<td>Bottom</td>
<td>Top Left</td>
</tr>
<tr>
<td>Top Right</td>
<td>Bottom Left</td>
<td>Bottom Right</td>
</tr>
</tbody>
</table>

3 To move the legend outside of the plot area, complete these steps:
   
a. Select the **Outside Plot Area** radio button.
   
b. Select the new position from the list box.
The list box has the following options:

<table>
<thead>
<tr>
<th>Top</th>
<th>Bottom</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left</td>
<td>Right</td>
</tr>
</tbody>
</table>

4 Click **OK**.
Modifying Plot and Axis Properties

Working with Plot Properties

The Plot Properties Dialog Box
General Properties
Plot Properties
Axis Properties

Working with Axis Properties

Working with Axis Labels

Edit an Existing Axis Label
Add an Axis Label
Show or Hide an Axis Label
Delete an Axis Label

Working with Plot Properties

The Plot Properties Dialog Box

You can modify all of the properties of the plots and axes that are in a cell by using the Plot Properties dialog box.
To open the Plot Properties dialog box, right-click in a plot and select **Plot Properties**. You can also click in the plot area and then select **Format ➤ Plot Properties** from the main menu.

**Note:** Click the Select icon in the Graph toolbar if you are moving from manipulating selected graph elements to editing plot properties. This action exits Select Data Label mode and enables you to open **Plot Properties**.

The Plot Properties dialog box contains the following tabs:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>used to edit the general properties of the plot or the cell containing plots</td>
</tr>
<tr>
<td>Plots</td>
<td>used to edit the properties of individual plots</td>
</tr>
<tr>
<td>Axes</td>
<td>used to edit the properties of one or more axes</td>
</tr>
</tbody>
</table>
**General Properties**

In the **General** tab, you can modify the wall color and border of the cell.

You can select or clear the **Fill** and **Outline** check boxes to toggle on and off the fill color and outline of the plot area. When the **Fill** check box is selected, you can select a fill color from the list box.

**Plot Properties**

**About Plot Properties**

In the **Plots** tab, you can modify the properties of individual plots. If more than one plot is open, then you can select the plot that you want to modify from the **Plot** list box.

The types of properties that you see vary depending on the type of plot that you are modifying.

**Note:** Based on plot settings, the initial value for a property might be shown as **Auto** or **Group**. This means that the value is derived from the original plot setting or from the group variable. You can later revert back to the original **Auto** or **Group** setting if desired.

If you change the properties, the settings that you specify override any style that has been applied to the graph.

**Note:** Some plot types do not allow you to edit their plot properties. These plot types are AXISTABLE, BLOCKPLOT, POLYGONPLOT, MOSAICPLOTSPARM, and WATERFALLCHART.

**Marker and Line Properties**

You can specify the color, pattern, and thickness of a plot's lines from the list boxes.
You can specify the color, the representative symbol, and the size of a plot's markers from the list boxes.

**Note:** By default, the specified color of the marker is also the color of any error bar in the graph. For example, a graph might have a large, filled marker, a specified color response, and an error bar that is short in length. The marker might obscure the error bar because their colors are the same.
For markers, in addition to Auto or Group value, the initial value for any of the properties might be as follows:

- Starting with SAS 9.4M2, the COLORRESPONSE variable can be specified during the generation of a scatter plot, a scatter plot matrix, or a surface plot. In these cases the COLORRESPONSE variable is displayed as the current color value.
- Starting with SAS 9.4M3, the same is true for text plots, polygon plots, and decision tree diagrams. The Color field is dimmed, indicating that you cannot change it.

Attributes specified during the creation of the SGE file take precedence in the editor over the specification of any COLORRESPONSE or GROUP variables. If COLORRESPONSE and GROUP variables are specified, then the Fill and Outline fields in the editor are dimmed. Priority is given to the COLORRESPONSE variable value over the GROUP variable value.

Note: Starting with SAS 9.4M2, the COLORRESPONSE= option replaces the MARKERCOLORGRADIENT= option. The syntax and functionality are the same. The MARKERCOLORGRADIENT= option is still honored, but the COLORRESPONSE= option is preferred. In releases prior to SAS 9.4M2, if the MARKERCOLORGRADIENT variable is specified, then Gradient is displayed as the current color value.
If the MARKERCHARACTER variable is specified, then **Character** is displayed as the current symbol. The symbol and size are dimmed, indicating that you cannot change them.

If the SIZERESPONSE variable is specified during the generation of a scatter plot or a scatter plot matrix, then **Size Response** is displayed as the current size. The **Size** field is dimmed, indicating that you cannot change it.

**Note:** Starting with **SAS 9.4M2**, the SIZERESPONSE= option replaces the MARKERSIZERESPONSE= option. The syntax and functionality are the same. The MARKERSIZERESPONSE= option is still honored, but the SIZERESPONSE= option is preferred.

---

**Fill and Outline Properties**

Plots such as bar charts and histograms use graphical elements that have a fill color. The **Fill** check box is selected by default. If you specify an outline for the plot, then you can clear the **Fill** check box.

When the **Fill** check box is selected, you can specify the fill color and the transparency. Moving the slider to the right makes the fill color more transparent. (The other parts of the plot, such as its outline, do not change.) The default value for transparency is obtained from the plot definition.
In **SAS 9.4M2**, a specified COLORRESPONSE variable becomes the uneditable fill color value for bubble plots. Starting with **SAS 9.4M3**, the following statements are true for all plots. If the COLORRESPONSE variable is specified, then **Color Response** is displayed as the current fill color value. The color list is dimmed, indicating that you cannot change the color. However, you can change the color of the outline. If, after changing the color of the outline, you deselect **Fill**, the outline color is reset to the color specified by the COLORRESPONSE variable.

Starting with **SAS 9.4M3**, you can change the plot fill and outline color attributes of the group variable in both a HISTOGRAM plot and a DENSITY plot. With the specification of a GROUP variable, **Group** is displayed as the current fill and outline color values.

**Note:** The editor modifies graphics elements that have fill attributes, but does not manipulate data transparency. Therefore, transparency is not applied to lines, text, and markers. In addition, if data transparency has been defined in the graph, then specifying a fill transparency causes the data transparency to be ignored.

You can toggle the plot's outline on and off. If the **Outline** check box is selected, then you can specify a color for the outline.

**Note:** When a DATASKIN variable is specified, regardless of the plot type, any outline specifications are ignored.

**Note:** If a fill color is specified for a bubble plot, it overrides any pattern and thickness specified for the outline.

**Note:** If a fill color is not specified for a bubble plot, the color for the outline is derived from the specification of a color response or a color group.
Contour Properties

Contour has different graphical elements, such as lines, labels, fill, and gradient based on the contour type. You can change the contour type.

If the contour plot includes an area, such as a fill or gradient, then the color can be reversed by selecting the **Reverse Gradient** check box.

If the contour plot contains lines or labeled lines, then the line properties are enabled and can be edited.
Node Properties

A PATHDIAGRAM plot is an example of a simple plot that has node and link graphical elements. The **Plot Properties** dialog box contains tabs that organize the node properties that you can change. You can modify the appearance of a node’s label and title.

**Note:** For information about modifying the links connecting the nodes, or moving the location of nodes in the plot, see “About Nodes and Links” on page 72.

In the **Node Label** tab, you can modify the font’s color, family, size, and style properties of the plot’s node labels. When there is more than one node in the plot, the modifications apply to the text of all the labels. The label appears in the top right corner outside of the node.
In the **Node Title** tab, you can modify the font’s color, family, size, and style properties of the plot’s node titles. When there is more than one node in the plot, the modifications apply to the text of all the titles. The title appears inside each node. The title can represent a variable name, for example.
Note: Enlarging the text font size of either a node’s label or title can result in the truncation of text.

See Also
“About Nodes and Links” on page 72

Axis Properties
On the Axes tab, you can modify the properties of labels for all the axes in a plot.

For more information, see “Working with Axis Properties” on page 59.

Working with Axis Properties
Ax

Axis properties reside in the Plot Properties dialog box. To open the Axes tab of the Plot Properties dialog box, right-click an axis and select Axis Properties.
On the **Axes** tab, you can modify the properties of labels for all the axes in a plot. You can select the axis that you want to modify from the **Axis** list box.

**Note:** You can edit secondary axes in single-cell and multi-cell graphs.

Select or clear the **Label** check box to toggle the label on and off for the selected axis.

Select or clear the **Grid** check box to toggle the grid lines on and off for the selected axis. If the **Grid** check box is selected, then you can modify the color, the pattern (such as dotted or dashed), and the thickness of the grid lines.

For changes that can be made to axis labels, see “**Working with Axis Labels**” on page 60.

---

**Working with Axis Labels**

You can change the appearance of a graph by adding labels to the graph's axes. For instructions on working with axis labels, see the following topics:

- “**Edit an Existing Axis Label**” on page 61
You can also show grid lines for an axis and specify the visual properties of the grid lines. For more information, see “Axis Properties ” on page 59.

**Edit an Existing Axis Label**

You can edit an existing X or Y axis label (or X,Y, and Z labels for three-dimensional graphs). If the same axis is displayed on both sides of the graph (right and left or top and bottom), then your edits apply to both of the axis labels.

**Note:** Once you edit a label, the alternate short text is no longer used for the label. For more information, see “Use of Alternate Short Text in Graph Elements ” on page 42.

To edit an axis label:

1. Double-click the axis label that you want to edit.
2. Enter or delete text in the axis label.
3. To change the font characteristics, select the label text and then use the Formatting toolbar to make your changes. For details, see “Using the Formatting Toolbar” on page 36.

**Add an Axis Label**

To add a label to an axis:

1. Right-click along the axis where you want to add a label.
2. Select **Add ('Edit') Label** from the pop-up menu. A text box appears.
3 Enter the label for your axis in the text box. The label cannot exceed 256 characters.

4 To change the font characteristics, select the text and then use the Formatting toolbar to make your changes. For details, see “Using the Formatting Toolbar” on page 36.

Show or Hide an Axis Label

To show or hide an axis label:

1 Right-click the axis label and select **Axis Properties**. The Plot Properties dialog box appears with the **Axes** tab displayed.

2 In the **Axis** list box, select the axis whose label you want to show or hide.

3 Check or uncheck the **Label** box to show or hide the label.

4 Click **OK**.
Delete an Axis Label

To delete an axis label permanently from a graph:

1. Click the axis label that you want to delete.

2. Select Edit ➤ Delete. Alternatively, you can press the Delete key.

   The label is permanently deleted.

Note: To undo the change, select Edit ➤ Undo from the main menu.
Display or Hide Data Labels

Some plots might display data labels for each observation in the plot. If there are a lot of observations, then the plot can become cluttered. You can limit the display to those data labels that are important to the analysis.

To display or hide data labels:

1. Click the data label icon in the Graph toolbar.

2. Select the observations for data label management in any of the following ways:
   - Click an observation to select it. If you press Ctrl and click an observation, you can toggle the observation on and off. Pressing Ctrl also enables you to select multiple observations.
   - Click on the data label of an observation to select it.
Click and drag to select an area within the plot. All the observations in this area are selected. You can add more items to the selection list by pressing Ctrl while you click and drag to select another area containing additional observations.

3 Right-click and select one of the following label options:

- **Show Only Selected** shows labels only for those data points that are currently selected. This option first turns off all the data labels and then displays the labels only for the selected data points.

- **Show Selected** shows labels for the data points that are selected. This option leaves unchanged the data labels for all other data points that are not currently selected. For example, if you previously selected data points and set them to show, with this option, they remain selected.

- **Hide Selected** hides labels for those data points that are selected.

- **Show All** shows labels for all the data points.

- **Hide All** hides labels for all the data points.

All items in the selection list are displayed with the selection color. If the selected item is in a scatter overlay and a marker is selected, then the marker is displayed with the selection color. For a line overlay, if the marker is not turned on, then a temporary circle is created and displayed with the selection color.

The layout of a plot refreshes when labels are turned off or on. If some labels are located away from their data points, the labels move closer to the data points if space is made available by hiding other labels.

---

**Working with Multi-Cell Graphs**

A graph can contain multiple cells, each cell with one or more plots. For a visual description of graphs and cells, see “Components of a Graph” on page 6.

Multi-cell graphs can be created in different ways:
A multi-cell graph can be defined using a GRIDDED or LATTICE layout. Each cell is defined independently and can contain different types of plots.

You can modify plot properties separately for each cell.

A multi-cell graph can be defined using a DATALATTICE or DATAPANEL layout. Both layouts are data-driven layouts that create a grid of cells based on a graph prototype and one or more classification variables. The number of the cells is determined by the values of the classification variables.
When you change the plot properties for one cell, the change is applied to all the cells of the graph.

- A multi-cell graph can be created by using a SCATTERPLOTMATRIX layout.
Each non-diagonal cell contains the same plot types, but for a different crossing of the variables. When you change the plot properties for one of these cells, the change is applied to all non-diagonal cells. (The wall and outline properties apply to all cells.)

You cannot change the properties of the following:

- the diagonal cells
- the axes
Working with Nodes and Links

About Nodes and Links ................................................................. 72
Realign Node Links ..................................................................... 73
Realign a Straight Node Link ....................................................... 73
Realign a Curved Node Link .......................................................... 75
Realign Nodes and Their Links as a Unit ..................................... 75
  Enter Edit Mode ....................................................................... 76
  Draw a Rectangle around Nodes and Their Links to Re-align as a Unit .................................................... 76
  Selectively Choose the Nodes and Their Links to Re-align as a Unit .......................................................... 76
Insert a Breakpoint on a Straight Node Link .............................. 77
Delete a Breakpoint on a Straight Node Link ............................... 78
Change a Link’s Curvature ............................................................. 79
  Enter Edit Mode ....................................................................... 79
  Curve a Link Line .................................................................... 79
  Straighten a Link Line .............................................................. 80
Realign a Self-Link ..................................................................... 80
  Enter Edit Mode ....................................................................... 81
  Realign a Self-Link .................................................................. 81
About Nodes and Links

A PATHDIAGRAM plot contains graphical elements known as nodes and links. A PATHDIAGRAM plot is created by the SAS/STAT CALIS procedure PATHDIAGRAM statement. Nodes contain data and are labeled, given titles, and can display details under the title. For information about modifying the appearance of a node's label or title, see “Node Properties” on page 57.

The links connecting nodes can be straight or curved. Straight links are drawn through breakpoints. Curved links have only one control point, which is physically on or near the line drawn. A self-link is a special type of curved link that originates from the same node to which it connects. In SAS 9.4M3, you can now edit to realign these self-links.

You can realign existing links that connect nodes in a plot, realign as a unit the nodes connected by those links, and realign breakpoints within links. The endpoints of the link attached to the nodes realign whenever you realign the nodes. It is possible to add or delete link breakpoints. Any breakpoints in the link realign when the link realigns. You can also change a curved link to a straight link or vice versa. Starting with SAS 9.4M3, you can realign self-links to snap into one of eight positions around the parent node to which it is connected. For instructions on working with nodes and links, see the following topics:

- “Realign Node Links ” on page 73
- “Realign Nodes and Their Links as a Unit ” on page 75
- “Insert a Breakpoint on a Straight Node Link” on page 77
- “Delete a Breakpoint on a Straight Node Link ” on page 78
- “Change a Link's Curvature” on page 79
- “Realign a Self-Link” on page 80

See Also

- “Node Properties” on page 57
Realign Node Links

You can realign links connecting nodes in a plot. For instructions specific to the type of node link that you want to work with, see the following:

- “Realign a Straight Node Link” on page 73
- “Realign a Curved Node Link” on page 75
- To realign a self-link, you must realign the node to which it is connected. For instructions, see “Realign Nodes and Their Links as a Unit ” on page 75.

See Also

- “Node Properties” on page 57
- SAS/STAT User’s Guide

Realign a Straight Node Link

To realign a straight link:

1. If you are not in Edit mode, enter it by clicking the Select Data Label icon a in the Graph toolbar.

2. Right-click anywhere on the link to surface its breakpoints. Each breakpoint is displayed as a box on the link line.

3. To realign a link with only two breakpoints, you must re-align the nodes to which the link is connected. See “Realign Nodes and Their Links as a Unit ” on page 75.

Note: Minimally, a straight link has two breakpoints. One indicates the originating point, and the other indicates the ending point in relation to the connected nodes.
Because the straight link indicates the shortest distance between two nodes, you must insert another breakpoint in order to realign this link. The originating and ending breakpoints cannot be edited. For instructions, see “Insert a Breakpoint on a Straight Node Link” on page 77.

4 If there are more than two breakpoints, you can realign an individual breakpoint or realign a group of breakpoints.

Note: Originating or ending breakpoints can be re-aligned only in unison with the realignment of the nodes to which the link line connects.

a To realign an individual breakpoint, right–click on it and drag the highlighted box to its new location.

b To realign a group of breakpoints:

1 Right-click on a breakpoint to select it. The box is highlighted.

2 Press the Ctrl key and right-click on each additional breakpoint that you want to select. Every selected breakpoint is highlighted.

3 Drag any one of the breakpoints to the new location and all of the selected breakpoints realign.

Note: The originating and ending points of a link cannot be selected. Their position is permanently attached to their respective node.

Note: The nodes associated with the link whose breakpoints you are realigning remain stationary.

Note: To deselect a breakpoint, right-click on it again while pressing the Ctrl key. The box is no longer highlighted.

Note: To clear the display of all breakpoints, right-click either on the link line or on a clear area in the plot.

See Also

- “Realign a Curved Node Link” on page 75
- “Realign Node Links ” on page 73
Realign a Curved Node Link

To re-align a curved link:

1. If you are not in Edit mode, enter it by clicking the Select Data Label icon in the Graph toolbar.

2. Right-click near the link to surface the control point. The control point is displayed as a separate box. This point controls how the node is curved.

3. Right-click on the control point box to select it. The box is highlighted.

4. Drag the control point to the new location. The link, and any associated text, move in unison.

5. Release the mouse button when the link is positioned where you want it.

**Note:** A self-link is a special type of curved link that originates from the same node to which it connects. Self-links are not editable. You cannot change them to another type of link.

See Also

- “Realign a Straight Node Link” on page 73
- “Realign Node Links” on page 73
- “Realign Nodes and Their Links as a Unit” on page 75

Realign Nodes and Their Links as a Unit

You can realign nodes and links by either drawing a rectangle around them or by selectively choosing each node and link to realign.
Enter Edit Mode

If you are not in Edit mode, enter it by clicking the Select Data Label icon in the Graph toolbar.

Draw a Rectangle around Nodes and Their Links to Re-align as a Unit

To realign nodes and their links as a unit with a drawn rectangle:

1. Draw a rectangle around the set of nodes and their links that you want to realign.

2. To automatically realign the nodes and the links connecting them, right-click on any selected node or link within the rectangle. From the pop-up menu, click **Align horizontally** or **Align vertically**. All selected nodes and their connected links align according to the position of the first selected reference node.

   **Note:** To manually realign the nodes and the links connecting them, click on any selected node or link within the rectangle. Drag and drop all selected elements to the new location.

3. All selected nodes and their connected links realign according to your choice.

   **Note:** It is possible to have one node with an associated link, called a self-link. The node is both the originating and ending point for the self-link. You realign the self-link by realigning the node. The positioning of the self-link is automatically adjusted as the other links in the plot are taken into account.

Selectively Choose the Nodes and Their Links to Re-align as a Unit

You can realign nodes and their links as a unit by selectively choosing each element. Once you select your elements, right-clicking on any one selected element enables you to re-align all elements.
Insert a Breakpoint on a Straight Node Link

To insert a breakpoint on a straight node link:
1 If you are not in Edit mode, enter it by clicking the Select Data Label icon in the Graph toolbar.

2 Right-click on the straight link at the position where you want the new breakpoint and select **Insert a point** from the pop-up menu.

   The breakpoint is displayed as a small box on the link line. Any text describing the link might realign to display between the two middle breakpoints. A link with six breakpoints, for example, displays its text between the third and fourth breakpoints.

   **Note:** To move text describing a link, insert breakpoints.

3 Repeat **Step 2** for each breakpoint that you want to insert.

   **Note:** You cannot insert a breakpoint on a curved link. Every curved link has only one control point.

See Also

- “Realign Node Links ” on page 73
- “Node Properties” on page 57

---

**Delete a Breakpoint on a Straight Node Link**

If you are not in Edit mode, enter it by clicking the Select Data Label icon in the Graph toolbar.

To delete a breakpoint in a node link:

1 Right-click on a breakpoint to select it. The box is highlighted.

2 Right-click on the breakpoint and select **Delete selected point(s)** from the pop-up menu.

   The link line is displayed without the breakpoint that you just deleted.
To delete more than one breakpoint in a node link:

1 Right-click on a breakpoint to select it. The box is highlighted.

2 Right-click on each additional breakpoint that you want to select. Every box selected is highlighted.

3 Right-click on any one of the breakpoints and select **Delete selected point(s)** from the pop-up menu.

   The link line is displayed without the breakpoints that you just deleted.

**Note:** To deselect all breakpoints, right-click on a clear area in the plot.

**Note:** You cannot delete a curved link’s control point.

See Also

- “Insert a Breakpoint on a Straight Node Link” on page 77
- “Node Properties” on page 57

---

### Change a Link’s Curvature

This section describes how you can change a link line from straight to curved, or vice versa. To realign a curved link, see “Change a Link’s Curvature” on page 79.

### Enter Edit Mode

If you are not in Edit mode, enter it by clicking the Select Data Label icon in the Graph toolbar.

### Curve a Link Line

To change a straight link line to a curved link line:

1 Right-click on the link line.
2 Select Curved from the pop-up menu. This action creates a curved link line.

Note: If you change a straight link line with more than two breakpoints into a curved link line, then all the breakpoints are replaced by one control point.

Note: If the resulting curved link line is difficult to differentiate from a straight line, then you can increase its curvature. Right-click near the link to surface the control point. The control point is displayed as a separate box. Right-click on the control point box to select it, and drag it slightly so that the curve of the link line appears more pronounced.

### Straighten a Link Line

To change a curved link line to a straight link line:

1 Right-click on the link's control point to select it. (Click near the link to surface the control point.)

2 Select the check-marked Curved from the pop-up menu. This action deselects the curved link line in effect and creates a straight link line.

See Also
- “Change a Link’s Curvature” on page 79
- “Realign Node Links” on page 73
- “Node Properties” on page 57

### Realign a Self-Link

This section describes how you can realign a self-link around its parent node. This function is available starting with SAS 9.4M3. The parent node is both the originating point and the ending point for the self-link connected to it. A parent node has four sides and four corners. A self-link can be aligned to any one of these eight positions around the node.
Enter Edit Mode

If you are not in Edit mode, enter it by clicking the Select Data Label icon in the Graph toolbar.

Realign a Self-Link

To realign a self-link around its parent node:

1. Move the cursor over the self-link line. When the cursor changes to a hand icon, right-click on the self-link line to select it.

2. Drag the self-link to one of eight allowed positions around its parent node. Click on free space in the graphic to release the cursor and snap the self-link into the position that you chose.
The following graphics illustrate the realignment of self-links. Take note of the positions of self-links ‘d2’, ‘e9’, and the two ‘e...’s in the original partial graph:

![Original partial graphic](image1)

Compare the original partial graphic with this second graphic, noting the realigned positions of self links ‘d2’, ‘e9’, and the two ‘e...’s. For example, self-link ‘d2’ is realigned to the upper left corner of its parent node:

![Second graphic](image2)

**Note:** Only one self-link can be selected at a time.
See Also

“Change a Link’s Curvature” on page 79
About the Viewport Function

The editor provides the ability to adjust the view parameters of certain graphs through basic viewport functions. The viewport is a finite rectangular space within the graphical output area in the editor where the SGE file is rendered. This viewport space can be expanded or reduced with the cursor alone or in combination with the Ctrl key and keyboard keys. If you click on an axis to select it and then drag it with the mouse, the viewport pans in the direction of the drag.

There are two ways to access the viewport function. The Graph toolbar contains the Viewport icon as well as the Reset viewport icon. Click on either of these icons when you have an eligible SGE file open in the editor. You can also select or deselect
Viewport from the View menu. The Viewport function is deselected by default. Click the check box and select the Viewport function.

All the changes that you make with the editor’s viewport function can be saved to the SGE file. You can also choose to reset or redo any of your changes.

The editor supports the adjustment of the viewing parameters of a graph with either a single layout overlay or a 3-D layout overlay. Examples of such graphs are histograms, density, surface, and fringe plots. Exceptions to this support include log axis and broken axis graphs with their data skin specifications. The editor does not output the graph result when the viewport adjustment of rotating axis tick marks causes them to align horizontally. It takes up too much space in the graphic output area.

See Also

“Resizing the View of a Graph” on page 86

---

Resizing the View of a Graph

After you are in Viewport mode, you can adjust the size of the viewport rectangle by zooming, panning, or setting a viewport region. At any point, you can undo any changes made to the view with the Reset viewport function. You also have the ability to save your changes as an SGE file for future editing. The following sections describe how to access the viewport function, and then the various ways that you can use that viewport function.

Accessing the Viewport Function

Enter Viewport Mode by clicking the Viewport icon in the Graph toolbar. A hand cursor with multidirectional capability appears in the graphical output area.

Note: The icon is enabled only when the graph contains single or 3-D layout overlays. Otherwise, the icon is dimmed. Examples of such graphs are histograms, density, surface, and fringe plots.

Now you are ready to adjust the size of the viewport space in which the graph resides. Take one of the following actions:
Zooming the View of the Graph

You must be in **Viewport** mode. If you are not, see “Accessing the Viewport Function” on page 86.

You can expand or decrease the size of the graph in the viewport rectangle. Use the wheel of the mouse or press Ctrl and right-mouse click and drag a section of the viewport area. The mouse must be in the graphical output area. Notice that tick marks on both axes of the graph are adjusted based on the amount that you move the mouse or mouse wheel. The axis size itself is adjusted by the editor after the Viewport resizing is complete. When using the wheel of the mouse to resize, a move or click of the mouse indicates that resizing is complete.

If the cursor is a closed hand, you can expand only the view area of the graph.

You can expand a plot with 3-D layout overlays, such as a surface plot. Press the Ctrl key, click anywhere on the graph and drag the cursor in the direction of the ‘Y’ axis. When the multidirectional expansion cursor appears, drag it to zoom the view of the graph. The default zoom (expansion) value is 1.0 degree. The zoom value appears in the upper right hand corner of the graph as you manipulate it. You cannot decrease the view area of a 3-D plot.

**Note:** The editor does not output the graph resulting from a viewport adjustment of rotating the axis tick marks. When the rotation causes them to align horizontally, the graph takes up too much space in the graphic output area.

**Note:** Expanding the size of a graph can cause annotation objects in a graph to be moved out of the graph.
Panning the View of the Graph

You must be in Viewport mode. If you are not, see “Accessing the Viewport Function” on page 86.

You can scroll either the ‘Y’ or the ‘X’ axis after you adjust the size of your graph. Click on an axis to select it and drag it in either direction. This action adjusts the area of the axis that appears in the viewport rectangle. Tick marks go in and out of viewing range, depending on the direction the cursor moves.

Some plots such as surface plots have 3-D layout overlays. When you click anywhere on the graph and drag the cursor in the direction of the ‘X’ (horizontal) axis, it changes the rotation (azimuth) value. The default azimuth value is 54.0 degrees. By dragging the cursor in the direction of the ‘Y’ (vertical) axis, you change the tilt (inclination) value. The default inclination value is –20.0 degrees. These values appear in the upper right hand corner of the graph as you manipulate them.

**TIP** While using your mouse, you can use the Ctrl key in combination with keyboard keys to accomplish the same directional movement. See “Using Keyboard and Ctrl Keys to Adjust the View of the Graph” on page 88.

Using Keyboard and Ctrl Keys to Adjust the View of the Graph

You must be in Viewport mode. If you are not, see “Accessing the Viewport Function” on page 86.

To zoom, press the ‘H’ key or the ‘X’ key while scrolling the mouse wheel to expand or decrease the graph only in a horizontal direction (along the X axis). Press the ‘V’ key or the ‘Y’ key while scrolling the mouse wheel to expand or decrease the graph only in a vertical direction (along the Y axis). Using the Ctrl key in conjunction with these other keys and dragging the mouse pointer accomplishes the same actions.
To pan, press the ‘H’ key or the ‘X’ key while dragging the mouse pointer to pan the horizontal axis (the X axis). Press the ‘V’ key or the ‘Y’ key while dragging the mouse pointer to pan the vertical axis (the Y axis).

**Setting a Viewport Region**

You must be in Viewport mode. If you are not, see “Accessing the Viewport Function” on page 86.

To set the size of the viewport to a region of your choice, press the ‘R’ key and drag the mouse pointer to set the viewport area. This does not work with 3-D layout overlay plots.

**Undoing a Change to the View of a Graph**

There are two ways to undo changes that you do not wish to keep. You can double click inside the graph to reset to the default viewport values. Or you can click the Reset viewport icon in the Graph toolbar. This also resets the viewing area of the graph back to its original state.

**Saving the Adjusted View of a Graph**

Save the graph output with its view adjustments as an SGE file to enable further editing. See Also

- “Save Graph Output ” on page 17
- “About the Viewport Function” on page 85
About Annotation Objects

You can use ODS Graphics Editor to add the following annotation objects to a graph:

- text annotations
- lines and arrows
- ovals (and circles)
- rectangles (and squares)
Note: A PATHDIAGRAM plot (created by the SAS/STAT CALIS procedure PATHDIAGRAM statement), will not accept annotations.

The annotation objects are rendered on top of the graph. Unlike titles and footnotes, annotation objects do not cause a graph to be resized or rearranged.

Annotation objects can be attached to a graph data points. If the graph is resized, the annotations move with the data point. For more information, see “Understanding Annotation Objects and Data” on page 94.

Understanding Annotation Objects and Data

You can add free-form annotations (such as text, lines, circles, images, and markers) to a graph. The annotation objects are rendered on top of the graph. Unlike titles and footnotes, annotation objects do not cause a graph to rearrange. However, annotation objects can be attached to data points in the plot area. If the graph is resized, the annotations move with the data points.

Whether an annotation is attached to the data depends on where the annotation was created in the graph, as described in the following table:
### Table 10.1 Location Determines Default Data Attachment

<table>
<thead>
<tr>
<th>Annotation Location</th>
<th>Behaviors</th>
</tr>
</thead>
</table>
| Created totally within in the plot area | By default, the annotation object is attached to the data markers, lines, and so on, in the plot area. For example, suppose that you create a rectangle in the plot area next to a data marker. Suppose also that the graph changes due to the addition or removal of titles or footnotes. The location of the rectangle changes along with the location of the data marker even though the plot area might change in size. In other words, the rectangle location remains synchronized with the data location. There are three exceptions:  
- Plots with a DATALATTICE or DATAPANEL layout do not support this data synchronization feature. Annotations that are added to these plots cannot be attached to data points.  
- Three-dimensional plots, such as surface plots, also do not support the data synchronization feature.  
- Image annotations cannot be attached to data points. They always behave as if they were created outside the plot area.  
By default, if you move an annotation object that was created in the plot area beyond the plot area border, the annotation is cropped at the plot area boundary.  
For most annotation objects, you can specify that annotations created inside the plot area act like annotations created outside the plot area (that is, they lose their data synchronization). For details, see “Change the Data Attachment Properties of an Annotation” on page 108.  |
| Created totally outside plot area    | By default, annotation objects created outside the plot area are positioned relative to the overall size of the graph. These annotation objects are not attached to the data in the plot area.  
If the graph is resized, the annotation object maintains its position relative to the entire graph. For example, suppose you add a marker annotation to the bottom center of a graph (outside the plot area). If you resize the graph, the marker stays in the bottom center.  
Annotation objects that are created outside the plot area and then moved inside the plot area do not become attached to the data. |
<table>
<thead>
<tr>
<th>Annotation Location</th>
<th>Behaviors</th>
</tr>
</thead>
<tbody>
<tr>
<td>Created both inside and outside the plot area</td>
<td>You can create a line or arrow that has one end inside the plot area and the other end outside the plot area. Only the end that was created within the plot area is attached to the data. If the graph is resized, the attached end stays with the data point. Moving either end does not change the original data synchronization behavior. If you want the entire line to be synchronized with the data, you must create a new line that is entirely within the plot area. All non-line annotation objects are attached to the data only if the starting position is in the data area. Unlike lines and arrows, the other annotation objects are either entirely attached to the data or not attached to the data.</td>
</tr>
</tbody>
</table>

## Data Attachment Examples for Annotations

### Example: Text Annotation

This example shows how text annotations behave when the plot area is resized. The behavior varies depending on whether the annotation is attached to the data.

The following display shows a text annotation in the upper left corner within a plot. In the example, the text annotation has a red circle around it:
By default, the annotation is attached to data in the upper left corner.

The following display shows the same graph with titles added. The titles cause the plot to get smaller. The annotation stays with the data when the graph is resized.
The next display shows the result when you add titles to the graph but change the properties of the text annotation. The annotation is not attached to the data.

**Figure 10.3  Text Annotation That Is Not Attached to the Data**
The text remains in place when the plot is resized because the text is not attached to the data.

**Example: Oval Annotation around a Data Point**

This example shows the behavior of ovals that are created around data points when the plot area is resized. The behavior varies depending on whether the oval is attached to the data point.

The following display shows an oval annotation around a data point in a plot:

*Figure 10.4 Oval Annotation in a Plot*

By default, the annotation is attached to the data point.
The following display shows the same graph with more titles added. The titles cause the plot to get smaller. The oval stays around the data point when the graph is resized.

*Figure 10.5 Oval Annotation in a Resized Plot*

The next display shows the result when you add titles to the graph but have changed the properties of the oval so that it is not attached to the data.
Figure 10.6 Oval Annotation That Is Not Attached to the Data

The oval does not move when the plot is resized because the oval is not attached to the data point.

Example: Arrow Annotation Partially Attached to Data

This example shows the behavior of arrow annotations when the plot area is resized. One end of the arrow is attached to the data and the other end is not.

The following display shows an arrow with one end in a plot and the other end outside the plot:
Only the end that resides within the plot is attached to the data.

The following display shows the same graph with another title added. When the plot is resized, the end of the arrow that is attached to the data moves while the other end stays in place.
**Figure 10.8**  Arrow in a Resized Plot

Example: Marker Annotation with Text That Is Cropped

This example shows the behavior of marker annotations that have text when the text is moved off the edge of the plot.

The following display shows a marker annotation with text (toward the bottom of the plot):
By default, the marker and its text are attached to the data.

The next display shows the marker after it has been moved downward so that the text moves outside the plot. The text disappears (is cropped). By default, when the annotation is attached to the data, any part of the annotation that resides outside the plot is cropped.
Figure 10.10  Marker Annotation with Cropped Text

The next display shows the result when you change the properties of the marker so that cropping is disabled. The marker text appears outside the plot.
Note: Another way to make the marker text appear is to reposition the text above the marker. You can also change the properties of the marker so that it is not attached to the data.

Example: Annotation Positioned over a Legend in a Graph That Is Resized

This example shows the behavior of an annotation that is positioned over a legend. Because it is created outside the plot area, the annotation is not attached to the data. When the graph is resized, the annotation stays in place.

The following display shows a graph that has a legend, with an oval created around part of the legend:
By default, the annotation is not attached to the data because it was created outside of the plot area.

The next display shows the same graph when it is reduced in size. The oval moves with the graph, but is no longer around the same portion of the legend.
Figure 10.13 Oval Annotation in a Resized Graph

Note: The same behavior occurs when you save the graph as a PNG file and specify a DPI larger than 100. When you close and then reopen the PNG, you see that the graph size has changed. However, the oval that was positioned over the legend is no longer around the same portion of the legend.

Change the Data Attachment Properties of an Annotation
Depending on where you create an annotation object, the object might be attached to the data inside the plot area. For more information about data attachment, see “Understanding Annotation Objects and Data” on page 94.

You can change the data attachment behavior of an annotation object. You can control whether the object is attached to data and whether to crop any portion of the object that resides outside of the plot.

To change the data attachment behavior for an annotation object:

1. Right-click the annotation object whose behavior you want to change and select **Annotation Properties** from the pop-up menu.

2. Select the **Position** tab.

3. If you are modifying a line or arrow, then make the following changes:
   
   a. In the **Line Point** list box, select which end of the line or arrow you want to change.
Select or clear **Attach to data in underlying Plot area.** If this option is selected, then the corresponding end of the line is attached to data and is not visible outside the plot area. If you clear this option, then the corresponding end of the line is not attached to the data and becomes visible outside the plot area.

If the line or arrow was created outside the plot area, then this check box is dimmed.

You can also change the vertical or horizontal placement of the selected end point. For more information, see “Resize By Using the Annotation Properties Dialog Box ” on page 136 and “Rotate By Using the Annotation Properties Dialog Box ” on page 139.

4 If you are modifying an oval, rectangle, or marker, then make the following changes:

- Select or clear **Attach to data in underlying Plot area.** If this option is selected, then the annotation object is attached to the data.
If the annotation object is attached to data (*Attach to data in underlying Plot area* is selected), then you can crop the part of the object that is outside of the plot. To toggle cropping on or off, select or clear *Crop the part outside Plot area*.

If the annotation was created outside the plot area, then both of these check boxes are dimmed.

You can also rotate the annotation. For more information, see “*Rotate By Using the Annotation Properties Dialog Box*” on page 139.

5 Click **OK**.

If the original graph is a data panel or data lattice that contains an annotation, the editor preserves the cropping that was performed by SAS when the graph was created. As a result, the *Crop the part outside Plot area* check box is dimmed. In addition, annotations that are added to these plots cannot be attached to data points. For annotations that you add, both the *Crop the part outside Plot area* and the *Attach to data in underlying Plot area* check boxes are dimmed.
Using Annotations in a Graph

About Text Annotations ................................................. 113
Add a Text Annotation to a Graph ................................. 114
Edit a Text Annotation .................................................. 115
About Lines and Arrows .................................................. 115
Add a Line to a Graph .................................................... 116
Add an Arrow to a Graph ............................................... 117
About Ovals and Rectangles .......................................... 118
Add an Oval to a Graph ............................................... 119
Add a Rectangle to a Graph .......................................... 119
About Markers ............................................................ 120
Add a Marker to a Graph .............................................. 121
About Images ............................................................. 121
Add and Position an Image in a Graph ......................... 122

About Text Annotations
You can change the appearance of a graph by adding text annotations. For instructions on working with text annotations, see the following topics:

- “Add a Text Annotation to a Graph” on page 114
- “Edit a Text Annotation” on page 115
- “Format a Text Annotation” on page 123

You can also make the following changes:

- Change the size of a text annotation. For instructions, see “Resize an Annotation” on page 135.
- Rotate a text annotation. For instructions, see “Rotate an Annotation” on page 139.
- Move a text annotation. For instructions, see “Move an Annotation” on page 141.
- Change the data attachment properties of a text annotation. For instructions, see “Change the Data Attachment Properties of an Annotation” on page 108.
- Copy and paste a text annotation. For instructions, see “Copy and Paste an Annotation Object” on page 142.
- Delete a text annotation. For instructions, see “Delete an Annotation” on page 142.

Add a Text Annotation to a Graph

To add a text annotation to a graph:

1. Click the text icon in the Graph toolbar, or select Insert ➤ Text from the main menu.

2. Click the area of the graph where you want to position your text. A text box appears.

3. Enter the text in the box.

   The width of the text box determines the maximum width of the text line. If a line exceeds the width of the text box, then the text wraps to the next line.
If needed, drag one of the circles on the border of the text box to the right or left to widen the text box.

4 If you want to format the text, select the entire text string. Then use the Formatting toolbar to change the appearance of the font. For formatting options, see “Format a Text Annotation” on page 123.

By default, if the text object was created in the data area then it is attached to the data, and any part that is outside the data area is cropped. For more information, see “Understanding Annotation Objects and Data” on page 94.

---

**Edit a Text Annotation**

To edit a text annotation:

1 Double-click the text annotation that you want to change.

2 Enter your textual changes.

3 If you want to format the text, select the entire text string. Then use the Formatting toolbar to change the appearance of the font. For formatting options, see “Format a Text Annotation” on page 123.

---

**About Lines and Arrows**

You can change the appearance of a graph by adding lines and arrows. You can also add text to the lines and arrows. For instructions on working with lines and arrows, see the following topics:
“Add a Line to a Graph” on page 116

“Add an Arrow to a Graph” on page 117

“Change the Color, Pattern, and Thickness of a Line or Arrow” on page 124

You can also make the following changes:

- Add text to a line or arrow. For instructions, see “Add Text to an Annotation” on page 132.
- Change the length of a line or arrow. For instructions, see “Resize an Annotation” on page 135.
- Rotate a line or arrow. For instructions, see “Rotate an Annotation” on page 139.
- Move a line or arrow. For instructions, see “Move an Annotation” on page 141.
- Change the data attachment properties of a line or arrow. For instructions, see “Change the Data Attachment Properties of an Annotation” on page 108.
- Copy and paste a line or arrow. For instructions, see “Copy and Paste an Annotation Object” on page 142.
- Delete a line or arrow. For instructions, see “Delete an Annotation” on page 142.

---

**Add a Line to a Graph**

To add a line to a graph:

1. Click the line icon ↪ in the Graph toolbar, or select **Insert ▶ Line** from the main menu.

2. Position your cursor at a starting position in the graph.

3. Click and drag to create the line in the graph.

   You can control the line as follows:
If you press the Ctrl key and then click and drag, the line is created from the center and moves outward.

If you press Shift and then click and drag, then the line's orientation stays in multiples of 15 degrees. You can create a perfect horizontal or vertical line this way. You can also rotate the line in 15 degree increments to create a diagonal line.

If you press Ctrl+Shift and then click and drag, the line is created from the center, moves outward, and can be rotated in 15 degree increments.

You can add text to the line. For instructions, see “Add Text to an Annotation” on page 132.

---

### Add an Arrow to a Graph

You can add an arrow to a graph to point out specific information. To add an arrow to a graph:

1. Click the arrow icon ➔ in the Graph toolbar, or select **Insert ➔ Arrow** from the main menu.

2. Position your cursor at a starting position in the graph.

3. Click and drag to create the arrow. By default, the arrow is drawn from the tail to the head.

   You can control the arrow as follows:

   - If you press the Ctrl key and then click and drag, the arrow is created from the head to the tail.

   - If you press Shift and then click and drag, then the arrow's orientation stays in multiples of 15 degrees. You can create a perfect horizontal or vertical arrow this way. You can also rotate the arrow in 15 degree increments to create a diagonal arrow.
If you press Ctrl+Shift and then click and drag, the arrow is created from the head to the tail, and can be positioned in 15 degree increments.

After you create the arrow, you can add text to the tail end of the arrow. For instructions, see “Add Text to an Annotation” on page 132.

About Ovals and Rectangles

You can change the appearance of a graph by adding ovals (or circles) and rectangles (or squares). You can also add text to the ovals and rectangles. For instructions on working with ovals and rectangles, see the following topics:

- “Add an Oval to a Graph” on page 119
- “Add a Rectangle to a Graph” on page 119
- “Change the Color, Transparency, and Outline Properties of an Oval or Rectangle” on page 125

You can also make the following changes:

- Add text to an oval or rectangle. For instructions, see “Add Text to an Annotation” on page 132.
- Change the size of an oval or rectangle. For instructions, see “Resize an Annotation” on page 135.
- Rotate an oval or rectangle. For instructions, see “Rotate an Annotation” on page 139.
- Move an oval or rectangle. For instructions, see “Move an Annotation” on page 141.
- Change the data attachment properties of an oval or rectangle. For instructions, see “Change the Data Attachment Properties of an Annotation” on page 108.
- Copy and paste an oval or rectangle. For instructions, see “Copy and Paste an Annotation Object” on page 142.
Delete an oval or rectangle. For instructions, see “Delete an Annotation” on page 142.

---

**Add an Oval to a Graph**

To add an oval (or a circle) to a graph:

1. Click the oval icon 🌀 in the Graph toolbar, or select **Insert ➤ Oval** from the menu.

2. Place your cursor at the top left position in the graph where you want your oval to begin.

3. Click and drag your cursor to the right to create an oval.

   You can control the oval as follows:
   - If you press the Ctrl key and then click and drag, the oval expands from the center.
   - If you press the Shift key and then click and drag, you can draw a perfect circle.
   - If you press Shift + Ctrl and then click and drag, you draw a circle that expands from the center.

   You can add text to the oval. For instructions, see “Add Text to an Annotation” on page 132.

---

**Add a Rectangle to a Graph**

To add a rectangle (or a square) to a graph:

1. Click the rectangle icon □ in the Graph toolbar, or select **Insert ➤ Rectangle** from the menu.
2 Place your cursor at the top left position in the graph where you want your rectangle to begin.

3 Click and drag your cursor to the right to create a rectangle.

You can control the rectangle as follows:

- If you press the Ctrl key and then click and drag, the rectangle expands from the center.
- If you press the Shift key and then click and drag, you can draw a perfect square.
- If you press Shift + Ctrl and then click and drag, you draw a square that expands from the center.

You can add text to the rectangle or square. For instructions, see “Add Text to an Annotation” on page 132.

About Markers

You can change the appearance of a graph by adding markers to the graph. For instructions on working with markers, see the following topics:

- “Add a Marker to a Graph” on page 121
- “Change the Color, Symbol, and Size of a Marker” on page 127

You can also make the following changes:

- Add text to a marker. For instructions, see “Add Text to an Annotation” on page 132.
- Rotate a marker. For instructions, see “Rotate an Annotation” on page 139.
- Move a marker. For instructions, see “Move an Annotation” on page 141.
- Change the data attachment properties of a marker. For instructions, see “Change the Data Attachment Properties of an Annotation” on page 108.
- Copy and paste a marker. For instructions, see “Copy and Paste an Annotation Object” on page 142.
Delete a marker. For instructions, see “Delete an Annotation” on page 142.

---

**Add a Marker to a Graph**

You can use a marker to identify or accentuate key data elements in a graph, such as data points that are outliers.

To add a marker to a graph:

1. Click the marker icon ✭ in the Graph toolbar, or select **Insert ▶ Marker** from the main menu.

   **Note:** As shown here, the marker icon is a star. The icon in your operating environment might be different. In addition, you can change the symbol that is used for the icon. For instructions, see “Change the Color, Symbol, and Size of a Marker” on page 127.

2. Click the area of the graph where you want to place the marker.

   You can add text to the marker. For instructions, see “Add Text to an Annotation” on page 132.

---

**About Images**

You can add images to a graph. For instructions on working with images, see the following topics:

- “Add and Position an Image in a Graph” on page 122
- “Format an Outline around an Image” on page 128

You can also make the following changes:

- Add text to an image. For instructions, see “Add Text to an Annotation” on page 132.
Change the size of an image. For instructions, see “Resize an Annotation” on page 135.

Rotate an image. For instructions, see “Rotate an Annotation” on page 139.

Move an image. For instructions, see “Move an Annotation” on page 141.

Copy and paste an image. For instructions, see “Copy and Paste an Annotation Object ” on page 142.

Delete an image from a graph. For instructions, see “Delete an Annotation” on page 142.

---

**Add and Position an Image in a Graph**

You can add an image, such as a logo, to a graph. When you add an image to a graph, the image appears in the center of the graph. You can reposition and resize the image if necessary.

To add, resize, and reposition an image:

1. Click ![image](image) from the Graph toolbar, or select **Insert ▶ Image** from the main menu.
2. From the Image dialog box that is displayed, select and open the image that you want to insert.
   - The image appears in the center of the graph.
3. To resize the image, select the image and drag one of the circles that appear around the image. You can maintain the ratio of width to length. Position your cursor on a corner circle, press Shift, and drag the corner circle.
4. To move the image to a different position, click and drag the image to another position in the graph.

**Note:** Images are not attached to the data. For more information about data attachment, see “Understanding Annotation Objects and Data” on page 94.
Changing the Visual Properties of Annotations

Format a Text Annotation .......................................................... 123
Change the Color, Pattern, and Thickness of a Line or Arrow 124
Change the Color, Transparency, and Outline Properties of an Oval or Rectangle .................................................. 125
Change the Color, Symbol, and Size of a Marker .................. 127
Format an Outline around an Image ........................................... 128

Format a Text Annotation

You can change the font, size, style (for example, bold or italicized), alignment, or color of the text in a text annotation.

To format a text annotation:

1  Click the text annotation.

2  Use the Formatting toolbar to make your changes. For details, see “Using the Formatting Toolbar” on page 36.
Text format changes that you make here remain in effect for new annotations that you add.

As an alternative to this procedure, you can right-click the text annotation, select **Annotation Properties**, and make your changes in the **Text** tab. You can change the font, size, style, and color.

### Change the Color, Pattern, and Thickness of a Line or Arrow

To change the color, pattern (such as dotted or dashed), or thickness of a line or arrow:

1. Right-click the line or arrow and select **Annotation Properties** from the menu. The Annotation Properties dialog box appears.

2. Make sure that the **Appearance** tab is selected.
3  Click the down arrows to select the line's color, pattern, and thickness. The line or arrow changes appearance.

4  Click **OK**.

Line format changes that you make remain in effect for new annotations that you add.

---

**Change the Color, Transparency, and Outline Properties of an Oval or Rectangle**

You can change various format properties of an oval or a rectangle.

To format ovals and rectangles:

1  Right-click the oval or rectangle and select **Annotation Properties** from the menu. The Annotation Properties dialog box appears.
2 Make sure that the **Appearance** tab is selected.

3 You can specify a fill color for the oval or rectangle as follows:
   - Select the **Fill** check box and then select a color from list box. For details, see "Using the Color List Box" on page 37.
   - Change the fill transparency of the oval or rectangle by sliding the arrow in the **Transparency** field. Moving the slider to the right makes the fill more transparent.

4 In the **Outline** section of the dialog box, you can change the outline of the oval or rectangle as follows:
   - Select a color for the outline from the **Color** list box.
   - Select a different pattern (such as dotted or dashed) for the outline from the **Pattern** list box.
Select a different thickness for the outline from the **Thickness** list box.

If the **Fill** check box is selected, then you can remove the outline. Select or clear the **Outline** check box to toggle the outline on and off.

5 Click **OK**.

Outline and fill format changes that you make remain in effect for new annotations that you add.

---

**Change the Color, Symbol, and Size of a Marker**

To change the color, symbol, and size of a marker:

1 Right-click the marker and select **Annotation Properties**. The Annotation Properties dialog box appears.
2 Make sure that the **Appearance** tab is selected.

3 To specify a color, symbol, or size, click the arrows in the fields and make a selection.

   You can also change the marker's size using a click-and-drag method. For details, see “Resize an Annotation” on page 135.

4 Click **OK**.

---

**Format an Outline around an Image**

You can add an outline to an image and then specify the color, pattern, and thickness of the outline.

To add and format an outline:

1 Right-click the image and select **Annotation Properties**. The Annotation Properties dialog box appears.
2 Make sure that the **Appearance** tab is selected.

3 Select the **Outline** check box to add an outline to the image.

4 To specify the outline's color, pattern, and thickness, click the arrows in the fields and make a selection.

5 Click **OK**.
Adding Text to Annotations

Overview of Adding Text to Annotations .............................................. 131
Add Text to an Annotation .............................................................. 132
Edit Text That Has Been Added to an Annotation ......................... 133
Format Text That Has Been Added to an Annotation ..................... 133
Move Text That Has Been Added to an Annotation ......................... 134

Overview of Adding Text to Annotations

In addition to adding text annotations to a graph, you can add text to lines, arrows, ovals, rectangles, images, and markers.

Note: When you create an arrow in your graph, a text box appears. The text box disappears if you click outside the arrow without entering text. You can later add text to the arrow.

For instructions on working with annotations and text, see the following topics:

- “Add Text to an Annotation” on page 132
- “Edit Text That Has Been Added to an Annotation” on page 133
- “Format Text That Has Been Added to an Annotation” on page 133
Add Text to an Annotation

To add text to an annotation:

1. Right-click the annotation object and select **Add ('Edit') Text** from the pop-up menu.

   A text box appears. The location of the text box depends on the type of annotation.

   - For ovals and rectangles, the text box appears inside the oval or rectangle.

   ![Oval with Text Box]

   - For lines, the text box appears within the line. The following display shows a text box within a line.

   ![Line with Text Box]

   - For arrows, the text box appears at the tail end of the arrow.

   ![Arrow with Text Box]

   - For markers and images, the text box appears beneath the marker or image.

   ![Marker with Text Box]

2. Enter text in the box.

3. If you want to format the text, select the entire text string. Then use the Formatting toolbar to change the appearance of the font. For formatting options, see “Format Text That Has Been Added to an Annotation” on page 133.
For an oval or rectangle, the text is placed inside the oval or rectangle by default. The text wraps when it reaches the boundary of the annotation object. If there is insufficient space for the text that wraps, then the oval or rectangle increases its size to make space.

**Edit Text That Has Been Added to an Annotation**

To edit text that has been added to an annotation:

1. Right-click the annotation object and select **Add (‘Edit’) Text** from the pop-up menu. A text box surrounds the text.
2. Edit text in the box.
3. If you want to format the text, select the entire text string. Then use the Formatting toolbar to change the appearance of the font. For formatting options, see “Format Text That Has Been Added to an Annotation” on page 133.

**Format Text That Has Been Added to an Annotation**

To format text that has been added to an annotation:

1. Right-click the annotation object and select **Add (‘Edit’) Text** from the pop-up menu. A text box surrounds the text.

2. Select the entire text string. Then use the Formatting toolbar to change the appearance of the font. For details, see “Using the Formatting Toolbar” on page 36.

Changes that you make remain in effect for any new annotations that you add.
As an alternative to this procedure, you can right-click the text annotation, select **Annotation Properties**, and make your changes in the **Text** tab. You can change the font, size, style (for example, bold or italicized), and color.

---

**Move Text That Has Been Added to an Annotation**

To move text that has been added to an annotation:

1. Right-click the annotation object and select **Annotation Properties** from the pop-up menu.

2. Select the **Text** tab.

3. Select the desired position for the text as follows:
   - For lines and arrows, select the **Through**, **Above**, **Below**, **Start**, or **End** radio button to position the text with respect to the line or arrow.
   - For all other annotation objects, select the **Inside**, **Above**, or **Below** radio button to position the text with respect to the object.

4. Click **OK**.

For all annotations other than images, if your selection places the text outside of the plot, then the text might be cropped. For more information, see “Understanding Annotation Objects and Data” on page 94. To turn cropping off, see “Change the Data Attachment Properties of an Annotation” on page 108.
Modifying Annotations

**Resize an Annotation** ................................................................. 135
  Resize By Dragging ................................................................. 135
  Resize By Using the Annotation Properties Dialog Box .......... 136

**Rotate an Annotation** ............................................................. 139
  Rotate By Dragging the Annotation ........................................... 139
  Rotate By Using the Annotation Properties Dialog Box .......... 139

**Move an Annotation** ............................................................... 141

**Copy and Paste an Annotation Object** ..................................... 142

**Delete an Annotation** ............................................................. 142

**Working with Groups of Annotation Objects** .......................... 143

**Change the Order of Annotation Objects** ............................... 143

**Align Multiple Annotation Objects** ........................................ 144

---

**Resize an Annotation**

**Resize By Dragging**

To change the size of an annotation:
1 Click the annotation object that you want to resize.
   Small circles surround the object. If you click a line or arrow, a circle appears at each end of the line or arrow.

2 Click and drag a circle to change the size of the annotation as follows:
   - To change the length of a line or arrow, drag an end circle backward or forward.
     
     Press Shift and drag to keep the line or arrow perfectly horizontal, vertical, or diagonal in 15 degree increments.
   - To resize all other annotations, drag one of the circles to expand or reduce the annotation. To change the width and length of the annotation simultaneously, position the cursor in a circle at one of the corners.
     You can maintain the ratio of width to length. Position the cursor in a corner circle, press Shift, and drag the corner circle.
     The following display shows the cursor positioned on a corner circle of a marker.

   Note: For text annotations, this procedure changes the size of the text block, not the size of the font. To change the font, see “Format a Text Annotation” on page 123.

**Resize By Using the Annotation Properties Dialog Box**

You can use the Annotation Properties dialog box to resize markers and change the length of lines and arrows. This method provides more granular control of the size.

1 Right-click the line, arrow, or marker and select **Annotation Properties** from the pop-up menu. The Annotation Properties dialog box appears.
2 To resize a marker, complete these steps:
   a Select the **Appearance** tab.
   b Select the size that you want from the **Size** list box.

3 To change the length of a line or arrow, complete these steps:
   a Select the **Position** tab.
Select one end of the line from the **Line Point** list box. You select either the start point or the end point of the line.

If the selected end point is attached to the data, then the **Horizontal** and **Vertical** values correspond to a point along the X and Y axis, respectively.

If the end point is not attached to the data, then the **Horizontal** and **Vertical** values are measured in inches from the top left corner of the graph.

c From the **Horizontal** list box, select the new start or end point (whichever you have selected) in order to extend or shrink the length of the line or arrow. Only one end of the line or arrow moves. The other end remains fixed.

d (Optional) Repeat steps b and c to extend or shrink the other end of the line.

4 Click **OK**.
Rotate an Annotation

Rotate By Dragging the Annotation

To rotate an annotation:

1. Select the annotation object that you want to rotate.
   Small circles surround the object, and a handle appears at the top of the object. If you select a line or arrow, a circle appears at each end of the line or arrow.

2. To rotate a line or arrow, drag an end circle upward or downward.
   If you press Shift and then drag, you can rotate the line in 15 degree increments.

3. To rotate all other annotations, complete these steps:
   a. Place your cursor in the circle at the top of the handle. The cursor changes to a rotated arrow.
   b. Click and drag the handle to the right or left to rotate the annotation object.

Rotate By Using the Annotation Properties Dialog Box

You can use the Annotation Properties dialog box to rotate annotation objects. This method provides more granular control of the angle of rotation.

1. Right-click the annotation object and select Annotation Properties from the pop-up menu. The Annotation Properties dialog box appears.
2. Select the **Position** tab.

3. To rotate a line or arrow, complete these steps:

   a. Select one end of the line from the **Line Point** list box. You select either the start or the end point of the line.

      If the selected end point is attached to the data, then the **Horizontal** and **Vertical** values correspond to a point along the X and Y axis, respectively.

      If the end point is not attached to the data, then the **Horizontal** and **Vertical** values are measured in inches from the top left corner of the graph.

   b. From the **Vertical** list box, select the new start or end point (whichever you have selected) in order to move the end point upward or downward. Increasing the value of **Vertical** moves the end point down. Only one end of the line or arrow moves. The other end remains fixed.

4. To rotate all other annotation objects, select or enter the angle of rotation in the **Rotation** list box. Specify an integer between zero and 359. (If you enter a non-integer value, the number is truncated to an integer.) The object rotates clockwise.
5 Click OK.

---

Move an Annotation

To move an annotation:

1 Position your cursor on the annotation that you want to move.
   A double arrow appears.  

2 Click and drag the annotation to a new location in the graph.
Copy and Paste an Annotation Object

You can copy and paste an annotation object to a new location in the graph.

To copy and paste an annotation object:

1. Right-click the object and select Copy from the pop-up menu.

2. Right-click again and select Paste. The new object is pasted on top of the original, offset a little.

3. Move the pasted object to a new position in the graph.

Copy (or cut) and paste commands that are applied to annotation objects do not use the system clipboard. Instead, you copy and paste annotations between the graph and an internal editor stack. The copy and paste commands used for annotations are not affected by the contents of the system clipboard.

Delete an Annotation

To delete an annotation permanently from a graph:

1. Select the annotation that you want to delete.

2. Select Edit ▶ Delete. Alternatively, you can press the Delete key.

   Note: To undo the change, select Edit ▶ Undo.
Working with Groups of Annotation Objects

When you group annotation objects, you can easily move all items in the group as one object.

You cannot work on an individual object if it is part of a group. For example, in order to modify the text of a member object, you must first ungroup the objects.

To create and work with groups:

1 To create a group:
   a Press and hold the Ctrl key while you click on the annotation objects that you want to group.
   b Right-click and select Grouping ▶ Group from the pop-up menu.
      You can also select Arrange ▶ Grouping ▶ Group from the main menu.

2 To move a group, click the group and drag it to a new location.

3 To ungroup the objects, right-click the group and select Grouping ▶ Ungroup from the pop-up menu.

Change the Order of Annotation Objects

When you annotate a graph, annotation objects are placed in the top layer of the graph. Annotations are placed in the order in which they are created, with the last object on top. For example, if you create a rectangle and then create an oval on the rectangle, the oval is on top. You can change the order so that the rectangle is on top.
Note: GTL DRAW objects that are part of the original graph can be either in the back layer behind the graph or in the top layer. The editor adds annotations only in the top layer. You can change the ordering of annotation objects only within that top layer. If a DRAW object was added to the back layer of the original graph, then you cannot bring it in front of the objects in the top layer. For example, if an image was added using DrawImage(layer=back), then the image cannot be moved in front of objects in the top layer.

To change the order of an annotation object:

1. Right-click the object and select **Order** from the pop-up menu.
   
   You can also select **Arrange ➤ Order** from the main menu.

2. From the cascading menu, select one of the following options:
   
   - **Bring to Front** moves the selected object forward to the top of the stack.
   - **Bring Forward** moves the selected object forward one layer in the stack.
   - **Send to Back** moves the selected object to the bottom of the stack.
   - **Send Backward** moves the selected object back one layer in the stack.

---

**Align Multiple Annotation Objects**

You can specify that a group of annotations be left-aligned, centered, right-aligned, and so on.

To align multiple annotation objects:

1. Press and hold the Ctrl Key while you click on the objects to be aligned. The first object clicked is used as a reference object. The reference object stays in its place, and the other objects are moved to align with it.

2. From the main menu, select **Arrange ➤ Align**.
You can also select **Arrange ▶ Align** from the main menu.

3 From the cascading menu, select your alignment:

- **Top** aligns all selected objects with the top edge of the reference object.
- **Bottom** aligns all selected objects with the bottom edge of the reference object.
- **Left** aligns all selected objects with the left edge of the reference object.
- **Right** aligns all selected objects with the right edge of the reference object.
- **Center** aligns all selected objects around the center of the reference object.
Part 4

Examples

Chapter 15
   Editing and Annotating a Simple Graph by Example .......... 149

Chapter 16
   Showing and Hiding Labels by Example ......................... 159

Chapter 17
   Modifying a Multi-Cell Graph by Example ..................... 165

Chapter 18
   Editing and Annotating a SAS/STAT Graph by Example ...... 175
Editing and Annotating a Simple Graph by Example

About the Simple Graph .......................................................... 149

Code for the Simple Graph Example ....................................... 150

Editing the Graph .................................................................. 151
  Add a Title to the Graph ...................................................... 151
  Change the Axis Labels for the Graph .................................... 151
  Change the Marker Symbol and Size .................................... 151
  Change the Graph Style ...................................................... 152
  Change the Size of the Graph ............................................... 152
  View Your Changes ........................................................... 153

Annotating the Graph ............................................................ 154
  Add a Line Annotation to the Graph ..................................... 154
  Add Text to the Graph ....................................................... 156
  View Your Annotation Changes .......................................... 157

About the Simple Graph

This example uses the Class data set in the SAS Help library. The example provides the height and weight of individual students in a class and uses the SGPLOT procedure to produce a scatter plot.
In this example, you edit the graph by adding a title and changing the axis labels. You also change the scatter plot markers, the graph style, and the graph size.

Figure 15.1 Edited and Annotated Simple Graph

Code for the Simple Graph Example

ods html sge=on;
proc sgplot data=sashelp.class;
  scatter x=weight y=height;
run;
Editing the Graph

Add a Title to the Graph

To add a title to the graph:

1  Click the title icon in the Graph toolbar. A text box appears at the bottom of the graph and displays the highlighted text Insert Title.

2  Type Student Height.

Change the Axis Labels for the Graph

Change the axis labels to make them more informative.

To change the axis labels:

1  Double-click the Y axis label (Height) and change the text to Height in Inches.

2  Double-click the X axis label (Weight) and change the text to Weight in Pounds.

Change the Marker Symbol and Size

When you change the marker for the data points, you modify plot properties.

To change the markers:

1  Right-click inside the plot and select Plot Properties. The Plot Properties dialog box appears.

2  On the Plots tab, select the unfilled star marker (☆) from the Symbol list box.

3  Select 9 from the Size list box.
4 Click OK.

**Change the Graph Style**

The default style for the graph is StatGraphScheme, which inherits attributes from the style that was used when the graph was created (in this example, HTMLBlue). In this step, you change the style to Analysis.

1 Select **Format ▶ Style** from the main menu.

2 From the cascading menu, select **Analysis**.

Notice that the color of the markers has changed, but the marker symbol and size remain the same as they were. The reason is that you explicitly changed the marker symbol and size. The marker attributes that you specified override the settings that are associated with the new style.

**Change the Size of the Graph**

In this example, you want the graph to be five inches by approximately three inches in order to fit in a color presentation.

To change the size:

1 Right-click the graph and select **Graph Properties**. The Graph Properties dialog box appears.
2 Change the width of the graph to 5.  

*Keep Aspect Ratio* is currently selected. Changing the width to 5 also changes the height to 3.75 to maintain the current aspect ratio. However, you will not see the changed height number unless you return to this window.

3 Click **OK**.

**View Your Changes**

Here are the results of the editing changes that you have made so far to the graph.
Annotating the Graph

Add a Line Annotation to the Graph

You can annotate the graph that you edited in “Editing the Graph” on page 151.

In this step, you draw a red line to represent the approximate average height.

To draw a line:

1. Click the line icon in the Graph toolbar.

2. Position your cursor at any starting position along the Y axis and drag the line horizontally across the plot to the alternate Y axis.
3 Right-click the line and select **Annotation Properties**. The Annotation Properties dialog box appears.

4 On the **Appearance** tab, select the red color from the **Color** list box.

5 Do the following.

   a Select the **Position** tab.

   b Make sure **Start** is selected in the **Line Point** list box, and type 62 in the **Vertical** list box.
c Select *End* from the **Line Point** list box, and, if necessary, type 62 in the **Vertical** list box.

6 Click **OK**.

**Add Text to the Graph**

To add a text annotation:

1 Click the text icon in the Graph toolbar, or select **Insert ➤ Text** from the main menu.

2 Click the area of the graph where you want to position your text. A text box appears.

3 Drag one of the circles on the border of the text box to the right or left to widen the text box.
4 Enter the following text in the box: *Approximate average height: 62 inches*

The width of the text box determines the maximum width of the text line. If a line exceeds the width of the text box, then the text wraps to the next line.

5 Select the entire text string and use the Formatting toolbar to change the color of the font. Select a red color from the color list box. For details, see “Using the Color List Box” on page 37.

**View Your Annotation Changes**

Here are the results of the annotations that you have added to the graph.
Figure 15.3  Annotations Made to the Simple Graph

Approximate average height: 62 inches
About the Linear Regression for Sports Cars Example

The linear regression example shows the relationship between miles per gallon and horsepower for a number of sports cars. In this example, you are interested in the cars that fall outside of the confidence band. However, the labels in the middle portion of the graph are cluttered together. It is not clear which label belongs to which observation.
Your strategy is to show only a few of the data labels and hide the others. When you hide data labels, ODS Graphics Editor redraws the labels on the graph. This time, there is more space for the data labels of interest.

The code uses the REG procedure to create the linear regression and the SGPLOT procedure to create the graph.

### Code for the Linear Regression Example

SAS/STAT must be installed on the system in order to successfully run this code.

```sas
data sportscars;
  set sashelp.cars;
  if type = "Sports";
  run;
proc print data=sportscars;run;
```
data sportscars2 (keep= horsepower mpg_city shortname);
  set sportscars;
  id=find(strip(model), " ");
  put model id;
  if (id > 0) then shortname=substr(model, 1, id);
run;
proc print data=sportscars2;run;

proc sort data=sportscars2;
  by shortname;
run;
proc means data=sportscars2;
  by shortname;
  var horsepower mpg_city;
  output out=sasuser.sportsCarsMean
    mean = HP MPG;
run;
proc print data=sasuser.sportsCarsMean;run;

title 'Linear Regression';
proc reg data=sasuser.sportsCarsMean outest=sportscarfit_est;
  model hp=mpg;
  output out=sasuser.sportsCarMeanFit
    lcl=lower
    ucl=upper
    lclm=lowermean
    uclm=uppermean
    predicted=predict;
run;
proc sort data=sasuser.sportsCarMeanFit;
  by mpg;
run;
proc print data=sasuser.sportsCarMeanFit; run;
/* */
ods listing sge=on style=Listing;
ods graphics on / reset width=400px imagename='CarsLabels';
proc sgplot data=sasuser.sportsCarMeanFit;
  band x=mpg upper=uppermean lower=lowermean / name='band'
    legendlabel='Confidence';
  scatter x=mpg y=hp / dataLabel=shortname name='plot';
  series x=mpg y=predict / name='predict' legendlabel='Predicted';
Show and Hide Labels

For this example, select all the observations that lie outside the confidence band:

1. Select the data label icon ✓ in the Graph toolbar.

2. Right-click the plot and select Hide All. Hiding the labels makes it easier to see which data points to select.

3. Press Ctrl and click the observations that lie outside the confidence band. The selected data points are displayed in the selection color.

4. Right-click and choose Show Only Selected from the menu. Labels appear next to the data points that you selected.

5. Click inside the graph again. The data points and their labels are displayed in the normal graph color. Only the data points that lie outside the confidence band have labels.

6. Select Format ▶ Style ▶ Listing from the main menu.

The revised example is shown here:
Figure 16.2  Labels Show Only for Observations outside the Confidence Band
Modifying a Multi-Cell Graph by Example

About the Classification Panel Example ........................................... 165
Code for the Classification Panel Example ....................................... 166

Editing a Multi-Cell Graph That Uses a Single Data Set .................... 167
Modify the Classification Panel Example ........................................... 167

Modifying Individual Plots in a Diagnostic Panel ............................ 169
About the Fitness Example .............................................................. 169
Code for the Fitness Example ......................................................... 170
Modify the Fitness Example ............................................................ 171

About the Classification Panel Example

This example uses the Heart data set in the SAS Help library. The example provides the cholesterol distribution for a group of men and women. The code uses the SGPANEL procedure to create a classification panel with two cells. Both cells are driven by the same data set.

In this example, you edit the graph by modifying the background fill color, changing the color of the density curve, and adding an arrow annotation to one of the cells.
Figure 17.1 Classification Panel Example

Code for the Classification Panel Example

```sas
ods listing sge=on;
proc sgpanel data=sashelp.heart noautolegend;
  title "Cholesterol Distribution in Heart Study";
  panelby sex;
  histogram cholesterol;
  density cholesterol;
run;

title;
ods listing close;
```
Editing a Multi-Cell Graph That Uses a Single Data Set

Modify the Classification Panel Example

Change the Background Color

When you change the background fill color, you modify the graph’s properties.

1. Right-click the graph and select **Graph Properties**. The Graph Properties dialog box appears.
2 In the Background section, select a gray color from the Fill list box. For details about setting the color, see “Using the Color List Box” on page 37.

The outside of the plot area changes to the color that you selected.

3 Click OK.

Change the Color of the Density Curve

When you change the color of the density curve in the cells, you modify plot properties. For the type of multi-celled graph used in this example, any change that you make to plot properties in one cell affects all cells in the graph.

1 Right-click inside either cell and select Plot Properties. The Plot Properties dialog box appears.

2 In the Plots tab, select DENSITY from the Plot list box.

3 Select an orange color from the Color list box.

4 Click OK.

Add an Arrow Annotation to One of the Cells

You can annotate an individual cell in a multi-cell graph. In this step, you draw a green arrow in one of the cells.

To draw an arrow:

1 Click the arrow icon in the Graph toolbar.

2 Position your cursor at a starting position in the graph and drag the arrow toward a data point of interest.

3 Right-click the arrow and select Annotation Properties. The Annotation Properties dialog box appears.

4 In the Appearance tab, select the green color from the Color list box.

5 Click OK.
Results of Your Changes

Your changes look similar to the following:

Figure 17.2 Modified Classification Panel

Modifying Individual Plots in a Diagnostic Panel

About the Fitness Example

This example analyzes the resting and active pulse rates for participants in a physical fitness study. As part of the study, individuals of various ages and weights run for a variable amount of time, and their pulse rates are measured before and after the run. The code uses the REG procedure to create a graph with paneled diagnostic plots. The running time (RUNTIME) is a response variable in the study.


**Code for the Fitness Example**

SAS/STAT must be installed on the system in order to successfully run this code.

```sas
ods listing sge=on;

data fitness;
    input age weight oxy runtime rstpulse runpulse maxpulse;
    datalines;
44  89.47  44.609 11.37 62 178 182
40  75.07  45.313 10.07 62 185 185
44  85.84  54.297  8.65 45 156 168
42  68.15  59.571  8.17 40 166 172
38  89.02  49.874  9.22 55 178 180
47  77.45  44.811 11.63 58 176 176
```

---

**Figure 17.3  Fitness Example**
Modify the Fitness Example

Change the Graph's Title

By default, the graph's title contains the RUNTIME variable. Change the graph's title to make it more meaningful.
Double-click the title (Fit Diagnostics for runtime).

Select all of the text and enter the new title *Model Fit Diagnostics for Regression Analysis of Running Time*.

**Change the Axis Label for a Cell**

In this example, each cell has its own set of axis labels.

To change an axis label:

1. Double-click the Y axis label for the middle cell. (The label contains the text *runtime*.) A box appears around the text.

2. Change *runtime* to **Run Time** with a capital R and T.

**Change the Color of a Plot**

For the type of graph used in this example, you can modify plot properties separately for each cell.

To change plot properties:

1. Right-click inside the middle cell and select **Plot Properties**. The Plot Properties dialog box appears.

2. On the **Plots** tab, select *lineparm2* from the **Plot** list box.

3. Select a blue color from the **Color** list box.

4. Click **OK**. The diagonal plot in the middle cell becomes blue.

**Change the Graph's Background Color**

To change the graph's background color:

1. Right-click the graph and select **Graph Properties**. The Graph Properties dialog box appears.

2. Select a gray color from the **Fill** list box.

3. Click **OK**.
Results of Your Changes

The revised example is shown here:

**Figure 17.4  Modified Fitness Example**
Editing and Annotating a SAS/STAT Graph by Example

About the Economy Growth Example ............................................. 176

Code for the Economy Example .................................................. 177

Editing the Graph ................................................................. 179
  Change the Graph's Title ...................................................... 179
  Add a Footnote to the Graph .................................................. 179
  Move the Legend .............................................................. 179
  Change the Line Pattern ........................................................ 180

Adding Annotations to Highlight Outlier Data ............................. 181
  Add an Oval to the Outlier .................................................... 181
  Change the Color of the Oval ................................................ 181
  Draw an Arrow That Points to the Outlier ................................ 182
  Add Text to the Arrow .......................................................... 183

Preparing the Graph for Presentation ......................................... 183
  Change the Graph's Style ...................................................... 183
  Change the Size of the Graph ................................................ 184

Viewing and Saving the Results of Your Changes ....................... 185
  Results of Your Changes to the Graph .................................... 185
  Save Your Changes ............................................................ 186
About the Economy Growth Example

The Economy Growth example uses the Distance by Distance graph, which is generated using the ROBUSTREG procedure. The main purpose of robust regression is to detect outliers and leverage points and to provide stable results in the presence of such influential points.

This graph identifies leverage points for economic growth data for different countries. The distances displayed are appropriately scaled. They measure the distance from the center of the data to the observation. The vertical axis distance is a robust version of the classical distance measure on the horizontal axis. Observations with large discrepancies between these two distances have high leverage. The diagonal reference line helps identify these observations. Such observations also have large ROBUST MCD distance; those observations that are above the horizontal leverage cutoff line are considered leverage points.
The data used in this example was obtained from a national growth study conducted by De Long and Summers in 1991. 1

Code for the Economy Example

SAS/STAT must be installed on the system in order to successfully run this code.

data growth;
  input country$ GDP LFG EQP NEQ GAP @@;
datalines;
  Argentin  0.0089 0.0118 0.0214 0.2286 0.6079
  Austria   0.0332 0.0014 0.0991 0.1349 0.5809
  Belgium   0.0256 0.0061 0.0684 0.1653 0.4109
  Bolivia   0.0124 0.0209 0.0167 0.1133 0.8634
  Botswana  0.0676 0.0239 0.1310 0.1490 0.9474
  Brazil    0.0437 0.0306 0.0646 0.1588 0.8498
  Cameroon  0.0458 0.0169 0.0415 0.0885 0.9333
  Canada    0.0169 0.0261 0.0771 0.1529 0.1783
  Chile     0.0021 0.0216 0.0154 0.2846 0.5402
  Colombia  0.0239 0.0266 0.0229 0.1553 0.7695
  CostaRic  0.0121 0.0354 0.0433 0.1067 0.7043
  Denmark   0.0187 0.0115 0.0688 0.1834 0.4079
  Dominica  0.0199 0.0280 0.0321 0.1379 0.8293
  Ecuador   0.0283 0.0274 0.0303 0.2097 0.8205
  ElSalvad  0.0046 0.0316 0.0223 0.0577 0.8414
  Ethiopia  0.0094 0.0206 0.0212 0.0288 0.9805
  Finland   0.0301 0.0083 0.1206 0.2494 0.5589
  France    0.0292 0.0089 0.0879 0.1767 0.4708
  Germany   0.0259 0.0047 0.0890 0.1885 0.4585
  Greece    0.0446 0.0044 0.0655 0.2245 0.7924
  Guatemala 0.0149 0.0242 0.0384 0.0516 0.7885
  Honduras  0.0148 0.0303 0.0446 0.0954 0.8850
  HongKong  0.0484 0.0359 0.0767 0.1233 0.7471
  India     0.0115 0.0170 0.0278 0.1448 0.9356
  Indonesi  0.0345 0.0213 0.0221 0.1179 0.9243
  Ireland   0.0288 0.0081 0.0814 0.1879 0.6457
  Israel    0.0452 0.0305 0.1112 0.1788 0.6816
  Italy     0.0362 0.0038 0.0683 0.1790 0.5441
  IvoryCoa  0.0278 0.0274 0.0243 0.0957 0.9207
  Jamaica  0.0055 0.0201 0.0609 0.1455 0.8229
  Japan     0.0535 0.0117 0.1223 0.2464 0.7484

<table>
<thead>
<tr>
<th>Country</th>
<th>0.0646</th>
<th>0.0346</th>
<th>0.0462</th>
<th>0.1268</th>
<th>0.9415</th>
</tr>
</thead>
<tbody>
<tr>
<td>Korea</td>
<td>0.0479</td>
<td>0.0282</td>
<td>0.0557</td>
<td>0.1842</td>
<td>0.8807</td>
</tr>
<tr>
<td>Luxembourg</td>
<td>0.0236</td>
<td>0.0064</td>
<td>0.0711</td>
<td>0.1944</td>
<td>0.2863</td>
</tr>
<tr>
<td>Madagascar</td>
<td>-0.0102</td>
<td>0.0203</td>
<td>0.0219</td>
<td>0.0481</td>
<td>0.9217</td>
</tr>
<tr>
<td>Malawi</td>
<td>0.0153</td>
<td>0.0226</td>
<td>0.0361</td>
<td>0.0935</td>
<td>0.9628</td>
</tr>
<tr>
<td>Malaysia</td>
<td>0.0332</td>
<td>0.0316</td>
<td>0.0446</td>
<td>0.1878</td>
<td>0.7853</td>
</tr>
<tr>
<td>Mali</td>
<td>0.0044</td>
<td>0.0184</td>
<td>0.0433</td>
<td>0.0267</td>
<td>0.9478</td>
</tr>
<tr>
<td>Mexico</td>
<td>0.0198</td>
<td>0.0349</td>
<td>0.0273</td>
<td>0.1687</td>
<td>0.5921</td>
</tr>
<tr>
<td>Morocco</td>
<td>0.0243</td>
<td>0.0281</td>
<td>0.0260</td>
<td>0.0540</td>
<td>0.8405</td>
</tr>
<tr>
<td>Netherlands</td>
<td>0.0231</td>
<td>0.0146</td>
<td>0.0778</td>
<td>0.1781</td>
<td>0.3605</td>
</tr>
<tr>
<td>Nigeria</td>
<td>-0.0047</td>
<td>0.0283</td>
<td>0.0358</td>
<td>0.0842</td>
<td>0.8579</td>
</tr>
<tr>
<td>Norway</td>
<td>0.0260</td>
<td>0.0150</td>
<td>0.0701</td>
<td>0.2199</td>
<td>0.3755</td>
</tr>
<tr>
<td>Pakistan</td>
<td>0.0295</td>
<td>0.0258</td>
<td>0.0263</td>
<td>0.0880</td>
<td>0.9180</td>
</tr>
<tr>
<td>Panama</td>
<td>0.0295</td>
<td>0.0279</td>
<td>0.0388</td>
<td>0.2212</td>
<td>0.8015</td>
</tr>
<tr>
<td>Paraguay</td>
<td>0.0261</td>
<td>0.0299</td>
<td>0.0189</td>
<td>0.1011</td>
<td>0.8458</td>
</tr>
<tr>
<td>Peru</td>
<td>0.0107</td>
<td>0.0271</td>
<td>0.0267</td>
<td>0.0933</td>
<td>0.7406</td>
</tr>
<tr>
<td>Philippines</td>
<td>0.0179</td>
<td>0.0253</td>
<td>0.0445</td>
<td>0.0974</td>
<td>0.8747</td>
</tr>
<tr>
<td>Portugal</td>
<td>0.0318</td>
<td>0.0118</td>
<td>0.0729</td>
<td>0.1571</td>
<td>0.8033</td>
</tr>
<tr>
<td>Senegal</td>
<td>-0.0011</td>
<td>0.0274</td>
<td>0.0193</td>
<td>0.0807</td>
<td>0.8884</td>
</tr>
<tr>
<td>Spain</td>
<td>0.0373</td>
<td>0.0069</td>
<td>0.0397</td>
<td>0.1305</td>
<td>0.6613</td>
</tr>
<tr>
<td>Sri Lanka</td>
<td>0.0137</td>
<td>0.0207</td>
<td>0.0138</td>
<td>0.1352</td>
<td>0.8555</td>
</tr>
<tr>
<td>Tanzania</td>
<td>0.0184</td>
<td>0.0276</td>
<td>0.0860</td>
<td>0.0940</td>
<td>0.9762</td>
</tr>
<tr>
<td>Thailand</td>
<td>0.0341</td>
<td>0.0278</td>
<td>0.0395</td>
<td>0.1412</td>
<td>0.9174</td>
</tr>
<tr>
<td>Tunisia</td>
<td>0.0279</td>
<td>0.0256</td>
<td>0.0428</td>
<td>0.0972</td>
<td>0.7838</td>
</tr>
<tr>
<td>U.K.</td>
<td>0.0189</td>
<td>0.0048</td>
<td>0.0694</td>
<td>0.1132</td>
<td>0.4307</td>
</tr>
<tr>
<td>U.S.</td>
<td>0.0133</td>
<td>0.0189</td>
<td>0.0762</td>
<td>0.1356</td>
<td>0.0000</td>
</tr>
<tr>
<td>Uruguay</td>
<td>0.0041</td>
<td>0.0052</td>
<td>0.0155</td>
<td>0.1154</td>
<td>0.5782</td>
</tr>
<tr>
<td>Venezuela</td>
<td>0.0120</td>
<td>0.0378</td>
<td>0.0340</td>
<td>0.0760</td>
<td>0.4974</td>
</tr>
<tr>
<td>Zambia</td>
<td>-0.0110</td>
<td>0.0275</td>
<td>0.0702</td>
<td>0.2012</td>
<td>0.8695</td>
</tr>
<tr>
<td>Zimbabwe</td>
<td>0.0110</td>
<td>0.0309</td>
<td>0.0843</td>
<td>0.1257</td>
<td>0.8875</td>
</tr>
</tbody>
</table>

ods listing sge=on;
ods select "Distance by Distance";

    proc robustreg data=growth plot=all method=lts;
       model GDP = LFG GAP EQP NEQ / diagnostics(all);
    run;
ods listing close;
title;
Editing the Graph

Change the Graph's Title

Change the graph's title to make it more meaningful to your target audience.

1. Double-click the title (Leverage Diagnostics).
2. Select all of the text and enter the new title Analysis of Economy Growth.

Add a Footnote to the Graph

Add a footnote that shows the respective year for the data.

1. Click the footnote icon in the Graph toolbar. A text box appears at the bottom of the graph and displays the highlighted text Insert Footnote.

Move the Legend

Once the footnote has been added, the bottom of the graph looks crowded. Because there is ample space available inside the plot area, move the legend into the plot in the lower right corner.

1. Right-click the legend and select Legend Properties from the pop-up menu. The Legend Properties dialog box appears.
2 Select the **Inside Plot Area** button.

3 Select **Bottom Right** from the list box.

4 Click **OK**. The legend appears within the plot area.

Data source: De Long and Summers (1991)

**Change the Line Pattern**

Change the horizontal reference line so that it is a dashed line.

1 Right-click the line and select **Plot Properties** from the pop-up menu.
2 Select the **Plots** tab if it is not already selected.

3 Make sure that **ReferenceLine1** is selected in the **Plot** list box.

4 From the **Pattern** list box, select the third pattern (dashed line) in the list. The reference line changes to a dashed pattern.

5 Click **OK**.

---

**Adding Annotations to Highlight Outlier Data**

The observation in the middle of the plot denoted by a red plus sign is an outlier. You can label it with the name of the country that it represents in order draw attention to the outlier. To do this, use the oval and arrow annotation tools in the Graph toolbar.

**Add an Oval to the Outlier**

To add an oval:

1 Select the oval icon in the Graph toolbar.

2 Press Ctrl, click the observation, and drag the cursor to create an oval around the observation. Click and drag the circles along the border of the oval to change the size of the annotation.

**Change the Color of the Oval**

Change the color of the oval in order to make the oval stand out from the rest of the graph.
1 Right-click the circle and select **Annotation Properties** from the pop-up menu. The Annotation Properties dialog box appears.

2 In the **Outline** area of the dialog box, select the red color from the **Color** list box.

3 Click **OK**.

**Draw an Arrow That Points to the Outlier**

To draw an arrow:

1 Click the arrow icon in the Graph toolbar.

2 Position your cursor at a starting position in the graph and drag the arrow toward the circle annotation.
Add Text to the Arrow

To add text to the arrow:

1. Right-click the arrow and select Add (‘Edit’) Text from the pop-up menu. A text box appears at the tail end of the arrow.

2. In the text box, type Zambia.

3. Right-click the arrow and select Annotation Properties. The Annotation Properties dialog box appears.

4. On the Text tab, select the red color from the Color list box. Then click OK. The annotations all display in red.

Preparing the Graph for Presentation

Change the Graph's Style

Change the style that is applied to the graph in order to make the graph more suitable for printing with a black-and-white printer. Select Format ▶ Style ▶ Journal from the main menu.

Note: When you apply the Journal style, all of the objects in the graph change to shades of gray. However, the annotations (oval and arrow) are red because you explicitly set their color.
Change the Size of the Graph

To change the size:

1. Right-click the graph and select **Graph Properties**. The Graph Properties dialog box appears.

2. Change the width of the graph to 6. **Keep Aspect Ratio** is currently selected. Changing the width to 6 also changes the height to 4.5 to maintain the current aspect ratio.

3. Click **OK**.
Viewing and Saving the Results of Your Changes

Results of Your Changes to the Graph

Here are the results of the changes that you made to the graph.

Because you have applied the Journal style, all of the objects in the graph are in shades of gray. However, the annotations (oval and arrow) are red because you explicitly set their color. If you want the annotation color to be consistent with the style’s colors, you can restore the annotations to their default color.

For a description of the graph, see “About the Economy Growth Example” on page 176.
Save Your Changes

To save the changes that you made to the graph:

1. Select **File ▶️ Save As** from the main menu.

2. Specify the directory, filename, and file type. For more information, see “Save Graph Output” on page 17.
annotation
a label, marker, or note that is not obtained from the data but is placed on a graph independently. Such annotations might or might not be linked to data values in the plot.

cell
a distinct rectangular subregion of a graph that can contain plots, text, or legends.

class variable
See classification variable

classification panel
a multi-cell graph in which the cell data is driven by the values of one or more classification variables. The number of the cells is determined by the unique values of the classification variables. Each cell of the panel has the same types of plots.

classification variable
a variable whose values are used to classify the observations in a data set into different groups that are meaningful for analysis. A classification variable can have either character or numeric values. Classification variables include group, subgroup, category, and BY variables.

graph panel
a graph with multiple cells.

Graph Template Language
an extension to the Output Delivery System (ODS) that enables users to create sophisticated analytical graphs.
GTL
See Graph Template Language

locale
a setting that reflects the language, local conventions, and culture for a geographic region. Local conventions can include specific formatting rules for paper sizes, dates, times, and numbers, and a currency symbol for the country or region. Some examples of locale values are French_Canada, Portuguese_Brazil, and Chinese_Singapore.

marker
a symbol such as a diamond, a circle, or a triangle that is used to indicate the location of, or annotate, a data point in a plot or graph.

ODS
See Output Delivery System

ODS Graphics
an extension to ODS that is used to create analytical graphs using the Graph Template Language.

outlier
a data point that differs from the general trend of the data by more than is expected by chance alone. An outlier might be an erroneous data point or one that is not from the same sampling model as the rest of the data.

Output Delivery System
a component of SAS software that can produce output in a variety of formats such as markup languages (HTML, XML), PDF, listing, RTF, PostScript, and SAS data sets.

plot
a visual representation of data such as a scatter plot, needle plot, or contour plot.
SGE file

A file created in the ODS Graphics environment that contains an editable graph. Such files have a .sge file extension and can be edited only with the ODS Graphics Editor. You can edit SGE files from the SAS Results window or by opening the SGE file from within the ODS Graphics Editor.
Index

A

about ODS Graphics Editor 4
aligning annotations 144
alternate short text 42
annotating graphs
  add text to objects 131
  align objects 144
  annotation concepts 94
change data attachment
  properties 108
copy and paste objects 142
delete objects 142
group objects 143
GTL annotations 7
images 121
lines and arrows 115
markers 120
move objects 141
order objects in layers 143
ovals (and circles) 118
rectangles (and squares) 118
resize objects 135
rotate objects 139
text annotations 113
annotation concepts 94
annotation objects 93
arrows 115
attribute priority

changing 28
overview 31
axis labels 60
grid lines 59
turn on and off 59

C

cell 6
circles
  See ovals
color, changing
data 51
  graph background 27
  plot background 51
colors, specifying 37
components of a graph 6
concepts
  annotation 94
  editing 7
copy and paste
  annotation object 142
  graph 18

data attachment
change properties 108
corcepts 94
data labels, show or hide 65
delete an annotation 142

edit a graph 13
editable graphs 11
editing concepts 7
editing graphs
  change attribute priority 28
  change background color 27
  change group attributes 28
  plot properties 49
  resetting the view of a graph 86
  resize a graph 25
  resizing the view of a graph 86
  show or hide data labels 65
  specify a style 23
  working with axis labels 60
  working with footnotes 33
  working with legends 43
  working with nodes and links 72
  working with titles 33

features of the editor 5
file types that can be edited 5
footnotes 33
Formatting toolbar 36

graph components 6
Graph Template Language (GTL) 4
Graph toolbar 15
graphics
  See images
grid lines 59
group attributes, changing 28
  grouping annotations 143

images 121
Interaction with SAS Viya 3

labels on data points
  show or hide 65
legends 43
lines 115
link breakpoints
  deleting 78
  inserting 77
links, working with 72
locale setting 8
M

markers 120
move an annotation 141
multi-cell graphs 66

N

node links
  changing curvature 79
  realigning 73
  realigning self-links 80
  nodes, working with 72

O

open a graph 13
order of annotations 143
ovals 118

P

plot area 6
plot properties 49
PNG files 5
print a graph 18
properties of a plot 49

R

realign a node link 73
rectangles 118
reset a graph view 86
resize
  annotation 135
  graph 25
resize a graph view 86
rotate an annotation 139

S

save a graph 17
SGE files 5
SGRENDER procedure 17
short text 42
size
  reset a graph view 86
  resize a graph 25
  resize a graph view 86
  resize an annotation 135
  size of an annotation 135
squares
  See rectangles
stand-alone editor
  downloading 10
  using 11
start the editor 13
style of a graph 23

T

text annotations 113
text, add to annotations 131
titles 33
toolbar, Formatting 36
toolbar, Graph 15

view of a graph

adjusting 85
viewport space
adjusting the graph size within 85
Gain Greater Insight into Your SAS® Software with SAS Books.

Discover all that you need on your journey to knowledge and empowerment.

support.sas.com/bookstore for additional books and resources.