# Contents

*What's New in SAS BI Dashboard 4.41* ......................................................... v

**Chapter 1 • SAS BI Dashboard Viewers** ......................................................... 1
  - Viewer Support for SAS BI Dashboard .................................................. 1
  - Viewer Feature Comparison ............................................................... 1

**Chapter 2 • Dashboard Viewer** ................................................................. 3
  - Overview ............................................................................................... 3
  - Access the SAS BI Dashboard Viewer .................................................. 4
  - Open a Dashboard or Indicator ............................................................. 4
  - Clear the Default Dashboard View Setting ........................................... 5
  - Navigate among Multiple Dashboards or Indicators ............................. 5
  - Working with Favorites ........................................................................ 6
  - Printing a Dashboard or Indicator ......................................................... 9
  - Creating Comments and Replying ......................................................... 9
  - Refresh the Viewer Contents ............................................................... 12
  - Set the Automatic Refresh Interval ...................................................... 12
  - Exceptions in SAS BI Dashboard 4.41 Viewer ....................................... 13

**Chapter 3 • Dashboard Portlet** ................................................................. 15
  - Setting Up a SAS BI Dashboard Portlet ............................................... 15
  - Working in the SAS BI Dashboard Portlet .......................................... 20
What's New in SAS BI Dashboard 4.41

**Important:** SAS BI Dashboard 4.41 designer has been discontinued. Users can continue to view existing dashboards and indicators that were created in SAS BI Dashboard designer with the SAS BI Dashboard 4.41 viewer or SAS BI Dashboard 4.41 portlets.

The SAS BI Dashboard 4.41 viewer user interface has been rewritten in HTML5. In addition, SAS BI Dashboard 4.41 portlets can be seen in SAS Information Delivery Portal 4.4, which has also been rewritten in HTML5.

Adobe announced that it intends to end support for Flash technology and will cease to update and distribute the Flash Player at the end of 2020. Browser vendors will disable Flash by default in 2019. For more information about Adobe Flash end-of-life, see SAS Software and Its Use of the Adobe Flash Player.

In addition, Internet Explorer 11 is not a supported browser for SAS BI Dashboard 4.41.

For specific information about SAS BI Dashboard 4.41 viewer, see “Exceptions in SAS BI Dashboard 4.41 Viewer” on page 13.
Chapter 1
SAS BI Dashboard Viewers

Viewer Support for SAS BI Dashboard

SAS BI Dashboard provides dashboard viewer support in the following ways:
• the SAS BI Dashboard viewer, part of the SAS BI Dashboard web application
• a SAS BI Dashboard portlet, defined in the SAS Information Delivery Portal

Viewer Feature Comparison

The following table details the feature support in each viewer.

Note: An X indicates support.

<table>
<thead>
<tr>
<th>Features</th>
<th>Dashboard Viewers</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Viewer</td>
</tr>
<tr>
<td>Viewing dashboards or indicators</td>
<td>X</td>
</tr>
<tr>
<td>Default dashboard setting</td>
<td></td>
</tr>
<tr>
<td>Note: The Information Delivery</td>
<td></td>
</tr>
<tr>
<td>Portal provides a similar feature for the portlet.</td>
<td></td>
</tr>
<tr>
<td>Navigation among dashboards or</td>
<td>X</td>
</tr>
<tr>
<td>indicators</td>
<td></td>
</tr>
<tr>
<td>Client caching to reduce response times and resource demands</td>
<td>X</td>
</tr>
</tbody>
</table>
## Chapter 1 • SAS BI Dashboard Viewers

<table>
<thead>
<tr>
<th>Features</th>
<th>Dashboard Viewers</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Viewer</td>
</tr>
<tr>
<td>Manual refresh</td>
<td>X</td>
</tr>
<tr>
<td>Automatic refresh</td>
<td>X</td>
</tr>
<tr>
<td>Zoom</td>
<td>X</td>
</tr>
<tr>
<td>Print</td>
<td>X</td>
</tr>
<tr>
<td>Personal indicator alerts</td>
<td>X</td>
</tr>
<tr>
<td>Comments</td>
<td>X</td>
</tr>
<tr>
<td>Favorites</td>
<td>X</td>
</tr>
</tbody>
</table>
Chapter 2
Dashboard Viewer

Overview

The dashboard viewer provides the same functionality as the SAS BI Dashboard portlet, as well as enabling you to perform the following tasks:

- set dashboards and indicators as favorites
- make comments about indicators
- view dashboards and indicators in a larger display area
Access the SAS BI Dashboard Viewer

You can access the SAS BI Dashboard viewer by entering the following web address in your web browser: http://server:port/SASBIDashboard:

server:port is the web address of your SAS BI Dashboard server.

Note: The port and the default root directory for SAS BI Dashboard are set during the installation of the product. The web address used by your organization might vary.

Open a Dashboard or Indicator

To open a dashboard or indicator, click ✽ on the toolbar. From the menu, select Open. A file selection window appears.

You can select a dashboard or an indicator. Dashboard files use the DCX file extension and indicator files use the IDX file extension.

Use the Type: menu to narrow your search of either dashboards or indicators. You can also use the Search field to search for specific dashboards or indicators. Navigate to the dashboard or indicator that you want to open, click on the file, and select Open. The indicator or dashboard appears in the workspace.

You can also expand the view of an individual indicator. After you have opened a dashboard or indicator, place your mouse pointer over an indicator and select ✩. The indicator is expanded. To return the indicator to the original view, place your mouse pointer over the expanded indicator and select ✩.
Clear the Default Dashboard View Setting

By default, the SAS BI Dashboard viewer displays the last dashboard or indicator that was displayed when the SAS BI Dashboard viewer was closed. However, there might be times when you do not want to display this dashboard or indicator.

To display no dashboard or indicator when you first start the SAS BI Dashboard viewer, click View ⇒ Open the Previously Viewed Dashboard by Default to clear the default view setting.

Navigate among Multiple Dashboards or Indicators

In the SAS BI Dashboard v, you can open and display multiple dashboards and indicators. After you open a second dashboard or indicator, the navigation controls appear below the menu bar.

You can scroll through the different dashboards or indicators by clicking ◀ or ▶. You can also click ▼ to go to a specific dashboard or indicator.

Dashboard navigation is also available when you click View ⇒ Go To.
The navigation controls enable you to move backward and forward through the dashboards and indicators that you have opened. You can also select from the list of available dashboards and indicators.

Working with Favorites

Overview

To easily bookmark and return to a dashboard or an indicator, you can add it to your favorites. On the toolbar, select Favorites (🌟). The Favorites menu opens.

Add a Dashboard to Your Favorites

To add a dashboard to your favorites, click Favorites ⇒ Add Dashboard to Favorites. This dashboard now appears in the Favorites menu and selecting Add to Favorites.

Add a Dashboard with Parameters to Your Favorites

As of the second maintenance release of SAS BI Dashboard 4.31, when you save a dashboard as a favorite, you can choose to save the dashboard with its currently selected parameters. If you view a sales chart, for example, you might select a specific year and geographic location to modify your data view. You can save the dashboard with the selected year and geographic settings.

To add a dashboard with parameters to your favorites, click Favorites ⇒ Add Dashboard to Favorites (with parameters). This dashboard now appears in the Favorites menu. The parameters saved with the dashboard appear in parentheses after the dashboard name.

Add an Indicator to Your Favorites

To add an indicator to your favorites, click Favorites ⇒ Add Indicator to Favorites ⇒ <Name of indicator>. This indicator now appears in the Favorites menu. You can also add an indicator to your favorites by placing your mouse pointer over an indicator and clicking ✲. Then select Add to Favorites. Here is the menu when opened from an indicator:
Select a Favorite

To select a favorite, click **Favorites ➜ <Name of favorite>**. The selected favorite appears in the viewer. If you already have a dashboard or indicator displayed in the viewer, the favorite appears over that content.

Managing Favorites

To organize your favorites, click **Favorites ➜ Manage Favorites**. The Manage Favorites window appears.

A list of dashboards and indicators that have been added as favorites is displayed. You can manage and organize your favorites in the following ways:

- To create a folder in your favorites, click **New Folder**. A folder is added to the favorites list.
You can now rename the folder. Double-click on the folder and enter a new name.

- To reorder a favorite or folder, click and drag the item to a new position in the list.
- To move an item to a folder, click and drag the item into the folder. Once an item has been added to a folder, an arrow appears beside the folder. You can also move an item out of a folder by dragging the item.
- To rename a favorite or folder, double click the item's name, and then enter the new name.
- To delete a favorite or folder, click the item's name, and then click □.
Printing a Dashboard or Indicator

In the SAS BI Dashboard viewer, you can print an entire dashboard or a single indicator.

- To print a dashboard, click ‌ on the toolbar. From the menu, select Print. The Print window appears with all indicators in the dashboard visible in the print preview.
- To print an indicator, place your mouse pointer over an indicator and click ‌. Then select Print Indicator. The Print window appears with the indicator visible in the print preview.

Creating Comments and Replying

Overview

You and other users that have access to an indicator can make comments about that indicator. Using comments, you can communicate among your coworkers and improve productivity. An indicator can have multiple topics of conversation and each topic can be an extended conversation of comments and replies. If a conversation is extensive, you can sort, filter, and search the comments.

To access indicator comments, place your mouse pointer over an indicator and click ‌. Select Manage Comments. The Manage Comments window appears.

View and Create Comments

To make a new comment, complete the following steps:
1. Open the Manage Comments window. Click in the **New Topic** field to name a new topic.

2. In the comment field that appears, enter a comment.

3. (Optional) Click 📄 to attach a file to the comment. On the file window that opens, select one or more files to attach. In this figure, a comment is created and an attachment is added.

To remove the attachment from the comment, click 🗑️.

4. Click **Post** to save and post your comment. When you post a comment, it is added to a topic thread of comments about that indicator. After you post a comment, other users can respond. Their comments are also added to the topic thread of comments.
Respond to a Comment

You can also respond to a comment for an indicator. To respond to a comment, complete the following steps:

1. Open the Manage Comments window.
2. Expand the topic thread of comments.
3. Locate the comment that you want to reply to and click in the Respond field.
4. Enter a comment and click Post. The comment is added to the thread of comments.
5. (Optional) Click @ to attach a file to the comment. On the file window that opens, select one or more files to attach.

Note: To remove the attachment from the comment, click 🗑️.
**Edit an Existing Comment**

If you are in the Comments Administrator role, you can edit comments. To edit a comment, click 
. Edit the comment and click **Post**.

Business users cannot edit existing comments. For more information, see the SAS 9.4 Middle-Tier Administration Guide and the SAS 9.4 Web Application Administration Guide.

**Delete a Comment**

If you are in the Comments Administrator role, you can delete comments. To delete a comment, click 
. The comment is deleted.

Business users cannot delete comments. For more information, see the SAS 9.4 Middle-Tier Administration Guide and the SAS 9.4 Web Application Administration Guide.

**Search through Comments**

In the Manage Comments window, type one or more characters in the **Search** field. Click 
. Any comments that include the search string appear in a results list.

**Important:** Comments that were created with SAS BI Dashboard viewer, prior to SAS BI Dashboard 4.41 are not automatically available in the 4.41 viewer. To make these comments available in the viewer, a manual step must be performed. See “Exceptions in SAS BI Dashboard 4.41 Viewer” on page 13 for more information.

**Refresh the Viewer Contents**

To refresh the contents of the SAS BI Dashboard viewer, select **File ⇒ Refresh**. The viewer display is updated.

**Set the Automatic Refresh Interval**

To automatically refresh the contents of the SAS BI Dashboard viewer, complete the following steps:

1. Click **View ⇒ Set Automatic Refresh Interval**. The Refresh Interval window appears.
2. Click **Automatic refresh**, and then specify the time interval in the **Interval (in seconds)** field.

3. Click **OK**.

**Important:** If a refresh interval is set, the **File ⇒ Refresh** option is inactive.

**Note:** The automatic refresh feature updates only the underlying data that is used by the indicators on the dashboard. If you change the dashboard by adding, removing, or modifying indicators, these changes are not displayed in the viewer after an automatic refresh. To ensure that dashboard changes are reflected in the viewer, you must manually refresh the viewer.

---

**Exceptions in SAS BI Dashboard 4.41 Viewer**

In SAS BI Dashboard 4.41 viewer, you will notice some differences from previous releases of SAS BI Dashboard viewer that were based on Flash. This is because the SAS BI Dashboard 4.41 viewer is now accessed in HTML5. These differences can include how tables and graphs are displayed and how data is displayed. Here are some specific variances when working with SAS BI Dashboard 4.41 viewer:

- In SAS BI Dashboard 4.41 viewer, dashboards scale to the size of the window. If there are more indicators than available display space in a window, the remaining indicators wrap in the display.

- The column width for spark tables is automatically extended to the longest value in the column.

- When you view charts and graphs in indicators, sorting of labels is now case sensitive.

- When you work with plots or charts in SAS BI Dashboard viewer, you can move interactive lines by selecting and dragging a line.

  **TIP** You must click the line rather than a point in order to drag the line.

- Comments that were created with SAS BI Dashboard viewer prior to SAS BI Dashboard 4.41 are not automatically available in the 4.41 viewer. To make these comments available in the viewer, a manual step must be performed. See [SAS Note 65505](https://support.sas.com/resources/papers/sas note/65505.pdf).

**Important:** Dashboards should be designed without conflicting interactions. If you created a dashboard and you have an indicator that filters multiple sources, the resulting display can be nondeterministic when viewed in SAS BI Dashboard 4.41 viewer.
Chapter 3
Dashboard Portlet

Setting Up a SAS BI Dashboard Portlet

Overview
The SAS BI Dashboard portlet is supported by the following portals:

- SAS Information Delivery Portal
- WebSphere Portal

Before you can access the SAS BI Dashboard portlet, you must log on to the SAS Information Delivery Portal and create a portal page. Then you can add a SAS BI Dashboard portlet in which to view a dashboard.

Log On to the SAS Information Delivery Portal
After you set up a SAS BI Dashboard portlet, you can access the portlet by logging on to your portal. To log on to the SAS Information Delivery Portal, complete the following steps:

1. Open your browser and enter the web address for the portal.

   Note: To obtain the web address, contact your portal administrator.
The Log On page appears.

2. Enter your user name and password.

3. Click **Sign In**. Your personal portal opens. Typically, most portal users see a page that contains a collection portlet (My Collection) and a bookmark portlet (Bookmarks).

![SAS® Portal]

**Create a Page**

To create a new portal page to contain the SAS BI Dashboard portlet, complete the following steps:

1. Click **Customize ⇒ Add Page**. The Add Pages to Profile page appears.

![Add Pages to Profile]

2. On the **Create** tab, type descriptive information about the page:

   **Name**
   is a short name that appears in the page tab in the navigation bar.

   **Description**
   is a short description that appears along with the page title in search results.

   **Keywords**
   are single words that you or other users can use to search for this page. Use spaces to separate keywords from one another.

   **Note**: To ensure efficient searching, develop a list of standard keywords and use these keywords consistently.
Page rank

is a number that indicates the importance of this page as compared to other pages. The default value is 100.

This number determines the order in which pages are listed in the navigation bar. The pages are ordered by rank from lowest to highest. Pages that have equal rank are listed in the order in which they were created.

Location (group)

specifies the group with which to share the page. If you select a value in the Location (group) field, the Share type field appears.

Note: This list appears only if you are a group content administrator or a portal administrator.

TIP

- To share with everyone, select Public from the list. However, sharing a portal page among potentially hundreds or more users can impact performance. To share with a select group of users, consider using the Templates feature. For more information, see the SAS Information Delivery Portal documentation.

- This selection supports sharing with only one group at a time. To share with more than one group, you must have authorization manager capability in SAS Management Console. In SAS Management Console Permissions, expand Authorization Manager ⇒ By Type ⇒ PSPortletPage. Click your new portal page. In the View Properties window, on the Authorization tab, add any users and groups to share. Click OK.

Share type

indicates how the page is shared with users.

Note: This list appears only if you are a group content administrator and have made a selection in the Location (group) list.

This list provides the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Available</td>
<td>Users in the group can find the page using Search. They can add the page if needed.</td>
</tr>
<tr>
<td>Default</td>
<td>Users in the group automatically see the page the next time they log on to the portal. Users can remove the page from the navigation bar if the page is not needed.</td>
</tr>
<tr>
<td>Persistent</td>
<td>Users in the group automatically see the page the next time they log on to the portal. However, users cannot remove the page from the navigation bar.</td>
</tr>
</tbody>
</table>

3. Click Add. A message appears, indicating that a new page was added.

4. Click Done. The new empty page appears in the portal.

Add a SAS BI Dashboard Portlet to the Page

To add a SAS BI Dashboard portlet to a page, complete the following steps:

1. Navigate to the SAS Information Delivery Portal page to which you want to add a portlet.
2. Click **Customize**  ➔  **Edit Page**  ➔  **Edit Page Content**. The Edit Page Content page appears.

![Edit Page Content](image1)

3. Click **Add Portlets**. The Add Portlets to Page page appears.

![Add Portlets to Page](image2)

4. From the **Portlet type** list, select **SAS BI Dashboard Portlet**.
5. Enter the name, description, and keywords, if any.
6. Click **Add**.
7. Click **Done**.
8. On the Edit Page Content page, click **OK**. The new portlet appears on the page displaying the portlet dashboard viewer.
Select a Dashboard

To select a dashboard for viewing, complete the following steps:

1. In the SAS BI Dashboard portlet title bar, click 📚. The Edit Portlet page appears.

2. From the tree, select a dashboard. This list includes dashboards created by your organization. When you select a dashboard, its properties appear below the tree.

   Note: You can select only those dashboards that you are authorized to view.

3. (Optional) You can change the size of the portlet so that it is easier to view on the portal page. Enter the new dimensions in the Dashboard width and Dashboard height fields.

   Note: You cannot edit the Portlet title field.

4. (Optional) You can change how the dashboard is automatically refreshed. For more information, see “Change How a Dashboard Is Automatically Refreshed” on page 21.

5. Click OK. The dashboard appears in the portlet.
Working in the SAS BI Dashboard Portlet

**Change the Size of the Dashboard**

You can change the size of the dashboard to make it easier to view in the portlet. To change the dashboard dimensions, complete the following steps:

1. In the SAS BI Dashboard portlet title bar, click the **Edit Portlet** button. The Edit Portlet page appears.
2. In the **Dashboard width** field, enter the value for the width.
3. In the **Dashboard height** field, enter the value for the height.
4. Click **OK**.

**Navigate between Linked Dashboards**

Navigation controls are available to enable you to move backward and forward through the dashboards that you have opened. The controls include forward and backward arrows for sequential navigation, as well as a history list that records the flow of navigation between dashboards.

In the dashboard portlet, navigation support is available only for dashboards that are linked. The navigation controls are not displayed when the portlet initially loads. However, when you activate a link from one dashboard to another in the portlet, the navigation controls are displayed and can then be used.

**Manually Refresh the Portlet Contents**

To manually refresh the contents of a SAS BI Dashboard portlet, click **Refresh** on the portlet and select **Refresh**.
**Change How a Dashboard Is Automatically Refreshed**

By default, the automatic refresh interval is set to 30 seconds. If this setting causes excessive flashing or slow response time, you might want to increase the interval or turn off automatic refresh.

To change the automatic refresh interval of the portlet contents, complete the following steps:

1. In the SAS BI Dashboard portlet title bar, click \[.] The **Edit Portlet** page appears.
2. To turn off automatic refresh, next to **Auto refresh interval**, clear the **Refresh every** check box.
3. To change the interval, click **Refresh every**, and then enter a value in the field.
4. Click **OK**.

*Note:* The automatic refresh feature updates only the underlying data that is used by the indicators on the dashboard. If you change the dashboard by adding, removing, or modifying indicators, these changes are not displayed in the portlet after an automatic refresh. To ensure that dashboard changes are reflected in the portlet, you must manually refresh the portlet.

**Change the Dashboard Portlet Title**

To change the title of the dashboard portlet, complete the following steps:

1. In the dashboard portlet title bar, click \[.] The **Edit Portlet Properties** page appears.
2. In the **Name** field, enter the new name for the portlet.
3. Click **OK**.

**Print a Dashboard**

To print a dashboard, click \[ on the portlet and select **Print**. The Print window appears.
Viewing a Dashboard in the SAS BI Dashboard Viewer

You can choose to view the dashboard in the SAS BI Dashboard viewer. Switching to the SAS BI Dashboard viewer enables you to use comments, favorites, and personal indicator alerts. The SAS BI Dashboard viewer can also provide more space for viewing a dashboard. To switch to the SAS BI Dashboard viewer, click on the portlet and select Open in Web Viewer.
Gain Greater Insight into Your SAS® Software with SAS Books.

Discover all that you need on your journey to knowledge and empowerment.

support.sas.com/bookstore for additional books and resources.