## Contents

### PART 1  What's New in SAS Cost and Profitability Management 8.4  

1  

**Chapter 1**  •  What's New in SAS Cost and Profitability Management 8.4  
- Introduction  
- Update to Applications to Remove Adobe Flash  
- Updated Third-Party Support  

2  

**PART 2  Getting Started  

5  

**Chapter 2**  •  Logging On  
- Log On Dialog Box  

7  

**Chapter 3**  •  Working in SAS Cost and Profitability Management  
- Introduction  
- Parcel Express Tutorial Model  
- The General Work Flow  
- Model Availability  
- Model Size and Performance  
- Saving and Refreshing Data  
- Sessions and Tasks  
- Shortcut Keys  

16  

**Chapter 4**  •  Navigation Pane  
- What Is the Navigation Pane?  
- How to Access the Navigation Pane  
- Minimize the Navigation Pane  
- Partition the Navigation Pane  

23  

**Chapter 5**  •  Workspace Manager  
- Workspace Manager  
- Item Properties Dialog Box  
- Create Shortcut Dialog Box  
- New Folder Dialog Box  

27  

**Chapter 6**  •  User Capabilities and Groups  
- Overview  
- Capabilities  
- Group Permissions  
- Giving Read or Read/Write Permission to Members of a Group  
- Changing Owners  
- Select User Dialog Box  

35  

**Chapter 7**  •  General Application Tools  
- Manage Tasks Dialog Box  

39
Contents

Chapter 8 • Naming Conventions .................................................. 43
   Naming Conventions ............................................................. 43
   Reference Conventions ....................................................... 48

PART 3   Models  51

Chapter 9 • Model Concepts ....................................................... 53
   Elements of a Model ............................................................ 53
   Guidelines for Creating the Model Structure ............................. 59
   Guidelines for Sharing Models, Configurations, and Data ............. 61

Chapter 10 • Windows for Models ................................................. 65
   Models Workspace ................................................................ 66
   New Model Dialog Box ....................................................... 67
   Change Model or Context Dialog Box ..................................... 67
   Model Properties Dialog Box ............................................... 68
   Model Summary Window ..................................................... 72
   Copy a Model .................................................................... 72
   Model Locking Status Dialog Box ........................................ 73
   Export and Register Tables Dialog Box ................................. 75

Chapter 11 • How To: Models ......................................................... 77
   Create a Model ................................................................... 78
   Open a Model for Editing ................................................... 91
   Open a Model for Viewing ................................................ 91
   Acquire or Release a Lock on a Model ................................. 93
   Delete a Model .................................................................. 94
   Calculate Costs for a Model ................................................ 95
   Change the Properties of a Model ....................................... 95
   Change Model Owner or Give Access to a Model .................. 95
   Review the Summary of a Model ....................................... 96
   Copy a Model ................................................................... 97
   Create a Period/Scenario Association ................................. 98
   Change the Current Period/Scenario Association ................ 98
   Copy Period/Scenario Data ............................................... 98
   Publish a Period/Scenario Association for a Model .............. 99
   Export and Register Tables Containing Model Data .............. 99

PART 4   Currencies  101

Chapter 12 • Working with Currencies ......................................... 103
   Overview ........................................................................... 103
   Windows Currency Settings ................................................ 103
   Exchange Rates .................................................................. 104
   Selecting Currencies for an Exchange Rates Table .............. 104

Chapter 13 • Windows for Currencies .......................................... 105
   Manage Exchange Rates Dialog Box .................................... 105
<table>
<thead>
<tr>
<th>Chapter 14 • How To: Currencies</th>
<th>109</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a Currency</td>
<td>109</td>
</tr>
<tr>
<td>Set up Multiple Currencies</td>
<td>110</td>
</tr>
<tr>
<td>Copy an Exchange Rates Table</td>
<td>110</td>
</tr>
<tr>
<td>Set up an Exchange Rates Table</td>
<td>111</td>
</tr>
<tr>
<td>Add Euro Exchange Rates</td>
<td>112</td>
</tr>
<tr>
<td>Copy an Exchange Rates Table</td>
<td>112</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>PART 5  Periods and Scenarios</th>
<th>113</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chapter 15 • Working with Periods and Scenarios</td>
<td>115</td>
</tr>
<tr>
<td>About Periods and Scenarios</td>
<td>115</td>
</tr>
<tr>
<td>Periods</td>
<td>115</td>
</tr>
<tr>
<td>Period Levels</td>
<td>115</td>
</tr>
<tr>
<td>Scenarios</td>
<td>116</td>
</tr>
<tr>
<td>Scenario Levels</td>
<td>116</td>
</tr>
<tr>
<td>Setting up Periods and Scenarios</td>
<td>116</td>
</tr>
<tr>
<td>Periods and Scenarios in OLAP Analysis</td>
<td>116</td>
</tr>
</tbody>
</table>

| Chapter 16 • Windows for Periods and Scenarios                    | 119 |
| Manage Periods Dialog Box                                         | 120 |
| New Period Dialog Box                                             | 121 |
| Period Properties Dialog Box                                       | 121 |
| Period Level Names Dialog Box                                     | 122 |
| Manage Scenarios Dialog Box                                       | 123 |
| New Scenario Dialog Box                                           | 124 |
| Scenario Properties Dialog Box                                    | 124 |
| Scenario Level Names Dialog Box                                   | 125 |

| Chapter 17 • How To: Periods and Scenarios                        | 127 |
| Create a Period                                                  | 127 |
| Delete a Period                                                  | 129 |
| Manage Period Level Names                                         | 129 |
| Create a Scenario                                                | 130 |
| Delete a Scenario                                                | 131 |
| Manage Scenario Level Names                                       | 131 |

<table>
<thead>
<tr>
<th>PART 6  Period and Scenario Associations</th>
<th>133</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chapter 18 • Working with Period and Scenario Associations</td>
<td>135</td>
</tr>
<tr>
<td>About Period/Scenario Associations</td>
<td>135</td>
</tr>
<tr>
<td>Calculation Status of Associations</td>
<td>135</td>
</tr>
<tr>
<td>Status of Associations</td>
<td>135</td>
</tr>
<tr>
<td>Copying Data from One Association to Another</td>
<td>136</td>
</tr>
</tbody>
</table>

| Chapter 19 • Windows for Period and Scenario Associations         | 137 |
| Period and Scenario Associations View                             | 137 |
| Associate Periods and Scenarios Dialog Box                        | 138 |
Contents

Chapter 20 • How To: Period and Scenario Associations ................................. 143
  Create a Period/Scenario Association .................................................. 143
  Change the Current Period/Scenario Association .................................. 145
  Copy Model Data from One Period/Scenario to Another .......................... 145
  Publish a Period/Scenario Association for a Model .............................. 148
  Change the Properties of a Period/Scenario Association ........................ 149
  Delete a Period/Scenario Association .................................................. 149

PART 7 Modules 151

Chapter 21 • Working with Modules ......................................................... 153
  Introduction to Modules ..................................................................... 153
  Guidelines for Creating Modules ....................................................... 154
  Activity-Based Costing Modules ......................................................... 155

Chapter 22 • Windows for Modules .............................................................. 161
  Module View .................................................................................... 161

Chapter 23 • How To: Modules ................................................................. 163
  Create a Module ............................................................................. 163
  View a Module .............................................................................. 163
  Working in a Module View ............................................................... 164

PART 8 Dimensions 167

Chapter 24 • What Are Dimensions? ......................................................... 169
  Dimensions .................................................................................... 169
  Dimension Levels .......................................................................... 169
  Dimension Members ....................................................................... 170
  Structural Dimensions ................................................................... 173
  Attribute Dimensions ...................................................................... 173
  Guidelines for Creating Dimensions .................................................. 174

Chapter 25 • Windows for Dimensions ....................................................... 179
  Dimensions View ............................................................................ 179
  New Dimension Dialog Box .............................................................. 180
  Edit Dimension Dialog Box .............................................................. 181
  Dimension Properties Dialog Box ...................................................... 182
  New Dimension Member Dialog Box .................................................. 182
  Find Dimension Member Dialog Box ................................................ 183
  Dimension Member Properties Dialog Box .......................................... 184

Chapter 26 • How To: Dimensions .............................................................. 185
  Create a Dimension ....................................................................... 185
  Create a Dimension Member ............................................................ 186
  Create a Dimension Attribute ........................................................... 187
  Reorder Dimension Members ............................................................ 187
  Change the Parent of a Dimension Member ......................................... 189
## PART 9 Accounts 195

### Chapter 27 • What are Accounts? 197
- Introduction .................................................. 197
- Accounts as Dimension-Member Crossings .............. 198
- Rollup Accounts and Module Rollups .................. 202
- Using All Intersections .................................. 202
- Creating and Deleting Accounts ......................... 205
- Guidelines for Creating Accounts ....................... 205

### Chapter 28 • Windows for Accounts 209
- New Account Dialog Box .................................. 209
- Search for Accounts Dialog Box ......................... 211
- Search Account Results Dialog Box ..................... 212
- Item (Account) Properties and Attributes Dialog Box . 213

### Chapter 29 • How To: Accounts 215
- Create Accounts ........................................... 215
- Reorder Accounts ......................................... 219
- Search for Accounts ....................................... 222
- Save Queries for Account Search ....................... 226
- Go to an Account .......................................... 228
- Expand All Levels ......................................... 229

## PART 10 Cost Elements 231

### Chapter 30 • What Are Cost Elements? 233
- Introduction .................................................. 233
- Entered Cost Elements ..................................... 234
- Received Cost Elements .................................... 236

### Chapter 31 • Windows for Cost Elements 237
- New Entered Cost Element Dialog Box ................. 237

### Chapter 32 • How To: Cost Elements 239
- Create an Entered Cost Element ......................... 239
- Delete an Entered Cost Element ......................... 241

## PART 11 Attributes 243

### Chapter 33 • Types of Attributes 245
- Introduction .................................................. 245
- Dimension Attributes, Dimension Member Attributes, and Dimension Value Attributes ...................... 246
- Numeric Attributes ........................................ 247
- Calculated Attributes ..................................... 248
Tag Attributes ................................................................. 248
Text Attributes ................................................................. 249
Stage Attributes ................................................................. 249

Chapter 34 • Attributes on Dimension Members ........................................ 251
   General Description .................................................................. 251
   Attach an Attribute to a Dimension Member .................................. 261
   Remove Attributes from Dimension Members ............................... 265

Chapter 35 • Windows for Attributes .............................................. 269
   Attributes View ..................................................................... 270
   New Attribute Dialog Box .......................................................... 271
   Manage Attributes Dialog Box .................................................... 273
   Attribute Properties Dialog Box .................................................. 274
   Find a Property or Attribute Dialog Box ........................................ 277
   Search for Properties and Attributes Dialog Box ............................ 278
   Attribute Folder Properties Dialog Box ......................................... 278
   New Attribute Folder Dialog Box ................................................ 279

Chapter 36 • How To: Attributes .................................................. 281
   Create an Attribute .................................................................. 281
   Create a Dimension Attribute ..................................................... 284
   Create an Attribute Folder ........................................................ 285
   Add an Attribute to an Account ................................................... 285
   Add an Attribute to a Dimension Member ....................................... 286
   Specify an Attribute's Value ......................................................... 286
   Add Stage Attributes to Accounts ............................................... 287
   Show the Accounts To Which an Attribute Has Been Added .......... 288
   Remove an Attribute from an Account ......................................... 289
   Delete an Attribute .................................................................. 289
   Change the Properties of an Attribute ........................................... 289

PART 12  Column Layouts  .......................................... 291

Chapter 37 • Working with Column Layouts ........................................ 293
   What is a Column Layout? .......................................................... 293
   System Column Layouts ............................................................. 295
   Understanding Properties in a Column Layout ............................... 298

Chapter 38 • Windows for Column Layouts ......................................... 309
   Column Layout Dialog Box ......................................................... 309
   Format Column Dialog Box ......................................................... 311
   Save Column Layout As Dialog Box ............................................. 312

Chapter 39 • How To: Column Layouts ............................................. 313
   Create a Column Layout ............................................................. 313
   Remove a Column ..................................................................... 315
   Order Columns ......................................................................... 316
   Format a Column ....................................................................... 316
   Conditionally Highlight Cells in a Column ....................................... 320
   Select the Period to which the Column Refers ............................... 324
   Save a Column Layout ............................................................... 324
   Apply a Saved Column Layout .................................................... 324
   Specify a Default Column Layout ................................................ 325
Chapter 40 • Introducing Drivers  .................................................. 329
  What Is a Driver? .................................................................. 329
  Guidelines for Creating Drivers ........................................... 331

Chapter 41 • Evenly Assigned Driver  ........................................... 333
  Overview ........................................................................... 333
  System Assigns DQF ............................................................ 333
  Calculate DrvQtyCalc, TDQCalc, and TDQ ............................... 334
  Calculate DrvblCost and DrvRate ........................................ 335
  Calculate DrvDrvnCost ........................................................ 335

Chapter 42 • Percentage Driver .................................................... 337
  Percentage Driver ............................................................... 337
  Example of a Percentage Driver ........................................... 340

Chapter 43 • Standard Driver ........................................................ 341
  What Is a Standard Driver? .................................................. 341
  Examples of a Standard Driver ............................................. 345

Chapter 44 • Calculated Driver ...................................................... 367
  Calculated Driver ............................................................... 367
  Further Information on Calculated Drivers ............................ 370
  Examples of a Calculated Driver ........................................... 371

Chapter 45 • Driver Topics ............................................................. 373
  User-Entered Cost Allocation ................................................ 374
  Fixed Driver Quantities ....................................................... 374
  Variable Driver Quantities ................................................ 375
  Variable Driver Quantities and Fixed Driver Quantities .......... 377
  Driver Weights .................................................................. 378
  Unique and Non-Unique (Shared) Driver Quantities ............... 379
  Driver Sequencing ............................................................... 381
  Idle Quantities .................................................................. 384
  Reciprocal Costing ............................................................. 388

Chapter 46 • Windows for Drivers .................................................. 389
  Drivers View ..................................................................... 389
  New Driver Dialog Box ........................................................ 390
  Driver Properties Dialog Box ............................................... 393

Chapter 47 • How To: Drivers ......................................................... 397
  Create a Driver .................................................................. 397
  Create a Rule-Based Driver ................................................ 398
  Specify the Weights for a Weighted Driver ........................... 398
  Specify the Default Driver .................................................. 398
  Associate a Driver Using an Account's Item Properties .......... 399
  Associate a Driver Using a Module's Grid ................................ 401
  Change the Properties of a Driver ....................................... 402
### PART 14 Assignments 403

#### Chapter 48 • Making Assignments
- What Is an Assignment? 405
- Guidelines for Making Assignments 410
- Make Assignments Using a Rule 410

#### Chapter 49 • Windows for Assignments
- Add Accounts for Assignments Dialog Box 421

#### Chapter 50 • How To: Assignments
- Add an Account for Making an Assignment 423
- Make an Assignment 424
- Make Assignments Using a Rule 427
- Show Assignments Panes 427
- Show Assignments To and From an Account 427
- Delete Assignments 428

### PART 15 Using Formulas with Drivers and Calculated Attributes 429

#### Chapter 51 • Formulas
- Formula 431
- Formula Context 433
- Enhanced Formula Capabilities 439
- Using Numeric Attributes in a Formula 441
- Troubleshooting Formulas 443
- Operator Precedence 444
- Formula Builder Dialog Box 445

#### Chapter 52 • Boolean Functions
- Introduction 449
- HasAttribute function 450
- if function 450
- Intersection.Match function 450
- IsChildOf function 453
- IsClose function 454
- IsNone function 455
- IsNull function 456
- Match function 456

#### Chapter 53 • Numeric Functions
- abs function 459
- degrees function 459
- exp function 460
- max function 460
- min function 460
- pi function 460
- power function 461
- quotient function 461
- radians function 461
- round function 461
- sign function 462
Part 16: Cube Configurations

Chapter 56: What is a Cube Configuration?
Overview ......................................................... 475

Chapter 57: Windows for Cube Configurations
New Cube Configuration ...................................... 477
Metadata Server Options .................................. 478

Chapter 58: How To: Cube Configurations
Create a Cube Configuration ............................... 481
Copy a Cube Configuration to a Different Model ...... 492
Select Dimension Members for Inclusion in Cubes . 493

Part 17: Calculation

Chapter 59: Calculating Costs
Overview ......................................................... 499
Changing the Model Structure after Calculating Costs 499
Period/Scenario Association ................................. 500
Errors ................................................................. 500

Chapter 60: Properties in Calculation
Types of Properties ........................................... 501
Assignment and Account Driver Properties ............. 504
Outgoing Cost .................................................. 508
Incoming Cost .................................................. 510

Chapter 61: Detailed Example of Calculation
Introduction ....................................................... 513
Step 1–User Enters Driver Quantities (DQF, DQV, DWF, DWV, DrvAllocCost) 516
Step 2–DrvQtyCalc for Assignments to Cost Object Accounts 517
Step 3–TDQC for Activity Accounts ........................ 518
Step 4–TDQ for Activity Accounts .......................... 519
Step 5–DrvQtyCalc for Assignments to the Activity Accounts .......................... 520
Step 6–TDQCalc for Resource Account .......................................................... 521
Step 7–TDQ for Resource Account ................................................................. 522
Step 8–AllocCost for Resource Account ......................................................... 523
Step 9–DrvBlCost for Resource Account ......................................................... 524
Step 10–DrvRate for Resource Account ......................................................... 525
Step 11–DrvDrvCost for Assignments to Activity Accounts ......................... 526
Step 12–DrvCost for Assignments to Activity Accounts ............................... 527
Step 13–DrvBlCost for Activity Accounts ...................................................... 528
Step 14–DrvRate for Outgoing Drivers from Activity Accounts .................... 529
Step 15–DrvDrvCost for Assignments to Cost Object Accounts ................... 530
Step 16–DrvCost for Assignments to Cost Object Accounts ......................... 531
Step 17–Cost for Cost Object Accounts ........................................................ 532

Chapter 62 • Windows for Calculation ........................................................... 533
Calculate Costs Dialog Box .............................................................................. 533

PART 18 Generating Cubes 535

Chapter 63 • What is a Cube? ................................................................. 537
Introduction ........................................................................................................ 537
Predefined Cubes ............................................................................................. 539
Using the Cubes with Other Software ............................................................ 541

Chapter 64 • Incremental Cube Generation .............................................. 543
Incremental Cube Generation .......................................................................... 543

Chapter 65 • Windows for Cube Generation ......................................... 547
Generate Cubes .................................................................................................. 547

Chapter 66 • How To: Generating and Managing Cubes ......................... 549
Generate Cubes ................................................................................................. 549
Include Numeric Attributes in a Cube ............................................................. 551
Display the Internal Name of a Cube ............................................................... 551
Delete a Cube or Fact Table ............................................................................ 552
Manage Cube Permissions .............................................................................. 553

PART 19 OLAP Analysis 555

Chapter 67 • Using the Analysis Workspace .......................................... 557
Analysis Workspace ........................................................................................ 557
OLAP Views ...................................................................................................... 558
SAS OLAP Limitations ..................................................................................... 559

Chapter 68 • Analysis Workspace Windows ......................................... 561
OLAP Analyzer ................................................................................................. 561
Save OLAP View As Dialog Box .................................................................... 562
Change Cube Context Dialog Box .................................................................. 563

Chapter 69 • How To: Analysis Workspace ........................................... 565
Use the SAS OLAP Analyzer .......................................................................... 565
Chapter 87 • Publish Period/Scenario Associations for a Model

Chapter 88 • Publish Behaviors to SAS Profitability Management

PART 24 Customizing the Interface

Chapter 89 • User Options

PART 25 Properties Reference

Chapter 90 • Alphabetic List of Properties
<table>
<thead>
<tr>
<th>Content</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Driver Sequence Number (DrvSeq)</td>
<td>730</td>
</tr>
<tr>
<td>Driver Type (DrvType)</td>
<td>731</td>
</tr>
<tr>
<td>Driver Used Cost (DrvUsedCost)</td>
<td>731</td>
</tr>
<tr>
<td>Driver Weight Fixed (DWF)</td>
<td>732</td>
</tr>
<tr>
<td>Driver Weight Variable (DWV)</td>
<td>732</td>
</tr>
<tr>
<td>Entered Cost (EntCost)</td>
<td>733</td>
</tr>
<tr>
<td>Entered Unit Cost (EntUnitCost)</td>
<td>734</td>
</tr>
<tr>
<td>Fixed Driver Quantity Override</td>
<td>734</td>
</tr>
<tr>
<td>Formula</td>
<td>735</td>
</tr>
<tr>
<td>Has Assignments (HasAsgn)</td>
<td>735</td>
</tr>
<tr>
<td>Has Attributes (HasAttr)</td>
<td>736</td>
</tr>
<tr>
<td>Has Entered Cost (HasEntCost)</td>
<td>736</td>
</tr>
<tr>
<td>Has Idle Cost (HasIdlCost)</td>
<td>736</td>
</tr>
<tr>
<td>Has Notes (HasNotes)</td>
<td>737</td>
</tr>
<tr>
<td>Has Used Cost (HasUsedCost)</td>
<td>737</td>
</tr>
<tr>
<td>Idle Cost (IdlCost)</td>
<td>738</td>
</tr>
<tr>
<td>Idle Driver Quantity (IdlDrvQty)</td>
<td>739</td>
</tr>
<tr>
<td>Idle Driver Quantity UE (IdlQtyUE)</td>
<td>739</td>
</tr>
<tr>
<td>Idle Flow Method (IdleFlow)</td>
<td>740</td>
</tr>
<tr>
<td>Idle Percentage (IdlPent)</td>
<td>741</td>
</tr>
<tr>
<td>Idle Quantity (IdlQty)</td>
<td>742</td>
</tr>
<tr>
<td>Intersection Name (IntsctnName)</td>
<td>742</td>
</tr>
<tr>
<td>Intersection Reference (IntsctnRef)</td>
<td>743</td>
</tr>
<tr>
<td>IsBehavior (IsBehavior)</td>
<td>743</td>
</tr>
<tr>
<td>IsReciprocal (IsRecip)</td>
<td>744</td>
</tr>
<tr>
<td>Model Note (ModNote)</td>
<td>744</td>
</tr>
<tr>
<td>Module Order (ModOrdr)</td>
<td>745</td>
</tr>
<tr>
<td>Name (Name)</td>
<td>745</td>
</tr>
<tr>
<td>Output Quantity (OutQty)</td>
<td>746</td>
</tr>
<tr>
<td>Output Quantity UE (OutQtyUE)</td>
<td>746</td>
</tr>
<tr>
<td>Periodic Note (PerNote)</td>
<td>747</td>
</tr>
<tr>
<td>Profit (Profit)</td>
<td>747</td>
</tr>
<tr>
<td>Received Allocated Cost (RcvAllocCost)</td>
<td>748</td>
</tr>
<tr>
<td>Received Cost (RcvCost)</td>
<td>748</td>
</tr>
<tr>
<td>Received Driven Cost (RcvDrvCost)</td>
<td>749</td>
</tr>
<tr>
<td>Received Idle Cost (RcvIdlCost)</td>
<td>749</td>
</tr>
<tr>
<td>Received Non Reciprocal Cost (RcvNRecipCost)</td>
<td>750</td>
</tr>
<tr>
<td>Received Reciprocal Cost (RcvRecipCost)</td>
<td>750</td>
</tr>
<tr>
<td>Received Used Cost (RcvUcost)</td>
<td>751</td>
</tr>
<tr>
<td>Reciprocal Id (RecipId)</td>
<td>751</td>
</tr>
<tr>
<td>Reference (Reference)</td>
<td>752</td>
</tr>
<tr>
<td>Revenue (Revenue)</td>
<td>752</td>
</tr>
<tr>
<td>Sold Cost (SoldCost)</td>
<td>753</td>
</tr>
<tr>
<td>Sold Quantity (SoldQty)</td>
<td>753</td>
</tr>
<tr>
<td>Total Driver Quantity (TDQ)</td>
<td>754</td>
</tr>
<tr>
<td>Total Driver Quantity Basic (TDQBasic)</td>
<td>754</td>
</tr>
<tr>
<td>Total Driver Quantity Calculated (TDQCalc)</td>
<td>755</td>
</tr>
<tr>
<td>Total Driver Quantity UE (TDQUE)</td>
<td>756</td>
</tr>
<tr>
<td>Type (Type)</td>
<td>756</td>
</tr>
<tr>
<td>Unassigned Cost (UnAsgnCost)</td>
<td>757</td>
</tr>
<tr>
<td>Unassigned Quantity (UnAsgnQty)</td>
<td>757</td>
</tr>
<tr>
<td>Unique Driver Quantities (UniqDrvQty)</td>
<td>758</td>
</tr>
<tr>
<td>Unit Cost (UnitCost)</td>
<td>758</td>
</tr>
<tr>
<td>Unit Of Measure (UoM)</td>
<td>759</td>
</tr>
<tr>
<td>Unit Profit (UnitProfit)</td>
<td>759</td>
</tr>
<tr>
<td>Unit Revenue (UnitRevenue)</td>
<td>760</td>
</tr>
</tbody>
</table>
Use Fixed Quantities (UseFixQty) ........................................ 761
Use Variable Quantities (UseVarQty) ................................... 761
Use Weighted Quantities (UseWeightedQty) ........................ 762
Used Cost (UsedCost) ....................................................... 762
Used Quantity (UsedQty) .................................................. 763
User-Entered Cost Allocation ............................................. 763
Variable Driver Quantity Override .................................... 764

Chapter 91 • Property Relationship Diagrams ......................... 767
Cost Flowing Into and Out of an Account (Non-Reciprocal) .......... 768
Cost Flowing Into and Out of an Account (Reciprocal) ............... 770
Assignment Properties ..................................................... 771
Account Driver Properties ............................................... 771
Combined Account Cost Properties .................................... 773
How to Read these Diagrams ............................................ 774

Index ........................................................................ 777
Part 1

What’s New in SAS Cost and Profitability Management 8.4

Chapter 1

What’s New in SAS Cost and Profitability Management 8.4 ........... 3
Chapter 1

What’s New in SAS Cost and Profitability Management 8.4

Introduction

This section is for users of SAS Activity-Based Management. It describes differences between SAS Cost and Profitability Management and SAS Activity-Based Management so that users of the older product know what they need to do differently in SAS Cost and Profitability Management. It also describes changes to existing models that are migrated from SAS Activity-Based Management to SAS Cost and Profitability Management. Users who are new to SAS Cost and Profitability Management who are not migrating from its predecessor product, SAS Activity-Based Management, can skip this section.

SAS Cost and Profitability Management 8.4 has the following new features and enhancements:

• Update to applications using Adobe Flash:
  • “Surveys” on page 4
  • “What-If and Scenario Builder” on page 4
  • “Updated Third-Party Support” on page 4

Update to Applications to Remove Adobe Flash

As Adobe is discontinuing support for Flash player, we are removing applications based on Flash from SAS Cost and Profitability Management.
Surveys

You can create surveys by exporting them to Excel and then send them out. You can import the completed survey data into a SAS Cost and Profitability Management model. You can generate the following surveys:

• Driver Survey
• Attribute Survey
• Entered Cost Element Survey
• Output Quantity Survey

What-If and Scenario Builder

The separate What-If and Scenario Builder Flash application has been removed from the application. This does not affect the ability to do “What-If” analysis and scenario building in the SAS Cost and Profitability Management solution. Users can load multiple periods and scenarios directly into SAS LASR to perform the analysis in SAS Visual Analytics. Use this process to replace the external What-If and Scenario Builder application.

Updated Third-Party Support

SAS Cost and Profitability Management will support more current versions of Red Hat Linux (RHEL) and Java.

• For RHEL 6.X: Up to RHEL 6.10 is tested and supported.
• For RHEL 7.X: Up to RHEL 7.6 is tested and supported.
• JAVA 8 is now supported.
Part 2

Getting Started

Chapter 2
Logging On ................................................................. 7

Chapter 3
Working in SAS Cost and Profitability Management ............... 15

Chapter 4
Navigation Pane .......................................................... 23

Chapter 5
Workspace Manager ....................................................... 27

Chapter 6
User Capabilities and Groups ........................................... 35

Chapter 7
General Application Tools .................................................. 39

Chapter 8
Naming Conventions ....................................................... 43
Chapter 2

Logging On

Log On Dialog Box

Logging On

To log on to the SAS Cost and Profitability Management client:

1. Select Start $\Rightarrow$ SAS $\Rightarrow$ SAS Cost and Profitability Management: 8.4 $\Rightarrow$ SAS Cost and Profitability Management Solution

The log on dialog box opens.

2. Select whether or not to use Integrated Windows Authentication (IWA).

With IWA, you don’t have to specify a user ID and password because you are logged onto SAS Cost and Profitability Management with the same user ID and password that you used to log onto your Windows desktop. See “Enabling Integrated Windows Authentication (IWA)” on page 10.
Use Integrated Windows Authentication

Specify the following:

**SAS Environment**
From the drop-down list, select a SAS Web Infrastructure Platform server. See “Connecting to a SAS Environment” on page 9.

**Metadata Machine**
Specify the metadata server machine to use for authentication.

*Note:* It is not necessary that the metadata server machine be Microsoft Windows. IWA is supported in a Linux environment. The only requirement is that the machine on which the client is running is Windows and the user is logged in to that machine using valid network credentials that correspond to a user account in SAS metadata with SAS Cost and Profitability Management capability.

**Metadata Port**
Specify the port to use for authentication.

Don’t Use Integrated Windows Authentication

Specify the following:
SAS Environment
From the drop-down list, select a SAS Web Infrastructure Platform server. See “Connecting to a SAS Environment” on page 9.

User ID
ID of user registered in SAS Management Console. See “Creating Users” in Chapter 1 of SAS Cost and Profitability Management: Data Administration Guide.

Your SAS Cost and Profitability Management user name and password might or might not be the same as your network user name and password.

• If they are the same, then you can use your user name and password to connect to the SAS environment. If IWA is configured, you can connect directly using the IWA option which does not require you to type a user name or password.

• If they are not the same, then you then must supply the user name as defined in metadata and the password.

Password
Password of the registered user.

Note: If multiple languages are installed on your computer, the language that is used is determined by the location setting in Windows (select Settings ⇒ Control Panel ⇒ Regional and Language Options).

Connecting to a SAS Environment

Overview
When you log on to SAS Cost and Profitability Management, the file sassw.config (whose default installation location is C:\Program Files\SASHome) provides the URL of the file sas-environments.xml. The following picture shows a sample sassw.config file containing the following statement pointing to the location of the file sas-environments.xml.

SASENVIRONMENTSURL=C:\sas\sas-environment.xml

Of course the file sas-environments.xml can reside on another machine. For example:

SASENVIRONMENTSURL=http://rde01011.sas.com:8080/SASLogon/sas-environment.xml

The file, sas-environment.xml, associates each entry in the SAS environment drop-down list of the Log On dialog with the URL of a SAS WIP Server (Web Infrastructure Platform). The WIP Server authenticates your logon information and provides an interface to a SAS Cost and Profitability Management Metadata Server. Because you, as a client user, log on to a WIP Server instead of directly to a SAS Cost and Profitability
Management Metadata Server, the Metadata Server can be changed without affecting
your client log-on procedure.

The following picture displays a sample `sas-environments.xml` file with several
environments defined.

Enabling Integrated Windows Authentication (IWA)

If your metadata server and mid-tier are configured to accept IWA connections, then you
can use Windows authentication for logging on to SAS Cost and Profitability
Management. There are three requirements for Windows authentication:

1. You must be using a network (Active Directory) user ID.
2. You must create a user in SAS Management Console with `domain\user ID`, as shown
   in the following picture. You do not need to put in passwords.
There are two things to consider:

- how the user name appears to the middle tier
- how the user name appears to the object spawner

By default, Tomcat strips the Kerberos realm off the user name so that is how it is seen by the middle tier. On UNIX, the object spawner also strips the realm off the user name in the ticket. So if the server tier is on UNIX, it is sufficient to have a single account in Metadata with no domain or password. For example:

```
myUsername - DefaultAuth
```

On Windows, the object spawner uses the native SSPI API to validate the ticket, and this returns the user name in the form `<domain>\<username>`. So if the server tier is
on Windows, by default you must have two accounts for each user in Metadata. For example:

myUsername - DefaultAuth
myDomain\myUsername - DefaultAuth

3. On the Logical Workspace Server, **Server Access Security** must be set to **Negotiate**.

   Normally, this is done automatically by the SAS Deployment Wizard (SDW) during installation when you select to do an IWA installation. You can verify that it has been done by doing the following:

   a. Open SAS Management Console.
   b. From the **Plug-in** tab, expand **Environment Management** ⇒ **Server Manager** ⇒ **SASApp**.
   c. Right-click **SASApp – Logical Workplace Server** and select **Properties**.
   d. Click the **Options** tab.
   e. For **Server Access Security** verify that **Negotiate** is selected.
   f. Click **OK**.
Note: If your metadata server machine accepts IWA connections (you can log in to SAS Management Console using IWA), then a user can succeed in logging on to the SAS Cost and Profitability Management client even if it was not installed to use IWA—provided that the user has the appropriate SAS Cost and Profitability Management capabilities (see Chapter 1, “User Capabilities and Groups,” in SAS Cost and Profitability Management: Data Administration Guide). If you intend users to log on using IWA, it is recommended that you specify IWA when you install SAS Cost and Profitability Management. For more information on enabling SAS Cost and Profitability Management for IWA, see SAS Cost and Profitability Management 8.4: Installation, Migration, and Configuration Guide.
**Introduction**

By applying direct and indirect business costs to activities, SAS Cost and Profitability Management enables managers to get a true understanding of the costs and profits that are associated with a product, customer, service, or business process.

An activity-based management system identifies activities, associates resources (expenditures) with those activities, and flows the cost of activities to cost objects.

With SAS Cost and Profitability Management, you can analyze business trends, and you can make the results of your analyses available to business professionals throughout your organization. You do not need to know how to program or how to use database tools.
Parcel Express Tutorial Model

You can import an already-completed model for the Parcel Express Tutorial by doing the following:

1. Select File ➔ Import ➔ Model Data.
2. Select XML or ZIP File as the type of data you want to import, and click Next.
3. Navigate to, and select the following file: `<install directory>\x86\SASCostandProfitabilityManagementClient\8.4\Samples\Models\Native\ParcelExpressTutorial.xml`
4. Name the tutorial model. You can name it anything you want and provide a reference value for it. Click Next, review your choices, and then click Finish.

As soon as the import operation summary appears, the tutorial model is imported. You must calculate the model to view calculated data.

The General Work Flow

Overview

By storing model data in a structure that is optimized for analytical purposes, SAS Cost and Profitability Management provides fast and intuitive analysis of broad trends and relationships. SAS Cost and Profitability Management is designed specifically for analyzing data. The following design features enable SAS Cost and Profitability Management to respond rapidly to complex queries that involve large amounts of data:

- Data is stored in a multidimensional data structure.
- Some of the summary calculations are performed before you request them.

Enter Business Data

1. Plan periods and scenarios. Then, set up periods and set up scenarios for each SAS Cost and Profitability Management server.
   
   On each server, all the periods and scenarios are shared across all models. Your organization should determine the period hierarchy that works best for all models. Then, set up periods and scenarios.

2. Create a model or import model data.
3. Calculate costs.
4. Generate OLAP cubes.

Analyze Business Data

- Use OLAP cubes to analyze business data.
**Make Business Analyses Available to Others**

- Set up and save column layouts and OLAP views.
- (Optional) Export OLAP views.

---

**Model Availability**

Sometimes, you might not be able to perform certain tasks in a model. For example, if you attempt to edit a part of the model that someone else is editing, you will not be able to edit.

Other tasks affect model availability, regardless of what type of user you are. These tasks require that the model data be in a stable state for some amount of time. You do not want someone to change the costs of accounts while a cube is being generated. Likewise, when SAS Cost and Profitability Management is calculating a model’s costs, you do not want someone to change an account’s cost. Allowing such a change would cause the final calculated costs to be wrong.

SAS Cost and Profitability Management prevents changes from being made during the following tasks:

- calculating costs
- generating cubes
- exporting data

---

**Model Size and Performance**

The number of accounts, assignments, dimensions, and dimension members within a model determine how long the model is unavailable, as well as how long it takes to perform a task. In a model that has few of these items (a small model), tasks complete faster than in a model that has numerous items (a large model). Model complexity can also affect such tasks as calculation and cube generation. For example, models that make extensive use of driver rules or have very large systems of reciprocal assignments can take longer to calculate. Cube generation for models containing very long assignment paths can take longer than for simpler models.

Model size affects performance when you interact with SAS Cost and Profitability Management (such as when you expand a roll-up account in the Resource module, the Activity module, or the Cost Object module, when you copy period/scenario association data, and when you create an account).
Saving and Refreshing Data

Saving

SAS Cost and Profitability Management enables multiple users to interact with a model that is located on a server. If you are unfamiliar with such an application, there are several differences from a desktop application.

• Unlike a desktop application in which you must explicitly save data, data is saved automatically.
  
  Automatic saving enables all users to see the most current data. (The availability of data is controlled by your user type and the status of the period/scenario association.)
  
  Unlike a desktop application in which your changes can be canceled, changes cannot be canceled.
  
  A user who has the write-lock ability can edit the model. Only one user can edit the model at any given time.
  
• Unlike a desktop application, which stores a copy of your data in memory so that you can undo your changes, SAS Cost and Profitability Management writes directly to the model.
  
  This enables all users to see the most current data immediately.
  
  You cannot undo your changes except by re-entering previous values. However, to preserve the state of the model before you make changes, you can export the model. You can then revert to the previous version by importing the model.

Refreshing

As you work in SAS Cost and Profitability Management, some information is updated automatically. However, it might not be updated immediately. You must click the button to make the updated information available to you.

*Note:* You might not see the new information. It could be on another view or in part of a hierarchy that is collapsed.

Users can see changes to global items, such as exchange rates and period/scenario associations, only after they restart SAS Cost and Profitability Management.

Sessions and Tasks

Multiple Sessions

You can create multiple sessions of SAS Cost and Profitability Management at the same time: that is, you can launch several instances of the SAS Cost and Profitability Management client application at one time and use them as if they are different applications. (The client application sessions can even talk to different SAS Cost and Profitability Management servers.) Multiple sessions enable you to easily compare multiple models or different areas of the same model.
**Canceling a Server Task**

You can cancel a server task that you initiate. However, canceling a task that makes changes to model data (such as an import) might leave the model in an unusable state.

You might need to cancel a server task when you realize that the task will require too much time or when you start a server task by mistake.

*Note:* A system administrator can cancel any task, regardless of who started it. If a system administrator cancels a task that you started, a message will notify you.

**See Also**

“Manage Tasks Dialog Box” on page 39

**See Also**

- “Manage Tasks Dialog Box” on page 39
- “Operation Summaries Dialog Box” on page 40

---

**Shortcut Keys**

**Navigation Tasks**

<table>
<thead>
<tr>
<th>Shortcut key</th>
<th>Action performed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt+Left Arrow</td>
<td>Move backward</td>
</tr>
<tr>
<td>Alt+Right Arrow</td>
<td>Move forward</td>
</tr>
<tr>
<td>Numeric keypad plus (+)</td>
<td>Expand the hierarchy</td>
</tr>
<tr>
<td>Numeric keypad minus (-)</td>
<td>Contract the hierarchy</td>
</tr>
</tbody>
</table>

**Basic Editing tasks**

<table>
<thead>
<tr>
<th>Shortcut key</th>
<th>Action performed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+X</td>
<td>Cut selected text to the Windows clipboard</td>
</tr>
<tr>
<td>Ctrl+C</td>
<td>Copy selected text to the Windows clipboard</td>
</tr>
<tr>
<td>Ctrl+V</td>
<td>Paste text from the Windows clipboard</td>
</tr>
</tbody>
</table>
### Shortcut key  |  Action performed
--- | ---
Ctrl+Q | Create a new folder in Workspace Manager or on the Attributes view
F5 | Refresh the information

**Modeling tasks**

<table>
<thead>
<tr>
<th>Shortcut key</th>
<th>Action performed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+A</td>
<td>Create a new item (other than an entered cost element)</td>
</tr>
<tr>
<td>Ctrl+O</td>
<td>Create a new entered cost element</td>
</tr>
<tr>
<td>Ctrl+E</td>
<td>Manage the attributes that have been added to an account</td>
</tr>
<tr>
<td>Ctrl+G</td>
<td>Go to the selected account</td>
</tr>
<tr>
<td>Alt+Enter</td>
<td>Show the item's properties</td>
</tr>
<tr>
<td>F7</td>
<td>Create assignments between the selected account and all of the accounts in the left and right assignments panes</td>
</tr>
</tbody>
</table>
| Shift+F7     | Delete all incoming assignments to the selected account and all outgoing assignments from the selected account.  
*Note:* It is not necessary that either the incoming accounts or the outgoing accounts be visible in an Assignments pane for the assignments to be deleted. In fact, it is not even necessary that an Assignments pane be displayed.

**Notes:**

- The JAWS screen-reading program occasionally locks input fields of HTML pages, preventing you from entering data. If this happens while you are using JAWS, press Alt+N to re-enable screen input.
- The JAWS screen-reading program assigns the label graphics plus a random number to unlabeled graphics. You can assign your own label using the JAWS Graphics Labeler.
- Due to a Windows bug, the underscore is not displayed for top-level menu items. For example, in the following display, the underscore is missing for File. However, the Alt key still works, even for File.
Using the JAWS Graphics Labeler

If a graphic in SAS Cost and Profitability Management has not been assigned a label, JAWS assigns it the label graphic followed by a random number. You can use the graphics labeler to assign such graphics a more meaningful label. You can either label a graphic manually or you can use the auto-labeler.

To label a graphic manually:

1. Find the graphic that you want to label.
2. Press Insert + g to open the graphics labeler.
3. Enter your label in the edit field.
4. Tab to the next edit field to enter the graphic label for your Braille display.
   When you press Tab again, you see three radio buttons that indicate where you want to save your labeled graphic. Choose where you want to save it, and then press Enter to activate the label.

To label a graphic manually, make sure that All Graphics is selected in the JAWS verbosity settings.
Chapter 4
Navigation Pane

What Is the Navigation Pane?

The Navigation Pane allows you to navigate among the workspaces that constitute SAS Cost and Profitability Management:

- Workspace Manager See “Workspace Manager” on page 27.
- Models See “Models Workspace” on page 66.
- Analysis See “Analysis Workspace” on page 557.
How to Access the Navigation Pane

If the Navigation Pane is not visible, then select View ➪ Navigation Pane.

Minimize the Navigation Pane

1. Click the Auto hide icon (the push pin) to minimize the Navigation Pane.

   When you roll over the minimized tab, the Navigation Pane returns but only temporarily.
2. Click the Auto Hide icon again to keep the Navigation Pane open (or select **View ➔ Navigation Pane**).

1. Click Auto hide, and the Navigation Pane is minimized.

2. Roll over the tab, and the Navigation Pane reappears (temporarily).

3. Click the push pin, and the Navigation Pane stays open.

---

**Partition the Navigation Pane**

Move the gripper up or down to change the relative size of the task area and the button area in the Navigation Pane.
Note: You cannot move the gripper up further than is necessary to fully display all the buttons in the button area.
Chapter 5
Workspace Manager

Overview

Use the Workspace Manager to start frequently used tasks. You can perform tasks from the Workspace Manager without first opening a model.

The Workspace Manager provides a treeview of all SAS Cost and Profitability Management elements—from models to cube configurations—and gives you access to them all.

Note: The availability of these features depends on your permissions.
Note: The Show items owned by user drop-down list is available only to administrators.

**How to Access the Workspace Manager**

1. If the Navigation Pane is not visible, click View ➤ Navigation Pane.
2. Click Workspace Manager.

**Workspace Manager Layout**

**About the Workspace Manager Layout**
Workspace Manager looks similar to Windows Explorer, and most of the commands and techniques that you use in Windows Explorer, including drag-and-drop, function identically in Workspace Manager.

Workspace Manager displays information in two panes. When you select an item in the left pane, the contents of the selected item are shown in the right pane.

The left pane has two main parts: the server area and My Shortcuts.
Server Area
The server area shows you all the items on a SAS Cost and Profitability Management server. The name of the workspace area is the name of the server on which the items are stored, followed by the word Workspace. For example, if the server is named ABCdata, the server area is named ABCdata Workspace. You cannot change this name.

In the server area, you see only those items for which you have permission. Also, you see the folders that have been created by all users, although you do not necessarily see the contents of each folder.

If you are a SAS Cost and Profitability Manager administrator, you see every item, regardless of who owns the item, and you can interact with every item (though you might not have permission to view the data contents of some items).

Creating and Deleting Items in the Server Area
You cannot rename or delete the top-level folders in the server area. However, if you have the necessary permissions, you can create and delete subfolders within these top-level folders.

When you delete a model, workspace items that depend on that model are not deleted. As a result, when you open a workspace item, you might see an error message about the missing model.

Note: When you see a workspace item without an associated model, you can delete the item and then create an identical item that is based on another model. Alternatively, you can edit the item to base it on another model. You cannot change the model that is associated with an item. To avoid the error message, delete the workspace item, and then create an identical item that is based on another model.

My Shortcuts
My Shortcuts enables you to organize the items that you need for your work. You can create shortcuts to items that are in the server area. Then, use a shortcut to open and use an item.

Note: Even when the item that a shortcut refers to is renamed or moved, or when the folder that contains the item is renamed, the shortcut still works.

My Shortcuts holds only folders and shortcuts. Each user of SAS Cost and Profitability Management has a different shortcut area, so you see only the folders and shortcuts that you create. You can use these folders and shortcuts from any computer that is connected to the server on which you create the folders and shortcuts.
Items in the server area are arranged by type. By contrast, in My Shortcuts, you can arrange folders by task and project, and you can create shortcuts to many different types of items in those folders.

Ownership and Permissions for Server Area Workspace Items

A workspace stores the items, such as column layouts and models, that are created in SAS Cost and Profitability Management. A workspace is shared by all users on the same server, and it enables your organization to define standard items once and to apply them to different models as needed.

When you create a server area item, SAS Cost and Profitability Management assigns ownership to you. You can modify the item, rename it, or move it.

To each group established with SAS Management Console, you can assign the permission to read or to read and write to any item that you own. If you do not assign permissions to a group, users who are members of that group cannot see the item.

Create a shortcut to a workspace item

1. In Workspace Manager, select an item in the server area.
2. Select File ⇒ Create Shortcut.
   
   The Create Shortcut dialog box appears.

Review or change the properties of a workspace item

1. In Workspace Manager, select an item.
2. Select Edit ⇒ Item Properties.
   
   The Item Properties dialog box appears.

Create a folder

1. In Workspace Manager, select a folder under which to create the new folder.
2. Select Edit ⇒ New Folder.
   
   The New Folder dialog box appears.

Refresh Workspace Manager

Select View ⇒ Refresh.

Show items that are owned by a specific user

Note: This feature is available only to administrators.

From the Show items by user menu, select a user.
See Also

- “Workspace Manager” on page 27
- Chapter 6, “User Capabilities and Groups,” on page 35

---

**Item Properties Dialog Box**

**About the Item Properties Dialog Box**

In the Item Properties dialog box, you can review or change information about a workspace item and you can set permissions for the workspace item.

*Note:* The availability of these features depends on your permissions.

**How to Access the Item Properties Dialog Box**

In Workspace Manager, select an item and select $\text{Edit} \Rightarrow \text{Item Properties}$. The Item Properties dialog box appears.

**Specify Information**

1. Click the **General** tab.

   ![Item Properties Dialog Box]

   2. Type the **Name**.
      
      The name must follow the naming guidelines. See “Naming Conventions” on page 43.

      *TIP* When you rename an item, notify other users. Otherwise, they might look for an item name that no longer exists.

   3. Type the **Description**.
Set Permissions

Note: Permissions are not applicable to shortcuts.

1. Click the Permissions tab.
2. Select an Owner.
3. In the Privileges list, select or clear the check boxes that are next to each listed group.

Note: To assign permissions to a group, you must be a member of that group or you must obtain administrative capabilities.

See Also

• Chapter 6, “User Capabilities and Groups,” on page 35
• Chapter 1, “User Capabilities and Groups,” in SAS Cost and Profitability Management: Data Administration Guide

Create Shortcut Dialog Box

About the Create Shortcut Dialog Box

In the Create Shortcut dialog box, you can name a shortcut and select its location in My Shortcuts.

How to Access the Create Shortcut Dialog Box

In Workspace Manager, select a workspace item in the server area and select File ➪ Create Shortcut. The Create Shortcut dialog box appears.

Specify information

1. Type the Name of the shortcut.
   The name must follow the naming guidelines.
2. In the Create in list, select the folder in which you want to place the shortcut.
3. To create a new folder in which to place the shortcut, click **New Folder**.
   The New Folder dialog box appears.

   **TIP** You can create a shortcut by dragging an object from the server area into My Shortcuts.

---

**New Folder Dialog Box**

**About the New Folder Dialog Box**

In the New Folder dialog box, you can name a new folder in Workspace Manager.

**How to Access the New Folder Dialog Box**

Do one of the following:
- In Workspace Manager, select **Edit ➔ New Folder**.
- In the Create Shortcut dialog box, click **New Folder**.

**Specify Information**

Type the folder **Name**.
Chapter 6
User Capabilities and Groups

Overview

The abilities that you possess as a SAS Cost and Profitability Management user depend on the following:

- the capabilities that you inherit from the groups to which you belong. See “Capabilities” on page 35.
- the permissions that are granted to the groups to which you belong.

The owner of an item, such as a model, can grant Read or Read/Write access to the model to all the members of a group. See “Giving Read or Read/Write Permission to Members of a Group” on page 36.

For complete information on users, groups, capabilities, and roles, see Chapter 1, “User Capabilities and Groups,” in SAS Cost and Profitability Management: Data Administration Guide. Also see Chapter 2, “How to Manage Permissions,” in SAS Cost and Profitability Management: Data Administration Guide.

Capabilities

When a SAS Cost and Profitability Management administrator created your SAS Cost and Profitability Management account, you inherited one or more of the following capabilities by virtue of belonging to a group with those capabilities.

Note: A group has capabilities because of the roles that the group is a member of.
Quite likely, most users will have inherited either Create Models capability or View Models capability. The Create Models capability provides the abilities of a Modeler in previous releases of SAS Cost and Profitability Management. It gives full access to a model including model creation and deletion, cube creation and viewing, etc. Plus, it gives users some other abilities not related to a particular model such as creating column layouts and setting up exchange rates.

Similarly the View Models capability provides the abilities of a Business User in previous releases of SAS Cost and Profitability Management.

If you do not know what capabilities you have inherited, ask your SAS Cost and Profitability Management administrator.

---

**Group Permissions**

The administrator creates groups for your organization and assigns you to one or more groups. Your abilities depend on the Read and Read/Write permissions granted to the groups to which you belong.

---

**Giving Read or Read/Write Permission to Members of a Group**

The creator of a model or other workspace item is, by default, its owner. Of course the owner has Read/Write access to the item. The owner can grant Read or Read/Write access to the item to users in a group. If you are a member of a group that has been granted access to a model or other workspace item, then you have that access as a member of the group.

The owner of a model or other item (or an administrator) grants access to the item to members of a group by selecting the item in the Workspace Manager and selecting **Edit ⇒ Item Properties**. Then, by checking either **Read** or **Read/Write**, the owner grants that access to members of the group.
Note: Only the owner of an item (or an administrator) can grant access to that item. Non-administrator members of a group that have been granted Read/Write access to an item cannot grant access to other groups.

If you do not know to what groups you belong, ask your SAS Cost and Profitability Management administrator.

**Changing Owners**

The creator of a model or other workspace item is, by default, its owner. The owner (or an administrator) can transfer ownership to another user. To transfer ownership, the owner (or administrator) selects the item in the Workspace Manager and selects Edit ➜ **Item Properties**. Then the owner (or administrator) selects a new owner from the dropdown list of users.
Note: The drop-down list of potential owners includes those users who have Create capability for the item. For example, you can transfer ownership of a model only to those users who have Create Models capability.

---

Select User Dialog Box

About the Select User Dialog Box

Use this dialog box to display items owned by a particular user.

Note: This dialog box is available only to users with Administrator capability.

![Select User Dialog Box](image)

How to Access the Select User Dialog Box

Select Tools ➔ Select User.
Chapter 7
General Application Tools

Manage Tasks Dialog Box ................................................................. 39
About the Manage Tasks Dialog Box .............................................. 39
How to Access the Manage Tasks Dialog Box ............................... 40
Cancel a Task .............................................................................. 40

Operation Summaries Dialog Box .................................................. 40
About the Operation Summaries Dialog Box ................................. 40
How to Access the Operation Summaries Dialog Box .................. 40
Delete a Summary ........................................................................ 40
View Details about a Server Operation ........................................ 41
Export the Operation Summaries .................................................. 41

Audit Log Window ........................................................................ 41
About the Audit Log Window ....................................................... 41
How to Access the Audit Log Window .......................................... 41
Sort the Information ..................................................................... 42
Limit the Information ................................................................... 42

Manage Tasks Dialog Box

About the Manage Tasks Dialog Box

In the Manage Tasks dialog box, you can monitor the status of tasks that are being performed on a SAS Cost and Profitability Management server.
Note: You can perform the following tasks without first opening a model.

**How to Access the Manage Tasks Dialog Box**

Do one of the following:

- Click **Tasks** in the status bar.
  
  The Tasks button is visible only during an operation that you can cancel, and only when the status bar is not hidden.
- Select **Tools ⇒ Manage Tasks**.

**Cancel a Task**

1. From the list of **Tasks**, select a task.
   
   You can select more than one task. A check mark is displayed next to the selected tasks.

2. Click **End Tasks**.
   
   There might be a delay before the operation is canceled.

---

**Operation Summaries Dialog Box**

**About the Operation Summaries Dialog Box**

In the Operation Summaries dialog box, you can see a list of all of the operations that you have performed on a SAS Cost and Profitability Management server. For example, an operation entry is added to this list whenever you calculate costs or generate a cube.

*Note:* Except for administrators, the Operation Summaries dialog box displays summaries for a specific user account in a specific domain, such as LOCALMACHINE/Alex. If Alex also has an account in the domain COMPANY, and if he logs in as COMPANY/Alex, he will not see the summaries for the account LOCALMACHINE/Alex.

*Note:* You cannot change this information.

**How to Access the Operation Summaries Dialog Box**

Select **Tools ⇒ Operation Summaries**.

**Delete a Summary**

1. Select the check box next to a summary.

2. Click **Delete**.
View Details about a Server Operation

1. Select the check box next to a summary.
2. Click View.
   The Operation Summary window appears.
3. Click Show Details.

Export the Operation Summaries

1. Click Export.
   The Save As dialog box appears.
2. Navigate to a location.
3. Type the File name.

Audit Log Window

About the Audit Log Window

The availability of this feature depends on your permissions.

In the Audit Log window, you can see a history of the actions that have been performed on a SAS Cost and Profitability Management server. The history includes information such as what action was performed, the user who performed the action, and the item that was acted upon.

How to Access the Audit Log Window

Select Tools ⇒ Audit Log.
Sort the Information
Under **Choose column order**, select a column to sort on from the **Column** drop-down list. Then select **Ascending** to sort in ascending order on the contents of the selected column. Or, deselect **Ascending** to sort in descending order on the contents of that column.

Limit the Information
From the **User**, **Name**, **Period**, and **Scenario** menus, select values to use for limiting the information.
Chapter 8
Naming Conventions

Naming Conventions

General naming conventions
The name of any item must conform to the following rules:

• Names cannot contain this character: |

• Any item, such as a dimension, a driver, an attribute, and so on, that might become a
dimension in a cube cannot have the reserved names All or None.

• Names are case insensitive. For example, the name My Model is the same as my
model and mY mODEL.
In addition to the general naming conventions, there are more restrictive naming conventions for the following items.

**Attribute naming conventions**

In addition to the general naming conventions, attribute names must conform to these rules:

- Attribute names must be unique within a parent.
- Attribute names may contain up to 64 alphanumeric characters. However, attribute names longer than 50 characters are truncated to 50 characters when a cube is generated for Microsoft Analysis Services. SAS OLAP allows all 64 characters for attribute names.
- An attribute name cannot be the name of a numeric property.
- Attribute names may contain these characters, even though these characters are not valid in cubes:

  . , ! " : ? * & $ ! - + = ( ) [ ] { } / \n
  Each of these characters will be replaced with an underscore (_) when a cube is generated.

  For additional considerations concerning stage attributes, see “Stage Attributes” on page 249.

**Dimension naming conventions**

In addition to the general naming conventions, dimension names must conform to these rules:

- Dimension names may contain up to 64 alphanumeric characters. However, dimension names longer than 32 characters are truncated to 32 characters when a cube is generated for Microsoft Analysis Services. SAS OLAP allows all 64 characters for dimension names.
- Dimension names must be unique among all dimensions and dimension attributes.
- Dimension names must be unique.
- Dimension names may contain these characters, even though these characters are not valid in cubes:

  . , ! " : ? * & $ ! - + = ( ) [ ] { } / \n
  Each of these characters will be replaced with an underscore (_) when a cube is generated.

  **Note:** “Module”, “Period”, “Scenario”, and “Driver” are reserved names and you cannot use them for either a dimension name or a dimension reference.

**Dimension level naming conventions**

In addition to the general naming conventions, dimension level names must conform to these rules:

- Dimension level names may contain up to 64 alphanumeric characters. However, dimension level names longer than 50 characters are truncated to 50 characters when
a cube is generated for Microsoft Analysis Services. SAS OLAP allows all 64 characters for dimension level names.

- Dimension level names must begin with an alphabetic character.
- Dimension level names cannot contain these characters:
  
  \ / | \ 

- Dimension level names may contain these characters, even though these characters are not valid in cubes:

  . [ ]

Each of these characters will be replaced with an underscore (_) when a cube is generated.

- Note: Because of the mechanism used by SAS Cost and Profitability Management to store dimension level names, some user-specified names will cause conflicts with the underlying database (regardless of whether Microsoft SQL Server or Oracle is used). These conflicts will appear as obscure error messages when calculating a model. Dimension level names that will cause conflicts are reserved words in the Microsoft SQL query language. Some of the more common reserved words are: level, group, function, drop, and join. To avoid dimension level name conflicts in cases where you need to use a word such as a level name, add a descriptive prefix or suffix. For example, using the name Level or LeVeL might cause errors, but the names Dept_Level and Level_02 are fine.

To change the name of a dimension level:

1. Open a model.
2. Select **Model** → **Dimensions**.
3. Right-click a dimension and select **Item Properties**.

   The Dimension Properties window opens.

4. Type a new name, and then click **OK**.
**Dimension member naming conventions**

In addition to the general naming conventions, dimension member names must conform to these rules:

- Dimension member names may contain up to 256 alphanumeric characters. However, dimension member names longer than 50 characters are truncated to 50 characters when a cube is generated for Microsoft Analysis Services. SAS OLAP allows all 256 characters for dimension member names.

- Dimension member names may contain these characters, even though these characters are not valid in cubes:

  . [ ]

  Each of these characters will be replaced with an underscore (_) when a cube is generated.

  Dimension member names must be unique within a parent.

**Driver naming conventions**

In addition to the general naming conventions, driver names must conform to these rules:

- Driver names must be unique within all drivers.

- Driver names may contain up to 64 alphanumeric characters. However, driver names that are longer than 50 characters are truncated to 50 characters when a cube is generated.

- Driver names may contain these characters, even though these characters are not valid in cubes:

  . [ ]

  Each of these characters will be replaced with an underscore (_) when a cube is generated.

**Entered cost element naming conventions**

In addition to the general naming conventions, entered cost element names must conform to these rules:

- Entered cost element names may contain up to 64 alphanumeric characters.

- Entered cost element names must be unique under the same account in the same period/scenario association.

- Entered cost element names may contain these characters, even though these characters are not valid in cubes:

  . [ ]

  Each of these characters will be replaced with an underscore (_) when a cube is generated.

**Module naming conventions**

When renaming modules, the name must conform to these rules:
• Module names may contain up to 64 alphanumeric characters.
• Module names can contain the following characters: alphanumeric, underscores, embedded blanks.

**Period naming conventions**

In addition to the general naming conventions, period names must conform to these rules:
• Period names must be unique within all periods.
• Period names may contain up to 64 alphanumeric characters. However, period names that are longer than 50 characters are truncated to 50 characters when a cube is generated.
• Period names may contain these characters, even though these characters are not valid in cubes:
  . [ ]

Each of these characters will be replaced with an underscore (_) when a cube is generated.

**Period level naming conventions**

In addition to the general naming conventions, period level names must conform to these rules:
• Period level names must be unique within all period levels.
• Period level names may contain up to 64 alphanumeric characters. However, period level names that are longer than 50 characters are truncated to 50 characters when a cube is generated.
• Period level names may contain these characters, even though these characters are not valid in cubes:
  . [ ]

Each of these characters will be replaced with an underscore (_) when a cube is generated.

**Scenario naming conventions**

In addition to the general naming conventions, scenario names must conform to these rules:
• Scenario names must be unique within all scenarios.
• Scenario names may contain up to 64 alphanumeric characters. However, scenario names that are longer than 50 characters are truncated to 50 characters when a cube is generated.
• Scenario names may contain these characters, even though these characters are not valid in cubes:
  . [ ]

Each of these characters will be replaced with an underscore (_) when a cube is generated.
**Scenario level naming conventions**

In addition to the general naming conventions, scenario level names must conform to these rules:

- Scenario level names must be unique within all scenario levels.
- Scenario level names may contain up to 64 alphanumeric characters. However, scenario level names that are longer than 50 characters are truncated to 50 characters when a cube is generated.
- Scenario level names may contain these characters, even though these characters are not valid in cubes:
  
  `[ ]`

Each of these characters will be replaced with an underscore (_) when a cube is generated.

**Stage attribute naming conventions**

In addition to the general naming conventions and Attribute naming conventions, stage attribute names must conform to these rules:

- Stage names must begin with an alphabetic character (letter).
- You can change stage names as long as they retain their order when sorted. If the sort order changes them, you will need to regenerate the fact tables for all period/scenarios in the model.

**Workspace item naming conventions**

In addition to the general naming conventions, workspace item names must conform to these rules:

- Workspace item names cannot contain these characters:
  
  `/ \ or |`

- Workspace item names must be unique within a folder.
- Workspace item names may contain up to 64 alphanumeric characters.

---

**Reference Conventions**

**Account reference conventions**

- Account references must be unique within a module for all period/scenario associations.

For additional considerations concerning stage attributes, see “Stage Attributes” on page 249.
Attribute reference conventions

- Attribute references must be unique within all attributes.

Dimension reference conventions

- Dimension references must be unique within all dimensions and dimension attributes.

Note: “Module”, “Period”, “Scenario”, and “Driver” are reserved names and you cannot use them for either a dimension name or a dimension reference.

Dimension member reference conventions and dimension attribute reference conventions

- Dimension member references and dimension attribute references must be unique within a dimension.

Period reference conventions

- Period references must be unique within all periods.

Scenario reference conventions

- Scenario references must be unique within all scenarios.

Entered cost element reference conventions

- Entered cost element references must be unique within a module for all period/scenario associations.
Part 3

Models

Chapter 9
Model Concepts ......................................................... 53

Chapter 10
Windows for Models ..................................................... 65

Chapter 11
How To: Models .......................................................... 77
Chapter 9
Model Concepts

Elements of a Model

Periodic and Structural Elements

A model is the basic container for information in SAS Cost and Profitability Management. A meaningful model reflects the organization that it is modeling and uses terms that are familiar to the people who work at the organization.

A model contains two types of elements:
Periodic elements
Periodic elements can exist in one period/scenario and not in another. Periodic elements are stored separately for each period/scenario in a model. The following elements are periodic:

- Accounts
- Entered Cost Elements
- Assignments
- Attributes
- Currency Rates

Structural elements
Structural elements are independent of any period/scenario. A structural element exists in every period/scenario in a model. The following elements are structural:

- Modules
- Dimensions
- Dimension Members
- Drivers

Periods and Scenarios
You define periods and scenarios independently of any model. Any period and scenario can be shared by all the models on a server.

A period is any range of dates such as a year, month, week, or quarter. You can define a hierarchy of periods such as months within quarters within years.

A scenario is a label that you associate with a period so that you can distinguish the data for that period with that label from data for the same period with a different label. Two common labels are “Actual” and “Budget”. Using those labels (scenarios) allows you to distinguish actual costs and budgeted costs in a period. You can also define a hierarchy of scenarios such as Budget—>WhatIf1, Budget—>WhatIf2.

See “Step 2: Specify Initial Period and Scenario” on page 79.

Period and Scenario Associations
A period and scenario association (also referred to as a period/scenario association, or just period/scenario) is an ordered pair consisting of one period and one scenario. You associate a period with a scenario when you specify the initial period and scenario for a model. Until you create additional period/scenario associations, all periodic model data belongs to the initial period/scenario association.

See “Create a Period/Scenario Association” on page 143.

Modules
A module contains a set of accounts. The set of modules forms an ordered set of sets of accounts. The set of modules is an ordered set because it determines the direction of cost flow in a model:

- An account in one module can flow costs to any other account (including itself) in the same module.
• An account in one module can flow costs to any other account in any module after its own module in the direction determined by the module order.

Modules are structural elements. The modules that you define for a model exist in every period/scenario in the model.


Dimensions

Dimensions are the top-level categories that lay out the types of accounts that exist in your model. Examples of dimensions are: Region, Channel, Product, Customer, Resource, General Ledger, Materials, Department, and Activity.

Dimensions are structural elements. The dimensions that you define for a model exist in every period/scenario in the model.


Dimension Members

Dimension members form a tree structure under their respective dimensions and further refine the types of accounts that exist in your model. For example, the tree structure under the region dimension might be:

• Americas
  • US
    • New York
    • Washington, D.C.
  • Cary
  • Canada
  • Brazil
• Europe
  • Germany
  • England
  • France
• Asia
  • China
  • Korea
  • Japan

Dimension members are structural elements. The dimension members that you define for a model exist in every period/scenario in the model.

See “Dimension Members” on page 170.

Accounts

An account is a point where costs accumulate in a model and is defined by an intersection of dimension members—one dimension member from each dimension in a
module. For example, if a model contains the dimensions Region, Activity, and Product, one account might be the following:

London x Shipping x Hat

Where London is a dimension member of Region, Shipping is a dimension member of Activity, and Hat is a dimension member of Product.

Accounts are periodic elements. The accounts in one period/scenario may exist in another period/scenario. And, when an account (same dimension signature) exists in multiple period/scenarios, its cost in one period/scenario is independent of its cost in another period/scenario.

See Chapter 27, “What are Accounts?,” on page 197.

### Cost Elements

The cost in an account is the sum of its entered cost elements and its received cost elements:

**Entered Cost Element**

An entered cost element is one that you create and to which you assign costs directly by giving it one or both of:

- **Entered Cost**: A lump sum that you give to the cost element
- **Entered Unit Cost**: If you specify Entered Unit Cost, then the cost for the cost element is determined by multiplying that unit cost times the number of units of the parent account that are assigned to destination accounts.

*Note:* All of the cost in a model originates with entered cost elements.

**Received Cost Element**

A received cost element is one that you create indirectly by creating an assignment from one account to another. The cost that the destination account receives from that source account is a received cost element.

Cost elements are periodic elements. The cost elements in one period/scenario may exist in another period/scenario. And, when a cost element (with the same name and reference in the same module) exists in multiple periods/scenarios, its cost in one period/scenario is independent of its cost in another period/scenario.


### Attributes

Attributes are items that you define to associate categories or values to accounts. Attributes are either:

- **Value attributes**: A value attribute has a value that is true of an account. Value attributes can be of the following kind:
  - Numeric
  - Text

- **Tag attributes**: A tag attribute (also known as Boolean) does not have a value. You can apply a tag attribute to one or more accounts, and you can use a tag attribute in a formula to identify accounts that have that tag attribute.
Dimension attributes

*Dimension attributes* are like ordinary (structural) dimensions because they contain members (dimension member attributes) that you can use to group or categorize the types of accounts that exist in your model. For example, the dimension attribute FixedVariable can contain the dimension member attributes Fixed and Variable. By applying either the dimension member attribute Fixed or the dimension member attribute Variable to accounts, you can distinguish fixed costs from variable costs in your model. Stage attributes are a special case of dimension attributes used for a specific purpose.

*Note:* Like numeric attributes, dimension attributes can appear in the OLAP cubes that are generated from your model. Text and tag attributes do not appear in OLAP cubes.

Attributes are periodic elements. An attribute that is attached to an account in one period/scenario may or may not be attached to the same account in another period/scenario. And, when a value attribute is attached to the same account in multiple periods/scenarios, its value in one period/scenario is independent of its value in another period/scenario.

See Chapter 33, “Types of Attributes,” on page 245.

*Properties*

*Properties* have values that are true of the elements of a model. Properties are either:

**System-defined**

*System-defined properties* are those that are available for every model. You provide either the values for such properties or the data that is used to calculate the values. For example, Cost is a system-defined property of an account. You might assign one account $100 of cost, whereas you might assign another account $0 of cost.

All model elements have system-defined properties.

System-defined properties are structural elements. They exist in every period/scenario in a model. However, the value of a system-defined property may be either structural or periodic depending on the particular property. For example, DriverName, which is a system-defined property, has the same value for a particular driver in every period/scenario, whereas DrivenQuantity, which is also a system-defined property of drivers, can have different values for the same driver in different period/scenarios.

See:

- Chapter 90, “Alphabetic List of Properties,” on page 709
- Chapter 91, “Property Relationship Diagrams,” on page 767
- Chapter 60, “Properties in Calculation,” on page 501

*Drivers*

A *driver* distributes costs from a source account to one or more destination accounts. There are four types of drivers:

**Evenly assigned**

Distributes the cost evenly to each of the destination accounts.

**Percentage**

Distributes the cost by percentages that you specify to each of the destination accounts.
Standard
Uses a system-defined formula for distributing the cost to each of the destination accounts. The formula is system-defined, but you determine the values of the properties used in the formula.

Calculated
Uses a user-defined formula for distributing the cost to each of the destination accounts. You define the formula, and you determine the values of the properties and attributes in the formula.

Drivers are structural elements. They exist in every period/scenario in a model. And, if a driver has a formula or a rule formula, then those formulas are the same in every period/scenario. However, the evaluation of a formula can result in different values in different period/scenarios. And, a particular driver that is attached to an account in one period/scenario may not be attached to the same account in a different period/scenario.


Assignments

An assignment is a directional connection or association between a single source account and one or more destination accounts. It defines the distribution of costs between accounts using the source account’s driver. The amount of cost that flows is controlled by the driver. A single source account can make assignments to any number of destination accounts, but each source account can have only one driver.

Assignments are periodic elements. An assignment between two accounts in one period/scenario may or may not exist between the same accounts in another period/scenario. And, when an assignment exists between the same accounts in multiple periods/scenarios, its values in one period/scenario are independent of its values in another period/scenario.


Column Layouts

A column layout is the set of properties and attributes that display when you view the modules in your model or when you view the dimension members in your model. You can customize column layouts so that the properties and attributes that are displayed are the ones that you want to see. You can create any number of column layouts.

Column layouts are structural elements. Once a column layout has been defined in association with a model and saved, it exists in every period/scenario in a model. However, a column layout can contain properties and attributes that are specific to a particular period/scenario. By default, the values displayed in a column layout for attributes and properties are their values for the current period/scenario. Column layouts created for one model can also be loaded into other models. If a column layout is displayed that contains properties and attributes that are specific to a particular period/scenario and there is no data for that period/scenario in the model, then those properties and attributes are displayed as blank.

See “What is a Column Layout?” on page 293.

Currencies and Exchange Rate Tables

When you create a model, you must specify its base currency which determines how costs are displayed. You can also create exchange rate tables for converting costs to other
currencies. An exchange rate table applies to a single period/scenario association in a model and can contain any number of currencies.

See Chapter 12, “Working with Currencies,” on page 103.

See Also

“Create a Model” on page 78

Guidelines for Creating the Model Structure

Anticipate the Needs of Users

Before you build a model, define the goals of the model. Each organization has different goals that affect how a model is designed. There is no single correct way to design a model.

Before you build the model, consider the following questions:

• What are the required outputs, such as cubes?
  The people in your organization might need to answer questions such as, What does this product or service cost? and Why does it cost that?
  The type and detail of analysis that users need to perform determines the model structure that you define.

• How well do you know your organization?
  Consider your organization's systems, products or services, and customers before starting to build a model.

• What types of information do the people in your organization need?
  Ensure that the model accommodates the needs and goals of the organization. Include only that information that supports the needs and goals.

• What level of detail is important to your organization?
  If you include too much detail, you might complicate the analysis without adding useful information. A detailed model requires more maintenance in the future. If you include too little detail, you might fail to reveal opportunities for improvement.

Building a model is an iterative process. Few people build a model with all of the necessary information the first time. A model often requires several iterations to determine the best balance between too much information and not enough information.

Communicate often with those people who will use the information provided by the model. Are you including the information that meets their needs? Is the amount of detail enough? Do these people need to analyze the data in ways you have not accommodated in the model?

The best method to design a model is to create a paper model before attempting to build the model in SAS Cost and Profitability Management.

Create a Paper Model

A paper model helps you focus on the model structure before entering data into the model. Sketch the model structure on paper, and note the important levels in the
organizational hierarchy. Then, review the paper model with other people in your organization to determine whether you are approaching their needs correctly.

Your paper model might look something like the following:

After you determine that the paper model meets the needs of the people in your organization, you should start collecting the data that is needed by the model.

**Collect Data**

A review of the paper model will identify the data that you need to collect. The quality and the integrity of the model depend on identifying the data and collecting the data.

There are many different ways to collect data. Most organizations use a combination of techniques and methods, such as the following:

- conducting interviews with people
- distributing questionnaires to people
- analyzing historical records
- gathering a panel of experts or focus groups
- observing people and work flow

**Guidelines for Designing a Model**

Each organization has different goals that affect how a model is designed. There is no single correct way to design a model.

Here are some guidelines for creating a model that runs efficiently and that provides useful information:

- Define the goals.
  
  What are the goals and the scope?
- Decide what types of information are needed.
What types of information do managers need? Make sure that the model accommodates the needs and goals of the organization.

- Design the model structure before entering data into the model.
  Note the important levels in the organizational hierarchy.

- Decide how much detail to include.
  What level of detail is important to your organization? If you include too much detail, you might complicate the analysis without adding useful information. A detailed model requires more maintenance in the future. If you include too little detail, you might fail to reveal opportunities for improvement.

- Combine similar accounts.
  Are particular costs incurred together, or are multiple costs caused by the same factor? If so, you might want to combine such items. For example, if your organization's General Ledger lists the details of travel expenses, such as airfare, hotel, or entertainment, you might want to combine these accounts into one travel expense account. Also, if some accounts have small costs, you might want to combine the small accounts into accounts that represent more general categories.

- Group related accounts.
  Group accounts into rollup accounts (folders) if the accounts have similar functionality or if the accounts are linked to similar activities.

- Gather costs.
  Consider the relationship between the time period that you use for gathering costs and the time period that you use for gathering resource values and activity driver values.

- Collect driver data.
  When you collect driver data to assign, for example, activity costs to cost objects, ensure that the data is current, available, and accurate. Ask individuals in your organization to verify the data's accuracy.

- Minimize the use of unique driver quantities.
  Unique driver quantities can use a lot of memory. They increase your processing time, and they do not provide a calculation advantage.

---

**Guidelines for Sharing Models, Configurations, and Data**

**Overview**

After you create a model and analyze it, you will have data that helps you and others in your organization make business decisions. You will want to share your results so that co-workers can use the business data that you have prepared. However, because much data is stored on a single server, you should establish naming conventions and other guidelines so that all users can easily find the correct information.

Workspace Manager lists items that are available for all SAS Cost and Profitability Management users who are using the same server.
**Saving Items**

Establish guidelines for when to save and when not to save column layouts and OLAP views.

**Naming Items**

**Overview**
To manage the lists of items that are on a SAS Cost and Profitability Management server, establish a naming convention. Decide whether a name should include the owner's initials or a departmental or functional prefix or suffix. Names of items affect the sort order within folders in Workspace Manager.

**Naming Import Configurations and Models**
For model names and import configurations, you might want to include the following information:

- the goal for the model
- the users that can work with the model
- a short way of referring to the types of structures, dimensions, attributes, or measures that are selected when data is imported
- the period/scenario associations
- the date on which the model was imported

**Naming Column Layouts**
For column layout names, you might want to include the following information:

- the users or teams who use the column layout
- the models or types of models that use the column layout
- the validation or purpose of the layout

**Naming OLAP Views**
By default, each description on the Analysis workspace contains the following information:

- the description that was entered when the OLAP view was saved
- the date on which the OLAP view was saved
- the model name
- the type of predefined cube
- the network login of the person who saved the OLAP view

**Removing Items**
Your organization should encourage users to remove items that were automatically saved or that they saved and no longer need. You can establish guidelines for when to remove items.
Sharing Data with Others

For people who do not use SAS Cost and Profitability Management, you can export cubes to a Microsoft Excel spreadsheet.
Chapter 10
Windows for Models

Models Workspace .......................................................... 66
About the Models Workspace ......................................... 66
How to Access the Models Workspace ............................ 66
Sort information in the Models Workspace .................... 66

New Model Dialog Box .................................................. 67
About the New Model Dialog Box .................................. 67
How to Access the New Model Dialog Box .................... 67

Change Model or Context Dialog Box ............................. 67
About the Change Model or Context Dialog Box ............... 67
How to Access the Change Model or Context Dialog Box ... 68

Model Properties Dialog Box ........................................... 68
About the Model Properties Dialog Box ......................... 68
How to Access the Model Properties Dialog Box ............. 69
General Tab ................................................................. 69
Cube Tab ................................................................ 70
Attributes in Cubes Tab .................................................. 71
Model Dimensions Tab .................................................... 71
Module Rename Tab ......................................................... 71

Model Summary Window ................................................ 72
About the Model Summary Window ............................... 72
How to Access the Model Summary Window .................. 72

Copy a Model ................................................................ 72

Model Locking Status Dialog Box ................................. 73
Overview .................................................................... 73
How to Access the Model Locking Status ...................... 73
See What Users Have a Lock on a Particular Model .......... 73
Terminate a Lock on a Particular Model ......................... 74

Export and Register Tables Dialog Box ......................... 75
Overview .................................................................... 75
How to Access the Export and Register Tables dialog box 76
Models Workspace

About the Models Workspace

Note: The availability of these features depends on your permissions.

From the Models workspace, you can open a model.

The list of Folders and the list of Models correspond to the Models branch of the server area in Workspace Manager.

How to Access the Models Workspace

Do one of the following:

- If no model is open, click Models in the Navigation Pane.
- Select Model ⇒ Change Model or Context to open a different model.

Sort information in the Models Workspace

1. Click the Sort By link.
   A menu appears.
2. Select an option. The options contain the following criteria:

<table>
<thead>
<tr>
<th>Name</th>
<th>The name of the model</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date and Time</td>
<td>The date and time which the model was created</td>
</tr>
</tbody>
</table>
New Model Dialog Box

About the New Model Dialog Box

Use the New Model dialog box to create a new model. Creating a model entails specifying:

- model name, reference, and base currency.
- initial period/scenario association.
- the number of modules, their names, and their order.
- the dimensions belonging to each module.

See Also
- “Create a Model” on page 78
- Chapter 9, “Model Concepts,” on page 53

How to Access the New Model Dialog Box

Do one of the following:

- Select File ➔ New ➔ Model from the menu bar.
- Select Create New Model from the Navigation Pane (see Chapter 4, “Navigation Pane,” on page 23).

Change Model or Context Dialog Box

About the Change Model or Context Dialog Box

Use this dialog to do any of the following:

- Open a different model, specifying its period/scenario association and column layout
- Change the period/scenario association for the currently open model
- Change the column layout of the currently open model
How to Access the Change Model or Context Dialog Box

Select Model ⇒ Change Model or Context.

Note: You must be in the Models Workspace for this menu item to be available.

See Also
“Models Workspace” on page 66

Model Properties Dialog Box

About the Model Properties Dialog Box

The availability of these features depends on your permissions.

In the Model Properties dialog box, you can review or change information about a model.

The Model Properties dialog contains the following tabs:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>General (p. 69)</td>
<td>Specify general options</td>
</tr>
<tr>
<td>Cube (p. 70)</td>
<td>Specify In or Out for each module of a Multi-stage Contributions cube</td>
</tr>
<tr>
<td>Attributes in Cubes (p. 71)</td>
<td>Specify the numeric attributes to be included in cubes</td>
</tr>
<tr>
<td>Model Dimensions (p. 71)</td>
<td>View the dimensions that each module contains</td>
</tr>
</tbody>
</table>
**How to Access the Model Properties Dialog Box**

Open a model and select Model ⇒ Properties.

**General Tab**

![Model Properties Dialog Box](image)

Click the General tab, and choose among the following options:

**Model’s base currency**

A model’s base currency is the currency that was selected when the model was created. You cannot change the model’s base currency.

**Default Output Quantity**

This property is intended for demonstration purposes only and not for working models. The value that you specify for Default Output Quantity is substituted for Driver Quantity Calculated under certain conditions when the value of Driver Quantity Calculated is zero. This allows those accounts to drive costs for demonstration purposes that they wouldn’t otherwise drive.

**Default column layout for dimensions**

This is the column layout that is displayed by default for the Dimensions view. Whenever you are in the Dimensions view you can activate a different layout.

**Default driver and column layout for each module**

- The default driver is the driver that is associated with an assignment when you first create the assignment. You can change the driver subsequently after making the assignment.
- The default column layout for a module is the layout that is displayed by default whenever you view that module. Whenever you are viewing that module you can
activate a different layout. However, the next time you open the model and view that module, the its default column layout is displayed again.

**Cube Tab**

The options that you select here are automatically selected as defaults when you create a new cube configuration for the model. You can, however, override the defaults when you create the cube configuration.

*Note:* Changing these options after a cube has been generated does not affect the generated cube. It only affects the defaults for the creation of new cube configurations.

1. Click the **Cube** tab.
2. Choose one of the following options:
   - **Define stages by each module.** Each module defines a separate stage (one stage per module) in the order in which you defined the modules, or in the following order for a traditional activity-based costing model:
     1. External Unit
     2. Resource
     3. Activity
     4. Cost Object
   - **Define stages by a dimension attribute named Stages.**
     Each stage is defined by a dimension member attribute in a dimension attribute named Stages. For more information, see “Stage Attributes” on page 249 and “Add Stage Attributes to Accounts” on page 287.
3. In the **Use the cost as it flows in or out of each stage** list, select the **Cost Flow (In or Out)** for each module or stage.

If you select **In**, then only costs flowing into accounts in the module or stage are included in the cube. If you select **Out**, then only costs flowing out of accounts in the module or stage are included in the cube.

*Note:* The **In/Out** option only makes a difference in the case of accounts that make assignments to other accounts in the same module or stage (or in an earlier stage). If such is the case, then not all cost flowing into that account also flow out of it from the same stage or module. If such is the case, then you must decide whether you want the cube to show cost flowing into the account in that stage or module, or cost flowing out of the account from that stage or module. If, on the other hand, there are no accounts that make assignments to other accounts in the same module or stage (or in an earlier stage), then the **In/Out** option makes no difference. All cost flowing into an account in one stage or module also flows out of it from that module or stage (or, at least is accounted for as None if it remains in the account).
**Attributes in Cubes Tab**

**Overview**
Use the Attributes in Cubes tab of the Model Properties dialog box to work with attributes. However, the function of this tab is different for a single-stage contribution cube than for a resource contribution cube or a multi-stage contribution cube.

**Single-Stage Contribution Cube**
To include numeric attributes in a single-stage contribution cube:
1. Select the Attributes in Cubes tab.
2. Select the numeric attributes to be included in the cube.
   
   If you generate a single-stage contribution cube, then the numeric attributes that you select are included in the cube.

**Resource Contribution Cube and Multi-Stage Contribution Cube**
The numeric attributes that you select on the Attributes in Cubes tab are automatically checked for inclusion when you create a new cube configuration for the model. You can, however, decide not to include the properties when you create the cube configuration, and you can include different attributes. The attributes that you select here are only checked by default. You can reverse the decision for any particular cube configuration.
1. Click the Attributes in Cubes tab.
2. Select the numeric attributes to be checked by default in a new cube configuration.

**See Also**
See also: “Include Numeric Attributes in a Cube” on page 551.

**Model Dimensions Tab**

1. Click the Model Dimensions tab.
2. In the Dimensions used in each module list, expand a module.
   
   The dimensions that are used in the module are displayed.

**Module Rename Tab**

This tab allows you to rename any module in a model.
Model Summary Window

About the Model Summary Window

In the Model Summary window, you can see summary information about various aspects of a model for the current period/scenario association, such as total costs for each module and the number of cycles (reciprocal cost assignments) in the model.

Note: You cannot change this information.

How to Access the Model Summary Window

Open a model and select Model ⇒ Summary.

Copy a Model

Before making major changes to a model, you can make a copy of the model that you can refer to, or revert to, later on.

To copy a model:
1. Go to the Workspace Manager.
2. Select the model that you want to copy, and then select Edit ⇒ Copy (or, right-click the model and select Copy).
3. Select the directory in which you want to place the model. Then select **Edit ➔ Paste** (or right-click the directory and select **Paste**). The Paste Model dialog box opens.

4. If the model that you want to copy was previously calculated and fact tables were generated, then you can include the calculated data and fact tables along with the model. If you choose to copy the fact table, then the calculated data is automatically included. Choose none, one, or both of the following options:
   - Include Calculated data
   - Include FACT Tables

   Whereas models that you export and re-import must be recalculated and their fact tables regenerated, models that you copy do not require those steps.

---

**Model Locking Status Dialog Box**

**Overview**

Use the Model Locking Status dialog box to:
- see what users have a lock on a particular model
- terminate the locks on a particular model

**How to Access the Model Locking Status**

To access the Model Locking Status dialog box:
- Select **Tools ➔ Model Locking Status**.

**See What Users Have a Lock on a Particular Model**

To see what users have a lock on a particular model:
1. Select **Tools ⇒ Model Locking Status**.

2. Select a model from the drop-down list.

   The Model Locking Status dialog box shows the users that have a lock on that model and the type of lock.

### Terminate a Lock on a Particular Model

An administrator and a modeler with Read/Write access to the model can terminate the lock of another user. A viewer can terminate the viewer’s own Read lock—but not the lock of another user.

To terminate a lock on a particular model:

1. Select **Tools ⇒ Model Locking Status**.

2. Select a model from the drop-down list.

   The Model Locking Status dialog box shows the users that have a lock on that model and the type of lock.

3. Select the lock(s) to terminate.

4. Click **Terminate Locks**.
5. A warning message appears, indicating that errors could occur if an administrator or modeler with read/write access to the model terminates the write lock on a model when the modeler is working on the model. Click **Yes** to terminate the lock.

---

Export and Register Tables Dialog Box

**Overview**

Use the Export and Register Tables dialog box to export database tables that are registered in SAS Management Console for use with other SAS or non-SAS programs. The tables are exported to your default database—the one into which FACT tables are written.

*Note:* **Also load selected tables into a library for the SAS LASR Analytic Server** is enabled only if you have access to a library that is enabled for the SAS LASR Analytic Server. See “Metadata Server Options” on page 478.
**How to Access the Export and Register Tables dialog box**

To access the Export and Register Tables dialog box:

- With a model open, select **Model > Export and Register Tables**.
# Chapter 11
## How To: Models

Create a Model ................................................................. 78
- Open the New Model dialog box .................................... 78
- Step 1: Specify Model Name, Reference, and Currency ........ 78
- Step 2: Specify Initial Period and Scenario ....................... 79
- Step 3: Select the Model Type ......................................... 80
  - Type 1: Create an Activity-Based Costing Model ............... 80
  - Type 2: Create a User-Defined Costing Model ................. 84
  - Type 3: Create a Model from Template ......................... 87

Open a Model for Editing .................................................. 91

Open a Model for Viewing .................................................. 91
- Open a Model for Viewing with No Model Open .................. 91
- Open a Model with a Model Already Open ......................... 92

Acquire or Release a Lock on a Model .................................. 93
- Overview ................................................................. 93
- Write Lock .............................................................. 93
- Read Lock ............................................................... 93

Delete a Model ............................................................... 94

Calculate Costs for a Model ............................................... 95

Change the Properties of a Model ...................................... 95

Change Model Owner or Give Access to a Model ....................... 95
- Change Model Owner .................................................. 95
- Give Access to a Model ............................................... 96

Review the Summary of a Model ......................................... 96

Copy a Model .................................................................. 97

Create a Period/Scenario Association .................................... 98

Change the Current Period/Scenario Association ....................... 98

Copy Period/Scenario Data ................................................ 98

Publish a Period/Scenario Association for a Model ................. 99

Export and Register Tables Containing Model Data .................. 99
Create a Model

Open the New Model dialog box

To create a model, do one of the following:

• Select File ⇒ New ⇒ Model from the menu bar.
• Select Create New Model from the Navigation Pane (see Chapter 4, “Navigation Pane,” on page 23).

The New Model dialog box opens. See “New Model Dialog Box” on page 67.

Step 1: Specify Model Name, Reference, and Currency

1. In the Model Name box, type the name. See “Naming Conventions” on page 43.
2. In the Reference field, type an 8-byte string. This short reference is used in public views. (See Chapter 8, “Registered Table Schemas,” in SAS Cost and Profitability Management: Data Administration Guide.) Also see “Reference Conventions” on page 48.
3. From the Select the base currency list, select a currency.
   Notice that once you select a base currency, you cannot change it later.
4. Click Next.
Step 2: Specify Initial Period and Scenario

When you create a new model, you must specify an initial period and an initial scenario for the model. The pair that you select is the initial period/scenario association for the model. Until you add other period/scenario associations to your model, all your data will reside in this initial period/scenario association.

1. From the Select the initial period list, select a period.
   
   You can do either of the following:
   
   • Select from the periods listed.
   
   • Create a new period to select by first clicking New Period. This opens the Manage Periods dialog box, which you can use to create a new period. See “Create a Period” on page 127.

2. From the Select the initial scenario list, select a scenario.
   
   You can do either of the following:
   
   • Select from the scenarios listed.
   
   • Create a new scenario to select by first clicking New Scenario. This opens the Manage Scenarios dialog box, which you can use to create a new scenario. See “Create a Scenario” on page 130.

3. Click Next.

See Also

Chapter 15, “Working with Periods and Scenarios,” on page 115
Step 3: Select the Model Type

Select the type of model to create.

**Activity-based costing model**

By default, with this type of model there are four modules: External Units, Resource, Activity, and Cost Object. You can, however, change the number of modules. See “Type 1: Create an Activity-Based Costing Model” on page 80.

**User-defined costing model**

A user-defined costing model can have from 1 to 10 modules. For each module, you can specify its name, reference, and its structural dimensions. See “Type 2: Create a User-Defined Costing Model” on page 84.

**Create a model from template**

When you create a model from a template, you provide information contained in the template to the new model. A template includes the following information:

- the model’s modules, including their order, name, and reference
- the dimensions included in each module

You can override the template information when you create a new model. See “Type 3: Create a Model from Template” on page 87.

**Type 1: Create an Activity-Based Costing Model**

**Overview**
With an Activity-Based Costing Model, there are four modules by default: External Units, Resource, Activity, and Cost Object. You can, however, change the number of modules and rename them.

For the first three steps of creating any new model, see “Create a Model” on page 78.

Step 4: Choose Default or Custom Dimensions

Choose one of the following options:

Select or define the dimensions for each module
With this option, you can:

• choose how many modules to include in the model
• rename modules
• choose what dimensions to give to each module

After clicking Next, proceed to “Step 5: Rename the Modules and Add or Remove Modules” on page 82.

Use the default module and dimension selections
With this option, your model will contain the following modules and dimensions. You can not add or remove modules, rename them, or change their dimensions.

<table>
<thead>
<tr>
<th>Module</th>
<th>Dimensions</th>
</tr>
</thead>
<tbody>
<tr>
<td>External Unit</td>
<td>Materials</td>
</tr>
<tr>
<td>Resource</td>
<td>Organization</td>
</tr>
<tr>
<td></td>
<td>General Ledger</td>
</tr>
<tr>
<td>Activity</td>
<td>Organization</td>
</tr>
<tr>
<td></td>
<td>Activities</td>
</tr>
<tr>
<td>Cost Object</td>
<td>Customers</td>
</tr>
<tr>
<td></td>
<td>Products and Services</td>
</tr>
</tbody>
</table>

Note: If you choose this option, then you have finished defining your model.
Step 5: Rename the Modules and Add or Remove Modules

You can modify the default modules by doing the following:

- Change a module name or reference by typing over it. See “Module naming conventions” on page 46.
- Click Add to add additional modules.
- Click Remove to remove a module.
- Click Move Up or Move Down to change the order of modules. The module order determines the direction of cost flow. See “Assignment Paths” on page 406.

Click Next.

Step 6: Specify Dimensions for Each Module

In the left-hand pane, click each module in turn and select its dimensions.

Note: The Next button is enabled only after you have selected the dimensions for every module.

1. From the list of Available dimensions, select a dimension, and click Add.

You can select multiple dimensions but only one dimension at a time.

2. To create a new dimension, do the following:
a. Click **New**.

The New Dimension dialog box appears. See “New Dimension Dialog Box” on page 180.

![New Dimension Dialog Box](image)

b. Type the **Name**.

The name must follow the naming conventions. See “Naming Conventions” on page 43.

c. Type the **Reference**.

A default reference is created from the dimension's name. If you change the reference, the new reference must follow the reference conventions. See “Reference Conventions” on page 48.

d. Type a **Short Reference**. The short reference is used in public views. See Chapter 8, “Registered Table Schemas,” in *SAS Cost and Profitability Management: Data Administration Guide*.

3. Click **Next**.


**Step 7: Define Dimension Attributes**

This step is optional. In addition to defining the structural dimensions whose intersections constitute the accounts in a module, you can also define dimension attributes for a model. The values of a dimension attribute (its dimension members) can be applied to the accounts in a module. A dimension attribute is available in a cube as another dimension just like the structural dimensions. A common example of a dimension attribute is Stages whose values are used to subdivide a model into temporal phases.

See also:
- “Dimension Attributes, Dimension Member Attributes, and Dimension Value Attributes” on page 246
- “Stage Attributes” on page 249

**Step 8: Review Choices and Finish**

1. Review the summary information.
2. If you need to change any information, click **Back**. All the information that you have specified is saved. Click **Next** to advance through the wizard.
3. Click **Browse** if you want to save the model as a template. A template includes the following information:
   - the model’s modules, including their order, name, and reference
   - the dimensions included in each module

   A template is an XML file that can be stored on the machine of your choice and shared with other modelers for creating new models. See “Type 3: Create a Model from Template” on page 87.
4. Click **Finish**.

   The model is created and the Dimensions page appears for you to define dimension members.

---

**Type 2: Create a User-Defined Costing Model**

**Overview**

A user-defined costing model can have from 1 to 10 modules.

For the first three steps of creating any new model, see “Create a Model” on page 78.
Step 4: Name the Modules and Add or Remove Modules

You can modify the default modules by doing the following:

- Change a module name or reference by typing over it. See “Module naming conventions” on page 46.
- Click Add to add additional modules.
- Click Remove to remove a module.
- Click Move Up or Move Down to change the order of modules. The module order determines the direction of cost flow. See “Assignment Paths” on page 406.

Click Next.

Step 5: Specify Dimensions for Each Module

In the left-hand pane, click each module in turn and select its dimensions.

Note: The Next button is enabled only after you have selected the dimensions for every module.

1. From the list of Available dimensions, select a dimension, and click Add.
You can select multiple dimensions but only one dimension at a time.

2. To create a new dimension, do the following:
   a. Click **New**.
      
      The New Dimension dialog box appears. See “New Dimension Dialog Box” on page 180.
      
      ![New Dimension Dialog Box](image)
      
      b. Type the **Name**.
         
         The name must follow the naming conventions. See “Naming Conventions” on page 43.
      
      c. Type the **Reference**.
         
         A default reference is created from the dimension's name. If you change the reference, the new reference must follow the reference conventions. See “Reference Conventions” on page 48.
      
      d. Type a **Short Reference**. The short reference is used in public views. See Chapter 8, “Registered Table Schemas,” in *SAS Cost and Profitability Management: Data Administration Guide*.

3. Click **Next**.


**Step 6: Define Dimension Attributes**

This step is optional. In addition to defining the structural dimensions whose intersections constitute the accounts in a module, you can also define dimension attributes for a model. The values of a dimension attribute (its dimension members) can be applied to the accounts in a module. A dimension attribute is available in a cube as another dimension just like the structural dimensions. A common example of a
dimension attribute is Stages whose values are used to subdivide a model into temporal phases.

See also:

- “Dimension Attributes, Dimension Member Attributes, and Dimension Value Attributes” on page 246
- “Stage Attributes” on page 249

Step 7: Review Choices and Finish

1. Review the summary information.

2. If you need to change any information, click **Back**. All the information that you have specified is saved. Click **Next** to advance through the wizard.

3. Click **Browse** if you want to save the model as a template. A template includes the following information:
   - the model’s modules, including their order, name, and reference
   - the dimensions included in each module

   A template is an XML file that can be stored on the machine of your choice and shared with other modelers for creating new models. See “Type 3: Create a Model from Template” on page 87.

4. Click **Finish**.

   The model is created and the Dimensions page appears for you to define dimension members.

**Type 3: Create a Model from Template**
When you create a model from a template, you provide information contained in the template to the new model. A template includes the following information:

- the model’s modules, including their order, name, and reference
- the dimensions included in each module

You can override the template information when you create a new model.

For the first three steps of creating any new model, see “Create a Model” on page 78.

**Step 4: Specify a Template and Modify the Modules**

1. Specify a template.

   ![Select a template](image)

   When you create a model from a template, you provide information contained in the template to the new model. A template includes the following information:

   - the model’s modules, including their order, name, and reference
   - the dimensions included in each module

2. Optionally, rename the modules and add or remove modules.

**Step 5: Specify Dimensions for Each Module**

In the left-hand pane, click each module in turn and select its dimensions.

*Note:* The **Next** button is enabled only after you have selected the dimensions for every module.
1. From the list of Available dimensions, select a dimension, and click **Add**.

   You can select multiple dimensions but only one dimension at a time.

2. To create a new dimension, do the following:
   a. Click **New**.

      The New Dimension dialog box appears. See “New Dimension Dialog Box” on page 180.

   b. Type the **Name**.

      The name must follow the naming conventions. See “Naming Conventions” on page 43.

   c. Type the **Reference**.

      A default reference is created from the dimension's name. If you change the reference, the new reference must follow the reference conventions. See “Reference Conventions” on page 48.

   d. Type a **Short Reference**. The short reference is used in public views. See Chapter 8, “Registered Table Schemas,” in *SAS Cost and Profitability Management: Data Administration Guide*.

3. Click **Next**.

Step 6: Define Dimension Attributes

This step is optional. In addition to defining the structural dimensions whose intersections constitute the accounts in a module, you can also define dimension attributes for a model. The values of a dimension attribute (its dimension members) can be applied to the accounts in a module. A dimension attribute is available in a cube as another dimension just like the structural dimensions. A common example of a dimension attribute is Stages whose values are used to subdivide a model into temporal phases.

See also:

• “Dimension Attributes, Dimension Member Attributes, and Dimension Value Attributes” on page 246
• “Stage Attributes” on page 249

Step 7: Review Choices and Finish

1. Review the summary information.
2. If you need to change any information, click Back. All the information that you have specified is saved. Click Next to advance through the wizard.
3. Click Browse if you want to save the model as a template. A template includes the following information:
   • the model’s modules, including their order, name, and reference
   • the dimensions included in each module
A template is an XML file that can be stored on the machine of your choice and shared with other modelers for creating new models. See “Type 3: Create a Model from Template” on page 87.

4. Click Finish.

The model is created and the Dimensions page appears for you to define dimension members.

---

**Open a Model for Editing**

You must acquire a write lock on the model to edit it. When you open a model for editing, no one else can edit it. However, other users can open the model for viewing. You must have a read/write access to the model to open it for editing.

To open a model for editing, in the Models tab of the Navigation pane, double-click the model. The model opens for editing with a write lock.

*Note:* If the model is already open in read mode, then you must close the model before you can acquire a write lock on it. To close the model, select Model ➔ Close Model and Release Lock from the open model.

---

**Open a Model for Viewing**

How you open a model depends on whether no model is open or whether a model is already open and you want to open a different one.

**Open a Model for Viewing with No Model Open**

Even though a user (with a write lock) is editing a model, multiple users can open the model simultaneously for viewing.

If no model is open:

1. Click the Models tab in the Navigation Pane. (See Chapter 4, “Navigation Pane,” on page 23.)

   ![Navigation Pane](image)

   *Note:* You can also click the Workspace Manager tab and then select the Models folder.
2. If you have only read access to the model, double-click the model in the list of models.

If you have read/write access to the model, right-click the model in the list of models and select **Open with Read Lock**.

**Note:** To close the model and thereby release the read lock, you can do any of the following:

- In the **Workspace Manager**, right-click the model and select **Release Read Lock**.
- Select **Model ⇒ Close Model and Release Lock**.
- Acquire read lock on a different model.
- Close the client application.

See “Acquire or Release a Lock on a Model” on page 93.

---

**Open a Model with a Model Already Open**

Even though a user (with a write lock) is editing a model, multiple users can open the model simultaneously in read mode for viewing.

If a model is already open and you want to open a different model, do one of the following:

- Select a model from the **Model** drop-down list, and select a period and scenario from the **Period/Scenario** drop-down list, and then click the arrow icon.

If you do not see the model that you want to use, you probably do not have permission to view it.

- Click the **Go to Models Workspace** icon on the toolbar, and then select a model to open.

- Select **Model ⇒ Change Model or Context** to open a different model

**Note:** To close the model and thereby release the read lock, you can do any of the following:

- In the **Workspace Manager**, right-click the model and select **Release Read Lock**.
- Select **Model ⇒ Close Model and Release Lock**.
- Acquire read lock on a different model.
- Close the client application.

See “Acquire or Release a Lock on a Model” on page 93.
Acquire or Release a Lock on a Model

Overview

Because models are no longer stored in a database, there is no database management system to handle model access. If you want to edit a model, you must first acquire a write lock on it. If you want to view a model, you must acquire a read lock on it. Only one user can acquire a write lock on a model at a time and edit that model. However, when one user has a write lock on a model, multiple users can acquire a read lock on the model to view it.

The following describes how to open and close models for editing or viewing.

Write Lock

You must acquire a write lock on a model to edit it. When you have a write lock, no one else can acquire a write lock on the model. You must release the write lock on the model so that another user can acquire a write lock on it.

Acquire

To acquire a write lock, double-click the model in the Workspace Manager. Alternatively, right-click the model and select Open. The model opens for editing.

Note: A modeler must have read/write access to open the model with a write lock.

Release

- To release the write lock on a model, the modeler with the lock can select Model ➜ Close Model and Release Lock when the model is open. Selecting this action closes the model.

  TIP It is good practice to release the write lock on a model that you are no longer actively working on so as to free up system resources. Each write lock involves a running process that uses system memory. So, if you are not actively working on a model, it is desirable that you release its write lock to free up memory.

- The write lock that is held by a modeler is released if the modeler closes the client application. But, the write lock is not released if the modeler acquires a write lock on another model.

  Note: If you want to release a lock by closing the model or by closing the client application when an operation (such as exporting data, calculating costs, and so on) is in progress, you must cancel the operation first or wait for the operation to finish.

- An administrator or a modeler with read/write access to the model can release any user’s lock on the model by selecting Tools ➜ Model Locking Status. See “Model Locking Status Dialog Box” on page 73.

Read Lock

When you open a model for viewing, you automatically acquire a read lock on it. Multiple users can open a model with a read lock and view it simultaneously.
Acquire

- If you have read access to the model, double-click the model in the **Workspace Manager** to acquire the read lock. Alternatively, right-click the model and select **Open**.

- If you have read/write access to the model, right-click the model in the **Workspace Manager** and then select **Open with Read Lock** to acquire the read lock on the model.

Release

- To release the read lock on a model, the modeler with the read lock can do any of the following:
  - In the **Workspace Manager**, right-click the model and select **Release Read Lock**.
  - Select **Model ➤ Close Model and Release Lock**.
  - Acquire a read lock on a different model.
  - Close the client application.

  *Note:* If you want to release a lock by closing the model or by closing the client application when an operation (such as exporting data, calculating costs, and so on) is in progress, you must cancel the operation first or wait for the operation to finish.

- An administrator or a modeler with read/write access to the model can release the lock on the model by selecting **Tools ➤ Model Locking Status**. See “Model Locking Status Dialog Box” on page 73.

**See Also**

“Model Locking Status Dialog Box” on page 73

---

**Delete a Model**

1. In the Models Workspace, right-click a model and select **Delete**.

   *Note:* Depending on your permissions, **Delete** might not be available.

2. In the confirmation dialog box, click **Yes**.

3. In the Delete Model dialog box, select the following check boxes:

   - **Delete the cube (if any) for the selected model** Select this check box to delete the cubes that are generated for the selected model.

   - **Delete the database tables (if any) that contained model data for reporting** Select this check box to delete the database tables that are created to export the model data for reporting. If the model data is exported to the default database, SAS Cost and Profitability Management deletes those default database tables. If the model data is exported to any database other than the default database, SAS Cost and Profitability Management does not delete those database tables.

4. Click **OK**.
Calculate Costs for a Model

Select Model ➔ Calculate Costs.

The Calculate Costs dialog box appears.

See Also

- “Calculate Costs Dialog Box” on page 533
- Chapter 59, “Calculating Costs,” on page 499

Change the Properties of a Model

Select Model ➔ Properties.

The Model Properties dialog box appears.

See Also

“Model Properties Dialog Box” on page 68

Change Model Owner or Give Access to a Model

Change Model Owner

When a model or other workspace item is created, the creator becomes the item owner. However, the owner (or an administrator) can transfer ownership of the item to another user.

1. Select the item Workspace Manager and select Edit ➔ Item Properties.
2. Select a new owner from the drop-down list of users.

![Change owner](image)
Give Access to a Model

The owner of a model or other workspace item (or an administrator) can grant Read or Read/Write access to the item to members of a group. To grant access to the item:

1. Select the workspace item.
2. Right-click and select Item Properties (or select Edit ⇒ Item Properties).
3. Click the Permissions tab.
4. Grant Read or Read/Write access to the desired groups. (Only groups are listed—not roles.)

![Item Properties dialog box](image)

- **Click Permissions**
- **Assign permissions to members of a group**

Review the Summary of a Model

Select Model ⇒ Summary.

The Model Summary window appears with information concerning the model such as the number of its drivers and assignments.
Copy a Model

Before making major changes to a model, you can make a copy of the model that you can refer to, or revert to, later on.

To copy a model:

1. Go to the Workspace Manager.
2. Select the model that you want to copy, and then select \texttt{Edit \Rightarrow Copy} (or, right-click the model and select \texttt{Copy}).
3. Select the directory in which you want to place the model. Then select \texttt{Edit \Rightarrow Paste} (or right-click the directory and select \texttt{Paste}). The Paste Model dialog box opens.
4. If the model that you want to copy was previously calculated and fact tables were generated, then you can include the calculated data and fact tables along with the model. If you choose to copy the fact table, then the calculated data is automatically included. Choose none, one, or both of the following options:

- Include Calculated data
- Include FACT Tables

Whereas models that you export and re-import must be recalculated and their fact tables regenerated, models that you copy do not require those steps.

---

**Create a Period/Scenario Association**

See “Create a Period/Scenario Association” on page 143.

---

**Change the Current Period/Scenario Association**

See “Change the Current Period/Scenario Association” on page 145.

---

**Copy Period/Scenario Data**

See “Copy Model Data from One Period/Scenario to Another” on page 145.
Publish a Period/Scenario Association for a Model

Publish a period/scenario association so that it can no longer be modified and can be viewed by anyone with View Model capability. See “Publish a Period/Scenario Association for a Model” on page 148.

Export and Register Tables Containing Model Data

To export database tables that describe a model’s structure and which are registered in the SAS Management Console for use with other SAS or non-SAS programs, select Model Ξ Export and Register Tables.

See Also

- “Export and Register Tables Dialog Box” on page 75
Part 4

Currencies

Chapter 12  
*Working with Currencies*  
103

Chapter 13  
*Windows for Currencies*  
105

Chapter 14  
*How To: Currencies*  
109
Chapter 12

Working with Currencies

Overview

A currency represents a unique monetary system that is identified by a name and by a three-letter code (currency code).

You can display a model's costs in more than one currency simultaneously. However, you must first define the currencies and their exchange rates. SAS Cost and Profitability Management can display a model's costs in whatever currency you select, using the exchange rate that is associated with each currency.

When you create a model, you can select the base currency that you want to use for calculating the model costs. SAS Cost and Profitability Management saves the base currency with the model.

**Note:** Once you set a model's base currency, you cannot change it later.

See Also

Chapter 14, “How To: Currencies,” on page 109

Windows Currency Settings

The Windows Regional Options for your computer let you set your locale, which affects only the display of currency on your computer. A locale is a group of language settings that you want to use on your computer. You can accept the default values for the selected locale's number of digits after the decimal, or you can select a different value from a list for that locale.

**Note:** The base currency determines the currency symbol. Windows Regional Options do not affect the currency symbol.
Exchange Rates

An exchange rate is a multiplier that is used to convert values from one currency to another. You enter exchange rates in an exchange rates table. Because exchange rates tables are shared by all the models on the same SAS Cost and Profitability Management server, you can compare costs between models.

When you enter an exchange rate in an exchange rates table, the exchange rate's corresponding multiplier is automatically entered. After entering an exchange rate, you can change it.

You can easily add all the euro exchange rates at once. After adding the default euro exchange rates, you can change them. If a period is before 1999, the euro currency is not available.

Exchange rates can vary from one period/scenario association to another period/scenario association. To add exchange rates quickly, you can copy an exchange rates table from one period/scenario association to another period/scenario association.

The display precision that you see in an exchange rates table is determined by the Rates value in the Options dialog box.

See Also

- “CurrencyRate table” in Chapter 6 of SAS Cost and Profitability Management: Data Administration Guide
- “Currency Codes” in Chapter 6 of SAS Cost and Profitability Management: Data Administration Guide

Selecting Currencies for an Exchange Rates Table

A currency is not the same as a locale. A locale can support multiple currencies. For example, you can use Windows to set the locale to United Kingdom. In SAS Cost and Profitability Management, you can format a unit cost column for Pound Sterling with a currency of Pound Sterling (GBP) and add a column and format it with a currency of euro.

All currencies are available for you to specify in an exchange rates table. You add the currencies that you want to use.

See Also

- “CurrencyRate table” in Chapter 6 of SAS Cost and Profitability Management: Data Administration Guide
- “Currency Codes” in Chapter 6 of SAS Cost and Profitability Management: Data Administration Guide
Chapter 13
Windows for Currencies

Manage Exchange Rates Dialog Box

About the Manage Exchange Rates Dialog Box
In the Manage Exchange Rates dialog box, you can set up exchange rates between currencies.

Add/Remove Currencies Dialog Box

About the Add/Remove Currencies Dialog Box

Copy Rates From Dialog Box

About the Copy Rates From Dialog Box
Note: You can open the Manage Exchange Rates dialog box without first opening a model.

The availability of this feature depends on your permissions.

How to Access the Manage Exchange Rates Dialog Box

Select Tools \(\Rightarrow\) Manage Exchange Rates.

See Also

Chapter 14, “How To: Currencies,” on page 109

Add/Remove Currencies Dialog Box

About the Add/Remove Currencies Dialog Box

The availability of these features depends on your permissions.

In the Add/Remove Currencies dialog box, you can manage currencies before you define exchange rates.

How to Access the Add/Remove Currencies Dialog Box

In the Manage Exchange Rates dialog box, click the Add/remove currency link.

See Also

“Manage Exchange Rates Dialog Box” on page 105

See Also

Chapter 14, “How To: Currencies,” on page 109
Copy Rates From Dialog Box

**About the Copy Rates From Dialog Box**

In the Copy Rates From dialog box, you can copy an exchange rates table from one period/scenario association to another period/scenario association.

![Copy Rates From Dialog Box](image)

The availability of this feature depends on your permissions.

**How to Access the Copy Rates From Dialog Box**

In the Manage Exchange Rates dialog box, select **Copy rate table from**.

**See Also**

“Manage Exchange Rates Dialog Box” on page 105
Add a Currency

   The Manage Exchange Rates dialog box appears.

2. Click the Add/remove currency link.
   The Add/Remove Currencies dialog box appears.
3. In the Available currencies list, select one or more currencies. To select more than one currency, use standard Microsoft Windows selection techniques.

4. Click >.

The currency is added to the Selected currencies list.

*Note:* To add all currencies, click >>.

---

**Set up Multiple Currencies**

You can follow these steps to set up currencies for all the models on a SAS Cost and Profitability Management server.


2. Set up exchange rates in an exchange rates table. See “Set up an Exchange Rates Table” on page 111.

3. (Optional) Add columns and change the column formats to one of the added currencies. See “Currency Formatting” on page 319.

---

**Copy an Exchange Rates Table**


   The Manage Exchange Rates dialog box appears.

2. Click the Copy rate table from link.

   The Copy Rates From dialog box appears.
3. Select the **Period/Scenario** association that has the exchange rates table that you want to copy.

---

### Set up an Exchange Rates Table

1. In the Manage Exchange Rates dialog, Select a Period and Scenario.

2. (Optional) Click the **Add/remove currency** link.

   The Add/Remove Currencies dialog box appears.

3. In the Rate table, click on the intersection between two currencies, and type an exchange rate.

4. Repeat the previous step for each exchange rate.

5. (Optional) Add euro exchange rates.
Add Euro Exchange Rates

1. In the Manage Exchange Rates dialog box, click **Save changes**.
   Before you can add euro exchange rates, you must save any changes to the exchange rates table.

2. Add the currency named euro:
   a. Click **Add/remove currency**.
      The Add/Remove Currencies dialog box appears.
   b. Select the currency named euro.
   c. Select the **Show Euro member currencies** option.

See Also

- “Add/Remove Currencies Dialog Box” on page 106
- “Add Euro Exchange Rates” on page 112

Copy an Exchange Rates Table

In the Manage Exchange Rates dialog box, click **Copy rate table from**

The Copy Rates From dialog box appears.

See Also

- “Manage Exchange Rates Dialog Box” on page 105
- “Copy Rates From Dialog Box” on page 107
Part 5

Periods and Scenarios

Chapter 15
Working with Periods and Scenarios ........................................ 115

Chapter 16
Windows for Periods and Scenarios ........................................ 119

Chapter 17
How To: Periods and Scenarios ............................................. 127
Chapter 15

Working with Periods and Scenarios

About Periods and Scenarios

SAS Cost and Profitability Management stores information for specific amounts of time (periods) and for specific sets of data (scenarios).

Note: The structure of a model is based on periods. Therefore, if you change the period/scenario association for a model, the model structure might change. In fact, the entire model structure might disappear if the period/scenario association contains no structure data.

Periods

A period can represent any number of days: a month, a quarter, a year, and so on. For example, if your organization chooses to enter data each month, then the marketing payroll cost is the amount of payroll for one month.

Period Levels

You can create a hierarchy of periods, such as FY2003 > Q1 > January. By default, each level is given a name such as Period L1. However, these names are not descriptive when you generate cubes. So, you can name a period level.
Scenarios

Scenarios are used for managing different variations of data within a period. A scenario can be any set of data: actual data, budget data, aggressive plan data, conservative plan data, and so on. The default scenarios are Actual and Budget. Some scenarios can be agreed upon and can be set up before people start to use SAS Cost and Profitability Management. Other scenarios can be created when they are needed. That is, not all scenarios can be anticipated by an organization. Your organization might want to develop guidelines for naming and organizing scenarios in a hierarchy so that the list of scenarios on a server does not become unmanageable.

Scenario Levels

You can create a hierarchy of scenarios, such as Budget > Aggressive. By default, each level is given a name such as Scenario L1. However, these names are not descriptive when you generate cubes. So, you can name a scenario level.

Setting up Periods and Scenarios

Periods and scenarios are shared by all the models on the same server. Therefore, before people start to use SAS Cost and Profitability Management, your organization might want to set up a period hierarchy, and you might want to publish guidelines for defining scenarios. On the OLAP Analyzer view, SAS Cost and Profitability Management automatically rolls up values for each period and scenario that is in the hierarchy above the hierarchy level that contains data.

See Also

Chapter 17, “How To: Periods and Scenarios,” on page 127

Periods and Scenarios in OLAP Analysis

Periods and scenarios are dimensions and can be used by business users for OLAP analysis. Periods and scenarios can aggregate data or separate data. For example, suppose that a model contains actual cost data for the first three months of 2005 in the following period/scenario associations: Jan 2005/ACTUAL, Feb 2005/ACTUAL, and Mar 2005/ACTUAL. When the OLAP cubes are generated and all period/scenario associations are included in an OLAP cube, business users can analyze the data in several ways on the OLAP view. For example, business users can aggregate the costs by month and then by category, as shown in the following figure of the Cube Explorer View:
Or, business users can aggregate the costs by category and then by month, as shown in the following figure:

Using combinations of periods and scenarios, business users can achieve many of their analysis goals.
# Chapter 16

Windows for Periods and Scenarios

<table>
<thead>
<tr>
<th>Dialog Box</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manage Periods Dialog Box</td>
<td>120</td>
</tr>
<tr>
<td>About the Manage Periods Dialog Box</td>
<td>120</td>
</tr>
<tr>
<td>How to Access the Manage Periods Dialog Box</td>
<td>120</td>
</tr>
<tr>
<td>New Period Dialog Box</td>
<td>121</td>
</tr>
<tr>
<td>About the New Period Dialog Box</td>
<td>121</td>
</tr>
<tr>
<td>How to Access the New Period Dialog Box</td>
<td>121</td>
</tr>
<tr>
<td>Period Properties Dialog Box</td>
<td>121</td>
</tr>
<tr>
<td>About the Period Properties Dialog Box</td>
<td>121</td>
</tr>
<tr>
<td>How to Access the Period Properties Dialog Box</td>
<td>122</td>
</tr>
<tr>
<td>Period Level Names Dialog Box</td>
<td>122</td>
</tr>
<tr>
<td>About the Period Level Names Dialog Box</td>
<td>122</td>
</tr>
<tr>
<td>How to Access the Period Level Names Dialog Box</td>
<td>123</td>
</tr>
<tr>
<td>Manage Scenarios Dialog Box</td>
<td>123</td>
</tr>
<tr>
<td>About the Manage Scenarios Dialog Box</td>
<td>123</td>
</tr>
<tr>
<td>How to Access the Manage Scenarios Dialog Box</td>
<td>123</td>
</tr>
<tr>
<td>New Scenario Dialog Box</td>
<td>124</td>
</tr>
<tr>
<td>About the New Scenario Dialog Box</td>
<td>124</td>
</tr>
<tr>
<td>How to Access the New Scenario Dialog Box</td>
<td>124</td>
</tr>
<tr>
<td>Scenario Properties Dialog Box</td>
<td>124</td>
</tr>
<tr>
<td>About the Scenario Properties Dialog Box</td>
<td>124</td>
</tr>
<tr>
<td>How to Access the Scenario Properties Dialog Box</td>
<td>125</td>
</tr>
<tr>
<td>Scenario Level Names Dialog Box</td>
<td>125</td>
</tr>
<tr>
<td>About the Scenario Level Names Dialog Box</td>
<td>125</td>
</tr>
<tr>
<td>How to Access the Scenario Level Names Dialog Box</td>
<td>126</td>
</tr>
</tbody>
</table>
Manage Periods Dialog Box

About the Manage Periods Dialog Box

In the Manage Periods dialog box, you can:

- “Create a Period” on page 127
- “Delete a Period” on page 129
- “Manage Period Level Names” on page 129

The availability of this feature depends on your permissions.

Note: You can use the Manage Periods dialog box without first opening a model.

TIP If a row is highlighted, the dates for the period are outside the date range for the parent period. This situation can occur when data is imported. Correct the dates for the highlighted period.

TIP You can widen the columns by dragging the column separators.

Use the Manage Periods dialog box to perform the following tasks:

How to Access the Manage Periods Dialog Box

Do one of the following:

- Select Tools ⇒ Manage Periods .
- In the Associate Periods and Scenarios dialog box, click New Period.

See Also

- Chapter 15, “Working with Periods and Scenarios,” on page 115
- “Create a Period/Scenario Association” on page 143
- “Change the Current Period/Scenario Association” on page 145
New Period Dialog Box

About the New Period Dialog Box

In the New Period dialog box, you can name a new period and you can specify other information about the period.

<table>
<thead>
<tr>
<th>Name:</th>
<th>New Period</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reference:</td>
<td>New Period</td>
</tr>
<tr>
<td>Start date:</td>
<td>1/1/2013</td>
</tr>
<tr>
<td>End date:</td>
<td>12/31/2013</td>
</tr>
<tr>
<td>Description:</td>
<td></td>
</tr>
</tbody>
</table>

Note: The availability of these features depends on your permissions.

How to Access the New Period Dialog Box

Do one of the following:

- In the Manage Periods dialog box, click New.
- In the Associate Periods and Scenarios dialog box, click New Period.

See Also

- Chapter 15, “Working with Periods and Scenarios,” on page 115
- “Create a Period” on page 127
- “Associate Periods and Scenarios Dialog Box” on page 138

Period Properties Dialog Box

About the Period Properties Dialog Box

In the Period Properties dialog box, you can review or change a period's properties.
Note: The availability of these features depends on your permissions.

**How to Access the Period Properties Dialog Box**

In the Manage Periods dialog box, select a period and click Properties.

**See Also**

Chapter 15, “Working with Periods and Scenarios,” on page 115

---

**Period Level Names Dialog Box**

**About the Period Level Names Dialog Box**

In the Period Level Names dialog box, you can name period levels.

Note: The availability of these features depends on your permissions.
How to Access the Period Level Names Dialog Box

In the Manage Periods dialog box, select a period and click Levels.

See Also

“Manage Period Level Names” on page 129

Manage Scenarios Dialog Box

About the Manage Scenarios Dialog Box

In the Manage Scenarios dialog box, you can:

• “Create a Scenario” on page 130
• “Delete a Scenario” on page 131
• “Manage Scenario Level Names” on page 131

Note: You can perform the following tasks without first opening a model.

Note: The availability of these features depends on your permissions.

How to Access the Manage Scenarios Dialog Box

Do one of the following:

• Select Tools ⇒ Manage Scenarios.
• In the Associate Periods and Scenarios dialog box, click New Scenario.
New Scenario Dialog Box

About the New Scenario Dialog Box

In the New Scenario dialog box, you can name a new scenario and you can specify other information about the scenario.

Note: The availability of these features depends on your permissions.

How to Access the New Scenario Dialog Box

Do one of the following:

- In the Manage Scenarios dialog box, click New.
- In the Associate Periods and Scenarios dialog box, click New.

See Also

- “Create a Scenario” on page 130
- Chapter 15, “Working with Periods and Scenarios,” on page 115

Scenario Properties Dialog Box

About the Scenario Properties Dialog Box

In the Scenario Properties dialog box, you can review or change a scenario's properties.
Note: The availability of these features depends on your permissions.

**How to Access the Scenario Properties Dialog Box**

In the Manage Scenarios dialog box, select a scenario and click **Properties**.

**See Also**

- Chapter 15, “Working with Periods and Scenarios,” on page 115
- Chapter 17, “How To: Periods and Scenarios,” on page 127

---

**Scenario Level Names Dialog Box**

**About the Scenario Level Names Dialog Box**

In the Scenario Level Names dialog box, you can name scenario levels.

The availability of these features depends on your permissions.
How to Access the Scenario Level Names Dialog Box

From the Manage Scenarios dialog box, click Levels.

See Also

“Manage Scenario Level Names” on page 131
Chapter 17
How To: Periods and Scenarios

Create a Period

1. Select Tools ➪ Manage Periods.

The Manage Periods dialog box appears.

2. Do one of the following:
   - To create a brand new period, select All Periods.
To create a sub-period under an existing period, select the period under which to create the new period.

3. Click **New**.

The New Period dialog box appears.

4. Type the **Name**.

The name must follow the naming conventions. See “Naming Conventions” on page 43.

5. Type the **Reference**.

A default reference is created from the period's name. If you change the reference, the new reference must follow the reference conventions. See “Reference Conventions” on page 48.

6. Type the **Start date** and the **End date**, or select dates from the drop-down calendar.

When you define a period, you specify its start date and its end date. These dates are useful to people in your organization and do not affect the data.

- The duration of the period must be at least one day.
- The start date can be no earlier than January 1, 1980.
- The end date can be no later than December 31, 2029.

A period must meet these criteria:

Periods that are at the same level in the hierarchy must meet these criteria:

- The periods must be sequential, with no overlapping dates.
- Each period must be within the date range of the period that is at the next higher level.
7. Type the Description.

See Also

“New Period Dialog Box” on page 121

Delete a Period

1. If the period is part of a period/scenario association in a model, delete the period/scenario association from that model.

2. Select the period from the Period column of the Manage Periods dialog box.

3. Click Delete.

Manage Period Level Names

1. Select Tools ➞ Manage Periods.

   The Manage Periods dialog box appears.

   ![](Manage_Periods.png)

2. From the Period column, select a period.

3. Click Levels.

   The Period Level Names dialog box appears.
4. In the **New level name** column, double-click in a row and type a name. The name must follow the naming conventions. See “Naming Conventions” on page 43.

**See Also**

“Period Level Names Dialog Box” on page 122

---

**Create a Scenario**

1. Select **Tools ⇒ Manage Scenarios**.

   The Manage Scenarios dialog box appears.

   ![Manage Scenarios dialog box](image)

   2. From the **Scenario** column, select a scenario under which to create the new scenario.
3. Click **New**.
The New Scenario dialog box appears.

![New Scenario dialog box](image)

4. Type the **Name**.
The name must follow the naming conventions. See “Naming Conventions” on page 43.

5. Type the **Reference**.
A default reference is created from the scenario's name. If you change the reference, the new reference must follow the reference conventions. See “Reference Conventions” on page 48.

6. Type the **Description**.

**See Also**

- Chapter 15, “Working with Periods and Scenarios,” on page 115
- “New Scenario Dialog Box” on page 124

---

**Delete a Scenario**

1. If the scenario is part of a period/scenario association in a model, delete the period/scenario association from that model.

2. Select the scenario from the **Scenario** column of the Manage Scenarios dialog box.

3. Click **Delete**.

---

**Manage Scenario Level Names**

1. Select **Tools ⇒ Manage Scenarios**.
The Manage Scenarios dialog box appears.
2. From the Scenario column, select a scenario.

3. Click Levels.

The Scenario Level Names dialog box appears.

4. In the New level name column, double-click in a row and type a name.

The name must follow the naming conventions. See “Naming Conventions” on page 43.

See Also

- “Scenario Level Names Dialog Box” on page 125
- “Scenario Level Names Dialog Box” on page 125
Part 6

Period and Scenario Associations

Chapter 18
  Working with Period and Scenario Associations . . . . . . . . . . . . . . . . . . 135

Chapter 19
  Windows for Period and Scenario Associations . . . . . . . . . . . . . . . . . . 137

Chapter 20
  How To: Period and Scenario Associations . . . . . . . . . . . . . . . . . . . . . 143
Chapter 18
Working with Period and Scenario Associations

About Period/Scenario Associations
A period/scenario association identifies a specific period, such as Q1, and a specific scenario, such as Budget. All model data must reside in a period and must pertain to a scenario. An association represents a period-scenario pair.

Depending on your permissions, the Period/Scenario menu lists in SAS Cost and Profitability Management may show only associations that have been published.

Calculation Status of Associations
The calculation status of a period/scenario association indicates whether the data in the association is complete and accurate. A calculation status can be either Not calculated or Calculated.

Status of Associations
A period/scenario association can be either Not published or Published.

By default, a period/scenario association is Not published. The data is not ready for the general viewer to see because the data is in the process of being entered.

When the data for a period/scenario association is entered and calculated, the association is published. This enables the general user to see and analyze the data in that period/scenario association.

Note: As long as a period/scenario association has a status of Published, the data within the association cannot be edited.
Typically, an association is published at the end of a period, such as at the end of a fiscal quarter.

---

**Copying Data from One Association to Another**

You can copy data from one period/scenario association to another period/scenario association. The ability to copy data enables you to propagate association data to similar periods and/or to similar period/scenario associations.

See “Copy Model Data from One Period/Scenario to Another” on page 145.
Chapter 19
Windows for Period and Scenario Associations

Period and Scenario Associations View... 137
   About the Period and Scenario Associations View... 137
   How to Access the Period and Scenario Associations View... 138
Associate Periods and Scenarios Dialog Box... 138
   About the Associate Periods and Scenarios Dialog Box... 138
   How to Access the Associate Periods and Scenarios Dialog Box... 139
Period/Scenario Association Properties Dialog Box... 139
   About the Period/Scenario Association Properties Dialog Box... 139
   How to Access the Period/Scenario Association Properties Dialog Box... 140
Copy Period/Scenario Data Dialog Box... 140
   About the Copy Period/Scenario Data Dialog Box... 140
   How to Access the Copy Period/Scenario Data Dialog Box... 141

Period and Scenario Associations View

About the Period and Scenario Associations View

The availability of this feature depends on your permissions.

On the Period and Scenario Associations view, you can create new period/scenario associations, publish period/scenario associations, and generally manage the period/scenario associations for a model.

The period/scenario association that is open is indicated by a check in the first column:
Status
Published or Not published. See “Publish a Period/Scenario Association for a Model” on page 148.

Calculate Status
Calculated or Not calculated.

How to Access the Period and Scenario Associations View
Open a model and select Model ⇒ Period and Scenario Associations.

See Also
- Chapter 15, “Working with Periods and Scenarios,” on page 115
- “Associate Periods and Scenarios Dialog Box” on page 138
- “Create a Period/Scenario Association” on page 143
- “Change the Current Period/Scenario Association” on page 145
- “Copy Model Data from One Period/Scenario to Another” on page 145
- “Publish a Period/Scenario Association for a Model” on page 148

Associate Periods and Scenarios Dialog Box

About the Associate Periods and Scenarios Dialog Box
In the Associate Periods and Scenarios dialog box, you can associate periods and scenarios.

![Associate Periods and Scenarios Dialog Box](image)
How to Access the Associate Periods and Scenarios Dialog Box

Do either of the following:

• From the task list of the Period/Scenario Associations view, click **Associate Period–Scenario**.

• On the Period/Scenario Associations view, select a period/scenario association, and then select **Edit ➔ New Association**.

See Also

• Chapter 15, “Working with Periods and Scenarios,” on page 115
• “Create a Period/Scenario Association” on page 143
• “Change the Current Period/Scenario Association” on page 145

---

**Period/Scenario Association Properties Dialog Box**

*About the Period/Scenario Association Properties Dialog Box*

In the Period/Scenario Association Properties dialog box, you mark a period/scenario association as published or not published, and you can add notes to the association.
Note: The availability of these features depends on your permissions.

**How to Access the Period/Scenario Association Properties Dialog Box**

On the Period and scenario associations view, select an association and select **Edit** ⇒ **Item Properties**.

**See Also**

“Period and Scenario Associations View” on page 137

---

**Copy Period/Scenario Data Dialog Box**

About the Copy Period/Scenario Data Dialog Box

Use the Copy Period/Scenario Data dialog box to copy model data from one Period/Scenario association to another.
For information, see “Copy Model Data from One Period/Scenario to Another” on page 145.

**How to Access the Copy Period/Scenario Data Dialog Box**

1. Acquire a write lock on a model and open the model.
2. Select **Model ⇒ Copy Period/Scenario Data**.
   The Copy Period/Scenario Data dialog box appears.

**See Also**

- “Copy Model Data from One Period/Scenario to Another” on page 145
- “Create a Period/Scenario Association” on page 143
- “Change the Current Period/Scenario Association” on page 145
Chapter 20
How To: Period and Scenario Associations

Create a Period/Scenario Association
Introduction......................................................................................................................... 143
While Creating a New Model ............................................................................................. 143
While Editing an Existing Model ...................................................................................... 144
Change the Current Period/Scenario Association .......................................................... 145
Copy Model Data from One Period/Scenario to Another ................................................ 145
Publish a Period/Scenario Association for a Model ......................................................... 148
Overview ......................................................................................................................... 148
How to Publish ................................................................................................................ 148
Change the Properties of a Period/Scenario Association ................................................ 149
Delete a Period/Scenario Association ............................................................................. 149

Create a Period/Scenario Association

Introduction
You can create a period/scenario association in two ways:
• while creating a new model
• while editing an existing model

See Also
• Chapter 15, “Working with Periods and Scenarios,” on page 115
• “Associate Periods and Scenarios Dialog Box” on page 138
• “Change the Current Period/Scenario Association” on page 145

While Creating a New Model
When you create a new model, you must specify an initial period and an initial scenario for the model. The pair that you select is the initial period/scenario association for the model. See “Step 2: Specify Initial Period and Scenario” on page 79.
While Editing an Existing Model

Do the following to create a new period/scenario association for the model that is currently open:

1. Select **Tools ⇒ Period and Scenario Associations**.
   The Period and scenario associations page appears.

2. Select **Edit ⇒ New Association**.
   The Associate Periods and Scenarios dialog box appears.

3. Select the **Period**. To create a new period, do the following:
   a. Click **New Period**.
      The Manage Periods dialog box appears. Create a new period as described in the Create a Period section.
   b. Select the **Period**.

4. Select the **Scenario**. To create a new scenario, do the following:
   a. Click **New Scenario**.
      The Manage Scenarios dialog box appears. Create the scenario as described in the Create a Scenario section.
   b. Select the **Scenario**.

5. Type **Notes** for the association.
Change the Current Period/Scenario Association

The current period/scenario association is the period and scenario to which costs are assigned when you add costs to a model.

To change the current period/scenario association, select from the period/scenario drop-down list on the Resource, Activity, Cost Object, or External Object view of an open model and click the arrow button.

The current period is indicated by a check mark on the Period and Scenario Association view.

To open the Period and Scenario Association view, open a model and select Model ⇒ Period and Scenario Association view.

See Also

- Chapter 15, “Working with Periods and Scenarios,” on page 115
- “Associate Periods and Scenarios Dialog Box” on page 138
- “Period and Scenario Associations View” on page 137

Copy Model Data from One Period/Scenario to Another

1. Acquire a write lock on a model and open the model.
2. Select Model ⇒ Copy Period/Scenario Data.
   The Copy Period/Scenario Data dialog box appears.
3. Select a source **Period/scenario** association.

4. For the target period/scenario association, do one of the following:
   
a. Select the **Existing period/scenario association** option, and then select a period/scenario association from the drop-down list of period/scenario associations already belonging to the model.
   
b. Select the **New period/scenario association** option, and then select a target period/scenario association to be added to the model.

   Then, click **Next**.

5. Specify what values are to be copied for accounts and whether the values for entered cost element are to be copied.

6. Specify what assignment information you want to copy.

   You can select for which modules (as source modules) assignments are copied. And, for selected modules, you can select for which drivers information is to be copied.
Then, click Next.

7. Specify what attribute information you want to copy.

You can select which attribute associations are copied along with their attribute values.

Then, click Next.

8. Review your selections, and then click Finish.
Publish a Period/Scenario Association for a Model

Overview

Publishing a period/scenario association makes it available for viewing by anyone with View Model capability.

If a period/scenario association is published, then you cannot modify any periodic element belonging to that period/scenario association.

If a period/scenario association is published, then you can do the following:

• modify periodic elements belonging to other period/scenario associations in the model
• modify any structural element belonging to the model

See “Periodic and Structural Elements” on page 53.

How to Publish

To publish a period/scenario association:
1. Select Model ⇒ Period and Scenario Associations.
   
   The Period and scenario associations page appears.
2. Select a period/scenario association.
Or right-click a period/scenario association, and select **Publish/Unpublish**.

---

**See Also**

“Period and Scenario Associations View” on page 137

---

**Change the Properties of a Period/Scenario Association**

1. Select a period/scenario association.
2. Select **Edit ➤ Item Properties**.
   
   The Period/Scenario Association Properties dialog box appears.

---

**Delete a Period/Scenario Association**

1. Select a period/scenario association.
2. Select **Edit ➤ Delete**.
Part 7

Modules

Chapter 21
  *Working with Modules* .................................................. 153

Chapter 22
  *Windows for Modules* .................................................. 161

Chapter 23
  *How To: Modules* .......................................................... 163
Chapter 21
Working with Modules

Introduction to Modules

What Is a Module?

Each module contains a set of accounts. The set of modules forms an ordered set—a set of sets of accounts. The set of modules is an ordered set because it determines the direction of cost flow in a model:

- An account in one module can flow costs to any other account (including itself) in the same module.
- An account in one module can flow costs to any other account in any module after its own module in the direction determined by the ordered set of modules.
- For more information on the direction of cost flow, see “Assignment Paths” on page 406.

Each module is displayed in its own view.
If a model is not a complete Cost and Profitability costing implementation, you are not required to use all of the available modules when building the model. For example, costs can be entered directly into activities in the Activity module, assignments can be made from those activities to products in the Cost Object module, and then costs can be calculated. In this example, you do not need the Resource module.

Modules are structural elements. The modules that you define for a model exist in every period/scenario in the model.

### Column Layouts

SAS Cost and Profitability Management displays information in each module in user-defined columns in a grid. You can add or remove columns from the grid and specify how information in the columns appears. When you are satisfied with the appearance, you can save the display configuration (called a saved column layout). At a later time, you can display the saved column layout and the columns will be displayed like they were when you saved the column layout.

*Note:* The **Display Name** column, which is the left-most column in the column layout, is required, so you cannot remove it, change it, or reorder it.

**See Also**

“What is a Column Layout?” on page 293

### References

Within each module, a reference is a unique identifier for an item, such as an account, a dimension, or a cost element.

References are similar to the account numbers or account codes in a chart of accounts and in a General Ledger; account numbers uniquely identify line items. Generally, the references for accounts and cost elements in the Resource module match the account numbers in an organization's chart of accounts.

**See Also**

“Reference Conventions” on page 48

### Guidelines for Creating Modules

Before you create the modules, consider the following:

- Start by creating the Cost Object module.
Identify the expected result and work toward it. If your organization is in the service industry, the cost objects might not be known. In this situation, start by creating the Activity module.

- Identify the departments (or branches) of your organization.

The structural dimensions for the Activity module and the Resource module depend on this knowledge. (More information is presented in the sections that address the Activity module and the Resource module.)

- Create the modules without calculating costs or generating cubes, but validate the model as you progress.

Not calculating costs or generating cubes enables you to create a model quickly and helps you to identify flaws in the model design before you spend the time calculating costs and generating cubes.

**Activity-Based Costing Modules**

*Introduction*

Activity-based costing is the basic tool of activity-based management. Two critical limitations of traditional cost accounting systems are the following:

- the inability to analyze individual product, customer, service, or process costs with a reasonable level of accuracy
- the inability to provide useful feedback to management for the purpose of operational control

When managers of complex organizations make important decisions using traditional cost accounting systems, inaccurate and/or inappropriate cost information and profitability information cause incorrect decisions. These decisions often affect such areas as pricing, product mix, resource allocations, and budgeting.

Activity-based costing more accurately tracks costs than traditional methods because activity-based costing assumes the following:

- Activities cause expenditure of resources.
- Cost objects (the results of activities or products and services produced) create the demand for activities.

Using SAS Cost and Profitability Management, one or more models can be built to apply direct and indirect organizational costs to specific activities and processes. As a result, managers are able to see actual cost assignments and their bottom-line impacts from an operational perspective. Managers get a true understanding of the cause-and-effect relationships that link resources and processes to outputs. Therefore, business planners can easily forecast resource requirements, create budgets, and optimize capacity usage.

**The Resource Module**

*Overview*

The Resource module contains information about resources, such as salaries, materials, and depreciation. Resources are the costs that are consumed by activities such as planning, introducing new line items, advertising, or promoting products. To understand
and manage resources, you should focus on activities and on how they consume resources.

Guidelines for Creating the Structural Dimensions

The typical structural dimensions in the Resource module are General Ledger and Organization. These dimensions are denoted as General Ledger x Organization.

Before you create the structural dimensions, consider the following typical dimensions, suggested dimension level names, and example dimension members.

General Ledger Dimension

The General Ledger dimension typically contains information about expense categories and individual expenses. The information for this dimension can be found in your organization's general ledger or other transactional financial system.

The General Ledger categorizes expenses into a hierarchy, an example of which is shown in the following example:

```
1xx Wages, Salaries, and Benefits
  10x Salaries and Wages
    101 Wages - Hourly
    102 Wages - Salary Non-Exempt
    103 Wages - Salary
    104 Overtime Premium
    105 Shift Differential
    106 Management Bonus
```

The lowest level of detail shown (items 101-106) is generally captured in the General Ledger for such purposes as taxes, expense analysis, reconciliation, and internal control. Although this low level of detail is necessary for financial accounting, it is usually too detailed for a SAS Cost and Profitability Management model. This level of detail is cost classification, whereas the level of detail for a model should be cost behavior.

To obtain the level of detail of cost behavior, the lowest level of detail in the General Ledger that should be used in a SAS Cost and Profitability Management model is the next higher level in the example (10x Salaries and Wages). For example:

<table>
<thead>
<tr>
<th>Dimension Level Name</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>GL Account Group</td>
<td>Wages, Salaries, and Benefits</td>
</tr>
<tr>
<td>GL Account</td>
<td>Salaries and Wages</td>
</tr>
</tbody>
</table>

If the most detailed level of the General Ledger must be in a model, you can use entered cost elements to store these costs.

Organization Dimension

The Organization dimension that is created in the Activity module can be reused here. See “Guidelines for Creating the Structural Dimensions” on page 157.

See Also

- Chapter 24, “What Are Dimensions?,” on page 169
- “New Account Dialog Box” on page 209
The Activity Module

Overview
The Activity module contains information about activities. Activities are tasks performed within an organization, such as entering the details of a customer order, operating a machine, or loading a pallet.

Activities can receive costs from resource accounts or from other activity accounts.

Guidelines for Creating Activities
When you create activities, consider these guidelines:

• An activity is a significant portion of an organization's cost (at least 5 percent of the total cost).
• Activities have the same type of process.
• An activity has one cost driver that is used for assigning product costs.
• An activity is a cost category that management is already concerned about.
• An activity involves and action or actions; it is not just an arbitrary accounting bucket.
• Ensure that all required activities are defined.
• To determine your organization's activities, conduct surveys of people in the organization.
• Create an activity only if management needs to know details about the activity to make decisions.

Methods of Organizing Activities
Use one of the following methods to organize the Activity module:

• Hierarchically by departments
  This is usually the best method.
• By process
  If you organize activities by their process, then organize the items within a rollup account either by their order in the process or by the order in which you want to report them.

To determine which method to use, consider how you want to assign costs to activities. Decide how you want to assign activity costs to cost objects. Keep in mind that you create assignments between accounts, not between rollup accounts.

Rollup accounts enable you to view the total cost of groups of related activities. For example, you can create a rollup account that groups activities in a process or that groups activities that are performed by a single department.

Guidelines for Creating the Structural Dimensions
The typical structural dimensions in the Activity module are Activities and Organization. These dimensions are denoted as Activities x Organization.

Before you create the structural dimensions, consider the following suggested dimension level names and example dimension members:
Activities Dimension
The Activities dimension typically contains information about business processes and individual activities.

A business process is a group of activities with a common outcome or output. Because activities are the building blocks of business processes, activities and business processes can be incorporated into a single structural dimension. The business processes can be created as the upper (more summary) dimension members, and the activities can be created as the lower (more detailed) dimension members. For example:

<table>
<thead>
<tr>
<th>Dimension Level Name</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Macro Process</td>
<td>Receive Packages</td>
</tr>
<tr>
<td>Process</td>
<td>Collect by Region</td>
</tr>
<tr>
<td>Activity</td>
<td>Unload Trucks</td>
</tr>
</tbody>
</table>

Organization Dimension
The Organization dimension typically contains information about the organization's structure. The information for this dimension can be found in your organization's Organizational Chart.

Each department manager is responsible for the expenses incurred by his/her department. The activity-based management model that is most useful to business users preserves the departments. Preserving each department enables each department manager to examine the activities performed in the department, the costs of those activities, and how the resources for which each manager is responsible affect the activities that he/she manages.

For example:

<table>
<thead>
<tr>
<th>Dimension Level Name</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Facility</td>
<td>North Carolina</td>
</tr>
<tr>
<td>Function</td>
<td>Manufacturing</td>
</tr>
<tr>
<td>Department</td>
<td>Inspection</td>
</tr>
</tbody>
</table>

See Also
Chapter 24, “What Are Dimensions?,” on page 169

Cost Object Module

Overview
The Cost Object module contains information about products and services. Additionally, products and services can be organized by customers, channels, regions, and so on.

Cost objects can receive costs from resources, activities, other cost objects, or any combination of these three.

Guidelines for Creating the Structural Dimensions
The typical structural dimensions in the Cost Object module are Products, Customers, and Channels. These dimensions are denoted as Product x Customer x Channel. (For
public organizations, the typical structural dimensions are Service and Region. If your organization is complex, you might need to create other dimensions.

Before you create the structural dimensions, consider the following suggested dimension level names (so that business users can examine data at various levels).

**Products Dimension**
The Products dimension typically contains information about product categories and individual products. For example:

<table>
<thead>
<tr>
<th>Dimension Level Name</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product Line</td>
<td>Shoes</td>
</tr>
<tr>
<td>Product Group</td>
<td>Summer Sandals</td>
</tr>
<tr>
<td>Product</td>
<td>Leather Weave</td>
</tr>
<tr>
<td>SKU (if needed)</td>
<td>Tan576830</td>
</tr>
</tbody>
</table>

**Customers Dimension**
The Customers dimension typically contains information about customer categories and individual customers. For example:

<table>
<thead>
<tr>
<th>Dimension Level Name</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customer Group</td>
<td>Retail</td>
</tr>
<tr>
<td>Customer Category</td>
<td>Discount</td>
</tr>
<tr>
<td>Specific Customer</td>
<td>Big Mart</td>
</tr>
<tr>
<td>Location (if needed)</td>
<td>Phoenix</td>
</tr>
</tbody>
</table>

**Channels Dimension**
The Channels dimension typically contains information about distribution channel categories and individual channels. For example:

<table>
<thead>
<tr>
<th>Dimension Level Name</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Channel Group</td>
<td>Traditional</td>
</tr>
<tr>
<td>Channel Category</td>
<td>Wholesale</td>
</tr>
<tr>
<td>Channel</td>
<td>Catalog</td>
</tr>
<tr>
<td>Channel Details (if needed)</td>
<td>Targeted Mail</td>
</tr>
</tbody>
</table>

**See Also**
- Chapter 24, “What Are Dimensions?,” on page 169
- “New Account Dialog Box” on page 209

**External Unit Module**
The External Unit module contains information about external unit cost elements. An external unit is an item, such as a part purchased from a supplier, whose cost is maintained outside of a SAS Cost and Profitability Management model, but needs to be accounted for in the model.

Like the other modules, the External Unit module can contain multiple dimensions. For example, if you obtain parts from several suppliers, you can create the dimensions...
Supplier and Part. Then, based on the availability and cost of a part, you can enter cost information for the supplier from whom you bought the part.

Suppose that your organization is a municipality that supplies garbage-collection services to residents. You can create an external unit named Tons of Garbage that has a unit cost that is the cost per ton your organization is charged to dispose of the garbage. You can enter the number of tons of garbage collected to calculate the total charge. Also, if your organization supplies bins or carts in which residents place their garbage, you can create an external unit for the cost of each bin or cart.

See Also

- Chapter 24, “What Are Dimensions?,” on page 169
- “New Account Dialog Box” on page 209
Chapter 22
Windows for Modules

Module View

About the Module View
The availability of this feature depends on your permissions.

Use the module view to view the accounts in a module and to make assignments between accounts.

How to Access the Module View
Open a model and select Model ⇒ Modules ⇒ <name of module>. For example:
Model ⇒ Modules ⇒ Cost Object.

See Also
Chapter 23, “How To: Modules,” on page 163
Chapter 23
How To: Modules

Create a Module

When you create a model, you create modules by specifying the number of modules desired, giving each one a name, and specifying their order. See “Create a Model” on page 78.

Once you have created a model, you can not change the number of modules in the model or change their order.

View a Module

To open a module view with the selected module as the primary pane, do one of the following:

• Select the module from the Navigation Pane.
Select the module from the drop-down list that is available from the Select Module icon on the tool bar.

**Working in a Module View**

**Show Assignments Panes**

See “Show Assignments Panes” on page 427.

**See Also**

“Assignments Panes” on page 407

**Make an Assignment**

See “Make an Assignment” on page 424.

**Show Assignments To and From an Account**

See “Show Assignments To and From an Account” on page 427.

**Delete Assignments**

See “Delete Assignments” on page 428.
Create an account
See “Create Accounts” on page 215.

Delete an Item
1. Select an item.
2. Select Edit ➔ Delete.

Create an Entered Cost Element
See “On an Existing Account in a Module Page” on page 240.

Go to an Account in Another Module
See “Go to an Account” on page 228.

Manage the Attributes of an Account
See “Specify an Attribute's Value” on page 286.

Edit the Column Layout
1. Select Model ➔ Column Layout ➔ Edit Columns.
   The Column Layout dialog box appears.
   TIP Alternatively, you can double-click a column heading.

2. To save the column layout, select Model ➔ Column Layout ➔ Save As.
   The Save Column Layout As dialog box appears.

See Also
• “Column Layout Dialog Box” on page 309
• “Save Column Layout As Dialog Box” on page 312

Change the Properties of an Item
1. Select an item.
2. Select Edit ➔ Item Properties.
   The Item Properties dialog box appears.
See Also

“Item (Account) Properties and Attributes Dialog Box” on page 213
Part 8

Dimensions

Chapter 24
What Are Dimensions? ............................................. 169

Chapter 25
Windows for Dimensions ........................................... 179

Chapter 26
How To: Dimensions .................................................. 185
A dimension is a category by which data can be analyzed. For example, you might want to categorize sales figures by region, by customer, and by product. Each of these categories represents a single dimension. Common dimensions are products, time, geography, customers, promotions, and sales channels.

To further illustrate, suppose that a manager says, I need to see the data items $x$, $y$, and $z$ grouped by $a$, by $b$, and by $c$. In this statement, $x$, $y$, and $z$ represent measures, and $a$, $b$, and $c$ represent dimensions. For example, perhaps the manager needs to see revenue, cost, and profit grouped by region, by customer, and by product.

Note: For information about specifications for dimensions in Microsoft Analysis Services, see the Microsoft documentation.

Dimensions are structural elements. The dimensions that you define for a model exist in every period/scenario in the model.

To present data in a manageable or interesting form, you can group items within a dimension. Each item is then at a specific level in a hierarchy.
By default, each dimension level is given a name, such as Level1. To make this name more meaningful during OLAP analysis, you can rename dimension levels. There is more information about dimension level naming conventions.

For example, in the Products dimension, you can start with product families (the dimension level named Family). You can divide product families first into product lines (the dimension level named Line), and then into stock keeping units (the dimension level named SKU).

In this example, the Products dimension has three levels below it. The levels enable you to show the measures for each level of information.

Dimension levels are a powerful modeling tool because they enable you to ask general questions and expand a dimension in order to reveal more detail. For example, you might first ask to see product costs for the past three fiscal years. You might notice that the costs for 2001 are higher than the costs for other years. You might explore levels of the Products dimension to see whether costs were high for a particular product family, product line, or SKU. This type of exploration is known as drill-down.

When you create a model, you select the dimension levels.

---

**Dimension Members**

**Overview**

Dimension members are the unique elements in the dimension levels. In the previous example, Backpacking, Frame, and Hiker are examples of dimension members.

Dimension members are structural elements. The dimension members that you define for a model exist in every period/scenario in the model.
All, No <Dimension Name>, None, and (Data) on the Module views

To understand what a Model view is showing, add a column for the Intersection Name property. The intersection name lists the dimension members in the dimension order from left to right.

In the following picture, the COST OBJECT module rollup cost represents all product costs and all customer costs. In this case, the dimension order is the Product dimension by the Customer dimension, which is often written as Product X Customer. In an intersection name, All represents all dimension members in that position in the dimension order. By looking at the intersection name (IntsectnName column), you see that the Solo Light rollup account is the intersection of the Solo Light dimension member of the Product dimension and all the dimension members of the Customer dimension (Solo Light x All). So, the Solo Light rollup account represents all of the product costs of Solo Light, which includes the costs for all customers and all other costs.

As you drill down into the COST OBJECT module rollup, you see more details about its costs. When you expand Solo Light to see its accounts, you see a No <Customer> account, which indicates costs (which are $248,253.44) that affect the total cost of the Solo Light product, but that are not directly assigned to any specific customer (such as raw materials, manufacturing, and production activities). When you look at the No <Customer> intersection name, you see that No <Customer> is the intersection of the dimension member and no customer dimension members (Solo Light x No <Customer>).

No <dimension> represents costs that are outside the identified intersections. For example, suppose that you create a model that represents your department. When you import costs from the General Ledger (which contains the costs for all departments), you can ensure that the costs of the other departments do not affect your department by putting the costs for the other departments in No <dimension>.

The other Solo Light account is LLCorn, a customer. This account's intersection name indicates that the account is the intersection of the Solo Light product and the LLCorn customer (Solo Light X LLCorn). The account's cost represents the product costs of Solo Light and the customer costs of LLCorn.
All, No <Dimension Name>, None, and (Data) in Grid View

In OLAP grid view, every dimension has the same value for the total value in the entire cube, which is shown in the All field. The All member of the dimension is not associated with any values, and the None value is used to balance the All value with values that are associated with other members in the dimension.
Structural Dimensions

Structural dimensions are the building blocks of the modules in a model. For example, the typical structural dimensions of the Resource module are region, organization, and General Ledger; the Activity module might be structured according to the region or organization dimension, along with an activity dimension. The combination of dimension members that uniquely identifies an account is its dimension signature.

Structural dimensions are basically “buckets” to model the flow of costs through your organization. However, this perspective of the costs is generally too detailed for other people in your organization. These people require a higher level of detail, such as details that are provided by attribute dimensions and OLAP analysis. Be aware that how you create the structural dimensions can greatly help users manipulate the model data into a form that suits their needs.

Note: Structural dimensions are created when you first create a model. You cannot delete structural dimensions later, and you cannot create new structural dimensions (but you can create dimension attributes). However, you can add and delete dimension members within each structural dimension.

Attribute Dimensions

Attribute dimensions are dimensions that are created whenever dimension attributes are created. You cannot explicitly create an attribute dimension. The SAS Cost and Profitability Management OLAP tool makes no distinction between attribute dimensions and structural dimensions.

See “Dimension Attributes, Dimension Member Attributes, and Dimension Value Attributes” on page 246.
Guidelines for Creating Dimensions

Before you create dimensions, consider the following points:

• There is a limit of 126 total user-defined dimensions in a model—including both structural dimensions and attribute dimensions.

• Think in terms of dimensions when you begin to plan the model, such as Who do I work for? At the highest level, it's your entire organization. This can be further refined by a geographic office (world area, country, and/or state or province), a business area (Sales or Finance), and a department (Public Sales or Accounts Payable).

A dimension signature uniquely identifies an account in the model; the dimension signature is the intersection of two or more dimensions. So, think of what dimensions are needed to uniquely identify an account.

• Dimensions help users pull apart (deconstruct) information in a model. Consider the needs of the users.

Identify a dimension by the fact that users need to have the information appear during OLAP analysis.

• Decide what required data translates into model structure or what data translates into attributes.

• After you have defined the structural dimensions, consider how to enhance the structure with attributes to support different aggregations of costs for different users.

Attribute dimensions are for users needs for analysis. Do not put these needs into the models structural dimensions because doing so creates a burden when entering model data or when revising a model.

• For better performance and easier data entry, minimize the number of dimensions.

Although a dimension intersection can include an unlimited number of dimensions, a smaller number (five or fewer) is more manageable.

• Ensure that you have a justifiable business need for every dimension or dimension level.

If you create unnecessary dimensions and dimension levels, the resulting OLAP cubes provide too much information and not enough understanding.

• To help distinguish a dimension from a dimension member, consider the following points:

• If part of a model is repeated in a single dimension (such as the General Ledger accounts of Rent-North Carolina, Rent-New York, and Rent-Kansas), then that part is probably a dimension. In this example, you provide more flexibility for OLAP analysis by creating two dimensions: one dimension for the office location and one dimension for the General Ledger expenses.

• A dimension member can be identified by whether it gives or receives costs (it is part of an assignment).

Example: Multiple Dimensions for Better Analysis

Suppose that your organization wants to model the North America region, specifically the offices in the states of North Carolina and New York. The model must store the
resource costs of personnel, operating expenses, and equipment for each of these locations.

From your perspective as model builder, you can create a single, structural dimension on the Dimensions view as shown in the following figure:

![Diagram of General Ledger and Resource module structure with example values entered]

In the Resource module, the structure looks like the following figure (with example values entered):

![Table showing Resource, Cost, and example values]

Using this structural dimension, after you build the entire model, the calculated costs are correct. Users can analyze the cost data in the OLAP Analyzer, as shown in the following figure of the Cube Explorer View:
Users can examine the costs associated with New York or North Carolina (which is not expanded in the figure). However, they cannot combine the costs of individual accounts for both North Carolina and New York. For example, users cannot examine the total cost of personnel for both North Carolina and New York.

Now, suppose that you want to allow users more flexibility during OLAP analysis, so that they can combine accounts from different office locations. You can change the previous single, structural dimension to become two dimensions, as shown in the following figure of the Dimensions view:

In the Resources module, the structure looks identical to the previous example. However, in addition to the OLAP analysis shown in the previous example, users can display the model data so that it reveals the total personnel costs for both North Carolina and New York, as shown in the following figure:
Chapter 25
Windows for Dimensions

Dimensions View

About the Dimensions View ............................................. 179
How to Access the Dimensions View ............................... 179

New Dimension Dialog Box .......................................... 180
About the New Dimension Dialog Box ............................. 180
How to Access the New Dimension Dialog Box ................. 180

Edit Dimension Dialog Box .......................................... 181
About the Edit Dimension Dialog Box ............................. 181
How to Access the Edit Dimension Dialog Box ................. 181

Dimension Properties Dialog Box ................................ 182
About the Dimension Properties Dialog Box ..................... 182
How to Access the Dimension Properties Dialog Box ........ 182

New Dimension Member Dialog Box ............................... 182
About the New Dimension Member Dialog Box ................. 182
How to Access the New Dimension Member Dialog Box ....... 182

Find Dimension Member Dialog Box ............................... 183
How to Access the Find Dimension Member Dialog Box ...... 183
Find a Dimension Member .............................................. 184

Dimension Member Properties Dialog Box ...................... 184
About the Dimension Member Properties Dialog Box ........ 184
How to Access the Dimension Member Properties Dialog Box 184

Dimensions View

About the Dimensions View

The availability of this feature depends on your permissions.

On the Dimensions view, you can manage a model's dimensions and the dimension member names.
How to Access the Dimensions View

Open a model and select Model ➔ Dimensions.

See Also

- Chapter 24, “What Are Dimensions?,” on page 169
- “Create a Dimension Member” on page 186

New Dimension Dialog Box

About the New Dimension Dialog Box

In the New Dimension dialog box, you can create a new dimension if you are creating a new model.

Note: The availability of these features depends on your permissions.

1. Click in the Name column and type the name of the new dimension.
   The name must follow the naming conventions. See “Naming Conventions” on page 43.

2. Click in the Reference column and type the reference.
   A default reference is created from the dimension’s name. If you change the reference, the new reference must follow the reference conventions. See “Reference Conventions” on page 48.

How to Access the New Dimension Dialog Box

In the New Model Wizard, when you are specifying the model's dimensions, click New.
See Also

- “New Model Dialog Box” on page 67
- Chapter 24, “What Are Dimensions?,” on page 169

Edit Dimension Dialog Box

About the Edit Dimension Dialog Box

In the Edit Dimension dialog box, you can edit information about a dimension if you are creating a new model.

The availability of this feature depends on your permissions.

How to Access the Edit Dimension Dialog Box

In the New Model Wizard, when you are specifying the dimensions in the model, select a dimension and click Edit.

See Also

- Chapter 24, “What Are Dimensions?,” on page 169
- “Dimension Properties Dialog Box” on page 182
Dimension Properties Dialog Box

**About the Dimension Properties Dialog Box**

In the Dimension Properties dialog box, you can review or change information about a dimension.

![](image)

**How to Access the Dimension Properties Dialog Box**

On the Dimensions view, select a dimension and select **Edit ➔ Item Properties**.

**See Also**

- “Edit Dimension Dialog Box” on page 181
- Chapter 24, “What Are Dimensions?,” on page 169

New Dimension Member Dialog Box

**About the New Dimension Member Dialog Box**

In the New Dimension Member dialog box, you can name a new dimension member and you can specify other information about the dimension member.

*Note:* The availability of these features depends on your permissions.
How to Access the New Dimension Member Dialog Box

On the Dimensions view, select an item and select **Edit ➔ New Dimension Member**.

See Also

- “Create a Dimension Member” on page 186
- Chapter 24, “What Are Dimensions?,” on page 169

Find Dimension Member Dialog Box

In the Find Dimension Member dialog box, you can quickly find dimension members when creating a new account.

How to Access the Find Dimension Member Dialog Box

Open a model and select **Edit ➔ New Account**. When the New Account Wizard opens, click **Find**.
Find a Dimension Member

1. Type the Member name.
2. Select the dimension from the Dimension name menu.
3. (Optional) Select **Match name exactly** to find only exact matches with the member name that you type.
   - If you don't select **Match name exactly**, then you can use an asterisk (*) as a wildcard to stand for 0 or more of any characters. And, the member name that you type is implicitly appended with an asterisk so that, for example, typing Equipment matches Equipment Depreciation and Equipment Expenses (it is the same as typing Equipment*).
   - If you select **Match name exactly**, then only exact matches are made and there are no wildcards. If you type a name with an asterisk, then it will match only a member whose name itself contains an asterisk. And, the name that you type is not implicitly appended with an asterisk wildcard.

Dimension Member Properties Dialog Box

About the Dimension Member Properties Dialog Box

In the Dimension Member Properties dialog box, you can review or change information about a dimension member.

![Dimension Member Properties](image)

The availability of these features depends on your permissions.

How to Access the Dimension Member Properties Dialog Box

On the Dimensions view, select a dimension member and select **Edit ⇒ Item Properties**.

See Also

Chapter 24, “What Are Dimensions?,” on page 169
Chapter 26
How To: Dimensions

Create a Dimension

When you create a model, you specify the model’s dimensions and you cannot change them afterwards. When you specify the model’s dimensions, you can create a new dimension.

See Also

- “Create a Model” on page 78
- “New Dimension Dialog Box” on page 180
Create a Dimension Member

1. On the Dimensions page, select a dimension or a dimension member within which to create the new dimension member.

2. Select Edit ➤ New Dimension Member.

The New Dimension Member dialog box appears.

3. Click Add.

A new row is added to the Dimension members list. The row contains default information.

4. Click in the Name column and type the name of the new dimension member.

The name must follow the naming conventions. See “Naming Conventions” on page 43.

5. Click in the Reference column and type the reference.

A default reference is created from the dimension member's name. If you change the reference, the new reference must follow the reference conventions. See “Reference Conventions” on page 48.

6. Click in the Level Name column and select a level name.

7. Select or clear the Show this dialog box every time I create a dimension member option.

8. Click Add.

9. On a module page, create the account that corresponds to the dimension member.

See Also

- “New Dimension Member Dialog Box” on page 182
- Chapter 24, “What Are Dimensions?,” on page 169
Create a Dimension Attribute

See “Create a Dimension Attribute” on page 284.

Reorder Dimension Members

Overview

You can use the mouse, keyboard, or staging tables to change the order of dimension members.

Using the Mouse

1. Go to the Dimensions view and select the dimension member that you want to reorder.

2. Click the dimension member so that the cursor changes to the following:

3. Drag the cursor to the dimension member after which you want to move the selected item.
4. Drop the item and the dimension members are reordered.

Note: If you drag a dimension member out of its parent, then the system assumes that you want to change the parent of the dimension member.

Using the Keyboard

To reorder dimension members using the keyboard, do the following:

1. Go to the Dimensions view.
2. Use the up or down arrow keys to navigate to the dimension member that you want to reorder.
3. Press **CTRL + D** to select the dimension member.
4. Use the up or down arrow keys to navigate to the dimension member after which you want to place the dimension member.
5. Press **CTRL + R** to drop the item.
   The item is moved to the new position.

Note: If you drag a dimension member out of its parent, then the system assumes that you want to change the parent of the dimension member.

Using Staging Tables

To specify the display order of dimension members using staging tables, use the DisplayOrder field in the DimensionMember table.

You might consider numbering dimension members with increments of 10 so that you can easily interprose dimension member rows that are out of order in the staging table.
For example, in the following picture the dimension member, Land Distribution, is assigned DisplayOrder=15 so that it displays immediately after AirDistribution (DisplayOrder=10) and before Expedite Shipping (DisplayOrder=20).

<table>
<thead>
<tr>
<th>DimRef</th>
<th>Reference</th>
<th>Name</th>
<th>ParentRef</th>
<th>DisplayOrder</th>
</tr>
</thead>
<tbody>
<tr>
<td>Act</td>
<td>Air Distribution</td>
<td>Air Distribution</td>
<td></td>
<td>10</td>
</tr>
<tr>
<td>Act</td>
<td>Expedite Shipping</td>
<td>Expedite Shipping</td>
<td></td>
<td>20</td>
</tr>
<tr>
<td>Act</td>
<td>Inspect Packaging</td>
<td>Inspect Packaging</td>
<td></td>
<td>30</td>
</tr>
<tr>
<td>Act</td>
<td>Land Distribution</td>
<td>Land Distribution</td>
<td></td>
<td>(15)</td>
</tr>
<tr>
<td>Chnl</td>
<td>Customer Pickup</td>
<td>Customer Pickup</td>
<td></td>
<td>10</td>
</tr>
<tr>
<td>Chnl</td>
<td>Drop Box</td>
<td>Drop Box</td>
<td></td>
<td>20</td>
</tr>
<tr>
<td>Chnl</td>
<td>Storefront</td>
<td>Storefront</td>
<td></td>
<td>30</td>
</tr>
<tr>
<td>GL</td>
<td>Equipment Expense</td>
<td>Equipment Expenses</td>
<td></td>
<td>10</td>
</tr>
<tr>
<td>GL</td>
<td>Operating Expense</td>
<td>Operating Expenses</td>
<td></td>
<td>20</td>
</tr>
<tr>
<td>GL</td>
<td>Wages</td>
<td>Wages</td>
<td></td>
<td>30</td>
</tr>
</tbody>
</table>

For information on staging tables, see Chapter 5, “About Staging Tables,” in *SAS Cost and Profitability Management: Data Administration Guide*.

**See Also**

“Change the Parent of a Dimension Member” on page 189

---

**Change the Parent of a Dimension Member**

**Overview**

You can use the mouse or keyboard to change the parent of a dimension member by moving the dimension member to its new parent.

*Note:* You can move a dimension member to a new parent only in the same dimension.

**Using the Mouse**

1. Go to the Dimensions view and select the dimension member that you want to reparent.
2. Click the dimension member so that the cursor changes to the following:

3. Press and hold the **ALT** key, and then click and hold **Mouse button 1**.

Note: It is important to press the ALT key before clicking the mouse button.

4. Drag the cursor to the new parent (continuing to hold down the ALT key).

5. Drop the item.

   You are asked to confirm that you want to re-parent the item. If you confirm, then the item is moved under the new parent.
6. The dimension member is always added at the end as the last child of the new parent. If this is not where you want it, you can reorder the dimension member under its new parent.

*Note:* If you drag a dimension member out of its current parent, then the system assumes that you want to change the parent of the dimension member and it is not necessary to hold the ALT key.

**Using the Keyboard**

To re-parent an account using the keyboard, do the following:

1. Go to the Dimensions view.
2. Use the up or down arrow keys to navigate to the dimension member that you want to re-parent.
3. Press `CTRL + D` to select the dimension member.
4. Use the up or down arrow keys to navigate to the dimension member that is to be the parent.
5. Press `CTRL + Shift + R` to drop the item.

You are asked to confirm that you want to re-parent the item. If you confirm, then the item is moved under the new parent.
Using Staging Tables

You can specify the parent of a dimension member with the ParentReference field in the DimensionMember table.

*Note:* However, if a model already exists, you can not change the parent of a dimension member by re-importing a table with a different value for its ParentReference field—if the values are different, the imported value is ignored.

For information on staging tables, see Chapter 5, “About Staging Tables,” in *SAS Cost and Profitability Management: Data Administration Guide*.

See Also

“Reorder Dimension Members” on page 187

Change Dimension Level Names

To change the name of a dimension level:

1. Open a model.
2. Select **Model ➜ Dimensions**.
3. Right-click a dimension and select **Item Properties**.
   
   The Dimension Properties window opens.
4. Type a new name, and then click **OK**.

See Also

“Dimension level naming conventions” on page 44
Attach Attributes to Dimension Members

See Chapter 34, “Attributes on Dimension Members,” on page 251.
Part 9

Accounts

Chapter 27
What are Accounts? ........................................ 197

Chapter 28
Windows for Accounts .................................... 209

Chapter 29
How To: Accounts ........................................... 215
Chapter 27
What are Accounts?

Introduction

An account is an intersection of dimension members—one dimension member from each dimension in a module—and is the bearer of costs in a model. In the following picture you can see that the account 2nd Day Guaranteed is the intersection of the dimension members Beaverton x Drop Box x 2nd Day Guaranteed. Those dimension members are, in turn, members of the dimensions Region, Channel, and Products and Services respectively.

You can notice that the display name of the account, 2nd Day Guaranteed, is the name of the last member in the intersection of the dimension members when the order of dimension members is the order of their containing dimensions—Region, Channel, Products. The order of dimensions is the order in which you define them when you create a model.

Don’t be confused by the fact that the display name of an account is the name of its last dimension member into thinking that the account just is that last dimension member. To repeat, an account is the intersection of dimension members. In addition to a display name, each account has an intersection name which is includes the name of each dimension member in the intersection. For example, the intersection name of 2nd Day Guaranteed is Beaverton x Drop Box x 2nd Day Guaranteed.
Note: An account must contain a dimension member from every dimension in a module. However, you can omit specifying a dimension member from a particular dimension by selecting instead the "None" dimension member that the system automatically generates for each dimension.

Accounts are periodic elements. The accounts in one period/scenario may exist in another period/scenario. And, when an account (same dimension signature) exists in multiple period/scenarios, its cost in one period/scenario is independent of its cost in another period/scenario.

Accounts as Dimension-Member Crossings

**Introduction**

This topic discusses accounts as dimension-member crossings with a simple example. The following picture shows a model whose Resource module has two dimensions: Dimension1 and Dimension2.

Dimension1 has the following dimension members:

- AAA
  - 111
  - 222
- BBB
  - 333

Dimension2 has the following dimension members:

- CCC
  - 444
Note: The picture also shows both dimensions along with their dimension members underneath them. Such a view is not available in the product UI but was created using an image editor.

**Parent Dimension Members Only**

The following picture shows the accounts that are created as a result of selecting a number of dimension members and also selecting **parent dimension members only**. Notice that even though leaf members 111, 222, 333, 444, 555, and 666 are selected, they are not included in any intersections because of the **parent dimension members only** selection.

**Leaf Dimension Members Only**

The following picture shows a sample of the accounts that are created as a result of selecting a number of dimension members and also selecting **leaf dimension members only**. Notice that even though parent members AAA, BBB, CCC, and DDD are selected, they are not included in any intersections because of the **leaf dimension members only** selection.
Note: The selections leaf dimension members only and parent dimension members only do not apply to the “No” dimension member. If you select the “No” dimension member (for example, No <Channel>) then it is included in dimension crossings regardless of whether you select leaf dimension members only or parent dimension members only. Another way to put this is that the “No” dimension member is treated as both a parent node and as a leaf node.

All Intersections

The following picture shows a sample of the accounts that are created as a result of selecting a number of dimension members and also selecting all intersections.

The following picture shows all the accounts that are created as a result of the same selections as above. Notice that all intersections is not just the union of parent dimension members only and leaf dimension members only. The accounts highlighted in yellow under all intersections are accounts that are not created when you select either parent dimension members only or leaf dimension members only. An example of such an account highlighted in yellow is AAA x 444. Notice that it includes both a parent dimension member, AAA, and a leaf dimension member, 444.
Accounts as Dimension-Member Crossings

- Parent dimension members only
  - AAA
  - BBB
  - CCC

- Leaf dimension members only
  - AAA
  - BBB
  - CCC
  - DDD

- All intersections
  - AAA
  - BBB
  - CCC
  - DDD

[Diagram with various intersections and combinations]

[Too many accounts to show]
Rollup Accounts and Module Rollups

A rollup account is a cluster of accounts or a cluster of other rollup accounts that are related by function, department, location, or group. The cost of a rollup account is the sum of costs for all of the accounts and rollup accounts in the immediate subordinate level. Each module contains a module rollup. A module rollup is the highest level in the module. A module rollup represents all the accounts and rollup accounts in the module.

Each module contains a module rollup. A module rollup is the highest level in the module. A module rollup represents all the accounts and rollup accounts in the module.

Accounts contain cost elements. For information on cost elements, see Chapter 30, “What Are Cost Elements?,” on page 233.

Using All Intersections

As discussed previously, the all intersections selection can create accounts that include both a parent node and a leaf node. (See “All Intersections” on page 200.)

The question arises, then, as to why you might want to do this. To provide an answer, we first show some accounts created with the leaf dimension members option. The following picture shows the following four leaf-node-only accounts:

- Beaverton x Resolve Customer Complaints
- Eugene x Resolve Customer Complaints
- Beaverton x Expedite Package Shipments
- Eugene x Expedite Package Shipments
Next, the following picture shows how to add two mixed-node accounts with the **all intersections** option:

Beaverton x Personnel Intensive Activities (leaf node x parent node)  
Eugene x Personnel Intensive Activities (leaf node x parent node)

And, the following picture shows those two mixed-node accounts added to the module.
Because these accounts have just added to the module, they initially do not have any cost. So, after adding an entered cost element to each of those accounts and recalculating, the costs and rollup costs are as shown in the following picture.

For information on entered cost elements, see “Introduction” on page 233.

In the preceding picture, you can notice two things:

- The cost for the rollup account, Personnel Intensive Activities, includes the cost of the account, Personnel Intensive Activities and two other accounts: Resolve Customer Complaints and Expedite Package Shipments. Do not confuse the rollup account, Personnel Intensive Activities with the account, Personnel Intensive Activities.
• The cost of the account, Personnel Intensive Activities comes (in this example) from an entered cost element. The cost of the account does not include the cost of the two other accounts: Resolve Customer Complaints and Expedite Package Shipments. The account, Personnel Intensive Activities, is not a rollup account.

Creating and Deleting Accounts

Creating and Deleting Accounts

An account corresponds to dimension members. You must create the dimension member before you can create the account that corresponds to the dimension member.

When you delete an account, the corresponding dimension member still exists, and the dimension member will appear in any cube that you generate. To remove the dimension member from a cube, you must delete the dimension member.

*Note:* When you delete an account, the model to which it belongs can be viewed but cannot be edited while the delete is in progress.

Guidelines for Creating Accounts

Guidelines for Creating Accounts

• An account can consist of the intersection of at most 30 user-defined dimensions (including both structural dimensions and attribute dimensions).

• Combine similar accounts.

  If your organization's general ledger lists the details of travel expenses, such as airfare, hotel, or entertainment, you might want to combine these expenses into one travel account. Are the particular costs incurred together, or are multiple costs caused by the same factor? If so, you might want to combine such costs. Also, if some accounts have small costs, you might want to combine the small accounts into larger accounts that represent more general categories.

  Combining accounts into a single account can make creating and maintaining a model easier. However, you must ensure that combining accounts does not hinder business users from obtaining the information that they need.

• Group related accounts.

  Group accounts into roll-up accounts if the accounts have similar functionality or are linked to similar activities. For example, the following ungrouped accounts could be grouped as shown:
Grouping accounts is similar to the advice concerning the use of multiple dimensions in Chapter 6, Dimensions. A group, and the levels within a group, provide business users with more flexibility to analyze costs at different levels. In the previous example, business users can examine the individual costs of advertising through Magazine Inserts, Direct Mail, and In-Store Circulars. Business users can also examine the total cost of these methods at the Print level, and the total cost of advertising, regardless of the method.

- In OLAP analysis, the lowest level that can be examined in a cube is the accounts; cost element costs are rolled up into accounts and cannot be examined individually. Therefore, ensure that cost information that must be available to business users is in accounts, not in cost elements.

**Guidelines for Creating Cost Object Accounts**

Before you create cost object accounts, consider the following:

- Name and organize the cost objects so that they are familiar to the business users.

**Guidelines for Creating Activity Accounts**

Before you create activity accounts, consider the following:

- Name and organize the activity accounts so that they are familiar to the business users.

- Distinguish an activity from a task and a process from an activity. A task provides too much detail and a process provides too little detail.

Follow the 5-50 rule:

If a potential activity consumes less than 5% of anyone's time, then it is probably a task. Combine tasks to create an activity or several activities. For example, the tasks of opening correspondence, typing correspondence, and applying postage can be combined into the activity of Communicate with Customers.

However, understanding the task level is important because it clarifies the scope of an activity, it clarifies the boundaries between adjacent activities, and it helps people in your organization relate to the activity.

If a potential activity consumes more than 50% of anyone's time, then it is probably a business process (or business macro process). Divide the activity into finer detail to identify the activities that are involved in the process. For example, the process of Secure Facility can be divided into the activities of Patrol the Grounds, Monitor Automobile Traffic, and Issue Security Badges.
An activity account must be active; it is not an arbitrary accounting bucket. The action is denoted by naming an activity account using a verb-noun phrase, such as Process Order or Enter Invoices.

An activity account is a cost category that management is concerned about.

Ensure that all required activity accounts are defined.

To determine your organization's activities, conduct surveys with the people in your organization.

Create an activity account only if management needs to know details about the activity to make decisions.

An activity account has one driver that is used for assigning costs.

**Guidelines for Creating Resource Accounts**

Before you create resource accounts, consider the following:

- Name and organize the resource accounts so that they are familiar to the business users. Create the references for resource accounts and cost elements so that the references match the account numbers in your organization's chart of accounts.

**See Also**

“New Account Dialog Box” on page 209
Chapter 27 • What are Accounts?
Chapter 28
Windows for Accounts

New Account Dialog Box

About the New Account Dialog Box

How to Access the New Account Dialog Box

Search for Accounts Dialog Box

About the Search for Accounts Dialog Box

How to Access the Search for Accounts Dialog Box

Search Account Results Dialog Box

About the Search Account Results Dialog Box

How to Access the Search Account Results Dialog Box

Item (Account) Properties and Attributes Dialog Box

About the Item Properties and Attributes Dialog Box

How to Access the Item Properties and Attributes Dialog Box

General Tab

Properties Tab

Attributes Tab

New Account Dialog Box

About the New Account Dialog Box

Use the New Account dialog box to create an account as an intersection of dimension members in a module.
How to Access the New Account Dialog Box

To open the New Account dialog box:


2. Do one of the following:
   - Select Edit ⇒ New Account
   - Right-click the module name and select New Account.

   The New Account dialog opens.
About the Search for Accounts Dialog Box

In the Search for Accounts dialog box, you can specify criteria to build and update a query to search for accounts. This is useful when you build a model.

How to Access the Search for Accounts Dialog Box

Open a model and select Edit ⇒ Search Accounts or click the Search Accounts icon.

See Also

- “Search for Accounts” on page 222
- “Search Account Results Dialog Box” on page 212
- “Save Queries for Account Search” on page 226
- “Find a Property or Attribute Dialog Box” on page 277
Search Account Results Dialog Box

About the Search Account Results Dialog Box

In the Search Account Results dialog box, you can see the results of the query that you built in the Search for Accounts dialog box. The final search criteria are displayed in the non-editable Query box.

How to Access the Search Account Results Dialog Box

From the Search for Accounts dialog box, click **Search** to initiate a search. When the search completes, the results are displayed.

See Also

- “Search for Accounts” on page 222
- “Search for Accounts Dialog Box” on page 211
- “Save Queries for Account Search” on page 226
- “Find a Property or Attribute Dialog Box” on page 277
Item (Account) Properties and Attributes Dialog Box

About the Item Properties and Attributes Dialog Box

In the Item Properties and Attributes dialog box, you can see the properties and attributes of an account.

Note: The availability of these features depends on your permissions.

The Item Properties and Attributes dialog box contains the following tabs:

- “General Tab” on page 213
- “Properties Tab” on page 213
- “Attributes Tab” on page 214

How to Access the Item Properties and Attributes Dialog Box

In a module view, select an item and then select Edit ➔ Item Properties.

General Tab

The General tab displays the account name, reference, display reference, ID, and identifies whether it is an account or rollup account.

Properties Tab
The Properties tab displays the values of properties for the account. If the value is modifiable by a user, then you can modify it here.

**Attributes Tab**

The Attributes tab displays the values of attributes that are attached to the account and allows you to modify the values.

An attribute on an account is **System Generated** when it is added by the system to the account as a result of your having added the attribute to a dimension member that is in the dimension signature of that account.

*Note*: If you change the value of a system-generated attribute from its default value, then it is no longer a system-generated attribute. See “System-generated versus user-entered attribute values” on page 259.
Chapter 29
How To: Accounts

Create Accounts
Reorder Accounts
Overview
Using the Mouse
Using the Keyboard
Using Staging Tables
Search for Accounts
Invoke the Search Accounts Dialog Box
Build a Query to Search for Accounts
Update Your Query to Search for Accounts
Sort the Search Results
Perform an Action on the Accounts That Are Found
Save Queries for Account Search
Save a Query
Retrieve Queries
Export Account Search Queries
Import Account Search Queries
Go to an Account
Expand All Levels

Create Accounts

To create an accounts:


2. Do one of the following:
   • Select Edit ⇒ New Account
   • Right-click the module name and select New Account.

The New Account dialog box opens.
3. From the list of Dimensions, select at least one dimension member from each dimension.

**TIP** To quickly locate a dimension member, click **Find** in the New Account Wizard. The Find Dimension Member dialog box appears.

Accounts are created at the intersection of the dimension members that you select. See “Introduction” on page 197.

4. From the Create accounts using drop-down list, select one of the following:
   - leaf dimension members only
   - parent dimension members only
   - all intersections

*Note:* These selections do not apply to the “No” dimension member. If you select the “No” dimension member (for example, No <Channel>) then it is included in dimension crossings regardless of whether you select **leaf dimension members only**, **parent dimension members only** or **all intersections**.

See “Accounts as Dimension-Member Crossings” on page 198.

**leaf dimension members only**

creates accounts only for the intersections of the lowest dimension members in each dimension, as shown:
parent dimension members only
creates accounts only for the intersections of the highest dimension members

all intersections
creates accounts for the intersections of all the dimension members in each dimension, as shown:
5. To change the name of an account, click in the Name column and type a new name. The name must follow the naming conventions. See “General naming conventions” on page 43.

Note: You can change the name of an account but you cannot change its display name—these are two different properties. The following picture makes the difference clear.

- The system uses the display name in its graphical representation of the hierarchical structure of a module.
- The name is a string of your choosing that you can add to a column layout. See “What is a Column Layout?” on page 293.
- The intersection name shows the dimension members whose intersection constitutes an account.


7. Click Finish or click Next.

If you click Next, then the New Account — Cost Elements dialog appears. This dialog allows you to create cost elements for accounts.
8. To create a cost element for an account, select the account and click **Add Cost Element**.

**See also:**

- “New Entered Cost Element Dialog Box” on page 237
- Chapter 30, “What Are Cost Elements?,” on page 233
- “Create an Entered Cost Element” on page 239

To change the name of a cost element, click in the **Name** column and type a new name. The name must follow the naming conventions. See “Entered cost element naming conventions” on page 46.

To change the reference of a cost element account, click in the **Reference** column and type a new reference. The reference must follow the reference conventions. See “Entered cost element reference conventions” on page 49.

9. Click **Finish**.

The accounts are created as intersections of the selected dimension members.

---

**Reorder Accounts**

**Overview**

You can control the display order of accounts by reordering dimension members on the Dimensions view. The order that you establish is preserved when you export and import a model.

You can reorder accounts using the mouse, keyboard, or staging tables.

**Using the Mouse**

1. Go to the Dimensions view and select the dimension member that you want to reorder.
2. Hover over the dimension member until the cursor changes to the following:

3. Drag the cursor to the dimension member after which you want to move the selected item.

4. Drop the item and the dimension members are reordered.
Note: If you drag a dimension member out of its parent, then the system assumes that you want to change the parent of the dimension member. For more information on re-parenting, see Changing the Parent of a Dimension Member.

When you open the appropriate assignments pane, you can notice that the accounts are reordered.

And the new order is reflected in cubes:

Using the Keyboard

To reorder an account using the keyboard, do the following:

1. Go to the Dimensions view.
2. Use the up or down arrow keys to navigate to the dimension member that you want to reorder.
3. Press CTRL + D to select the dimension member.
4. Use the up or down arrow keys to navigate to the dimension member after which you want to place the dimension member.
5. Press \texttt{CTRL + R} to drop the item.
   The item is moved to the new position.

\textbf{See Also}

“Change the Parent of a Dimension Member” on page 189

\textbf{Using Staging Tables}

To specify the display order of dimension members using staging tables, use the DisplayOrder field in the DimensionMember table.

For information on staging tables, see Chapter 5, “About Staging Tables,” in \textit{SAS Cost and Profitability Management: Data Administration Guide}.

\section*{Search for Accounts}

\textbf{Invoke the Search Accounts Dialog Box}

To search for accounts, open a model and do either of the following:

\begin{itemize}
\item Select \texttt{Edit} $\Rightarrow$ \texttt{Search Accounts}
\item Click the Search Accounts icon
\end{itemize}

\textit{Note: } If a network user from a different domain (than that of the SAS Cost and Profitability Management client machine) logs in to the client machine to search for accounts, then that user must be granted WRITE access to the 	exttt{[ClientInstallpath]/bin} folder for the operation to succeed.

\textbf{Build a Query to Search for Accounts}

1. Select a Property or Attribute.
2. Select an Operator and specify a Value (numeric, Boolean, text, enumerated values, sets) to add criteria to your query.
3. Click \texttt{Add} to add the line to your query. The combined search criteria display in the Query box.
4. Repeat Steps 1 through 3 as necessary to build your query.
5. Filter the search results by selecting options in the Search for and Search in fields. You can select the \texttt{Use * as wildcard} check box and limit the result count in multiples of 50.
6. Click \texttt{Search}. The Search Account Results dialog box appears.
   You can update an existing query to search for accounts.

\textbf{Update Your Query to Search for Accounts}

1. Select the line in the Query box that you want to change and modify the criteria as necessary.
2. Click **Update** to display the updated search criteria in the Query box.

3. To remove a single line from the query, select the line in the Query box that you want to delete and click **Remove**. To remove all the lines of the query, click **Remove All**.

   **TIP** To quickly recall the last query that you used, click **Get Last**.

**Sort the Search Results**

To sort the results by column, click the column heading.

**Perform an Action on the Accounts That Are Found**

**Overview**

Select one or more accounts from the list of search results, and click **Actions** to perform any of the following actions:

- “Go to an Account” on page 223
- “Add Accounts” on page 223
- “Delete Accounts” on page 223
- “Add Attributes and Values” on page 224
- “Remove Attributes” on page 224
- “Mark Accounts as Profitability Management Behaviors” on page 225
- “Unmark Accounts as Profitability Management Behaviors” on page 225
- “Delete Assignments” on page 225

**Go to an Account**

1. Select an account from the list of results.

2. Click **Actions** ⇒ **Go to Account** to go to the selected account.

**Add Accounts**

1. Select one or more accounts from the list of results.

2. Click one of the following:

   **Actions** ⇒ **Add Accounts in Left Pane**

   **Actions** ⇒ **Add Accounts in Right Pane**

   **Note:** These actions are disabled on the **Actions** menu if the appropriate pane is not already open.

**Delete Accounts**

1. Select one or more accounts from the list of results.

2. Click **Actions** ⇒ **Delete Accounts** to delete the selected accounts. You are asked to confirm the deletion before the actual deletion takes place.

   **Note:** When you delete an account, the model to which it belongs can be viewed but cannot be edited while the delete is in progress.
Add Attributes and Values

1. Select one or more accounts from the list of results.

2. Click **Actions ⇒ Add Attributes and Values**. The Add Attributes and Values dialog box opens.

3. Select each attribute that you want to add to the selected accounts, and then click **Add**.

4. Enter a new value in the **Value** column if you want to change the value of the attribute.

   **Note:** The value that is displayed in the **Value** column is the default value for an attribute, not its current value even if the account already has that attribute. An existing attribute is reset to its default value unless you specify a new value.

   **Note:** You cannot change Boolean attributes or calculated attributes. A calculated attribute retains its formula. If you want to change the formula of a calculated attribute, you must go to the Attributes view and change the formula from there.

5. Click **OK**. The attributes (along with their values) are added to the selected accounts.

   **Note:** This method of adding attributes to accounts is an efficient method for adding stage attributes to multiple accounts to create multi-stage contribution cubes.

Remove Attributes

1. Select one or more accounts from the list of results.

2. Click **Actions ⇒ Remove Attributes**.

   The Remove Attributes dialog box opens, showing all the attributes from all selected accounts.
3. Select each attribute that you want to remove from the selected accounts, and click **Remove**.

   If you have selected multiple accounts, and an attribute that you select for removal belongs to more than one of the selected accounts, then the attribute is removed from all of those accounts.

4. Click **OK**. The attributes are removed from the selected accounts.

**Mark Accounts as Profitability Management Behaviors**

1. Select one or more accounts from the list of results.

2. Click **Actions** ⇒ **Mark Accounts as Behaviors**. A message is displayed if the action is successful.

   *Note:* Rollup accounts cannot be marked as behaviors.

Once you have marked accounts as behaviors, you can publish them to SAS Profitability Management.

See also:

- “Mark Accounts as Behaviors” on page 693
- Chapter 17, “Working with SAS Profitability Management,” in *SAS Cost and Profitability Management: Data Administration Guide*

**Unmark Accounts as Profitability Management Behaviors**

1. Select one or more accounts from the list of results.

2. Click **Actions** ⇒ **Unmark Accounts as Behaviors**. A message is displayed if the action is successful.

See also:

- “Mark Accounts as Behaviors” on page 693
- Chapter 17, “Working with SAS Profitability Management,” in *SAS Cost and Profitability Management: Data Administration Guide*

**Delete Assignments**

1. Select one or more accounts from the list of results.

2. Click one of the following:

   **Actions** ⇒ **Delete Incoming Assignments** to delete assignments coming into the selected accounts.
Actions \(\Rightarrow\) **Delete Outgoing Assignments** to delete assignments going out of the selected accounts.

**Actions \(\Rightarrow\) Delete Incoming and Outgoing Assignments** to delete both sorts of assignments.

*Note:* These options are not available for rollup accounts. You are asked to confirm the deletion before the actual deletion takes place.

**See Also**

- “Search for Accounts Dialog Box” on page 211
- “Search Account Results Dialog Box” on page 212
- “Save Queries for Account Search” on page 226

---

**Save Queries for Account Search**

Queries for searching for accounts can be long, complicated, and tedious to construct. Now you can save your queries, retrieve them for subsequent use, export them, and import them.

**Save a Query**

Once a query has returned the results that you want, click **Save Query** on the Search Account Results dialog box to save the query.

A saved query is not associated with a particular model or a particular user but rather with the machine on which it is saved. Any SAS Cost and Profitability Management user who uses that machine can see all the queries saved on that machine. In order to use the queries on another machine, you can export the queries and import them on the other machine.

**Retrieve Queries**

To retrieve a query for subsequent use, click **Saved Queries** on the Search for Accounts dialog box. All those queries that have been saved on that machine are displayed for selection and reuse.
Export Account Search Queries

In order to use the queries on another machine, you can export the queries and import them on the other machine. When you export, all the queries saved on the machine are exported regardless of which users saved them. The exported queries may be imported by any user.

To export your queries:

1. Go to the Workspace Manager.

2. Select Files ➔ Export ➔ Account Queries.

   The Export Saved Search Account Queries dialog box opens.

3. Specify the name of the Registry file to which the queries are to be saved and click Export.

   Note:
   - It is not necessary to specify the file extension because it is added automatically. The default extension is .reg.
   - If you do not type a path before the file name, then the file is saved in <installation directory>\SASCostandProfitabilityManagementClient\8.4\bin.
   - You can click the Browse button to browse to the directory in which you want to save the export file. Again, it is not necessary to specify the file extension because it is added automatically. The default extension is .reg.
Import Account Search Queries

When you import queries on a machine, any SAS Cost and Profitability Management user who uses that machine can see all the imported queries. When you import saved queries, the imported queries replace any queries that were previously saved on that machine.

To import queries:

1. Go to the Workspace Manager.
2. Select Files ⇒ Import ⇒ Account Queries.
   The Import Saved Search Account Queries dialog box opens.
3. Specify the name of, or browse to the file to be imported and click Import.
   Note: When you import saved queries, the imported queries replace any queries that were previously saved on that machine.

See Also

- “Search for Accounts Dialog Box” on page 211
- “Search Account Results Dialog Box” on page 212

Go to an Account

You can quickly go to an account that is displayed in the left assignments pane or the right assignments pane.

1. Select an account in the left assignments pane or the right assignments pane.
2. Select Edit ⇒ Go To Account.
The selected account is displayed in the primary pane. You can display the source accounts and the destination accounts for the selected account.

See Also

“Assignments Panes” on page 407

Expand All Levels

To expand all dimension levels to see the accounts at every level, do either of the following:

- Select a module name (Resource, Activity, Cost Object, External Object), a dimension, or a dimension member. Then, select View → Expand → All Levels from the menu bar.

- Right-click a module, dimension, or dimension member, and select Expand → All Levels from the pop-up menu.
To collapse all dimension levels so that no accounts are visible, do either of the following:

- Select a module name, dimension, or dimension member that is fully or partially expanded, and then select **View ⇒ Collapse ⇒ All Levels** from the menu bar.

- Right-click a module, dimension, or dimension member that is fully or partially expanded, and then select **Collapse ⇒ All Levels** from the pop-up menu.

_Note:_

- You can only Expand All one at a time on a view. If an Expand All is in process, you cannot do another Expand All until the first one has finished.

- If you change models during an Expand All function, the expansion is canceled.
Part 10

Cost Elements

Chapter 30
What Are Cost Elements? .................................................. 233

Chapter 31
Windows for Cost Elements ............................................... 237

Chapter 32
How To: Cost Elements ..................................................... 239
Chapter 30
What Are Cost Elements?

Introduction

Cost elements are the bearers of cost in a model. The cost in an account is the sum of its entered cost elements plus its received cost elements:

**Entered cost elements**
An entered cost element is one that you create and to which you assign costs directly. An entered cost element is represented by the following icon: ☐. All of the cost in a model originates with entered cost elements.

See “Entered Cost Elements” on page 234.

**Received cost elements**
A received cost element is one that you create indirectly by creating an assignment from one account to another. The cost that the destination account receives from that source account is a received cost element.
Cost elements are periodic elements. The cost elements in one period/scenario may exist in another period/scenario. And, when a cost element (with the same name and reference in the same module) exists in multiple periods/scenarios, its cost in one period/scenario is independent of its cost in another period/scenario.

See Also

“Create an Entered Cost Element” on page 239

Entered Cost Elements

Introduction

An entered cost element is one that you create and to which you assign costs directly by giving it one or both of the following kinds of cost:

Entered Cost
A lump sum that you give to a cost element.

EnteredUnitCost
The unit cost that you assign to a cost element.

If you specify EnteredUnitCost, then the cost of the cost element is determined by the following formula:

\[
\text{Cost} = \text{EnteredCost} + \text{EnteredUnitCost} \times \text{Parent.TDQ}
\]

All of the cost in a model originates with entered cost elements. That cost is distributed to accounts via drivers that work by either push or pull:

push
A driver that works by push either:

- distributes a fixed amount of cost (either Entered Cost in the account or cost received from another account) to other accounts. Drivers that work by push are: Evenly assigned, Percentage, and Standard. For an example of how the Percentage driver pushes cost to other accounts, see “Percentage Driver” on page 337.

- or, it distributes cost to other accounts by multiplying the Entered Unit Cost in the account by the number of units outputted by that account. The Standard driver can distribute costs by this method. For an example of a Standard driver using this method, see “Example 1: Entered Unit Cost with Fixed Driver Quantities” on page 345.
In the case of pull, cost is determined by demand (hence, it is often referred to as “demand flow”). Cost is “pulled” by the quantity required at the final destination. The source account’s Entered Unit Cost is multiplied by the number of units demanded. In more detail, the source account’s Entered Unit Cost is multiplied by the driver’s variable driver quantity (DQV) and by the Destination.TDQ. For an example, see “Example 2: Entered Unit Cost with Variable Driver Quantities and SoldQty” on page 348. For more on pull, see “Variable Driver Quantities” on page 375.

Entered Cost

Entered Cost is a lump sum that you give to a cost element. The following picture shows an account with two cost elements both of which have entered cost: one of $20,000 and the other of $200. Notice that the Cost in the account is the sum of its cost elements. Also notice that the Entered Cost of the account is a roll up (sum) of the Entered Cost of its cost elements.

Entered Unit Cost

EnteredUnitCost is a user-assigned cost per unit. The total cost depends on the number of units. The total cost of an entered cost element is calculated by the following formula:

\[
\text{Cost} = \text{EnteredCost} + \text{EnteredUnitCost} \times \text{Parent.TDQ}
\]

For two examples of using Entered Unit Cost, see:

- “Example 1: Entered Unit Cost with Fixed Driver Quantities” on page 345
Received Cost Elements

A received cost element is one that you create indirectly by creating an assignment from one account to another. The cost that the destination account receives from that source account is a received cost element.

A received cost element is represented by the following kinds of icon: 1, 2, 3. The number in the icon indicates the number of the module from which the cost is received.

The following picture shows four received cost elements. You can see that:

- the received cost elements result from assignments from accounts that are shown in the left assignments pane.
- the cost received by each assignment is shown in the RcvCost column of the primary pane.
- the account that receives the received cost elements has an entered cost element named DirectCost.
- the Cost in the account that receives the received costs is calculated by the formula:

\[
\text{Cost} = \text{Entered Cost} + \text{Received Cost}
\]
Chapter 31
Windows for Cost Elements

New Entered Cost Element Dialog Box

About the New Entered Cost Element Dialog Box
In the New Entered Cost Element dialog box, you can create one or more entered cost elements.

How to Access the New Entered Cost Element Dialog Box

New Entered Cost Element Dialog Box

This dialog is displayed whenever one or more cost elements exist in other periods and have not yet been activated in this period.

If you clear this option, a new entered cost element is created, with a unique name and reference, without displaying this dialog box.
How to Access the New Entered Cost Element Dialog Box

In a module view, select an account, right-click, and select **Edit ➔ New Entered Cost Element.**

![New Entered Cost Element Dialog Box](image)

See Also

- Chapter 32, “How To: Cost Elements,” on page 239
- Chapter 30, “What Are Cost Elements?,” on page 233
- “Create an Entered Cost Element” on page 239
Chapter 32
How To: Cost Elements

Create an Entered Cost Element

Overview

You can create an entered cost element in two ways:

• “When Creating an Account” on page 239
• “On an Existing Account in a Module Page” on page 240

When Creating an Account

1. Open the New Account dialog to create an account. See “Create Accounts” on page 215.

2. Select an account from the list of accounts on the second page of the New Account dialog. See “New Account Dialog Box” on page 209.

3. Click Add Cost Element.

A new entered cost element appears.
4. You can change the Name, Reference, Entered Cost, and Entered Unit Cost of the new entered cost element.

The name must follow the naming conventions. See “Naming Conventions” on page 43.

The reference must follow the reference conventions. See “Reference Conventions” on page 48.

**On an Existing Account in a Module Page**

1. In a module, right-click an account (not a roll-up account).

2. Select **Edit ➔ New Entered Cost Element**.

   The New Entered Cost Element dialog box appears.

3. You can change the Name, Reference, Entered Cost, and Entered Unit Cost of the new entered cost element.
The name must follow the naming conventions. See “Naming Conventions” on page 43.

The reference must follow the reference conventions. See “Reference Conventions” on page 48.

---

Delete an Entered Cost Element

1. In a module, right-click an entered cost element and select **Delete**.

2. Click **Delete Cost Element**.
Part 11

Attributes

Chapter 33
   Types of Attributes ................................................. 245

Chapter 34
   Attributes on Dimension Members ................................. 251

Chapter 35
   Windows for Attributes ............................................. 269

Chapter 36
   How To: Attributes .................................................. 281
Chapter 33
Types of Attributes

Introduction

About Attributes
An attribute is a label that is added to an account. Each attribute is a characteristic that is used for analysis or for a calculated value, such as in a formula for a calculated attribute or calculated driver. An attribute conveys information about the item to which the attribute is added.

You create an attribute with the Attributes view. You add and delete (manage) the attributes that have been added to an account with a module view.

Attributes are periodic elements. An attribute that is attached to an account in one period/scenario may or may not be attached to the same account in another period/scenario. And, when a value attribute is attached to the same account in multiple periods/scenarios, its value in one period/scenario is independent of its value in another period/scenario.
Attribute Folders

An attribute folder organizes attributes. Generally, an attribute folder can contain any type of attribute, and it can contain multiple types of attributes, because the folder itself has no type. However, a dimension attribute folder can contain only dimension member attributes or other dimension value attributes. In addition, dimension member attributes must be contained in a dimension attribute folder.

You cannot explicitly create a dimension attribute folder. When you explicitly create a new dimension attribute, SAS Cost and Profitability Management automatically creates a dimension attribute folder in which dimension member attributes are contained. If you create a new dimension attribute when a dimension attribute folder is selected, the new dimension attribute is automatically created as a dimension member attribute. You cannot change this attribute type.

Dimension Attributes, Dimension Member Attributes, and Dimension Value Attributes

A dimension attribute is a type of dimension and is included in and displayed in cubes. When you create a dimension attribute on the Attributes view, it is automatically displayed on the Dimensions view, as shown:

The leaf node of a dimension attribute is called a dimension value attribute. It is the dimension value attribute that applies to an account. Whereas a dimension member attribute contains a dimension value attribute, a dimension value attribute cannot contain other attributes.

If you attempt to create another attribute within a dimension value attribute, the dimension value attribute automatically becomes a dimension member attribute. For example, you can see in the following that if you create an Ohio attribute inside the Midwest attribute, then the Midwest attribute automatically becomes a dimension member attribute:
Dimension value attributes can facilitate data entry because a drop-down list of possible attribute values is displayed in the interface. For example, from the previous picture, the following drop-down list is displayed when a user sets the value of the Vendors attribute:

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost</th>
<th>Vendors</th>
</tr>
</thead>
<tbody>
<tr>
<td>COST OBJECT (PRIMARY PANE)</td>
<td>$3,647,900.00</td>
<td></td>
</tr>
<tr>
<td>USA</td>
<td>$3,647,900.00</td>
<td></td>
</tr>
<tr>
<td>Oregon</td>
<td>$3,647,900.00</td>
<td></td>
</tr>
<tr>
<td>Seaverton</td>
<td>$1,930,900.00</td>
<td></td>
</tr>
<tr>
<td>Drop Box</td>
<td>$15,468.14</td>
<td>Southeast</td>
</tr>
<tr>
<td>2nd Day Guarantee</td>
<td>$0.00</td>
<td></td>
</tr>
<tr>
<td>Overnight Express</td>
<td>$0.00</td>
<td></td>
</tr>
<tr>
<td>Standard Ground</td>
<td>$0.00</td>
<td></td>
</tr>
</tbody>
</table>

Dimension attributes, dimension member attributes, and dimension value attributes provide business users with roll-up values for OLAP analysis that differ from the values available from the structural dimensions. Using dimension attributes, you enhance a model by classifying or organizing information in ways that will help business users analyze model results.

For example, dimension attributes are commonly used to indicate which resources are fixed or variable and which activities are value-added or non-value-added. Other typical dimension attributes include core, sustaining, and discretionary; strategic and non-strategic; and primary and secondary.

### Numeric Attributes

A numeric attribute stores a number. What the number represents is determined by the unit of measure. The unit of measure is text that provides meaning to the unit. For example, the unit of measure could be cases, pounds, kilograms, and so on. Without a unit of measure, a numeric attribute has little meaning. Alternatively, the name of the numeric attribute can indicate the unit of measure, as in Miles Shipped or Number of Pallets.

A numeric attribute can serve purposes such as:

- A numeric attribute can track a models financial measures or non-financial measures.
- A numeric attribute can track activity performance over time.

The data that a numeric attribute contains can be used in calculated drivers and in calculated attributes.

#### See Also

- “Using Numeric Attributes in a Formula” on page 441
- “Properties That Can Be in Formulas” on page 469
Calculated Attributes

Overview

A calculated attribute stores a number that is calculated from numeric properties of a model and/or from other calculated attributes, based on a formula that you define. (Examples of calculated attributes)

Property values and attribute values are derived from the item to which the attribute is attached. For example, the value of a calculated numeric attribute that is based on the property Cost depends on the item to which the attribute is attached, because each item has a different cost.

Unlike the formula for a calculated driver, which remains the same for all periods, the formula for a calculated attribute can change with each period.

Example: Average Cost of Processing a Customer Order

The following example illustrates how calculated attributes can be used in a model. Equations often include numeric properties and numeric attributes.

Suppose that a company provides order-processing services to other companies. To determine the average cost of processing an order, the cost (the property Cost) is divided by the number of orders processed (the user-defined numeric attribute Orders Processed), as follows:

Cost/Orders Processed

Example: Average Number of Cases Loaded per Employee

Suppose that a company loads goods onto trucks for shipping. Management wants to determine how many cases are loaded per full-time employee. The number of cases loaded (the user-defined numeric attribute Cases Loaded) is divided by the number of full-time employees who are loading cases (the user-defined numeric attribute FTE), as follows:

Cases Loaded/FTE

See Also

- Chapter 51, “Formulas,” on page 431
- “Using Numeric Attributes in a Formula” on page 441
- “Properties That Can Be in Formulas” on page 469

Tag Attributes

A tag attribute is either added to an account or it is not. A tag attribute does not store a value.
You can use the HasAttribute function in the formula for a calculated driver, rule-based
driver or calculated attribute to test whether an account has a particular tag attribute or
not.

Note: In previous releases of SAS Cost and Profitability Management, tag attributes
were called Boolean attributes.

The maximum length of a text attribute is 2048 characters.

---

**Text Attributes**

A text attribute stores alphabetic and numeric characters. A text attribute provides
information about the item to which the attribute is added. For example, a text attribute
named Cost Analysis can indicate whether a resource account is a fixed cost or a
variable cost. Or, a text attribute named Life Cycle can indicate where a cost object
account belongs in a life cycle: analysis, start-up, entry, build, mature, decline, or
withdrawal.

The maximum length of a text attribute is 2048 characters.

---

**Stage Attributes**

**Overview**

Stages are used for creating the Multi-stage Contributions cube. To define stages, you
create a dimension value attribute for each stage, and then you assign these attributes to
accounts. You must create these dimension value attributes within a dimension attribute
named Stages. You can give a dimension value attribute any name, but the name must
conform to the attribute naming conventions (see “Attribute naming conventions” on
page 44).

For more information, see “Add Stage Attributes to Accounts” on page 287.

Note:

- All the accounts for a given stage must belong to the same module.
- Stage names and references must begin with an alphabetic character (letter).

Note: Previous releases of SAS Cost and Profitability Management allowed stage
names and references to begin with a numeric character. In SAS Cost and
Profitability Management 7.2, this is not allowed. If you have a stage name or
reference that begins with a numeric character, then you must change it to begin
with an alphabetic character. For models using renamed stages, update cube
configurations to re-select the dimensions that are included in the cube and
regenerate any multi-stage contributions cubes. (Regenerating cubes is not
necessary if you are using Microsoft Analysis Services for cubes.)

- The stage name is used to define a dimension name in cubes. The stage name is
  concatenated with a user-defined dimension name to form the actual dimension
  in the cube.

- A Stages attribute example is Stage2 Activity, where Stage2 is the stage name
  and Activity is the user-defined dimension. If 2 is used in place of Stage2, then
  the generated cube dimension name becomes 2 Activity.
To see the stages in the Multi-stage Contributions cube, you must specify the properties for the cube. This is true regardless of which method you use for creating the Stages attributes.

**Guidelines for Adding the Stages Attributes to Accounts**

Follow these guidelines when you add Stages attributes to accounts:

- Add only one Stages attribute (or one member of a Stages attribute) to an account.
- Do not skip an account that you need for analysis.

For example, suppose that an IT Salaries account is assigned to an IT Help Desk account, and that the IT Help Desk account is subsequently assigned to a Design Products account. Ensure that a different Stages attribute is added to each account. Do not skip the IT Help Desk account.

- Do not add Stages attributes to accounts that you do not need for analysis.

Every account that has a Stages attribute is included in the Multi-stage Contributions cube. The cube can be generated more quickly if unnecessary accounts are omitted.

- To avoid performance problems, do not exceed six to eight stages.

**See Also**

“Add Stage Attributes to Accounts” on page 287
Chapter 34

Attributes on Dimension Members

General Description

Introduction
Setting an attribute on a dimension member sets the attribute on multiple accounts automatically.

Setting an attribute on a dimension member is an indirect method of setting the attribute on all the accounts whose dimension signature includes that dimension member. One reason that it is important to be able easily to set attributes on accounts is because having attributes on accounts is particularly important for generating rule-based drivers. Setting attributes on dimension members provides a method of quickly setting those attributes on many accounts.

To understand how setting an attribute on a dimension member works, first remember that an account is an intersection of dimension members. An account is defined by that intersection, which is called its dimension signature (or alternatively, its dimension identifier). For example, in the following picture you can see that the account 2nd Day Guaranteed is the intersection of the dimension members Beaverton x Drop Box x 2nd Day Guaranteed. Those dimension members are, in turn, members of the dimensions Region x Channel x Products and Services, respectively.

Note: The display name of the account, 2nd Day Guaranteed, is the name of the last member in the intersection of the dimension members when the order of dimension members is the order of their containing dimensions—Region, Channel, Products. The order of dimensions is the order in which you define them when you create a model.
Now, if you set an attribute on the dimension member Beaverton, you would automatically set the attribute on the 2nd Day Guaranteed account because its dimension signature is Beaverton x Drop Box x 2nd Day Guaranteed. And, in fact, you would automatically set the attribute on all the accounts whose dimension signature includes Beaverton.

**An Example**

Let's look at an example.

1. Create an attribute:

   You can use any existing attribute, but for this example suppose that you create a numeric attribute named `AttributeOnADimensionMember` with a default value of 100, as shown in the following picture.

2. Go to the model's Dimension view, and select the period in which the attribute is to be applied.

3. Select a dimension member, and select **Manage Attributes** to attach the attribute to the dimension member.
For this example, attach the attribute, AttributeOnADimensionMember, to the Beaverton dimension member in the Region dimension.

In fact, there are two ways in which to attach an attribute to a dimension member. And, you can modify the columns in the Dimension view to display attributes. For more information, see “Attach an Attribute to a Dimension Member” on page 261.

4. The result is that the attribute, AttributeOnADimensionMember, is applied to every account whose dimension signature includes Beaverton, as shown in the following picture.
You can see that the attribute with its default value is now on every account with the dimension member of Beaverton, but it is not on accounts with the dimension member Eugene. And, note, moreover, that the preceding picture shows only the Cost Object module. As a result of attaching dimension attributes to accounts, other modules that have accounts whose dimension signature includes Beaverton would also have attributes attached to those accounts. In short, an attribute that you initially assigned to a dimension member is now on multiple accounts.

**Frequently Asked Questions**

**FAQ**
- “What type of attributes can you attach to dimension members?” on page 255
- “Where precisely can you attach the attributes?” on page 255
- “Attribute associations are periodic” on page 257
- “How are attribute values inherited from dimension members?” on page 258
- “What are the default values for such attributes?” on page 258
- “System-generated versus user-entered attribute values” on page 259
- “What happens when a dimension member is re-parented?” on page 260

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Attribute On ADimension Member</th>
</tr>
</thead>
<tbody>
<tr>
<td>COST OBJECT (PRIMARY PANE)</td>
<td></td>
</tr>
<tr>
<td>USA</td>
<td></td>
</tr>
<tr>
<td>Oregon</td>
<td></td>
</tr>
<tr>
<td>Beaverton</td>
<td></td>
</tr>
<tr>
<td>No &lt;Channel&gt;</td>
<td></td>
</tr>
<tr>
<td>No 2nd Day Guaranteed</td>
<td>100.00</td>
</tr>
<tr>
<td>No Overnight Express</td>
<td>100.00</td>
</tr>
<tr>
<td>No Standard Ground</td>
<td>100.00</td>
</tr>
<tr>
<td>Drop Box</td>
<td></td>
</tr>
<tr>
<td>No &lt;Products and Services&gt;</td>
<td>100.00</td>
</tr>
<tr>
<td>No 2nd Day Guaranteed</td>
<td>100.00</td>
</tr>
<tr>
<td>No Overnight Express</td>
<td>100.00</td>
</tr>
<tr>
<td>No Standard Ground</td>
<td>100.00</td>
</tr>
<tr>
<td>Walk In</td>
<td></td>
</tr>
<tr>
<td>No &lt;Products and Services&gt;</td>
<td>100.00</td>
</tr>
<tr>
<td>No 2nd Day Guaranteed</td>
<td>100.00</td>
</tr>
<tr>
<td>No Overnight Express</td>
<td>100.00</td>
</tr>
<tr>
<td>No Standard Ground</td>
<td>100.00</td>
</tr>
<tr>
<td>Commercial Pick-up</td>
<td></td>
</tr>
<tr>
<td>No &lt;Products and Services&gt;</td>
<td>100.00</td>
</tr>
<tr>
<td>No 2nd Day Guaranteed</td>
<td>100.00</td>
</tr>
<tr>
<td>No Overnight Express</td>
<td>100.00</td>
</tr>
<tr>
<td>No Standard Ground</td>
<td>100.00</td>
</tr>
<tr>
<td>Eugene</td>
<td></td>
</tr>
<tr>
<td>No &lt;Channel&gt;</td>
<td></td>
</tr>
<tr>
<td>Drop Box</td>
<td></td>
</tr>
<tr>
<td>No &lt;Products and Services&gt;</td>
<td></td>
</tr>
<tr>
<td>No 2nd Day Guaranteed</td>
<td></td>
</tr>
<tr>
<td>No Overnight Express</td>
<td></td>
</tr>
<tr>
<td>No Standard Ground</td>
<td></td>
</tr>
<tr>
<td>Walk In</td>
<td></td>
</tr>
<tr>
<td>Commercial Pick-up</td>
<td></td>
</tr>
</tbody>
</table>
What type of attributes can you attach to dimension members?

You can attach any type of attribute to a dimension member, including dimension attributes and calculated attributes.

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text attribute</td>
<td>Text</td>
<td>Text</td>
</tr>
<tr>
<td>Tag attribute</td>
<td>Tag</td>
<td>Tag</td>
</tr>
<tr>
<td>Numeric attribute</td>
<td>Numeric</td>
<td>Numeric</td>
</tr>
<tr>
<td>Calculated numeric attribute</td>
<td>Calculated numeric attribute</td>
<td>Numeric</td>
</tr>
<tr>
<td>Dimension attribute</td>
<td>Dimension</td>
<td>Dimension</td>
</tr>
</tbody>
</table>

So, you can attach any of the following types of attributes to a dimension member:

- Text
- Tag (Boolean)
- Numeric (including calculated numeric)
- Dimension

Where precisely can you attach the attributes?

- You can attach an attribute to any dimension member.
- You cannot attach an attribute to a dimension.

For example, in the following picture, you can attach an attribute to (among others) the dimension members Personnel Intensive Activities (Level1) and Resolve Customer Complaints (Level2), but you cannot attach an attribute to the Activities dimension.

- You cannot attach an attribute to a dimension attribute.

You can attach an attribute only to a structural dimension. Thus, for example, in the Parcel Express Tutorial model, you cannot attach an attribute to the FixedVariable dimension attribute.
Do not be confused by terminology. A dimension attribute is called "dimension attribute" because it is like an ordinary (structural) dimension in that it is an element of an OLAP cube. Inside an OLAP cube there is no distinction between dimension attributes and structural dimensions. They are both dimensions of a measure.

However, whereas you can not attach an attribute to a dimension attribute, you can attach a dimension attribute to a dimension member. For example, in the following picture, the dimension attribute Fixed_Variable is attached to the following dimension members:

- Personnel Intensive Activities (with a value of Variable)
- Air Distribution (with a value of Variable)
- Land Distribution (with a value of Fixed)

The picture also shows the result of attaching the attribute Fixed_Variable to accounts. You can see that the attribute is attached to four different accounts in the Beaverton region. (It would also be attached to the appropriate accounts in the Eugene region, but those accounts are not shown.)

- You can not attach an attribute to a dimension attribute.

For example, in the following picture, if you have attached a particular attribute to the Beaverton dimension member (which is in the Region dimension), then you can
not attach the same attribute to the Drop Box dimension because it is in the Channel

dimension.

The reason for this restriction is to avoid conflicting attribute assignments. Suppose
that you could attach the same attribute to dimension members in different
dimensions. Take, for example, our previous example of the 2nd Day Guaranteed
account whose dimension signature is Beaverton x Drop Box x 2nd Day Guaranteed.
Suppose that the attribute AttributeOnDimensionMember has the value 100 when it
is attached to the Beaverton dimension member. And, suppose that the same attribute
has the value 99 when it is attached to the Drop Box dimension member. Then, the
2nd Day Guaranteed account will get the AttributeOnDimensionMember attribute
from both the Beaverton dimension member and the Drop Box dimension member.
But, in that case, what is its value? Is it 100 (from Beaverton) or 99 (from Drop
Box)?

Attribute associations are periodic

When you attach an attribute to a dimension member, you attach it in a particular period.
Consequently, a dimension member can have a particular attribute in one period but not
in another. And, it can have one value in a particular period and a different value in
another period.
How are attribute values inherited from dimension members?

When an attribute on a dimension member is applied to an account, and when there are additional attributes on dimension members in the same dimension hierarchy, then the first dimension member found up the hierarchy from the account is used.

For example, in the following picture the value of the attribute AttributeOnDimensionMember is 5 on the account, Portland x Drop Box x 2nd Day Guaranteed. It is 5 because there is no attribute on the Portland dimension member, so the account inherits the value 5 from the attribute AttributeOnDimensionMember on the parent dimension member, Oregon. The value of the attribute, AttributeOnDimensionMember, is 10 on the accounts that inherit from the Beaverton dimension member. The value is 15 on the accounts that inherit from the Eugene dimension member.

What are the default values for such attributes?

Because attributes on dimension members are ordinary attributes, once they have been applied to accounts, they have the same default values as ordinary attributes:

- For attributes with a user-defined default value for the active period/scenario, the attribute is initialized with the user-defined default value.
- Numeric attributes that do not have a user-defined default value are initialized with zero. Calculated numeric attributes are initialized with the result of their formula.
- Text attributes are initialized with an empty string.
- Tag attributes and dimension attributes do not have a value, so they are not initialized with a default value.

Despite the existence of default values, an error occurs during calculation if an attribute is referenced in a formula and both of the following conditions are true:

- the attribute has no user-defined default value, and
• the attribute is not attached to the account whose formula is being evaluated (for the period being calculated).

If either of the preceding conditions is false, then no error occurs during calculation. That is, no error occurs if either of the following conditions is true (the negations, respectively, of the preceding conditions):

• the attribute has a user-defined default value (even if it is not attached to the account whose formula is being evaluated), or

• the attribute is attached to the account whose formula is being evaluated (even if it has no user-defined default value).

**System-generated versus user-entered attribute values**

When an attribute on a dimension member is applied to an account, the account receives the attribute with its default value, if one is defined for that period/scenario. The following question then arises:

• What happens if you edit the attribute on that account to modify the value? Does the attribute on the account once again receive its default value, or does it retain its modified value?

• The answer is that it retains its modified value.

SAS Cost and Profitability Management distinguishes between system-generated attribute values and user-entered attribute values:

• A system-generated attribute value is the value that an attribute on an account receives when the attribute is applied to the account in virtue of having been attached to a dimension member.

• A user-entered attribute value is the value that an attribute on an account receives when you, the user, modifies the attribute value.

**Note:**

• An attribute value is considered to be user-entered even if you overwrite the attribute value with exactly the same value. It is sufficient to type into the attribute value field, no matter what you type.

• You can not change the attribute value of a system-generated tag attribute. That is, if you attach a tag attribute to a dimension member, then it is automatically applied to every account whose dimension signature includes that dimension member and you can not remove it from any such account except by removing it from the dimension member (which automatically removes it from every account whose dimension signature includes that dimension member). If you want to apply a tag attribute to some accounts and not others, then you can do so on individual accounts.

Once an attribute value is marked as user-entered, the only way in which it can be returned to system-generated (if you want to return to using its default value) is by doing the following:

1. Remove the attribute from the dimension member. (That is, remove the association between the attribute and the dimension member—this does not mean deleting the attribute itself.)

2. Re-attach the attribute to the dimension member with the default value desired.

**Note:** Tag attributes and dimension attributes do not have a value, so the question of their default value does not arise.
When you re-parent a dimension member, accounts that have that dimension member in their signature can no longer inherit attributes from the old parent of that dimension member (assuming that the old parent is another dimension member). They now inherit attributes from the new parent (assuming, again, that the new parent is another dimension member).

For example, in the following picture, Portland is moved out from under Oregon to be directly under USA. This means that accounts whose dimension signature includes Portland no longer can inherit from any attributes on the Oregon dimension member.

Importing and exporting attributes on dimensions

When you export a model, the associations of attributes with dimension members are exported. If you subsequently import the same model, then dimension members have the same attributes that they had when the model was exported, as do the accounts to which those attributes apply.

See Also

- “Attach an Attribute to a Dimension Member” on page 261
- “Remove Attributes from Dimension Members” on page 265
Attach an Attribute to a Dimension Member

Introduction

Attaching attributes to dimension members is done in two stages:
- “Define the Attribute Columns to be Displayed in the Dimensions View” on page 261
- “Attach Attributes to Dimension Members” on page 263

Define the Attribute Columns to be Displayed in the Dimensions View

1. Select Model ➔ Dimensions.
2. Select Model ➔ Column Layout ➔ Edit Columns to open the Column Layout dialog box.
   Note: You can also double-click the column header.

The Column Layout dialog opens, showing the layout for the Dimensions view.

3. Select and add the attributes that you want to display in the column layout so that you can attach them to dimension members.

   For each attribute that you select, specify the following:
Column Name
The column name is the name that is displayed in the Dimensions view to identify an attribute on a dimension member. It is an arbitrary name that you can assign to enable you to recognize an attribute. It might identify the period and scenario in which the attribute is assigned so that you can distinguish different instances of the same attribute applied to different periods and scenarios.

Period/Scenario
The period and scenario in which this attribute is applied when it is applied to an account. Attributes on dimension members are periodic. They can have different values in different periods and scenarios.

Format
Click the format icon to open the Format Column dialog to format the column display of the attribute.

Note: The following fields of the Column Layout dialog are not modifiable. They are for information only:

Field Name
The Field Name is the name of the attribute that you assigned to it when you created it.
Type

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Field Name</th>
<th>Type</th>
<th>Period/Scenario</th>
<th>Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>DimLevelName</td>
<td>DimLevelName</td>
<td>Dimension Level</td>
<td>&lt;&lt; Current &gt;&gt;</td>
<td>A</td>
</tr>
<tr>
<td>Attr1 (current)</td>
<td>Attr1 (current)</td>
<td>Attribute (current)</td>
<td>&lt;&lt; Current &gt;&gt;</td>
<td>A</td>
</tr>
<tr>
<td>Attr1 (period 1)</td>
<td>Attr1 (period 1)</td>
<td>Attribute (period)</td>
<td>&lt;&lt; Current &gt;&gt;</td>
<td>A</td>
</tr>
<tr>
<td>Attr1 (period 2)</td>
<td>Attr1 (period 2)</td>
<td>Attribute (period)</td>
<td>&lt;&lt; Current &gt;&gt;</td>
<td>A</td>
</tr>
</tbody>
</table>

4. Click **Save As** if you want to save the column layout.

5. Click **OK**.

The Attribute Layout dialog closes and returns to the Dimensions view, with the attribute columns displayed that you just defined.

**Note:** The attributes are not yet attached to any dimension members. You have only determined what attribute columns to display.

**Attach Attributes to Dimension Members**

There are two ways to attach an attribute to a dimension member:
- Attach attributes using the Dimensions view
- Attach attributes using the Manage Attributes dialog

**Attach attributes using the Dimensions view**
After defining the attribute columns to be displayed in the Dimensions view, type the attribute value (or select the value for a dimension attribute) in the column cell for a dimension member.

**Note:** The period to which the value that you type applies is the period specified for this column in the Column Layout dialog, as shown for example in the following picture:

**Note:** You can not use this method for attaching a calculated numeric attribute (because you don't enter its value—it is calculated)

**Attach attributes using the Manage Attributes dialog**

To use the Manage Attributes dialog:

1. Select **Model ⇒ Dimensions**.

2. Select a period/scenario association. The period/scenario that you select is the period/scenario in which any attribute that you add will apply.

3. Select a dimension member, right-click, and select **Manage Attributes**.

   The Manage Attributes dialog opens.
4. Select the attributes that you want to attach to the dimension member.

5. Click **OK**.

**See Also**

“Remove Attributes from Dimension Members” on page 265

---

**Remove Attributes from Dimension Members**

There are three ways in which you can remove the association of attributes with dimension members:

- Remove a particular attribute from a dimension member
- Remove all attributes from a dimension member
- Remove attributes using the Manage Attributes dialog

**Remove a particular attribute from a dimension member**

To remove a particular attribute from a dimension member:

1. Select **Model ➔ Dimensions** to open the Dimensions view.

2. Right-click on the cell where the column for the attribute to be deleted intersects the row of the dimension member from which the attribute is to be removed (see the following picture), and select **Delete Attribute Association**.
Remove all attributes from a dimension member

To remove all attributes from a dimension member:

1. Select Model -> Dimensions to open the Dimensions view.
2. Right-click on the dimension member from which you want to remove all attributes, and select Delete All Attribute Associations.

Remove attributes using the Manage Attributes dialog

To use the Manage Attributes dialog:

1. Select Model -> Dimensions to open the Dimensions view.
2. Select a dimension member, right-click, and select Manage Attributes.

The Manage Attributes dialog opens.
3. Select the attribute that you want to remove from the dimension member, and then click Remove.

4. Click OK to close the Manage Attributes dialog.
Chapter 35
Windows for Attributes

Attributes View ................................................................. 270
About the Attributes View .................................................. 270
How to Access the Attributes View ...................................... 270
New Attribute Dialog Box ..................................................... 271
About the New Attribute Dialog Box ..................................... 271
How to Access the New Attribute Dialog Box ......................... 271
General Tab ................................................................. 271
Advanced Tab (for a Numeric Attribute) ......................... 272
Manage Attributes Dialog Box ............................................... 273
About the Manage Attributes Dialog Box .............................. 273
How to Access the Manage Attributes Dialog Box ................. 273
System Generated Attributes ................................................. 274
Attribute Properties Dialog Box ............................................... 274
About the Attribute Properties Dialog Box ............................. 274
How to Access the Attribute Properties Dialog Box ............... 274
General Tab ................................................................. 275
Advanced Tab (for a Numeric Attribute) ......................... 276
Find a Property or Attribute Dialog Box ................................. 277
About the Find a Property or Attribute Dialog Box .......... 277
How to Access the Find a Property or Attribute Dialog Box ....... 277
Search for Properties and Attributes Dialog Box .................... 278
About the Search for Properties and Attributes Dialog Box .... 278
How to Access the Search for Properties and Attributes Dialog Box 278
Attribute Folder Properties Dialog Box .................................... 278
About the Attribute Folder Properties Dialog Box ............. 278
How to Access the Attribute Folder Properties Dialog Box .... 279
New Attribute Folder Dialog Box ............................................... 279
About the New Attribute Folder Dialog Box ....................... 279
How to Access the New Attribute Folder Dialog Box ............. 279
Attributes View

About the Attributes View

The availability of this feature depends on your permissions.

On the Attributes view, you can manage a model's attributes.

Note: You cannot directly edit the information on the Attributes view.

See Also

- Chapter 33, “Types of Attributes,” on page 245
- Chapter 36, “How To: Attributes,” on page 281
- Chapter 34, “Attributes on Dimension Members,” on page 251

How to Access the Attributes View

Open a model and select Model ⇒ Attributes View.

See Also

- Chapter 33, “Types of Attributes,” on page 245
- “Create an Attribute” on page 281
- Chapter 36, “How To: Attributes,” on page 281
New Attribute Dialog Box

About the New Attribute Dialog Box

In the New Attribute dialog box, you can name a new attribute and you can specify other information about the attribute. You can create a dimension attribute folder.

Note: The availability of these features depends on your permissions.

How to Access the New Attribute Dialog Box

On the Attributes view, select either an attribute folder or ATTRIBUTES and select Edit ⇒ New Attribute.

General Tab

Specify the following general information for an attribute:

Name
   See “Attribute naming conventions” on page 44.

Reference
   See “Attribute reference conventions” on page 49.

Short Reference
   A short reference is required only when the type of attribute is Dimension.
Attribute type
See Chapter 33, “Types of Attributes,” on page 245.

Note: If you select Dimension when either ATTRIBUTES or an existing dimension attribute is selected, you will create a dimension attribute folder, not a dimension attribute.

Unit of measure
A unit of measure is required only for a numeric attribute.

Advanced Tab (for a Numeric Attribute)

<table>
<thead>
<tr>
<th>General</th>
<th>Advanced</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Define the characteristics that are specific to the selected period and scenario.

Using this period/scenario association:

2012 / Actual

Default value:

[ ] Calculated

Formula: [Formula Builder...]

The Advanced tab is available only for numeric attributes.

Using this period/scenario association
The value of a numeric attribute is periodic—it can vary from one period to another.

Default value
(Optional) Specify the value that this attribute is to have unless it is overridden when the attribute is attached to a particular account.

Note: A numeric attribute can have a default value even if the attribute is not attached to any account. The default value can be used, for example, in a driver formula. See “Using Numeric Attributes in a Formula” on page 441.

Calculated
Select this option for a calculated driver. See Chapter 44, “Calculated Driver,” on page 367.

Click Formula Builder to define a formula. See “Formula Builder Dialog Box” on page 445.

The Formula Builder dialog box appears.
Manage Attributes Dialog Box

About the Manage Attributes Dialog Box

In the Manage Attributes dialog box, you can add or remove attributes and change their value.

The availability of these features depends on your permissions.

How to Access the Manage Attributes Dialog Box

- In a module view, select an account and select Edit ➔ Manage Attributes.
- In the Dimensions view, select a dimension member and select Edit ➔ Manage Attributes.

Adding an attribute to a dimension member is an indirect way of adding the attribute to all the accounts that include that dimension member in its dimension signature. See Chapter 34, “Attributes on Dimension Members,” on page 251.

See Also

- “Attributes View” on page 270
- Chapter 33, “Types of Attributes,” on page 245
- Chapter 34, “Attributes on Dimension Members,” on page 251
System Generated Attributes

An attribute on an account is System Generated when it is added by the system to the account as a result of your having added the attribute to a dimension member that is in the dimension signature of that account.

Note: If you change the value of a system-generated attribute from its default value, then it is no longer a system-generated attribute. See “System-generated versus user-entered attribute values” on page 259.

See Also
Chapter 34, “Attributes on Dimension Members,” on page 251

Attribute Properties Dialog Box

About the Attribute Properties Dialog Box

In the Attribute Properties dialog box, you can review or change information about an attribute.

The availability of these features depends on your permissions.

How to Access the Attribute Properties Dialog Box

On the Attributes view, select an attribute, and select Edit ➤ Item Properties.

See Also
“Attributes View” on page 270
**General Tab**

<table>
<thead>
<tr>
<th>General</th>
</tr>
</thead>
<tbody>
<tr>
<td>Define the basic characteristics that remain constant across all periods and scenarios in the model.</td>
</tr>
<tr>
<td>Name:</td>
</tr>
<tr>
<td>Reference:</td>
</tr>
<tr>
<td>Short Reference:</td>
</tr>
<tr>
<td>Attribute type: Dimension</td>
</tr>
<tr>
<td>Unit of measure:</td>
</tr>
</tbody>
</table>

Specify the following general information for an attribute:

**Name**
See “Attribute naming conventions” on page 44.

**Reference**
See “Attribute reference conventions” on page 49.

**Short Reference**
A short reference is required only when the type of attribute is Dimension.

**Attribute type**
See Chapter 33, “Types of Attributes,” on page 245.

*Note:* If you select Dimension when either ATTRIBUTES or an existing dimension attribute is selected, you will create a dimension attribute folder, not a dimension attribute.

**Unit of measure**
A unit of measure is required only for a numeric attribute.
Advanced Tab (for a Numeric Attribute)

The Advanced tab is available only for numeric attributes.

Using this period/scenario association
The value of a numeric attribute is periodic—it can vary from one period to another.

Default value
(Optional) Specify the value that this attribute is to have unless it is overridden when the attribute is attached to a particular account.

Note: A numeric attribute can have a default value even if the attribute is not attached to any account. The default value can be used, for example, in a driver formula. See “Using Numeric Attributes in a Formula” on page 441.

Calculated
Select this option for a calculated driver. See Chapter 44, “Calculated Driver,” on page 367.

Click Formula Builder to define a formula. See “Formula Builder Dialog Box” on page 445.

The Formula Builder dialog box appears.

TIP You can also modify the formula in the Formula box.

See Also

“Calculated Attributes” on page 248
Find a Property or Attribute Dialog Box

About the Find a Property or Attribute Dialog Box

Use this dialog to find a property or attribute that you want to select in order to build a search query in the Search for Accounts dialog box.

How to Access the Find a Property or Attribute Dialog Box

In the Search for Accounts dialog box, click Find.

See Also

- “Search for Accounts Dialog Box” on page 211
- “Search Account Results Dialog Box” on page 212
Search for Properties and Attributes Dialog Box

**About the Search for Properties and Attributes Dialog Box**

In the Search for Properties and Attributes dialog box, you can find data to display when you add a column, or you can find a property when you review the properties of an item or when you review the attributes of an item.

![Search for Properties and Attributes Dialog Box](image)

**How to Access the Search for Properties and Attributes Dialog Box**

Do one of the following:

- In the Column Layout dialog box, click **Search**.
  See “Column Layout Dialog Box” on page 309.
- In the Item Properties dialog box, click **Search**.
  See “Item (Account) Properties and Attributes Dialog Box” on page 213.

Attribute Folder Properties Dialog Box

**About the Attribute Folder Properties Dialog Box**

In the Attribute Folder Properties dialog box, you can review or change information about an attribute folder.
The availability of this feature depends on your permissions.

**How to Access the Attribute Folder Properties Dialog Box**

On the Attributes view, select a folder, and select **Edit ➤ Item Properties**.

**New Attribute Folder Dialog Box**

**About the New Attribute Folder Dialog Box**

In the New Attribute Folder dialog box, you can name a new folder and you can specify the folder's reference.

*Note:* The availability of these features depends on your permissions.

**How to Access the New Attribute Folder Dialog Box**

On the Attributes view, select an item and select **Edit ➤ New Folder**.

**See Also**

- “Attributes View” on page 270
- “Naming Conventions” on page 43
- “Reference Conventions” on page 48
Chapter 36
How To: Attributes

Create an Attribute

1. Open a model and select Model ⇒ Attributes Page.
   The Attributes page appears.

2. Select the folder in which the attribute is to go.
   A dimension attribute can go in the ATTRIBUTES folder or in an existing dimension attribute.
   Other attributes can go in the ATTRIBUTES folder or in another attribute folder.
3. Select **Edit** $\rightarrow$ **New Attribute**.

The New Attribute dialog box appears.

4. Type the **Name**.

The name must follow the naming conventions. See “Naming Conventions” on page 43.

5. Type the **Reference**.

An attribute reference is required only for dimension attributes and is used in public views. See the chapter on “Public Views” in the *SAS Activity-Based Management Data Administration Guide*. A reference must follow the reference conventions. See “Reference Conventions” on page 48.

6. Select the **Attribute type**.

   **Note:** If you select **Dimension** when either **ATTRIBUTES** or an existing dimension attribute is selected, you will create a dimension attribute folder, not a dimension attribute.

   **For a numeric attribute only:**

7. Type the **Unit of measure**.

8. Click the **Advanced** tab.
9. From the **Using this period/scenario association** drop-down list, select a period/scenario association.

10. Type the **Default value**.

11. If this is a calculated attribute, perform the following steps:
   a. Select the **Calculated** option.
   b. Click **Formula Builder**.
      
      The Formula Builder dialog box appears.
You can also modify the formula in the Formula box.

c. Select an item from the list of Numeric properties, from the list of Operators, or from the list of Attributes.

d. Click Insert.

The item is added to the formula.

**Tip** You can also type the formula.

e. Continue to insert items until you have built the entire formula.

f. To remove the last item that you inserted, click Undo.

g. To delete the entire formula, click Clear.

h. Click Test.

If no errors are displayed, the syntax of the formula is valid.

**See Also**

- Chapter 33, “Types of Attributes,” on page 245
- “Add an Attribute to an Account” on page 285
- “Specify an Attribute's Value” on page 286
- “Show the Accounts To Which an Attribute Has Been Added” on page 288
- “Remove an Attribute from an Account” on page 289

**Create a Dimension Attribute**

1. Select ATTRIBUTES or an existing dimension attribute.
2. Select Edit ⇒ New Attribute.
   The New Attribute dialog box appears. See “New Attribute Dialog Box” on page 271.

See Also

“Dimension Attributes, Dimension Member Attributes, and Dimension Value Attributes” on page 246

Create an Attribute Folder

1. Open a model and select Model ⇒ Attributes Page.
   The Attributes page appears.
2. Select an attribute folder (other than a dimension attribute folder) within which to create the new folder.
   The New Attribute Folder dialog box appears.
4. Type the Name.
   The name must follow the naming conventions. See “Naming Conventions” on page 43.
5. Type the Reference.
   A default reference is created from the name. If you change the reference, the new reference must follow the reference conventions. See “Reference Conventions” on page 48.

Add an Attribute to an Account

Note: This topic describes how to add an attribute directly to an account. You can also add an attribute to accounts indirectly by adding the attribute to a dimension member that is included in an account’s dimension signature. For information, see Chapter 34, “Attributes on Dimension Members,” on page 251.

1. On a module page, select an account, and select Edit ⇒ Manage Attributes.
   The Manage Attributes dialog box appears.
2. From the Attribute hierarchy list, select an attribute.

3. Click Add >.

   The attribute is added to the Account's attributes list.

See Also

“Specify an Attribute's Value” on page 286

Add an Attribute to a Dimension Member

You can add an attribute to a dimension member as an indirect way of adding the attribute to account. If you add an attribute to a dimension member, then the system automatically adds the attribute to all the accounts whose dimension signature includes that dimension member.

See Chapter 34, “Attributes on Dimension Members,” on page 251.

Specify an Attribute's Value

1. On a module page, select an account, and select Edit ➤ Manage Attributes.

   The Manage Attributes dialog box appears.

2. From the Account's attributes list, select an attribute.

3. Set the Value.

   The type of value that you can specify depends on the type of attribute.
Add Stage Attributes to Accounts

Overview

Adding stage attributes to accounts requires two steps:

1. Create stage attributes
2. Add stage attributes to accounts

To Create Stage Attributes:

1. Open a model and select Model ⇒ Attributes view. The Attributes view opens.
2. On the Attributes view, select Edit ⇒ New Attribute (or click the New Attribute button). The New Attribute dialog box opens.
3. In the New Attribute dialog box, specify Stages as the name of the new attribute and select Dimension as its Attribute Type, then click OK.
4. On the Attributes view, select the Stages dimension (that you created in Step 3) and select Edit ⇒ New Attribute (or click the New Attribute button). The New Attribute dialog box opens again.
5. From the New Attribute dialog box, name the new attribute (which represents a stage) and select Dimension Member as the Attribute Type.
6. Repeat steps 4 and 5 for as many times as you want stages - one dimension member attribute per stage.

The direction of cost flow between stages is determined by the display order of stage attributes, so you can assign any name and reference to stages that you want. For example, in the following picture you can see that the display order of three stage attributes is:

1. Planning
2. Acquisition
3. Fabrication

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>ATTRIBUTES</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ATTRIBUTES (PRIM. PANE)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Stages</td>
<td>Stages</td>
<td>Dimension</td>
</tr>
<tr>
<td>Planning</td>
<td>Planning</td>
<td>Dimension Member</td>
</tr>
<tr>
<td>Acquisition</td>
<td>Acquisition</td>
<td>Dimension Member</td>
</tr>
<tr>
<td>Fabrication</td>
<td>Fabrication</td>
<td>Dimension Member</td>
</tr>
</tbody>
</table>

Consequently, Planning flows to Acquisition which flows to Fabrication because that is their display order.
To Add Stage Attributes to Accounts, Do One of the Following:

- Add attributes from the Manage Attributes dialog box.
- Search for accounts and add attributes to accounts that are found.

*Note:* All of the accounts for a stage must belong to the same module (Resource, Activity, Cost Object, or external Unit). The following picture shows adding the stage1 attribute to accounts that are found as a result of searching for accounts.

See Also

“Stage Attributes” on page 249

Show the Accounts To Which an Attribute Has Been Added

You can divide the Attributes page to see the accounts to which an attribute has been added.

1. Select **Model ➔ Attributes**.
   The Attributes page appears.

2. Select **Model ➔ Assignments ➔ Show Right Assignments Pane**.
   The right assignments pane is displayed.

3. Select an attribute.
4. Select Model ⇔ Assignments ⇔ Show Right.

If the attribute has been added to any accounts, then those accounts are displayed.

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attributes</td>
<td>Attributes</td>
<td></td>
</tr>
<tr>
<td>Value Added</td>
<td>Value Added</td>
<td>Text</td>
</tr>
<tr>
<td>Non Value Added</td>
<td>Non Value Added</td>
<td>Text</td>
</tr>
</tbody>
</table>

Remove an Attribute from an Account

1. On a module page, select a account, and select Edit ⇔ Manage Attributes.

   The Manage Attributes dialog box appears.

2. From the Account's attributes list, select an attribute.

3. Click Remove.

   The attribute is removed from the Attribute hierarchy list.

Delete an Attribute

1. Open a model and select Model ⇔ Attributes Page.

2. Select an attribute.

3. Select Edit ⇔ Delete.

Change the Properties of an Attribute

1. Open a model and select Model ⇔ Attributes Page.

2. Select an attribute.

3. Select Edit ⇔ Item Properties.

   The Attribute Properties dialog box appears. See “Attribute Properties Dialog Box” on page 274.
Part 12

Column Layouts

Chapter 37

Working with Column Layouts ........................................... 293

Chapter 38

Windows for Column Layouts ........................................... 309

Chapter 39

How To: Column Layouts .................................................. 313
Chapter 37
Working with Column Layouts

What is a Column Layout?
SAS Cost and Profitability Management displays information in a grid. A column layout is a set of column headers for a grid along with the specification for how information in those columns should appear.

Using the Column Layout dialog (“Column Layout Dialog Box” on page 309) you can customize and save your own column layouts for the following:

- Module views
- Dimensions view
It is important to understand that a column layout for a module view specifies the columns for all the panes of the module view:

- Left pane
- Primary pane
- Right pane

In addition to custom column layouts that you define, the system provides a number of layouts for your use. You can find all the column layouts in the Column Layouts folder of the Workspace manager. See “Workspace Manager” on page 27.
You can import and export your saved custom column layouts:

- “Import a Column Layout” on page 643
- “Export a Column Layout” on page 643

You can also set the default column layout for each module in a model and for the Dimensions view of a model:

- See “Specify a Default Column Layout” on page 325.

---

**System Column Layouts**

SAS Cost and Profitability Management provides the following predefined column layouts. You can not modify these layouts, but you can add to or remove columns from them and then save the layout by another name for future use as a custom column layout.

**Note:** Intersection Name is a required column which cannot be removed in the Left and Right panes. Display name is a required column in the Primary pane and also cannot be removed.

**Default Dimension**

This view is presented by default when you open the Dimensions view.

<table>
<thead>
<tr>
<th>Primary pane</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
</tr>
<tr>
<td>ShortRef</td>
</tr>
<tr>
<td>Reference</td>
</tr>
<tr>
<td>DimLevelName</td>
</tr>
</tbody>
</table>

**Default (Module View)**

This view is presented by default when you view a module. It contains minimal column information.
### Cost Flow
This view is designed to display the properties needed to explain the flow of cost through the model. It is optimized for the three-pane view.

<table>
<thead>
<tr>
<th>Left pane</th>
<th>Primary pane</th>
<th>Right pane</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Intersection Name)</td>
<td>(Display Name)</td>
<td>(Intersection Name)</td>
</tr>
<tr>
<td>Reference</td>
<td>Display Reference</td>
<td>Reference</td>
</tr>
<tr>
<td>Cost</td>
<td>Cost</td>
<td>Cost</td>
</tr>
</tbody>
</table>

### Advanced Cost Flow
This view gives a detailed view of the cost flows, including allocations, drivers, idle costs and unassigned costs. It is optimized for the primary and right panes.

<table>
<thead>
<tr>
<th>Left pane</th>
<th>Primary pane</th>
<th>Right pane</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Intersection Name)</td>
<td>(Display Name)</td>
<td>(Intersection Name)</td>
</tr>
<tr>
<td>DrvName</td>
<td>DrvName</td>
<td>DrvCost</td>
</tr>
<tr>
<td>Cost</td>
<td>Cost</td>
<td>DrvQtyCalc</td>
</tr>
<tr>
<td>AllocCost</td>
<td>DrvAllocCost</td>
<td></td>
</tr>
<tr>
<td>DrvnCost</td>
<td>DrvIdlCost</td>
<td></td>
</tr>
<tr>
<td>IdlCost</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AsgnIdlCost</td>
<td></td>
<td></td>
</tr>
<tr>
<td>UnAsgnCost</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Assignment
This view is used when making assignments and entering or verifying properties of the assignment relationship. It is optimized for the primary and left panes.

<table>
<thead>
<tr>
<th>Left pane</th>
<th>Primary pane</th>
<th>Right pane</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Intersection Name)</td>
<td>(Display Name)</td>
<td>(Intersection Name)</td>
</tr>
<tr>
<td>Reference</td>
<td>Reference</td>
<td>Reference</td>
</tr>
<tr>
<td>DrvName</td>
<td>DrvName</td>
<td>DQF</td>
</tr>
<tr>
<td>Cost</td>
<td>TDQCalc</td>
<td>DQV</td>
</tr>
<tr>
<td></td>
<td></td>
<td>DWF</td>
</tr>
<tr>
<td></td>
<td></td>
<td>DWV</td>
</tr>
<tr>
<td></td>
<td></td>
<td>DrvQtyCalc</td>
</tr>
<tr>
<td></td>
<td></td>
<td>DrvAllocCost</td>
</tr>
</tbody>
</table>
IdleTracking
This view is used for managing idle cost flows. It is optimized for the primary and right panes only.

<table>
<thead>
<tr>
<th>Left pane</th>
<th>Primary pane</th>
<th>Right pane</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Intersection Name)</td>
<td>(Display Name)</td>
<td>(Intersection Name)</td>
</tr>
<tr>
<td>DrvName</td>
<td>IdlQtyUE</td>
<td></td>
</tr>
<tr>
<td>TDQCalc</td>
<td>DrvQtyCalc</td>
<td></td>
</tr>
<tr>
<td>TDQUE</td>
<td>DQF</td>
<td></td>
</tr>
<tr>
<td>IdlQty</td>
<td>DQV</td>
<td></td>
</tr>
<tr>
<td>UnAsgnQty</td>
<td>DWF</td>
<td></td>
</tr>
<tr>
<td></td>
<td>DWV</td>
<td></td>
</tr>
</tbody>
</table>

Performance
This view is used when investigating performance of accounts such as profitability and account costs and unit costs. It is intended to be a primary pane view only.

<table>
<thead>
<tr>
<th>Left pane</th>
<th>Primary pane</th>
<th>Right pane</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Intersection Name)</td>
<td>(Display Name)</td>
<td>(Intersection Name)</td>
</tr>
<tr>
<td>Cost</td>
<td></td>
<td>Cost</td>
</tr>
<tr>
<td>UnitCost</td>
<td>Cost</td>
<td>UnitCost</td>
</tr>
<tr>
<td></td>
<td>Profit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>SoldQty</td>
<td></td>
</tr>
<tr>
<td></td>
<td>SoldCost</td>
<td></td>
</tr>
<tr>
<td></td>
<td>UnitRevenue</td>
<td></td>
</tr>
<tr>
<td></td>
<td>UnitCost</td>
<td></td>
</tr>
<tr>
<td></td>
<td>UnitProfit</td>
<td></td>
</tr>
</tbody>
</table>

External Unit
This view contains columns for EntCost and EntUnitCost. All cost in a model originates with these two properties.

<table>
<thead>
<tr>
<th>Left pane</th>
<th>Primary pane</th>
<th>Right pane</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Intersection Name)</td>
<td>(Display Name)</td>
<td>(Intersection Name)</td>
</tr>
<tr>
<td>Reference Cost</td>
<td></td>
<td>Cost</td>
</tr>
<tr>
<td></td>
<td>UsedQty</td>
<td>UnitCost</td>
</tr>
<tr>
<td></td>
<td>EntCost</td>
<td></td>
</tr>
<tr>
<td></td>
<td>EntUnitCost</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cost</td>
<td>DrvCost</td>
</tr>
</tbody>
</table>
Understanding Properties in a Column Layout

Overview

This chapter discusses how to understand the significance of properties when they are added to a column layout.

*Note:* With the ability to add attributes to dimension members, you can also add properties to column layouts for the Dimensions view (see Chapter 34, “Attributes on Dimension Members,” on page 251). But, in this chapter, we are concerned only with adding properties to column layouts for assignments panes.

Assignments panes provide a window into accounts. The primary assignments pane shows all the accounts in the module to which the pane is attached. The left and right assignments panes provide a restricted (filtered) view of accounts:

- The left assignments pane shows accounts making assignments to the primary pane.
- The right assignments pane shows accounts receiving assignments from the primary pane.

The primary assignments pane shows accounts in one module only. Given the existence of intra-modular assignments (assignments within the same module), the right and left assignments panes can show accounts in more than one module.

Properties fall into the following categories:

**Assignment properties**

Refer to a particular assignment between accounts. Assignments are displayed in the narrow area between assignments panes, as shown in the following picture:

In a column layout, given that you cannot add properties in between assignments panes, the following question arises: if you attach an assignment property to one assignments pane, does it refer to an assignment to the left of that pane or to the right of it? The answer, as we shall see in more detail shortly, is to the left.

**Outgoing properties**

Refer to costs flowing out of an account, across assignment paths, into one or more destination accounts. Outgoing properties are relational. They attach to an account, but they refer to cost flows to other accounts.

**Incoming properties**

Refer to costs flowing into an account, across an assignment path, from one or more source accounts. Incoming properties are also relational. They refer to cost flows from other accounts.

**Account properties**

Refer to accounts apart from any flow into or out of the account.
Driver properties refer to drivers apart from any particular assignment between accounts.

**Assignment Properties**

An assignment property describes a flow between accounts. Driver Quantity Fixed (DQF), for example for a percentage driver, specifies the percentage of an account's cost that flows to each of its destination accounts. The DQF for one destination account can be, say, 60%, and 30% for a different destination account, and 10% for another.

Given that you attach properties only to assignments panes and not to the flow between panes, it makes most sense to attach assignment properties to the right assignments pane. The following picture shows why. Notice that in the right assignments pane, you can clearly see to which assignment path each DQF of 23,000 and 50,000, respectively, applies. By contrast, in the primary pane, you can see the DQF of 15,000, but to which incoming assignment does it apply? When there is more than one incoming assignment (in this case there are three), you cannot tell from the primary assignments panes to which assignment it applies. And the situation is even worse in the left assignments pane because you can’t see any of the incoming assignments. So, in short, attach assignment properties to the right assignments pane.

The following table lists assignment properties. The second column shows the properties whose value you can set in an assignments pane.

**Table 37.1 Assignment Properties**

<table>
<thead>
<tr>
<th>Property</th>
<th>Set By User?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Driver Allocated Cost</td>
<td>Yes</td>
</tr>
<tr>
<td>Driver Cost</td>
<td></td>
</tr>
<tr>
<td>Driver Driven Cost</td>
<td></td>
</tr>
<tr>
<td>Property</td>
<td>Set By User?</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>--------------</td>
</tr>
<tr>
<td>Driver Driven Quantity</td>
<td></td>
</tr>
<tr>
<td>Driver Idle Cost</td>
<td></td>
</tr>
<tr>
<td>Driver Percentage</td>
<td></td>
</tr>
<tr>
<td>Driver Quantity Basic</td>
<td></td>
</tr>
<tr>
<td>Driver Quantity Calculated</td>
<td></td>
</tr>
<tr>
<td>Driver Quantity Fixed (DQF)</td>
<td>Yes</td>
</tr>
<tr>
<td>Driver Quantity Variable (DQV)</td>
<td>Yes</td>
</tr>
<tr>
<td>Driver Used Cost</td>
<td></td>
</tr>
<tr>
<td>Driver Weight Fixed (DWF)</td>
<td>Yes</td>
</tr>
<tr>
<td>Driver Weight Variable (DWV)</td>
<td>Yes</td>
</tr>
<tr>
<td>Idle Driver Quantity</td>
<td></td>
</tr>
<tr>
<td>Idle Driver Quantity UE</td>
<td>Yes</td>
</tr>
<tr>
<td>Idle Percentage</td>
<td></td>
</tr>
<tr>
<td>Is Reciprocal</td>
<td></td>
</tr>
<tr>
<td>Reciprocal Id</td>
<td></td>
</tr>
</tbody>
</table>

**Outgoing Properties**

An outgoing property refers to a cost flow going out of accounts across assignment paths to destination accounts. The following picture shows the DrvnCost property attached to the left, primary, and right assignments panes. In every case, regardless of which pane the property is attached to, it shows something going out of an account to destination accounts.

The following table lists outgoing properties. The second column lists the properties whose value you can set in an assignments pane. With two exceptions, you can not set outgoing properties.
Table 37.2  Outgoing Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Set By User?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allocated Cost</td>
<td></td>
</tr>
<tr>
<td>Assigned Cost</td>
<td></td>
</tr>
<tr>
<td>Assigned Idle Cost</td>
<td></td>
</tr>
<tr>
<td>Assigned Idle Quantity</td>
<td></td>
</tr>
<tr>
<td>Assigned Non-Reciprocal Cost</td>
<td></td>
</tr>
<tr>
<td>Assigned Reciprocal Cost</td>
<td></td>
</tr>
<tr>
<td>Calculate Error</td>
<td></td>
</tr>
<tr>
<td>Drivable Cost</td>
<td></td>
</tr>
<tr>
<td>Driven Cost</td>
<td></td>
</tr>
<tr>
<td>Driven Quantity</td>
<td></td>
</tr>
<tr>
<td>Driver Rate</td>
<td></td>
</tr>
<tr>
<td>EnteredUnitCost</td>
<td>Yes</td>
</tr>
<tr>
<td>Has Idle Cost</td>
<td></td>
</tr>
<tr>
<td>Has Used Cost</td>
<td></td>
</tr>
<tr>
<td>Idle Cost</td>
<td></td>
</tr>
<tr>
<td>Idle Quantity</td>
<td></td>
</tr>
<tr>
<td>Total Driver Quantity (TDQ)</td>
<td></td>
</tr>
<tr>
<td>Total Driver Quantity Basic (TDQBasic)</td>
<td></td>
</tr>
<tr>
<td>Total Driver Quantity Calculated (TDQCalc)</td>
<td></td>
</tr>
<tr>
<td>Total Driver Quantity UE (TDQUE)</td>
<td>Yes</td>
</tr>
<tr>
<td>Unassigned Cost</td>
<td></td>
</tr>
<tr>
<td>Unassigned Quantity</td>
<td></td>
</tr>
<tr>
<td>Unit Cost</td>
<td></td>
</tr>
</tbody>
</table>
Incoming Properties

An incoming property refers to cost flows coming into accounts, across assignment paths, from source accounts. The following picture shows Received Cost attached to the left, primary, and right assignments panes. In every case, regardless of which pane the property is attached to, the property shows costs flowing into an account from source accounts.

The following table lists incoming properties.

Table 37.3  Incoming Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Set By User?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Has Assignments</td>
<td></td>
</tr>
<tr>
<td>Received Allocated Cost</td>
<td></td>
</tr>
<tr>
<td>Received Cost</td>
<td></td>
</tr>
<tr>
<td>Received Driven Cost</td>
<td></td>
</tr>
<tr>
<td>Received Idle Cost</td>
<td></td>
</tr>
<tr>
<td>Received Non-Reciprocal Cost</td>
<td></td>
</tr>
<tr>
<td>Received Reciprocal Cost</td>
<td></td>
</tr>
<tr>
<td>Received Used Cost</td>
<td></td>
</tr>
</tbody>
</table>
**Driver Properties**

*Driver properties* are properties of a driver that are independent of any particular assignment. For example, Driver Name is the same for a given driver in all its assignment paths.

The following picture shows two driver properties (DrvName and DrvSeq) attached to all three assignments panes.

The following table lists driver properties. You can set driver properties only in driver dialogs, not in assignments panes.

<table>
<thead>
<tr>
<th>Property</th>
</tr>
</thead>
<tbody>
<tr>
<td>Driver Formula</td>
</tr>
<tr>
<td>Driver Name</td>
</tr>
<tr>
<td>Driver Sequence Number</td>
</tr>
<tr>
<td>Driver Type</td>
</tr>
<tr>
<td>Idle Flow Method</td>
</tr>
<tr>
<td>Unique Driver Quantities</td>
</tr>
<tr>
<td>Use Fixed Quantities</td>
</tr>
<tr>
<td>Use Variable Quantities</td>
</tr>
<tr>
<td>Use Weighted Quantities</td>
</tr>
</tbody>
</table>

**Account Properties**

*Accounts properties* are properties of an account considered by itself, apart from any flow into or out of the account. For example, Entered Cost is an account property and not an outgoing property because it may or may not flow out of the account to which it is attached. The following picture shows the account property (EntCost) attached to all three assignments panes.
The following table lists account properties.

**Table 37.5  Account Properties**

<table>
<thead>
<tr>
<th>Property</th>
<th>Set By User?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost</td>
<td></td>
</tr>
<tr>
<td>Entered Cost</td>
<td>Yes</td>
</tr>
<tr>
<td>Entered Unit Cost</td>
<td>Yes</td>
</tr>
<tr>
<td>Has Attributes</td>
<td></td>
</tr>
<tr>
<td>Has Entered Cost</td>
<td></td>
</tr>
<tr>
<td>Has Notes</td>
<td></td>
</tr>
<tr>
<td>Is Behavior</td>
<td>Yes</td>
</tr>
<tr>
<td>Is Reciprocal</td>
<td></td>
</tr>
<tr>
<td>Model Note</td>
<td>Yes</td>
</tr>
<tr>
<td>Periodic Note</td>
<td>Yes</td>
</tr>
<tr>
<td>Profit</td>
<td></td>
</tr>
<tr>
<td>Output Quantity</td>
<td></td>
</tr>
<tr>
<td>Output Quantity UE</td>
<td>Yes</td>
</tr>
<tr>
<td>Reciprocal Id</td>
<td></td>
</tr>
<tr>
<td>Revenue</td>
<td>Yes</td>
</tr>
<tr>
<td>Sold Cost</td>
<td></td>
</tr>
<tr>
<td>Sold Quantity</td>
<td>Yes</td>
</tr>
<tr>
<td>Unit Profit</td>
<td></td>
</tr>
<tr>
<td>Unit Revenue</td>
<td></td>
</tr>
</tbody>
</table>
Summary

In thinking about properties, you might find useful the following rule of thumb: if a property is prefixed with “Driver”, then it is either an assignment property or a driver property. If it is prefixed with “Received”, then it is an incoming property. And, if it is prefixed with neither “Driver” nor “Received”, then it is either an outgoing property or an account property.

The following table lists the properties in alphabetical order and specifies the type of property for each one.

Table 37.6 Property Type

<table>
<thead>
<tr>
<th>Property</th>
<th>Outgoing</th>
<th>Incoming</th>
<th>Assignment</th>
<th>Account</th>
<th>Driver</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allocated Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Assigned Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Assigned Idle Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Assigned Idle Quantity</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Assigned Non-Reciprocal Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Assigned Reciprocal Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Calculate Error</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Drivable Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driven Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driven Quantity</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Allocated Cost</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Cost</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Driven Cost</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Driven Quantity</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Formula</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Driver Idle Cost</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Name</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Driver Percentage</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Quantity Basic</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Quantity Calculated</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Property</td>
<td>Outgoing</td>
<td>Incoming</td>
<td>Assignment</td>
<td>Account</td>
<td>Driver</td>
</tr>
<tr>
<td>----------------------------------------------</td>
<td>----------</td>
<td>----------</td>
<td>------------</td>
<td>---------</td>
<td>--------</td>
</tr>
<tr>
<td>Driver Quantity Fixed (DQF)</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Quantity Variable (DQV)</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Rate</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Sequence Number</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Driver Type</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Driver Used Cost</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Weight Fixed (DWF)</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Weight Variable (DWV)</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Entered Cost</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Entered Unit Cost</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Has Assignments</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Has Attributes</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Has Entered Cost</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Has Idle Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Has Notes</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Has Used Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Idle Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Idle Driver Quantity</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Idle Driver Quantity UE</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Idle Flow Method</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Idle Percentage</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Idle Quantity</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Is Behavior</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Is Reciprocal</td>
<td>✓</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Model Note</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Model Note</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Output Quantity</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Output Quantity UE</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Periodic Note</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Property</td>
<td>Outgoing</td>
<td>Incoming</td>
<td>Assignment</td>
<td>Account</td>
<td>Driver</td>
</tr>
<tr>
<td>----------------------------------------------</td>
<td>----------</td>
<td>----------</td>
<td>------------</td>
<td>---------</td>
<td>--------</td>
</tr>
<tr>
<td>Profit</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Received Allocated Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Received Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Received Driven Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Received Idle Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Received Non-Reciprocal Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Received Reciprocal Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Received Used Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Reciprocal Id</td>
<td></td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Revenue</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sold Cost</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sold Quantity</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total Driver Quantity (TDQ)</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total Driver Quantity Basic (TDQBasic)</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Total Driver Quantity Calculated (TDQCalc)</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total Driver Quantity UE (TDQUE)</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Unassigned Cost</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Unassigned Quantity</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Unique Driver Quantities</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Unit Cost</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Unit Profit</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Unit Revenue</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Use Fixed Quantities</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Use Variable Quantities</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Use Weighted Quantities</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Used Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Used Quantity</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Chapter 38
Windows for Column Layouts

Column Layout Dialog Box

About the Column Layout Dialog Box .......................... 309
Icons ........................................................................ 309
How to Access the Column Layout Dialog Box ............ 310

Format Column Dialog Box ........................................ 311
How to Access the Format Column Dialog Box .......... 311

Save Column Layout As Dialog Box ............................ 312
About the Save Column Layout As Dialog Box .. .......... 312
How to Access the Save Column Layout As Dialog Box . 312

Column Layout Dialog Box

About the Column Layout Dialog Box

Use the Column Layout dialog box to manage the columns in the:
• Module view (see “What Is a Module?” on page 153)
• Dimensions view (see “Dimensions View” on page 179)

Rows in the Column Layout dialog box (from top to bottom) represent columns (from left to right) in a module view or dimensions view.
You can use the Column Layout dialog box to:
- "Create a Column Layout" on page 313
- "Remove a Column" on page 315
- "Order Columns" on page 316
- "Format a Column" on page 316
- "Conditionally Highlight Cells in a Column" on page 320
- "Select the Period to which the Column Refers" on page 324
- "Save a Column Layout" on page 324
- "Apply a Saved Column Layout" on page 324
- "Specify a Default Column Layout" on page 325

**Note:** The **Display Name** column, which is the left-most column in the column layout, is not displayed in this dialog box. The Display Name column is required, so you cannot remove it, change it, or reorder it.

**Icons**

Icons indicate whether each item in the column is a property, an attribute, or a dimension:

<table>
<thead>
<tr>
<th>This icon</th>
<th>Represents this</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="icon.png" alt="Icon" /></td>
<td>Property</td>
</tr>
</tbody>
</table>
This icon Represents this

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Attribute</td>
</tr>
<tr>
<td></td>
<td>Dimension</td>
</tr>
</tbody>
</table>

**How to Access the Column Layout Dialog Box**

- In a Module view or the Dimensions view, select **Model ➔ Column Layout ➔ Edit Columns**, or double-click the column header.

![Double-click the column header]

**See Also**

- Chapter 37, “Working with Column Layouts,” on page 293
- Chapter 38, “Windows for Column Layouts,” on page 309
- “Understanding Properties in a Column Layout” on page 298

---

**Format Column Dialog Box**

In the Format Column dialog box, you can format the information in the columns in a module view, and in the Dimensions view.

**How to Access the Format Column Dialog Box**

In the Column Layout dialog box, select a row and click the ![Format Column](image)

The Format Column dialog box appears:
Save Column Layout As Dialog Box

About the Save Column Layout As Dialog Box

In the Save Column Layout As dialog box, you can name a column layout.

See Also
“Column Layout Dialog Box” on page 309

How to Access the Save Column Layout As Dialog Box

Do one of the following:

- In a module view, select Model ⇒ Column Layout ⇒ Save As.
- In the Column Layout dialog box, click Save As.
Create a Column Layout

1. On a module view or Dimensions view, select Model ➔ Column Layout ➔ Edit Columns.
Alternatively, you can double-click a column heading. The Column Layout dialog box appears.

2. From the list of **Displayed columns**, select the pane from the appropriate tab (**Left**, **Primary**, or **Right**) to which you want to add the column.

3. From the list of **Properties, Attributes, and Dimensions**, select an item.

4. To search for an item, do the following:
   a. Click **Search**. The Search for Properties and Attributes dialog box appears.

   b. From the **Show** drop-down list, select the items to display.

   c. To rapidly move through the list of items, type a phrase in the **Search** box.
As you type text, the item that most closely matches the text is selected.

d. Select an item from the list.

The Description of the item is displayed.

Note: Some items, such as attributes, might not have a description.

e. Click OK.

5. Click Add >.

6. To rename the column, click the Column Name of the new row, and type a new name.

This text is displayed in the column heading of the column layout.

7. To select a different period/scenario association, click in the Period/Scenario column, and select a period/scenario association.

8. Select Save As to create the layout with a new name.

Note: If your column layout has too many column headings to be able to view in a window all at once, you can use the scroll wheel of the mouse to scroll the column headings.

---

See Also

“Understanding Properties in a Column Layout” on page 298

---

Remove a Column

1. On a module page, select Model -> Column Layout -> Edit Columns.

   The Column Layout dialog box appears.

2. Select the Module to which this column layout applies.

3. From the list of Displayed columns, select the pane from the appropriate tab (Left, Primary, or Right) from which you want to remove the column.

4. Select a row (which represents a column in the view).

5. Click < Remove.

   The row (column) is removed from the list of Displayed columns.
Order Columns

1. On a module page, select Model ➔ Column Layout ➔ Edit Columns.
   The Column Layout dialog box appears.
2. Select the Module to which this column layout applies.
3. From the list of Displayed columns, select the pane from the appropriate tab (Left, Primary, or Right) that you want to order.
4. Select a row (which represents a column in the view).
5. To move the row up, click Move Up.
   The column will be moved to the left.
6. To move the row down, click Move Down.
   The column will be moved to the right.

TIP You can drag columns in a module view to change the order of columns.

Format a Column

Overview

When you add a column to a module view or to the dimensions view, SAS Cost and Profitability Management assigns default formatting to the columns.

The default formatting is based on the following factors:
- the type of underlying data
- your Windows Regional Options
- the default currency
- the display precision that you specified in your options

You can change some of the formatting for individual columns. You can specify a columns general appearance, such as text color, background color, cell alignment, and font style. Additionally, you can specify the currency and the format type. Changing the currency or the format type affects how the underlying data is displayed on the screen; it does not change the currency or the format type of the underlying data itself.

Formatting affects the display of information in the grid; cubes on the OLAP view display the model's base currency in the view title bars. Measures are formatted as numbers.

How to Format

1. In a module view, select Model ➔ Column Layout ➔ Edit Columns.
   The Column Layout dialog box appears.
2. In a row that represents the column that you want to format, click ![Format Column](https://example.com/format_column.png).

The Format Column dialog box appears.

3. In the **Type and Size** section, select the **Type** of data.

4. For **Display values using this currency**, select or clear an option.

5. From the **When viewing negative numbers use** drop-down list, select or clear an option.

6. Specify the precision:
   - Select or clear the **Override default precision** option.
   - Set a value for the number of **decimal places**.

7. To quickly set the width of a column so that the column is wide enough to display all data, select the **Size column to text** option.

8. In the **Font settings** section, select or clear options for **Alignment**, **Style**, and **Color**.

### Color, Style, and Alignment

To highlight important information, you can specify the foreground color and the background color for a column. Also, you can specify the font style, such as bold or italic, and the alignment of data within a column, such as right-aligned or left-aligned.

To ensure that columns are not too wide or too narrow for their contents, you can specify that column widths should change according to the width of each column's contents.
Currency Type

The Currency type displays column values as currency. A column can display either the model's base currency or a currency that was specified in an exchange rates table. You can select any available currency, including the currencies that are not specified in an exchange rates table. If you select a currency that does not have an exchange rate, all of the column values are displayed as zeros.

Number Type

The Number type displays column values as numbers.

Percentage Type

The Percentage type displays column values by multiplying each value by 100 and then appending the percentage symbol (%).

Note: The Percentage type pertains only to individual column values. The percentage that each column value contributes to the total of all the column values is not calculated.

Text Type

The Text type displays column values as text.

Checkbox Type

The Checkbox type displays column values as check boxes. Each cell is either checked or not checked.

Available Format Types

The format types that are available for a specific column depend on the data in the column. For example, a column that contains text cannot be formatted to display as percentages or as numbers because the underlying data is not numeric. The following table lists the format types for underlying data:

<table>
<thead>
<tr>
<th>Underlying data</th>
<th>Available format types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Text</td>
</tr>
<tr>
<td>Cost or rate</td>
<td>Currency (default)</td>
</tr>
<tr>
<td></td>
<td>Number</td>
</tr>
<tr>
<td>Number or quantity</td>
<td>Number (default)</td>
</tr>
<tr>
<td></td>
<td>Currency</td>
</tr>
<tr>
<td></td>
<td>Percentage</td>
</tr>
</tbody>
</table>
### Underlying data

<table>
<thead>
<tr>
<th>Underlying data</th>
<th>Available format types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Percentage</td>
<td>Percentage (default)</td>
</tr>
<tr>
<td></td>
<td>Number</td>
</tr>
<tr>
<td>Boolean</td>
<td>Checkbox</td>
</tr>
</tbody>
</table>

### Negative Numbers

You can specify how negative numbers are displayed. The default appearance for negative numbers is based on your Windows regional settings.

### Precision

Precision is the number of decimal places that are displayed for numbers in a column. Your user options affect precision.

**Tip** Before you add new columns, set the default precision in your user options. Then, set the precision for any column in which you want the precision to be different from the default precision.

**Note:** For the following properties, if you select the Percentage type, each column value can have only two decimal places:

- Driver Percentage
- Idle Percentage

### Currency Formatting

The number of decimal places that you specify in your options overrides the No. of digits after decimal setting in Windows Regional Options.

<table>
<thead>
<tr>
<th>Change this</th>
<th>in this dialog box.</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Positive currency format</td>
<td>Customize Regional Options</td>
<td>1,1 F</td>
</tr>
<tr>
<td>Negative currency format</td>
<td>Customize Regional Options</td>
<td>-1,1 F</td>
</tr>
<tr>
<td>Decimal symbol</td>
<td>Customize Regional Options</td>
<td>,</td>
</tr>
<tr>
<td>No. of digits after decimal</td>
<td>Customize Regional Options</td>
<td>2</td>
</tr>
<tr>
<td>Digit grouping symbol</td>
<td>Customize Regional Options</td>
<td>a space</td>
</tr>
</tbody>
</table>
### Change this in this dialog box.

<table>
<thead>
<tr>
<th>Change this</th>
<th>in this dialog box.</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Digit grouping</td>
<td>Customize Regional Options</td>
<td>123 456 789</td>
</tr>
</tbody>
</table>

### Displaying the Currency Symbol

You can add columns on the Resource module view, the Activity module view, and the Cost Object module view to display different currencies in the same display.

You can choose to display the currency symbol as part of the number formatting, or in column headings. If you choose to display the currency symbol in column headings, then you can choose to display the currency symbol, the currency code, both, or neither. You might want to display only the currency code if your computer's fonts do not support currency symbols.

### Conditionally Highlight Cells in a Column

### Overview

With conditional highlighting of cells, you can change the text and background color of the cells in a column that satisfy conditions that you specify. For example, you can highlight in red all the Cost cells that contain a negative value. Or, you can highlight text cells with a particular content.

To conditionally highlight cells in a column:

1. Open the Column Layout dialog. See “Column Layout Dialog Box” on page 309.
2. Select a column whose cells you want to highlight.
3. Click the Conditions icon.

The Conditional Formatting dialog opens.

4. Specify a condition that determines which cells are to be highlighted. For allowable conditions, see “Conditions” on page 323.
5. Specify the highlighting that is to be applied to each cell whose data satisfies the condition specified. You can specify:
   - Background color
   - Text color

6. Click Add to select additional cells for highlighting. For each set of additional cells selected, you can specify different highlighting. See “Highlight Additional Cells” on page 321.
Highlight Additional Cells

For each column, you can select more than one set of cells for highlighting. For each set of cells selected, you can specify different highlighting.

To select more than one set of cells in a column for highlighting, do the following:

1. From the Column Layout dialog box, click the Conditions icon.

   The Conditional Formatting dialog opens.

2. Specify a condition that determines which cells are to be highlighted.

3. Specify the highlighting that is to be applied to each cell whose data satisfies the condition specified.

4. Click Add to select additional cells for highlighting. For each set of additional cells selected, you can specify different highlighting.

The following picture shows highlighting cells in the Profit column as follows:

<table>
<thead>
<tr>
<th>Cells</th>
<th>Condition</th>
<th>Highlighting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set 1</td>
<td>is less than 0</td>
<td>Background: red, Text: white</td>
</tr>
</tbody>
</table>
Cells | Condition | Highlighting
---|---|---
Set 2 | is greater than 500,000 | Background: green
 |  | Text: black

**Remove Highlighting**

To remove the highlighting from cells:

1. On the Conditional Formatting window, click **Delete**.
2. Select the condition to be deleted.
3. Click **OK**.
**Save the Highlighting**

To save the conditional highlighting specifications, select **Save** or **Save As** from the Column Layout dialog.

The conditional highlighting specifications are saved along with the column layout. They persist with the column layout if the column layout is exported and subsequently imported.

![Column Layout dialog](image)

**Conditions**

The conditions that you can specify to select cells for highlighting depend on the type of column selected. The conditions are as follow:

**Numeric Columns**

You can select cells in a numeric data column by using the following conditions:

- is equal to
- is not equal to
- is between
- is greater than
- is greater than or equal to
- is less than
- is less than or equal to

**Text Columns**

You can select cells in a text data column by using the following conditions:

- is equal to
- is not equal to

**Boolean Property Columns**

You can select cells in a Boolean property column (such as HasAttribute) by using the following conditions:

- is checked
- is unchecked
Tag Attribute Columns
You can select cells in a tag attribute column by using the following condition:
• is checked

Select the Period to which the Column Refers
From the Period/Scenario drop-down menu, select the period/scenario association to which the data in the column refers.

Note: <<Current>> refers to the period/scenario association currently displayed in the module view or dimensions view to which the column layout is being applied.

Save a Column Layout
Select Model ➔ Column Layout ➔ Save.
The Save Column Layout As dialog box appears.

Apply a Saved Column Layout

Note: You can apply a saved column layout to a module view or a dimensions view.
1. From the Column Layout drop-down list, select a column layout.
2. Click .
Specify a Default Column Layout

To specify the column layout that is displayed by default when you:
• view a module
• are in the Dimensions view

1. Select Model ➔ Properties
2. Click the General tab.
3. for modules
   Select a column layout for each module in the Default driver a column layout for each module field.

 for dimensions
   Specify a column layout in the Default column layout for dimensions field.

Once you are in the Dimensions view or are viewing a module, you can activate a different column layout. However, when you open the model again, the default column layout is displayed when you go to the Dimensions view or view a module.

Import or Export a Column Layout

• “Import a Column Layout” on page 643
• “Export a Column Layout” on page 643
Part 13

Drivers

Chapter 40
  *Introducing Drivers* ....................................................... 329

Chapter 41
  *Evenly Assigned Driver* .................................................. 333

Chapter 42
  *Percentage Driver* .......................................................... 337

Chapter 43
  *Standard Driver* .............................................................. 341

Chapter 44
  *Calculated Driver* ............................................................ 367

Chapter 45
  *Driver Topics* ................................................................. 373

Chapter 46
  *Windows for Drivers* .......................................................... 389

Chapter 47
  *How To: Drivers* ............................................................... 397
Chapter 40
Introducing Drivers

What Is a Driver?

Overview

A driver distributes cost in an account to one or more destination accounts.

There are four types of drivers, each of which is described in detail in the following chapters:

- Chapter 41, “Evenly Assigned Driver,” on page 333
- Chapter 42, “Percentage Driver,” on page 337
- Chapter 43, “Standard Driver,” on page 341
- Chapter 44, “Calculated Driver,” on page 367

Drivers are structural elements. They exist in every period/scenario in a model. And, if a driver has a formula or a rule formula, then those formulas are the same in every period/scenario. However, the evaluation of a formula can result in different values in different period/scenarios. And, a particular driver that is attached to an account in one period/scenario may not be attached to the same account in a different period/scenario.

For all drivers, the basic mechanism for distributing costs is by calculating the following three properties:

**Driver Quantity Calculated** (DrvQtyCalc)
the number of units going to each destination account

**Driver Rate** (DrvRate)
the cost per unit for every destination account

**Driver Driven Cost** (DrvDrvnCost)
the cost going to each destination account. It is calculated by multiplying DrvQtyCalc (the number of units) times DrvRate (the cost per unit)
**DrvQtyCalc**

The following table shows for each type of driver what properties it uses for calculating DrvQtyCalc—the number of units going to each destination account—and what formula it uses for the calculation:

<table>
<thead>
<tr>
<th>Type of Driver</th>
<th>Properties Used</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Evenly assigned</td>
<td>DQF</td>
<td>DrvQtyCalc = DQF = 1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>DQF is automatically assigned a value of 1 for every assignment path of the driver. DQF is not changeable by a user for this driver.</td>
</tr>
<tr>
<td>Percentage</td>
<td>DQF</td>
<td>DrvQtyCalc = DQF</td>
</tr>
<tr>
<td>Standard</td>
<td>DQF, DWF, DQV, DWV, TDQ</td>
<td>DrvQtyCalc = (DQF x DWF) + (DQV x DWV x Dest.TDQ)</td>
</tr>
<tr>
<td>Calculated</td>
<td>See Chapter 55, “Properties That Can Be In Formulas,” on page 469.</td>
<td>DrvQtyCalc = the value of the driver formula</td>
</tr>
</tbody>
</table>

**DrvRate**

For every driver type:

\[
\text{DrvRate} = \frac{\text{DrvblCost}}{\text{TDQ}}
\]

where:

\[
\text{DrvblCost} = \text{Cost} - \text{AllocatedCost}
\]

- DrvblCost (Drivable Cost) is the cost that is distributed by the driver.
- Cost is the cost in the account.
- AllocatedCost is cost that is distributed to destination accounts in lump sums rather than by the driver mechanism. (See “User-Entered Cost Allocation” on page 374.)

and where:

\[
\text{TDQ} = \text{TDQCalc} + \text{SoldQuantity}
\]

- TDQ (Total Driver Quantity) is the total quantity (of whatever measure) that flows out of an account via its driver to any number of destination accounts.
- TDQCalc is the sum of DrvQtyCalc for all the destinations of a given account.
- DrvQtyCalc is the quantity on an assignment to an individual destination.
- SoldQuantity is a user-entered value for an account.

**DrvDrvnCost**

For every driver type:

\[
\text{DrvDrvnCost} = \text{DrvQtyCalc} \times \text{DrvRate}
\]
DrvDrvnCost (the cost driven by an assignment) is calculated by multiplying DrvQtyCalc (the number of units on the assignment) times DrvRate (the cost per unit).

---

**Guidelines for Creating Drivers**

Before you create drivers, consider the following points:

- A formula for a driver can contain at most 32K characters.
- Minimize the use of unique driver quantities. Unique driver quantities can use a lot of memory. They increase processing time, and they do not provide a calculation advantage. See “Unique and Non-Unique (Shared) Driver Quantities” on page 379.
- Create drivers whose quantities or volumes are already being collected or cost little to measure.
- When you collect driver data, ensure that the data is current, available, and accurate. Ask individuals in your organization to verify the data's accuracy.
Chapter 41
Evenly Assigned Driver

Overview

An evenly assigned driver distributes equal portions of cost to every destination account. The evenly assigned driver is often used as a first approximation of the costs that flow between accounts when actual driver quantities are not known. When actual driver quantities are known, you can replace this driver with a driver that is more accurate.

System Assigns DQF

The following picture shows Account1 distributing $100 in equal portions to Account2 and Account3.

Step 1: The system automatically sets DQF to 1 for each assignment to a destination account. DQF represents the number of units going to a destination account.
Note: The driver quantities DQF, DQV, DWF, and DWV are preset for the evenly assigned driver. You cannot change them.

Calculate DrvQtyCalc, TDQCalc, and TDQ

Step 2: DrvQtyCalc represents the total units going to a destination account. In the case of the evenly assigned driver, DrvQtyCalc=DQF. So, in this case DrvQtyCalc=1.

Note: Actually, the evenly assigned driver uses the same formula for calculating DrvQtyCalc as the standard driver, which formula is the following (see “What Is a Standard Driver?” on page 341):

\[ \text{DrvQtyCalc} = (DQF \times DWF) + (DQV \times DWV \times \text{Dest.TDQ}) \]

In the case of the evenly assigned driver, DQF=1, DWF=1, DQV=0, and DWV=1. So, by substitution:

\[ \text{DrvQtyCalc} = (1 \times 1) + (0 \times 1 \times \text{Dest.TDQ}) \]

Then:

\[ \text{DrvQtyCalc} = 1 \]

Step 3: TDQCalc is the total units going out to all destination accounts. In other words, it is the sum of DrvQtyCalc for all destination accounts. In this example, DrvQtyCalc is 1 for each of two destination accounts, so TDQCalc=2.

Step 4: If we ignore complications which are discussed in other chapters, Total Driver Quantity (TDQ) equals TDQCalc. So, TDQ=2.

Note: TDQ can exceed TDQCalc if either is the case:

- SoldQty is specified for the source account, in which case \( \text{TDQ} = \text{SoldQty} + \text{TDQCalc} \).

- TDQUE (Total Driver Quantity User-Entered) is specified as greater than TDQ, in which case \( \text{TDQ} = \text{TDQUE} \) (TDQUE overrides TDQ).

Specifying TDQUE as greater than TDQ indicates that there is idle capacity—more units on the source account than are actually distributed to target accounts (the total units distributed is represented by TDQCalc).
**CalculateDrvblCost and DrvRate**

1. DQF=1
2. DrvQtyCalc=1

$100

Account 1

1. DQF=1
2. DrvQtyCalc=1

Account 2

3. TDQCalc=2
4. TDQ=2
5. DrvblCost=$100
6. DrvRate = DrvblCost/TDQ = $100/2 = $50

In the case of this simple example, there is no allocated cost, so Drivable Cost equals the cost in the account. In this example, DrvblCost=$100.

Step 6. Driver Rate is the cost per unit for any destination account. It is the Drivable Cost divided by the total units going to all destination accounts (DrvblCost/TDQ). In this example, DrvRate = $100/2 = $50.

---

**Calculate DrvDrvnCost**

1. DQF=1
2. DrvQtyCalc=1

$100

Account 1

1. DQF=1
2. DrvQtyCalc=1

Account 2

3. TDQCalc=2
4. TDQ=2
5. DrvblCost=$100
6. DrvRate = DrvblCost/TDQ = $100/2 = $50

Step 7. Driver Driven Cost is the cost that is distributed on an assignment to a particular destination account. It is calculated by multiplying DrvQtyCalc (the number of units going to a destination account) times DrvRate (the cost per unit for any destination account). In this example, DrvDrvnCost = 1 x $50 = $50 for each of the assignments.
Chapter 42
Percentage Driver

Percentage Driver

Overview
A percentage driver distributes cost to destination accounts in fixed percentages. The percentage driver is often used as a first approximation of the costs that flow between accounts when actual driver quantities are not known.

User Specifies DQF
The following picture shows Account1 distributing 25% of $400 to Account2 and 75% of the same $400 to Account3.

![Diagram showing $400 distributed to Account2 and Account3]

Step 1: You set DQF to the percentage of cost that is to be distributed to each destination account. The system issues an error if the total percentage exceeds 100 percent and a warning if it is less than 100 percent.
Note: The driver quantities DWF, DQV, and DWV are set by the system for the percentage driver. You cannot change them.

**Calculate DrvQtyCalc, TDQCalc, and TDQ**

Step 2: DrvQtyCalc represents the percentage of cost going to a destination account. In the case of the percentage driver, DrvQtyCalc=DQF. So, for one assignment DQF=25, and for the other assignment DQF=75.

Note: Actually, the percentage driver uses the same formula for calculating DrvQtyCalc as the standard driver, which formula is the following (see “What Is a Standard Driver?” on page 341):

\[
\text{DrvQtyCalc} = (DQF \times DWF) + (DQV \times DWV \times \text{Dest.TDQ})
\]

In the case of the percentage driver, DWF=1, DQV=0, and DWV=1. So, by substitution:

\[
\text{DrvQtyCalc} = (DQF \times 1) + (0 \times 1 \times \text{Dest.TDQ})
\]

Then:

\[
\text{DrvQtyCalc} = DQF
\]

Step 3: TDQCalc is the total percentage of cost going to all destination accounts. In other words, it is the sum of DrvQtyCalc for all destination accounts. In this simple example, TDQCalc is 100. An error is issued if TDQCalc>100, and a warning is issued if TDQCalc<100.

Step 4: If we ignore complications which are discussed in other chapters, Total Driver Quantity (TDQ) equals TDQCalc.

Note: TDQ can exceed TDQCalc if either is the case:

- SoldQty is specified for the source account, in which case \( \text{TDQ} = \text{SoldQty} + \text{TDQCalc} \).
- TDQUE (Total Driver Quantity User-Entered) is specified as greater than TDQ, in which case \( \text{TDQ} = \text{TDQUE} \) (TDQUE overrides TDQ).

Specifying TDQUE as greater than TDQ indicates that there is idle capacity—more units on the source account than are actually distributed to target accounts (the total units distributed is represented by TDQCalc).
Calculate DrvblCost and DrvRate

Step 5. Drivable Cost (DrvblCost) equals Cost minus Allocated Cost. (See “User-Entered Cost Allocation” on page 374) In the case of this simple example, there is no allocated cost, so Drivable Cost equals the cost in the account: DrvblCost=$400.

Step 6. Driver Rate is the cost per unit for any destination account. In the case of the percentage driver, Driver Rate is the cost per percentage point. It is Drivable Cost divided by the total percentage going to all destination accounts (DrvblCost/TDQ). In this example, DrvRate = $400/100 = $4. That is, $4 is distributed for each percentage point that is to be distributed to a destination account.

Calculate DrvDrvnCost

Step 7. Driver Driven Cost is the cost that is distributed on an assignment to a particular destination account. It is calculated by multiplying DrvQtyCalc (the total percentage going to a particular destination account) times DrvRate (the cost for each percentage point). For one assignment, DrvDrvnCost = 25 x $4 = $100. For the other assignment, DrvDrvnCost = 75 x $4 = $300.
You can see that the math involved for a percentage driver is essentially the same for the evenly assigned driver.

### Example of a Percentage Driver

The following example illustrates how a percentage driver can be used in a model.

Suppose that an organization decides that it's not practical to determine the actual number of hours that clerical personnel spend on various tasks per year. The cost to determine the actual number of hours outweighs the benefit. To approximate the annual number of hours, management asks the clerical personnel to record their actual hours for one week. From these recordings, a percentage is assigned to each task. For this organization, a percentage is reasonably accurate and acceptable.
Chapter 43
Standard Driver

What Is a Standard Driver?

Introduction

The standard driver is the most flexible type of driver. Unlike the evenly assigned and percentage drivers, which use only DQF to distribute cost, the standard driver can use any or all of the following properties:

Driver Quantity Fixed (DQF)

See “Fixed Driver Quantities” on page 374. Also, see “Variable Driver Quantities and Fixed Driver Quantities” on page 377.

Driver Weight Fixed (DWF)

See “Driver Weights” on page 378.

Driver Quantity Variable (DQV)

Demand flow is the calculation of the quantities involved in assignments. Demand flow is always calculated before cost flow. That is, before costs can be calculated, it is necessary to calculate the quantities of things involved. Whereas cost flows from left to right (for example, from the Resource module to the Activities module to the Cost Object module) demand flows from right to left (that is, before calculating how much cost flows to a destination account, it is necessary to know how much output is required at the destination). This should become clear in the course of the examples.
See “Variable Driver Quantities” on page 375. Also, see “Variable Driver Quantities and Fixed Driver Quantities” on page 377.

**Driver Weight Variable (DWV)**
See “Driver Weights” on page 378.

**Driver Formula (Formula)**
See “Calculated Driver” on page 367.

Like the evenly assigned and percentage drivers, the standard driver calculates DrvDrvnCost (the cost going to each destination account) by determining the value of two other properties:

**Driver Quantity Calculated (DrvQtyCalc)**
the number of units going to each destination account

A standard driver uses the following formula to calculate DrvQtyCalc:

$$
\text{DrvQtyCalc} = (DQF \times DWF) + (DQV \times DWV \times \text{Dest.TDQ})
$$

where:

- DQF: Driver Quantity Fixed
- DWF: Driver Weight Fixed
- DQV: Driver Quantity Variable
- DWV: Driver Weight Variable
- Dest.TDQ: Total Driver Quantity on the Destination account

**Driver Rate (DrvRate)**
the cost per unit for any destination account

A standard driver uses the same formula to calculate Driver Rate as the other two drivers:

$$
\text{DrvRate} = \frac{\text{DrvblCost}}{\text{TDQ}}
$$

For the sake of simplicity, the following example of a standard driver uses only DQF to determine the distribution of costs.

### User Specifies Quantities

Step 1: You set DQF to determine how much cost is to be distributed for each assignment to a destination account. DQF can represent any unit of measurement—number of hours, amount of electricity, volume of weight. By adding the total of whatever unit is distributed to all destination accounts, the system determines what portion is distributed to each individual account and distributes cost accordingly.

For this simple example, we assume that you as a user do not set DQV, so the system assigns DQV a value of zero.
And, for this example we assume that you do not attach any weights to the particular assignments. So, the system assigns 1 to each of DWF and DWV so that those properties have no effect in the formula for the distribution of cost.

**Calculate DrvQtyCalc, TDQCac, and TDQ**

Step 2: DrvQtyCalc represents the total units going to a destination account. In the case of a standard driver, the formula for calculating DrvQtyCalc is:

$$\text{DrvQtyCalc} = (DQF \times DWF) + (DQV \times DWV \times \text{Dest.TDQ})$$

Because this is a simple example, Dest.TDQ=0. Remember that TDQ is total units going to destination accounts. And, in this example, neither Account2 nor Account3 has any outgoing assignments. So, TDQ is zero for both Account2 and Account3. And, since Account2 and Account 3 are the destination accounts of Account1, Dest.TDQ for Account1 is zero.

By substitution for the one assignment we have:

$$\text{DrvQtyCalc} = (25 \times 1) + (0 \times 1 \times 0) = 25$$

and for the other assignment:

$$\text{DrvQtyCalc} = (75 \times 1) + (0 \times 1 \times 0) = 75$$

Step 3: TDQCac is the total units going to all destination accounts. In other words, it is the sum of DrvQtyCalc for all destination accounts. In this example, $TDQCac = 25 + 75 = 100$.

Step 4: If we ignore complications which are discussed in other chapters, Total Driver Quantity (TDQ) equals TDQCac.

**Note:** TDQ can exceed TDQCac if either is the case:

- SoldQty is specified for the source account, in which case $TDQ=\text{SoldQty} + \text{TDQCac}$.
- TDQUE (Total Driver Quantity User-Entered) is specified as greater than TDQ, in which case $TDQ=\text{TDQUE}$ (TDQUE overrides TDQ).

Specifying TDQUE as greater than TDQ indicates that there is idle capacity—more units on the source account than are actually distributed to target accounts (the total units distributed is represented by TDQCac).
Calculate DrvblCost and DrvRate

Step 5. Drivable Cost (DrvblCost) equals Cost minus Allocated Cost. (See “User-Entered Cost Allocation” on page 374) In this example, there is no allocated cost, so Drivable Cost equals the cost in the account. DrvblCost=$100.

Step 6. Driver Rate is the cost per unit for any destination account. It is Drivable Cost divided by the total number of units going to all destination accounts (DrvblCost/TDQ). In this example, $1 of cost is distributed for each unit that is distributed to a destination account.

\[
\text{DrvRate} = \frac{\text{DrvblCost}}{\text{TDQ}} = \frac{$100}{100} = $1
\]

Calculate DrvDrvnCost

Step 7. Driver Driven Cost is the cost that is distributed on an assignment path to a particular destination account. It is calculated by multiplying DrvQtyCalc (the number of units going to a particular destination account) times DrvRate (the cost per unit for any destination account).

So, for one assignment:

\[
\text{DrvDrvnCost} = 25 \times $1 = $25
\]
and for the other assignment:

\[ \text{DrvDrvnCost} = 75 \times 1 \times \$1 = \$75 \]

---

**Examples of a Standard Driver**

**Example 1: Entered Unit Cost with Fixed Driver Quantities**

**Overview**

For fixed quantities, the cost that flows out of an account does not depend on downstream demand—how much output is demanded from the account. It depends only on how much is specified to flow out of the account, which is specified as a fixed quantity.

**A. User-Entered Values**

The following picture shows a very simple example of a standard driver distributing wheels to two destinations. One assignment distributes 20 wheels (DQF=20) to Italy. A second assignment distributes 30 wheels (DQF=30) to France. The Entered Unit Cost of each wheel is $10.

**B. Calculate DrvQtyCalc, TDQCalc, and TDQ**

The next diagram shows the following calculations:

1. DrvQtyCalc represents how much is driven by an individual assignment. The general formula for calculating DrvQtyCalc is the following:

   \[ \text{DrvQtyCalc} = (\text{DQF} \times \text{DWF}) + (\text{DQV} \times \text{DWV} \times \text{Dest.TDQ}) \]

   In the case of this simple example, DQV=0 so the second part of the formula drops out. And, for this example, no weight is specified so DWF=1. So, in the case of this simple example:

   \[ \text{DrvQtyCalc} = \text{DQF} \]

2. TDQCalc is the sum of DrvQtyCalc for all the assignments of a particular driver. So, if one assignment distributes 20 wheels to Italy and a second assignment distributes 30 wheels to France, then TDQCalc=50.

3. In general, TDQ is calculated according to the following formula:
TDQ = TDQCalc + SoldQty

In the case of this simple example there is no SoldQty, so TDQ = TDQCalc = 50

C. Calculate Cost

In general, the cost in an account is calculated according to the following formula:

\[ \text{Cost} = \text{EnteredCost} + \text{EnteredUnitCost} \times \text{TDQ} \]

In the case of this example the Wheels account has no EnteredCost, so its cost is EnteredUnitCost times TDQ (or $10 times 50). As you would expect, the total cost of wheels is determined by multiplying the cost of each wheel times the number of wheels.

D. Calculate DrvblCost and DrvRate

Now let’s see how the cost is distributed to each of the destination accounts.

5. In general, DrvblCost is calculated according to the following formula:

\[ \text{DrvblCost} = \text{Cost} - \text{AllocatedCost} \]

AllocatedCost is a cost that is distributed to destination accounts in lump sums rather than by the mechanism of a driver. In the case of this example there is no AllocatedCost, so DrvblCost = Cost = $500.

6. Driver Rate is the dollar amount going to each destination account per unit. Driver rate is calculated according to the following formula:

\[ \text{DrvRate} = \frac{\text{DrvblCost}}{\text{TDQ}} \]
Notice that in this case DrvRate=EnteredUnitCost=$10. In general, DrvRate=EnteredUnitCost unless the Cost to be distributed (DrvblCost) is reduced by sending some of the cost to destination accounts in the form of AllocatedCost.

E. Calculate DrvDrvnCost and Cost

7. DrvDrvnCost represents the cost driven on a particular assignment path. It is calculated according to the following formula:

\[
\text{DrvDrvnCost} = \text{DrvQtyCalc} \times \text{DrvRate}
\]

In other words, the cost driven on a particular assignment is the number of units on the assignment multiplied by the cost per unit.

8. The Cost on a destination account is calculated according to the following formula:

\[
\text{Cost} = \text{ReceivedCost} + \text{EnteredCost}
\]

For this example, the destination accounts have no EnteredCost in the form of Entered Cost Elements belonging to the destination accounts. So, the Cost on the destination accounts is the Cost that they receive from the source accounts.
Example 2: Entered Unit Cost with Variable Driver Quantities and SoldQty

Demand Flow
For variable quantities, the cost that flows out of an account depends on the downstream demand—how much output is demanded from the account to flow downstream. In concrete terms, how much is demanded from an account to flow downstream is represented by the destination account’s TDQ (total driver quantity). You can see this from the formula for the account’s DrvQtyCalc (the number of units flowing from the account to a destination account):

\[ \text{DrvQtyCalc} = (\text{DQF} \times \text{DWF}) + (\text{DQV} \times \text{DWV} \times \text{Dest.TDQ}) \]

In this formula, you see that the variable quantity (DQV) is multiplied by Dest.TDQ (and by a driver weight if it exists). If you look at the diagram for account driver properties, you can see that (assuming TDQ is not overridden by TDQUE) the following formula holds:

\[ \text{TDQ} = \text{UsedQty} \times \text{TDQCalc} + \text{SoldQty} \]

That is, TDQ depends on two quantities:

- TDQCalc
- SoldQty

Figure 43.1 Account Driver Properties (assuming that TDQUE=0)

For this first example, the user enters the value of EntUnitCost, DQV, and SoldQty.

The problem: calculate how much is spent for cars and trucks respectively, given the following information:

- 50 cars were sold, and 5 trucks were sold
- SoldQty(cars)=50
- SoldQty(trucks)=5
Each car has 4 wheels, and each truck has 8 wheels
DQV(cars)=4
DQV(trucks)=8

Each wheel (regardless of car or truck) has 5 lug nuts
DQV=5

Each lug nut costs $0.05 per nut
EnteredUnitCost=$0.05

For an example with a variable quantity and Dest.TDQ instead of SoldQty, see “Examples 3: Entered Unit Cost with Variable Driver Quantity and Dest.TDQ” on page 356.

See also:
• “Diagram 3: Account Driver Properties ” on page 503
• “Variable Driver Quantities” on page 375

A. Specify the User-Entered Values
The following picture shows the information that is entered by a user.

You can also see that TDQ(cars)=50 and TDQ(trucks)=5. In this example, TDQ=SoldQty for cars and trucks respectively. This is explained as follows. (Refer to Figure 43.1 on page 348) Because there is no further outgoing flow of costs from either cars or trucks, it follows that their TDQCalc=0. So, given that UsedQty=TDQCalc +SoldQty, it follows that UsedQty=SoldQty. Furthermore, because TDQ=IdlQty +UsedQty, and because there is no Idle Quantity (for this example we assume that TDQUE=0), it follows that TDQ=SoldQty.

B. DrvQtyCalc for Each Assignment to Cars and Trucks
In general, DrvQtyCalc is calculated according to the formula:

\[ \text{DrvQtyCalc} = (DQF \times DWF) + (DQV \times DWV \times \text{Dest.TDQ}) \]

For this example we are assuming that DQF=0, so:

\[ \text{DrvQtyCalc} = DQV \times DWV \times \text{Dest.TDQ} \]

And, because the driver from Wheels to Cars and Trucks is not weighted, \( DWV = 1 \).

So, by substitution, for one assignment we have:
1. DrvQtyCalc = 4 x 1 x 50 = 200

and for the other assignment:

1. DrvQtyCalc = 8 x 1 x 5 = 40

Note: For the pictures that follow for this example, DrvQtyCalc is abbreviated as DQCalc in order to save space.

C. TDQCalc and TDQ for Wheels

TDQCalc for the Wheels account is the number of wheels for cars plus the number of wheels for trucks:

2. TDQCalc = DrvQtyCalc(cars) + DrvQtyCalc(trucks) = 200 + 40 = 240

And, given that TDQ = TDQCalc + SoldQty, and because Wheels itself has no SoldQty:

3. TDQ = TDQCalc = 240
**D. DrvQtyCalc for the Assignment to Wheels**

Remember that the general formula for calculating DrvQtyCalc is the following:

\[
\text{DrvQtyCalc} = (DQF \times DWF) + (DQV \times DWV \times \text{Dest.TDQ})
\]

In the case of the assignment from Lug Nuts to Wheels \(DQF=0, DWF=1\) (the driver is not weighted), \(DQV=5\) (there are 5 lug nuts per vehicle), and \(\text{Dest.TDQ}=240\) (see above).

So, by substitution we have:

4. \(\text{Drv QtyCalc} = (0 \times 1) + (5 \times 1 \times 240) = 1200\)

**E. TDQCalc and TDQ for Lug Nuts**

TDQCalc is the sum of DrvQtyCalc for the individual assignments, and since there is only one assignment from Lug Nuts to Wheels:

5. \(\text{TDQCalc} = 1200\)

\(\text{TDQ} = \text{TDQCalc} + \text{SoldQty}\), and since \(\text{SoldQty for LugNuts}=0\), it follows that:

6. \(\text{TDQCalc} = \text{TDQ} = 1200\)

Given the calculation of TDQCalc, and therefore also TDQ, we now know how many lug nuts are needed for both cars and trucks.
F. Cost and DrvblCost for Lug Nuts

Knowing how many lug nuts are needed in total, we can calculate the cost according to the formula:

\[ \text{Cost} = \text{UnitCost} \times \text{TDQ} = $0.05 \times 1200 = $60 \]

Furthermore, because

\[ \text{DrvblCost} = \text{Cost} - \text{Allocated Cost} \]

and, because there is no Allocated Cost in this example, it follows that:

\[ \text{DrvblCost} = \text{Cost} = $60 \]
Knowing the total cost, $60, we distribute the cost for cars and trucks respectively according to the formula

\[ \text{DrvDrvnCost} = \text{DrvblCost} \times \frac{\text{DrvQtyCalc}}{\text{TDQ}} \]

By substitution for the first assignment:

8. \( \text{DrvDrvnCost} = \$60 \times \frac{200}{240} = \$50 \)

and for the second assignment:

8. \( \text{DrvDrvnCost} = \$60 \times \frac{40}{240} = \$10 \)
You might have noticed that the formula shown in this example for calculating DrvDrvnCost:

\[
\text{DrvDrvnCost} = \text{DrvblCost} \times \left( \frac{\text{DrvQtyCalc}}{\text{TDQ}} \right)
\]

is different from the one shown earlier (“DrvDrvnCost” on page 330):

\[
\text{DrvDrvnCost} = \text{DrvQtyCalc} \times \text{DrvRate}
\]

However, we can show that the two formulas are equivalent. If you remember that

\[
\text{DrvRate} = \frac{\text{DrvblCost}}{\text{TDQ}}
\]

then by substitution in the second formula we have:

\[
\text{DrvDrvnCost} = \text{DrvQtyCalc} \times \left( \frac{\text{DrvblCost}}{\text{TDQ}} \right)
\]

and that is mathematically equivalent to:

\[
\text{DrvDrvnCost} = \text{DrvblCost} \times \left( \frac{\text{DrvQtyCalc}}{\text{TDQ}} \right)
\]

More intuitively, whereas the standard formula calculates DrvDrvnCost as:

\[
\text{DrvDrvnCost} = \text{DrvblCost} \times \text{DrvRate} \times \text{DrvQtyCalc} \times \frac{1}{\text{TDQ}}
\]

the formula shown in this example calculates DrvDrvnCost as:

\[
\text{DrvDrvnCost} = \text{DrvblCost} \times \text{DrvQtyCalc} \times \frac{1}{\text{TDQ}}
\]
Or, more simply:

\[ \text{DrvDrvnCost} = \text{DrvblCost} \times \left( \frac{\text{DrvQtyCalc}}{\text{TDQ}} \right) \]

(the proportion of costs to a particular destination)

**H. Cost for Cars and Trucks**

The cost for a given account is the sum of costs driven to that account (its ReceivedCost) plus any cost entered directly into the account:

\[ \text{Cost} = \text{RcvCost} + \text{EnteredCost} \]

Because, for this example, there is only one driver into each of the Cars and Trucks accounts, the cost is the DrvDrvnCost for that driver. So, for the first assignment:

9. Cost (Cars) = DrvDrvCost (Wheels) = $50

and for the other assignment:

9. Cost (Trucks) = DrvDrvCost (Wheels) = $10


**Examples 3: Entered Unit Cost with Variable Driver Quantity and Dest.TDQ**

**Overview**

The previous example used DQV along with SoldQty to determine how much output was demanded from a source account. (See “Example 2: Entered Unit Cost with Variable Driver Quantities and SoldQty” on page 348) The example in this section uses DQV along with the destination account’s TDQ to determine how much output is demanded from the source account. The problem: calculate how much is spent for cars and trucks respectively, given the following information:

Cars require 200 wheels in all
Trucks require 40 wheels in all
Each wheel (regardless of car or truck) has 5 lug nuts
Each lug nut costs $0.05 per nut

<table>
<thead>
<tr>
<th></th>
<th>DQF(cars)</th>
<th>DQF(trucks)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cars require 200 wheels in all</td>
<td>200</td>
<td>40</td>
</tr>
<tr>
<td>Trucks require 40 wheels in all</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Each wheel (regardless of car or truck) has 5 lug nuts</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Each lug nut costs $0.05 per nut</td>
<td></td>
<td></td>
</tr>
<tr>
<td>EntrodedUnitCost=$0.05</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**A. User-Entered Values**

A user begins by specifying the following user-entered values:

- EntUnitCost=$0.05
- Each lug not costs $0.05
- DQV=5
- Five lug nuts are required for each wheel
- DQF=200 and DQF=40
- 200 wheels are required in all for cars; and 40 wheels are required in all for trucks

![Diagram](image)

**B. How Many Wheels (DrvQtyCalc) for Cars and Trucks?**

The general formula for calculating the number of units going from a source account to a destination account is the following:

\[ \text{DrvQtyCalc} = (\text{DQF} \times \text{DWF}) + (\text{DQV} \times \text{DWV} \times \text{Dest.TDQ}) \]

Because there is no weighting factor for drivers in this example, DWF and DWV both equal 1. And, because cars and trucks are at the end of the line of assignments, they have no destination accounts and, so, their Dest.TDQ=0. Consequently, DrvQtyCalc=DQF as can be seen from the following:
DrvQtyCalc = (DQF x 1) + (0 x 1 x 0)
DrvQtyCalc = DQF

Therefore:
DrvQtyCalc(cars)=DQF=200
DrvQtyCalc(trucks)=DQF=40

C. How Many Wheels Are Demanded Altogether (TDQ)?

To calculate how many wheels are demanded altogether one must add the wheels for cars plus the wheels for trucks. In general:

\[ \text{TDQCalc} = \sum \text{DrvQtyCalc} \]

TDQCalc=200+40
TDQCalc=240

In general, TDQ (the total units flowing from a source account) is calculated according to the following formula:

\[ \text{TDQ} = \text{TDQCalc} + \text{SoldQty} \]

In the current example, there is no SoldQty, so:

TDQ=TDQCalc
TDQ=240

D. How Many Lug Nuts (DrvQtyCalc) Are Needed for the Wheels?

To calculate how many lug nuts are needed for the 240 wheels, one again uses the general formula:

\[ \text{DrvQtyCalc} = (\text{DQF} \times \text{DWF}) + (\text{DQV} \times \text{DWV} \times \text{Dest.TDQ}) \]
By substitution, where Dest.TDQ=240 is the number of wheels, and DQV=5 is the number of lug nuts required per wheel:

\[ \text{DrvQtyCalc} = (0 \times 1) + (5 \times 1 \times 240) \]
\[ \text{DrvQtyCalc} = 1200 \]

So, 1200 lug nuts are required for 240 wheels.

E. What Does It Cost to Provide the Lug Nuts Demanded?

In general:

\[ \text{TDQCalc} = \sum \text{DrvQtyCalc} \]

And, because, in this example, lug nuts are used only for wheels, there is only one DrvQtyCalc to consider, so:

\[ \text{TDQCalc} = \text{DrvQtyCalc} = 1200 \]

The cost of lug nuts is calculated by multiplying the number of lug nuts required by the unit cost of each lug nut:

\[ \text{Cost} = 1200 \times 0.05 = 60 \]

F. What Does It Cost to Provide the Wheels Demanded?

To recapitulate: first the cost of lug nuts was calculated by determining how many lug nuts are required downstream. This meant adding the number of wheels demanded for cars to the number of wheels demanded for trucks, and multiplying that sum by the
number of lug nuts required for each wheel. Now that the cost of lug nuts has been
determined, we can calculate how that cost is distributed.

In general, the cost driven (distributed) from an account is calculated according to the
following formula:

\[ \text{DrvDrvnCost} = \text{DrvQtyCalc} \times \text{DrvRate} \]

Because \( \text{DrvRates} = \frac{\text{DrvblCost}}{\text{TDQ}} \), the following formula obtains:

\[ \text{DrvDrvnCost} = \text{DrvQtyCalc} \times \left( \frac{\text{DrvblCost}}{\text{TDQ}} \right) \]

By substitution, to determine DrvDrvnCost for lug nuts we have:

\[ \text{DrvDrvnCost} = 1200 \times \left( \frac{60}{1200} \right) \]
\[ \text{DrvDrvnCost} = 60. \]

That is, all the cost in the Lug Nuts account is distributed to its one destination account,
Wheels.

Next, to determine the cost of wheels for cars and trucks, the same general formula for
DrvDrvnCost is applied to each one.

For wheels, we have:

\[ \text{DrvDrvnCost} = \text{DrvQtyCalc} \times \left( \frac{\text{DrvblCost}}{\text{TDQ}} \right) \]
\[ \text{DrvDrvnCost} = 200 \times \left( \frac{60}{240} \right) \]
\[ \text{DrvDrvnCost} = 50 \]

For trucks, we have:

\[ \text{DrvDrvnCost} = \text{DrvQtyCalc} \times \left( \frac{\text{DrvblCost}}{\text{TDQ}} \right) \]
\[ \text{DrvDrvnCost} = 40 \times \left( \frac{60}{240} \right) \]
\[ \text{DrvDrvnCost} = 10 \]

So, of the $50 spent on lug nuts, $40 went to car wheels and $10 went to truck wheels.
Example 4: Weighted Driver with Variable Driver Quantities

A. Specify User-Entered Values

Now we show an alternative method for distributing the cost of lug nuts to cars and trucks. Instead of creating an account for Wheels and having a separate driver from the Wheels account to each of the Cars and Trucks accounts, we now have a single driver from Lug Nuts with different weights for Cars and Trucks.

Driver weights are used when, in addition to driver quantities, some special characteristics need to be considered to distribute costs. For example, complexity of the product, length of the order (and so forth). In this example, the weight captures how many wheels are required for each of Cars and Trucks respectively, as shown in the following picture:

B. DrvQtyCalc for Each Assignment from Lug Nuts to Cars and Trucks

As before, we calculate DrvQtyCalc according to the formula

$$\text{DrvQtyCalc} = \text{DQV} \times \text{DWV} \times \text{Dest.TDQ}$$

This time, however, there is a weight to be included in the calculation, as shown in the following picture:
C. TDQCalc for Lug Nuts
As shown in the following picture, TDQCalc for Lug Nuts is the sum of DrvQtyCalc for cars plus DrvQtyCalc for trucks.

1. TDQCalc = DQV x DWV x Dest.TDQ
   DQCalc(cars) = 5 x 4 x 50 = 1000
   DQCalc(trucks) = 5 x 8 x 5 = 200

2. TDQCalc = DQCalc(1) + DQCalc(2) + ... + DQCalc(n)
   TDQCalc = 1000 + 200 = 1200

D. TDQ for Lug Nuts
TDQ = TDQCalc + SoldQty, and because SoldQty=0, TDQ = TDQCalc. So, now we know how many lug nuts are needed in total for both cars and trucks.

1. TDQ = TDQCalc + SoldQty
   TDQ = 50 cars
   SoldQty=50
   TDQ = 5 trucks
   SoldQty=5

3. TDQ = 1200 nuts
E. Cost and DrvblCost for Lug Nuts

Cost equals the total number of lug nuts times the unit cost for each lug nut:

\[ \text{Cost} = \text{UnitCost} \times \text{TDQ} = 0.05 \times 1200 = 60 \]

because:

\[ \text{DrvblCost} = \text{Cost} - \text{Allocated Cost} \]

and, because there is no Allocated Cost in this example, it follows that

\[ \text{DrvblCost} = \text{Cost} \]

F. DrvDrvnCost for Each Assignment from Lug Nuts to Cars and Trucks

Knowing that drivable cost is $60, we can distribute the cost to cars and trucks respectively according to the formula:

\[ \text{DrvDrvnCost} = \text{DrvblCost} \times \text{DrvQtyCalc}/\text{TDQCalc} \]

as shown in the following picture:
G. Cost for Cars and Trucks

The cost for a given account is the sum of costs driven to that account by all the drivers into it, plus whatever entered cost is entered directly into the account. Because, for this example, there is no entered cost and there is only one driver going into each of the Cars and Trucks accounts, the cost is the DrvDrvnCost for that driver, as shown in the following picture:
Example 5: Weighted Driver with Fixed Driver Quantities

For this example, we show the properties in a single picture. The problem for this example is to distribute the cost of support calls for two products: cars (a less complex product requiring less time to support) and trucks (a more complex product requiring more time to support). The data given for the problem is the following:

- $320 was spent on support calls for both cars and trucks combined.
- Whereas each support call for a car takes 3 minutes (DWF=3), each support call for a truck requires 10 minutes (DWF=10).

The following picture shows the calculation of the cost driven to each product (DrvDrvnCost) using the following formulas:

1. \( DQV = 5 \)
2. \( DWV = 4 \)
3. \( TDQ_{calc} = TDQ = 1200 \)
4. \( DRV_{calc} = DRV_{calc}(1) + DRV_{calc}(2) + \ldots + DRV_{calc}(n) \)
5. \( TDQ = TDQ_{calc} + SoldQty \)
6. \( DrvDrvnCost = DrvBlCost \times (DrvQtyCalc/TDQ) \)

\[
\begin{align*}
1. & \quad DQV = 5 \\
2. & \quad DWV = 4 \\
3. & \quad TDQ_{calc} = TDQ = 1200 \\
4. & \quad DRV_{calc} = DRV_{calc}(1) + DRV_{calc}(2) + \ldots + DRV_{calc}(n) \\
5. & \quad TDQ = TDQ_{calc} + SoldQty \\
6. & \quad DrvDrvnCost = DrvBlCost \times (DrvQtyCalc/TDQ)
\end{align*}
\]
Example 6: Weighted Driver with Fixed and Variable Driver Quantities

For this example, we again show the properties in a single picture for the cost flow of a driver with two assignment paths, each using a different weight.

Once again, the picture shows the calculation of the cost driven to each product (DriverCost) using the following formulas:

1. DrvQtyCalc = (DQF x DWF) + (DQV x DWV x Dest.TDQ)
   DrvQtyCalc(cars) = (20 x 3) + (0 x 1 x 0) = 60
   DrvQtyCalc(trucks) = (10 x 1) + (3 x 1 x 0) = 100
2. TDQCalc = DrvQtyCalc(cars) + DrvQtyCalc(trucks)
   TDQCalc = 60 + 100 = 160
3. TDQ = TDQCalc + SoldQty
   TDQ = 160 + 0
   TDQ = 160
4. DrvDrvnCost = DrvblCost x (DrvQtyCalc / TDQ)
   DrvDrvnCost(cars) = $320 x (60 / 160)
   DrvDrvnCost(cars) = $120
   DrvDrvnCost(trucks) = $320 x (100 / 160)
   DrvDrvnCost(trucks) = $200

Example 6: Weighted Driver with Fixed and Variable Driver Quantities

For this example, we again show the properties in a single picture for the cost flow of a driver with two assignment paths, each using a different weight.

Once again, the picture shows the calculation of the cost driven to each product (DriverCost) using the following formulas:

- DrvQtyCalc = (DQF x DWF) + (DQV x DWV x Dest.TDQ)
- TDQCalc = DrvQtyCalc(1) + DrvQtyCalc(2) + ... + DrvQtyCalc(n)
- TDQ = TDQCalc + SoldQty
- DrvDrvnCost = DrvblCost x (DrvQtyCalc / TDQ)
<table>
<thead>
<tr>
<th>Source</th>
<th>Assignment Path</th>
<th>Destination</th>
</tr>
</thead>
<tbody>
<tr>
<td>R1</td>
<td>TDQCalc = 3</td>
<td>A1</td>
</tr>
<tr>
<td></td>
<td>DQ 20 220</td>
<td>TDQ Cost = 2 100</td>
</tr>
<tr>
<td></td>
<td>DQV DWF DWW DrvQtyCalc DrvDrvnCost</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>3        2</td>
<td>18</td>
</tr>
<tr>
<td>2</td>
<td>2        1</td>
<td>202</td>
</tr>
</tbody>
</table>

1. DrvQtyCalc = (DQF * DWF) + (DQV * DWW * Dest TDQ)
   DrvQtyCalc(A1) = (3*2) + (3*2*2) = 18
   DrvQtyCalc(A2) = (2*1) + (2*1*100) = 202

2. TDQCalc = ∑ DrvQtyCal
   TDQCalc = 18 + 202 = 220

3. TDQ = TDQCalc + SoldQty
   TDQ = 220 + 0 = 220

4. DrvDrvnCost =DrvblCost x (DrvQtyCalc / TDQ)
   DrvDrvnCost(A1) = 100 x (18/220) = 8.18
   DrvDrvnCost(A2) = 100 x (202/220) = 91.82
Chapter 44
Calculated Driver

Introduction

A calculated driver is a variety of standard driver. It is one that, instead of using the standard formula for calculating DrvQtyCalc, uses a formula—referred to as a Driver Formula—that you specify as a user. The formula can use any number of properties and attributes and can be as simple or as complicated as you want. See Chapter 55, “Properties That Can Be In Formulas,” on page 469.

For example, suppose that a company wants to calculate the shipping cost for products that are shipped on pallets. The shipping vendor’s cost is based on how many pallets are shipped, not on how many units are produced. To determine the shipping cost, the output quantity (the property OutputQty) is divided by the number of products that a pallet can hold (the user-defined numeric attribute UnitsPerPallet), as follows:

\[ \text{OutputQty/UnitsPerPallet} \]

If the physical dimensions of the product change, then the number of units that a pallet can hold will change. The value of UnitsPerPallet can be changed accordingly. Also, the value of UnitsPerPallet can be different for each product, but the same equation can be used for multiple products.

The following picture shows a very simple example using a calculated driver, whose driver formula is \( \text{OutputQty/UnitsPerPallet} \), to distribute part of $100 from Account1 to Account2 and the remaining part to Account3.
Calculate DrvQtyCalc, TDQCalc, and TDQ

Step 1: DrvQtyCalc represents the number of units going on an assignment to a destination account. In the case of a calculated driver, DrvQtyCalc is assigned the value of the driver’s formula, OutputQty/UnitsPerPallet. In this case, OutputQty is a system property of each destination account, and UnitsPerPallet is a user-defined attribute assigned to each destination account.

- For the first assignment, DrvQty=100/10=10
- For the second assignment, DrvQty=180/12=15

Step 2: TDQCalc is the total number of units going to all destination accounts. In other words, it is the sum of DrvQtyCalc for all of the destination accounts. In this example, TDQCalc is 25.

Step 3: If we ignore complications which are discussed in other chapters, Total Driver Quantity (TDQ) equals TDQCalc. So, for this example, TDQ=TDQCalc=25.

Note: TDQ can exceed TDQCalc if either is the case:

- SoldQty is specified for the source account, in which case \( TDQ = SoldQty + TDQCalc \).
- TDQUE (Total Driver Quantity User-Entered) is specified as greater than TDQ, in which case \( TDQ = TDQUE \) (TDQUE overrides TDQ).

Specifying TDQUE as greater than TDQ indicates that there is idle capacity—more units on the source account than are actually distributed to target accounts (the total units distributed is represented by TDQCalc).
**Calculate DrvblCost and DrvRate**

$100

1. DrvQtyCalc=OutputQty/UnitsPerPallet
   DrvQtyCalc=100/10
   DrvQtyCalc=10

2. TDQCalc=10+15=25
3. TDQ=25
4. DrvblCost=100
5. DrvRate = DrvblCost/TDQ = $100/25 = $4

Step 4. Drivable Cost (DrvblCost) equals Cost minus Allocated Cost. (See "User-Entered Cost Allocation" on page 374.) For this example, there is no allocated cost, so Drivable Cost equals the cost in the account=100.

Step 5. Driver Rate is the cost per unit for any destination account. It is the Drivable Cost divided by the total number of units going to all destination accounts (DrvblCost/TDQ). In this example, $4 is distributed for every unit that is distributed to a destination account.

**Calculate DrvDrvCost**

$100

1. DrvQtyCalc=OutputQty/UnitsPerPallet
   DrvQtyCalc=100/10
   DrvQtyCalc=10

2. TDQCalc=10+15=25
3. TDQ=25
4. DrvblCost=100
5. DrvRate = DrvblCost/TDQ = $100/25 = $4

Step 6. Driver Driven Cost is the cost that is distributed on an assignment to a particular destination account. It is calculated by multiplying DrvQtyCalc (the units going to a particular destination account) times DrvRate (the cost per unit for any destination account).
Further Information on Calculated Drivers

The formula for a calculated driver is not periodic; the formula remains the same for all periods.

By default, if a name in the formula of a calculated driver is not found belonging to the source account, then it is assumed to belong to the destination account. In more detail, the order of precedence for resolving references (for example “Foo”) in the formula of a calculated driver is the following:

1. Assignment path
2. Destination account
3. Source account
4. Dimension reference
5. Attribute reference

The following properties are not valid for use in the formula of a calculated driver and, therefore, do not appear in the Formula Builder drop-down list:

- DriverQuantityBasic
- IdleDriverQuantity

The reason is that in an assignment these quantities depend on DrvQtyCalc. Consequently, a vicious circle would be created if the formula were to make DrvQtyCalc depend on these quantities. That is, DrvQtyCalc could not be determined without first determining these quantities, and these quantities could not be determined without first determining DrvQtyCalc.

The following examples illustrate how calculated drivers can be used in a model. These equations often include numeric properties and numeric attributes.

Note: You can use cost properties in the driver formula for a calculated driver, but you will need to use driver sequencing to ensure that the properties are non-zero. If you use the default sequence of 1, then all cost values will be zero except for Entered Cost.

See Also

- Chapter 51, “Formulas,” on page 431
- “Using Numeric Attributes in a Formula” on page 441
- “Properties That Can Be in Formulas” on page 469
Examples of a Calculated Driver

Delivering a Product to Customers

Suppose that a company wants to calculate the cost of product delivery. To determine the delivery cost, the number of deliveries to each customer per month is multiplied by the average delivery time. Both of these attributes are user-defined numeric attributes.

\[ \text{DeliveriesPerMonth} \times \text{AvgTimePerDelivery} \]

A customer who prefers more deliveries per month might pay a different delivery cost than a customer who prefers fewer deliveries. Likewise, a customer who is farther away from the company might pay a different delivery charge than a customer who is closer.

Storage Costs for an Inventory of Finished Goods

Suppose that a company wants to calculate the cost of storing slow-moving products. To determine the storage cost, the output quantity (the property OutputQuantity) is divided by the speed at which a product sells (the user-defined numeric attribute InventoryTurns). The result of that calculation is multiplied by the volume of storage space that a product requires (the numeric attribute CuFtPerUnit), as follows:

\[ \left( \frac{\text{OutputQuantity}}{\text{InventoryTurns}} \right) \times \text{CuFtPerUnit} \]

Dividing OutputQuantity by InventoryTurns yields the average inventory level in units. In order to use CuFtPerUnit, the Resource module in the model must include costs, such as utilities or rent, that are based on per-cubic-foot values.

Carrying Costs of an Inventory of Finished Goods

Suppose that a company wants to add costs to a model to calculate the financial carrying cost of inventory. The previous equation could be altered to calculate the financial carrying cost of the inventory, not the physical storage cost:

\[ \left( \frac{\text{OutputQuantity}}{\text{InventoryTurns}} \right) \times \text{Cost} \]

Processing Customer Orders

Suppose that a company processes orders for other companies. The number of orders that are processed is only part of the important data. The company might need to consider the complexity of each customer's order.

To determine the cost of processing an order, the number of orders that are processed (the user-defined numeric attribute NumberOfOrdersProcessed) is multiplied by the complexity of each order (the user-defined numeric attribute OrderComplexityByCustomer), as follows:

\[ \text{NumberOfOrdersProcessed} \times \text{OrderComplexityByCustomer} \]

For OrderComplexityByCustomer, a different value could be assigned to each customer, and the same equation could be used for all customers.
User-Entered Cost Allocation

User-entered cost allocation enables you to assign a specific cost to an assignment path by setting the Driver Allocated Cost (DrvAllocCost) property.

Some organizations allocate a specific cost to an account or department at the start of a budgetary period. This cost is then depleted during the budgetary period. This type of allocation is used in more traditional costing methodologies, but it is generally not part of the activity-based costing methodology. However, if the people within your organization are more familiar with this method of allocating costs, you can employ user-entered cost allocation to simulate this use.

See Also

- “Allocated Cost (AllocCost)” on page 711
- “Driver Allocated Cost (DrvAllocCost)” on page 722
- “Received Allocated Cost (RcvAllocCost)” on page 748

Fixed Driver Quantities

For fixed driver quantities, the cost that flows to a destination account from a source account does not depend on any property of the destination account. In other words, it does not depend on demand. The cost is “pushed” by the quantity supplied. The source
account’s driver rate is multiplied by the fixed driver quantity (represented by the property DQF).

For example, suppose that $100.00 in the resource account Salary flows into two activity accounts: Take Orders and Process Orders. The costs that flow through a Standard, fixed-quantity driver are shown in the following figure:

The total driver quantity (TDQ) for Salary is 3.00 (2.00 for Take Orders plus 1.00 for Process Orders).

The driver rate that flows from Salary is calculated by dividing the total drivable cost of Salary by the total driver quantity (TDQ) of Salary: $100.00/3.00 = $33.33.

So, the cost for each account is calculated as follows:

<table>
<thead>
<tr>
<th>Account</th>
<th>DrvRate x DQF</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Take Orders</td>
<td>$33.33 x 2.00</td>
<td>$66.67</td>
</tr>
<tr>
<td>Process Orders</td>
<td>$33.33 x 1.00</td>
<td>$33.33</td>
</tr>
</tbody>
</table>

Note: All values are rounded.

See Also

- Chapter 41, “Evenly Assigned Driver,” on page 333
- “Percentage Driver” on page 337
- “Example 1: Entered Unit Cost with Fixed Driver Quantities” on page 345

### Variable Driver Quantities

For variable driver quantities, the cost that flows to a destination account from a source account depends on the destination account’s total driver quantity. In other words, the cost is determined by demand. It is “pulled” by the quantity required at the final destination. The source account’s driver rate is multiplied by the variable driver quantity (DQV) and by the Destination.TDQ.

For example, suppose that $100.00 in the resource account Salary flows into two activity accounts, Take Orders and Process Orders. The costs that flow through a Standard, variable-quantity driver are shown in the following figure:

The total driver quantity (TDQ) for Salary is 130.00, which is calculated as follows:
The driver rate that flows from Salary is calculated by dividing the total drivable cost of Salary by the total driver quantity (TDQ) of Salary: $100.00/130.00 = $0.7692.

So, the cost for each account is calculated as follows:

<table>
<thead>
<tr>
<th>Account</th>
<th>DrvRate x DQV x Test.TDQ</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Take Orders</td>
<td>$00.7692 x 10 x 10.00</td>
<td>$76.92</td>
</tr>
<tr>
<td>Process Orders</td>
<td>$00.7692 x 3 x 10.00</td>
<td>$23.08</td>
</tr>
</tbody>
</table>

Note: All values are rounded.

As for TDQ, it is determined in general by two quantities:

TDQC\text{alc}

For an account that uses a variable quantity driver (Account 1 in the picture below), if at least one of its destination accounts (Account 2) assigns costs using a fixed quantity driver, then the DQF for that assignment makes for a non-zero TDQC\text{alc} (TDQC\text{alc}=3 in the picture below) for that destination account, and hence for a non-zero TDQ (TDQ=3). And, this is the Dest.TDQ for the account (Account 1) that uses the variable quantity driver.

SoldQty

You can determine the quantity demanded for a product by specifying SoldQty for some destination account of a source account (Account 1 in the picture below) that uses a variable quantity driver.

The following picture (which is reproduced from “Diagram 3: Account Driver Properties ” on page 503) shows the relationship between TDQ and TDQC\text{alc} and SoldQty (and UsedQty and OutQty)).
Variable Driver Quantities and Fixed Driver Quantities

You can use both variable quantities and fixed quantities in a single driver.

For example, suppose that $100.00 in the resource account Salary flows into two activity accounts, Take Orders and Process Orders. The costs that flow through a Standard, fixed-quantity and variable-quantity driver are shown in the following figure:

<table>
<thead>
<tr>
<th>Account</th>
<th>(DQF)</th>
<th>(DQV x Dest.TDQ)</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Take Orders</td>
<td>2.00</td>
<td>10.00 x 10.00</td>
<td>102.00</td>
</tr>
<tr>
<td>Process Orders</td>
<td>1.00</td>
<td>3.00 x 10.00</td>
<td>31.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>133.00</td>
</tr>
</tbody>
</table>

The driver rate that flows from Salary is calculated by dividing the total drivable cost of Salary by the total driver quantity (TDQ) of Salary: $100.00/133.00 = $0.07519.

So, the cost for each account is calculated as follows:

<table>
<thead>
<tr>
<th>Account</th>
<th>(DrvRate x DQF) +</th>
<th>(DrvRate x DQV x Dest.TDQ)</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Take Orders</td>
<td>$0.07519 x 2.00</td>
<td>$0.07519 x 10.00 x 10.00</td>
<td>$76.69</td>
</tr>
</tbody>
</table>
### Driver Weights

#### Overview

A weighted driver contains two factors that represent the relationship between accounts. The first factor measures volume (or frequency), and the second factor measures intensity (or complexity). The two factors are multiplied to produce a calculated value that is used for distributing costs. This calculated value, based on weight, is necessary because if the cost of a source account is merely passed to each destination account, the cost incurred by the complexity of each destination account is not considered. Therefore, the cost of each destination account is not accurate. To compensate for the intensity or complexity of each destination account, a relative weight is specified for each destination account.

For example, in the following figure, the cost ($100) for the activity Process Orders is equally assigned to the cost objects Simple Product and Complex Product. But, this cost is not accurate because of the difference in complexity between the products.

![Diagram](image1)

Suppose that Complex Product is four times more complex than Simple Product. To consider the different complexities, assign a weighted driver to Process Orders. Then, specify the driver weight of 1 to Simple Product and 4 to Complex Product. After calculating, the costs for the products are significantly different and more accurate.

![Diagram](image2)
Specify the driver weights using the properties Driver Weight Fixed and Driver Weight Variable, depending on whether the driver supports fixed quantities, variable quantities, or both. (Examples of weighted drivers)

Example: Processing Customer Orders

The following examples illustrate how weighted drivers can be used in a model. These equations often include numeric properties and numeric attributes.

Suppose that a company sells products with varying numbers of options. Some products offer no options and some products offer many options. The cost of processing customer orders is equal to the number of orders that are processed (frequency), multiplied by the average number of lines per order (complexity, which is the number of options for each product). The products that offer the most options have greater weights than the products that offer fewer (or no) options.

Example: Supporting Products

Suppose that a company sells products of varying complexity. Some products are simple and yield customer telephone calls that require little time. Some products are complex and yield customer calls that require significant time. Each product is assigned a weight based on the amount of time needed for an average customer call.

See Also

- “Driver Weight Fixed (DWF)” on page 732
- “Driver Weight Variable (DWV)” on page 732
- “Specify the Weights for a Weighted Driver” on page 398
- “Fixed Driver Quantities” on page 374
- “Variable Driver Quantities” on page 375

Unique and Non-Unique (Shared) Driver Quantities

Unique Driver Quantities

Driver quantities determine the amount of a cost to distribute from a source account to destination accounts. A driver quantity can be unique or non-unique.

A unique driver quantity is a quantity for a destination account that can differ for every assignment to that destination account through the same driver. For each account that receives costs, you must specify the driver quantity.
Non-Unique (Shared) Driver Quantities

A non-unique driver quantity is a quantity for a destination account that is identical for every assignment to that destination account through the same driver. You specify the driver quantity once for the destination account, and that driver quantity is applied to all assignments. If you determine that you must put the same driver quantity on multiple destination accounts using the same driver, then that driver probably needs to be non-unique.

Changing Driver Quantities between Unique and Non-Unique

You can change a driver quantity from unique to non-unique, or vice versa, at any time, even after driver quantities have been calculated. If you change a non-unique driver quantity to a unique driver quantity, the driver quantity is copied to each destination account. If you change a unique driver quantity to a non-unique driver quantity, the first driver quantity that is encountered is copied to each destination account.

Suppose that the activities Take Orders and Process Orders flow costs to the cost objects Simple Product and Complex Product, as shown in the following figure:
The driver for Take Orders is a basic, non-unique driver (named Basic Non-Unique). The driver for Process Orders is a basic, unique driver (named Basic Unique). Even though both activities flow costs to the same cost objects, the driver quantities for each cost object are different (the column DQF).

Now, suppose that the driver Basic Unique for the activity Process Orders is changed to the driver Basic Non-Unique. Because the driver quantities are now non-unique, the driver quantities specified for the cost objects in the assignment to Take Orders are copied to the assignment to activity Process Orders. This is shown in the following figure:

In the previous example, a non-unique driver might be the best type because the number of orders processed for each product is probably the same number of orders taken for each product.

---

**Driver Sequencing**

**Overview**

Driver sequencing allows you define multiple calculation passes through assignments such that the driver quantity (DQF or DQV) of a sequenced driver (in a subsequent pass) is based on a cost resulting from drivers that execute in a previous pass.

To create a sequenced driver:

1. Click the **Advanced** tab of the Driver Properties dialog and select Use this sequence number.

2. Select a sequence number greater than 1.

   By default, non-sequenced drivers have a sequence number of 1.
3. Select **Replace fixed quantity with** or **Replace variable quantity with** (or both) and select a cost from the drop down list.

The cost that you select is used as the Driver Quantify Fixed (DQF) or Driver Quantity Variable (DQV) for the driver.

In the following example there are two workers and a manager. The two workers contribute a fixed portion (DQF) of their salary using a Basic driver to two activities, Activity 1 and Activity 2, as shown in the following table. By using a sequenced driver for the manager, you can base the manager's cost contribution to the two activities on the relative contributions of the two people that the manager manages.

<table>
<thead>
<tr>
<th></th>
<th>DQF Activity 1</th>
<th>DQF Activity 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Worker 1</td>
<td>1</td>
<td>5</td>
</tr>
<tr>
<td>Worker 2</td>
<td>1</td>
<td>2</td>
</tr>
<tr>
<td>Manager</td>
<td>to be determined</td>
<td>to be determined</td>
</tr>
</tbody>
</table>

As the following picture shows, the driver quantities that are used for Driver 2 (the driver that executes in sequence 2 for the manager) are based on costs from the drivers that execute in sequence 1.
The following picture perhaps shows more clearly the processing sequence in the example under consideration. In a first pass, all drivers of sequence 1 are calculated. In this first pass the Manager's costs for Activity 1 and Activity 2 are calculated as $0. In a second pass, the Manager's costs are calculated based on the costs resulting from the first pass.

The following table summarizes the values shown in the preceding picture:

<table>
<thead>
<tr>
<th>Src. Cost (Salary)</th>
<th>DQF Activity 1</th>
<th>DQF Activity 2</th>
<th>Dst. Cost Activity 1</th>
<th>Dst. Cost Activity 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Worker 1</td>
<td>$1200</td>
<td>1</td>
<td>5</td>
<td>$200</td>
</tr>
<tr>
<td>Worker 2</td>
<td>$1200</td>
<td>1</td>
<td>2</td>
<td>$400</td>
</tr>
<tr>
<td>Manager</td>
<td>$1600</td>
<td>200+400=600</td>
<td>1000+800=1800=1</td>
<td>$400</td>
</tr>
</tbody>
</table>

Note: These overwritten values remain, even when you remove driver sequencing for the driver. To change the driver quantities, you must manually change them. Because of this potentially extensive impact on model data, SAS recommends that you define
a new driver for use with driver sequencing. You should not use an existing driver to
experiment with driver sequencing.

**Misconceptions about Driver Sequencing**

The following list presents common misconceptions about driver sequencing:

- Every driver needs a sequence number.
  
  Specify a sequence number for a driver only when the driver quantities on the
  destination accounts need to be replaced. This replacement is the only function of
  driver sequencing.

- Every driver in an assignment path needs a sequence number.
  
  Do not specify a driver sequence in an attempt to indicate the calculation sequence
  between accounts in an assignment path. For example in the following picture
  specifying a sequence is unnecessary. The driver between Account A and Account B
  will automatically run before the driver between Account B and Account C.

![Account A ➔ Account B ➔ Account C](Sequence 1 ➔ Sequence 2)

- A sequenced driver is not paired with any particular previous driver. The cost that
  replaces the DQF or DQV for a sequenced driver is the cost for an account at the
time the sequenced driver runs, regardless of what drivers have contributed to that
cost. For example in the following picture, the DQF for Driver 3 is not just the cost
resulting from Driver 2 - it is the cost resulting both from Driver 1 and Driver 2.
More generally, the cost of a driver in a sequence is the cost resulting from all drivers
in a previous sequence.

![Account A ➔ Driver 1, sequence 1 ➔ Driver 2, sequence 2 ➔ Driver 3, sequence 3 ➔ Account B](Sequence 1 ➔ Sequence 2)

---

**Idle Quantities**

**Overview**

Idle quantities are unused resources or unused time in a model. For example, if a
machine can run for 10 hours a day, but is used for only eight hours a day, the idle
quantity for that machine is two hours. You can assign the idle quantity to the destination
accounts, as follows:
The 10 hours that the machine can run is specified in the user-entered total driver quantity (the column TDQUE). The eight hours that the machine is used is specified in the fixed-driver quantities (the column DQF; five hours for the Front Fender and three hours for the Rear Fender). The two hours of idle quantity is calculated by the system (the column IdlQty; 10 TDQUE on the source account minus 8 DQF on the destination accounts).

You can specify how idle quantities are distributed for a driver. If you do not activate this feature, idle quantities are not displayed in an account’s hierarchy, and idle quantities are not used when an account’s cost is calculated.

To specify how idle quantities are distributed in an assignment, you can select one of the choices described below. The effect of each choice on the previous example is shown, based on the hourly cost of the machine (a press, in this example), which is $100.00.

**User-Entered Quantities**

If you choose to distribute idle quantities using user-entered quantities, you specify the idle quantities to be assigned to the idle components (the property idle quantity user-entered; the column IdlQtyUE). For example, you enter two hours for the Rear Fender.

<table>
<thead>
<tr>
<th>IntsctnName</th>
<th>DQF</th>
<th>IdlQtyUE</th>
<th>IdlDrvQty</th>
<th>DrvIdlCost</th>
</tr>
</thead>
<tbody>
<tr>
<td>North America x Front Fender</td>
<td>5.00</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>North America x Rear Fender</td>
<td>3.00</td>
<td>2.00</td>
<td>2.00</td>
<td>$200.00</td>
</tr>
</tbody>
</table>

The system-generated value for the idle driver quantity (the column IdlDrvQty) corresponds to your entry. After calculating the costs, the driver idle cost (the column DrvIdlCost) is $200.00 (2.00 x $100.00).

**User Proportion Quantities**

If you choose to distribute idle quantities using user-proportioned quantities, you specify the proportions for the idle quantities (the property idle quantity user-entered; the column IdlQtyUE). For example, you enter 1 for the Front Fender and 3 for the Rear Fender.

<table>
<thead>
<tr>
<th>IntsctnName</th>
<th>DQF</th>
<th>IdlQtyUE</th>
<th>IdlDrvQty</th>
<th>DrvIdlCost</th>
</tr>
</thead>
<tbody>
<tr>
<td>North America x Front Fender</td>
<td>5.00</td>
<td>1.00</td>
<td>0.50</td>
<td>$50.00</td>
</tr>
<tr>
<td>North America x Rear Fender</td>
<td>3.00</td>
<td>3.00</td>
<td>1.50</td>
<td>$150.00</td>
</tr>
</tbody>
</table>

The total user-entered idle quantities is 4.00: 1.00 + 3.00. After calculating the costs, the idle driver quantity (the column IdlDrvQty) for the Front Fender is 0.50 (1/4 x 2.00), and the idle driver quantity for the Rear Fender is 1.50 (3/4 x 2.00).

Therefore, the driver idle cost (the column DrvIdlCost) for the Front Fender is $50.00 (0.50 x $100.00). The driver idle cost for the Rear Fender is $150.00 (1.50 x $100.00).
Use Driver Quantities

If you choose to distribute idle quantities with driver quantities, the ratio of the driver quantities is used for assigning the idle quantities. For example, the ratio of the driver quantity for the Front Fender is 5/8 (5.00/(5.00+3.00)). The ratio of the driver quantity for the Rear Fender is 3/8 (3.00/(5.00+3.00)).

<table>
<thead>
<tr>
<th>IntsctnName</th>
<th>DQF</th>
<th>IdlQtyUE</th>
<th>IdlDrvQty</th>
<th>DrvIdlCost</th>
</tr>
</thead>
<tbody>
<tr>
<td>North America x Front Fender</td>
<td>5.00</td>
<td>1.25</td>
<td></td>
<td>$125.00</td>
</tr>
<tr>
<td>North America x Rear Fender</td>
<td>3.00</td>
<td>0.75</td>
<td></td>
<td>$75.00</td>
</tr>
</tbody>
</table>

After calculating the costs, the idle driver quantity (the column IdlDrvQty) for the Front Fender is 1.25 (5/8 x 2.00), and the idle driver quantity for the Rear Fender is 0.75 (3/8 x 2.00).

<table>
<thead>
<tr>
<th>IntsctnName</th>
<th>DQF</th>
<th>IdlQtyUE</th>
<th>IdlDrvQty</th>
<th>DrvIdlCost</th>
</tr>
</thead>
<tbody>
<tr>
<td>North America x Front Fender</td>
<td>5.00</td>
<td>1.00</td>
<td></td>
<td>$100.00</td>
</tr>
<tr>
<td>North America x Rear Fender</td>
<td>3.00</td>
<td>1.00</td>
<td></td>
<td>$100.00</td>
</tr>
</tbody>
</table>

Therefore, the driver idle cost (column DrvIdlCost) for the Front Fender is $125.00 (1.25 x $100.00). The driver idle cost for the Rear Fender is $75.00 (0.75 x $100.00).

Evenly Assigned Quantities

If you choose to distribute idle quantities with evenly assigned quantities, the idle quantities are divided evenly among the destination accounts. For example, each of the destination account’s idle quantity is 1.00, which is half of the source account’s idle quantity of 2.00.

<table>
<thead>
<tr>
<th>IntsctnName</th>
<th>DQF</th>
<th>IdlQtyUE</th>
<th>IdlDrvQty</th>
<th>DrvIdlCost</th>
</tr>
</thead>
<tbody>
<tr>
<td>North America x Front Fender</td>
<td>5.00</td>
<td>1.00</td>
<td></td>
<td>$100.00</td>
</tr>
<tr>
<td>North America x Rear Fender</td>
<td>3.00</td>
<td>1.00</td>
<td></td>
<td>$100.00</td>
</tr>
</tbody>
</table>

After calculating the costs, the driver idle cost (the column DrvIdlCost) for both the Front Fender and the Rear Fender is $100.00 (1.00 x $100.00).

Example of Idle Flow

The following picture shows the four different methods of flowing an Idle Quantity from a source account to destination accounts. The four different methods are:

User Entered
The idle quantity is distributed as specified by the value of IdleQtyUE for each assignment path. Any idle quantity that is not distributed is assigned to the property Unassigned.

User Proportion
The idle quantity is distributed in the relative proportion of the IdleQtyUE of each assignment path.

Driver Quantity
The idle quantity is distributed in the relative proportion of the DQF of each assignment path.
Evenly Assigned

The idle quantity is distributed equally among the destination accounts.

Note: \( \text{IdleQty} = \text{TDQUE} - \text{UsedQuantity} \)

See Also

“Idle Quantities” on page 384
Reciprocal Costing

Overview

Reciprocal costing is a technique that enables costs to be shared between two or more accounts in the same module. With reciprocal costing, part of an account’s cost flows to another account, and part of that account’s cost flows back to the original account.

Note: In the Model Summary window, reciprocal cost assignments are referred to as cycles.

For example, suppose that part of the cost of the Information Technology (IT) department is based on how much time IT personnel spend maintaining the computers in the Human Resources (HR) department. Part of the cost of the HR department is based on how much time HR personnel spend hiring IT workers. These two activities are reciprocal accounts because they share costs.

Reciprocal Costs Calculation

Reciprocal costs are calculated using simultaneous equations. This means that the costs that are shared between accounts A and B are calculated at the same time, as shown below:

The equations:

\[
\begin{align*}
R1 &= 1500 + 0.10(2500 + 0.25A) \\
R2 &= 2500 + 0.25A
\end{align*}
\]

\[
\begin{align*}
A1 &= 0.5A \\
A2 &= 0.25A + 0.9B
\end{align*}
\]

The calculations:

\[
\begin{align*}
R1 &= 1500 + 0.10(2500 + 0.25A) \\
&= 1500 + 250 + 0.025A \\
&= 1750 + 0.025A
\end{align*}
\]

\[
\begin{align*}
R1 &= 1750 \cdot 0.025 = 1794.87 \\
A1 &= 0.5 \cdot 1794.87 = 897.44 \\
A2 &= 0.25 \cdot 1794.87 + 0.9 \cdot 2048.72 = 3102.56
\end{align*}
\]

See Also

- “IsReciprocal (IsRecip)” on page 744
- “Reciprocal Id (RecipId)” on page 751
Chapter 46
Windows for Drivers

Drivers View

About the Drivers View
How to Access the Drivers View

New Driver Dialog Box
About the New Driver Dialog Box
How to Access the New Driver Dialog Box
General Tab
Advanced Tab

Driver Properties Dialog Box
About the Driver Properties Dialog Box
How to Access the Driver Properties Dialog Box
General Tab
Advanced Tab

Drivers View

About the Drivers View
On the Drivers view, you can manage a model's drivers, the types of drivers, and the driver quantities.

*Note:* You cannot directly edit the information on the Drivers view.

**How to Access the Drivers View**

Open a model and select **Model ➤ Drivers**.

**See Also**

- Chapter 40, “Introducing Drivers,” on page 329
- “Create a Driver” on page 397
- “New Driver Dialog Box” on page 390
- “Driver Properties Dialog Box” on page 393

---

**New Driver Dialog Box**

**About the New Driver Dialog Box**

In the New Driver dialog box, you can name a new driver and you can specify other information about the driver.

*Note:* The availability of these features depends on your permissions.

**How to Access the New Driver Dialog Box**

On the Drivers view, select **Edit ➤ New Driver**.
General Tab

Specify the following information:

**Name**
- See “Driver naming conventions” on page 46.

**Driver type**

**This driver’s quantities are unique**
- Unique means that when this driver goes from multiple source accounts to the same destination account, then DQF, DQV, DWF, and DWV can have different values on the assignments to that destination account.

- Non-Unique (also called “Shared” and “Destination-Specific”) means that when this driver goes from multiple source accounts to the same destination account, then DQF, DQV, DWF, and DWV have the same value on all assignments to that destination account.

- See “Unique and Non-Unique (Shared) Driver Quantities” on page 379.

**Allow fixed driver quantities**
- DQF is user-editable on an assignment.

- See “Fixed Driver Quantities” on page 374.
Allow variable driver quantities
DQV is user-editable on an assignment.
See “Variable Driver Quantities” on page 375.

Allow weighted quantities
DWF and DWV are user-editable on an assignment.
See “Driver Weights” on page 378.

Formula
This option is available for calculated drivers. See Chapter 44, “Calculated Driver,” on page 367.
Click Formula Builder to define a formula. See “Formula Builder Dialog Box” on page 445.
The Formula Builder dialog box appears.
Tip You can also modify the formula in the Formula box.

Use Rule Formula
Select this option if you want the driver to be a rule-based driver. See “Make Assignments Using a Rule” on page 410.
Then, click Formula Builder. See “Formula Builder Dialog Box” on page 445.
Note: If you create a formula for the rule and run calculate to create assignments, then you can subsequently uncheck Use Rule Formula to cause calculate not to create assignments based on the rule formula. The rule formula is retained but calculate ignores it. This is useful in allowing you to run calculate once to create the assignments, and then remove some of those assignments or add additional ones. If you have done this, then you don't want calculate to restore the assignments that you removed or remove the assignments that you added. You can also turn off all rule formulae by selecting Disable Driver Rules during calculate.
Note: Selecting Use Rule Formula does not by itself cause assignments to be generated. It only allows you to define a rule formula. Assignments are generated only during calculate.

See Also
• “Make Assignments Using a Rule” on page 410
• Chapter 44, “Calculated Driver,” on page 367
• “Formula Builder Dialog Box” on page 445
**Advanced Tab**

These choices are optional. The available options depend on the type of driver that is being created.

**Assign idle quantities using this method**
See “Idle Quantities” on page 384.

**Use this sequence number**
If you select this option, then specify a number in the box on the right. See “Driver Sequencing” on page 381.

**Replace fixed quantity with**
If you select this option, then select a numeric property from the menu on the right. See “Fixed Driver Quantity Override” on page 734. Also see “Fixed Driver Quantities” on page 374.

*Note:* This option is only available for Basic, Bill of Costs, and Weighted drivers.

**Replace variable quantity with**
If you select this option, then select a numeric property from the menu on the right. See “Variable Driver Quantity Override” on page 764.

*Note:* This option is only available for Basic, Bill of Costs, and Weighted drivers.

**Allow user-entered cost allocation**
See “Allocated Cost (AllocCost)” on page 711.

---

**Driver Properties Dialog Box**

**About the Driver Properties Dialog Box**

The availability of these features depends on your permissions.

In the Driver Properties dialog box, you can review or change the properties of a driver.
**How to Access the Driver Properties Dialog Box.**

On the Drivers view, select a driver and select **Edit** ⇒ **Item Properties**.

**General Tab**

Specify the following information:

**Name**

See “Driver naming conventions” on page 46.

**Driver type**


**This driver’s quantities are unique**

Unique means that when this driver goes from multiple source accounts to the same destination account, then DQF, DQV, DWF, and DWV can have different values on the assignments to that destination account.

Non-Unique (also called “Shared” and “Destination-Specific”) means that when this driver goes from multiple source accounts to the same destination account, then DQF, DQV, DWF, and DWV have the same value on all assignments to that destination account.

See “Unique and Non-Unique (Shared) Driver Quantities” on page 379.
Allow fixed driver quantities
   DQF is user-editable on an assignment.
   See “Fixed Driver Quantities” on page 374.

Allow variable driver quantities
   DQV is user-editable on an assignment.
   See “Variable Driver Quantities” on page 375.

Allow weighted quantities
   DWF and DWV are user-editable on an assignment.
   See “Driver Weights” on page 378.

Formula
   This option is available for calculated drivers. See Chapter 44, “Calculated Driver,” on page 367.
   Click Formula Builder to define a formula. See “Formula Builder Dialog Box” on page 445.
   The Formula Builder dialog box appears.
   Tip You can also modify the formula in the Formula box.

Use Rule Formula
   Select this option if you want the driver to be a rule-based driver. See “Make Assignments Using a Rule” on page 410.
   Then, click Formula Builder. See “Formula Builder Dialog Box” on page 445.
   Note: If you create a formula for the rule and run calculate to create assignments, then you can subsequently uncheck Use Rule Formula to cause calculate not to create assignments based on the rule formula. The rule formula is retained but calculate ignores it. This is useful in allowing you to run calculate once to create the assignments, and then remove some of those assignments or add additional ones. If you have done this, then you don't want calculate to restore the assignments that you removed or remove the assignments that you added. You can also turn off all rule formulae by selecting Disable Driver Rules during calculate.
   Note: Selecting Use Rule Formula does not by itself cause assignments to be generated. It only allows you to define a rule formula. Assignments are generated only during calculate.

See Also
   • “Make Assignments Using a Rule” on page 410
   • Chapter 44, “Calculated Driver,” on page 367
   • “Formula Builder Dialog Box” on page 445
Advanced Tab

These choices are optional. The available options depend on the type of driver that is being created.

**Assign idle quantities using this method**

See “Idle Quantities” on page 384.

**Use this sequence number**

If you select this option, then specify a number in the box on the right. See “Driver Sequencing” on page 381.

**Replace fixed quantity with**

If you select this option, then select a numeric property from the menu on the right. See “Fixed Driver Quantity Override” on page 734. Also see “Fixed Driver Quantities” on page 374.

*Note:* This option is only available for Basic, Bill of Costs, and Weighted drivers.

**Replace variable quantity with**

If you select this option, then select a numeric property from the menu on the right. See “Variable Driver Quantity Override” on page 764.

*Note:* This option is only available for Basic, Bill of Costs, and Weighted drivers.

**Allow user-entered cost allocation**

See “Allocated Cost (AllocCost)” on page 711.
Chapter 47
How To: Drivers

Create a Driver
1. Open a model and select Model ⇒ Drivers Page.
The Drivers page appears.
2. Select the DRIVERS folder.
3. Select Edit ⇒ New Driver.
The New Driver dialog opens.
4. Select options on the General tab of the New Driver dialog. See “General Tab” on page 394.
5. Select options on the Advanced tab of the New Driver dialog. See “Advanced Tab” on page 396.

See Also
Chapter 40, “Introducing Drivers,” on page 329
Create a Rule-Based Driver

See “Make Assignments Using a Rule” on page 410.

Specify the Weights for a Weighted Driver

1. Open the module that contains the destination accounts for the source account that uses a weighted driver.

2. For a weighted driver that uses fixed driver quantities, add a column to contain the property Driver Weight Fixed.

3. For a weighted driver that uses variable driver quantities, add a column to contain the property Driver Weight Variable.

4. Click in the Driver Weight Fixed (DWF) column or the Driver Weight Variable (DWV) column for a destination account, and type a value.

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost</th>
<th>DWF</th>
<th>DWV</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACTIVITY (PRIMARY PANE)</td>
<td>$9,000.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>No Organization</td>
<td>$9,000.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Stamping Parts</td>
<td>$7,333.33</td>
<td>1.00</td>
<td>2.50</td>
</tr>
<tr>
<td>Chroning Parts</td>
<td>$1,000.00</td>
<td>3.00</td>
<td>5.00</td>
</tr>
<tr>
<td>Attaching Bumper</td>
<td>$666.57</td>
<td>2.00</td>
<td>4.00</td>
</tr>
</tbody>
</table>

If you are prevented from entering these values, verify that the following are correct:

- The source account's driver is a weighted driver.
- The weighted driver allows fixed driver quantities, variable driver quantities, or both.

See Also

“Driver Weights” on page 378

Specify the Default Driver

1. Select Model ➔ Properties.

The Model Properties dialog box appears.
2. Click the **General** tab.

3. In the **Module Default Driver Options** section, select a default driver for each module.

   **Note:** If you delete a driver that is used, all accounts using the driver are flagged as using the module’s default driver. If there is no default driver, then the account is flagged as having no driver (i.e. undefined). If you delete the default driver, then the default driver is set to “undefined”.

---

**Associate a Driver Using an Account's Item Properties**

1. In a module view, select an account.

2. Select **Edit ➤ Item Properties**.

   The Item Properties dialog box appears.
3. Click the **Properties** tab.

4. From the **Properties** list, locate the **Driver Name** property.

5. Click in the **Value** column and select a driver.
Associate a Driver Using a Module's Grid

1. In a module view, add a column to display the **Driver Name** property.
2. Click in the **DrvName** column and select a driver.
Change the Properties of a Driver

1. Open a model and select Model ⇒ Drivers
2. Select a driver.
3. Select Edit ⇒ Item Properties.
   The Driver Properties dialog box appears. See “Driver Properties Dialog Box” on page 393.
Part 14

Assignments

Chapter 48
  Making Assignments ............................................. 405

Chapter 49
  Windows for Assignments ..................................... 421

Chapter 50
  How To: Assignments ............................................ 423
What Is an Assignment?

Overview

An assignment distributes costs between accounts using a driver. The amount of cost that flows is controlled by the driver. A single source account can make assignments to any number of destination accounts, but each source account can have only one driver.

Costs that are assigned between accounts in the same module are called inner-module assignments. Costs that are assigned between accounts in different modules are cross-module assignments.

Before creating an assignment, you must select accounts to add to the assignment.

Assignments are periodic elements. An assignment between two accounts in one period/scenario may or may not exist between the same accounts in another period/scenario. And, when an assignment exists between the same accounts in multiple periods/scenarios, its values in one period/scenario are independent of its values in another period/scenario.

See Also

- Chapter 40, “Introducing Drivers,” on page 329
- “Make an Assignment” on page 424
Assignment Paths

The sequence of accounts through which costs flow is called the assignment path. For example, suppose that costs are assigned from account A to account B. Then costs are assigned from account B to account C. This process creates an assignment path from account A to account C.

The following picture illustrates the rules for making assignments:
1. An account can receive assignments from any number of accounts (including zero) and can make assignments to any number of accounts (including zero).
   
   A rollup account can not make or receive assignments. See “Rollup Accounts and Module Rollups” on page 202.
   
   Try to assign 100 percent of an account's costs to other accounts. If you do not assign all costs, the system issues warnings when you calculate costs.
2. An account can make an assignment to another account in the same module. However, an assignment can not go backwards—from an account in one module to an account in a previous module.
3. Assignments can skip modules—for example from an account in module 1 to an account in module 3.
4. An account can make an assignment to itself. See “Reciprocal Costing” on page 388.
5. One account can indirectly make an assignment to itself—by assigning, directly or indirectly, to an account that makes an assignment to the one account.
Assignments Panes

Overview
You can view the accounts in a module using up to three window panes. This enables you to create assignments and to see the assignments between accounts.

In both the two-pane view and the three-pane view, costs flow from the left to the right.
Primary Pane
The primary pane shows you one module at a time. The primary pane displays the hierarchy of a module—its accounts and rollup accounts. (See Chapter 27, “What are Accounts?” on page 197.)

To show the primary pane, do one of the following:

- Select Model ➔ Assignments ➔ Show Single Pane.
- Click the View Assignments Pane icon and select Single Pane.

Left Assignments Pane
The left assignments pane shows all and only those accounts that make assignments to accounts in the primary pane.

Note: The accounts displayed in the left assignments pane are all and only those accounts that make assignments to accounts in the primary pane—regardless of which module the accounts in the left assignments pane belong to. For example, because an account can assign costs to another account in the same module, accounts displayed in the left assignments pane can belong to the same module as that displayed in the primary pane. Similarly, because an account can skip modules in assigning costs to another account, the accounts displayed in the left assignments pane can belong to modules considerably to the left of the module displayed in the primary pane.

To show the left assignments pane, do one of the following:

- Select Model ➔ Assignments ➔ Left Assignments Pane.
- Click the View Assignments Pane icon and select Left Assignments Pane.

Right Assignments Pane
The right assignments pane shows all and only those accounts that receive assignments from accounts in the primary pane.

Note: The accounts displayed in the right assignments pane are all and only those accounts that receive assignments from accounts in the primary pane—regardless of which module the accounts in the right assignments pane belong to. For example, because an account can assign costs to another account in the same module, accounts displayed in the right assignments pane can belong to the same module as that displayed in the primary pane. Similarly, because an account can skip modules in assigning costs to another account, the accounts displayed in the right assignments...
pane can belong to modules considerably to the right of the module displayed in the primary pane.

To show the right assignments pane, do one of the following:

- Select **Model ⇒ Assignments ⇒ Right Assignments Pane**.
- Click the View Assignments Pane icon and select **Right Assignments Pane**.

### Splitter Bar

The space between the panes is called the splitter bar. Within the splitter bar, lines and arrows indicate the assignments between accounts. Costs flow from the left to the right.

To display both incoming and outgoing assignments in the splitter bar, do the following:

1. Select **Left and Right Assignments Panes** from the View Assignments Panes icon.

2. Select **Show Left and Right** from the Show Assignments icon.

**Tip** You can split the assignments panes simply by clicking the Show Left and Right Assignments Panes button. It is not necessary to pull down the menu.

If there are no assigned costs, you see nothing additional when you show assignments.

**Tip** You can also divide the Attributes view to see the accounts to which an attribute has been assigned. See “Attributes View” on page 270.
See Also

“Understanding Properties in a Column Layout” on page 298

Guidelines for Making Assignments

Before you create assignments, consider the following:

• You can assign costs from one account to another account, but you cannot assign costs to a roll-up account.

• Try to assign 100 percent of an account's costs to other accounts.

  If you do not assign 100 percent, SAS Cost and Profitability Management issues warnings when you calculate costs.

See Also

“What Is an Assignment?” on page 405

Make Assignments Using a Rule

About Rule-based Drivers

Rule-based drivers allow you to generate cost assignments automatically. A rule-based driver is an ordinary driver with an associated rule formula. The formula determines for which destination accounts an assignment is automatically generated from every source account to which the driver is attached.

Creating and using rule-based drivers is a four-step process:

1. Attach a formula to a driver.

   To attach a formula, on the Driver Properties dialog select Use Rule Formula and click Formula Builder.

   Any sort of driver (evenly assigned, percentage, standard, calculated) can have a formula (referred to as a rule formula).

   Use the Formula Builder to build a rule formula. The following is a sample formula:

   Module="CostObject" AND Destination.HasAttribute("SuppHours") AND SuppHours > 5

   This sample formula returns true for every destination account in the CostObject module that has an attribute "SuppHours" whose value is greater than 5.

2. Attach the driver to one or more source accounts.

   The source accounts can be in any module.

3. Calculate the model.
During calculation every source account that has a rule-based driver (a driver with an associated rule formula) attached to it starts the following process:

- Every destination account that is downstream of the source account is evaluated for the rule formula. (A destination account is downstream of a source account if it is in the same module as the source account or if it is in a later module when the modules are considered in the order in which you defined the modules, or in the following order in the case of a traditional activity-based costing model: External Unit, Resource, Activity, Cost Object).
- If the rule formula tests true for the destination account, then an assignment is made between the source account being considered and that destination account.
- If the rule formula tests false for the destination account and there is currently an assignment between the source account being considered and that destination account, then the assignment is deleted.
- If the rule formula tests false for the destination account and there is currently no assignment between the source account being considered and that destination account, then no assignment is made.

4. **Clean up the assignments made.**

This step is optional and is recommended only for rapid prototyping.

- Manually delete any assignments that were created that you don't want.
- Manually create any additional assignments that you do want between a source account with a rule-based driver and a destination account for which the rule formula tested false.

*Note:* If you do this sort of manual clean-up, then you should be aware of the fact that running a subsequent calculation will restore the assignments that you deleted and delete the additional assignments that you made. You can avoid this in either of two ways:

- Selecting Disable Driver Rules during calculation to disable all rule-based drivers.
- Deselecting Use Rule Formula in the Driver Properties dialog box to disable the rule formula for an individual driver.

**Sample Rule-based Drivers**

Suppose we have a model with the following dimensions:
Suppose also that we have a numeric attribute named SuppHours:

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>Type</th>
<th>UoM</th>
</tr>
</thead>
<tbody>
<tr>
<td>ATTRIBUTES</td>
<td>ATTRIBUTES</td>
<td></td>
<td></td>
</tr>
<tr>
<td>SuppHours</td>
<td>SuppHours</td>
<td>Numeric</td>
<td>hours</td>
</tr>
</tbody>
</table>

The attribute is attached to two Cost Object accounts:

<table>
<thead>
<tr>
<th>Display Name</th>
<th>SuppHours</th>
</tr>
</thead>
<tbody>
<tr>
<td>COST OBJECT</td>
<td></td>
</tr>
<tr>
<td>No &lt;Customers&gt;</td>
<td></td>
</tr>
<tr>
<td>Retail</td>
<td></td>
</tr>
<tr>
<td>Sears</td>
<td></td>
</tr>
<tr>
<td>4 No &lt;Products&gt;</td>
<td></td>
</tr>
<tr>
<td>Recreation</td>
<td></td>
</tr>
<tr>
<td>4 Bike</td>
<td>5.00</td>
</tr>
<tr>
<td>Lawn &amp; Garden</td>
<td></td>
</tr>
<tr>
<td>Kmart</td>
<td></td>
</tr>
<tr>
<td>4 No &lt;Products&gt;</td>
<td></td>
</tr>
<tr>
<td>Recreation</td>
<td></td>
</tr>
<tr>
<td>4 Bike</td>
<td>15.00</td>
</tr>
<tr>
<td>Lawn &amp; Garden</td>
<td></td>
</tr>
<tr>
<td>Wholesale</td>
<td></td>
</tr>
<tr>
<td>Passthru</td>
<td></td>
</tr>
</tbody>
</table>

Suppose, finally, that we have defined three rule-based drivers with the rule formulas shown in the following table:

<table>
<thead>
<tr>
<th>Driver Name</th>
<th>Driver Type</th>
<th>Rule Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>CustSupp</td>
<td>Standard</td>
<td>SuppHours&lt;&gt;0</td>
</tr>
</tbody>
</table>
Notice that a rule-based driver can be of any type (evenly assigned, percentage, standard, calculated). So, a calculated rule-based driver has two formulas: a rule formula to determine assignments and a driver formula to determine the calculation for each assignment. The following picture shows drivers in our sample model:

The following picture shows the two assignments that are generated by the driver CustSupp whose rule formula is: \textbf{SuppHours}<>0:

- Kmart x Bike (for which account SuppHours=15)
- Sears x Bike (for which account SuppHours=5)

The following picture shows the two assignments that are generated by the driver Stock, whose rule formula is: Cust.DimMemRef="None" AND Prod.DimMemRef<>"None"

- No <Customers> x Mower
- No <Customers> x Bike

It is important to note that even though the column for the intersection name shows "No <Customers>" in the following picture, you must use the internal name "None" in your formulas.
CAUTION!

Because “None” is localizable, you must use the value of “None” for your locale. Following is a list of possible values according to locale:

German  Kein
English  None
Spanish  Ninguno
French   Néant
Italian  Nessuno
Japanese  なし
Korean  なかった
Dutch    Geen
Portuguese (Brazil)  Nenhum
Chinese Simplified  无
Chinese Traditional (Hong Kong SAR)  无
Chinese Traditional (Taiwan)  无

Note: Instead of using a localizable constant, you can use the IsNone() function, which will work in any locale. See “IsNone function” on page 455.

The following picture shows the three assignments that are generated by the driver Sell whose rule formula is: \text{Prod.DimMemRef}="None" \text{ AND Cust.DimMemRef<>"None"}

\begin{itemize}
  \item Sears \times \text{No <Products>}
  \item Kmart \times \text{No <Products>}
  \item Passthru \times \text{No <Products>}
\end{itemize}

Note: Again, note that the formula uses "None" for the null intersection even though the column heading in the assignments pane shows "No <Prod>".
**Two More Rule-Based Drivers**

Now let's introduce two more rule-based drivers to create assignments from Cost Object accounts to other Cost Object accounts:

<table>
<thead>
<tr>
<th>Driver Name</th>
<th>Driver Formula</th>
</tr>
</thead>
</table>

The following picture shows three of the assignments that are generated by the driver Product, whose rule formula is the following:

```
Prod.DimMemRef<>"None"
AND Cust.DimMemRef<>"None"
AND Source.Cust.DimMemRef="None"
```

And, the following picture shows three more assignments that are generated by the driver Product:

The following picture shows two of the assignments that are generated by the driver Customer, whose rule formula is the following:

```
Prod.DimMemRef<>"None"
AND Cust.DimMemRef<>"None"
```
The following picture shows two more assignments that are generated by the driver Customer, whose rule formula is the following:

Prod.DimMemRef<>"None"
AND Cust.DimMemRef<>"None"
AND Source.Prod.DimMemRef="None"

And, the following picture shows the last two assignments that are generated by the driver Customer, whose rule formula is the following:

Prod.DimMemRef<>"None"
AND Cust.DimMemRef<>"None"
AND Source.Prod.DimMemRef="None"
**Additional Rule Formulas**

The following are some examples of formulas that you can use in a rule-based driver. For a full list of functions, see Functions.

<table>
<thead>
<tr>
<th>Rule Formula</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Match( Name, &quot;*Salary&quot; )</td>
<td>The name of the destination account matches &quot;*Salary&quot; e.g., &quot;Wages &amp; Salary&quot;.</td>
</tr>
<tr>
<td>TDQ &gt; 0 and TDQ &lt;= 100</td>
<td>The TDQ of the destination account is between 0 and 100.</td>
</tr>
<tr>
<td>Cost &gt; 0 and Source.Cost &lt; 0</td>
<td>The cost of the destination account is greater than 0 and the cost of the source account is less than 0.</td>
</tr>
<tr>
<td>(NumberOfCalls &gt; 0) OR (NumberOfReturns &gt; 0)</td>
<td>The value of the attribute, NumberOfCalls, on the destination account is greater than 0, or the value of the attribute NumberOfReturns, also on the destination account, is greater than 0.</td>
</tr>
</tbody>
</table>
| if(not IsNull(SoldQuantity), SoldQuantity, OutputQuantity) > 0 | The condition is evaluated as follows:  
1. If SoldQuantity is not null, then SoldQuantity is returned.  
2. If SoldQuantity is null, then OutputQuantity is returned.  
3. If whichever quantity is returned (SoldQuantity or OutputQuantity) is greater than 0, then the condition is true and an assignment is made. |

**Limitations**

- Properties on the source account related to outgoing assignments will be accessible but are not recommended for use in rule formulas. In all cases these will be zero because the outgoing assignments haven't been created yet. These properties are
TotalDriverQuantity, IdleQuantity, AssignedIdleQuantity, OutputQuantity, UsedQuantity, TotalDriverQuantityCalculated, TotalDriverQuantityBasic, DrivenQuantity, DrivableCost, IdleCost, AssignedIdleCost, UsedCost, AllocatedCost, DrivenCost, UnassignedCost, AssignedCost, AssignedReciprocalCost, AssignedNonReciprocalCost.

• A syntax error occurs if a rule formula uses an assignment property since they do not exist in the context of a rule evaluation. These properties are: AllocatedCost, Cost, DrivenCost, DriverQuantityCalculated, DriverQuantityFixed, DriverQuantityVariable, DriverRate, DriverWeightFixed, DriverWeightVariable, IdleCost, IdleDriverQuantityUE, UsedCost.

• If the **Use Rule Formula** checkbox is checked for a driver but no rule formula is defined, then all outgoing assignments are deleted from accounts that use that driver. If you want to retain existing assignments make sure the **Use Rule Formula** checkbox is unchecked when the rule formula is empty.

• No warning is issued if your formula refers to dimensions that exist but in an order that does not exist. For example, not warning is issued if your formula attempts to assign from an Activity module account to a Resource module account. Such an assignment does not exist because assignments cannot go in a backwards direction (e.g., from Activity module to Resource module).

• Assignments are not generated when you define a rule formula or when you import a model with rule-based drivers. Assignments are generated only when you calculate a model.

• When a field contains space between two words, always enclose the field in double quotation marks. For example, write `Intersection.Match("Product Type", Product, Cust)`.

**Recommendations**

Please be aware of the following considerations and recommendations in using rule-based drivers:

**Do Not Create Unnecessary Assignments**

The ease of creating assignments with rule-based drivers can lead to generating millions of unnecessary assignments. Unnecessary assignments both use up memory and increase calculate time. The more accounts there are that use rules-based drivers the more work there is for calculation to do beyond flowing costs.

One way to avoid unnecessary assignments is to include a check in the rule formula to eliminate assignments with zero cost flow. For example, suppose you have a calculated driver that uses the attribute NumberOfCalls to calculate cost. You could include in a rule formula the condition `NumberOfCalls > 0` to avoid making assignments with zero cost flow.

**Numeric Functions Are Faster Than String Functions**

Formulas that use string concatenation and functions that return strings are slower to evaluate than numeric or boolean expressions. Plan accordingly when using them in rule formulas or in calculated attributes that are referenced by rule formulas.

**Be Wary of Creating Reciprocal Assignments**

Remember that rule-based drivers can result in the creation of assignments from accounts in one module to destination accounts in the same module. As a result you can end up with unintended reciprocal costs. You can avoid reciprocal costs by specifying the destination module with the condition `Module.DimMemRef=`. For example:
Apart from these recommendations, always enclose a field (that is present in the formula) in double quotation marks when it contains a space between two words. For example, write `Intersection.Match("Product Type", Product, Cust)

**See Also**

- “Enhanced Formula Capabilities” on page 439
- “Formula” on page 432
- “Formula Context” on page 433
- “Troubleshooting Formulas” on page 443
- “Using Numeric Attributes in a Formula” on page 441
- Chapter 52, “Boolean Functions,” on page 449
- Chapter 53, “Numeric Functions,” on page 459
- Chapter 54, “String Functions,” on page 465
Chapter 49
Windows for Assignments

Add Accounts for Assignments Dialog Box

Overview

In the Add Accounts for Assignments dialog box, you can select accounts to display in an assignments pane in preparation for creating an assignment.

Note: Some functionality is not available depending upon your permissions

How to Access the Add Accounts for Assignments Dialog Box

Do one of the following:

• In any module view, open the left or right assignments pane and select Model ⇒ Assignments ⇒ Add Accounts in Left Pane (or Add Accounts in Right Pane).

• Click an Add accounts for assignment button on the toolbar.
See Also

- “Add an Account for Making an Assignment” on page 423
- “What Is an Assignment?” on page 405
Add an Account for Making an Assignment

1. Select Model ⇒ Assignments to display an additional assignment pane.
   - If the source account is in the primary pane, then select Show Right Assignments Pane to select the destination accounts. See “Right Assignments Pane” on page 408.
   - If the source account is in the left assignments pane, then select Show Left Assignments Pane.

   From the left assignments pane, you can make assignments only to the primary pane. If the desired source account is not visible in the left assignments pane, you can add it to that pane.

   See “Show Assignments Panes” on page 427.

2. Add accounts for assignments.
   a. Do one of the following:
      - Select Model ⇒ Assignments ⇒ Add Accounts in Right Pane.
      - Select Model ⇒ Assignments ⇒ Add Accounts in Left Pane.
      - Click one of the Add Accounts for Assignment icon.
The Add Accounts for Assignment dialog box appears. See “Add Accounts for Assignments Dialog Box” on page 421.

b. Select the accounts that you want to add to the left or right assignments pane and click Add Accounts.

The selected accounts are added to the appropriate assignments pane.

If you select a roll-up account, all accounts within that roll-up account are added.

Note: You cannot select the module roll-up (e.g., Cost Object) and add all accounts within it.

Make an Assignment

To make an assignment from a source account to a destination account:

1. Add the DrvName property to the column layout of the assignment pane that contains the source account.

   The source account can be in either the left assignments pane or the primary assignments pane. You can not make an assignment from an account in the right assignments pane because there is no pane visible to the right of the right assignments pane.

   For information on adding columns to a column layout, see “Create a Column Layout” on page 313.

   Note: If you want to make an assignment from a source account in the left assignments pane to an account in the primary pane, and if the source account is not visible in the left assignments pane, then you can add that account to the left assignments pane. See “Add an Account for Making an Assignment” on page 423.
2. Select **Model → Assignments** to display an additional assignment pane.

   - If the source account is in the primary pane, then select **Show Right Assignments Pane** to select the destination accounts. See “Right Assignments Pane” on page 408.
   
   - If the source account is in the left assignments pane, then select **Show Left Assignments Pane**.

     From the left assignments pane, you can make assignments only to the primary pane. If the desired source account is not visible in the left assignments pane, you can add it to that pane.

     See “Show Assignments Panes” on page 427.

3. Add accounts for assignments.

   a. Do one of the following:

      - Select **Model → Assignments → Add Accounts in Right Pane**.
      
      - Select **Model → Assignments → Add Accounts in Left Pane**.
      
      - Click one of the Add Accounts for Assignment icon.

      Add accounts to the left assignments pane  Add accounts to the right assignments pane

      The Add Accounts for Assignment dialog box appears. See “Add Accounts for Assignments Dialog Box” on page 421.

      b. Select the accounts that you want to add to the left or right assignments pane and click **Add Accounts**.

         The selected accounts are added to the appropriate assignments pane.

         If you select a roll-up account, all accounts within that roll-up account are added.

         *Note:* You cannot select the module roll-up (e.g., Cost Object) and add all accounts within it.

4. In the DrvName column for the row of the source account, select the driver that you want to use for making assignments.
5. To assign the cost to an account in the right assignments pane, click the arrowhead to the left of the account.

An arrow connects the two accounts.

To assign the cost from an account in the left assignments pane, click the arrowhead to the right of the account.

To summarize, as the following picture shows, you click an arrowhead in the splitter bar to make an assignment either:
- from the selected source account in the primary pane to an account in the right assignments pane
- from a source account in the left assignments pane to the selected account in the primary pane.

_TIP_ To quickly create assignments to many accounts, select Model ⇒ Assignments ⇒ Assign All Left, Assign All Right, or Assign All Left and Right.
Show Assignments To and From an Account

**Show Assignments to an Account**

1. Select **Model ⇒ Assignments ⇒ Show Left Assignments Pane**.
   
   The view is split to include an empty left assignments pane. The selected module is displayed in the primary pane on the right.

2. Expand the module hierarchy and select an account.

3. Select **Model ⇒ Assignments ⇒ Show Left**.
Show Assignments from an Account

1. Select **Model ➔ Assignments ➔ Show Right Assignments Pane**.
   The view is split to include an empty right assignments pane. The selected module is displayed in the primary pane on the left.

2. Expand the module hierarchy and select an account.

3. Select **Model ➔ Assignments ➔ Show Right**.
   Arrows indicate that the listed accounts are destination accounts for the selected account.

Show Assignments to and from an Account

1. Select **Model ➔ Assignments ➔ Show Left and Right Assignments Pane**.
   The view is split to include empty left and right assignments panes. The selected module is displayed in the primary pane in the center.

2. Expand the module hierarchy and select an account.

3. Select **Model ➔ Assignments ➔ Show Left and Right**.
   Arrows indicate the accounts that are source accounts for the selected account, as well as the accounts that are destination accounts for the selected account.

Delete Assignments

1. Decide which assignments panes to show.

2. To delete an assignment, click the arrowhead to the right (or to the left) of the source account (or of the destination account).
   An arrow connects the two accounts.

   **Tip** To quickly delete assignments to many accounts, select **Model ➔ Assignments ➔ Delete All Assignments Left, Delete All Assignments Right**, or **Delete All Assignments Left and Right**.

   **Tip** To delete all assignments, left and right, you can also click **Shift + F7**. All assignments are deleted—not just those that are displayed, in case there are some assignments not currently displayed.
Part 15

Using Formulas with Drivers and Calculated Attributes

Chapter 51
  *Formulas* ................................................................. 431

Chapter 52
  *Boolean Functions* ...................................................... 449

Chapter 53
  *Numeric Functions* ..................................................... 459

Chapter 54
  *String Functions* ........................................................ 465

Chapter 55
  *Properties That Can Be In Formulas* ............................... 469
Formula

Overview

A formula consists of expressions made up of the following elements that are evaluated in a context:

- strings and the string concatenation operator &
- Boolean operators: NOT, AND, OR
- numbers and numerical operators +, -, *, **, %, (, )
- relational operators <, <=, =, >=, >, <>
- functions
- system-defined properties
- user-defined attributes
- user-defined dimensions and dimension members
- user-defined dimension attributes and dimension member attributes
- system-defined dimensions: Module, Period, Scenario

Note:
Use the Formula Builder dialog box to create a formula for use with a:

- calculated driver (See Chapter 44, “Calculated Driver,” on page 367.)
- rule-based driver (See “Make Assignments Using a Rule” on page 410.)
- calculated attribute (See “Calculated Attributes” on page 248.)

Using attributes in a formula

To include user-defined attributes, you must create these attributes before you define a formula.

If you use an attribute in a calculated driver formula, you must add that attribute to all destination accounts of the assignment before running any calculations. When you add the attribute, enter the appropriate values for both the numeric attribute and the driver quantity. The numeric attribute and the driver quantity must contain values; they cannot be blank. You can add the attribute either before defining the calculated driver, or after. The numeric attribute must be added before you run a calculation. Otherwise, you might encounter errors, or costs might be calculated as zero.

Source account and destination accounts

A formula can use the numeric properties and numeric attributes of a source account or a destination account. In the SAS Cost and Profitability Management interface, the list of numeric properties includes the keywords [Source] and [Destination]. When you select either of the keywords to include in a formula, you see the notation Source. or Destination., followed by a property or attribute. For example, Source.Cost or Destination.UnitCost.
Note: By default in the formula for a calculated driver and for a rule-based driver, properties and attributes refer to destination accounts.

Property names in formulas

The property names in formulas are the same as the property names that you see elsewhere in SAS Cost and Profitability Management, except that the spaces are removed. For example, the property Allocated Cost is \texttt{AllocatedCost} in a formula.

Occasionally, the property name that is used in a formula contains an abbreviation, such as \texttt{DimLevelName} for the property Dimension Level Name, or \texttt{TDQ} for the property Total Driver Quantity.

Properties for a source account and a destination account

You can access the values of properties for a source account or a destination account. To access the properties for a source account, use the keyword \texttt{[Source]}, a period (.), and a property name. For example, \texttt{Source.Cost}. To access the properties for a destination account, use the keyword \texttt{[Destination]}. Both of the keywords are available when you define a formula.

Testing formulas

Testing a formula validates the operators and ensures that there are no spaces in the formula. However, numeric properties and numeric attributes are not validated. Testing does not guarantee that the formula is valid or that the formula will yield the intended value.

During calculation, if a formula references an item that does not exist, a warning is displayed. If you use an invalid formula, SAS Cost and Profitability Management halts the calculation as soon as it encounters the invalid formula. Subsequent values in the model are not calculated.

Using attribute names

To ensure that SAS Cost and Profitability Management correctly interprets any special characters or spaces in a numeric attribute name, enclose the name in double quotation marks (" "). You do not need to use quotation marks for names of numeric properties.

For example, in the following formula, \texttt{OutputQuantity} does not require quotation marks because it is a system-defined numeric property. But, \texttt{Units Per Pallet} requires quotation marks because that name contains spaces.

\texttt{OutputQuantity/"Units Per Pallet"}

Formula Context

Overview

A formula consists of expressions made up of the following elements:

- strings and the string concatenation operator &
• Boolean operators: NOT, AND, OR
• numbers and numerical operators +, -, *, /, **, %, (, )
• relational operators <, <=, =, >=, >, <>
• functions
• system-defined properties
• user-defined attributes
• user-defined dimensions and dimension members
• user-defined dimension attributes and dimension member attributes
• system-defined dimensions: Module, Period, Scenario

Note: See “Operator Precedence” on page 444.

Some expressions are not dependent on context. For example the string ABC and the number 2010 refer to the same thing regardless of context. Other expressions, such as attributes and properties depend on context. The property Cost, for example, only has a value relative to an account or an assignment. Hence, you should be aware of the following principles concerning formulas:

**calculated driver**

The formula for a calculated driver is calculated in the context of an assignment from each source account to which the driver is attached and each destination account, in turn, from that source account.

By default, properties and attributes in the formula refer to the destination account.

**rule-based driver**

The formula for a rule-based driver is calculated in the context of an assignment from each source account to which the driver is attached and each potential destination account, in turn, from that source account.

By default, properties and attributes in the formula refer to the destination account.

**calculated attribute**

The formula for a calculated attribute is evaluated in the context of an account.

---

**Qualifying Properties**

When you include a property in a formula, you can qualify the name of the property to specify unambiguously which property you are referring to. Although qualifiers may not be necessary in a particular case, you are always allowed to use up to two levels of qualifiers:

```
Source Dimension Reference Property
```

For example: `Source.Product.OutputQuantity`

Following are some examples:
Example

Products.DimMemRef
Source.Products.DimMemRef
Destination.Products.DimMemRef

Explanation

In this example, "Products" is a dimension reference. When unqualified with either Source or Destination, Destination is assumed.

When you create a dimension member you must specify its reference.

When the dimension member is displayed in an assignments pane, its column header is labelled DimMemRef to distinguish it from the column for an account reference.

Example

Products.DrivableCost
Source.Products.DrivableCost
Destination.Products.DrivableCost

Explanation

In this example, "Products" is a dimension reference. When unqualified with either Source or Destination, Destination is assumed.
Example
Module.DimMemRef
Destination.Module.DimMemRef
Source.Module.DimMemRef

Explanation
Possible values for Module.DimMemRef are:
• "ExternalUnit"
• "Resource"
• "Activity"
• "CostObject"

You can use Module.DimMemRef in expressions such as
Module.DimMemRef="CostObject".

Example
Period.2009

Explanation
Quotation marks are not required around the name of the period.

Example
Scenario.Budget

Explanation
Quotation marks are not required around the name of the scenario.

An Example

Let's consider an extended example using the Parcel Express Tutorial. The tutorial model has the following module dimensions:

- Resource
  - Region
  - General Ledger
- Activity
  - Region
  - Activities
- Cost Object
  - Region
  - Channel
  - Products and Services
- External Unit
- Profitability

The dimensions have the following dimension members.
Now let’s consider an assignment, shown in the picture below, from the following source account in the Activity module:

<table>
<thead>
<tr>
<th>Region Dimension Member</th>
<th>Activity Dimension Member, Level 1</th>
<th>Activity Dimension Member, Level 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton</td>
<td>Personnel Intensive Activities</td>
<td>Expedite Package Shipments</td>
</tr>
</tbody>
</table>

...to the following destination account in the Cost Object module:

<table>
<thead>
<tr>
<th>Region Dimension Member</th>
<th>Channel Dimension Member</th>
<th>Products and Services Dimension Member</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton</td>
<td>None</td>
<td>2nd Day Guaranteed</td>
</tr>
</tbody>
</table>

Now let’s assume that the destination account is the context account for this example. As the picture below shows, the following expressions that might appear in a formula have the value shown in the following table:

<table>
<thead>
<tr>
<th>Formula Expression</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Destination.Region.DimMemRef</td>
<td>Beaverton</td>
</tr>
<tr>
<td>Destination.Prod_Serv.DimMemRef</td>
<td>2nd Day Guaranteed</td>
</tr>
<tr>
<td>Formula Expression</td>
<td>Value</td>
</tr>
<tr>
<td>------------------------------------------</td>
<td>------------------------------</td>
</tr>
<tr>
<td>Destination.Chnnl.DimMemRef</td>
<td>None</td>
</tr>
<tr>
<td>Source.Region.DimMemRef</td>
<td>Beaverton</td>
</tr>
<tr>
<td>Source.Act.DimMemRef</td>
<td>Expedite Package Shipments</td>
</tr>
</tbody>
</table>

**Note:** It is very important to note that you refer to a null intersection with the constant None. The destination account is the intersection of the following dimension members:

<table>
<thead>
<tr>
<th>Region Dimension Member</th>
<th>Channel Dimension Member</th>
<th>Products and Services Dimension Member</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton</td>
<td>None</td>
<td>2nd Day Guaranteed</td>
</tr>
</tbody>
</table>

Even though the column for the intersection name shows No <Channel> for display purposes, you should use the internal name None in your formulas.

**CAUTION!**

Because “None” is localizable, you must use the value of “None” for your locale. Following is a list of possible values according to locale:

- German: Kein
- English: None
- Spanish: Ninguno
- French: Néant
- Italian: Nessuno
- Japanese: なし
- Korean: None
- Dutch: Geen
- Portuguese (Brazil): Nenhum
- Chinese Simplified: 元
- Chinese Traditional (Hong Kong SAR): 無
- Chinese Traditional (Taiwan): 無

**Note:** Instead of using a localizable constant, you can use the IsNone() function, which will work in any locale. See “IsNone function” on page 455.
Enhanced Formula Capabilities

Overview

Significant new capabilities have been added to SAS Cost and Profitability Management for creating the formula (rule formula) of a rule-based driver. You can use these same enhanced capabilities to create the driver formula for a calculated driver or the formula for a calculated attribute. These enhanced capabilities include:

New Features

- String support
  - String (text) values are fully supported inside formulas, including the string values of text attributes.
  - You can use the following string properties of an account in any formula: Reference, Name, and DriverName.
  - You can use the following string properties of an account’s intersection dimension members in any formula: Reference (or DimMemRef), Name (or DimMemName), Level, and LevelNumber.
- Access to properties
  - You can access the properties of an account’s intersection dimension members as well as the properties of attribute dimension members.
  - You can reference the system-defined dimensions Period, Scenario, and Module in any formula.
- Functionality for calculated drivers
- The driver formulas for Calculated Drivers can access cost and revenue properties on accounts.

  *Note:* If cost properties are used, you should use driver sequencing or the cost properties will be zero.

### New Functions

#### Boolean

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HasAttribute(s)</td>
<td>Determines if an attribute is associated with an account</td>
</tr>
<tr>
<td></td>
<td><em>Note:</em> You can use the new HasAttribute() function with Tag (Boolean) attributes as well as with Text and Numeric attributes.</td>
</tr>
<tr>
<td>IsChildOf(s)</td>
<td>Determines if a dimension member is a child of (self, immediate child, or descendent) of a given dimension member</td>
</tr>
<tr>
<td>Match(s1,&quot;s2&quot;)</td>
<td>Determines if string s1 matches a wildcard pattern s2.</td>
</tr>
<tr>
<td>isClose(n1,n2,digits)</td>
<td>Determines if two numbers are close, to accommodate floating point round-off issues</td>
</tr>
</tbody>
</table>

#### String

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left(s,n)</td>
<td>Returns the leftmost characters of a string</td>
</tr>
<tr>
<td>Mid(s,pos,len)</td>
<td>Returns a substring of a source string</td>
</tr>
<tr>
<td>Right(s,len)</td>
<td>Returns the rightmost characters of a string</td>
</tr>
<tr>
<td>Str(s,size,dec)</td>
<td>Converts a number to a string</td>
</tr>
<tr>
<td>Trim(s)</td>
<td>Trims leading and trailing spaces</td>
</tr>
</tbody>
</table>

#### Numeric

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Find(s1,s2)</td>
<td>Returns the position of string s1 within string s2.</td>
</tr>
<tr>
<td>Len(s)</td>
<td>Returns the length of a string</td>
</tr>
</tbody>
</table>
For a full list of functions, see Functions.

**Changed Functionality**

Expressions with Null values evaluate to false in comparison (\(<\), \(\leq\), \(=\), \(\geq\), \(>\), \(<\)) and Null for all other operators. Note that "Null=Null" is false so the IsNull() function should be used when it is important to determine whether a value (or expression) is Null or not. Null values occur when:

- an attribute is not attached to any account and does not have a default value
- for some properties such as TDQUE and OutputQuantityUE.

**Limitations**

1. Default values and formulas are not supported for Text attributes.
2. The following properties are not valid for use in the formula of a calculated driver and, therefore, do not appear in the Formula Builder drop-down list:
   - DriverQuantityBasic
   - IdleDriverQuantity

The reason is that in an assignment these quantities depend on DrvQtyCalc. Consequently, a vicious circle would be created if the formula were to make DrvQtyCalc depend on these quantities. That is, DrvQtyCalc could not be determined without first determining these quantities, and these quantities could not be determined without first determining DrvQtyCalc.

---

**Using Numeric Attributes in a Formula**

**Overview**

You can use both calculated numeric attributes and ordinary numeric attributes in a formula. All that you need to do is to refer to the attribute by its reference just as you would any property.

*Note:* If an attribute reference contains spaces or special characters, then you must enclose it in quotation marks.

**Using a Calculated Numeric Attribute**

In order to use a calculated attribute in a formula it is not necessary to attach the attribute to an account. It is sufficient that you refer to the attribute for the attribute's formula to be evaluated during calculation. This allows you to use calculated attributes to define common sub-expressions that are used by other formulas. This avoids cut-and-paste errors and allows for quick revisions without having to update multiple formulas. It also allows for the reusability of calculated attributes to define sub-expressions that can be reused by different drivers.

*Example*
Suppose you have the following three calculated drivers each with its driver formula as shown in the following table:

<table>
<thead>
<tr>
<th>Calculated Driver</th>
<th>Driver Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drvr1</td>
<td>((A / B) * (B / C))</td>
</tr>
<tr>
<td>Drvr2</td>
<td>((A / B) * 2)</td>
</tr>
<tr>
<td>Drvr3</td>
<td>((B / C) * 3)</td>
</tr>
</tbody>
</table>

Now, suppose you define the following calculated numeric attributes:

<table>
<thead>
<tr>
<th>Calculated Attribute</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rate1</td>
<td>((A / B))</td>
</tr>
<tr>
<td>Rate2</td>
<td>((B / C))</td>
</tr>
</tbody>
</table>

then you can modify the driver formula for each of the three calculated drivers to use a calculated attribute as shown in the following table:

<table>
<thead>
<tr>
<th>Calculated Driver</th>
<th>Driver Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drvr1</td>
<td>(\text{Rate1} * \text{Rate2})</td>
</tr>
<tr>
<td>Drvr2</td>
<td>(\text{Rate1} * 2)</td>
</tr>
<tr>
<td>Drvr3</td>
<td>(\text{Rate2} * 3)</td>
</tr>
</tbody>
</table>

**Note:** The cascading evaluation of attribute formulas is fully supported. For example, suppose calculated attribute CA1 uses calculated attribute CA2, which in turn uses calculated attribute CA3, etc. There is no restriction on the depth of references, but it will be more difficult to troubleshoot with increasing depth. However, cyclic reference is not supported. For example, CA1 CA2 CA3 CA1 is a cyclic reference (back to C1) and an error is returned when cyclic reference is encountered.

Of course, whenever a calculated attribute is attached to an account its calculated value is written to the model by the calculation. Even for sub-expression use, where you wouldnt normally attach the calculated attribute to an account, it can still be useful to attach it to one account when debugging complex formulas. When it is working you can then remove it from the account.

**Using a Calculated Attribute in the Driver Formula of a Calculated Driver**

In the driver formula for a calculated driver you can use only properties that represent a quantity. Consequently, if such a formula contains a calculated attribute, then that calculated attribute should also use only properties that represent a quantity.
**Determining the Value of a Numeric Attribute**

During calculation, when the system encounters a numeric attribute in a formula it uses the following rules of precedence for determining the attribute value. As soon as the system is able to determine the attribute value according to a rule it uses that value as the final calculation and does not consult any subsequent rule.

1. If it is a calculated attribute, then evaluate its formula and use the resulting value.
2. If the attribute is attached to the account, use the value of the attribute for that account.
3. If the attribute has a default value for the current period/scenario, then use the default value.
4. Use null as the attribute value.

---

**Troubleshooting Formulas**

**Using Cost in a Formula**

This section explains why using cost properties in a formula (driver formula for a calculated driver, rule formula for a rule-based driver, or formula for a calculated attribute) can make it difficult to troubleshoot problems, describes some troubleshooting techniques, and provides guidelines for their use.

Whenever cost is used to determine flow, driver sequencing is required. When you use Cost in a formula, the actual value used comes from the previous sequence. So if a driver uses sequence 3, then it takes Cost from the destination account after sequence 2 is evaluated. In the case where there is a single Cost property, the value is written to DQCalc and it is easy to determine what the value that was used.

More complicated formulas become more difficult. For instance, using a formula of "Cost / NumCalls" means that you would have to multiply DQCalc * NumCalls to determine the value of Cost that was evaluated in sequence 2 and used in sequence 3.

An even more complicated situation is where the formula uses a calculated attribute that in turn uses Cost. A common way to troubleshoot a calculated attribute is to attach it to an account, calculate through the sequence in question, and look at its value. This works well, but when Cost (or any cost property) is used in the attribute formula, a final evaluation is made before it is committed to the database to ensure that it uses the proper cost value. To see how this is significant you must understand how calculation orders its work:

```
Sequence Loop
  1. Clear calculated attribute values
  2. Create rule-based assignments (using rule formulas)
  3. Consumption (eval DQCalc, using driver formulas)
  4. Cost flow
End Loop
Clear calculated attribute values
Eval calculated attributes
```

In the steps above, calculated attributes can get evaluated during **2. Create rule-based assignments** as a result of evaluating rule formulas and during **3**.
Consumption as a result of evaluating driver formulas. Notice that this occurs before 4. Cost flow. Numeric attributes need a final evaluation so that any use of cost properties is in sync with the final cost values. So the cost values used in calculated attributes could be different from those used by rule formulas or driver formulas. This could easily cause confusion when troubleshooting the actual values used. To find out what values are used, stop calculation on the sequence step before they are actually used by a rule formula or driver formula to see what their value is.

To avoid confusion consider the following guidelines

1. If all you need is to use a cost property for DQF or DQV, then use FixedDQOverride or VariableDQOverride respectively. This keeps it simple.

2. If you need a more complicated driver formula or rule formula that uses cost properties, avoid using calculated attributes that have cost properties in their formulas (directly or indirectly).

3. If you must use cost properties in the formula for a calculated attribute, keep their use to a minimum.

Troubleshooting String Expressions

A typical way to troubleshoot formulas is to put the formula in a calculated numeric attribute and attach the attribute to an account. This works as long as the formula has a numeric result. But for string expressions this is not an option because calculated text attributes do not exist in SAS Cost and Profitability Management. So, how can you troubleshoot string expressions when you aren’t getting the results you want?

A technique is to use the if(condition,then,else) function in a numeric formula, as in the following example:

$$\text{If( } \text{Attr1 } & \text{ Attr2 } = \text{ "ABCD"}, \text{ 1, 0 })$$

This concatenates two attributes to see if they are a specific value and if they are returns a value of 1, and 0 if they aren't.

You aren't limited to concatenation—you can use any string expression and compare its results to something. For instance, you could use something like the following:

$$\text{If( HasAttribute(Attr2) and len(Attr2) > 2, 1, 0) }$$

Operator Precedence

The following table shows the priority given to operators when the system evaluates a formula. Priority goes from top to bottom of the table, and from left to right in a given row.

So, for example, NOT x+y is evaluated as (NOT x)+y rather than NOT(x+ y) because NOT takes priority over +.

And, for example, x*y/z is evaluated as (x*y)/z rather than x*(y/z) because multiplication takes priority over division.

Note: It is a good idea to use parentheses. Notice that parentheses have the highest priority and, thus, remove all ambiguity in a formula.
<table>
<thead>
<tr>
<th>Priority</th>
<th>Operator</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>(x)</td>
<td>parentheses</td>
</tr>
<tr>
<td>2</td>
<td>x**y</td>
<td>exponent</td>
</tr>
<tr>
<td>3</td>
<td>NOT x</td>
<td>unary boolean operator</td>
</tr>
<tr>
<td>4</td>
<td>+x, -x</td>
<td>unary numeric operators (positive, negative)</td>
</tr>
<tr>
<td>5</td>
<td>x*y, x/y, x%y</td>
<td>binary numeric operators: multiply, divide, percent</td>
</tr>
<tr>
<td>6</td>
<td>x+y, x-y, x&amp;y;</td>
<td>binary operators: plus, minus, string concatenation</td>
</tr>
<tr>
<td>7</td>
<td>x&lt;y, x&lt;=y, x&gt;=y, x&gt;y</td>
<td>numeric or string comparison</td>
</tr>
<tr>
<td>8</td>
<td>x=y, x&lt;&gt;y</td>
<td>numeric or string comparison</td>
</tr>
<tr>
<td>9</td>
<td>x AND y</td>
<td>boolean AND</td>
</tr>
<tr>
<td>10</td>
<td>x OR y</td>
<td>boolean OR</td>
</tr>
</tbody>
</table>

**Formula Builder Dialog Box**

**Overview**

In the Formula Builder dialog box, you can create a formula for a:

- calculated driver (See Chapter 44, “Calculated Driver,” on page 367.)
- rule-based driver (See “Make Assignments Using a Rule” on page 410.)
- calculated attribute (See “Calculated Attributes” on page 248.)
Note: Every formula is evaluated in a context. (See “Formula Context” on page 433.)

**How to Access the Formula Builder Dialog Box**

To create a formula for a calculated driver
In the New Driver dialog box, click **Formula Builder**.

To create a formula for a rule-based driver
In the New Driver dialog box, select **Use Rule Formula** and click **Formula Builder**.

To create a calculated attribute
In the New Attribute dialog box, click **Formula Builder**.

**Context**

Use the keywords Source or Destination to specify whether a property or attribute applies to a source or destination account. For example, Source.Cost or Destination.UnitCost.

Note: By default in the formula for a calculated driver, properties and attributes refer to destination accounts.

Note: By default in the formula for a rule-based driver, properties and attributes refer to destination accounts.
Operators and Functions

For functions, see:

- Chapter 52, “Boolean Functions,” on page 449
- Chapter 53, “Numeric Functions,” on page 459
- Chapter 54, “String Functions,” on page 465

Analysis

This tab contains a list of system-defined properties and user-defined attributes.

To ensure that SAS Cost and Profitability Management correctly interprets any special characters or spaces in a numeric attribute name, enclose the name in double quotation marks (" "). You do not need to use quotation marks for names of numeric properties.

For example, in the following formula, OutputQuantity does not require quotation marks because it is a system-defined numeric property. But, Units Per Pallet requires quotation marks because that name contains spaces.

\[ \text{OutputQuantity}/"\text{Units Per Pallet}" \]

Note: The names of the properties shown in the Formula Builder dialog box are different from the names of the properties in other parts of the interface. See: About Property names in formulas.

Dimensions

This tab contains a list of dimensions, dimension members, and dimension attributes.
Define a formula

1. Select an item from the available components.
2. Click **Insert**.
   
   The item is added to the formula.

   **Tip** You can also type the formula.
3. Continue to insert items until you have built the formula.

   **Note:** The formula can be at most 16383 characters long.
4. To remove the last item that you inserted, click **Undo**.
5. To delete the entire formula, click **Clear**.
6. (Optional) Click **Test**.

   If no errors are displayed, the syntax of the formula is valid.
A Boolean function, named after the English logician/mathematician George Boole, returns either a TRUE or a FALSE.

Note: Null values are considered to be false when evaluating a formula for a rule-based driver.

The following are Boolean functions:
- HasAttribute
- if
- Intersection.Match
- IsChildOf
- IsClose
- IsNone
- IsNull
- Match
HasAttribute function

Returns true if an account has an attribute attached to it for the attribute reference passed, and false otherwise. You can use the new HasAttribute() function with Tag (Boolean) attributes as well as with Text and Numeric attributes.

Syntax

```
HasAttribute( string )
```

where string is an attribute reference.

Examples

```
HasAttribute( "Quality" )
Destination.HasAttribute( "Quality" )
Source.HasAttribute( "Quality" )
```

Further explanation

If an attribute association does not exist but the attribute has a default value, false is returned. This works only for the numeric, text and tag value attributes—not for dimension attributes.

This function must be evaluated in the context of an account. Appropriate "Source." or "Destination." prefixes may be needed to select the correct account.

Note: When used in the assignment rule for a rule-based driver, the attribute is assumed to refer to the destination account unless Source is specified.

if function

The if function returns one value if a test evaluates to TRUE and a different value if the test evaluates to FALSE.

Syntax

```
if( test , true_value , false_value )
```

where:

- test is a value or expression that evaluates to TRUE or FALSE.
- true_value is the value that is returned when test is TRUE.
- false_value is the value that is returned when test is FALSE.

Examples

```
if( not IsNull( SoldQuantity ), SoldQuantity, OutputQuantity )
```

Intersection.Match function

The Intersection.Match function returns TRUE if for each dimension listed:

- the source account and destination account contain the same dimension member
- or, the source account contains the No-dimension member for that dimension.
Use the `Intersection.Match` function in a rule formula to identify the destination accounts of a rule-based driver. See “Make Assignments Using a Rule” on page 410.

**Syntax**
```plaintext
Intersection.Match( dim-ref1[.dim-member-ref1][, dim-ref2[.dim-member-ref2]]* )
```

**Examples**

**Intersection.Match(Product, Customer)**
This example is equivalent to:
```plaintext
(Source."Product".isNone() 
 OR Source."Product".DimMemRef=Destination."Product".DimMemRef) 
AND 
(Source."Customer".isNone() 
 OR Source."Customer".DimMemRef=Destination."Customer".DimMemRef)
```
This example ensures that the dimension members of the Product and Customer dimensions are the same in both source and destination accounts.

*Note:* The No-dimension account, "None", acts like a wild-card. It matches every destination account.

**Intersection.Match(Product, Customer, Channel)**
This example is equivalent to:
```plaintext
(Source."Product".isNone() 
 OR Source."Product".DimMemRef=Destination."Product".DimMemRef) 
AND 
(Source."Customer".isNone() 
 OR Source."Customer".DimMemRef=Destination."Customer".DimMemRef) 
AND 
(Source."Channel".isNone() 
 OR Source."Channel".DimMemRef=Destination."Channel".DimMemRef)
```
This example ensures that the dimension members of the Product, Customer, and Channel dimensions are the same in both source and destination accounts.

*Note:* The No-dimension account, "None", acts like a wild-card. It matches every destination account.

**Intersection.Match(Module.CostObject, Product, Customer)**
This example is equivalent to:
```plaintext
Destination."Module".DimMemRef="CostObject" 
AND 
(Source."Product".isNone() 
 OR Source."Product".DimMemRef=Destination."Product".DimMemRef) 
AND 
(Source."Customer".isNone() ) 
```
This example ensures that destination accounts are in the CostObject module. It also ensures that the dimension members of the Product and Customer dimensions are the same in both source and destination accounts.

*Note:* If there is a specific dimension-member-reference present (for example, Module.CostObject) then the condition applies only to destination accounts.

*Note:* Module is a system-defined dimension. CostObject is a dimension member.

*Note:* The No-dimension account, "None", acts like a wild-card. It matches every destination account.
**Intersection.Match(Product.Frisbee)**

This example is equivalent to:

```
Source."Product".isNone()
OR
Source."Product".DimMemRef=Destination."Product".DimMemRef
```

This example ensures that the destination account has dimension member named "Frisbee" in the Product dimension.

*Note:* If there is a specific dimension-member-reference present (for example, Product.Frisbee) then the condition applies only to destination accounts.

*Note:* The No-dimension account, "None", acts like a wild-card. It matches every destination account.


This example is equivalent to:

```
Destination."Module".DimMemRef="CostObject"
AND
Destination."Product".DimMemRef="Frisbee"
AND
(Source."Customer".isNone()
OR
Source."Customer".DimMemRef=Destination."Customer".DimMemRef)
```

This example ensures that destination accounts are in the CostObject module. It also ensures that the destination account has dimension member named "Frisbee" in the Product dimension. And, it ensures that the dimension members of the Customer dimension are the same in both source and destination accounts.

*Note:* If there is a specific dimension-member-reference present (for example, Module.CostObject and Product.Frisbee) then the condition applies only to destination accounts.

*Note:* Module is a system-defined dimension. CostObject is a dimension member.

*Note:* The No-dimension account, "None", acts like a wild-card. It matches every destination account.

**Notes:**

- The dimension-references can refer to either structural dimensions or attribute dimensions.
- It is not required that all the defining dimensions of an account be included in MatchIntersection for it to test true.
- You can use system-defined dimensions, including Module, Period, Scenario and Driver.
- The dimensions can be in any order. For example, Intersection.Match(Product, Customer) and Intersection.Match(Customer, Product) give the same results.
- You can not use Intersection.Match in the formula of a calculated attribute. You can use it in a driver formula; however, as a Boolean function, it is unlikely to be useful there.

You can use the Intersection.Match function to accomplish what the Sales Volume driver accomplished in previous versions of SAS Cost and Profitability Management. See Chapter 52, “Boolean Functions,” on page 449.
For example, suppose there is a model with two dimensions, Product and Customer, in the Cost Object module. The rule formula that was used for a Sales Volume driver was the following:

\[
\begin{align*}
\text{AND} & \quad \text{(Source.Product.dimMemRef="None" OR Source.Product.DimMemRef=Destination.Product.DimMemRef)} \\
\text{AND} & \quad \text{(Source.Customer.dimMemRef="None" OR Source.Customer.DimMemRef=Destination.Customer.DimMemRef)} \\
\text{AND} & \quad \text{SoldQuantity <> 0}
\end{align*}
\]

You can replace the entire formula above with the following equivalent formula using \text{Intersection.Match}

\[
\text{Intersection.Match(Product, Customer) and SoldQuantity<>0}
\]

This will match intersections in the following way

- \([\text{Bike,None}]\) matches \([\text{Bike,Target}]\) and \([\text{Bike,WalMart}]\)
- \([\text{None,Target}]\) matches \([\text{Bike,Target}]\) and \([\text{Shirt,Target}]\)

You can think of “None” as a type of wildcard. When an account is “matched” by the rule formula an assignment is created, such as \([\text{Bike,None}] \rightarrow [\text{Bike,Target}]\) and \([\text{Bike,None}] \rightarrow [\text{Bike,WalMart}]\). In ABM 7.2 the accounts are often in the same module but starting from 8.1 the non-None accounts (e.g. \([\text{Bike,Target}]\)) may be in a different module. In other words, a match will be made in the current or later modules and takes advantage of the new ModuleOrder property to define the order.

While it isn’t shown, \([\text{Bike,Target}]\) matches \([\text{Bike,Target}]\) as long as the account is in a different module, preventing a meaningless cycle-to-self.

Notice that Module is treated as a dimension and CostObj is just a member of the dimension. This can also be extended to any dimension so the user can force it to match a specific member on the destination account. For instance you could do the following:

\[
\text{Intersection.Match(Module.CostObj, Product.Ugly, Customer) and SoldQuantity<>0}
\]

This replaces the condition

\[
\text{(Source.Product.isNone() OR (Source.Product.DimMemRef=Destination.Product.DimMemRef))}
\]

with

\[
\text{(Destination.Product.DimMemRef="Ugly").}
\]

The source account’s Product is not used in this case.

### isChildOf function

Returns true if the dimension member is a child of (self, immediate child, or descendent) of a given dimension.

**Syntax**

\[
dimension.reference.isChildOf(dim-member-reference)
\]

**Examples**

- `Customer.isChildOf(Retail)`
- `Source.Dept.isChildOf(Sales)`
- `Source.Dept.isChildOf( "Sales" & "and Marketing" )`
- `Product.isChildOf(Source.Chnnl.Reference)`
Note: The dim-member-reference does not have to be the immediate child of the dimension.reference. For example, suppose you have the following hierarchy:

Products
  Wholesale
    ProductLineA
      Product1
      Product2
    ProductLineB
      Product3
      Product4
  Retail
    ProductLineC
      Product5
      Product6
    ProductLineD
      Product5
      Product6

In this case, the formula `Products.IsChildOf(ProductLineB)` tests true for Product3 and Product4.

Further explanation
If the account's intersection dimension member reference matches the string passed, true is returned. For instance, if the intersection has member Region.Raleigh and the formula has "Region.IsChildOf(Raleigh)" then a true is returned. IsChildOf() must evaluate in the context of a dimension member. To accomplish that, use compound references as shown in the examples to select a dimension member on an account's intersection. If an integer is passed then it is taken as-is without converting it to a number. This special case allows for syntax such as Period.2009 instead of requiring Period."2009".

Note: When used in the assignment rule for a rule-based driver, the member-reference is assumed to refer to the destination account unless Source is specified.

IsClose function

Returns true or false depending on whether the leading significant digits match.

Syntax

\[
\text{IsClose}( \text{number1}, \text{number2} [, \text{digits}] )
\]

Examples

\[
\begin{align*}
\text{IsClose}(0, 0) & \rightarrow \text{true} \\
\text{IsClose}(0, 1e-4) & \rightarrow \text{false} \\
\text{IsClose}(0, 1e-9) & \rightarrow \text{true} \\
\text{IsClose}(0, 1e-4, 3) & \rightarrow \text{true} \\
\text{IsClose}(123.4567, 123.4568, 6) & \rightarrow \text{true} \\
\text{IsClose}(0.00001234567, 0.00001234568, 6) & \rightarrow \text{true} \\
\text{IsClose}(1.234567e-5, 1.234568e-5, 6) & \rightarrow \text{true} \text{ (same as previous example)} \\
\text{IsClose}(1, 1.00000001) & \rightarrow \text{false} \\
\text{IsClose}(1, 1.000000001) & \rightarrow \text{true} \\
\text{IsClose}(1, 0.999999999) & \rightarrow \text{true}
\end{align*}
\]
**IsNone function**

Returns true or false depending on whether an account is a No-dimension account.

A No-dimension account is one in which one or more of the dimension members in its dimension signature is None. For example, Beaverton x None x Overnight Express. None indicates that there is no dimension member from a particular dimension in the dimension signature.

You can create a No-dimension account with the New Account dialog by selecting No `<dimension-member>`, as the following picture shows:

![New Account - Create Accounts at Dimension Intersections](image)

The following picture shows a number of No-dimension accounts:
Syntax

\[
\text{dimension-ref}.\text{IsNone}()
\]

Examples

"Product".IsNone()

"Channel".IsNone()

### IsNull function

Returns true or false depending on whether the leading significant digits match.

Syntax

\[
\text{IsNull( expression )}
\]

Examples

IsNull(SoldQuantity)

### Further explanation

Null values are considered to be false when evaluating a formula for a rule-based driver.

### Match function

Returns true when a string matches a given pattern. All comparisons are case insensitive.

Syntax

\[
\text{Match( string, "pattern" )}
\]

Examples

Match( Product.Reference, "*or*" ) matches or, ord, facilitator, but not asteroid

Match( Product.DimMemRef, "abc*" ) matches abc, abcd, but not asteroid, a, ab or bc

Match( Product.Reference, "xyz" ) matches xyz, wxyz, but not asteroid, x, y, z, or yz

Match( Product.DimMemRef, "billion" ) matches billion, abillion, but not billions

Match( Product.Reference, "??DEF" ) matches abcDEF, ABCDEF, but not DEF, aDEF, abDEF

Match( Product.DimMemRef, "\*bike\*" ) matches *bike*, *Bike*, but not *bikes*
Further explanation

Special characters:

* matches zero or more characters

? matches any single character

\ used as an escape character to allow matching a literal '*, '?, or '\' in the string. The escape character says that the immediately following character in the pattern (*, ?, or \) is being used as itself and not as a special character. So, for example, Match(Product, Name\?) matches Name? and does not match either Name or Names

Note: When used in the assignment rule for a rule-based driver, properties are assumed to refer to the destination account unless Source is specified.
Chapter 53
Numeric Functions

abs function

The abs function returns the absolute value of a number.

Syntax

abs(x)

where x is the number.

degrees function

The degrees function converts radians into degrees.

Syntax

degrees(x)
where \( x \) is the radians.

**Examples**

\[ \text{degrees}(1.57079633) = 90 \]

---

**exp function**

The exp function returns \( e \) raised to the power of the number. The constant \( e \) equals 2.71828182845904, the base of the natural logarithm.

**Syntax**

\[ \exp(x) \]

where \( x \) is the number.

**Examples**

\[ \exp(2) = 7.389056099 \]

---

**max function**

The max function returns the larger number of two numbers, or the greater of two strings.

*Note:* One string is greater than another if it comes after the other in UTF-16 sorting sequence (more simply stated, if it comes later in alphabetical order).

**Syntax**

\[ \text{max}(x, y) \]

where \( x \) and \( y \) are two numbers or two strings.

---

**min function**

The min function returns the smaller number of two numbers, or the smaller of two strings.

**Syntax**

\[ \text{min}(x, y) \]

where \( x \) and \( y \) are two numbers or two strings.

---

**pi function**

The pi function returns the number 3.14159265358979, the mathematical constant \( \pi \), and is accurate to 15 digits.

**Syntax**

\[ \pi() \]
There are no parameters.

**Examples**

\[ \pi( ) = 3.14159265358979 \]

---

**power function**

The power function returns the result of a number raised to a power.

**Syntax**

\[ \text{power}(x, y) \]

- \( x \) raised to the power of \( y \)

**Examples**

\[ \text{power}(3, 2) = 9 \]

---

**quotient function**

The quotient function returns the integer portion of a division. Use this function when you want to discard the remainder of a division.

**Syntax**

\[ \text{quotient}(x, y) \]

**Examples**

\[ \text{quotient}(17, 3) = 5 \]

---

**radians function**

The radians function converts degrees to radians.

**Syntax**

\[ \text{radians}(x) \]

- \( x \) is the degrees.

**Examples**

\[ \text{radians}(90) = 1.57079633 \]

---

**round function**

The round function returns a number that has been rounded to a specified number of decimal places.

**Syntax**

\[ \text{round}(x, y) \]

- \( x \) is the number.
\( y \) is the number of decimal places. \( y \) can be any of the following:

<table>
<thead>
<tr>
<th>Greater than zero</th>
<th>( x ) is rounded to the specified number of decimal places.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zero</td>
<td>( x ) is rounded to the nearest integer.</td>
</tr>
<tr>
<td>Less than zero</td>
<td>( x ) is rounded to the left of the decimal point.</td>
</tr>
</tbody>
</table>

**sign function**

The sign function returns a number that indicates the sign of a number.

**Syntax**

\[
\text{sign} (x)
\]

\( x \) is the number.

**Return values**

<table>
<thead>
<tr>
<th>1</th>
<th>indicates that the number is positive.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zero</td>
<td>indicates that the number is zero.</td>
</tr>
<tr>
<td>-1</td>
<td>indicates that the number is negative.</td>
</tr>
</tbody>
</table>

**sqrt function**

The sqrt function returns the positive square root of a number.

**Syntax**

\[
\text{sqrt} (x)
\]

\( x \) is the positive number. A negative number produces an error message.

**trunc function**

The trunc function truncates a number to an integer by removing the fractional part of the number.

**Syntax**

\[
\text{trunc} (x)
\]

\( x \) is the number to truncate.
Examples
\[ \text{trunc}(5.46) = 5 \]
& function (string concatenation) ............................. 465
find function ....................................................... 465
left function ....................................................... 466
len function ......................................................... 466
mid function ......................................................... 466
right function ....................................................... 467
str function ......................................................... 467
trim function ......................................................... 467
value function ....................................................... 467

& function (string concatenation)

Returns the concatenation of two strings.

Syntax

```sql
string & string
```

Examples

```
"Las Vegas" & "," & "Nevada"
Product.DimMemRef & " & "& Source.DimMemRef
```

find function

Returns the position of `find_string` in `within_string`, starting at `pos` (`pos` starts at 1).

Syntax

```sql
find( find_string, within_string, pos )
```

Examples

```
find(Source.DimMemRef, "x")
```

Further explanation

If `find_string` isn’t found in `within_string`, a Null is returned.
If \( pos \) is less than 1 or larger than the length of \( within\_string \), a Null is returned.

If \( find\_string \) is an empty string, then 1 is returned.

All comparisons are case sensitive.

**Note:** Null values are considered to be false when evaluating a formula for a rule-based driver.

---

**left function**

Returns a string with the leftmost length characters of string.

**Syntax**

\[
\text{left}( \text{string, length} )
\]

**Examples**

\[
\text{left(Source.Name, 5)}
\]

\[
\text{left(Source.Name, find(Source.Name, " and")-1)}
\]

**Further explanation**

If \( length \) is greater than the length of \( string \), then \( string \) is returned.

---

**len function**

Returns the number of characters in a string.

**Syntax**

\[
\text{len}( \text{string} )
\]

**Examples**

\[
\text{len(Source.Channel.Reference)}
\]

---

**mid function**

Returns a substring starting at \( pos \) with a length of \( length \) (\( pos \) starts at 1).

**Syntax**

\[
\text{mid}( \text{string, pos [, length]} )
\]

**Examples**

\[
\text{mid(Source.Channel.Reference,1)}
\]

\[
\text{mid(Channel.Reference, find(Channel.Reference, " and"), len(Channel.Reference)-find(Channel.Reference)-1)}
\]

**Further explanation**

If \( length \) is not included then all characters starting from \( pos \) to the end of the string are returned.
right function

Returns a string with the rightmost length characters of string.

Syntax

```plaintext
right( string, length )
```

Examples

```plaintext
right(Source.Channel.Reference,3)
right(Channel.Reference, find(Channel.Reference, " and"),
    len(Channel.Reference)-find(Channel.Reference)-1)
```

Further explanation

If `length` is greater than the length of `string`, then `string` is returned.

str function

Converts a number to a string.

Syntax

```plaintext
str( number [, size [, dec]] )
```

Examples

```plaintext
str(Destination.Cost)
str(len(Source.IdleQuantity))
```

Further explanation

The default parameter values are `size=16` (includes the decimal point when `dec > 0`) and `dec=6` for the number of digits past the decimal. If `size` is passed but `dec` is not, then `dec` defaults to a value of zero instead. If the `number` is larger than the `size` passed then more space will be created for it, so the string returned may be longer than the `size` passed. Passing a size of "1" removes all leading spaces from the number.

trim function

Returns the string with all spaces removed except for single spaces between words.

Syntax

```plaintext
trim( string )
```

Examples

```plaintext
trim(Destination.Name)
```

value function

Converts a string to a number.
Syntax

value( string )

Examples

value(Destination.DimLevel)

Further explanation

If a non-numeric character is encountered the conversion stops. An empty string evaluates to zero.
# Properties That Can Be in Formulas

The following table identifies all the properties that can be used in formulas. The Assignment column applies to assigned, internal and external cost elements.

<table>
<thead>
<tr>
<th>Property</th>
<th>Type</th>
<th>Account</th>
<th>Assignment</th>
<th>Dim Member</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>[Value Attributes]</td>
<td>Num or Char</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td>Text and Tag attributes can be used in addition to numeric attributes.</td>
</tr>
<tr>
<td>AllocatedCost</td>
<td>Num</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AssignedCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>AssignedIdleCost</td>
<td>Num</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AssignedIdleQuantity</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td>Valid property for assignment, but not accessible from formula because of circular reference.</td>
</tr>
<tr>
<td>AssignedNonReciprocalCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>AssignedReciprocalCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td>Num</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DimLevelName</td>
<td>Char</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DimLevelNumber</td>
<td>Num</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DimMemberName</td>
<td>Char</td>
<td></td>
<td>✓</td>
<td></td>
<td>Synonym of Name for Dim Member in an intersection</td>
</tr>
<tr>
<td>DimMemberRef</td>
<td>Char</td>
<td></td>
<td>✓</td>
<td></td>
<td>Synonym of Reference for Dim Member in an intersection</td>
</tr>
<tr>
<td>Property</td>
<td>Type</td>
<td>Accessible</td>
<td>Available in formula</td>
<td></td>
<td></td>
</tr>
<tr>
<td>--------------------------</td>
<td>------</td>
<td>------------</td>
<td>---------------------</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DrivableCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DrivenCost</td>
<td>Num</td>
<td>✓ ✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DrivenQuantity</td>
<td>Num</td>
<td>✓</td>
<td>Valid property for assignment, but not accessible from formula because of circular reference.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DriverName</td>
<td>Char</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DriverQuantityCalculated</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DriverQuantityFixed</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DriverQuantityVariable</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DriverRate</td>
<td>Num</td>
<td>✓ ✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DriverWeightFixed</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DriverWeightVariable</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>EnteredCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>IdleCost</td>
<td>Num</td>
<td>✓ ✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>IdleDriverQuantityUE</td>
<td>Num</td>
<td>✓</td>
<td>Was &quot;IdleDriverQuantity_UE&quot; in 6.4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>IdleQuantity</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Char</td>
<td>✓ ✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>OutputQuantity</td>
<td>Num</td>
<td>✓</td>
<td>Unavailable as Source property from assignment</td>
<td></td>
<td></td>
</tr>
<tr>
<td>OutputQuantityUE</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Profit</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReceivedAllocatedCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReceivedCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReceivedDrivenCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReceivedNonReciprocalCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReceivedReciprocalCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Reference</td>
<td>Char</td>
<td>✓ ✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Revenue</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SoldCost</td>
<td>Num</td>
<td>✓ ✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SoldQuantity</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Property</td>
<td>Type</td>
<td>Available</td>
<td>Notes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>------------------</td>
<td>------</td>
<td>-----------</td>
<td>--------------------------------------------</td>
<td></td>
<td></td>
</tr>
<tr>
<td>TDQ</td>
<td>Num</td>
<td>✓</td>
<td>Unavailable as Source property from assignment</td>
<td></td>
<td></td>
</tr>
<tr>
<td>TDQC Calculated</td>
<td>Num</td>
<td>✓</td>
<td>Unavailable as Source property from assignment</td>
<td></td>
<td></td>
</tr>
<tr>
<td>TDQUE</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>UnassignedCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>UnitCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>UnitProfit</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>UnitRevenue</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>UsedCost</td>
<td>Num</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>UsedQuantity</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Part 16

Cube Configurations

Chapter 56
What is a Cube Configuration? .......................................................... 475

Chapter 57
Windows for Cube Configurations ................................................... 477

Chapter 58
How To: Cube Configurations ......................................................... 481
Chapter 56
What is a Cube Configuration?

Overview

A cube configuration holds the options that you select for generating cubes and fact tables. After creating a cube configuration, you use it to generate cubes. Creating a cube configuration is preliminary to generating cubes—you don't generate cubes until later.

For information, see “Create a Cube Configuration” on page 481.
Chapter 57
Windows for Cube Configurations

New Cube Configuration

Overview

Use the New Cube Configuration wizard to create a cube configuration that remembers your options for creating a cube and fact table from a particular model.

For information, see “Create a Cube Configuration” on page 481.
How to Access the New Cube Configuration Dialog Box

1. Go to the Workspace Manager.

2. Select File ⇒ New ⇒ Cube Configuration.
   The New Cube Configuration wizard opens.

Metadata Server Options

About Metadata Server Options

Use the Metadata Server Options dialog box to specify a metadata library:

- for use with the SAS LASR Analytic Server.
- for publishing data to use as behaviors with SAS Profitability Management

Note: The settings displayed in the Metadata Server Options dialog box are determined during installation of SAS Cost and Profitability Management. However, you can use the Metadata Server Options dialog box to change these settings after installation.
After specifying a metadata library:

**for the SAS LASR Analytic Server**
- Generate a cube for a model whose cube configuration specifies output for the SAS LASR Analytic Server. See “Cube Configuration: Select a Model and General Options” on page 482. The output of cube generation goes to the metadata library that you have specified here in Metadata Server Options.

- You can export other tables that are registered in a SAS metadata folder that is enabled for the SAS LASR Analysis Server. See Chapter 82, “Export Registered Tables,” on page 659.

For information on creating a metadata library that is enabled for the SAS LASR Analytic Server, see Chapter 15, “Working with SAS LASR Analytic Server,” in *SAS Cost and Profitability Management: Data Administration Guide*.

*Note: A LASR library is displayed for selection only for a user who has Read/Write permission on the library. See “Authorize Users for the LASR-Enabled Metadata Library” in Chapter 15 of *SAS Cost and Profitability Management: Data Administration Guide*.*

**for SAS Profitability Management**
To publish behaviors to SAS Profitability Management, select File ⇔ Publish ⇔ Behaviors. The output goes to the metadata library that you have specified. See “Publish Behaviors to SAS Profitability Management” on page 695.

**How to Access the Metadata Server Options Dialog Box**

Select Tools ⇔ Metadata Server Options.
Chapter 58
How To: Cube Configurations

Create a Cube Configuration

Overview

A cube configuration holds the options that you select for generating cubes and fact tables. After creating a cube configuration, you use it to generate cubes. Creating a cube configuration is preliminary to generating cubes—you don't generate cubes until later.

1. Go to the Workspace Manager or to the Resource, Activity, or Cost Object module for a model.
2. Select File ⇒ New ⇒ Cube Configuration.

   The New Cube Configuration wizard opens.
3. Depending on the type of cube that you want to generate, complete the steps in the following table:

<table>
<thead>
<tr>
<th>Type of Contributions Cube</th>
<th>Steps to Create the Cube Configuration</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single-stage and Resource</td>
<td>• Step 1: “Cube Configuration: Select a Model and General Options” on page 482</td>
</tr>
<tr>
<td></td>
<td>• Step 2: “Cube Configuration: Cube Options” on page 488</td>
</tr>
<tr>
<td></td>
<td>• Step 3: “Cube Configuration: Select Numeric Attributes” on page 491</td>
</tr>
<tr>
<td></td>
<td>• Step 4: “Cube Configuration: Finish” on page 491</td>
</tr>
</tbody>
</table>
### Type of Contributions

<table>
<thead>
<tr>
<th>Cube</th>
<th>Steps to Create the Cube Configuration</th>
</tr>
</thead>
</table>
| Multi-Stage| • Step 1: “Cube Configuration: Select a Model and General Options” on page 482  
                        • Step 2: “Cube Configuration: Cube Options” on page 488  
                        • Step 3: “Cube Configuration: Options for a Multi-Stage Contribution Cube” on page 487  
                        • Step 4: “Cube Configuration: Select Numeric Attributes” on page 491  
                        • Step 5: “Cube Configuration: Finish” on page 491 |

### See Also

“Generate Cubes” on page 547

### Cube Configuration: Select a Model and General Options

In this step of creating a cube configuration you select the model, name the cube configuration, and select other options for cube generation.

#### Select a Model and Name the Cube Configuration

<table>
<thead>
<tr>
<th>New Cube Configuration - Cube and Fact Table</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Cube and Fact Table</strong></td>
</tr>
<tr>
<td>Step 1</td>
</tr>
<tr>
<td>Model name</td>
</tr>
<tr>
<td>Cube configuration name</td>
</tr>
<tr>
<td>Cube configuration reference</td>
</tr>
<tr>
<td>Description</td>
</tr>
</tbody>
</table>

**Model name**

Select the model whose cube and/or fact table is to be generated. A model can have more than one cube configuration because different cubes can be generated from the same model.

**Cube configuration name**

You will use the cube configuration later to generate cubes. In this step of the wizard, you assign a name that describes the cube to be generated.

You cannot use the following characters in the cube configuration name: ' (single quotation mark), " (quotation mark), / (slash), \ (backslash), or | (pipe).

**Cube configuration reference**

The cube configuration reference is used in public views as an unchangeable identifier for the configuration.

**Select the Type of Cube and Whether to Generate a Cube and Fact Table or a Fact Table Only**
Cube and Fact table or Fact table only
You can choose to generate both a cube and fact table, or only a fact table. You can use the fact table to generate a customized cube in another application, such as SAS OLAP Cube Studio or Microsoft SQL Server Analysis Services.

Type
Multi-Stage Contribution (MSC)
Analyzes the cost contributions to or from accounts that have stages attributes.

You can generate different multi-stage contribution cubes from the same model. A cube configuration remembers your selections for a particular cube and for a particular model.

Note: You can copy an existing cube configuration and change only the model with which the cube configuration is associated. See Copy a Cube Configuration to a Different Model.

Single-Stage Contribution (SSC)
Analyzes the cost contributions from one assignment level back.

Resource Contribution (RC)
Analyzes the costs contributions from original accounts where costs were entered for final accounts that do not assign costs to other accounts.

Suppress zero cost
Suppress items that have no associated costs to save generation time and reduce cube size.

Note: This option applies only to a Multi-Stage Contribution cube.

Also load tables into a library for the SAS LASR Analytic Server
The following tables are published to the database whenever you generate. If you select this option, then these tables are, in addition, published to and registered in the SAS metadata folder that you specified with Metadata Server Options. See “Metadata Server Options” on page 478.
### View Name

<table>
<thead>
<tr>
<th>View Name</th>
<th>Description</th>
</tr>
</thead>
</table>
| $ModelRef\_PD\_COSTELEMENT<suffix>$      | Details defining the types of cost elements.  
See “$modelRef\_PD\_COSTELEMENT<suffix>$” in Chapter 8 of *SAS Cost and Profitability Management: Data Administration Guide*. |
| where <suffix> is RC, SSC, or C<cube configuration ID> for a multi-stage contributions cube. |                                                                                                |
| For example:                             |                                                                                                |
| ABC\_PD\_COSTELEMENTRC                   |                                                                                                |
| ABC\_PD\_COSTELEMENTSSC                  |                                                                                                |
| ABC\_PD\_COSTELEMENTC1001                |                                                                                                |
| $ModelRef\_PD\_dimShortRef<suffix>$      | Single dimension-member details: level by level, noting ID, Reference, and Name.  
See “$modelRef\_PD\_dimShortRef<suffix>$” in Chapter 8 of *SAS Cost and Profitability Management: Data Administration Guide*. |
| where <suffix> is RC, SSC, or C<cube configuration ID> for a multi-stage contributions cube. |                                                                                                |
| For example:                             |                                                                                                |
| ABC\_PD\_REGIONRC                        |                                                                                                |
| ABC\_PD\_REGIONSSC                       |                                                                                                |
| ABC\_PD\_REGIONC1001                     |                                                                                                |
| $ModelRef\_PD\_DRIVER<suffix>$           | Driver ID and corresponding Driver Name.  
See “$modelRef\_PD\_DRIVER<suffix>$” in Chapter 8 of *SAS Cost and Profitability Management: Data Administration Guide*. |
| where <suffix> is RC, SSC, or C<cube configuration ID> for a multi-stage contributions cube. |                                                                                                |
| For example:                             |                                                                                                |
| ABC\_PD\_DRIVERRC                        |                                                                                                |
| ABC\_PD\_DRIVERSSC                       |                                                                                                |
| ABC\_PD\_DRIVERC1001                     |                                                                                                |
| $ModelRef\_PD\_MODULE<suffix>$           | Details defining the types of modules.  
See “$modelRef\_PD\_MODULE<suffix>$” in Chapter 8 of *SAS Cost and Profitability Management: Data Administration Guide*. |
<p>| where &lt;suffix&gt; is RC, SSC, or C&lt;cube configuration ID&gt; for a multi-stage contributions cube. |                                                                                                |
| For example:                             |                                                                                                |
| ABC_PD_MODULERC                        |                                                                                                |
| ABC_PD_MODULESSC                       |                                                                                                |
| ABC_PD_MODULEC1001                     |                                                                                                |</p>
<table>
<thead>
<tr>
<th>View Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ModelRef_PD_PERIOD&lt;suffix&gt;</td>
<td>Details defining the periodic hierarchy.</td>
</tr>
<tr>
<td></td>
<td>See “modelRef_PD_PERIOD&lt;suffix&gt; ” in Chapter 8 of SAS Cost and Profitability Management: Data Administration Guide.</td>
</tr>
<tr>
<td>ABC_PD_PERIODRC</td>
<td></td>
</tr>
<tr>
<td>ABC_PD_PERIODSSC</td>
<td></td>
</tr>
<tr>
<td>ABC_PD_PERIODC1001</td>
<td></td>
</tr>
<tr>
<td>ModelRef_PD_SCENARIO&lt;suffix&gt;</td>
<td>Details defining the types of available scenarios.</td>
</tr>
<tr>
<td></td>
<td>See “modelRef_PD_SCENARIO&lt;suffix&gt; ” in Chapter 8 of SAS Cost and Profitability Management: Data Administration Guide.</td>
</tr>
<tr>
<td>ABC_PD_SCENARIORC</td>
<td></td>
</tr>
<tr>
<td>ABC_PD_SCENARIOSSC</td>
<td></td>
</tr>
<tr>
<td>ABC_PD_SCENARIOC1001</td>
<td></td>
</tr>
<tr>
<td>ModelRef_PD_YESNO&lt;suffix&gt;</td>
<td>Dimensional definition for Boolean values: Text strings.</td>
</tr>
<tr>
<td></td>
<td>See “modelRef_PD_YESNO&lt;suffix&gt; ” in Chapter 8 of SAS Cost and Profitability Management: Data Administration Guide.</td>
</tr>
<tr>
<td>ABC_PD_YESNORC</td>
<td></td>
</tr>
<tr>
<td>ABC_PD_YESNOSSC</td>
<td></td>
</tr>
<tr>
<td>ABC_PD_YESNOC1001</td>
<td></td>
</tr>
</tbody>
</table>
**View Name**

`ModelRef_PF_<suffix>`

where `<suffix>` is RC, SSC, or `<CubeConfigRef>` for a multi-stage contributions cube.

For example:

ABC_PF_RC
ABC_PF_SSC
ABC_PF_abcRef

If you have checked *Also load tables into a library for the SAS LASR Analytic Server*, then, in addition to the tables using the naming convention above, tables in star-schema format are also generated that use the following naming convention:

`ModelRef_PF_<suffix>`

where `<suffix>` is RCSTAR, SSCSTAR, or `<cubeConfigRef>`-STAR for a multi-stage contributions cube.

For example:

ABC_PF_RCSTAR
ABC_PF_SSCSTAR
ABC_PF_abcRefSTAR

**Note:** Suppose that you selected the *Also load tables into a library for the SAS LASR Analytic Server* check box, the star-schema and all associated tables are loaded into a library for the SAS LASR Analytic Server, and the SAS LASR Analytic Server goes down. When the SAS LASR Analytic Server is running again, all the tables (including the star-schema) that are present in the library for the SAS LASR Analytic Server are unloaded. To reload the star-schema and associated table into the library for the SAS LASR Analytic Server, perform the following steps:

1. Ensure that the SAS LASR Analytic Server is running.
2. On the **Tools** menu, select **Operations Summary**.
3. In the **Operations Summary** dialog box, select the required operation that contains the information about the cube generation and click **View**. The **Summary** dialog box displays a summary of the cubes that are generated.
4. Copy the SAS code that is under the heading *CODE FOR PUSH TO LASR* for the required cube from the **Summary** dialog box into a text file.
5. Format the SAS code in the text file so that it can run on a SAS environment. Each SAS statement must end with a semicolon and the subsequent SAS statement must start on a new line.
6. Add the following statement at the beginning of the SAS code and then run the formatted SAS code in the SAS environment to load the cube-related tables into the library for the SAS LASR Analytic Server: `options metaserver="<<server_name>>" metauser="<<username>>"`
In addition to these tables, you can export other tables that are registered in a SAS metadata folder that is enabled for the SAS LASR Analytic Server. See Chapter 82, “Export Registered Tables,” on page 659.

**See Also**
Chapter 66, “How To: Generating and Managing Cubes,” on page 549

### Cube Configuration: Options for a Multi-Stage Contribution Cube

The following dialog box appears only for a multi-stage contribution cube.

#### Modules and Stages

**Modules**

Each module defines a single stage (one stage per module) in the order in which you defined your modules, or in the following order for a traditional activity-based costing model:

1. External Units
2. Resource
3. Activity
4. Cost Object

**Stages**

Each stage is defined by a dimension member attribute in a dimension attribute that is named Stages. For more information, see Stage attributes and Adding Stage Attributes to Accounts.
Select All
Check this box to select all dimensions in a module or stage for inclusion in the cube. Selecting this check box turns on the Include flag for each individual dimension.

Include
Check this box to include the selected dimension in the cube.

Cost Flow
Select whether to include cost flows into or out of the selected module or stage.

With some models, it makes a difference in generating a cube whether you select to show costs flowing into a module/stage or out of a module/stage. It makes a difference in case the model has assignments from accounts in a module/stage to accounts within the same module/stage. You cannot choose to show both assignments because that would result in double-counting final costs.

If a model has no cost assignments from accounts within a module/stage to accounts within the same module/stage, then the choice of showing cost flows into or out of a module/stage makes no difference (every cost into a module/stage is also a cost out of the module/stage). By defining multiple stages such that there are no assignments within a single stage, you avoid having to make the choice of showing cost flows in or out.

Include to Level
For dimensions with multiple levels, specify how many levels you want included in the cube for drill down. The default is to include up to and including level 2 of a dimension.

Note: Click Include All Levels to select all levels for inclusion in the cube. After clicking this button you can override the depth for particular dimensions so as to include fewer levels.

Filter Members
Click this button to select the dimension members to be included in the generated cube. You can select dimension members in any level of the dimension hierarchy up to and including the level specified in Include to Level. See “Select Dimension Members for Inclusion in Cubes” on page 493.

Include All Levels
Click this button to select all levels for inclusion in the cube. Clicking the button has the same effect as manually selecting the lowest level of each dimension for inclusion. After clicking the button you can override the depth for particular dimensions so as to include fewer levels.

See Also
• “Create a Cube Configuration” on page 481
• Chapter 66, “How To: Generating and Managing Cubes,” on page 549

Cube Configuration: Cube Options

Overview
Your options for creating a cube depend on whether you are using:

• SAS OLAP on page 489
• Microsoft SQL Server Analysis Services on page 490
**Cube Options for SAS OLAP**

*Note:* The following picture is only an example. By default you do not have to specify any options to generate a cube. Indeed, you should not specify any options unless you have experience with SAS programming.

**Parameters for options statement**

By default you do not have to specify any options for cube generation. However, if you want to override the default SAS system options, you can specify them here. The following are some sample options:

- `OPTION NOSYNTAXCHECK;`
- `OPTION SORTPGM=SAS;`
- `OPTION MEMSIZE=2G;`
- `OPTION REALMEMSIZE=1331M;`
- `OPTION SUMSIZE=1331M;`
- `OPTION BUFSIZE=64K;`
- `OPTION IBUFSIZE=32767;`
- `OPTION UBUPSIZE=64K;`
- `OPTION SORTSIZE=512M;`
- `OPTION CPUCOUNT=2;`
- `OPTION NOOVP;`

For all system options, see SAS System Options in the SAS 9.2 Language Reference: Dictionary.

**PROC OLAP options**

SAS Cost and Profitability Management uses the SAS OLAP procedure to generate cubes. By default you do not have to specify any PROC OLAP options for cube generation. However, if you want to override the default OLAP options, you can specify them here. The following are two sample options:

- `INDEXSORTSIZE=32 MAXTHREADS=2`

For all PROC OLAP options, see The OLAP Procedure in the SAS OLAP Server: User's Guide [online](http://support.sas.com/documentation/onlinedoc/olap/index.html). The following two options can possibly save disk storage space by reducing cube size: COMPACT_NWAY and NONUPDATEABLE.
COMPACT_NWAY
specifies that the cube build will include an additional summarization step that is
designed to decrease the size of the NWAY aggregation and improve viewing
performance. The amount of improvement depends on the nature of the data. The
cubes that improve the most are those that have the largest

NONUPDATEABLE
specifies that the dimension(s) should be built with the minimum amount of disk
space to represent the members available when the cube is created. By default,
new dimensions are built to allow for new members to be added in future
updates. NONUPDATEABLE is valid only when the cube is first created.

Note: The following options are not supported: DRILLTHROUGH_TABLE=,
WORKPATH=, DESCRIPTION=, IGNORE_MISSING_DIMKEYS=.

Metadata server cube folder path
If you want to override the default location for the generated cube, you can specify a
path on the SAS Metadata Server.

By default, the path is: /Products/SAS Cost and Profitability
Management/Cubes/. However, the default path could have been changed during
installation. In either case you can override the path here.

Note: The folder that you specify must already exist when cube generation is started
and you must have write access to the folder for cube generation to be successful.

Cube Options for Microsoft SQL Server Analysis Services

Pre-aggregation Percentage
Pre-aggregating numeric data results in faster performance when you work with a
cube in the OLAP analyzer. But, for large models pre-aggregating data can take a
long time which increases cube-generation time. So, the more pre-aggregation you do, the faster you can navigate a cube, but the longer it takes to generate it. This option allows you to trade generation time for execution speed.

**Process cube**

Processing a cube causes processing of all the measure groups within the cube and the constituent dimensions that are currently in an unprocessed state. When you process a cube, an SQL query is issued to retrieve values from the fact table to populate each member in the cube with appropriate measure values. For any specific path to a node in the cube, there is a value or a calculable value. Processing a cube creates machine-readable files that store relevant fact data. If there are aggregations created, they are stored in aggregation data files.

### Cube Configuration: Select Numeric Attributes

Select the numeric attributes to be included in the generated cube.

![New Cube Configuration - Numeric Attributes](image)

**Note:** You can select the numeric attributes that are to be checked by default in a new cube configuration by doing the following:

1. Open a model and select **Model ➔ Properties**.
2. Select the **Attributes in Cube** tab.
3. Select the attributes that are to be checked by default in a new cube configuration for that model.

Attributes that you select in Model Properties are automatically checked in a new cube configuration to be included in the generated cube. However, you can uncheck the attributes in the cube configuration and select others.

### See Also

- “Create a Cube Configuration” on page 481
- “Include Numeric Attributes in a Cube” on page 551
- Chapter 66, “How To: Generating and Managing Cubes,” on page 549
**Cube Configuration: Finish**

Review your selections; then click **Finish**.

The cube configuration is created. You can use it to generate cubes.

![New Cube Configuration - Summary](image)

**See Also**

- “Create a Cube Configuration” on page 481
- Chapter 66, “How To: Generating and Managing Cubes,” on page 549

---

**Copy a Cube Configuration to a Different Model**

A cube configuration is associated with one and only one model. You can copy a cube configuration, preserving all its specifications except the model with which it is associated. By doing this, you create a new cube configuration with all the specifications of the old one except for the model with which it is associated.

To make a copy of a cube configuration that is associated with a different model, do the following:

1. From the Navigation Pane, go to the Workspace Manager.
2. Select **Cube Configurations**.
3. Select **Copy To Model** from the pop-up menu.
   
   The **Copy To Model** dialog box opens.
4. Select the new model to which the cube configuration is to be assigned.
   
   *Note:* The new model must have the same dimensions as the old one.
5. Specify the name of the new cube configuration.
6. Click **OK**.

A new cube configuration is created with all the attributes of the old one, but associated with a different model.
Select Dimension Members for Inclusion in Cubes

Overview

Not only can you choose what dimensions to include and up to what level to include their dimensions members. But, you can also choose at any level what individual dimension members to include. This ability allows you to create cubes that go deep into the dimension hierarchy and yet remain small.

The following picture shows selecting dimension members at a deep level, and yet creating a small cube because it contains fewer dimension members.

You can pick and choose at every level

Selecting Dimension Members

Note: If, instead of selecting individual dimension members, you want to include all dimension members at all levels, you can click **Include all levels**.
To select individual dimension members to include in a generated cube, do the following:

1. Go to the Workspace Manager or to the module view for a model.
2. Select File ➜ New ➜ Cube Configuration or open an existing cube configuration.
3. For Step 1 of the Cube Configuration wizard, specify the following:
   • Model name
   • Cube configuration name
   • Cube configuration reference
   • Specify Create cube and fact table.
   • Specify Multi-Stage contribution as the type of cube to generate.
   Click OK to proceed to Step 2 of the Cube Configuration wizard.
   Click OK to proceed to Step 3 of the Cube Configuration wizard.
5. For Step 3 of the Cube Configuration wizard:
   a. Select a dimension member
   b. Select Include to include this dimension member in the generated cube.
   c. For Include to Level, select the level of the dimension hierarchy through which you want to include dimension members.
   d. Click Filter Members.

The Filter Dimension Members dialog opens.

6. In the Filter Dimension Members dialog, select the dimension members that you want to include in the cube.

Note: If you want to go deeper (or shallower) in the dimension hierarchy, use the Include to Level drop-down list to select a level. When you leave this dialog, the level is reflected in the previous Modules, Stages, Dimensions, and Levels window.
7. Click OK.

The Filter Dimension Member dialog closes, and a "Yes" in the Filter Members column indicates that not every dimension member is selected for inclusion in the cube.

Note: Although dimension members that you deselect are not included in a cube, their costs are included in the None category.
Part 17

Calculation

Chapter 59
  Calculating Costs ......................................................... 499

Chapter 60
  Properties in Calculation .................................................. 501

Chapter 61
  Detailed Example of Calculation ......................................... 513

Chapter 62
  Windows for Calculation ................................................... 533
Chapter 59

Calculating Costs

Overview

As you begin entering data from the paper model into the model in SAS Cost and Profitability Management, you should notice how the costs are conforming to expectations. At any time during the development of a model, you can assign the cost of each account according to the account's driver.

You can enter costs interactively. However, interactively entering data can be tedious and prone to errors. Importing data from an existing data source can minimize tedium and error. For example, if the costs from the general ledger are available, and if you have built the model so that the models resource account references match the general ledgers account numbers, it is more efficient to add costs to the model by importing them.

After you calculate costs, you might want to republish your data to SAS Strategy Management because your costs are not automatically updated.

To calculate the costs for a model, select Model ⇒ Calculate Costs.

The Calculate Costs dialog box appears.

Changing the Model Structure after Calculating Costs

After you have calculated costs for an entire model, any of the following actions can invalidate some of the model costs:

- Adding, deleting, or changing the cost of an entered cost element
- Changing an accounts driver, driver quantities, attribute quantities, or output quantities
• Adding or deleting a rollup account, an account, or a cost element
• Creating new assignments or deleting existing ones

In all of these cases, costs are updated if you calculate costs. However, it might not be necessary to calculate costs for a minor change.

---

**Period/Scenario Association**

When you calculate costs, you can choose a specific period/scenario association, or you can choose all period/scenario associations.

---

**Errors**

You should choose to report all errors at least once while you are calculating costs and generating cubes. Fix any problems that are reported. If you determine that the remaining errors are insignificant, you can choose to not report all errors. Then, you can limit the number of errors that are reported. If you limit the number of errors, performance might improve when costs are calculated and when cubes are generated.
Chapter 60
Properties in Calculation

Types of Properties

Introduction

Model properties that are involved in calculation fall into categories that are represented by the following diagrams:

- “Diagram 1: Cost Flowing Into and Out of an Account” on page 501
- “Diagram 2: Properties of an Assignment” on page 502
- “Diagram 3: Account Driver Properties” on page 503

This chapter begins by presenting the diagram for each category of properties. Then, in the subsequent sections, the interrelationships among the diagrams are examined in detail.

See Also

“How to Read these Diagrams” on page 774

Diagram 1: Cost Flowing Into and Out of an Account

The following diagram shows costs flowing into and out of a single account. This is the same diagram as shown in “Cost Flowing Into and Out of an Account (Non-Reciprocal)” on page 768 with the addition of numbering.

- The diagram is for non-reciprocal cost flow.
The column in the center shows the total cost in the account. Cells to the left show cost flowing into the account. Cells to the right show cost flowing out.

The numbers in the cells show the logical sequence for the calculation of properties. The calculation of a property with a higher number depends upon the prior calculation of certain properties with lower numbers. These numbers are used later in this chapter to label descriptions of the individual calculations. Letters are used (for example, 2a and 2b) to indicate that either can be calculated first.

### Diagram 2: Properties of an Assignment

The following diagram shows the properties associated with an individual assignment. This is the same diagram as shown in “Assignment Properties” on page 771 with the addition of numbering.

**Note:** This diagram does not apply to assignments made with a calculated driver. In the case of a calculated driver, DrvQtyCalc is derived from a user-specified formula.

**Note:** Although the properties are prefixed with the word “Driver” (or include it, as in the case of IdlDrvQty), they are all properties of an individual assignment.
Diagram 3: Account Driver Properties

The following diagram shows the properties associated with the driver for an account. For example, TDQCale for an account is the sum of DrvQtyCalc for the individual outgoing assignments that make up the driver for that account. Assignments are to one or more destination accounts.

This diagram is the same one as in "Account Driver Properties" on page 771 with the addition of numbering.

When TDQUE is not specified, then there are no idle quantities (IdlQty=0, AsgnIdlQty=0, and UnAsgnQty=0) and, therefore, TDQ=UsedQty=DrivenQty. When TDQUE is not specified, the diagram reduces to the following:
Assignment and Account Driver Properties

This section examines the interrelations among the following diagrams:

- “Diagram 1: Cost Flowing Into and Out of an Account” on page 501
- “Diagram 2: Properties of an Assignment” on page 502
- “Diagram 3: Account Driver Properties” on page 503

In the following diagram, the long blue arrows denote a dependency relationship between properties. The property pointed to by the arrow depends on the property that points to it. For example, the arrow that points to

4a. TDQCalc from

2a. Driver Quantity Calculated

indicates that TDQCalc (4a) depends on Driver Quantity Calculated (2a). In the table that follows the diagram, look for the row number that matches the number of the property pointed to. This row describes the dependency relationship between the two properties. For the current example, the row number is 4a and its text includes the following formula:

TDQCalc = Σ DrvQtyCalc (2a)

Note that (2a) is the number of the cell in the diagram for the property that TDQCalc is dependent on (DrvQtyCalc). DrvQtyCalc is described by the table row numbered 2a.

The portion of the diagram that is labeled “Diagram 2. An assignment” stands for one or more assignments to different destination accounts. So, for example, TDQCalc (which is in the portion of the diagram labeled “Diagram 3”) is the sum of DrvQtyCalc (in the portion of the diagram labeled “Diagram 2”) for all outgoing assignments.
### Table: Step-by-Step Calculations of Cost in Accounting

<table>
<thead>
<tr>
<th>Step #</th>
<th>Property</th>
<th>Property Type</th>
<th>Calculation</th>
</tr>
</thead>
<tbody>
<tr>
<td>0a.</td>
<td>Entered Cost</td>
<td>Incoming</td>
<td>Entered Cost is the sum of entered cost elements for the account (a single account can have multiple entered cost elements).</td>
</tr>
<tr>
<td>0b.</td>
<td>Received Cost</td>
<td>Incoming</td>
<td>RcvCost = EnteredCost (0a) + RcvDrvnCost (24) + RcvAllocCost (23c)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>All cost in a model originates with entered cost elements: either with EnteredCost or with EnteredUnitCost (see “Entered Cost Elements” on page 234).</td>
</tr>
<tr>
<td>1.</td>
<td>Cost</td>
<td>Cost in an account</td>
<td>Cost = Entered Cost (0a) + Received Cost (0b)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>The cost in an account is the sum of its own Entered Cost (its own entered cost elements) plus its Received Cost.</td>
</tr>
</tbody>
</table>

Now calculation looks at each individual outgoing assignment in turn.
<table>
<thead>
<tr>
<th>Step #</th>
<th>Property</th>
<th>Property Type</th>
<th>Calculation</th>
</tr>
</thead>
<tbody>
<tr>
<td>2a.</td>
<td>Driver Quantity Calculated</td>
<td>Assignment</td>
<td>DrvQtyCalc = (DQF x DWF)+(DQV x DWV x Dest.TDQ)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 2</td>
<td>Note: This formula does not apply to a Calculated driver—where DrvQtyCalc is determined by a user-defined formula. There are two kinds of quantities: fixed vs. variable. Fixed works by “push” (how much is supplied) whereas variable works by “pull” (how much is demanded). Variable requires looking forward until finding Dest.TDQ ne 0 (that is until Dest.SoldQty ne 0 or Dest.TDQUE ne 0 or Dest.TDQCalc ne 0). A single assignment can have both fixed and variable quantities, (it can work both by push and by pull). See “Fixed Driver Quantities” on page 374. Also see “Variable Driver Quantities” on page 375.</td>
</tr>
<tr>
<td>2b.</td>
<td>Idle Driver Quantity</td>
<td>Assignment</td>
<td>IdlDrvQty for an assignment is determined by its idle flow method (user-entered, user proportion, driver quantity, evenly assigned). For information, see “Idle Quantities” on page 384.</td>
</tr>
<tr>
<td>3.</td>
<td>Driver Driven Quantity</td>
<td>Assignment</td>
<td>DrvDrvnQty = DrvQtyCalc (2a) + IdlDrvQty (2b)</td>
</tr>
</tbody>
</table>

Now that the system has looked at all the outgoing assignments from an account, it can calculate the quantities associated with an account’s driver.

<table>
<thead>
<tr>
<th>Step #</th>
<th>Property</th>
<th>Property Type</th>
<th>Calculation</th>
</tr>
</thead>
<tbody>
<tr>
<td>4a.</td>
<td>TDQCalc</td>
<td>Account</td>
<td>TDQCalc = ∑ DrvQtyCalc (2a)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 3</td>
<td>TDQCalc for a driver is the sum of DrvQtyCalc for the individual outgoing assignments of that driver.</td>
</tr>
<tr>
<td>4b.</td>
<td>Sold Quantity</td>
<td>Account</td>
<td>User-entered.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 3</td>
<td></td>
</tr>
<tr>
<td>5.</td>
<td>Used Quantity</td>
<td>Account</td>
<td>UsedQty = TDQCalc (4a) + Sold Quantity (4b)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 3</td>
<td></td>
</tr>
<tr>
<td>6.</td>
<td>Output Quantity</td>
<td>Account</td>
<td>Output Quantity = Used Quantity (5) unless overridden by OutQtyUE.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 3</td>
<td>Output Quantity is used to determine Unit Cost according to the following formula: UnitCost = Cost/OutQty</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Also, UnitRevenue = Revenue / OutQty</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Also, UnitProfit = Profit / OutQty</td>
</tr>
<tr>
<td>7.</td>
<td>TDQ</td>
<td>Account</td>
<td>TDQ = Used Quantity (6) unless overridden by TDQUE</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 3</td>
<td></td>
</tr>
<tr>
<td>Step #</td>
<td>Property</td>
<td>Property Type</td>
<td>Calculation</td>
</tr>
<tr>
<td>-------</td>
<td>---------------------------</td>
<td>---------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>8. Idle Quantity</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Because TDQ equals UsedQty unless overridden by TDQUE, the only way that</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>IdlQty can be non-zero is if TDQUE is greater than UsedQty.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Note: If TDQUE is less than UsedQty, then the following error message</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>appears: “Overdriven source account. The value entered for TDQUE is less</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>than the Driven Quantity.”</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>IdlPcnt = 100 * IdlQty / TDQ (7)</td>
</tr>
<tr>
<td></td>
<td>Assigned Idle Quantity</td>
<td>Account driver</td>
<td>9. Assigned Idle Quantity</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 3</td>
<td>AsgnIdlQty for a driver is the sum of IdlDrvQty (2b) for the individual</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>assignments.</td>
</tr>
<tr>
<td></td>
<td>Unassigned Quantity</td>
<td>Account driver</td>
<td>10. Unassigned Quantity</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 3</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Driven Quantity</td>
<td>Account driver</td>
<td>11. Driven Quantity</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 3</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 2</td>
<td>Driver Allocated Cost (DrvAllocCost) for an individual assignment is user-</td>
</tr>
<tr>
<td></td>
<td>Allocated Cost</td>
<td>Outgoing</td>
<td>13. Allocated Cost</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 1</td>
<td>Allocated Cost is the sum of DrvAllocCost (12) on assignments going out</td>
</tr>
<tr>
<td></td>
<td>Drivable Cost</td>
<td>Outgoing</td>
<td>14. Drivable Cost</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 1</td>
<td>Also, DrvblCost = IdleCost (20b) + UsedCost (20a)</td>
</tr>
<tr>
<td></td>
<td>Driver Rate</td>
<td>Account driver</td>
<td>15. Driver Rate</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 3</td>
<td>Note: Driver Rate can be different from Unit Cost if any of the following</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>is true:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• TDQUE ne 0 (which overrides TDQ in the formula DrvRate = DrvblCost / TDQ)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• AllocCost ne 0 (which affects DrvblCost in the formula DrvRate = DrvblCost / TDQ)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• OutQtyUE ne 0 (which overrides OutQty in the formula UnitCost = Cost / OutQty)</td>
</tr>
</tbody>
</table>

Once the system has determined Driver Rate, it can calculate the costs flowing out on each outgoing assignment.
### Step # | Property | Property Type | Calculation
--- | --- | --- | ---
16. | Driver Driven Cost | Assignment | Driver Driven Cost = DrvQtyCalc (2a) x Driver Rate (15)
| | | Diagram 2 | So, Driver Driven Cost = DrvQtyCalc (2a) x (DrvblCost/TDQ)
| | | | Also, DrvDrvnCost = DrvIdlCost (17) + DrvUsedCost (18)
17. | Driver Idle Cost | Assignment | DrvIdlCost = IdlDrvQty (2b) x DrvRate (15)
| | | Diagram 2 |
18. | Driver Used Cost | Assignment | DrvUsedCost = DrvDrvnCost (16) – DrvIdlCost (17)
| | | Diagram 2 | Also, DrvUsedCost = DrvQtyCalc (2a) x DrvRate (15)
19. | Driver Cost | Assignment | Driver Cost = DrvAllocCost (12) + DrvDrvnCost (16)
| | | Diagram 2 | That is, the outgoing cost for an assignment is the sum of the cost that is allocated plus the sum that is driven by the driver.

### Outgoing Cost

This section examines the interrelations among the following diagrams:

- “Diagram 1: Cost Flowing Into and Out of an Account” on page 501
- “Diagram 3: Account Driver Properties” on page 503
### Step # | Property | Property Type | Calculation |
--- | --- | --- | --- |
20a. | Used Cost | Outgoing | Used Cost = UsedQty \(5\) x DrvRate \(15\) |
20b. | Idle Cost | Outgoing | Idle Cost = IdlQty \(8\) x DrvRate \(15\)  
Also, Idle Cost = AsgnIdlCost \(20c\) + UnAsgnCost \(22\) |
20c. | Assigned Idle Cost | Outgoing | AsgnIdlCost = AsgnIdlQty \(9\) x DrvRate \(15\)  
Also, AsgnIdlCost = sum of DrvIdlCost \(17\) on outgoing assignments |
20d. | Driven Cost | Outgoing | Driven Cost = DrvnQty \(11\) x DrvRate \(15\)  
Also, Driven Cost = Used Cost \(20a\) + AsgnIdlCost \(20c\) |
21. | Assigned Cost | Outgoing | Assigned Cost = Allocated Cost \(13\) + Driven Cost \(20d\) |
<table>
<thead>
<tr>
<th>Step #</th>
<th>Property</th>
<th>Property Type</th>
<th>Calculation</th>
</tr>
</thead>
<tbody>
<tr>
<td>22.</td>
<td>Unassigned Cost</td>
<td>Outgoing</td>
<td>UnAsgnCost = DrvblCost (14) + AllocCost (13) – AsgnCost (21)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 1</td>
<td>Also, UnAsgnCost = Cost (1) – AsgnCost (21)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Also, UnAsgnCost = IdlCost (20b) – AsgnIdlCost (20c)</td>
</tr>
</tbody>
</table>

Next, the system looks at costs flowing into the destination account.

**Incoming Cost**

This section examines the interrelations among the following diagrams:

- “Diagram 1: Cost Flowing Into and Out of an Account” on page 501
- “Diagram 2: Properties of an Assignment” on page 502

The assignment shown in this diagram stands for one or more assignments from different source accounts. For example, RevIdlCost, in the receiving account, is the sum of DrvIdlCost in all the incoming assignments to that account.
### Step # Property Property Type Calculation

**23a. Received Idle Cost**   
Incoming  
Diagram 1  
RevIdlCost = Σ DrvIdlCost  (17)  

RevIdlCost is the sum of idle costs from individual assignments, DrvIdlCost (17), to the destination account.

**23b. Received Used Cost**   
Incoming  
Diagram 1  
RevUsedCost = Σ DrvUCost  (18)  

RevUsedCost is the sum of used costs from individual assignments, DrvUCost (18), to the destination account.

**23c. Received Allocated Cost**   
Incoming  
Diagram 1  
RevAllocCost = Σ DrvAllocCost  (12)  

RevAllocCost is the sum of costs allocated on individual assignments, DrvAllocCost (12), to the destination account.
<table>
<thead>
<tr>
<th>Step #</th>
<th>Property</th>
<th>Property Type</th>
<th>Calculation</th>
</tr>
</thead>
<tbody>
<tr>
<td>24.</td>
<td>Received Driven Cost</td>
<td>Incoming</td>
<td>$RcvDrvnCost = \sum DrvDrvnCost$ (16)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 1</td>
<td>$RcvDrvnCost$ is the sum of costs driven by individual assignments, $DrvDrvnCost$ (16), to the destination account. Also, $RcvDrvnCost = RcvIdlCost$ (23a) + $RcvUsedCost$ (23b)</td>
</tr>
<tr>
<td>25.</td>
<td>Received Cost</td>
<td>Incoming</td>
<td>$Received Cost = RcvDrvnCost$ (24) + $RcvAllocCost$ (23c)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 1</td>
<td>Also, $Received Cost = RcvBOCCost$ (25a) + $RcvAsgnCost$ (25b)</td>
</tr>
<tr>
<td>26.</td>
<td>Sold Cost</td>
<td>Account</td>
<td>$SoldCost = SoldQty$ (4b) x $DrvRate$ (15)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 1</td>
<td></td>
</tr>
</tbody>
</table>

Now the destination account contains a cost that is equal to its Received Cost plus its own Entered Cost, and the process of examining outgoing assignments starts over until the calculation process has traversed all the accounts and all the assignments in the model.
Chapter 61
Detailed Example of Calculation

Introduction

This chapter describes what the system does to calculate the cost flows between accounts for the following simple example:
The description can help you to further understand that some system properties describe quantities flowing along an assignment path, while other system properties describe costs coming into or flowing out of an account. Although this example does not include all the properties available in a model, it does include those that are most frequently used in assignments.

To summarize the calculation process for this example:

- **Resource_account** assigns costs to **Activity_account1** and **Activity_account2** using a Standard driver, named “Weighted”.

  The Weighted driver has both fixed driver quantities (DQF and DWF) and variable driver quantities (DQV and DWV).

  The driver also has a user-entered cost allocation (DrvAllocCost).

- **Activity_account1** assigns costs to **CO_account1** and **CO_account2** using a Standard driver named “Standard”.

  This Standard driver has both a fixed driver quantity (DQF) and a variable driver quantity (DQV) — but not DWF and DWV.

- **Activity_account2** also assigns costs to **CO_account1** and **CO_account2** but using a Percentage driver.

The following is a schematic drawing which we will use in the rest of this chapter in discussing the calculation process.
The properties whose value is determined during calculation are the following:

1. “Step 1–User Enters Driver Quantities (DQF, DQV, DWF, DWV, DrvAllocCost)” See page 516
2. “Step 2–DrvQtyCalc for Assignments to Cost Object Accounts” See page 517
3. “Step 3–TDQCalc for Activity Accounts” See page 518
4. “Step 4–TDQ for Activity Accounts” See page 519
5. “Step 5–DrvQtyCalc for Assignments to the Activity Accounts” See page 520
6. “Step 6–TDQCalc for Resource Account” See page 521
7. “Step 7–TDQ for Resource Account” See page 522
8. “Step 8–AllocCost for Resource Account” See page 523
9. “Step 9–DrvblCost for Resource Account” See page 524
10. “Step 10–DrvRate for Resource Account” See page 525
11. “Step 11–DrvDrvnCost for Assignments to Activity Accounts” See page 526
12. “Step 12–DrvCost for Assignments to Activity Accounts” See page 527
13. “Step 13–DrvblCost for Activity Accounts” See page 528
14. “Step 14–DrvRate for Outgoing Drivers from Activity Accounts” See page 529
15. “Step 15–DrvDrvnCost for Assignments to Cost Object Accounts” See page 530
16. “Step 16–DrvCost for Assignments to Cost Object Accounts” See page 531
17. “Step 17–Cost for Cost Object Accounts” See page 532
Step 1–User Enters Driver Quantities (DQF, DQV, DWF, DWV, DrvAllocCost)

The following are user-entered driver quantities:

- DQF (Driver Quantity Fixed)
- DQV (Driver Quantity Variable)
- DWF (Driver Weight Fixed)
- DWV (Driver Weight Variable)
- DrvAllocCost (Driver Allocated Cost)
Step 2–DrvQtyCalc for Assignments to Cost Object Accounts

\[
\text{DrvQtyCalc} = (DQF \times DWF) + (DQV \times DWV \times \text{Dest.TDQ})
\]

- DrvQtyCalc from Activity\_account1 to CO\_account1 = \((1 \times 1) + (5 \times 1 \times 0) = 1\)
- DrvQtyCalc from Activity\_account1 to CO\_account2 = \((1 \times 1) + (10 \times 1 \times 0) = 1\)
- DrvQtyCalc from Activity\_account2 to CO\_account1 = \((60 \times 1) + (0 \times 1 \times 0) = 60\)
- DrvQtyCalc from Activity\_account2 to CO\_account2 = \((40 \times 1) + (0 \times 1 \times 0) = 40\)

Note: TDQ=0 for CO\_account1 and for CO\_account2 because there are no costs flowing out of these Cost Object accounts.

Note: A Percentage driver does not allow variable driver quantities. So, its DQV is null, and for calculations a null is counted as zero (DQV=0).

Note: Both the Percentage driver and the "Standard" driver are non-weighted drivers. For non-weighted drivers, DWF=1 and DWV=1.
Step 3–TDQCalc for Activity Accounts

TDQCalc = \sum(DrvQtyCalc)

TDQCalc for Activity_account1 = 1 + 1 = 2

TDQCalc for Activity_account2 = 60 + 40 = 100
Step 4–TDQ for Activity Accounts

TDQ = TDQ Calc + SoldQty

TDQ(Activity_account1) = 2 + 0 = 2

TDQ(Activity_account2) = 100 + 0 = 100

Note: SoldQty is a user-entered property and is zero in this example.
Step 5–DrvQtyCalc for Assignments to the Activity Accounts

\[
\text{DrvQtyCalc} = (DQF \times DWF) + (DQV \times DWV \times \text{Dest.TDQ})
\]

\[
\text{DrvQtyCalc(Activity_account1)} = (3 \times 2) + (3 \times 2 \times 2) = 18
\]

\[
\text{DrvQtyCalc(Activity_account2)} = (2 \times 1) + (2 \times 1 \times 100) = 202
\]
Step 6–TDQ Calc for Resource Account

TDQ Calc = \sum(DrvQtyCalc)

TDQ Calc = DrvQtyCalc(Activity_account1) + DrvQtyCalc(Activity_account2)

TDQ Calc = 18 + 202 = 220
Step 7–TDQ for Resource Account

\[ \text{TDQ} = \text{TDQCalc} + \text{SoldQty} \]

\[ \text{TDQ} = 220 + 0 = 220 \]

\[ \text{Note: SoldQty is a user-entered property and is zero in this example.} \]
Step 8–AllocCost for Resource Account

Allocated Cost = \( \sum (\text{DrvAllocCost}) \) for all outgoing assignments

\[ \text{DrvAllocCost(\text{to Activity_account1})} = \$12 \]

\[ \text{DrvAllocCost(\text{to Activity_account2})} = \$16 \]

(source) Allocated Cost = \$12 + \$16 = \$28
Step 9–Drivable Cost for Resource Account

Drivable Cost = Cost - Allocated Cost:

Drivable Cost = $100 - $28 = $72
DriverRate = DrivableCost / TDQ:

DriverRate = $72 / 220 = $0.33 (rounded up)
Step 11–DrvDrvCost for Assignments to Activity Accounts

\[ \text{DrvDrvnCost} = \text{DrvblCost} \times \left( \frac{\text{DrvQtyCalc}}{\text{TDQCalc}} \right) \]

- **DrvDrvnCost**(to Activity_account1) = \( \$72 \times \left( \frac{18}{220} \right) = \$5.89 \)

- **DrvDrvnCost**(to Activity_account2) = \( \$72 \times \left( \frac{202}{220} \right) = \$66.11 \)

**Detailed Example of Calculation**

- **Resource_account**
  - Cost=130
  - TDQCalc=220
  - TDQ=220
  - AllocCost=28
  -DrvblCost=72
  -DrvRate=0.33

- **Activity_account1**
  - TDQCalc=2
  -TDQ=2

- **Activity_account2**
  - TDQCalc=100
  -TDQ=100

**Calculation Steps**

- **A.**
  - DQF=3
  - DQV=3
  - DWF=2
  - DWF=2
  - DrvAllocCost=12
  - DrvQtyCalc=18
  - DrvDrvCost=5.89

- **B.**
  - DQF=2
  - DQV=2
  - DWF=1
  - DWF=1
  - DrvAllocCost=16
  - DrvQtyCalc=202
  - DrvDrvCost=66.11

**Resource_account**

- **C.**
  - DQF=1
  - DQV=5
  - DWF=1
  - DWF=1
  - DrvQtyCalc=1

- **D.**
  - DQF=1
  - DQV=10
  - DWF=1
  - DWF=1
  - DrvQtyCalc=1

- **E.**
  - DQF=60
  - DQV=0
  - DWF=1
  - DWF=1
  - DrvQtyCalc=80

- **F.**
  - DQF=40
  - DQV=0
  - DWF=1
  - DWF=1
  - DrvQtyCalc=40

**Calculated Values**

- **Resource_account**
  - TDQCalc=220
  - TDQ=220
  - AllocCost=28
  - DrvblCost=72
  - DrvRate=0.33

- **Activity_account1**
  - TDQCalc=2
  - TDQ=2

- **Activity_account2**
  - TDQCalc=100
  - TDQ=100

**Calculation**

- **DrvDrvCost = DrvblCost \times (DrvQtyCalc / TDQCalc):**
  - **DrvDrvCost**(to Activity_account1) = \( \$72 \times \left( \frac{18}{220} \right) = \$5.89 \)
  - **DrvDrvCost**(to Activity_account2) = \( \$72 \times \left( \frac{202}{220} \right) = \$66.11 \)
DriverCost = DrvDrvnCost + DrvAllocCost
Driver cost equals the cost that is driven by an account’s driver plus cost that is allocated.

DriverCost(to Activity_account1) = $5.89 + $12 = $17.89
DriverCost(to Activity_account2) = $66.11 + $16 = $82.11

Cost = RcvCost + EntCost
The cost in an account equals the cost it receives on assignments from other accounts plus cost that is entered directly into the account.

Cost(Activity_account1) = $17.89 + $0 = $17.89
Cost(Activity_account2) = $82.11 + $0 = $82.11
Step 13–DrvblCost for Activity Accounts

\[
\text{DrvblCost} = \text{Cost} - \text{Allocated Cost}:
\]

- DrvblCost for Activity_account1 = $17.89 - $0 = $17.89
- DrvblCost for Activity_account2 = $82.11 - $0 = $82.11

**Resource_account**
- Cost=100
- TDQcalc=220
- TDQ=220
- AllocCost=28
- DrvblCost=72
- DrvRate=0.33
**Step 14–DrvRate for Outgoing Drivers from Activity Accounts**

**DriverRate = DrivableCost / TDQ:**

DriverRate(Activity_account1) = $17.89 / 2 = $8.95 (rounded up)

DriverRate(Activity_account2) = $82.11 / 100 = $0.82 (rounded down)
Step 15–DrvDrvnCost for Assignments to Cost Object Accounts

\[\text{DrvDrvnCost} = \text{DrvblCost} \times \left( \frac{\text{DrvQtyCal}}{\text{TDQ}} \right)\]

\[
\begin{align*}
\text{DrvDrvnCost}(\text{Activity\_account1} \Rightarrow \text{CO\_account1}) &= $17.89 \times \left( \frac{1}{2} \right) = $8.95 \\
\text{DrvDrvnCost}(\text{Activity\_account1} \Rightarrow \text{CO\_account2}) &= $17.89 \times \left( \frac{1}{2} \right) = $8.95 \\
\text{DrvDrvnCost}(\text{Activity\_account2} \Rightarrow \text{CO\_account1}) &= $82.11 \times \left( \frac{60}{100} \right) = $49.27 \\
\text{DrvDrvnCost}(\text{Activity\_account2} \Rightarrow \text{CO\_account2}) &= $82.11 \times \left( \frac{40}{100} \right) = $32.84
\end{align*}
\]
Step 16–DrvCost for Assignments to Cost Object Accounts

DriverCost = DrvDrvnCost + DrvAllocCost

Driver cost equals the cost that is driven by an account’s driver plus cost that is allocated.

DriverCost(Activity_account1 to CO_account1) = $8.95 + $0 = $8.95
DriverCost(Activity_account1 to CO_account) = $8.95 + $0 = $8.95
DriverCost(Activity_account2 to CO_account1) = $49.27 + $0 = $49.27
DriverCost(Activity_account2 to CO_account2) = $32.84 + $0 = $32.84
Step 17–Cost for Cost Object Accounts

Cost = RecvCost + EntCost

The cost in an account equals the cost it receives on assignments from other accounts plus cost that is entered directly into the account.

Cost(CO_account1) = $8.95 + $49.27 = $58.21
Cost(CO_account2) = $8.95 + $32.84 = $41.79
Chapter 62
Windows for Calculation

Calculate Costs Dialog Box

Note: The availability of these features depends on your permissions.

1. Open a model and select Model ⇒ Calculate Costs.
   The Calculate Costs dialog box opens:

   ![Calculate Costs Dialog Box]

2. Select one or more period/scenario associations.
   Note: If there is an error calculating one period/scenario, then no others are calculated.

3. Select or clear the Stop calculating after sequence number option. If applicable, specify the sequence number.
For more information, see Driver sequencing.

4. Select **Force Calculate** to perform calculations even if a flag says that calculations are up to date.

   To speed processing, SAS Cost and Profitability Management skips calculating if the calculations are up to date. Use this option to perform the calculations even if they are already available.

5. Select **Disable Driver Rules** if you want calculation to ignore the rule formula attached to any rule-based driver.

   You can choose this option to disable driver rules to speed up calculation if you have previously done a calculation that has already created the driver assignments for rule-based drivers.

   If you do not select this option to disable driver rules, then calculation evaluates for which potential destination accounts the driver's formula tests true and creates an assignment from the source account to each such destination account. And, calculation evaluates for which potential destination accounts the driver's formula test false and deletes the assignment to that account if the assignment exists. This means that if you have previously allowed calculation to create assignments and subsequently you removed some of those assignments from the source account or created additional assignments to other destination accounts, then those manually created assignments will be undone and you will have to do them over again.

   *Note:* You can also turn off the formula for individual drivers by deselecting Use Rule Formula in the Driver Properties dialog box.

6. Select the number of error and warning messages to be displayed.

7. Click **OK**.
Part 18

Generating Cubes

Chapter 63  
What is a Cube? .............................................. 537

Chapter 64  
Incremental Cube Generation .............................. 543

Chapter 65  
Windows for Cube Generation .............................. 547

Chapter 66  
How To: Generating and Managing Cubes .................. 549
Chapter 63
What is a Cube?

Introduction
Cubes
Fact Tables
Generating Cubes
OLAP Analyzer Performance
Predefined Cubes
Resource Contributions Cube
Single-stage Contributions Cube
Multi-stage Contributions Cube
Summary
Using the Cubes with Other Software
Cognos PowerPlay
Microsoft Excel

A cube is the basic unit of analysis: it represents a particular domain of inquiry in online analytical processing (OLAP). A cube contains a subset of model data, such as single-stage contributions, multi-stage contributions, or resource contributions. Each cube combines multiple dimensions and the measures that the dimensions contain into one unit. SAS Cost and Profitability Management cubes are standard OLAP cubes.

You use SAS Cost and Profitability Management to connect to the cubes on a SAS Cost and Profitability Management server and to interact with these cubes. After generating cubes, you can then manipulate these cubes in the OLAP Analyzer to interactively analyze data.

In an analysis grid, a cube's dimensions determine the columns and rows. The measures are the data in the cells of the rows and columns.

A cube in which costs are indexed by two dimensions (for example, customer and product) is a two-dimensional cube. A cube in which costs are indexed by three dimensions (for example, region, customer, and product) is a three-dimensional cube.

It does not matter how many dimensions a cube has; the storage unit is still a cube, and the cube represents n dimensions of data. A cube enables you to perform
multidimensional data analysis. You extract useful knowledge from an n-dimensional cube, and you represent the knowledge so that it can be easily understood.

In a cube, measures are aggregated within a single dimension and for all combinations of dimension members from different dimensions. These aggregations enable you to analyze measures by dimension members in different dimensions simultaneously. For example, you can analyze quarterly costs for products within a region.

**Fact Tables**

Each cube is based on a fact table, which stores model data for the cube. When you generate a cube, the fact table is generated first. Then, the cube is created from the fact table.

To make your data analysis capabilities more flexible, you can choose to generate a fact table without generating the associated cube. You can use the fact table to generate a customized cube in another application, such as SAS OLAP Cube Studio or Microsoft Analysis Services.

*Note:* When you generate a fact table, SAS Cost and Profitability Management determines whether any model data has changed since the last time the model was calculated. If any model data has changed, the period/scenario association is calculated to ensure that the model data is correct. You can force the costs to be calculated.

**Generating Cubes**

After you calculate costs, you can generate cubes to analyze a model with the SAS OLAP Analyzer.

*Note:* When you generate a cube, SAS Cost and Profitability Management determines whether any model data has changed since the last time the model was calculated. If any model data has changed, the period/scenario association is calculated to ensure that the model data is correct. You can force the costs to be calculated.

When SAS Cost and Profitability Management generates cubes, it performs calculations that pre-aggregate numeric data to give you faster performance when you work on the OLAP view. For large models, pre-aggregating data for cubes can take many hours to complete.

The following factors are listed in order, from those that take more time to generate a cube, to those that take less time:

- the number of stages
- the number of dimensions
- the length of assignment paths

*Note:* Assignment paths should contain fewer than 10 items.

- the number of accounts and the number of assignment paths

*Note:* Whenever you generate cubes, cubes that were generated previously are no longer available for viewing.
**OLAP Analyzer Performance**

If the SAS Cost and Profitability Management server does not finish pre-aggregating data during cube generation, some data might be aggregated while you are using the OLAP Analyzer. This can result in poor performance. Therefore, you might want to increase the server's default time limit (about 10 hours) for pre-aggregating data. To increase the default time limit, contact your regional SAS Technical Support for assistance.

---

**Predefined Cubes**

**Resource Contributions Cube**

The Resource Contributions cube enables you to analyze resource costs that contribute to a product, customer, service cost, and so on. Or, use this cube to analyze the products, customers, service costs, and so on, that receive costs from resources.

The Resource Contributions cube enables you to study cost contributions from original accounts where costs were entered to final accounts that do not assign costs to other accounts. Generally, these cost contributions are from resource accounts to cost object accounts, but where the original or final accounts reside does not matter.

**Note:** The Resource Contributions cube contains only the costs of the first account in an assignment path and the costs of the last account. It does not contain the intermediate accounts and their costs.

Use the Multi-stage Contributions cube to analyze cost contributions to or from accounts that are tagged with stages attributes.

Use the Single-stage Contributions cube to analyze the cost contributions from one assignment level back.

**Single-stage Contributions Cube**

The Single-stage Contributions cube enables you to answer questions such as:

- Which activity costs contribute to product, customer, service cost, and so on?
- When costs are assigned within the Cost Object module, which sub-assembly costs contribute to product costs?
- What are the costs of resources that contribute to activities?

The Single-stage Contributions cube enables you to analyze the cost contributions from one assignment level back. Where costs originate or end does not matter. Typically, cost is contributed from:

- Activities to cost objects
- Resources to activities

You do not need to add stages attributes to accounts; you can use each module as a stage.

Use the Resource Contributions cube to analyze costs contributions from original accounts where costs were entered to final accounts that do not assign costs to other accounts.
Use the Multi-stage Contributions cube to analyze cost contributions to or from accounts that are tagged with stages attributes.

**Multi-stage Contributions Cube**

The Multi-stage Contributions cube enables you to address issues and answer questions such as:

- Product A is not profitable. I want to trace the costs back through activities and then to resources that contribute costs to this product.
- What are the costs for Product B that originate in salary resources and are assigned through the Inspection activity to this product?

The Multi-stage Contributions cube enables you to analyze cost contributions into and out of stages defined in a model. You can define each module as a stage or you can use stages attributes. The SAS OLAP Analyzer Cube Explorer View enables you to visually trace cost contributions through all the stages.

Use the Resource Contributions cube to analyze costs contributions from original accounts where costs were entered to final accounts that do not assign costs to other accounts.

Use the Single-stage Contributions cube to analyze the cost contributions from one assignment level back.

**Summary**

Using the Parcel Express Tutorial model as an example, the following picture shows for each type of cube the elements that are available in the SAS OLAP Analyser for adding to rows or columns.
Using the Cubes with Other Software

**Cognos PowerPlay**

To open SAS Cost and Profitability Management cubes with Cognos PowerPlay, see the Cognos online document titled *OLAP Server Connection Guide*. The chapter “Connect to Microsoft SQL Server OLAP Services” describes the procedure and concepts in detail.

The SAS Cost and Profitability Management Administrator can give you the model ID for each model. Instructions are in the “SAS Cost and Profitability Management Installation Checklist.”

If you require additional help after reviewing the Cognos documentation, please contact your regional SAS Technical Support.

**Microsoft Excel**

You can export a cube to Microsoft Excel and then modify, print, or save the data.
Incremental Cube Generation

Now, when you generate a cube, for every period/scenario association that is to be included in an existing cube, if

- the cube already contains that period/scenario association, and
- the period/scenario association has not been modified since the cube was last generated

then the period/scenario association is not regenerated. This means that cube generation is faster because periods that have already been generated are not regenerated.

In order to support incremental cube generation, SAS Cost and Profitability Management provides a new **Periodic data only** option in the Import Wizard that allows you to import only the periods that have changed in a model (for example, the new periods).

*Note:* Incremental cube generation is not supported for a Postgres database with SAS OLAP.
If you select **Periodic data only**, then only those staging tables that contain periodic data are displayed in the Import Wizard for you to select for importing.

Staging tables are distinguished by whether they contain periodic or structural data. Periodic data is model data that is stored separately for each period/scenario association. Structural data is model data that is independent of any period/scenario association. It is data that is common to all period/scenario associations.

The following table lists staging tables that contain periodic data and those that contain structural data:

<table>
<thead>
<tr>
<th>Periodic data</th>
<th>Structural data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account</td>
<td>Dimension</td>
</tr>
<tr>
<td>Assignment</td>
<td>DimensionMember</td>
</tr>
<tr>
<td>CurrencyRate</td>
<td>DimensionLevel</td>
</tr>
<tr>
<td>ExternalUnit</td>
<td>DimensionOrder</td>
</tr>
<tr>
<td>EnteredCostElement</td>
<td>Driver</td>
</tr>
<tr>
<td>ValueAttributeAssociation</td>
<td>ValueAttributes</td>
</tr>
<tr>
<td>ValueAttributePeriodicDef</td>
<td>Period</td>
</tr>
<tr>
<td>DimensionalAttributeAssociation</td>
<td>PeriodLevel</td>
</tr>
<tr>
<td></td>
<td>Scenario</td>
</tr>
<tr>
<td></td>
<td>ScenarioLevel</td>
</tr>
</tbody>
</table>

When you generate a cube for a model that has been generated before, SAS Cost and Profitability Management determines whether the entire cube must be regenerated or
whether only the new or modified periods need to be generated. You do not have to specify, when you generate a cube, whether you want incremental generation or not. SAS Cost and Profitability Management makes the determination for you.

Note: If you are using Microsoft Analysis Services for cubes, then incremental cube generation is available only if you are using either Microsoft SQL Server Enterprise or Microsoft SQL Server Developer. Incremental cube generation is not available with Microsoft SQL Server Standard.

Note: If you are using SAS OLAP for cubes, then incremental cube generation is not available under certain circumstances because SAS OLAP does not allow deleting or updating a Period/Scenario inside a cube. For example, if you have generated a cube containing a Period/Scenario which you subsequently modify inside the model, then when you regenerate the same cube, adding a new Period/Scenario, the entire cube must be regenerated because the previously generated Period/Scenario can neither be deleted nor updated. When you generate a cube using SAS OLAP, SAS Cost and Profitability Management determines whether it can use incremental cube generation or whether it must regenerate the entire cube.

Note: Cubes in SAS OLAP that are generated using either the NO_NWAY option or the NONUPDATEABLE option are not eligible for incremental generation. See “Cube Options for SAS OLAP” on page 489. Also see The OLAP Procedure in the SAS OLAP Server: User's Guide for more information: http://support.sas.com/documentation/onlinedoc/olap/index.html.

Note: With the implementation of incremental cube generation, OLAP views that were saved in a previous release of SAS Cost and Profitability Management will no longer work in SAS Cost and Profitability Management 7.2 if you are using Microsoft Analysis Services to build the cube. This is because the saved view is an MDX query, and the period names embedded in the query are no longer correct.
Chapter 65
Windows for Cube Generation

Generate Cubes

How to Generate a Cube

Use the Generate Cubes dialog box to generate a cube and/or fact table for a model.

1. Open the model for which you want to generate cubes.

2. Select Model ➔ Generate Cubes. The Generate Cubes dialog box opens.

3. Select the cube configurations to use. Each cube configuration generates a single cube.

See “Create a Cube Configuration” on page 481.
4. Select **Force Cube Generate** to generate the cubes even though they have already been generated. See “Incremental Cube Generation” on page 543.

5. Select either a period/scenario association or **Select All**.

6. Select how many error and warning messages to display.

7. Click **Count Rows** to count the number of rows in the cube to be generated. This gives you an idea of how long it will take to generate the cube. (It is not required to count the rows before generating.)

---

**How to Access the Generate Cubes Dialog Box**

1. Open a model.

2. Select **Model ⇒ Generate Cube**

*Note:* Before you can generate a cube, you must have created a cube configuration that contains your options for generating the cube or fact table.

**See Also**

- “Generate Cubes” on page 547
- “Create a Cube Configuration” on page 481
Chapter 66
How To: Generating and Managing Cubes

Generate Cubes

How to Generate a Cube
How to Access the Generate Cubes Dialog Box
Include Numeric Attributes in a Cube
Display the Internal Name of a Cube
Delete a Cube or Fact Table
Manage Cube Permissions

How to Generate a Cube

Use the Generate Cubes dialog box to generate a cube and/or fact table for a model.

1. Open the model for which you want to generate cubes.
2. Select Model ⇒ Generate Cubes. The Generate Cubes dialog box opens.
3. Select the cube configurations to use. Each cube configuration generates a single cube. See “Create a Cube Configuration” on page 481.

4. Select Force Cube Generate to generate the cubes even though they have already been generated. See “Incremental Cube Generation” on page 543.

5. Select either a period/scenario association or Select All.

6. Select how many error and warning messages to display.

7. Click Count Rows to count the number of rows in the cube to be generated. This gives you an idea of how long it will take to generate the cube. (It is not required to count the rows before generating.)

**How to Access the Generate Cubes Dialog Box**

1. Open a model.

2. Select Model ⇒ Generate Cube

*Note:* Before you can generate a cube, you must have created a cube configuration that contains your options for generating the cube or fact table.

**See Also**

- “Generate Cubes” on page 549
- “Create a Cube Configuration” on page 481
Include Numeric Attributes in a Cube

To include numeric attributes in a cube:


2. Select the numeric attributes to be included in the cube.

   When you generate a cube, then the numeric attributes that you select are included in the cube.

You can select the numeric attributes that are to be checked by default in a new cube configuration by doing the following:

1. Open a model and select Model > Properties.
2. Select the Attributes in Cube tab.
3. Select the numeric attributes that are to be checked by default in a new cube configuration for that model.

Attributes that you select in Model Properties are automatically checked in a new cube configuration to be included in the generated cube. However, you can uncheck the attributes in the cube configuration and select others before generating the cube.

See Also

“Cube Configuration: Select Numeric Attributes” on page 491

Display the Internal Name of a Cube

Instead of using SAS Cost and Profitability Management to view a generated cube, you can use SAS Enterprise Guide, SAS Web Report Studio, or SAS OLAP Cube Studio. Or you can use a third party tool other than SAS to view a cube and its fact table. Fact
tables are stored in the database and cubes are stored in the OLAP server. To open a fact table or cube you need to know its internal name.

*Note:* Using a program other than SAS Cost and Profitability Management to modify a cube that has been generated by SAS Cost and Profitability Management can affect display of the cube inside of SAS Cost and Profitability Management.

To display the internal name of a fact table or cube:

1. Open the model for whose fact tables or cubes you want to display the internal name.
2. Select **Model ➔ Manage Cubes and Permissions**.
   The Manage Cubes and Permissions dialog box opens.
   
   *Note:* For managing Microsoft Analysis Services cubes, you must have logged onto SAS Cost and Profitability Management having specified a domain name—for example, domain123/userxyz.
3. Select the fact table or cube whose internal name you want to display.
   
   *Note:* You can select only one row at a time.
4. Click **Internal names**. A dialog box opens displaying the internal names.
   
   *Note:* The internal name is composed by concatenating the model ID with the cube ID, separated by an underscore.

---

**Delete a Cube or Fact Table**

1. Open the model whose cubes or fact tables you want to delete.
2. Select **Model ➔ Manage Cubes and Permissions**.
   
   The Manage Cubes and Permissions dialog box opens.
3. Select the cube or fact table that you want to delete.
   
   Note: You can delete only one cube or fact table at a time.

4. Click **Delete**.

---

**Manage Cube Permissions**

After creating a cube, you can change its owner, and add or remove Read access to it.

To manage cube permissions:

1. Open the model for whose cubes you want to manage permissions.

2. Select **Model ⇒ Manage Cubes and Permissions**.
   
   The Manage Cubes and Permissions dialog box opens.
For managing Microsoft Analysis Services cubes, you must have logged onto SAS Cost and Profitability Management having specified a domain name—for example, domain123/userxyz.

3. Select the cube whose permissions you want to change.

   Note: You can change only one cube at a time.

4. Click Permissions. The Permissions dialog box opens.

5. You can add or remove Read access to groups. All members of the group inherit the permissions that you select for that group.

See Also

“Display the Internal Name of a Cube” on page 551
Part 19

OLAP Analysis

Chapter 67
Using the Analysis Workspace ........................................ 557

Chapter 68
Analysis Workspace Windows ........................................ 561

Chapter 69
How To: Analysis Workspace ......................................... 565
Chapter 67
Using the Analysis Workspace

Analysis Workspace

About the Analysis Workspace
In the Analysis workspace, you can open an OLAP view.

Note: The availability of these features depends on your permissions.
The list of Folders and the list of OLAP Views correspond to the OLAP branch of the server area in Workspace Manager.

**How to Access the Analysis workspace**

Do one of the following:

- If no OLAP view is open, click **Analysis** in the Navigation Pane.

- If an OLAP view is already open, click the **Go to Analysis Workspace** icon in the toolbar.

**See Also**

- “Create an OLAP View” on page 566
- “Open an OLAP View” on page 566

---

**OLAP Views**

**About OLAP Views**

OLAP is a technology that is used to create decision-support software. OLAP enables users to quickly analyze data that has been summarized into multidimensional views and hierarchies. By summarizing predicted queries into multidimensional views and hierarchies before run time, SAS Cost and Profitability Management's OLAP tool provides the benefit of increased performance over traditional database access tools. Most of the resource-intensive calculation that is required to summarize the data is done before a query is submitted.

You use the OLAP Analyzer to open and view an OLAP cube. See “OLAP Analyzer” on page 561.

**Cube Availability**

When you try to display a cube in an OLAP view, the following situations might cause the cube to be unavailable:

- Another user is currently regenerating the cube.
- The cube on which a saved OLAP view is based has been deleted.
SAS OLAP Limitations

The following restrictions exist in the SAS OLAP Server:

- Most OLAP names can be up to 32 characters in length except for aggregation names that can be up to 256 characters. When SAS processes a name it will be uppercased.
- Level names must be unique within a cube.
- Measure names must be unique within a cube.
- Number of dimensions: Maximum 128 (Minimum 1).
- Number of levels per dimension: Maximum 19.
- Number of levels per cube: Maximum 256.
- Number of measures per cube: Maximum 1024.
- Maximum length of a unique name is 32767 characters.
- Size of the MDX string is unlimited, but extremely long strings can affect performance.
Chapter 68
Analysis Workspace Windows

OLAP Analyzer

About the OLAP Analyzer ........................................... 561
How to Access the OLAP Analyzer ................................. 562

Save OLAP View As Dialog Box ................................. 562
About the Save OLAP View As Dialog Box .................. 562
How to Access the Save OLAP View As Dialog Box ........ 562

Change Cube Context Dialog Box ............................ 563
About the Change Cube Context Dialog Box ................. 563
How to Access the Change Cube Context Dialog Box ....... 563

OLAP Analyzer

About the OLAP Analyzer

With the OLAP analyzer you can study measures at dimension intersections by creating an OLAP view. You can analyze dimensions and measures in Grid View, Chart View, and Cube Explorer View.

Note: For the most information on the OLAP Analyzer, Press F1 for help while working in the analyzer, or select Help ➔ SAS OLAP Analyzer Help.
The predefined cube that you choose determines which dimensions and measures are available to you, as well as what kinds of analyses you can perform.

**Note:** Models are not displayed in the **Model** menu until you generate the model's cubes.

**How to Access the OLAP Analyzer**

Open an OLAP view in the Analysis Workspace. See “Open an OLAP View” on page 566.

**See Also**

“SAS OLAP Limitations” on page 559

---

**Save OLAP View As Dialog Box**

**About the Save OLAP View As Dialog Box**

In the Save OLAP View As dialog box, you can save a customized OLAP view.

**How to Access the Save OLAP View As Dialog Box**

Open an OLAP view and select **Analysis ⇒ Save View As**.
Change Cube Context Dialog Box

About the Change Cube Context Dialog Box

Use this dialog box to select a different cube to view for the currently open model or to select a different cube of a different model.

How to Access the Change Cube Context Dialog Box

Select Analysis ⇒ Change cube context.

Note: You must be in the Analysis Workspace with a cube view currently open for this menu item to be available.

See Also

“Analysis Workspace” on page 557
Chapter 69

How To: Analysis Workspace

Use the SAS OLAP Analyzer .................................................... 565
Create an OLAP View .......................................................... 566
Open an OLAP View ........................................................... 566
  Open an OLAP View with No OLAP View Open ......................... 566
  Open an OLAP View with an OLAP View Already Open ............... 567
Save an OLAP View ............................................................. 567
Change the Appearance of an OLAP Window .......................... 568
Show or Hide the Cube View Manager ........................................ 568
Open the View Editor ............................................................ 568
Open the MDX Editor ........................................................... 568
Export a Cube ........................................................................ 568
Print an OLAP View ............................................................... 569

Use the SAS OLAP Analyzer

SAS Cost and Profitability Management uses the SAS OLAP Analyzer to view cubes. With the SAS OLAP Analyzer, you can analyze dimensions and measures in a grid view, a chart view, and a Cube Explorer View. The predefined cube that you choose determines which dimensions and measures are available to you, as well as what types of analyses you can perform. You can view data in one or two windows, depending on your needs. The OLAP toolbar buttons that are available to you depend on which window is selected and on what type of information is displayed in the window.

Note: Models are not displayed in the Model drop-down list of the OLAP Analyzer until you generate the model's cubes.

The SAS OLAP Analyzer is usually part of SAS Enterprise Guide, which you might not have installed on your system. (Even if you don't have SAS Enterprise Guide, you do have the SAS OLAP Analyzer as part of SAS Cost and Profitability Management.) The help for SAS OLAP Analyzer includes help for SAS Enterprise Guide.

You can open the Help for SAS OLAP Analyzer from the Help menu of SAS Cost and Profitability Management.
Create an OLAP View

1. Select File ➔ New ➔ OLAP View.

   The New OLAP View Wizard appears.

2. From the Select the model you want to use drop-down list, select a model.

3. From the Select the cube you want to base the view on drop-down list, select a cube.

   The list contains only those cubes that have been generated.

4. If the cube contains a large amount of data and you want to quickly create the OLAP view, select the Do not select any dimensions by default option.

Open an OLAP View

Open an OLAP View with No OLAP View Open

If you open the Analysis workspace without an OLAP view open, you can open an OLAP view from the list of views in the workspace. The list of Folders and OLAP Views corresponds to the OLAP branch of the server area in Workspace Manager.

1. From the list of Folders, select a folder.

2. From the list of OLAP Views, click a view.
Open an OLAP View with an OLAP View Already Open

If an OLAP view is already open in the Analysis workspace and you want to open a different view, do one of the following:

- Select an OLAP view from the **Cube View** drop-down list.
- Click the Go to Analysis Workspace button and select another OLAP view.

Save an OLAP View

To save an OLAP view, do the following:

1. Go to the Analysis workspace.
2. Open an OLAP view.
3. Click **Save the current OLAP view**, or **Save to a new OLAP view**.

Once an OLAP view has been saved, open it from the Analysis workspace.

When you save an OLAP view, all of the following are saved:

- the cube
- the model
- the OLAP view's layout
- the OLAP view's contents
During analysis, changes that you make to a grid view, a chart view, and the Cube Explorer View are retained during a session, even when you return to the OLAP view after viewing other tabs. However, your changes are lost when you close SAS Cost and Profitability Management or when you close a grid view, a chart view, or the Cube Explorer View.

If you want these changes to be available later, save the OLAP view. However, the window positions and window states are not saved.

### Change the Appearance of an OLAP Window

1. Open an OLAP view on the Analysis workspace.
2. First, click a window's title bar.
   a. To display a grid, select OLAP \(\rightarrow\) Grid.
   b. To display a chart, select OLAP \(\rightarrow\) Chart \(\rightarrow\) <type of chart>.
   c. To display a Decomposition Tree, select OLAP \(\rightarrow\) Decomposition Tree.
   d. To display a perspective view, select OLAP \(\rightarrow\) Perspective.

### Show or Hide the Cube View Manager

Select Analysis \(\rightarrow\) View Manager.

A check indicates that View Manager is displayed.

### Open the View Editor

Select Edit View \(\rightarrow\) Edit with View Editor.

The View Editor allows you to create OLAP views by dragging and dropping dimensions and measures into the view.

### Open the MDX Editor

Select Edit \(\rightarrow\) Edit with MDX Editor.

The Edit MDX Statement dialog box appears.

### Export a Cube

Select Analysis \(\rightarrow\) Export To Excel.

Microsoft Excel opens and displays the exported data.
Print an OLAP View

From the Print menu, select Print Preview or Print.
Part 20

Conducting Surveys

Chapter 70
What are Surveys? .............................................................. 573

Chapter 71
Windows for Surveys ......................................................... 577

Chapter 72
How To: Surveys ............................................................... 581
Chapter 70
What are Surveys?

Introduction to Surveys

One of the most difficult tasks in maintaining a model is keeping its data accurate and up-to-date. Now you can create surveys to solicit data from the people who are directly responsible for the activities and accounts in your model. You can export the data from the surveys, update the data, and import it in the form Microsoft Excel.

Types of Surveys

The following table shows the types of surveys that you can create for each module and the fields that a survey taker can update for each type of survey.

<table>
<thead>
<tr>
<th>Type of Survey</th>
<th>Fields That Can Be Updated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Driver</td>
<td>Assignment.DriverQuantityFixed</td>
</tr>
<tr>
<td></td>
<td>See “Assignment table” in Chapter 6 of SAS Cost and Profitability Management: Data Administration Guide.</td>
</tr>
<tr>
<td>Entered Cost and Entered Unit Cost Survey</td>
<td>EnteredCostElement.EnteredUnitCost EnteredCostElement.EnteredCost</td>
</tr>
<tr>
<td></td>
<td>See “EnteredCostElement table” in Chapter 6 of SAS Cost and Profitability Management: Data Administration Guide.</td>
</tr>
</tbody>
</table>
The Survey Process in a Nutshell

The following steps summarize the process for using surveys:

1. A modeler exports the data of a model using a Microsoft Excel file.
2. A modeler shares the Microsoft Excel file with the required people to solicit feedback on the survey data.
4. A survey taker sends the Microsoft Excel file to the modeler.
   • The survey taker can modify the values of the `DriverQuantityFixed` column while taking the Driver survey. The columns other than `DriverQuantityFixed` are write-protected.
   • The survey taker can modify the values of the `NumericValue` or `StringValue` columns while taking the Attribute survey. The columns other than `NumericValue` or `StringValue` are write-protected.
   • The survey taker can modify the values of the `EnteredCost` or `EnteredUnitCost` columns while taking the Entered Cost or Entered Unit Cost survey. The columns other than `EnteredCost` or `EnteredUnitCost` are write-protected.
   • The survey taker can modify the values of the `OutputQuantityUE` column while taking the Output Quantities survey. The columns other than `OutputQuantityUE` are write-protected.

Note: Be sure to install Microsoft Office on the client machine.
   • When Microsoft Office is installed, the appropriate columns are write-protected and visible. You can edit only one column, depending on the type of survey.
   • If Microsoft Office is not installed, then all the columns of the table are visible and not protected.
   • If Microsoft Office is not installed, the user cannot export the survey in a .xlsx file. The user will see the following message: The application could not connect to Microsoft Excel. Microsoft Excel may not be registered or installed on this machine. Please contact your system administrator.
5. A modeler imports the Microsoft Excel file in SAS Cost and Profitability Management to update the model data.
Chapter 71
Windows for Surveys

Export Survey Wizard

About the Export Survey Wizard
Use the Export Survey wizard to export a model’s data for conducting a survey. When you export the data of a model for conducting a survey, you select the following data:

- period and scenario associations, and module
- type of the survey (such as attribute, driver)
- location of the survey

The model’s data is exported in a Microsoft Excel sheet at the specified location. You can share the Microsoft Excel sheet with all survey respondents to seek responses.

Open the Survey Export Wizard
Select File ⇄ Export ⇄ Survey Model Data. The Survey Export wizard appears. Specify the values on each step of the wizard and click Next to proceed. The following sections of the chapter explain the different steps of the Survey Export wizard.

Step 1: Specify Model Name, Period and Scenarios, and Module
1. In the Select a model to export list, select a model.
2. In the Select period/scenario associations that you want to export box, select the period and scenarios for which you want to export data of the model.
Click Select All to select all periods and scenarios. Click Clear All to clear all the selections that you made.

3. In the Select a module list, select a module.

4. Click Next.

**Step 2: Specify the Survey Type**

In the Type of survey list, select the type of survey that you want to conduct. You can select one of the following types of survey: Driver, Attribute, Entered Cost and Entered Unit Cost, and Output Quantities.

Based on survey type that you select in this step, the options in the next step differ.

**Step 3: Define the Scope of the Survey**

1. Perform one of the following actions:
   - If you selected Driver in the Type of survey list in “Step 2: Specify the Survey Type” on page 578, perform the following steps to define the scope of the survey:
     1. In the Drive name list, select the name of the driver.
     2. Click Select dimension member and then choose the dimension members for whom you want to conduct the survey. Alternatively, click All dimension members to choose all dimension members in the survey.
   - If you selected Attribute in the Type of survey list in “Step 2: Specify the Survey Type” on page 578, perform the following steps to define the scope of the survey:
     1. In the Attribute type list, select the type of the attribute for which you want to conduct the survey.
     2. In the Attribute name list, select the name of the attribute that you want to include in the survey.
   - If you selected Entered Cost and Entered Unit Cost in the Type of survey list in “Step 2: Specify the Survey Type” on page 578, click Select dimension member and then choose the dimension members for whom you want to conduct the survey. Alternatively, click All dimension members to choose all dimension members in the survey.
   - If you selected Output Quantities in the Type of survey list in “Step 2: Specify the Survey Type” on page 578, click Account name contains and then type the first few characters of the account name in the box to include the account in the survey. Alternatively, click Dimension member reference to select the dimensions of your choice in the survey. If you click Dimension member reference, click Select dimension member, and then choose the dimension members for whom you want to conduct the survey. Or click All dimension members to choose all dimension members in the survey.

2. Click Next.
**Step 4: Specify Location**

Click **Browse** to specify a location. The Survey Export - Connection Details dialog box appears. The following table describes the fields of the Survey Export - Connection Details dialog box.

**Table 71.1 Description of Fields of Survey Export - Connection Details Dialog Box**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File path</strong></td>
<td>The file path where you want to create the Microsoft Excel file to export survey data. The file path that you enter must have read/write permission.</td>
</tr>
<tr>
<td><strong>Driver type</strong></td>
<td>The type of the driver that you want to use for exporting or importing the Microsoft Excel file.</td>
</tr>
<tr>
<td><strong>Provider</strong></td>
<td>The provider that you must be used with Microsoft Excel. Generally, the Microsoft.ACE.OLEDB.12.0 is used with Microsoft Office.</td>
</tr>
<tr>
<td><strong>Advanced options</strong></td>
<td>The extended or advanced properties that can be used with Microsoft Excel file.</td>
</tr>
<tr>
<td><strong>Test Connection</strong></td>
<td>Click this button to test the database connection. This is an optional button.</td>
</tr>
<tr>
<td><strong>OK</strong></td>
<td>Click this button to save the details.</td>
</tr>
<tr>
<td><strong>Cancel</strong></td>
<td>Click this button to close the dialog box without saving the details that you specified.</td>
</tr>
</tbody>
</table>

Click **Browse** to select the file path and enter the file name. You can select .xls or .xlsx file type. To save the file, click **OK**.

**Step 5: Review Summary**

1. Review the export survey summary.
2. If you need to change any information, click **Back** until you reach the step that you need to change in the wizard. All of the information that you have specified is saved. Click **Next** to advance through the wizard.
3. To save the export survey configuration so that the export survey can be easily run again, do the following:
   a. Select the **Save configuration as** option.
   b. Enter the **Name**.
   c. Enter the **Description**.
4. Select **Save without running** to export the survey configuration with performing the import.
5. Click **Finish**.
Chapter 72
How To: Surveys

Export the Data of a Model for Conducting a Survey

Open the Survey Export Wizard
Select File ⇒ Export ⇒ Survey Model Data. The Survey Export wizard appears. Specify the values on each step of the wizard and click Next to proceed. The following sections of the chapter explain the different steps of the Survey Export wizard.

Step 1: Specify Model Name, Period and Scenarios, and Module
1. In the Select a model to export list, select a model.
2. In the Select period/scenario associations that you want to export box, select the period and scenarios for which you want to export data of the model.
   Click Select All to select all periods and scenarios. Click Clear All to clear all the selections that you made.
3. In the Select a module list, select a module.
4. Click Next.

Step 2: Specify the Survey Type
In the Type of survey list, select the type of survey that you want to conduct. You can select one of the following types of survey: Driver, Attribute, Entered Cost and Entered Unit Cost, and Output Quantities.

Based on survey type that you select in this step, the options in the next step differ.
Step 3: Define the Scope of the Survey

1. Perform one of the following actions:
   - If you selected **Driver** in the **Type of survey** list in “Step 2: Specify the Survey Type” on page 581, perform the following steps to define the scope of the survey:
     1. In the **Drive name** list, select the name of the driver.
     2. Click **Select dimension member** and then choose the dimension members for whom you want to conduct the survey. Alternatively, click **All dimension members** to choose all dimension members in the survey.
   - If you selected **Attribute** in the **Type of survey** list in “Step 2: Specify the Survey Type” on page 581, perform the following steps to define the scope of the survey:
     1. In the **Attribute type** list, select the type of the attribute for which you want to conduct the survey.
     2. In the **Attribute name** list, select the name of the attribute that you want to include in the survey.
   - If you selected **Entered Cost and Entered Unit Cost** in the **Type of survey** list in “Step 2: Specify the Survey Type” on page 581, click **Select dimension member** and then choose the dimension members for whom you want to conduct the survey. Alternatively, click **All dimension members** to choose all dimension members in the survey.
   - If you selected **Output Quantities** in the **Type of survey** list in “Step 2: Specify the Survey Type” on page 581, click **Account name contains** and then type the first few characters of the account name in the box to include the account in the survey. Alternatively, click **Dimension member reference** to select the dimensions of your choice in the survey. If you click **Dimension member reference**, click **Select dimension member**, and then choose the dimension members for whom you want to conduct the survey. Or click **All dimension members** to choose all dimension members in the survey.

2. Click **Next**.

Step 4: Specify Location

Click **Browse** to specify a location. The Survey Export - Connection Details dialog box appears. The following table describes the fields of the Survey Export - Connection Details dialog box.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File path</td>
<td>The file path where you want to create the Microsoft Excel file to export survey data. The file path that you enter must have read/write permission.</td>
</tr>
<tr>
<td>Driver type</td>
<td>The type of the driver that you want to use for exporting or importing the Microsoft Excel file.</td>
</tr>
</tbody>
</table>
### Field Description

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Provider</strong></td>
<td>The provider that you must be used with Microsoft Excel. Generally, the Microsoft.ACE.OLEDB.12.0 is used with Microsoft Office.</td>
</tr>
<tr>
<td><strong>Advanced options</strong></td>
<td>The extended or advanced properties that can be used with Microsoft Excel file.</td>
</tr>
<tr>
<td><strong>Test Connection</strong></td>
<td>Click this button to test the database connection. This is an optional button.</td>
</tr>
<tr>
<td><strong>OK</strong></td>
<td>Click this button to save the details.</td>
</tr>
<tr>
<td><strong>Cancel</strong></td>
<td>Click this button to close the dialog box without saving the details that you specified.</td>
</tr>
</tbody>
</table>

Click **Browse** to select the file path and enter the file name. You can select .xls or .xlsx file type. To save the file, click **OK**.

## Step 5: Review Summary

1. Review the export survey summary.

2. If you need to change any information, click **Back** until you reach the step that you need to change in the wizard. All of the information that you have specified is saved. Click **Next** to advance through the wizard.

3. To save the export survey configuration so that the export survey can be easily run again, do the following:
   a. Select the **Save configuration as** option.
   b. Enter the **Name**.
   c. Enter the **Description**.

4. Select **Save without running** to export the survey configuration with performing the import.

5. Click **Finish**.
Part 21

Importing and Exporting

Chapter 73
Connecting to a Database ........................................ 587

Chapter 74
Import Model Data from a Database .......................... 597

Chapter 75
Import a Model from an XML File ............................. 615

Chapter 76
Import Surveys ..................................................... 619

Chapter 77
Export Model Data .................................................. 621

Chapter 78
Cube Configurations ............................................... 641

Chapter 79
Column Layouts ..................................................... 643

Chapter 80
Export Module Views to Excel ................................. 645

Chapter 81
OLAP Views ......................................................... 655

Chapter 82
Export Registered Tables ........................................ 659

Chapter 83
Import and Export with Easy API ............................ 667
Chapter 73

Connecting to a Database

Overview

For importing or exporting, you can connect to a database using either a:

**server-side driver**

To use a server-side driver, you must have installed, on the IOM server machine, a 64-bit ODBC driver or the native driver for a particular database.

**client-side Microsoft Office driver**

To use a client-side Microsoft Office driver, you must have installed a 32-bit ODBC driver on the SAS Cost and Profitability Management client machine. See “Installing the ODBC Driver for Microsoft Access and Excel” on page 590.

To connect to a database:

1. From the File menu, select either to import or to export model data:
   - File ➔ Import ➔ Model Data
   - File ➔ Export ➔ Model Data
2. Select Database.
3. Click Browse.
   The Connection Information dialog opens.
Client-Side Microsoft Office Driver

You can import from or export to Microsoft Access and Microsoft Excel using a client-side driver. This has the advantage that you can now import from or export to client installations of Microsoft Office even if your SAS Cost and Profitability Management server is on a UNIX system where the Microsoft Office drivers would not work.

Microsoft Access

The following picture shows an example of connecting to Microsoft Access. The file path that you enter should have READ/WRITE permission.
Note:

- You must have installed a 32-bit ODBC driver on the SAS Cost and Profitability Management client machine. See “Installing the ODBC Driver for Microsoft Access and Excel” on page 590.
- The file path that you specify is relative to the machine on which the SAS Cost and Profitability Management client is installed.

**Microsoft Excel**

The following picture shows an example of connecting to Microsoft Excel. The file path that you enter should have READ/WRITE permission.

Note:
• You must have installed a 32-bit ODBC driver on the SAS Cost and Profitability Management client machine. See “Installing the ODBC Driver for Microsoft Access and Excel” on page 590.

• It is recommended that you save to a new Excel file rather than replace an already-existing one. If the model being exported contains more columns than the already-existing Excel file, then (because of a limitation with Microsoft Office) export fails with the message “Too many fields defined”—even though, from the server point-of-view, the operation appears to have been successful.

• You can save the Excel file as either *.xls (2003 format) or *.xlsx (2007 format).

• The file path that you specify is relative to the machine on which the SAS Cost and Profitability Management client is installed.

**Installing the ODBC Driver for Microsoft Access and Excel**

You must install 32-bit ODBC driver on the SAS Cost and Profitability Management client machine to import from or export to Access or Excel.

The following providers are supported:

• Microsoft.ACE.OLEDB.12.0 for use with either Microsoft Office 2007 or Microsoft Office 2010

• Microsoft.Jet.OLEDB.4.0 for use with JET

To display a list of ODBC drivers that are already installed, do the following:

1. Select **Start ➔ Control Panel** on the SAS Cost and Profitability Management client machine.

2. Select **Administrative Tools**.

3. Select **Data Sources (ODBC)**.

4. Click the **Drivers** tab.

5. Verify that drivers for Microsoft Access and Microsoft Excel are listed as shown.

If the drivers are not installed, you can install them by running AccessDatabaseEngine.exe, which you can obtain from the Microsoft Download Center at http://www.microsoft.com/downloads/. Because the SAS Activity-Based Management
client is a 32–bit application and can work only with 32–bit drivers, there are four cases to consider when downloading the drivers:

You have not installed Microsoft Office

You have installed Microsoft Office 2007, 32–bit
If you do not already have the drivers, you can download them. On the Microsoft Download Center, search for "2007 Office System Driver: Data Connectivity Components". Or search for "Microsoft Access Database Engine 2010 Redistributable" and select the 32–bit version (the 32–bit driver for Office 2010 works with Office 2007).

You have installed Microsoft Office 2010, 32–bit
If you do not already have the 32–bit drivers, you can download them. On the Microsoft Download Center, search for "Microsoft Access Database Engine 2010 Redistributable" and select the 32–bit version.

You have installed Microsoft Office 2010, 64–bit
If you have installed the 64–bit drivers, then you need to install the 32–bit drivers. However, Microsoft does not allow you to install 32–bit drivers for Office 2010 along with 64–bit drivers. Therefore, you must install the 32–bit drivers from Microsoft Office 2007 instead. On the Microsoft Download Center, search for "2007 Office System Driver: Data Connectivity Components".

Note: The 32–bit drivers for Microsoft Office 2007 do not replace the 64–bit drivers for Microsoft Office 2010, so the 64–bit drivers remain available for use with applications other than SAS Activity-Based Management.

---

**Server-Side Driver with SAS Datasets**

The following picture shows an example of using SAS datasets.

![Connection Information](image)

**Folder path relative to the IOM server**
The folder containing SAS datasets for import or export must be accessible by the SAS IOM Server.

- If the folder is on the same machine as the SAS IOM server, then you can specify the folder using a path such as `c:\datasetexport`. 

If the folder is on a different machine than the SAS IOM server, then you must specify the machine name in specifying the path. For example, if the folder, datasetexport, is on machine XYZ, then you might specify the path as \XYZ\datasetexport.

**TIP** If importing SAS datasets consumes an inordinate amount of RAM, you can sidestep the problem by setting the system variable SAS_NO_RANDOM_ACCESS. To set the system variable, do the following:

1. Stop the SAS Object Spawner service (Start ⇒ All Programs ⇒ Administrative Tools ⇒ Component Services ⇒ Services).
2. Right-click My Computer or Computer and select Properties.
3. Click Advanced system settings to open the System Properties dialog box.
4. On the Advanced tab, click Environment Variables.
5. In the System variables pane (not the User variables pane), click New.
   The New System Variable dialog box appears.
   *Note:* Make sure that the title is New System Variable and not New User Variable.

6. For Variable name, enter SAS_NO_RANDOM_ACCESS.
   For Variable value, enter 1.
7. Click OK.
8. Start the SAS Object Spawner service.

---

**Server-Side Driver with Microsoft SQL Server**

The following picture shows an example of connecting to a Microsoft SQL Server database.
The following are some considerations to keep in mind when connecting to a Microsoft SQL Server database:

**Host name**
the MachineName where the target database is installed from where users want to import or export

**Port**
the TCP port where the target database instance is running

If the database is on a Named Instance, then go to the SQL Server Configuration manager to check the TCP port on which it is running. Named Instances run on a dynamic TCP port.

**Advanced options**
separate multiple options with a semicolon. For example:

```
driver_trace=all;driver_tracefile='c:\temp\trace_lower.log';traceflags=7;
```

**Note:** Use logging options only in case of failures where you want to provide internal driver logs to technical support. Otherwise, logging operations slow your operation.

---

**Server-Side Driver with Oracle**

The following picture shows an example of connecting to an Oracle database.
Following are some considerations to keep in mind when connecting to an Oracle database:

- **Host name** is the MachineName where the target database is installed from where you want to import or export.
- **Port** is the TCP port where the target database instance is running.
  
  *Note:* The Oracle client should be installed on the machine on which SAS IOM Server is running for SAS Cost and Profitability Management.
- You can find the values of **Host name** and **Service name** in the file `tnsnames.ora`.
  
  ```
  ABMDSN2 =
  (DESCRIPTION =
   (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = abmblade1)(PORT = 1521))
   )
  (CONNECT_DATA =
    (SERVICE_NAME = abmdsn)
  )
  )
  ```

- Open the `sqlnet.ora` file and verify that it has EZCONNECT specified under `NAMES_DIRECTORY_PATH= (TNSNAMES, EZCONNECT)`. This file is at the same location as `tnsnames.ora`. For example:
  
  `C:\Oracle\product\11.1.0\client_1\network\admin\sqlnet.ora`

**Server-Side Driver with PostgreSQL**

The following picture shows an example of connecting to a PostgreSQL database.
Server-Side Driver with Other Database

Use the Database type of Other to connect to a database not already mentioned, such as MySQL.

**OBDC DSN**

Select from the drop-down list. The list includes all the System ODBC DSN that users have created on the SAS IOM server.

**Note:**

- It is recommended that you create a System ODBC DSN on the SAS IOM Server machine and use it in the connection details.
A DSN for Postgres should be created with the Unicode version of the Postgres driver (PostgreSQL Unicode(x64)).

**User name**
Database user

**Password**
Database user’s password

**Advanced options**
By default, the catalog name is *Staging*. You can specify any arbitrary name for CATALOG= as it is a logical name that is used internally by the system. Most databases require a catalog name to be specified in the connection URL, but not all. For example, SQL Server does not require a catalog name. If you are attempting to connect to a database that does not require a catalog name, then you must remove it from the **Advanced options** field or the connection will fail. Click **Edit** to modify the connection URL.

**Connection URL**
When you click **Test Connection**, the system takes the information that you enter and constructs a connection URL that it displays in the **Connection URL** field. Click **Edit** to modify the connection URL.

Following is a sample connection URL for a connection based on ODBC DSN:

```
DRIVER=ODBC;ODBC_DSN=DSNMySQL;UID=root;PWD=Pass99;CATALOG=Staging;
```

If you want to use an ODBC driver to connect to the target database, then the system creates a connection URL (which you can modify) for you. If you want to use a driver other than ODBC, then click **Edit** to enter the URL yourself.
Chapter 74
Import Model Data from a Database

General steps
The following general steps describe how to import data:

1. Verify that you have permission.
2. Import the data. You can choose to import the entire data set at once, or you can import the data in groups and populate the model in the following general steps:

Import 1
The first import step defines the existence of the model and includes the Dimension, DimensionOrder, Period, and Scenario tables. This step is equivalent to the finishing point of the New Model Wizard when you interactively build a model.

Database Considerations
Overview
The data schema
Understanding keys
Creating sample database tables
Database table relationships, dependencies, and data values
Guidelines for using dimension signatures and references
Period/scenario associations
Data from multiple databases
Data from a Microsoft Excel workbook

Periodic Import

Importing data with your own program
Using the Import Wizard to Import from a Database
Before Importing
Step 1 – Select Database
Step 2 – Connect to the Database
Step 3 – Select Model
Step 4 – Map Source Tables to Target Tables
Step 5 – Specify Type of Account Keys
Step 6 – Map Input Columns to Target Columns
Step 7 – Review Your Choices
Import 2
The second import step defines the model's content (resources, activities, and cost objects) and includes the Account, DimensionLevel, and DimensionMember tables. This step is equivalent to the finishing point of the New Account Wizard when you interactively create accounts. The Account table includes the revenue and sold quantities.

Import 3
The third import step loads costs into the model and includes the EnteredCostElement and ExternalUnit tables. This step is equivalent to the point where you create cost elements in the New Account Wizard when you interactively build a model.

Import 4
The fourth import step flows costs through the model using assignments with quantities for flow calculation. This step includes the Assignment and Driver tables and is equivalent to the point where you interactively create assignments and specify driver quantities in the New Account Wizard.

Import 5
The fifth import step creates attributes for analysis. This step includes the DimensionAttributeAssociation, ValueAttribute, and ValueAttributeAssociation tables. This step is equivalent to creating attributes and attaching attributes to accounts when you interactively build a model.

Import 6
(optional): The sixth import step includes the AssignmentNonUnique, CurrencyRate, PeriodLevel, and ScenarioLevel tables.

3. Calculate costs.
4. Generate cubes.

The following table summarizes which tables to group in each step and in what order to import tables:

<table>
<thead>
<tr>
<th>Table name</th>
<th>Requires dimension signature?</th>
<th>Requires reference?</th>
<th>Has multiple keys?</th>
<th>Import step order</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dimension</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Import 1</td>
</tr>
<tr>
<td>DimensionOrder</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Import 1</td>
</tr>
<tr>
<td>Period</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Import 1</td>
</tr>
<tr>
<td>Scenario</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Import 1</td>
</tr>
<tr>
<td>Account*</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Import 2</td>
</tr>
<tr>
<td>DimensionLevel</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Import 2</td>
</tr>
<tr>
<td>DimensionMember</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Import 2</td>
</tr>
<tr>
<td>EnteredCostElement</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Import 3</td>
</tr>
</tbody>
</table>
### Database Considerations

#### Overview

To import from a database, you can use the wizard, or you can write a program.  

For information on connecting to a database, see Chapter 73, “Connecting to a Database,” on page 587.

Make sure to observe the restrictions on table names in a database for all staging tables.

#### The data schema

The database to be imported must match the data schema. For information on the data schema, see Chapter 6, “Staging-Table Schemas,” in SAS Cost and Profitability Management: Data Administration Guide.

All tables and fields in the data schema (except tables that are designated for export only) must exist in the database. When the database is imported, SAS Cost and Profitability Management attempts to convert all values to a reasonable format type. For example, if imported dates are in the Microsoft SQL Server varchar format, the dates are

---

<table>
<thead>
<tr>
<th>Table name</th>
<th>Requires dimension signature?</th>
<th>Requires reference?</th>
<th>Has multiple keys?</th>
<th>Import step order</th>
</tr>
</thead>
<tbody>
<tr>
<td>ExternalUnit</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Import 3</td>
</tr>
<tr>
<td>Assignment</td>
<td></td>
<td>Yes</td>
<td></td>
<td>Import 4</td>
</tr>
<tr>
<td>Driver</td>
<td></td>
<td></td>
<td>No</td>
<td>Import 4</td>
</tr>
<tr>
<td>DimensionAttributeAssociation</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Import 5</td>
</tr>
<tr>
<td>ValueAttribute</td>
<td></td>
<td></td>
<td>No</td>
<td>Import 5</td>
</tr>
<tr>
<td>ValueAttributeAssociation</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Import 5</td>
</tr>
<tr>
<td>AssignmentNonUnique</td>
<td></td>
<td>Yes</td>
<td></td>
<td>Optional</td>
</tr>
<tr>
<td>CurrencyRate</td>
<td></td>
<td></td>
<td>No</td>
<td>Optional</td>
</tr>
<tr>
<td>PeriodLevel</td>
<td></td>
<td></td>
<td>No</td>
<td>Optional</td>
</tr>
<tr>
<td>ScenarioLevel</td>
<td></td>
<td></td>
<td>No</td>
<td>Optional</td>
</tr>
</tbody>
</table>

*Note:* The Account table must contain both a dimension signature and a reference number, while the other tables listed with "Yes" in both columns must have either a dimension signature or a reference number.
converted to binary dates that are compatible with the SAS Cost and Profitability Management database. SAS Cost and Profitability Management attempts to convert all numeric values.

**Understanding keys**

The SAS Cost and Profitability Management model is based on a dual-key concept. To define any account in the model, you can describe it based on its dimension signature key or its reference key.

**Dimension signature key**

The dimension signature consists of a dimension reference and a dimension member reference for each dimension used to define an account. In the following example, the Resource module has been defined based on two dimensions (Region and General Ledger Account). The individual accounts are defined as intersections of these two dimensions. So, the Wages account (highlighted) consists of an intersection of the Region=Beaverton and the General Ledger Account=Wages. This account definition can be displayed in the grid with the intersection name (the column IntsctnName) or the intersection reference (the column IntsctnRef) properties.

The dimension signature for this account is based on the dimensions used and the dimension members used, so the dimension signature for this account requires multiple values as shown here:

<table>
<thead>
<tr>
<th>Property</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>DimRef1</td>
<td>Region</td>
</tr>
<tr>
<td>DimMemberRef1</td>
<td>Beaverton</td>
</tr>
<tr>
<td>DimRef2</td>
<td>General Ledger Account</td>
</tr>
<tr>
<td>DimMemberRef2</td>
<td>Wages</td>
</tr>
</tbody>
</table>

**Reference key**

In the previous example, the reference for the account is B_WG, and this single value uniquely identifies the account. See “Guidelines for using dimension signatures and references” on page 602.

*Note:* Importing with reference numbers is faster than with dimension signatures. However, when importing a new model, you must use dimension signatures.
Creating sample database tables

To understand how to create database tables, you should interactively import a sample model. The sample model demonstrates the dimensions and dimension order for each module, the default period/scenario association, and anticipated periods and scenarios. Use the sample model as a source for the model export to a database for general use.

Create the sample database tables by performing the following general steps:

1. Import a sample model in XML format. The sample models are located in the following directory:
   
   C:\Program Files\<Client_Installation_Location>\SAS\Cost and Profitability Management Solution\Client\Samples\Models\Native

2. Create a target database to export your sample database.

3. Archive the model.
   
   This creates a set of database tables.

4. Review the contents of the model.

   ![Model Properties](image)

   If the model that you want to import has the same number of dimensions in each module as the sample model shown, you can use the sample model directly. The External Unit module consists of one dimension; the Resource module consists of two dimensions; the Activity module consists of two dimensions; and the Cost Object module consists of three dimensions. After you export the sample database, modify the contents of the tables to reflect your own data in the appropriate dimension signature columns.

   If the model that you want to import has a different number of dimensions in each module as the sample model, then the sample can still provide a good starting point for creating a staging table template. But, you must customize all of the tables that require the dimension signature (the Account, Assignment, EnteredCostElement, ExternalUnit, DimensionAttributeAssociation, and ValueAttributeAssociation tables) to include all of the dimensions that you used in the model that you want to import.
Number of dimensions in the imported model | Difference in the number of dimensions in the sample model
--- | ---
External Unit module: two dimensions | Add one dimension
Resource module: one dimension | Remove one dimension
Activity module: three dimensions | Add one dimension
Cost Object module: five dimensions | Add two dimensions

Exporting to a database creates all of the required tables with most of the required columns. The required columns in some of the tables depend on the number of dimensions in a model. Because each dimension signature consists of a pair of columns, any table with dimension signature columns will add columns as the number of dimensions in the model increases. Although you can manually create the tables, exporting to a database reduces the risk of omitting required tables, omitting required columns within tables, and creating typographical errors. And, it gives you a viable sample to follow in developing your own staging table content and when building a SAS Cost and Profitability Management model.

**Database table relationships, dependencies, and data values**

There are no database-enforced relationships between any of the SAS Cost and Profitability Management tables, and there are no dependencies between tables. You can specify any values in the tables that you need. However, while the data is being imported, SAS Cost and Profitability Management checks the validity of the values and rejects any invalid records. You will receive messages that indicate any errors.

If you import all the tables at one time, the wizard will import the tables in the correct order, so errors are minimized. However, if you import individual tables, then you must ensure that the tables are imported in the correct order, as noted in the Importing data: General steps Help section.

Following are a few examples of common errors made while importing tables:

- A record in the DimensionMember table does not correspond to a record in the Dimension table. You must import the Dimension table before you import the DimensionMember table.

- A record in the Account table does not correspond to a record in the DimensionMember table. You must import the DimensionMember table before you import the Account table.

- A record in the Assignment table (where the source account or the destination account is) is not in the Account table. You must import the Account table before you import the Assignment table. If you select the option to create a new Account through the Assignment's dimension signature, you do not need to import the Account table first.

**Guidelines for using dimension signatures and references**

When importing data for assignments, cost elements, dimension attribute associations, and value attribute associations, you can choose to import with either a dimension signature or reference key. As you define the extraction and transformation processes to
create the staging tables for SAS Cost and Profitability Management, you should be aware of the advantages and disadvantages of using one key over another.

If you are importing model data using references rather than dimension signatures, you must define both the reference and the dimension signature in the Account table. The Account table can be used as a mapping index to match the imported data in staging tables (Assignment, EnteredCostElement, DimensionAttributeAssociation, and the ValueAttributeAssociation tables) to their respective dimension signature as defined in the model. The advantage of using references rather than dimension signatures is that the import tables can have significantly fewer columns. For example, in a two dimension model, the reference would be a single column to import and the dimension signature would be four columns to import. The total impact of this change to the Assignment table would be six fewer columns required.

If you are importing model data using dimension signatures, you must include the dimension reference and dimension member reference for each dimension, which can be tedious to maintain. For example, in a two dimension model, the required keys include four columns for the two dimensions. However, there is one advantage of importing data using dimension signatures: You can automatically create new accounts that appear in the transaction tables (Assignment, EnteredCostElement, DimensionAttributeAssociation, and the ValueAttributeAssociation tables). The dimension signature method provides a distinct advantage over the reference key method because the reference key method skips over any new accounts found in the transaction tables and fails to import them.

**Period/scenario associations**

If you use the wizard to import data, you can import multiple period/scenario associations. If you write a program to import data, you can import more than one period/scenario association at a time. Period/scenario associations are imported if a model element (such as an account or a cost element) contains data for the period/scenario association.

Period/scenario associations are ignored unless there is a model element (such as an account or a cost element) that contains data for the period/scenario association.

**Data from multiple databases**

You can import data from multiple databases by first creating a database view. The view specifies which data you want to import from multiple tables in multiple databases. Then, you can use the wizard.

Alternatively, you can use the SAS Cost and Profitability Management Web Services Integration API to write a program that uses an XML import configuration to specify each database in a separate StagingArea element.

**Data from a Microsoft Excel workbook**

If you want to import data from a Microsoft Excel workbook, you must create named ranges for the different sets of data. To create a named range in Microsoft Excel, highlight the data and select Insert > Name > Define. Multiple named ranges must be defined for each required stage table inside a single Microsoft Excel spreadsheet, as shown in the following example:
Periodic Import

When you generate a cube, for every period (period and scenario association) that is to be included in an existing cube, if:

- the cube already contains that period, and
- the period has not been modified since the cube was last generated

then the period is not regenerated.

This means that cube generation is faster because periods that have already been generated are not regenerated.

In order to support incremental cube generation, SAS Cost and Profitability Management provides a Periodic data only option in the Import Wizard that allows you to import only the periods that have changed in a model—for example, the new periods.
If you select **Periodic data only**, then only those staging tables that contain periodic data are displayed in the Import Wizard for you to select for importing.

**Staging tables are distinguished by whether they contain periodic or structural data. Periodic data is model data which is stored separately for each period/scenario association. Structural data is model data which is independent of any period/scenario association. It is data that is common to all period/scenario associations.**

The following staging tables contain **periodic data**:  
- Account  
- Assignment  
- CurrencyRate  
- ExternalUnit  
- EnteredCostElement  
- PerformanceMeasure  
- ValueAttributeAssociation
The following staging tables contain **structural data**:  
- Dimension  
- DimensionMember  
- DimensionLevel  
- DimensionOrder  
- Driver  
- Model  
- ValueAttributes  
- Period  
- PeriodLevel  
- Scenario  
- ScenarioLevel  

When you generate a cube for a model that has been generated before, SAS Cost and Profitability Management determines whether the entire cube must be regenerated or whether only the new or modified periods need to be generated. You do not have to specify, when you generate a cube, whether you want incremental generation or not. SAS Cost and Profitability Management makes the determination for you.

*Note:* Cubes in SAS OLAP that are generated using either the NO\_NWAY option or the NONUPDATEABLE option are not eligible for incremental generation.

---

**Importing data with your own program**

To write a program for importing data in batch, you can use Easy API. For information, see Chapter 13, “Easy API,” in *SAS Cost and Profitability Management: Data Administration Guide*.

---

**Using the Import Wizard to Import from a Database**

**Before Importing**

Before attempting to import data from a database, see Chapter 73, “Connecting to a Database,” on page 587, which provides information about connecting to the most common databases.

*Note:* You can import a model without first opening a model.

1. Create a database or a database view that matches the data schema.

    For information about the data schema, see .
2. In SAS Cost and Profitability Management, verify or create any required period/scenario associations.

3. Select **File ➔ Import ➔ Model Data**.
   
The Import Data Wizard opens.

**Step 1 – Select Database**

1. Select the **Database** option.

![Import Data - Import Type](image)

2. Click **Next**.

**Step 2 – Connect to the Database**

1. Click the **Browse...** button on the Wizard page.

![Import Data - Data and Location](image)

The Connection Information window opens.
For information on using this window, see Chapter 73, “Connecting to a Database,” on page 587.

2. Click Next.

**Step 3 – Select Model**

1. If you want to import the database into a new model, do the following:
   a. Select the New model option.
   b. Type the Model name.

2. If you want to import the database into an existing model, do the following:
   a. Select the Existing model option.

   *Note:* If you attempt to replace a model that is currently open by importing a model, then it is possible that an error will occur when the system attempts to update the display of the model. To avoid any possible problem it is safer to close a model before attempting to replace it by importing a model.

   b. From the drop-down list, select a model.
c. To append the imported data to the existing model data, select the **Update all data in the model, then import new data** option.

d. Select **Periodic data only** to import only the staging tables that contain periodic data. See “Periodic Import” on page 604.

e. To remove all existing data, select the **Remove all data in the model, then import new data** option.

   **Note:** Ensure that the existing model does not contain any published period/scenario associations. The published period/scenario association might cause an error when you try to replace the existing model by importing another.

3. Click **Next**.

### Step 4 – Map Source Tables to Target Tables

In this step, you specify which tables to import. And, for each table that you import, you specify to what SAS Cost and Profitability Management table it maps.

1. To select a table to import, select the check box to the left of the table name in the **Source Table** column.

   **Note:** If you selected **Periodic data only** in the previous step, then only tables that contain periodic information are displayed for selection.

2. To map a **Source Table**, click in the **Target Table** column to the right of the source table, and select a SAS Cost and ProfitabilityManagement table from the drop-down list.
Note: If you have named the source tables with the same names that are used in SAS Cost and Profitability Management, the wizard automatically creates the mappings and selects the tables to be imported. If you have not used the same names, then you must specify which source table maps to which SAS Cost and Profitability Management table.

Note: You can map multiple source tables to the same target table. The following picture shows the source tables Account1 and Account2 both mapped to Account.

3. Repeat steps 1 and 2 to map every table that you want to import.

4. Click Next.

**Step 5 – Specify Type of Account Keys**

In this step, you specify how accounts are identified in source tables that contain accounts. You can identify each account by a dimension signature or by reference number. You can choose to have the wizard create accounts for all valid dimension signatures, even if accounts have not been created for those intersections.

1. To identify accounts by the dimension signature, select the check box in the Dimension Signature Required column to the right of each source Table.
If you clear the check box, accounts will be identified by their references.

2. To have the wizard automatically create accounts for all valid dimension signatures, select the **Automatically create accounts using dimension signatures** option.

   *Note:* The import process supports automatically creating accounts from the following tables only: Account, Assignment, EnteredCostElement, ValueAttributeAssociation, and Dimension AttributeAssociation.

3. Click **Next**.

### Step 6 – Map Input Columns to Target Columns

In this step, you specify which table columns to import. And, for each table column that you import, you specify to which table column in SAS Cost and Profitability Management it maps.

1. To select a table column to import, select the check box to the left of the table name in the **Source** column.

   You can select as many table columns as needed, but you must import those columns that are required. Required columns are denoted by an asterisk (*).
Note: If you have named the source table columns with the same column names that are used in SAS Cost and Profitability Management, the wizard automatically creates the mappings and selects the columns to be imported. If you have not used the same names, then you must specify which source table column maps to which SAS Cost and Profitability Management table column.

2. If you chose in the previous step to identify accounts by their dimension signatures, specify the number of Dimensions that are contained in the source table.

The Dimensions option appears only when you choose to identify accounts by their dimension signatures. You must specify the number of dimensions so that the interface displays the correct column names that you must map. For each dimension in the source table, there must be two columns that can be mapped to the SAS Cost and Profitability Management table columns; these two columns are named DimRef<number> and DimMemberRef<number>. For example, a source table that contains two dimensions must contain columns that must be mapped to DimRef1, DimMemberRef1, DimRef2, and DimMemberRef2.

3. To map a Source table column, click in the Target Column Name column to the right of the Source table column, and select a SAS Cost and Profitability Management table column from the drop-down list.

The drop-down list contains the values DimRef<number> and DimMemberRef<number> only if you chose to identify accounts by their dimension signatures, which is the only situation in which these values are needed.

4. It is not necessary that the source table contain every column that is required in the target table. If a source table does not contain a column that you want to create in the model, do the following:

a. Select the target table from among the tabs at the bottom of the dialog.

b. Click Add.

A new row appears at the bottom of the list of source columns.

c. Make sure that <None> is selected for the Source column.

<None> signifies that the column does not appear in the source table.
d. Select the column to be created in the target table from the **Target Column Name** drop-down list.

e. Type a **Default** value.

The following picture summarizes the process for adding to the target table a column that does not exist in the source table.

5. After adding all the desired missing columns to the target tables, click **Next**.

**Step 7 – Review Your Choices**

1. Review the import summary.

2. If you need to change any information, click **Back** until you reach the step that you need to change in the wizard.
All of the information that you have specified is saved. Click Next to advance through the wizard.

3. To save the import configuration so that the import can be easily run again, do the following:
   a. Select the **Save configuration as** option.
   b. Type the **Name**.
   c. Type the **Description**.

4. Select **Save without running** to save the import configuration with performing the import.

5. Click **Finish**.
Import a Model from an XML File

Using the Import Wizard

To build a model or to add data to a model in SAS Cost and Profitability Management, you can either add data interactively with the user interface or you can import data into a model.

**TIP** Because manually building a model is time-consuming and error-prone and leaves little time for analysis, importing data is the recommended method.

You can import data from the following sources:

**Database**

See “Using the Import Wizard to Import from a Database” on page 606.

**XML file**

The XML file must be an XML file that was exported from SAS Cost and Profitability Management. You should not import a manually created XML file, because it is challenging to dynamically create an XML file with the correct format for directly importing model data.

See “Importing from an XML File” on page 616.

To import a model from an XML file, select **File ➪ Import ➪ Model Data**, and then select **XML or ZIP file**.

**Oros model**

Please contact SAS technical support if you want to import an Oros model into SAS Cost and Profitability Management.

**Surveys**

See Chapter 4, “Introduction to Surveys,” in *SAS Cost and Profitability Management: Data Administration Guide*. 
Importing from an XML File

When you import model data from an XML file, a new model is created. You can choose to give the model a new name or you can reuse the name of an existing model. You cannot import model data from an XML file to incrementally update an existing model or to combine several models into a single model. Whatever data is contained by an existing model is removed and replaced by the model data in the imported XML file.

Note: You can perform this task without first opening a model.

1. Select File ➔ Import ➔ Model Data.

The Import Data Wizard appears.

2. Select the XML File option.

3. Click Next.

4. Type the absolute pathname to the XML file. Or, click Browse...

5. Click Next.
6. If you want to import the XML file into a new model, do the following:
   a. Select the **New model** option.
   b. Type the **Model name**.
   c. Type the **Model Reference**. The Model Reference is used in public views.

7. If you want to import the XML file into an existing model, do the following:
   a. Select the **Existing model** option.
   b. From the drop-down list, select a model.

   **Note:** If you attempt to replace a model that is currently open by importing a model, then it is possible that an error will occur when the system attempts to update the display of the model. To avoid any possible problem it is safer to close a model before attempting to replace it by importing a model.

   **Note:** Ensure that the existing model does not contain any published period/scenario associations. The published period/scenario association might cause an error when you try to replace the existing model by importing another.

8. Click **Next**.

9. Review the import summary.
10. If you need to change any information, click **Back** until you reach the step that you need to change in the wizard. All of the information that you have specified is saved. Click **Next** to advance through the wizard.

11. To save the import configuration so that the import can be easily run again, do the following:
   a. Select the **Save configuration as** option.
   b. Type the **Name**.
   c. Type the **Description**.

12. Select **Save without running** to save the import configuration with performing the import.

13. Click **Finish**.
Chapter 76
Import Surveys

1. Go to the Workspace Manager.
2. Select File ⇒ Import ⇒ Model Data.
3. In the Import Data - Import Type dialog box, select Surveys and click Next.
4. Click Browse to specify a location. The Connection Information dialog box appears.

The following table describes the fields of the Connection Information dialog box.

Table 76.1 Description of Fields of Survey Export - Connection Details Dialog Box

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File path</td>
<td>The file path where you want to create the Microsoft Excel file to export survey data. The file path that you enter must have read/write permission.</td>
</tr>
<tr>
<td>Driver type</td>
<td>The type of the driver that you want to use for exporting or importing the Microsoft Excel file.</td>
</tr>
<tr>
<td>Provider</td>
<td>The provider that you must be used with Microsoft Excel. Generally, the Microsoft.ACE.OLEDB.12.0 is used with Microsoft Office.</td>
</tr>
<tr>
<td>Advanced options</td>
<td>The extended or advanced properties that can be used with Microsoft Excel file.</td>
</tr>
<tr>
<td>Test Connection</td>
<td>Click this button to test the database connection. This is an optional button.</td>
</tr>
<tr>
<td>OK</td>
<td>Click this button to save the details.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Click this button to close the dialog box without saving the details that you specified.</td>
</tr>
</tbody>
</table>
5. In the Connection Information dialog box, click **Browse**. Select the surveyed file of type .xls or .xlsx and click **OK**.

6. In the Import Data - Import Type dialog box, click **Next**.

7. In the Import Data - Model dialog box, select **Existing model** from the drop-down list. The surveyed file can be imported on the existing model only. Click **Next**.

8. Verify the table mapping and click **Next**.

9. Verify the options for this import and click **Next**.

10. Verify the column mapping and click **Next**.

11. Review the summary and click **Finish**.
Choosing the Export Format

You can export model data to a database or to an XML file. If you want to export only a portion of the model data, you must export to a database. If you export to an XML file, all model data is exported. If you want to export all of the model data, you can export to a database or to an XML file.

The following table lists some of the reasons why you might export model data. For each reason, the table shows whether you would export to a database or to an XML file:

<table>
<thead>
<tr>
<th>Reason for Exporting</th>
<th>Export Destination</th>
</tr>
</thead>
<tbody>
<tr>
<td>To export model data and to manipulate the data, and then to import the data back into the model or into another model</td>
<td>Database</td>
</tr>
<tr>
<td>To archive a model</td>
<td>Database</td>
</tr>
<tr>
<td>XML file (requires less disk space)</td>
<td></td>
</tr>
<tr>
<td>To export some of the items in the model, but to exclude other items</td>
<td>Database</td>
</tr>
</tbody>
</table>

Note: When a table is exported to a database, SAS Cost and Profitability Management attempts to match the destination table's column names with the source table's...
column names as closely as possible, so that they are compatible with SAS. A name change is necessary when a database has certain naming limitations (such as a limited number of characters per field); those name changes are noted in the Field Name column of each table.

For information on exporting to a database, see “Choosing the Export Format” on page 621. Also, see Chapter 73, “Connecting to a Database,” on page 587.

Note: If a network user from a different domain (than that of the SAS Cost and Profitability Management client machine) logs in to the client machine to export to XML, then that user must be granted Write access to the <ClientInstallpath>\bin folder for the operation to succeed.

When exporting a table to a database, observe the following restrictions on the table name:

SQL Server:
- Table name must begin with a letter.
- Table name should not start with special characters like $, @, #, %, |, !
- Special characters like %, -, |, ! are not allowed in the table name.
- Table name must be less than or equal to 128 characters.

Oracle:
- Table name must begin with a letter.
- Table name should not start with special characters like $, _, #, %, -, |, !
- Special character like @, %, - are not allowed in the table name.
- Table name must be less than or equal to 30 characters.

MySQL:
- Special characters -, %, @, |, ! are not allowed in the table name.
- Table name must be less than or equal to 64 characters.

Microsoft Access:
- Table name must be less than or equal to 64 characters.
- Special characters like $, %, #, !, - are not allowed in the table name.

Microsoft Excel:
- Table name must be less than or equal to 32 characters.
- Special characters like $, %, #, !, - are not allowed in the table name.

See Also

“Export a Model to an XML File” on page 638
Archiving a Model

Overview

When you archive a model, important model data is preserved so that the model can be restored to a saved state. Although not all model data is preserved, user-entered data and unique data are saved. Model data that is not saved is regenerated by SAS Cost and Profitability Management when the model is restored and calculated.

You might want to archive a model for the following reasons:

• to create a backup
• to save a version before making major changes
• to restore a model after upgrading a SAS Cost and Profitability Management server
• to transport a model between SAS Cost and Profitability Management servers

Determining the Tables to Export

When you export model data for business analysis, you must determine which tables to export with the appropriate calculated values. You can export the following SAS Cost and Profitability Management standard staging tables with calculated values.

Account table

Exporting the Account table with the calculated values enables you to perform additional analysis on any account, which is useful for static, calculated values analysis, but is not useful for cost-flow analysis. The types of fields in an exported Account table include:

• Definitional
  Keys: dimension signature and reference
  Model, module type, period, scenario, driver names, model name, unit of measure, periodic note
• Entered values: OutputQuantityUE, Revenue, SoldQty, TDQUE
• Calculated values
  Cost values: AllocatedCost, AssignedCost, AssignedIdleCost, AssignedNonReciprocalCost, AssignedReciprocalCost, DrivableCost, DrivenCost, DriverRate, EnteredCost, IdleCost, ReceivedAllocatedCost, ReceivedBocCost, ReceivedCost, ReceivedDrivenCost, ReceivedNonReciprocalCost, ReceivedReciprocalCost, UnassignedCost, UsedCost

  Driver data: AssignedIdleQuantity, DrivenQuantity, IdlePercentage, IdleQuantity, OutputQuantity, TDQ, TDQBasic, TDQCalculated, UnassignedQuantity, UsedQuantity

  Profitability analysis (uses both entered values and calculated values): Cost, Profit, Revenue, SoldQuantity, UnitCost, UnitProfit, UnitRevenue
• Attributes (specific to the model design)

  Dimensional attributes - used for grouping

  Numerical attributes - entered values
Calculated attributes

Assignment table

Exporting the Assignment table with the calculated values enables you to trace specific costs as they flow through a model. The Assignment table provides the cost flow and driver-quantity flows between each source account and destination account. It contains the content from the Single-stage Contributions OLAP cube fact table. The types of fields in an exported Assignment table include:

- **Definitional**
  - Keys (for both the source account and destination account): dimension signature and reference
    - Destination module type, driver name, model name, period, scenario, source module type
  - Driver analysis: DriverQuantityBasic, DriverQuantityCalculated, DriverQuantityFixed, DriverQuantityVariable, DriverWeightFixed, DriverWeightVariable, IdleDriverQuantity, IdleDriverQuantityUE
  - Cost flow: allocated cost, cost, idle cost, source cost
  - Attributes (specific to the model design)
    - Dimensional attributes - used for grouping
    - Numerical attributes - entered values
    - Calculated attributes

Multi-stage Contribution cube fact table (with calculated values)

The types of fields in an exported Multi-stage Contribution cube include:

- **Definitional**
  - Keys for each account: dimension signature and reference
    - Activity module type, Cost Object module type, model name, period, Resource module type, scenario
  - Entered values: OutputQuantityUE, Revenue, SoldQty, TDQUE
  - Calculated values: Cost, OutputQuantity
  - Attributes specific to the model design
    - Dimensional attributes - used for grouping
    - Numerical attributes - entered values
    - Calculated attributes
The cube fact table holds all of the calculations for cost flow through the model. The Multi-stage Contribution cube holds cost flow from each step through the model. Using the Multi-stage Contribution cube, an analysis can be created to trace a single, final cost object, through each contributing cost, to the activities back to the original resource.

In the previous example, all stages (A through D) are available for analysis in the Multi-stage Contribution cube.

Resource Contributions cube

The types of fields in an exported Resource Contributions cube include:

- **Definitional**
  - Keys for each beginning or final account (resources, cost objects): dimension signature and reference
  - Destination module type, model name, period, scenario, source module type, source reference

- **Entered values**: DestinationSoldQuantity

- **Calculated values**: ContribCost, ContribPcnt, DestinationCost, DestinationOutputQuantity

- **Attributes specific to the model design for each beginning or final account (resources, cost objects)**
  - Dimensional attributes used for grouping
  - Numerical attributes entered values
  - Calculated attributes

### Working with Tables, Dimensions, Properties, and Attribute Values

For tables, dimensions, properties, and attribute values, you can export all items or specific items. You can change the name of each exported item from its default name. For maximum flexibility with tables, you can export the same table to multiple export
tables. For example, you can export the Account table to the tables named ResourceAccounts and ActivityAccounts.

**TIP** The Export wizard shows you which database fields are required for re-importing model data.

---

### Exporting, Filtering, and Limiting Calculated Results

Following are the general steps that you perform when exporting model data:

- **Export only certain period/scenario associations.**
  
  You can export one or more period/scenario associations.

- **Export only certain tables.**
  
  You can select the specific SAS Cost and Profitability Management staging table you want to export. You can choose to change the names of the tables that you are exporting, which is useful when you are exporting multiple tables of the same type for distribution across a large audience (actual account and planning account).

- **Choose the specific fields to be included in the dimension signature in all of the tables to be exported.**
  
  The required fields for the dimension signature include a dimensional reference and the dimensional member reference. These fields are required if you want to re-import the exported data into SAS Cost and Profitability Management. However, for readability and integration with other systems (data warehouses), you might find it helpful to include the dimension name, the dimension member name, the dimension level, and the dimension level name.

- **Export only certain fields in the tables.**
  
  You can select specific fields within each table to be exported. The default (archive) selections of fields do not include any calculated values, so be sure to carefully select the calculated values you need to export for further analysis or to import into another system (data warehouse). For each field you export, you can change the names of the fields, which is particularly useful when creating a SAS Cost and Profitability Management system to import into another system (which might have predefined fields). You can change the numbers in a dimension signature to a more useful notation of the organizational structure.

- **Export only certain dimensions in specific tables.**
  
  You can eliminate unnecessary fields in the exported data. This is useful in the Multi-stage Contributions cube. The default behavior is to include all of the possible dimensions in each stage of the export, but in most SAS Cost and Profitability Management models, only a limited number of dimensions actually apply to a given stage in the model. By eliminating unnecessary dimensions, you can significantly decrease the size of the exported data.

- **Export only certain members in a dimension in specific tables.**
  
  You can define a specific point in the dimensional hierarchy to include in the exported data. This filter method is useful for creating specific exports for an organizational structure (specific departments, specific product lines, or specific customer types).

- **Export multiple tables of a specific type -- add table and field -- filtering for content.**
  
  When performing business analysis, you might want to export a single model into multiple tables, which is useful when providing specific results tables to specific...
departments. The ability to export a single SAS Cost and Profitability Management staging table into multiple database tables might be useful when splitting the actual costs and budget costs. To export a single table into multiple tables, you need to add a table and select multiple versions of the same staging table type, and map the versions to different destination table names. Then, apply a filter to limit the results going to each destination table.

Filtering Data

Use the following methods to filter the data that you want to export:

- select parts of a dimension
- specify comparisons for the values of attributes
- specify comparison operators for the values of fields in a table

If you filter by a table field, you do not need to export the field.

The following table lists the comparison operators:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
<th>Field type</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIKE</td>
<td>Wildcard</td>
<td>Text</td>
</tr>
</tbody>
</table>

Use the percentage symbol (%) to specify any amount of text, including spaces. For example, Name LIKE fiscal% will match fiscal, fiscally, and fiscal year 2004.

Use an underscore (_) to specify a single character. For example, Name LIKE account_ will match account1, account2, and accountX.

If you omit both % and _, the comparison is the same as when you use the operator =. For example, Name LIKE fiscal is equivalent to Name = fiscal.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
<th>Field type</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equal</td>
<td>Text or numeric</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Not equal</td>
<td>Text or numeric</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less than</td>
<td>Numeric</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
<td>Numeric</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
<td>Numeric</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
<td>Numeric</td>
</tr>
</tbody>
</table>
Using the Export Wizard

Overview

When you use the Export wizard to export model data, you can do the following:

**Export to a Database**
To export a model to a database, select File ➔ Export ➔ Model Data, and then select Database. See “Export a Model to a Database” on page 628.

When you export to a database, you can select individual database tables and properties to export:

- “Determining the Tables to Export” on page 623
- “Exporting, Filtering, and Limiting Calculated Results” on page 626
- “Filtering Data” on page 627

**Export to an XML or ZIP File**
To export a model to an XML or ZIP file, select File ➔ Export ➔ Model Data, and then select XML or ZIP file. See “Export a Model to an XML File” on page 638.

*Note:* When you export to an XML file, you must export all of the model data. If the XML file already exists, it is overwritten.

*Note:* You can export model data without first having to open the model

**See Also**

- “Choosing the Export Format” on page 621
- “Archiving a Model” on page 623

**Export a Model to a Database**

Before attempting to export data to a database, see Chapter 73, “Connecting to a Database,” on page 587 which provides information about preparing to connect to the most common databases.

*Note:* You can perform this task without first opening a model.

1. Verify that the model is ready.
2. Select File ➔ Export Model Data.

   The Export Wizard appears.

**Step 1 of the Wizard**
1. Select the **Select specific tables and properties** option.
   Notice that the only export type available is **Database**.

2. Click **Next**.

**Step 2 of the Wizard**

1. Click **Browse...**

   The Connection Information window opens.
For information on using this window, see Chapter 73, “Connecting to a Database,” on page 587.

2. From the **Select a model to export** drop-down list, select a model.

3. From the **Select period/scenario associations you want to export from** list, select the check box next to one or more period/scenario associations.

4. Click Next.

**Step 3 of the Wizard**
1. To select a table to export, select the check box to the left of the table in the **Source Table** column.

   You can select as many tables as needed.

2. To change the name of an exported table, click in the **Target Table** column to the right of a source table and enter a new name.

3. To map a source table to more than one target table, do the following:
   a. Click **Add Table**.

      A new row is added with default information.

   b. Click in the **Source Table** column, and select a SAS Cost and Profitability Management table from the drop-down list.

4. Repeat steps 1 and 2 for every table that you want to export.

   Next, you will select dimensions to export for each table that contains dimension information.

5. Click **Next**.

**Step 4 of the Wizard**
1. To select dimensions within tables to export, select the check box to the left of the dimension in the **Column Name** column.

Columns that you select are selected by default on the next Export Wizard screen. However, you can change your selection on the next screen. That is, you can deselect a field that you had selected, or select a field that you had deselected.

Next, you will select dimensions and module information to export for each table that contains dimension information or module information.

2. Click **Next**.

**Step 5 of the Wizard**
1. Expand each table to review which columns are automatically selected to export.

You can change the name of the target column

2. To select a column to export, select the check box to the left of the Target Column Name.

Notice that columns marked with an asterisk (*) must be exported.

3. To change the name of an exported column, click in the Target Column Name column to the right of a column name, and enter a new name.
Next, you will select dimension members to export. By default, all data will be exported. By selecting dimension members, you can limit the amount of data that is exported.

4. Click Next.

**Step 6 of the Wizard**

1. Expand each table to view the dimension members.

2. If you want to select all dimension members when a dimension is selected, select the **Automatically check child dimension members** option.

3. To select a dimension member, select the check box to the left of the dimension member.

4. To search for a dimension member, do the following:
   a. Click **Search**.

   The Search dialog box appears.
b. In the **Enter the name of the item you are looking for** box, enter the name of the item.

You can search for a table, a dimension, or a dimension member.

c. Select the **Match whole word only** option and the **Match case** option.

d. Click **Find Next**.

The next occurrence of the item is found.

5. Repeat steps 1 through 3 for each dimension member that you want to export.

Next, you will select columns to export. You can limit which data to export by creating filters.

6. Click **Next**.

**Step 7 of the Wizard**

![Export - Choose Columns dialog box](image)

1. To select a column, select the check box to the left of the target column name.

   Notice that columns marked with an asterisk (*) must be exported.

2. To change the name of an exported column, click in the **Target Column Name** column to the right of a column name, and enter a new name.

3. To add a filter condition to a table, do the following:

   a. Click **Add**.

      The Add Filter Condition dialog box appears.
b. Select a database **Field** on which to base the filter condition.

c. From the **And/Or** drop-down list, select a logical operator.

d. Click **Add**.

   The field appears in the list.

e. Select an **Operator** from the drop-down list.

f. Enter a **Value** for the operator.

You can create as many filter conditions as needed, but each filter condition can specify only one field. For example, if you need to limit the export to a model named Headquarters with a base currency of United States Dollars, you would have to open the Add Filter Condition dialog box twice. The first time, you would need to create the filter condition for the model name Headquarters. The second time, you would need to create the filter condition for the base currency United States Dollars. The completed filter conditions would look like the following:

```
<table>
<thead>
<tr>
<th>Column Name</th>
<th>Target Column Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Model</td>
<td></td>
</tr>
<tr>
<td>Filter Conditions</td>
<td></td>
</tr>
<tr>
<td>Name = Headquarters'</td>
<td>BaseCurrency = 'USD'</td>
</tr>
</tbody>
</table>
```

Selected columns are exported only if they pass the filter. In other words, for a column to be exported, it must both:

- be selected
- pass whatever filters exist for the table
4. Click Next.

Step 8 of the Wizard

1. Review the export summary.

2. If you need to change any information, click Back until you reach the step that you need to change in the wizard.

   All of the information that you have specified is saved. Click Next to advance through the wizard.
3. To save the export configuration so that the export can be easily run again, do the following:
   a. Select the **Save configuration as** option.
   b. Enter the **Name**.
   c. Enter the **Description**.

4. Select **Save without running** to save the export configuration without performing the export.

5. Click **Finish**.

### Export a Model to an XML File

*Note:* You can perform this task without first opening a model.

1. Verify that the model is ready.

2. Select **File ➪ Export Model Data.**

   The Export Wizard appears.

3. Select the **Select default tables and properties to archive a model** option.

4. Select the **XML File** option.

5. Click **Next**.
6. Type the absolute pathname to the XML file. Or, click [Browse...].

7. From the Select a model to export drop-down list, select a model.

8. From the Select period/scenario associations you want to export from list, select the check box next to one or more period/scenario associations.

9. Click Next.

10. Review the export summary.
11. If you need to change any information, click Back until you reach the step that you need to change in the wizard. All of the information that you have specified is saved. Click Next to advance through the wizard.

12. To save the export configuration so that the export can be easily run again, do the following:
   a. Select the Save configuration as option.
   b. Enter the Name.
   c. Enter the Description.

13. Select Save without running to save the export configuration without performing the export.

14. Click Finish.
Chapter 78
Cube Configurations

Import Cube Configurations

1. Go to the Workspace Manager.
2. Select File ⇒ Import ⇒ Cube Configurations. The Import Cube Configuration dialog box opens.
3. Select the file to import and import options:
   - **Rename cube configuration being imported**
     If a cube configuration exists with the same name as a cube configuration being imported, the one that you are importing is renamed. This applies to every cube configuration being imported if multiple cube configurations are imported.
   - **Replace the existing cube configuration**
     If a cube configuration exists with the same name as a cube configuration being imported, then the existing cube configuration is replaced with the imported one.
   - **Do not import duplicate cube configurations**
     If a cube configuration exists with the same name as a cube configuration that you are importing, then the duplicate cube configuration is not imported. Leave the existing one in place.
4. Click Finish.

Export Cube Configurations

1. Go to the Workspace Manager.
3. Select the cube configurations to export and export options:

**Automatically check children**
Select this check box to recursively select cube configurations that are inside the selected folder.

*Note:* This option applies only to subsequent folder selections. It does not select subfolders of folders that are already selected.

**Include folders**
Select this check box to store folder information in the exported file. As a result, folders can be recreated when you import the cube configurations.

*Note:* This option does not create folders in the export directory. It stores the folder information in the export file so that the folders can be recreated later during import.

**Export to this path and file name**
Select the path and name of the export file.

*Note:* Only one export file is created, even if you select multiple folders and cube configurations to export.

4. Click Finish.
Chapter 79
Column Layouts

Import a Column Layout

Note: You can perform this task without first opening a model.
1. Select File ➔ Import ➔ Column Layouts.
   The Import Column Layouts Wizard appears.
2. Follow the directions in the wizard.

Export a Column Layout

You can perform this task without first opening a model.
1. Select File ➔ Export ➔ Column Layouts.
   The Export Column Layouts Wizard appears.
2. Follow the directions in the wizard.
Chapter 80
Export Module Views to Excel

Export Module Views to Excel

Summary

If you want a printable form of the hierarchical structure of a module, and one that you can easily modify without affecting the underlying model, you can export the module to Excel. For example, using system-supplied column layouts, you can view modules and export the resulting module views to Excel so as to obtain printed reports on different aspects of your model.

You can either select particular rows of a module view to export, or you can export the entire module.

Note: Exported spreadsheets cannot be re-imported into SAS Cost and Profitability Management.

Export the Entire Module

To export the expanded rows of an entire module:

1. Select the primary pane of the module view.
2. Without selecting any rows, right-click the module name.
   
   Note: If more than one row is selected, then only the selected rows are exported.
3. Select Export to Excel.
The Export to Excel dialog box appears.

*Note:* You can also click the Export to Excel icon in the toolbar.

4. Specify the name of the Excel file and the name of the sheet to be created and whether you want to overwrite existing data.
   - If the Excel file does not exist, it is created with a sheet named as you specify.
     *Note:* You must specify a complete path and file name.
     *Note:* Do not name the sheet Sheet1 unless you are replacing Sheet1 of an already existing Excel file.
     *Note:* The sheet name cannot contain any special characters except underscores.
   - If the Excel file already exists but does not contain a sheet with the name that you specify, then a new sheet is added to the existing file.

5. Click **OK**.

**Only Rows that are Expanded are Exported**

Only rows that are expanded when you perform the export are exported. So, what you see in the module view is what you get in the spreadsheet.

It is not necessary, however, that either all the rows or all the columns are visible when you perform the export.
• Some rows that are expanded may not be visible if there are more rows than fit on the screen, such that vertical scrolling is necessary to see them.

• Some columns in the column layout may not be visible if there are more columns than fit on the screen, such that horizontal scrolling is necessary to see them.

Exporting works as though you had an infinitely large screen that is able to display, without scrolling, all the rows in the hierarchy that are expanded and all the columns in the column layout.

Note: Columns that you have added to the current column layout are exported even if you haven't yet saved the column layout with the additional columns.

Note: If there are no accounts in the module, then the export is not performed.

**Select Particular Rows to Export**

If you select a subset of the rows in the primary pane of a module view and select **Export to Excel**, then only the selected rows are exported.

If the rows selected are contiguous and the first row selected is at the highest level of the selected rows, then the rows in the spreadsheet will exhibit the same hierarchy. For example, in the following picture, where all the rows for Drop Box and for WalkIn have been selected, their hierarchy will be reflected in the Excel spreadsheet.

The following picture shows the resulting spreadsheet.
However, if you select non-contiguous rows that are at different levels, then it may not be possible to preserve the hierarchy in the spreadsheet. For example, in the following picture Eugene will be at the same level in the Excel spreadsheet as Drop Box and WalkIn. Because the rows selected are non-contiguous and at different levels, it is not practical for the export facility to reconstruct the larger hierarchy, of which the non-contiguous rows are a part.

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Display Reference</th>
<th>Cost ($)</th>
<th>Item View Order</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drop Box</td>
<td>Rollup Account</td>
<td>0.90</td>
<td>6</td>
</tr>
<tr>
<td>No Products and Services</td>
<td>Account</td>
<td>0.90</td>
<td>7</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>Account</td>
<td>0.90</td>
<td>8</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Account</td>
<td>0.90</td>
<td>9</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>Account</td>
<td>0.90</td>
<td>10</td>
</tr>
<tr>
<td>Walk In</td>
<td>Rollup Account</td>
<td>0.90</td>
<td>11</td>
</tr>
<tr>
<td>No Products and Services</td>
<td>Account</td>
<td>0.90</td>
<td>12</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>Account</td>
<td>0.90</td>
<td>13</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Account</td>
<td>0.90</td>
<td>14</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>Account</td>
<td>0.90</td>
<td>15</td>
</tr>
</tbody>
</table>

The following picture shows the resulting spreadsheet. Notice that an empty row separates the discontinuous hierarchies.
Other Features

Panes are Frozen for Better Scrolling
When you export a module view, the Excel panes are frozen so that the column header does not scroll vertically. The column header is always visible. And, the account names are frozen so that they do not scroll horizontally. They are always visible when you scroll horizontally to see all the account properties. You can unfreeze the panes in Excel if you want scrolling to perform differently.
Additional Columns

When you export a module view to Microsoft Excel, SAS Cost and Profitability Management includes two additional columns in the spreadsheet: (Type) and (Item View Order).

(Type)

Tells what sort of data the spreadsheet row is for:

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost ($)</th>
<th>Type</th>
<th>(Item View Order)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Administration</td>
<td>$162,000.00</td>
<td>Rollup Account</td>
<td>2</td>
</tr>
<tr>
<td>Sales Marketing</td>
<td>$100,500.00</td>
<td>Rollup Account</td>
<td>3</td>
</tr>
<tr>
<td>Add Shows</td>
<td>$15,000.00</td>
<td>Account</td>
<td>4</td>
</tr>
<tr>
<td>Deprec Facilities</td>
<td>$9,000.00</td>
<td>Account</td>
<td>5</td>
</tr>
<tr>
<td>Salary Trade Shows</td>
<td>$31,200.00</td>
<td>Account</td>
<td>6</td>
</tr>
<tr>
<td>Salary Direct Sales</td>
<td>$46,500.00</td>
<td>Account</td>
<td>7</td>
</tr>
<tr>
<td>Salary Sale Manager</td>
<td>$4,200.00</td>
<td>Account</td>
<td>8</td>
</tr>
<tr>
<td>Salary Engineer</td>
<td>$19,200.00</td>
<td>Account</td>
<td>9</td>
</tr>
</tbody>
</table>

Note: The (Type) column contains the same data as the Type column in a column layout. If the module view being exported already contains a Type column, then SAS Cost and Profitability Management does not add an additional (Type) column to the exported spreadsheet.

(Item View Order)

Use this column to restore a sorted spreadsheet to its original display order (see “Unsorting” on page 651).

Sorting

In order to sort columns in the exported Excel spreadsheet, you must first ungroup the Display Name column.

To ungroup the Display Name column:

1. Select columns A through F (the Display Name column).
2. On the Home tab, select Merge & Center ➔ Unmerge Cells.
3. Select the column that you want to sort and perform the sort.

**Unsorting**
To restore a sorted spreadsheet to its original display order, you can use the (Item View Order) column that SAS Cost and Profitability Management adds to the Excel Spreadsheet for this purpose. The column contains the number of each row in the spreadsheet’s original display order.

**Decimal Places**
The number of decimal places that are displayed in an exported Excel file are the number of decimal places that you specified in SAS Cost and Profitability Management by selecting Tools ⇒ User Options.
Row names
Every row in an exported Excel spreadsheet is named using the account ID. The format of the name is `<sheetname>_ID_<account ID>`. The name appears in the drop-down list located before the Excel formula bar, as shown in the following picture. If you select a name in the drop-down list, then the corresponding row is highlighted.

Checkboxes
Checkboxes in the module view are also displayed as checkboxes in the exported spreadsheet. However, the checkboxes in the exported spreadsheet only reflect what is in the module view. They cannot be edited.
Restrictions

Currency formatting
Because Microsoft Excel does not support all the currency formats that SAS Cost and Profitability Management supports, currency fields are formatted as numeric columns in an exported spreadsheet. The currency symbol is displayed in the column header of the exported spreadsheet instead of in each spreadsheet cell. After exporting a module view, you can use Microsoft Excel to format currency cells as you like.

The following picture shows a module view in which costs are displayed both in dollars (the base currency) and in Euros (converted from dollars).

The following picture shows the resulting exported spreadsheet. Notice that the currency symbol is displayed in the spreadsheet column header, and the formula used for conversion is displayed in the formula area.
Negative numbers

Regardless of how negative numbers are formatted in a module view, they are preceded by a minus sign (-) and displayed in black when exported to Microsoft Excel. This is because the negative number formatting in the SAS Cost and Profitability Management module view might not be available in Microsoft Excel depending upon Excel’s national language settings. Once the Excel file has been created, you can format negative numbers in it any way that you like.
Chapter 81
OLAP Views

Import OLAP Views

To import OLAP views:

1. Go to the Workspace Manager.

2. Select File ⇒ Import OLAP Views. Step 1 of the Import OLAP Views dialog box opens.

3. Select the XML file (containing the views) to be imported.

4. Specify the model to associate with the views being imported.
   
   Note: Although a model was specified when the OLAP views were exported, you can associate the views with a different model on import.

   Rename OLAP view being imported
   
   If an OLAP view already exists with the same name as an OLAP view being imported, the one being imported is renamed. This applies to every OLAP view being imported if multiple views are imported.

   Replace the existing OLAP view
   
   If an OLAP view already exists with the same name as an OLAP view being imported, then the existing one is replaced with the imported one.

   Do not import duplicate OLAP views
   
   If an OLAP view already exists with the same name as an OLAP view being imported, then don't import the duplicate view. Leave the existing one in place.

5. Click Next. Step 2 of the Import OLAP Views dialog box opens.

6. For each OLAP view being imported, select a cube from the Cube drop-down list to associate with that view.

   The Cube drop-down list shows all the cubes that have been previously generated (on the import-to machine) for the model selected in Step 1.
If you are importing multiple views, you can choose to bypass importing individual ones.

7. Click **Finish**. The select views are imported.

### See Also

“Export OLAP Views” on page 656

---

### Export OLAP Views

To export OLAP views to an XML file:

1. Go to the Workspace Manager.
2. Select **File** ➔ **Export OLAP Views**. The Export OLAP Views dialog box opens.
3. Select one or more OLAP views to be exported. You can export any view to which you have access.

   **Automatically check children**
   - Selecting this causes cube configurations inside a folder to be recursively selected when you select the folder.
   - **Note:** This only applies to subsequent folder selections. It does not select the children of folders that are already selected.

   **Include folders**
   - Selecting this causes folder information to be stored in the export file so that the folders can be recreated when you subsequently import the cube configurations.
   - **Note:** This option does not create folders in the export directory. It only stores the folder information in the export file so that the folders can be recreated later during import.

   **Export to this path and XML file name**
   - Select the path and name of the export file.
   - **Note:** Only one export file is created even if you select multiple folders and cube configurations to be exported.

4. Click **Finish**.

### See Also

- “Import OLAP Views” on page 655
- “Export to Excel” on page 656

---

### Export to Excel

To export an OLAP View to Excel, do the following:

1. Go to the **Analysis** workspace.
2. Open an OLAP view.

3. Select Analysis ⇒ Export to Excel

Below is an example of an Excel with flattened dimensions and without flattened dimensions.

### Dimensions Flattened
The Excel table has more columns and fewer rows. The table has a single row of column headers, with one level per column.

### Dimensions not Flattened
The Excel table has fewer columns and more rows. Each dimension has its own row.

The following picture shows an example of an Excel with flattened dimensions and without flattened dimensions.
Chapter 82
Export Registered Tables

Overview

You can create database tables and views that mirror the memory-mapped files used by SAS Cost and Profitability Management. Each such database table or view is registered in SAS metadata and can be accessed by other SAS programs as well as your own. To see metadata for the registered tables and views, from the Plug-ins tab of SAS Management Console, expand Environment Management/Data Library Manager/Libraries/CPM Library. You see a list of registered tables and views.

Additional metadata is stored in the Folders tab under SAS Folders/Products/SAS Cost and Profitability Management/Registered Tables and Views.
There are three categories of registered tables and views. Of these three categories, only the first contains tables that you have to export explicitly:

**Model-structure tables**
These tables describe the structure of a model. You must export these tables explicitly. See “Model-Structure Tables” on page 660.

**Model-independent views**
These views are exported and registered automatically. See “Model-Independent Views” on page 662.

**Fact-table related views**
These views are related to fact table generation. They are exported and registered automatically during cube generation. See “Fact-Table Related Views” on page 662.

---

### Model-Structure Tables

The following tables describe the structure of a model. You must create these tables explicitly. See “How To Export and Register Tables” on page 665.

<table>
<thead>
<tr>
<th>Table Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>ModelRef_ACCOUNTMAP</code></td>
<td>A join of <code>ModelRef_PV_ACCOUNT</code> with other registered tables. Includes details for multiple periods, dimensional signature, and all numeric properties. See “<code>modelRef_ACCOUNTMAP</code>” in Chapter 8 of <em>SAS Cost and Profitability Management: Data Administration Guide</em>.</td>
</tr>
<tr>
<td><code>ModelRef_ASSIGNMENTMAP</code></td>
<td>A join of <code>ModelRef_PV_ASSIGNMENT</code> with other registered tables. Includes details for source and destination dimensional signatures, and all entered and calculated properties. See “<code>modelRef_ASSIGNMENTMAP</code>” in Chapter 8 of <em>SAS Cost and Profitability Management: Data Administration Guide</em>.</td>
</tr>
<tr>
<td>Table Name</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------</td>
<td>--------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>ModelRef_PV_ACCOUNT</td>
<td>Details for multiple periods, dimensional signature, and all numeric properties.</td>
</tr>
<tr>
<td></td>
<td>See “modelRef_PV_ACCOUNT ” in Chapter 8 of SAS Cost and Profitability Management: Data Administration Guide.</td>
</tr>
<tr>
<td>ModelRef_PV_ASSIGNMENT</td>
<td>Details for source and destination dimensional signatures, and all entered and calculated properties.</td>
</tr>
<tr>
<td></td>
<td>See “modelRef_PV_ASSIGNMENT ” in Chapter 8 of SAS Cost and Profitability Management: Data Administration Guide.</td>
</tr>
<tr>
<td>ModelRef_PV_ASSIGNMENTTEXT</td>
<td>Details for source and destination dimensional signatures, and all entered and calculated properties.</td>
</tr>
<tr>
<td></td>
<td>See “modelRef_PV_ASSIGNMENTTEXT ” in Chapter 8 of SAS Cost and Profitability Management: Data Administration Guide.</td>
</tr>
<tr>
<td>ModelRef_PV_ATTRIBUTE</td>
<td>Details defining the attribute, attribute types, formulas for calculations, and default values.</td>
</tr>
<tr>
<td></td>
<td>See “modelRef_PV_ATTRIBUTE” in Chapter 8 of SAS Cost and Profitability Management: Data Administration Guide.</td>
</tr>
<tr>
<td>ModelRef_PV_ATTRIBUTEVALUE</td>
<td>Attribute attachment to the model accounts and the numeric value for the attribute.</td>
</tr>
<tr>
<td></td>
<td>See “modelRef_PV_ATTRIBUTEVALUE ” in Chapter 8 of SAS Cost and Profitability Management: Data Administration Guide.</td>
</tr>
<tr>
<td>ModelRef_PV_DIMENSION</td>
<td>Details defining the model's dimensions.</td>
</tr>
<tr>
<td></td>
<td>See “modelRef_PV_DIMENSION ” in Chapter 8 of SAS Cost and Profitability Management: Data Administration Guide.</td>
</tr>
<tr>
<td>ModelRef_PV_DRIVER</td>
<td>Details defining the drivers, driver types, and formulas for rules assignment and for calculations.</td>
</tr>
<tr>
<td></td>
<td>See “modelRef_PV_DRIVER ” in Chapter 8 of SAS Cost and Profitability Management: Data Administration Guide.</td>
</tr>
<tr>
<td>ModelRef_PV_ENTEREDCE</td>
<td>Details of all entered cost elements, with their corresponding account attachment and values.</td>
</tr>
<tr>
<td></td>
<td>See “modelRef_PV_ENTEREDCE ” in Chapter 8 of SAS Cost and Profitability Management: Data Administration Guide.</td>
</tr>
</tbody>
</table>
**Model-Independent Views**

The following model-independent views are created automatically.

<table>
<thead>
<tr>
<th>View Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PUBLICMODEL</td>
<td>Contains a list of models.</td>
</tr>
<tr>
<td></td>
<td>See “PUBLICMODEL” in Chapter 8 of <em>SAS Cost and Profitability Management: Data Administration Guide</em>.</td>
</tr>
<tr>
<td>PUBLICMODELSTATUS</td>
<td>For each model, lists its period scenario associations and whether each one is calculated or not.</td>
</tr>
<tr>
<td></td>
<td>See “PUBLICMODELSTATUS” in Chapter 8 of <em>SAS Cost and Profitability Management: Data Administration Guide</em>.</td>
</tr>
<tr>
<td>PUBLICPERIOD</td>
<td>Contains a list of periods with their start and end dates.</td>
</tr>
<tr>
<td></td>
<td>See “PUBLICPERIOD” in Chapter 8 of <em>SAS Cost and Profitability Management: Data Administration Guide</em>.</td>
</tr>
<tr>
<td>PUBLICSCENARIO</td>
<td>Contains a list of scenarios.</td>
</tr>
<tr>
<td></td>
<td>See “PUBLICSCENARIO” in Chapter 8 of <em>SAS Cost and Profitability Management: Data Administration Guide</em>.</td>
</tr>
</tbody>
</table>

**Fact-Table Related Views**

The following model-specific views are related to fact table generation. These views are created and registered automatically during cube generation.

<table>
<thead>
<tr>
<th>View Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>ModelRef_PD_COSTELEMENT</em>&lt;suffix&gt;</td>
<td>Details defining the types of cost elements.</td>
</tr>
<tr>
<td></td>
<td>See “modelRef_PD_COSTELEMENT&lt;suffix&gt;” in Chapter 8 of <em>SAS Cost and Profitability Management: Data Administration Guide</em>.</td>
</tr>
</tbody>
</table>

- <suffix> is RC, SSC, or C<cube configuration ID> for a multi-stage contributions cube.

For example:

- ABC_PD_COSTELEMENTRC
- ABC_PD_COSTELEMENTSSC
- ABC_PD_COSTELEMENTC1001
### Fact-Table Related Views

<table>
<thead>
<tr>
<th>View Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>ModelRef_PD_dimShortRef&lt;suffix&gt;</code></td>
<td>Single dimension-member details: level by level, noting ID, Reference, and Name.</td>
</tr>
<tr>
<td>where <code>&lt;suffix&gt;</code> is RC, SSC, or C&lt;cube configuration ID&gt; for a multi-stage contributions cube.</td>
<td>See “modelRef_PD_dimShortRef&lt;suffix&gt;” in Chapter 8 of SAS Cost and Profitability Management: Data Administration Guide.</td>
</tr>
<tr>
<td>For example: ABC_PD_REGIONRC</td>
<td></td>
</tr>
<tr>
<td>ABC_PD_REGIONSSC</td>
<td></td>
</tr>
<tr>
<td>ABC_PD_REGIONC1001</td>
<td></td>
</tr>
<tr>
<td><code>ModelRef_PD_DRIVER&lt;suffix&gt;</code></td>
<td>Driver ID and corresponding Driver Name.</td>
</tr>
<tr>
<td>where <code>&lt;suffix&gt;</code> is RC, SSC, or C&lt;cube configuration ID&gt; for a multi-stage contributions cube.</td>
<td>See “modelRef_PD_DRIVER&lt;suffix&gt; ” in Chapter 8 of SAS Cost and Profitability Management: Data Administration Guide.</td>
</tr>
<tr>
<td>For example: ABC_PD_DRIVERRC</td>
<td></td>
</tr>
<tr>
<td>ABC_PD_DRIVERSSC</td>
<td></td>
</tr>
<tr>
<td>ABC_PD_DRIVERC1001</td>
<td></td>
</tr>
<tr>
<td><code>ModelRef_PD_MODULE&lt;suffix&gt;</code></td>
<td>Details defining the types of modules.</td>
</tr>
<tr>
<td>where <code>&lt;suffix&gt;</code> is RC, SSC, or C&lt;cube configuration ID&gt; for a multi-stage contributions cube.</td>
<td>See “modelRef_PD_MODULE&lt;suffix&gt;” in Chapter 8 of SAS Cost and Profitability Management: Data Administration Guide.</td>
</tr>
<tr>
<td>For example: ABC_PD_MODULERC</td>
<td></td>
</tr>
<tr>
<td>ABC_PD_MODULESSC</td>
<td></td>
</tr>
<tr>
<td>ABC_PD_MODULEC1001</td>
<td></td>
</tr>
<tr>
<td><code>ModelRef_PD_PERIOD&lt;suffix&gt;</code></td>
<td>Details defining the periodic hierarchy.</td>
</tr>
<tr>
<td>where <code>&lt;suffix&gt;</code> is RC, SSC, or C&lt;cube configuration ID&gt; for a multi-stage contributions cube.</td>
<td>See “modelRef_PD_PERIOD&lt;suffix&gt; ” in Chapter 8 of SAS Cost and Profitability Management: Data Administration Guide.</td>
</tr>
<tr>
<td>For example: ABC_PD.PERIODRC</td>
<td></td>
</tr>
<tr>
<td>ABC_PD.PERIODSSC</td>
<td></td>
</tr>
<tr>
<td>ABC_PD.PERIODC1001</td>
<td></td>
</tr>
<tr>
<td>View Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>ModelRef_PD_SCENARIO&lt;suffix&gt;</td>
<td>Details defining the types of available scenarios. See “modelRef_PD_SCENARIO&lt;suffix&gt;” in Chapter 8 of SAS Cost and Profitability Management: Data Administration Guide.</td>
</tr>
<tr>
<td>where &lt;suffix&gt; is RC, SSC, or C&lt;cube configuration ID&gt; for a multi-stage contributions cube.</td>
<td></td>
</tr>
<tr>
<td>For example:</td>
<td></td>
</tr>
<tr>
<td>ABC_PD_SCENARIORC</td>
<td></td>
</tr>
<tr>
<td>ABC_PD_SCENARIOSSC</td>
<td></td>
</tr>
<tr>
<td>ABC_PD_SCENARIOOC1001</td>
<td></td>
</tr>
<tr>
<td>ModelRef_PD_YESNO&lt;suffix&gt;</td>
<td>Dimensional definition for Boolean values: Text strings. See “modelRef_PD_YESNO&lt;suffix&gt;” in Chapter 8 of SAS Cost and Profitability Management: Data Administration Guide.</td>
</tr>
<tr>
<td>where &lt;suffix&gt; is RC, SSC, or C&lt;cube configuration ID&gt; for a multi-stage contributions cube.</td>
<td></td>
</tr>
<tr>
<td>For example:</td>
<td></td>
</tr>
<tr>
<td>ABC_PD_YESNORC</td>
<td></td>
</tr>
<tr>
<td>ABC_PD_YESNOSSC</td>
<td></td>
</tr>
<tr>
<td>ABC_PD_YESNOC1001</td>
<td></td>
</tr>
<tr>
<td>ModelRef_PF_&lt;suffix&gt;</td>
<td>Fact Table: Stages and member IDs for each step through contribution. Source table for cube generation. See “modelRef_PF_&lt;suffix&gt;” in Chapter 8 of SAS Cost and Profitability Management: Data Administration Guide.</td>
</tr>
<tr>
<td>where &lt;suffix&gt; is RC, SSC, or &lt;CubeConfigRef&gt; for a multi-stage contributions cube.</td>
<td></td>
</tr>
<tr>
<td>For example:</td>
<td></td>
</tr>
<tr>
<td>ABC_PF_RC</td>
<td></td>
</tr>
<tr>
<td>ABC_PF_SSC</td>
<td></td>
</tr>
<tr>
<td>ABC_PF_abcRef</td>
<td></td>
</tr>
<tr>
<td>If you have checked Also load tables into a library for the SAS LASR Analytic Server, then, in addition to the tables using the naming convention above, tables in star-schema format are also generated that use the following naming convention:</td>
<td></td>
</tr>
<tr>
<td>ModelRef_PF_&lt;suffix&gt;</td>
<td></td>
</tr>
<tr>
<td>where &lt;suffix&gt; is RCSTAR, SSCSTAR, or &lt;cubeConfigRef&gt;STAR for a multi-stage contributions cube.</td>
<td></td>
</tr>
<tr>
<td>For example:</td>
<td></td>
</tr>
<tr>
<td>ABC_PF_RCSTAR</td>
<td></td>
</tr>
<tr>
<td>ABC_PF_SSCSTAR</td>
<td></td>
</tr>
<tr>
<td>ABC_PF_abcRefSTAR</td>
<td></td>
</tr>
</tbody>
</table>
How To Export and Register Tables

Model data is stored in memory-mapped files rather than in a database. You can create database tables and views that mirror the memory-mapped files and are registered in SAS Metadata so as to be available to other SAS programs or for your own use.

To export database tables and views:

1. Select Model ➔ Export and Register Tables.

The Export and Register Tables dialog box opens.

2. Select whether to Also load selected tables into a library for the SAS LASR Analytic Server.

With this option, tables are created and registered in a SAS metadata library that is enabled for the SAS LASR Analytic Server.

Note:

- For the option Also load selected tables into a library for the SAS LASR Analytic Server to be available, you must have specified this library in the Metadata Server Options dialog box. See “Metadata Server Options” on page 478.
- In the Metadata Server Options dialog box, make sure that you have selected SASApp – Logical Workspace Server as shown in the following display.
You must also have authorization to write to the folder that is enabled for library. If you do not have those rights, the option is disabled. See “Authorize Users for the LASR-Enabled Metadata Library” in Chapter 15 of SAS Cost and Profitability Management: Data Administration Guide.

3. Select the tables that you want to export.

4. Click OK.

To see metadata for the registered tables and views, from the Plug-ins tab of SAS Management Console expand Environment Management/Data Library Manager/Libraries/CPM Library. Additional metadata is stored in the Folders tab under SAS Folders/Products/SAS Cost and Profitability Management/Registered Tables and Views.

Note:

- Model-independent tables are exported and registered automatically. You do not have to select them in order for them to be exported, so they are not listed in this dialog. See “Model-Independent Views” on page 662.

- Fact-table tables are exported automatically when you generate a model, so you do not have to select them here. See “Fact-Table Related Views” on page 662. But, you do have to specify in a cube configuration if you also want the fact-table tables to be exported for the SAS LASR Analytic Server. See “Cube Configuration: Select a Model and General Options” on page 482.
Using Easy API

Overview

Using Easy API, you can do in batch many of the same operations that you can do inside SAS Cost and Profitability Management. With Easy API, you can do the following:

• Acquire or release a Read or Read/Write lock on a model
• Terminate a Write lock on a model
• Import and export model data
• Calculate a model
• Generate a cube
• Copy and paste a model
• Copy model data from one period/scenario to another
• Import and export cube configurations
• Export and register tables
• Export model data as a report
• Export model data for performing a survey

In addition, you can use Easy API to run SAS stored processes, an external SAS Enterprise Guide project, or any other executable that you want to invoke. So, for example, you can use Easy API to export model data, invoke a SAS stored process to update the exported data, and finally import the updated data back into your model.

Operations are run in the order specified in your EasyAPI.txt file. Whatever operations you perform, Easy API synchronizes them so that the next operation to run does not
begin until the previous one has finished. For example, a SAS program to update exported tables does not run until the tables have been exported.

Invoking Easy API to perform a SAS Cost and Profitability Management operation involves three steps:

1. “Create an XML File” on page 668
   The XML file describes the operation to be performed.

2. “Save Easy API Commands in a Text File” on page 669
   Easy API commands invoke SAS Cost and Profitability Management and pass an XML file to tell it what to do.

3. “Invoke Easy API” on page 672
   Easy API uses the text file to run its commands.

See also
For more information, see Chapter 13, “Easy API,” in SAS Cost and Profitability Management: Data Administration Guide.

Create an XML File

SAS Cost and Profitability Management uses XML internally to encode the information that it needs for performing operations. Easy API uses the same XML to invoke SAS Cost and Profitability Management in batch to perform those operations. Following is sample XML to generate a cube. Notice that the XML specifies the model, periods, and cube configuration to be used in generating the cube.

Because Easy API uses exactly the same XML to invoke SAS Cost and Profitability Management that SAS Cost and Profitability Management itself uses internally, the easiest way for you to create the XML that you need to run Easy API is to ask SAS Cost and Profitability Management to create it.

To ask SAS Cost and Profitability Management to create XML:

1. Inside SAS Cost and Profitability Management, select Tools ⇒ User Options.
2. Click the Easy API Configuration tab.
3. Select Save operation xml in directory path.
4. Specify the directory path where the XML will be saved.

   Now, when you perform an operation inside SAS Cost and Profitability Management, the XML for that operation is saved in a file in the directory that you specified.
You can modify the XML file to suit your purposes. For example, you might modify the XML file shown here to generate different periods for the same model or to generate the same periods for a different model.

For detailed information on the XML files, see Chapter 12, “XML Passed to the API,” in *SAS Cost and Profitability Management: Data Administration Guide*.

### Save Easy API Commands in a Text File

The following table lists the Easy API commands and tells what each command does. Notice that each command takes one parameter which is either the path and name of an XML file, or the path and name of an external program.

<table>
<thead>
<tr>
<th>Command and sample argument</th>
<th>What it does</th>
</tr>
</thead>
</table>
| acquiremodellock "read | write" "modelRef" | Acquires a Read or Write lock on the model.  
*Note:* If you do not issue acquiremodellock before performing an operation on a model, the system attempts to do it for you. It is recommended, however, that you explicitly acquire a lock on a model before performing an operation. |
| releasemodellock "modelRef" | Releases whatever lock (Read or Write) that is on the model.  
*Note:* If you do not issue releasemodellock, the system releases the lock on the model for you. It is recommended, however, that you explicitly release the lock on a model to ensure that it is available for other operations. |
| terminatewritelock “modelRef” | Terminates a Write lock that is acquired by a modeler on the model. |
| calculate "<folder_path>/your.xml" | Calculates and/or generates a cube.  
*Note:* The XML file that you use determines whether this command does a calculation or generates a cube. |
<table>
<thead>
<tr>
<th>Command and sample argument</th>
<th>What it does</th>
</tr>
</thead>
<tbody>
<tr>
<td>copypaste &quot;&lt;folder_path&gt;/&lt;your.xml&quot;</td>
<td>Copies model data and pastes it as a new model.</td>
</tr>
<tr>
<td>copyperiod &quot;&lt;folder_path&gt;/&lt;your.xml&quot;</td>
<td>Copies model data from one period/scenario to another</td>
</tr>
<tr>
<td>export &quot;&lt;folder_path&gt;/&lt;your.xml&quot;</td>
<td>Exports model data.</td>
</tr>
<tr>
<td>export cube &quot;&lt;folder_path&gt;/&lt;your.xml&quot;</td>
<td>Exports cube configurations.</td>
</tr>
<tr>
<td></td>
<td>The cube configuration name and cube configuration reference that appear in the XML file to export the cube configuration must adhere to the following guidelines:</td>
</tr>
<tr>
<td></td>
<td>• Do not use the following characters in the cube configuration name: ' (single quotation mark), &quot; (quotation mark), / (slash), \ (backslash), or</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Do not use the following characters in the cube configuration characters: (space), . (period), , (comma), ; (semicolon), ' (single quotation mark), ` (grave accent), : (colon), ? (question mark), * (asterisk), &amp; (ampersand), % (percent sign), $ (dollar sign), ! (exclamation point), - (en dash), + (plus sign), = (equal sign), ( (opening parenthesis), ) (closing parenthesis), [ ] (brackets), { } (braces), / (slash), \ (backslash),</td>
</tr>
<tr>
<td>export and register tables &quot;&lt;folder_path&gt;/&lt;your.xml&quot;</td>
<td>Exports database tables that are registered in SAS Management Console for use with other SAS or non SAS programs. See Chapter 82, “Export Registered Tables,” on page 659.</td>
</tr>
<tr>
<td>export surveys &quot;&lt;folder_path&gt;/&lt;your.xml&quot;</td>
<td>Exports model data for conducting a survey. The model data is exported and saved in an Microsoft Excel file.</td>
</tr>
<tr>
<td>import &quot;&lt;folder_path&gt;/&lt;your.xml&quot;</td>
<td>Imports model data and survey data.</td>
</tr>
<tr>
<td>import cube &quot;&lt;folder_path&gt;/&lt;your.xml&quot;</td>
<td>Imports cube configurations.</td>
</tr>
<tr>
<td></td>
<td>The cube configuration name and cube configuration reference that appear in the XML file to import the cube configuration must adhere to the following guidelines:</td>
</tr>
<tr>
<td></td>
<td>• Do not use the following characters in the cube configuration name: ' (single quotation mark), &quot; (quotation mark), / (slash), \ (backslash), or</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Do not use the following characters in the cube configuration characters: (space), . (period), , (comma), ; (semicolon), ' (single quotation mark), ` (grave accent), : (colon), ? (question mark), * (asterisk), &amp; (ampersand), % (percent sign), $ (dollar sign), ! (exclamation point), - (en dash), + (plus sign), = (equal sign), ( (opening parenthesis), ) (closing parenthesis), [ ] (brackets), { } (braces), / (slash), \ (backslash),</td>
</tr>
<tr>
<td>Command and sample argument</td>
<td>What it does</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>--------------</td>
</tr>
<tr>
<td>export report &quot;&lt;folder_path&gt;\your.xml&quot;</td>
<td>Exports model data as a report. The XML file contains the required information (such as the name of the model, the dimensions, the type of report template, the periods and scenarios, and the database) to export the model data as a report. Suppose that you are exporting the model data as a report using the EasyAPI and a table with the same name already exists in the database. Then you must have exported the model data by selecting the <strong>Replace the table if a table with the same name already exists in the database</strong> check box in the Report Data wizard using the user interface of SAS Cost and Profitability Management at least once.</td>
</tr>
<tr>
<td>run &quot;&lt;folder_path&gt;\your.xml&quot;</td>
<td>Executes external programs including, but not limited to, SAS Stored Processes. For example, you can also run SAS Enterprise Guide vbscripts using this run command.</td>
</tr>
<tr>
<td>// Comment</td>
<td>You can put ‘ (single quotation mark) or // (double slash) in front of the command line to comment out (skip) a particular Easy API command.</td>
</tr>
</tbody>
</table>

**Note:** Refer to the PeriodDefinition and ScenarioDefinition database tables to obtain the values of the PeriodId and ScenarioId tags to used in the XML file.

To issue an Easy API command, put it in a text file named EasyAPI.txt residing in the following directory:

<installation directory>SASCostandProfitabilityManagementClient\8.4\EasyAPI\ For example: C:\Program Files\SASHome\x86\SASCostandProfitabilityManagementClient\8.4\EasyAPI\ To open the EasyAPI.txt, select **Start ➸ All Programs ➸ SAS ➸ SAS Cost and Profitability Management 8.4 ➸ EasyAPI ➸ 2. Specify parameters**. The following picture shows EasyAPI.txt as it is appears on installation of SAS Cost and Profitability Management.

![EasyAPI.txt](notepad.png)

Make sure to include your login credentials in the txt file.
The following picture shows EasyAPI.txt for logging on with IWA.

And the following picture shows EasyAPI.txt for logging on without IWA.

**Invoke Easy API**

To invoke Easy API, select Start ⇒ All Programs ⇒ SAS ⇒ SAS Cost and Profitability Management 8.4 ⇒ EasyAPI ⇒ 3. Run.

Easy API can e-mail you the results of its operation. To receive an e-mail with operation results:

1. Inside SAS Cost and Profitability Management, select Tools ⇒ User Options.
2. Click the Easy API Configuration tab.
3. Specify an SMTP server for sending the mail.
4. Specify an Email Id for successful operation.
5. Specify an Email Id for failure of operation.
Notes:

- Log files named EasyAPI.log or CustomEasyAPI.log are created in the Easy API Installation folder. You can also access the Easy API operations log in the Windows Event Viewer.

- You can also invoke Easy API by running EasyAPI.exe, which is installed in `<installation directory>\SAS\CostandProfitabilityManagementClient\8.4\EasyAPI\`. If you don't supply a path argument, then Easy API uses EasyAPI.txt in its installation directory.

- By supplying a path argument to EasyAPI.exe, you can tell it to use a different txt file for Easy API commands, for example, `EasyAPI.exe "c:\MyPath\EasyAPI2.txt"`. If you don't supply a path argument, then Easy API uses EasyAPI.txt in its installation directory.

- You can use the Microsoft Windows Scheduled Tasks Wizard to schedule EasyAPI.exe to run automatically at selected intervals.

- In the EasyAPI.txt file, you can either store your password in clear text or you can encode it using EncodePassword.exe located at `<installation directory>\SAS\CostandProfitabilityManagementClient\8.4\EasyAPI\`. EncodePassword.exe produces an encoded string that you can paste into EasyAPI.txt. Easy API then decodes the password before performing Easy API operations.

---

For More Information

See Chapter 13, “Easy API,” in *SAS Cost and Profitability Management: Data Administration Guide*. 
Part 22

Reporting Model Data

Chapter 84

About Reports ......................................................... 677

Chapter 85

Windows for Reports ..................................................... 679

Chapter 86

How To: Reports .......................................................... 685
**Chapter 84**

**About Reports**

---

**Reports**

You can export the model data for various periods and scenarios to generate the following types of reports:

- Destination Furthest
- Driver - Cost and Rate
- Multi-Level Contributions
- Resource Contribution
- Unassigned Costs
- Unit Cost
- Dimensional Attribute Cost

SAS Cost and Profitability Management contains a template for each type of report. SAS Cost and Profitability Management exports the model data in a table in the database. You can create a report to view, share, and analyze the data.

---

**Report Templates**

A report template specifies the layout of a report and the fields of data in a report (but not the report's data itself). When you create a report, you choose a report template.

SAS Cost and Profitability Management comes with several predefined report templates that provide set formats and permit great flexibility in the amount and type of data to include in a report. For information on the following templates, see “Working with Reports” in the *SAS Cost and Profitability Management: Data Administration Guide*, available from the Help menu or see a potentially more recent version at [http://support.sas.com/documentation/onlinedoc/abm/](http://support.sas.com/documentation/onlinedoc/abm/).
<table>
<thead>
<tr>
<th>Destination Furthest</th>
<th>Resource Contributions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dimensional Attribute Cost</td>
<td>Unassigned Costs</td>
</tr>
<tr>
<td>Multilevel Contributions</td>
<td>Unit Cost</td>
</tr>
<tr>
<td>Driver - Cost and Rate</td>
<td></td>
</tr>
</tbody>
</table>

Chapter 84 • About Reports
Chapter 85
Windows for Reports

Reports Folder

About the Reports Folder
In the Workspace Manager, the report configurations are available in the Report Data Exports folder. You can open a report configuration to export the model data. You can create a report configuration to save the new settings to export the model data.

Note: The availability of these features depends on your permissions.

How to Access the Reports Folder
After you log on to SAS Cost and Profitability Management, click Workspace Manager. The Workspace Manager displays a list of all folders, including the Report Data Exports folder.

Export Report Data to SAS Data Sets
To export report data to SAS data sets:
1. On the Database Location step of the Report Data wizard, select Use alternate database and then choose Browse.
The Connection Information dialog box appears.
For more information, see Step 7 on page 686.

2. In the Database type list, select SAS datasets.
3. Enter information in the following fields.

Table 85.1 Description of Fields to Export Report Data to SAS Data Sets

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Folder path relative to the IOM server</td>
<td>The folder containing SAS data sets for import or export must be accessible by the SAS Integrated Object Model (IOM) server.</td>
</tr>
<tr>
<td></td>
<td>• If the folder is on the same machine as the SAS IOM server, then you can specify the folder using a path such as c:\datasetexport.</td>
</tr>
<tr>
<td></td>
<td>• If the folder is on a different machine than the SAS IOM server, then you must specify the machine name in specifying the path. For example, if the folder, datasetexport, is on machine xyz, then you might specify the path as \xyz\datasetexport.</td>
</tr>
<tr>
<td>Advanced options</td>
<td>The advanced options that you might want to consider to connect to a SAS data set.</td>
</tr>
</tbody>
</table>

4. (Optional) Click Test Connection to test the database connection.
5. Click OK.

Export Report Data to the Microsoft SQL Server

To export report data to the Microsoft SQL server:

1. On the Database Location step of the Report Data wizard, select Use alternate database and then choose Browse.

   The Connection Information dialog box appears.
   For more information, see Step 7 on page 686.

2. In the Database type list, select Microsoft SQL server.
3. Enter information in the following fields.

Table 85.2 Description of Fields to Export Report Data to the Microsoft SQL Server

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Host name</td>
<td>The machine name where the target database is installed.</td>
</tr>
<tr>
<td>Port number</td>
<td>The TCP port where the target database instance is running. Adam to the SQL server configuration manager to check the TCP port on which it is running. Named Instances run on a dynamic TCP port.</td>
</tr>
</tbody>
</table>
### Export Report Data to Oracle

To export report data to Oracle:

1. On the **Database Location** step of the Report Data wizard, select **Use alternate database** and then choose **Browse**.

   The Connection Information dialog box appears.

   For more information, see [Step 7 on page 686](#).

2. In the **Database type** list, select **Oracle**.

3. Enter information in the following fields.

   **Table 85.3 Description of Fields to Export Report Data to Oracle**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Host name</td>
<td>The machine name where the target database is installed.</td>
</tr>
<tr>
<td>Port number</td>
<td>The TCP port where the target database instance is running.</td>
</tr>
</tbody>
</table>

---

4. (Optional) Click **Test Connection** to test the database connection.

5. Click **OK**.
Field | Description
--- | ---
Service name | You can find the values of Host name and Service name in the file `tnsnames.ora`.
ABMDSN2 =
(Description =
(Address List =
(ADDRESS = (PROTOCOL = TCP)(HOST = abmblade1)(PORT = 1521))
)
) (Connect Data =
(Service Name = abmdsn)
)

Username | The user name to connect to the database.
Password | The password to connect to the database.
Advanced options | The advanced options that you might want to consider while connecting to an Oracle database. You might want to open the `sqlnet.ora` file and verify that it has EZCONNECT specified under NAMES.DIRECTORY_PATH=(TNSNAMES, EZCONNECT).
This file is at the same location as `tnsnames.ora`. For example:
C:\Oracle\product\11.1.0\client_1\network\admin\sqlnet.ora

4. (Optional) Click Test Connection to test the database connection.
5. Click OK.

Export Report Data to PostgreSQL

To export report data to PostgreSQL:
1. On the Database Location step of the Report Data wizard, select Use alternate database and then choose Browse.
The Connection Information dialog box appears.
For more information, see Step 7 on page 686.
2. In the Database type list, select PostgreSQL.
3. Enter information in the following fields.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Host name</td>
<td>The host name.</td>
</tr>
<tr>
<td>Port number</td>
<td>The port number.</td>
</tr>
</tbody>
</table>
Export Report Data to Another Database

To export report data to another database:

1. On the Database Location step of the Report Data wizard, select Use alternate database and then choose Browse.
   The Connection Information dialog box appears.
   Step 7 on page 686For more information, see .
2. In the Database type list, select Other.
3. Enter information in the following fields.

Table 85.5 Description of Fields to Export Report Data to Another Database

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Host name</td>
<td>The host name.</td>
</tr>
</tbody>
</table>
| ODBC DSN       | Select from the drop-down list. The list includes all the System Open Database Connectivity (ODBC) data source name (DSN) that users have created on the SAS IOM server.  
                 |  
                 | **Note:**  
                 | • It is recommended that you create a System ODBC DSN on the SAS IOM server machine and use it in the connection details.  
                 | • A DSN for Postgres should be created with the Unicode version of the Postgres driver (PostgreSQL Unicode(x64)).  
| Username       | The user name to connect to the database.                                                                                                     |
| Password       | The password to connect to the database.                                                                                                       |
Field | Description
---|---
**Advanced options** | By default, the catalog name is *Staging*. You can specify any arbitrary name for CATALOG= because it is a logical name that is used internally by the system. Most databases require a catalog name to be specified in the connection URL but not all. For example, the SQL server does not require a catalog name. If you attempt to connect to a database that does not require a catalog name, then you must remove it from the **Advanced options** field or the connection will fail. Click **Edit** to modify the connection URL.

**Connection URL** | When you click **Test Connection**, the system takes the information that you enter and constructs a connection URL that it displays in the **Connection URL** field. Click **Edit** to modify the connection URL.

Following is a sample connection URL for a connection based on ODBC DSN:

```
DRIVER=ODBC;ODBC_DSN=DSNMySQL;UID=root;PWD=Pass99;CATALOG=Staging;
```

If you want to use an ODBC driver to connect to the target database, then the system creates a connection URL (which you can modify) for you. If you want to use a driver other than ODBC, then click **Edit** to enter the URL yourself.

4. (Optional) Click **Test Connection** to test the database connection.

5. Click **OK**.
Chapter 86
How To: Reports

Create a Report to Export Model Data ........................................... 685
Use a Report Configuration to Export Report Data .................. 687
Delete a Report Configuration ..................................................... 688

Create a Report to Export Model Data

Creating a report exports data from model data to a database. Modelers (with Read or
Read/Write access to a model) and viewers (with Read access to a model) can create a
report to export the data for the model. You must also need permission to the SAS
Folders\Products\SAS Cost and Profitability Management
\Registered Tables and Views directory in SAS Management Console to
register the report tables.

To create resource contributions and destination furthest reports, you must have already
generated the RC fact table for the model.

Perform the following steps to create a report:

   The Report Data Wizard appears.

2. On the Select Type step, select a report template and click Next.
   For information about what data each report template contains, see “Working with
   Reports” in the SAS Cost and Profitability Management: Data Administration Guide,
   available from the Help menu or from http://support.sas.com/documentation/
onlinedoc/abm/.

3. On the Select Model step, select a model to export its data and click Next.
   Note: You must have required Read or Read/Write permission to the model.

4. On the Select Period/Scenario step, select the periods and scenarios for which you
   want to export the report data, and click Next.

5. On the Select Module step, select a module for which you want to export the data,
   and click Next.
   To include data from all the modules, select the Use all modules option.
6. On the **Select Dimensional Attributes** step, select the dimensional attributes, and click **Next**.

   *Note:* The check boxes of this step are available when you selected the Dimensional Attribute Cost report.

7. On the **Database Location** step, use the following options to export the report data to a database:

   **Table 86.1 Description of Fields of the Database Location Step**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Select Database Location</strong></td>
<td></td>
</tr>
<tr>
<td>Use default database</td>
<td>Select this option to export the report data to the default database that SAS Cost and Profitability Management uses.</td>
</tr>
<tr>
<td>Use alternate database</td>
<td>Select this option to export the report data to a database other than the default database.</td>
</tr>
<tr>
<td>Browse to set up an alternate database connection</td>
<td>Click <strong>Browse</strong> to set up an alternate database connection to export the report data. After you click this button, the Connection Information dialog box appears. This button is available only when you select the <strong>Use alternate database</strong> option.</td>
</tr>
<tr>
<td><strong>Destination table name</strong></td>
<td>Enter a name for the database table. The table name must include alphanumeric characters. The only special character allowed is the underscore. The table name must not be more than 22 characters. SAS Cost and Profitability Management displays the letter R followed by the model ID and underscore before the field. This displayed information is prefixed to the table name that you enter in this field. In other words, SAS Cost and Profitability Management creates a table with a name in the following format: \texttt{R&lt;model_ID&gt;_user_specified_name}. For example, suppose that the model ID is 1234 and the table name that you enter is FY2018. Then, the \texttt{R1234_FY2018} table is created.</td>
</tr>
<tr>
<td>Load table into a library for SAS LASR Analytic Server</td>
<td>Click this check box to load the report data into a library for the SAS LASR Analytic Server. This check box is available when the SAS LASR Analytic Server is configured and you are exporting the report data to the default database.</td>
</tr>
<tr>
<td>Replace the table if a table with the same name already exists in the database</td>
<td>Select this check box to replace the table with the same name that is specified in the <strong>Destination table name</strong> field if it already exists in the database.</td>
</tr>
</tbody>
</table>

8. Click **Next**.

9. Review the summary.
10. (Optional) If you need to change any information, click Back until you reach the page that you need to change in the wizard.

11. (Optional) To save the report configuration so that the report can be easily run again, do the following:
   a. Select the Save configuration as option.
   b. Enter the Name.
   c. Enter the Description.

12. (Optional) To save the report configuration so that the report can be easily run without exporting the report data immediately, do the following:
   a. Select the Save without running option.
   b. Enter the new Name.
   c. Enter the Description.

13. Click Finish.

---

**Use a Report Configuration to Export Report Data**

You can use an already saved report configuration to easily export the report data. The configuration contains the following information:

- report template
- model
- periods and scenario associations
- module and dimension attributes
- information about the database connection

*Note:* Suppose that you created a report and its configuration definitions in SAS Activity-Based Management 7.1 and SAS Activity-Based Management 7.2 and you migrated to SAS Cost and Profitability Management 8.4. In such a scenario, the report configurations that were created in SAS Activity-Based Management 7.1 and SAS Activity-Based Management 7.2 are not migrated to SAS Cost and Profitability Management 8.4. You must create the report configurations again in SAS Cost and Profitability Management 8.4.

To use the report configuration to export the report data:

1. In the Workspace Manager, open the Report Data Exports folder.
2. Right-click a report configuration and click Open. The Report Data wizard appears and contains all the report-related information already selected in it.
3. (Optional) Change the report configuration information to meet any business requirements.
   You might want to change the name of the report table to avoid replacing the existing report table.
4. Click Finish.
Delete a Report Configuration

1. In the Workspace Manager, open the Report Data Exports folder.
2. Select a report configuration.
3. Click Delete.

*Note:* Depending on your permissions, you may not have the ability to delete a report configuration.
Part 23

Publishing

Chapter 87
   Publish Period/Scenario Associations for a Model ............... 691

Chapter 88
   Publish Behaviors to SAS Profitability Management .............. 693
Chapter 87
Publish Period/Scenario Associations for a Model

Publish a Period/Scenario Association for a Model ........................................... 691
Overview .............................................................................................................. 691
How to Publish ................................................................................................. 691

Publish a Period/Scenario Association for a Model

Overview

Publishing a period/scenario association makes it available for viewing by anyone with View Model capability.

If a period/scenario association is published, then you cannot modify any periodic element belonging to that period/scenario association.

If a period/scenario association is published, then you can do the following:
• modify periodic elements belonging to other period/scenario associations in the model
• modify any structural element belonging to the model

See “Periodic and Structural Elements” on page 53.

How to Publish

To publish a period/scenario association:
1. Select Model ⇒ Period and Scenario Associations.
   The Period and scenario associations page appears.
2. Select a period/scenario association.
   Or right-click a period/scenario association, and select Publish/Unpublish.
See Also

“Period and Scenario Associations View” on page 137
Chapter 88
Publish Behaviors to SAS Profitability Management

Overview

For complete information on working with SAS Profitability Management, see Chapter 17, “Working with SAS Profitability Management,” in SAS Cost and Profitability Management: Data Administration Guide.

Mark Accounts as Behaviors

Mark accounts as behaviors before publishing them to SAS Profitability Management. You can mark an individual account or multiple accounts.

Mark an Individual Account

1. Select the account.
2. Right-click the account.
3. Select Mark as Behavior.
Mark Multiple Accounts

1. Open the Search for Accounts dialog box.
2. Search for the accounts that you want to mark as behaviors.
3. From the list of accounts that are found, select the ones to be marked.
4. Click Actions, and then select Mark as Behaviors.

Search for Accounts Marked as Behaviors

1. Open the Search for Accounts dialog box.
2. Select the IsBehavior property (under Properties ⇒ Other).
3. Select the = operator.
4. Select True.
5. Click Add.
6. Click Search.

Accounts that have been marked as behaviors are listed.
Publish Behaviors to SAS Profitability Management

Select File ⇒ Publish ⇒ Behaviors. The Publish Behaviors wizard opens.

Note: Before you can publish behaviors, you must specify the SAS Profitability Management Library so that SAS Cost and Profitability Management knows where to store the published behaviors. And, you must have marked some accounts as behaviors.

1. Select a model and specify the name of the behavior table to be created.
Model name
   Select the model whose accounts you want to mark as behaviors.

Period/Scenario associations
   Select the period/scenario associations for which you want to publish the data.

Behavior table name
   Specify a name for the behavior table.

Option
   Create table
      Creates a behavior table. If a table with the same name exists, then the
      operation quits with an error message, and the existing table is undisturbed.

   Replace table
      Replaces an existing table with the same name.

   Append to table
      Appends records to an existing table.

2. Map properties and attributes of the accounts being published to fields in the
resulting behavior table being created.

Id
   is the identifying reference for the behavior

Name
   is the name of the behavior

Period
   defines the period for the costs

Unit value
   is the unit cost for each transaction with this source. If you select a Unit value,
   then you may not select a Total value.

Total value
   is the total source amount that will be spread. If you select a Total value, then you
   may not select a Unit value.
3. You can optionally set a condition that an account must satisfy to be published as a behavior. This allows you to select a subset of all the accounts that have been marked as behaviors.

4. You can further limit the number of accounts to be published by selecting dimensions. If you do not select any dimensions, then accounts (which are marked as behaviors) from all dimensions are published.

5. Review your selections, and then click Finish.
The published accounts are written to a behavior table in the Profitability Management Library.

See Also

- “Mark Accounts as Behaviors” on page 693
- Chapter 17, “Working with SAS Profitability Management,” in SAS Cost and Profitability Management: Data Administration Guide
Part 24

Customizing the Interface

Chapter 89
User Options .................................................. 701
**Chapter 89**

**User Options**

---

**Customizing the Interface: User Options**

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
<td>701</td>
</tr>
<tr>
<td>Language Shown in the Interface</td>
<td>701</td>
</tr>
<tr>
<td>Default Display Precision for New Columns</td>
<td>702</td>
</tr>
<tr>
<td>Appearance of Grids</td>
<td>703</td>
</tr>
<tr>
<td>Display of Certain Dialog Boxes and Wizards</td>
<td>703</td>
</tr>
<tr>
<td>Cause Background Colors to Be Printed</td>
<td>703</td>
</tr>
<tr>
<td>Hide or Show the Status Bar</td>
<td>704</td>
</tr>
<tr>
<td>User Options Dialog Box</td>
<td>704</td>
</tr>
<tr>
<td>About the User Options Dialog Box</td>
<td>704</td>
</tr>
<tr>
<td>How to Access the User Options Dialog Box</td>
<td>704</td>
</tr>
<tr>
<td>Data Tab</td>
<td>704</td>
</tr>
<tr>
<td>Display Tab</td>
<td>704</td>
</tr>
<tr>
<td>Advanced Tab</td>
<td>705</td>
</tr>
<tr>
<td>Easy API Configuration Tab</td>
<td>705</td>
</tr>
</tbody>
</table>

---

**Customizing the Interface: User Options**

**Overview**

You can customize the SAS Cost and Profitability Management user interface to fit your needs. User interface settings change the interface for you only, not for all users. They do not change any data in a model. These settings are different from model properties.

**Language Shown in the Interface**

If multiple languages are installed on your computer, the language that is used is determined by your location setting in Windows (select **Settings** ⇒ **Control Panel** ⇒ **Regional and Language Options**).

*Note:* Error messages are generated by SAS Cost and Profitability Management and by the SAS Cost and Profitability Management server. Therefore, you might see error messages both in the language that you selected and in the language that is installed on the SAS Cost and Profitability Management server.
**Default Display Precision for New Columns**

**Overview**
You can specify the default number of decimal places that are displayed for costs, driver quantities, and rates. When you add a column on the Model view, the display precision that you set in your user options is used by default.

The display precision option does not affect current columns. It does not change the precision of the underlying data. And, it does not affect cubes.

These settings are saved on each computer. Therefore, any changes that you make to the default display precision affect only columns that you add on the computer on which you changed the default display precision. The changes affect all models.

You can format an individual column to change its display precision.

**Default Precision for Cost Values**
For the following properties, the default display precision for cost values determines the default display precision for new columns that have the Currency type:

- Allocated Cost
- Assigned Cost
- Assigned Idle Cost
- Assigned Non-reciprocal Cost
- Assigned Reciprocal Cost
- Cost
- Drivable Cost
- Driven Cost
- Driver Allocated Cost
- Driver Cost
- Driver Driven Cost
- Driver Idle Cost
- Driver Percentage
- Driver Used Cost
- Entered Cost
- Idle Cost
- Idle Percentage
- Profit
- Received Allocated Cost
- Received Assignment Cost
- Received Cost
- Received Driven Cost
- Received Idle Cost
- Received Non-reciprocal Cost
- Received Reciprocal Cost
- Received Used Cost
- Revenue
- Unassigned Cost
- Used Cost
- User Entered Cost Allocation

**Default Precision for Numeric Values**
For the following properties, the default display precision for numeric values determines the default display precision for new columns that have the Number type:
Assigned Idle Quantity
Driven Quantity
Driver Driven Quantity
Driver Quantity Basic
Driver Quantity Calculated
Driver Quantity Fixed
Driver Quantity Variable
Driver Sequence Number
Driver Weight Fixed
Driver Weight Variable
Idle Driver Quantity
Idle Driver Quantity UE
Idle Quantity
Output Quantity
Output Quantity UE
Sold Quantity
Total Driver Quantity
Total Driver Quantity Basic
Total Driver Quantity Calculated
Total Driver Quantity UE
Unassigned Quantity
Used Quantity

**Default Precision for Currency Rates**

The default display precision for currency rates determines the default display precision for columns in the Manage Exchange Rates dialog box.

- Driver Rate
- Unit Cost
- Unit Profit
- Unit Revenue

**Appearance of Grids**

You can select the font size of text that is contained in grids (tables). This setting is different from the Windows Control Panel setting that specifies the font size for all fonts that are displayed on your monitor.

You can select the colors for alternating rows in grids.

**Display of Certain Dialog Boxes and Wizards**

By default, when you create an entered cost element or create a dimension member, you specify information about the item in a dialog box. The dialog box enables you to specify all the information about the item when the item is created. However, you can bypass the dialog box to quickly create numerous items. In this case, system-generated default information is used, but you can change the default information later.

---

**Cause Background Colors to Be Printed**

1. Select *Help ➜ Contents, Index, and Search ➜* .

The SAS Cost and Profitability Management Help appears.
2. Select **Options** ⇒ **Internet Options**.  
The Internet Options dialog box appears.
3. Click the **Advanced** tab.
4. In the **Settings** list, under the **Printing options**, select the **Print background colors and images** option.

---

**Hide or Show the Status Bar**

Select **View** ⇒ **Status Bar**.

---

**User Options Dialog Box**

**About the User Options Dialog Box**

In the User Options dialog box, you can specify options that affect how you use SAS Cost and Profitability Management.

*Note*: You can perform the following tasks without first opening a model.

**How to Access the User Options Dialog Box**

Select **Tools** ⇒ **User Options**.

**Data Tab**

**Select the Default Display Precision for New Columns**

1. Click the **Data** tab.
2. In the Decimal Places Displayed section, select the number of decimal places for Cost values, Numeric values, and Currency rates.

**Display Tab**

**Select the Grid Colors and Font Size**

1. Click the **Display** tab.
2. In the Grid Colors section, select values for First row color, Second row color, and Text color from the menus.
3. In the Grid Font Size section, select an option.

**Select Where to Display the Currency Symbol**

1. Click the **Display** tab.
2. In the Currency section, select or clear the options.

**Advanced Tab**

*Specify Whether Certain Dialog Boxes and Wizards Will Be Displayed*
1. Click the Advanced tab.
2. In the Settings section, under Dialog Boxes and Wizards, select the dialog boxes and wizards.

**Easy API Configuration Tab**

*Specify an SMTP server for sending emails*
If you specify an SMTP server, then Easy API sends an email to report the results of each operation. You can specify one email ID for receiving reports of a successful operation and a different email ID for receiving reports of a failed operation.

- Click the Easy API Configuration tab.
- Specify an SMTP server.

*Specify an email ID to receive good news*
You can specify one email ID for receiving reports of a successful Easy API operation.

- Click the Easy API Configuration tab.
- Specify an Email Id for successful operation.

*Specify an email ID to receive bad news*
You can specify a different email ID for receiving reports of a failed operation.

- Click the Easy API Configuration tab.
- Specify an Email Id for failure of operation.

*Turn on or off the saving of XML*
When SAS Cost and Profitability Management performs an operation, it uses XML to pass the parameters for the operation. You can ask SAS Cost and Profitability Management to save this XML when it performs an operation so that you can use the same XML to perform the same operation using Easy API.

To begin saving XML:

- Click the Easy API Configuration tab.
- Select Save operation xml in directory path.
- Specify the directory path where the XML is to be saved.

To stop saving XML:

- Click the Easy API Configuration tab.
- Unselect Save operation xml in directory path.
Part 25

Properties Reference

Chapter 90
Alphabetic List of Properties ........................................ 709

Chapter 91
Property Relationship Diagrams ................................. 767
### Alphabetic List of Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allocated Cost (AllocCost)</td>
<td>711</td>
</tr>
<tr>
<td>Assigned Cost (AsgnCost)</td>
<td>713</td>
</tr>
<tr>
<td>Assigned Idle Cost (AsgnIdlCost)</td>
<td>713</td>
</tr>
<tr>
<td>Assigned Idle Quantity (AsgnIdlQty)</td>
<td>714</td>
</tr>
<tr>
<td>Assigned Non Reciprocal Cost (AsgnNRecipCost)</td>
<td>714</td>
</tr>
<tr>
<td>Assigned Reciprocal Cost (AsgnRecipCost)</td>
<td>715</td>
</tr>
<tr>
<td>Calculate Error (CalcError)</td>
<td>715</td>
</tr>
<tr>
<td>Cost (Cost)</td>
<td>716</td>
</tr>
<tr>
<td>Dimension Level Name (DimLevelName)</td>
<td>716</td>
</tr>
<tr>
<td>Dimension Level Number (DimLevelNum)</td>
<td>717</td>
</tr>
<tr>
<td>Dimension Member Name (DimMemName)</td>
<td>717</td>
</tr>
<tr>
<td>Dimension Member Reference (DimMemRef)</td>
<td>718</td>
</tr>
<tr>
<td>Dimension Name (DimName)</td>
<td>718</td>
</tr>
<tr>
<td>Dimension Reference (DimRef)</td>
<td>719</td>
</tr>
<tr>
<td>Display Name (Display Name)</td>
<td>719</td>
</tr>
<tr>
<td>Display Reference (Display Reference)</td>
<td>720</td>
</tr>
<tr>
<td>Drivable Cost (DrvblCost)</td>
<td>720</td>
</tr>
<tr>
<td>Driven Cost (DrvnCost)</td>
<td>721</td>
</tr>
<tr>
<td>Driven Quantity (DrvnQty)</td>
<td>722</td>
</tr>
<tr>
<td>Driver Allocated Cost (DrvAllocCost)</td>
<td>722</td>
</tr>
<tr>
<td>Driver Cost (DrvCost)</td>
<td>723</td>
</tr>
<tr>
<td>Driver Driven Cost (DrvDrvnCost)</td>
<td>724</td>
</tr>
<tr>
<td>Driver Driven Quantity (DrvDrvnQty)</td>
<td>725</td>
</tr>
<tr>
<td>Driver Formula (DrvFormula)</td>
<td>725</td>
</tr>
<tr>
<td>Driver Idle Cost (DrvIdlCost)</td>
<td>726</td>
</tr>
<tr>
<td>Driver Name (DrvName)</td>
<td>726</td>
</tr>
<tr>
<td>Driver Percentage (DrvPcnt)</td>
<td>727</td>
</tr>
</tbody>
</table>
Chapter 90 • Alphabetic List of Properties

- Driver Quantity Basic (DrvQtyBasic) ........................................... 727
- Driver Quantity Calculated (DrvQtyCalc) .................................. 728
- Driver Quantity Fixed (DQF) ..................................................... 728
- Driver Quantity Variable (DQV) .............................................. 729
- Driver Rate (DrvRate) ............................................................... 730
- Driver Sequence Number (DrvSeq) .......................................... 730
- Driver Type (DrvType) .............................................................. 731
- Driver Used Cost (DrvUsedCost) ............................................. 731
- Driver Weight Fixed (DWF) ...................................................... 732
- Driver Weight Variable (DWV) ............................................... 732
- Entered Cost (EntCost) ............................................................ 733
- Entered Unit Cost (EntUnitCost) ............................................. 734
- Fixed Driver Quantity Override .............................................. 734
- Formula .............................................................................. 735
- Has Assignments (HasAsgn) ................................................. 735
- Has Attributes (HasAttr) ......................................................... 736
- Has Entered Cost (HasEntCost) ............................................. 736
- Has Idle Cost (HasIdlCost) ..................................................... 736
- Has Notes (HasNotes) ............................................................. 737
- Has Used Cost (HasUsedCost) .............................................. 737
- Idle Cost (IdlCost) ................................................................. 738
- Idle Driver Quantity (IdlDrvQty) ............................................ 739
- Idle Driver Quantity UE (IdlQtyUE) ...................................... 739
- Idle Flow Method (IdleFlow) .................................................. 740
- Idle Percentage (IdlPcnt) ......................................................... 741
- Idle Quantity (IdlQty) .............................................................. 742
- Intersection Name (IntsctnName) ......................................... 742
- Intersection Reference (IntsctnRef) ........................................ 743
- IsBehavior (IsBehavior) .......................................................... 743
- IsReciprocal (IsRecip) ............................................................. 744
- Model Note (ModNote) ........................................................... 744
- Module Order (ModOrdr) ......................................................... 745
- Name (Name) .................................................................... 745
- Output Quantity (OutQty) ....................................................... 746
- Output Quantity UE (OutQtyUE) .......................................... 746
- Periodic Note (PerNote) .......................................................... 747
- Profit (Profit) .................................................................... 747
Allocated Cost (AllocCost)

Allocated Cost is the sum of DrvAllocCost on assignments going out of the account. DrvAllocCost is user-entered.
The cost that is flowing out of an account to other accounts based on the user allocation method; a direct placement of money to a specified destination account, and the remainder of the cost could be assigned using driver quantities.

The value of this property is generated by the system. You cannot change this value. It represents the sum of all user-entered allocated costs. You enter a user-entered allocated cost by setting the value of Driver Allocated Cost (DrvAllocCost). You enable a user allocation method by checking the Allow user-entered cost allocation check box on the Advanced tab of the New Driver window. Unless you check this, Driver Allocated Cost (DrvAllocCost) is protected for the driver.

\[
\text{Drivable Cost} = \text{Cost} - \text{Allocated Cost}
\]

\[
\text{Driver Rate} = \frac{\text{Drivable Cost}}{\text{TDQ}}
\]

<table>
<thead>
<tr>
<th><strong>System generated or user entered?</strong></th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Default format in a column layout:</strong></td>
<td>Currency</td>
</tr>
<tr>
<td><strong>Data type:</strong></td>
<td>8–byte floating point number</td>
</tr>
<tr>
<td><strong>Type of property in an assignments pane:</strong></td>
<td>Outgoing</td>
</tr>
<tr>
<td></td>
<td>See “Outgoing Properties” on page 300.</td>
</tr>
<tr>
<td><strong>Formula</strong></td>
<td>( \text{AllocCost} = \sum \text{DrvAllocCost} )</td>
</tr>
</tbody>
</table>

**See Also**

“Create a Driver” on page 397
Assigned Cost (AsgnCost)

The cost that is flowing out of a cost element or account to other cost elements or accounts; the cost flowing out of an account to other accounts based on the driver method.

Assigned cost is calculated according to the following formula:

\[
\text{Assigned Cost} = \text{Driven Cost} + \text{Allocated Cost}
\]

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
<tr>
<td>Formula</td>
<td>(\text{Assigned Cost} = \text{Allocated Cost} + \text{Driven Cost})</td>
</tr>
</tbody>
</table>

See Also

- Assigned Reciprocal Cost on page 715
- Received Cost on page 748

Assigned Idle Cost (AsgnIdlCost)

The sum of costs on outgoing assignments that is specifically because of the source account's idle flow behavior.

Assigned Idle Cost is calculated according to the following formula:

\[
\text{Asgn IdlCost} = (\text{sum of DrvIdleCost of destination side accounts})
\]

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
<tr>
<td>Formula</td>
<td>See “Outgoing Properties” on page 300.</td>
</tr>
</tbody>
</table>
Formula

\[ \text{AsgnIdlCost} = \text{AsgnIdlQty} \times \text{DrvRate} \]

Also:

\[ \text{AsgnIdlCost} = \text{sum of DrvIdlCost on outgoing assignments} \]

See Also

- “Idle Quantities” on page 384
- “Example of Idle Flow” on page 386

**Assigned Idle Quantity (AsgnIdlQty)**

The amount of an account's idle quantity that causes cost on outgoing assignments because of the account's idle flow behavior.

AsgnIdlQty for a driver is the sum of IdlDrvQty for the individual assignments.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
<tr>
<td></td>
<td>See “Outgoing Properties” on page 300.</td>
</tr>
<tr>
<td>Formula</td>
<td>[ \text{AsgnIdlQty} = \sum \text{IdlDrvQty} ]</td>
</tr>
</tbody>
</table>

See Also

- “Idle Quantities” on page 384
- “Example of Idle Flow” on page 386

**Assigned Non Reciprocal Cost (AsgnNRecipCost)**

The sum of costs on an account's outgoing assignments where the destination accounts are not part of the same reciprocal system as the source account.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
</tbody>
</table>


Data type: 8-byte floating-point number

Type of property in an assignments pane: Outgoing
See “Outgoing Properties” on page 300.

Formula N/A

Assigned Reciprocal Cost (AsgnRecipCost)

The assigned cost that is flowing from a reciprocal account to other reciprocal accounts. For a non-reciprocal account, this value is NULL.

System generated or user entered? Calculated by system

Default format in a column layout: Currency

Data type: 8-byte floating-point number

Type of property in an assignments pane: Outgoing
See “Outgoing Properties” on page 300.

Formula N/A

See Also

• “Reciprocal Costing” on page 388
• Cost on page 716
• Received Reciprocal Cost on page 750

Calculate Error (CalcError)

The error status for a calculated driver or calculated attribute value.

This property rolls up in the module view and displays the highest priority error at the module level. This error information can be useful when debugging calculation errors.

System generated or user entered? Generated by system

Default format in a column layout: Text

Data type: 8-byte floating-point number
Type of property in an assignments pane: Outgoing
See “Outgoing Properties” on page 300.

Formula
N/A

Cost (Cost)

The calculated cost of a cost element or account.
Cost is calculated according to the formula:

\[ \text{Cost} = \text{EnteredCost} + \text{Received Cost} \]

System generated or user entered? System-generated

Default format in a column layout: Currency

Data type: 8-byte floating-point number

Type of property in an assignments pane: Account
See “Account Properties” on page 303.

Formula
\[ \text{Cost} = \text{EnteredCost} + \text{ReceivedCost} \]

See Also

- Chapter 59, “Calculating Costs,” on page 499
- Assigned Reciprocal Cost on page 715
- Received Cost on page 748

Dimension Level Name (DimLevelName)

The name of the level for the dimension that completes an intersection.

System generated or user entered? User modifiable But this property is read-only in a grid. You cannot change this value in a grid.

Default format in a column layout: Text

Data type: The maximum length is 64 alphanumeric Unicode characters

Type of property in an assignments pane: N/A
When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

See Also

- Chapter 24, “What Are Dimensions?,” on page 169
- Dimension Level Number (DimLevelNumber) on page 717

**Dimension Level Number (DimLevelNum)**

The depth in the dimension hierarchy of the dimension that completes an intersection.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Generated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>4-byte integer value</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
<tr>
<td>Formula</td>
<td>N/A</td>
</tr>
</tbody>
</table>

See Also

- Chapter 24, “What Are Dimensions?,” on page 169
- “Dimension Level Number (DimLevelNum)” on page 717
- Dimension Level Name (DimLevelName) on page 716

**Dimension Member Name (DimMemName)**

The name of the dimension member that defines an account (dimensional intersection).

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User entered, but not in a column layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 256 alphanumeric Unicode characters</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
</tbody>
</table>
When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

**See Also**

- Chapter 24, “What Are Dimensions?,” on page 169
- Dimension Member Reference (DimeMemberReference) on page 718

---

### Dimension Member Reference (DimMemRef)

The reference of the dimension member that defines an account (dimensional intersection).

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User entered, but not in a column layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters.</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
<tr>
<td>Formula</td>
<td>N/A</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

**See Also**

- Chapter 24, “What Are Dimensions?,” on page 169
- Dimension Member Name (DimMemberName) on page 717

---

### Dimension Name (DimName)

The name of the dimension that completes an intersection.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User entered, but not in a column layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters.</td>
</tr>
</tbody>
</table>
When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

**See Also**

- Chapter 24, “What Are Dimensions?,” on page 169
- Dimension Reference (DimReference) on page 719

---

**Dimension Reference (DimRef)**

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User entered, but not in a column layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
<tr>
<td>Formula</td>
<td>N/A</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

**See Also**

- Chapter 24, “What Are Dimensions?,” on page 169
- Dimension Name (DimName) on page 718

---

**Display Name (Display Name)**

The name for the displayed item.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Generated by system. However, you can change Name.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
</tbody>
</table>
When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

See Also

Display Reference on page 720

Display Reference (Display Reference)

The reference for the displayed item.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Generated by system. However, you can change Reference.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout</td>
<td>Text</td>
</tr>
<tr>
<td>Data type</td>
<td>The maximum length is 64 alphanumeric Unicode characters.</td>
</tr>
<tr>
<td>Type of property in an assignments pane</td>
<td>N/A</td>
</tr>
<tr>
<td>Formula</td>
<td>N/A</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

See Also

Display Name on page 719

Drivable Cost (DrvblCost)

The remainder of an account's cost that can be assigned by its driver after subtracting user-allocated costs.

You cannot change this value. It is generated by the system according to the following formula:

\[
\text{DrvblCost} = \text{Cost} - \text{AllocatedCost}
\]

Also:

\[
\text{DrvblCost} = \text{UsedCost} + \text{IdleCost}
\]

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout</td>
<td>Currency</td>
</tr>
</tbody>
</table>
Driven Cost (DrvnCost)

The amount of cost that is driven by the account's driver, including both Used Cost and Assigned Idle Cost.

Driven Cost is calculated according to the following formula:

\[
\text{Driven Cost} = \text{Used Cost} + \text{Assigned Idle Cost}
\]

See Also

• “Used Cost (UsedCost)” on page 762
• “Assigned Idle Cost (AsgnIdlCost)” on page 713
Driven Quantity (DrvnQty)

The sum of the driver quantity on an account's outgoing assignments, including both Used Quantity and Assigned Idle Quantity.

The value of this property is generated by the system. You cannot change this value. It is defined by the following formula:

\[
\text{DrivenQuantity} = \text{AssignedIdleQty} + \text{UsedQuantity}
\]

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
<tr>
<td>Formula</td>
<td>Driven Quantity = UsedQty + AsgnIdlQty</td>
</tr>
</tbody>
</table>


See Also

- “Assigned Idle Quantity (AsgnIdlQty)” on page 714
- “Driver Quantity Calculated (DrvQtyCalc)” on page 728

Driver Allocated Cost (DrvAllocCost)

The user-entered Allocated Cost value on an assignment path.

You enable the setting of Driver Allocated Cost by checking the Allow user-entered cost allocation check box on the Advanced tab of the New Driver window. Unless you check this, Driver Allocated Cost is protected for the driver.
System generated or user entered?  User-entered

Default format in a column layout:  Currency

Data type:  8-byte floating-point number

Type of property in an assignments pane:  Assignment

See “Assignment Properties” on page 299.

Formula  User-entered value

When you add this property to a column in a grid, the default format is Currency. This is an.

See Also

“Create a Driver” on page 397

Driver Cost (DrvCost)

The cost that is flowing out of or flowing into an account through an assignment.

Driver Cost is calculated according to the following formula:

\[
\text{Driver Cost} = (\text{Driver Driven Cost} + \text{Driver Allocated Cost})
\]

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
</tbody>
</table>
Type of property in an assignments pane: Assignment
See “Assignment Properties” on page 299.

Formula
Driver Cost = DrvAllocCost + DrvDrvnCost
That is, the outgoing cost for an assignment is the sum of the cost that is allocated plus the sum that is driven by the driver.

See Also
- “Example 6: Weighted Driver with Fixed and Variable Driver Quantities” on page 365
- “Step 12–DrvCost for Assignments to Activity Accounts” on page 527
- “Step 16–DrvCost for Assignments to Cost Object Accounts” on page 531
- Cost on page 716

Driver Driven Cost (DrvDrvnCost)

the cost going to each destination account. It is calculated by multiplying DrvQtyCalc (the number of units) times DrvRate (the cost per unit)

System generated or user entered?: Calculated by system

Default format in a column layout: Currency

Data type: 8-byte floating-point number

Type of property in an assignments pane: Assignment
See “Assignment Properties” on page 299.

Formula
Driver Driven Cost = DrvQtyCalc x Driver Rate
So:
Driver Driven Cost = DrvQtyCalc x (DrvblCost/TDQ)
Also:
DrvDrvnCost = DrvIdlCost + DrvUsedCost

See Also
- Cost on page 716
- “Step 11–DrvDrvnCost for Assignments to Activity Accounts” on page 526
- “Step 15–DrvDrvnCost for Assignments to Cost Object Accounts” on page 530
**Driver Driven Quantity (DrvDrvnQty)**

The assigned quantity that is flowing on an assignment path, including both Used Quantity and Assigned Idle Quantity.

Driver Driven Quantity is calculated according to the following formula:

\[ \text{DrvDrvnQty} = \text{DrvQtyCalc} + \text{IdleDrvQty} \]

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
</tbody>
</table>
| Type of property in an assignments pane: | Assignment  
See “Assignment Properties” on page 299. |
| Formula | \( \text{DrvDrvnQty} = \text{DrvQtyCalc} + \text{IdleDrvQty} \)  

When you add this property to a column in a grid, the default format is Number. The value of this property is generated by the system. You cannot change this value. This is an .

**Driver Formula (DrvFormula)**

The formula that is attached to a source account's driver.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User modifiable. But This property is read-only in a grid. You cannot change this value in a grid—only in the Driver properties dialog.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>Large text value</td>
</tr>
</tbody>
</table>
| Type of property in an assignments pane: | Driver  
See “Driver Properties” on page 303. |
| Formula | N/A |

When you import or export model data, this value must translate into the TEXT or NTEXT data types in Microsoft SQL Server.
Driver Idle Cost (DrvIdlCost)

A source account's Idle Cost. The assigned idle cost that is flowing on an assignment path.

Driver Idle Cost is calculated according to the following formula:

\[
\text{Driver Idle Cost} = \text{Idle DriverQty} \times \text{Driver Rate}
\]

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
<tr>
<td></td>
<td>See &quot;Assignment Properties&quot; on page 299.</td>
</tr>
</tbody>
</table>

Formula

\[
\text{DrvIdlCost} = \text{IdlDrvQty} \times \text{DrvRate}
\]

See Also

- Driver Cost on page 723
- “Idle Quantities” on page 384
- “Example of Idle Flow” on page 386

Driver Name (DrvName)

**Driver Name** (DrvName) The name of the driver that is associated with an account.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User-entered.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters.</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Driver</td>
</tr>
<tr>
<td></td>
<td>See “Driver Properties” on page 303.</td>
</tr>
</tbody>
</table>
When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

**Driver Percentage (DrvPcnt)**

The percentage of the total driver quantity for an assignment.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
<tr>
<td></td>
<td>See “Assignment Properties” on page 299.</td>
</tr>
<tr>
<td>Formula</td>
<td>DrvPcnt = (DrvQtyCalc/TDQ) x 100</td>
</tr>
</tbody>
</table>

**Driver Quantity Basic (DrvQtyBasic)**

The sum of the fixed and variable quantities that flows from one account to another.

Driver Quantity Basic is calculated according to the following formula:

\[ DrvQtyBasic = DQF + DQV \times \text{Dest.TDQ} \]

The formula for DrvQtyBasic is a limiting case of the general formula for DrvQtyCalc:

\[ DrvQtyCalc = (DQF \times DWF) + (DQV \times DWV \times \text{Dest.TDQ}) \]

where DWF and DWV both equal 1.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
<tr>
<td></td>
<td>See “Assignment Properties” on page 299.</td>
</tr>
<tr>
<td>Formula</td>
<td>DrvQtyBasic = DQF + DQV \times \text{Dest.TDQ}</td>
</tr>
</tbody>
</table>
Driver Quantity Calculated (DrvQtyCalc)

Represents the number of units going to each destination account.

The value of this property is generated by the system. You cannot change this value. It is calculated according to the following formula:

\[ \text{DrvQtyCalc} = (DQF \times DWF) + (DQV \times DWV \times \text{Dest.TDQ}) \]

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
<tr>
<td></td>
<td>See “Assignment Properties” on page 299.</td>
</tr>
<tr>
<td>Formula</td>
<td>[ \text{DrvQtyCalc} = (DQF \times DWF) + (DQV \times DWV \times \text{Dest.TDQ}) ]</td>
</tr>
</tbody>
</table>

See Also

- “DrvQtyCalc” on page 330
- “What Is a Driver?” on page 329
- Chapter 61, “Detailed Example of Calculation,” on page 513
- Driver Quantity Basic on page 727
- Driver Quantity Fixed on page 728
- Driver Quantity Variable on page 729

Driver Quantity Fixed (DQF)

The user-entered fixed quantity that flows from one account to another.

| System generated or user entered? | You can change this value only on assigned cost elements with a driver that allows fixed driver quantities. |
Driver Quantity Variable (DQV)

The user-entered variable quantity that flows from one account to another.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>You can change this value only on assigned cost elements with a driver that allows variable driver quantities.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
<tr>
<td></td>
<td>See “Assignment Properties” on page 299.</td>
</tr>
<tr>
<td>Formula</td>
<td>User-entered value</td>
</tr>
</tbody>
</table>

See Also

- “Fixed Driver Quantities” on page 374
- “Variable Driver Quantities” on page 375
- Driver Quantity Basic on page 727
- Driver Quantity Calculated on page 728
- Driver Quantity Variable on page 729
Driver Rate (DrvRate)

 Represents the cost per unit for every destination account. It is calculated according to the following formula:

\[
\text{DriverRate} = \begin{cases} 
\text{ExternalUnit} & \text{UnitCostEntered} \\
\text{ELSE} & \frac{\text{DrivableCost}}{\text{TDQ}}
\end{cases}
\]

And:

\[
\text{DrivableCost} = \text{Cost} - \text{AllocatedCost}
\]

**Note:** Driver Rate can be different from Unit Cost if any of the following is true:

- \(\text{TDQUE ne 0}\) (which overrides TDQ in the formula \(\text{DrvRate} = \frac{\text{DrivableCost}}{\text{TDQ}}\))
- \(\text{AllocCost ne 0}\) (which affects DrivableCost in the formula \(\text{DrvRate} = \frac{\text{DrivableCost}}{\text{TDQ}}\))
- \(\text{OutQtyUE ne 0}\) (which overrides OutQty in the formula UnitCost = \(\frac{\text{Cost}}{\text{OutQty}}\))

**System generated or user entered?** Calculated by system

**Default format in a column layout:** Currency

**Data type:** 8-byte floating-point number

**Type of property in an assignments pane:** Outgoing

See “Outgoing Properties” on page 300.

**Formula**

\[
\text{Driver Rate} = \frac{\text{DrivableCost}}{\text{TDQ}}
\]


**See Also**

- “DrvRate” on page 330
- “Step 10–DrvRate for Resource Account” on page 525
- “Step 14–DrvRate for Outgoing Drivers from Activity Accounts” on page 529

Driver Sequence Number (DrvSeq)

The sequence number that is associated with a source account's driver.

**System generated or user entered?** User entered, but not in a column layout

**Default format in a column layout:** Number
Data type: 4-byte integer value

Type of property in an assignments pane: Driver
See “Driver Properties” on page 303.

Formula N/A

See Also
“Driver Sequencing” on page 381

Driver Type (DrvType)
The type of driver: Evenly Assigned, Percentage, or Standard. The default driver is Standard.

System generated or user entered? User modifiable. But this property is read-only in a column-layout.

Default format in a column layout: Text

Data type: The maximum length is 64 alphanumeric Unicode characters.

Type of property in an assignments pane: Driver
See “Driver Properties” on page 303.

Formula N/A

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

See Also
Chapter 40, “Introducing Drivers,” on page 329

Driver Used Cost (DrvUsedCost)
The sum of costs on an account's outgoing assignments that is caused by the account's driver. This amount does not include Allocated Cost or Idle Cost.

Driver Used Cost is calculated according to the following formula:

\[
\text{Driver Used Cost} = \text{DriverQtyCalc} \times \text{Driver Rate}
\]

or, the following formula if there is no SoldQuantity

\[
\text{DriverUsedCost} = \text{DrivableCost} \times \frac{DQCalc}{TDQCalc}
\]
System generated or user entered? | Calculated by system
---|---
Default format in a column layout: | Currency
Data type: | 8-byte floating-point number
Type of property in an assignments pane: | Assignment
| See “Assignment Properties” on page 299.
Formula | DrvUsedCost = DrvDrvnCost – DrvIdlCost
| Also:
| DrvUsedCost = DrvQtyCalc x DrvRate

**Driver Weight Fixed (DWF)**

The numeric factor that modifies a fixed driver quantity. The default weight is 1.

System generated or user entered? | You can change this value only on assigned cost elements with a driver that allows fixed driver weights.
---|---
Default format in a column layout: | Number
Data type: | 8-byte floating-point number
Type of property in an assignments pane: | Assignment
| See “Assignment Properties” on page 299.
Formula | N/A

**See Also**
- “Fixed Driver Quantities” on page 374
- “Variable Driver Quantities” on page 375
- Driver Weight Variable on page 732

**Driver Weight Variable (DWV)**

The numeric factor that modifies a variable driver quantity. The default weight is 1.
### Entered Cost (EntCost)

The user-entered cost for a cost element or the calculated total of all account entered cost elements for an.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User entered</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Account</td>
</tr>
<tr>
<td>See “Account Properties” on page 303.</td>
<td></td>
</tr>
<tr>
<td>Formula</td>
<td>User-entered value</td>
</tr>
</tbody>
</table>

**See Also**

- “Entered Cost Elements” on page 234
- “Entered Unit Cost (EntUnitCost)” on page 734
- Cost on page 716
**Entered Unit Cost (EntUnitCost)**

The unit cost, as entered by a user, for a cost element. Or, the sum of the entered unit cost of all the cost elements belonging to an account.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User entered</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Account</td>
</tr>
<tr>
<td></td>
<td>See “Account Properties” on page 303.</td>
</tr>
</tbody>
</table>

**Formula**

User-entered value

**See Also**

- “Entered Cost Elements” on page 234
- “Entered Cost (EntCost)” on page 733
- Cost on page 716

**Fixed Driver Quantity Override**

For a sequenced driver, the name of the property that replaces the Driver Quantity Fixed value after the previous sequence pass.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User entered, but not in a column layout.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters.</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
<tr>
<td>Formula</td>
<td>N/A</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

**See Also**

- “Driver Sequencing” on page 381
Variable Driver Quantity Override on page 764

Formula

The formula for a calculated driver or calculated attribute.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User entered, but not in column layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>This is a large text-based value.</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
<tr>
<td>Formula</td>
<td>N/A</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into the TEXT or NTEXT data types in Microsoft SQL Server.

See Also

- Chapter 51, “Formulas,” on page 431
- Chapter 44, “Calculated Driver,” on page 367
- “Calculated Attributes” on page 248
- Driver Formula on page 725

Has Assignments (HasAsgn)

Indicates whether an account receives costs from another account.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>System generated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Checkbox</td>
</tr>
<tr>
<td>Data type:</td>
<td>Boolean</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Incoming</td>
</tr>
<tr>
<td></td>
<td>See “Incoming Properties” on page 302.</td>
</tr>
<tr>
<td>Formula</td>
<td>N/A</td>
</tr>
</tbody>
</table>
### Has Attributes (HasAttr)

Indicates whether an item has at least one attribute.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>System generated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Checkbox</td>
</tr>
<tr>
<td>Data type:</td>
<td>Boolean</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Account</td>
</tr>
<tr>
<td></td>
<td>See “Account Properties” on page 303.</td>
</tr>
<tr>
<td>Formula</td>
<td>N/A</td>
</tr>
</tbody>
</table>

### Has Entered Cost (HasEntCost)

Indicates whether an account has at least one user-entered cost element.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>System generated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Checkbox</td>
</tr>
<tr>
<td>Data type:</td>
<td>Boolean</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Account</td>
</tr>
<tr>
<td></td>
<td>See “Account Properties” on page 303.</td>
</tr>
<tr>
<td>Formula</td>
<td>N/A</td>
</tr>
</tbody>
</table>

### See Also

Chapter 30, “What Are Cost Elements?,” on page 233

### Has Idle Cost (HasIdlCost)

Indicates whether an item has a non-zero idle cost—that is, costs that don’t flow to other accounts.

| System generated or user entered? | System generated |
Has Used Cost (HasUsedCost)

Indicates whether an item has a non-zero used cost—that is, it flows costs to other accounts.

System generated or user entered?  Calculated by system

Default format in a column layout:  Checkbox
**Idle Cost (IdlCost)**

The idle cost is the remaining cost after all direct assignments have been made; the calculated cost that does not flow out of an account. It is the account unit cost x idle quantity (where idle quantity = user-entered total driver quantity – output quantity). Or, more succinctly:

\[
\text{Idle Cost} = \text{IdlQty} \times \text{Driver Rate}
\]

Also:

\[
\text{Idle Cost} = \text{AssignedIdleCost} + \text{UnassignedCost}
\]

Also:

\[
\text{IdleCost} = \text{IdleQty} \times \text{Driver Rate}
\]

This remaining cost can be assigned using a specific idle cost flow method (driver, percentage, user-entered, or evenly).

---

**See Also**

- “Idle Quantities” on page 384
- “Example of Idle Flow” on page 386
- Cost on page 716
- Idle Quantity on page 742
- Idle Percentage on page 741
Idle Driver Quantity (IdlDrvQty)

The quantity that causes cost on an assignment path that is specifically because of the source account's idle flow behavior.

IdlDrvQty for an assignment is determined by its idle flow method (user-entered, user proportion, driver quantity, evenly assigned). For information, see “Idle Quantities” on page 384.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
<tr>
<td></td>
<td>See “Assignment Properties” on page 299.</td>
</tr>
<tr>
<td>Formula</td>
<td>N/A</td>
</tr>
</tbody>
</table>

See Also

- “Idle Quantities” on page 384
- “Example of Idle Flow” on page 386
- Idle Driver Quantity UE on page 739
- Idle Flow Method on page 740

Idle Driver Quantity UE (IdlQtyUE)

The optional, user-entered idle driver quantity value for assigned cost elements and internal cost elements.

This value is used to drive idle costs that are based on source account's idle flow behavior.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User entered</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
<tr>
<td></td>
<td>See “Assignment Properties” on page 299.</td>
</tr>
</tbody>
</table>
Idle Flow Method (IdleFlow)

The method by which idle cost through a driver is calculated for a source account's outgoing assignments.

Interactively within the interface, the values can be: User Entered, User Proportion, User Driver Quantities, and Evenly Assigned. The default is User Entered. The Idle Flow Method is specified in a drop-down box on the Advanced tab of the Driver Properties window.

When you import model data, the values can be: Dont Assign, Evenly Assigned, User Driver Quantities, User Entered, User Proportion. The default is Dont Assign.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User-entered value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters.</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Driver</td>
</tr>
</tbody>
</table>

See Also

- “Idle Quantities” on page 384
- “Example of Idle Flow” on page 386
- Idle Driver Quantity on page 739
- Idle Flow Method on page 740
When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

**See Also**

- “Idle Quantities” on page 384
- “Example of Idle Flow” on page 386

---

**Idle Percentage (IdlPcnt)**

The calculated percentage of an account's cost that does not flow out of the account. The idle percentage is the remaining cost after all direct assignments have been made. It is 100 - (user-entered total driver quantity - calculated total driver quantity)/user-entered total driver quantity.

Idle Percentage is calculated according to the following formula:

\[
\text{IdlePercentage} = \frac{\text{IdleQty}}{\text{TDQ}}
\]

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Percentage</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
<tr>
<td></td>
<td>See “Assignment Properties” on page 299.</td>
</tr>
</tbody>
</table>
| Formula | \[
\text{IdlPcnt} = 100 \times \frac{\text{IdleQty}}{\text{TDQ}}
\]

**See Also**

- “Idle Quantities” on page 384
- “Example of Idle Flow” on page 386
- Idle Cost on page 738
- Idle Quantity on page 742
Idle Quantity (IdlQty)

The calculated amount of an account's quantity that does not flow out of the account. The idle quantity is the remaining cost after all direct assignments have been made. It is (user-entered total driver quantity – output quantity).

\[ \text{IdlQty} = \text{TDQUE} - \text{OutQty} \]

If TDQUE > OutputQty then Positive Idle

If TDQUE < OutputQty/OutputQtyUE then Negative Idle

Because TDQ equals UsedQty unless overridden by TDQUE, the only way that IdlQty can be non-zero is if TDQUE is greater than UsedQty.

Note: If TDQUE is less than UsedQty, then the following error message appears: “Overdriven source account. The value entered for TDQUE is less than the Driven Quantity."

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
<tr>
<td></td>
<td>See “Outgoing Properties” on page 300.</td>
</tr>
<tr>
<td>Formula</td>
<td>[ \text{IdlQty} = \text{TDQ} - \text{UsedQty} ]</td>
</tr>
</tbody>
</table>

See Also

- “Idle Quantities” on page 384
- “Example of Idle Flow” on page 386
- Idle Cost on page 738
- Idle Percentage on page 741

Intersection Name (IntsctnName)

The concatenation of all the names of the dimensions that intersect to create an item. Each name is separated by a special character.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>System generated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
</tbody>
</table>
**Data type:**
The maximum length is 64 alphanumeric Unicode characters.

**Type of property in an assignments pane:** N/A

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

**See Also**
Intersection Reference on page 743

---

**Intersection Reference (IntsctnRef)**

The concatenation of all the references of the dimension members that intersect to create an item. Each reference is separated by a special character.

**System generated or user entered?** System generated

**Default format in a column layout:** Text

**Data type:** The maximum length is 64 alphanumeric Unicode characters.

**Type of property in an assignments pane:** Account

See “Account Properties” on page 303.

**Formula** N/A

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

**See Also**
Intersection Name on page 742

---

**IsBehavior (IsBehavior)**

Indicates whether an account has been marked as a behavior for use in SAS Profitability Management.

**System generated or user entered?** User-entered. See “Mark Accounts as Behaviors” on page 693.

**Default format in a column layout:** Checkbox

**Data type:** Boolean
IsReciprocal (IsRecip)

Indicates whether an assignment or account is part of a reciprocal system. You can use this property in account search.

The property applies both to accounts and to assignments. For assignments, the property tests true when the source and destination accounts are in the same reciprocal system.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>System-generated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Checkbox</td>
</tr>
<tr>
<td>Data type:</td>
<td>Boolean</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Account</td>
</tr>
<tr>
<td></td>
<td>See “Account Properties” on page 303.</td>
</tr>
<tr>
<td></td>
<td>Assignment</td>
</tr>
<tr>
<td></td>
<td>See “Assignment Properties” on page 299.</td>
</tr>
<tr>
<td>Formula</td>
<td>N/A</td>
</tr>
</tbody>
</table>

See Also

- “Reciprocal Id (RecipId)” on page 751
- “Reciprocal Costing” on page 388

Model Note (ModNote)

Text describing an account. The text applies to every period/scenario in which the account occurs—unlike a Periodic Note which applies only to an account in one period/scenario.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User-entered</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>32K alphanumeric Unicode characters.</td>
</tr>
</tbody>
</table>
### Type of property in an assignments pane

<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account</td>
<td>See “Account Properties” on page 303.</td>
</tr>
</tbody>
</table>

### Formula

N/A

### See Also

“Periodic Note (PerNote)” on page 747

---

### Module Order (ModOrdr)

The relative position of the module in the ordered set of modules that determines the direction of cost flow. Valid values are in the range -1000 to +1000, exclusive. The order of modules is defined during model creation and cannot be changed afterwards.

<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>System generated or user entered?</td>
<td>User-defined during model creation</td>
</tr>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane: Account</td>
<td>See “Account Properties” on page 303.</td>
</tr>
</tbody>
</table>

### Formula

N/A

### See Also

“Create a Model” on page 78

---

### Name (Name)

The user-entered or default name of an item.

<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>System generated or user entered?</td>
<td>User-entered</td>
</tr>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters.</td>
</tr>
<tr>
<td>Type of property in an assignments pane: N/A</td>
<td></td>
</tr>
</tbody>
</table>

### Formula

N/A
When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

See Also
Reference on page 752

**Output Quantity (OutQty)**

The calculated amount that is produced for an account for a period/scenario association, or the user-entered amount (Output Quantity UE). The user-entered amount overrides the calculated amount.

You cannot change this value. It is generated by the system according to the following formula:

\[
\text{OutputQty} = \text{IF OutputQtyUE is not null THEN OutputQtyUE ELSE UsedQty}
\]

Output Quantity is used to determine Unit Cost according to the following formula:

\[
\text{UnitCost} = \frac{\text{Cost}}{\text{OutQty}}
\]

Also:

\[
\text{UnitRevenue} = \frac{\text{Revenue}}{\text{OutQty}}
\]

Also:

\[
\text{UnitProfit} = \frac{\text{Profit}}{\text{OutQty}}
\]

---

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Account</td>
</tr>
<tr>
<td></td>
<td>See “Account Properties” on page 303.</td>
</tr>
<tr>
<td>Formula</td>
<td>Output Quantity = Used Quantity</td>
</tr>
</tbody>
</table>

---

**Output Quantity UE (OutQtyUE)**

The user-entered output quantity.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User entered</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
</tbody>
</table>
### Type of property in an assignments pane

| Formula | User-entered value |

#### See Also

- Output Quantity on page 746

### Periodic Note (PerNote)

Descriptive text attached to an account for a particular period/scenario—unlike a Model Note whose text applies to an account in every period/scenario in which it occurs.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User entered</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 32,000 alphanumeric Unicode characters.</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Account</td>
</tr>
<tr>
<td></td>
<td>See “Account Properties” on page 303.</td>
</tr>
<tr>
<td>Formula</td>
<td>N/A</td>
</tr>
</tbody>
</table>

#### See Also

- “Model Note (ModNote)” on page 744
- Has Notes on page 737

### Profit (Profit)

The calculated difference between revenue and cost.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Account</td>
</tr>
<tr>
<td></td>
<td>See “Account Properties” on page 303.</td>
</tr>
</tbody>
</table>
Received Allocated Cost (RcvAllocCost)

The calculated cost of all allocated cost elements within an account. The sum of all allocated costs that flows into an account.

*Note:* You enable allocated cost elements by checking the **Allow user-entered cost allocation** check box on the **Advanced** tab of the New Driver window.

![New Driver window with User Cost Allocation option](image)

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Incoming</td>
</tr>
<tr>
<td></td>
<td>See “Incoming Properties” on page 302.</td>
</tr>
<tr>
<td>Formula</td>
<td>[ RcvAllocCost = \sum DrvAllocCost ]</td>
</tr>
</tbody>
</table>

Received Cost (RcvCost)

The calculated cost that is received by an account from all assignments.
Received Cost is calculated according to the following formula:

\[ \text{Received Cost} = \text{Received Driven Cost} + \text{Received Allocated Cost} \]

### System generated or user entered?
- Calculated by system

### Default format in a column layout:
- Currency

### Data type:
- 8-byte floating-point number

### Type of property in an assignments pane:
- Incoming
  - See “Incoming Properties” on page 302.

### Formula
- \[ \text{Received Cost} = \text{RcvDrvnCost} + \text{RcvAllocCost} \]
- Also:
  - \[ \text{Received Cost} = \text{RcvDrvnCost} + \text{RcvAllocCost} \]

---

**Received Driven Cost (RcvDrvnCost)**

The sum of costs of assignments to an account that is specifically caused by driver quantities and by excluding allocated cost amounts.

### System generated or user entered?
- Calculated by system

### Default format in a column layout:
- Currency

### Data type:
- 8-byte floating-point number

### Type of property in an assignments pane:
- Incoming
  - See “Incoming Properties” on page 302.

### Formula
- \[ \text{RcvDrvnCost} = \sum \text{DrvDrvnCost} \]
- RcvDrvnCost is the sum of costs driven by individual assignments, DrvDrvnCost to the destination account.
- Also:
  - \[ \text{RcvDrvnCost} = \text{RcvIdlCost} + \text{RcvUsedCost} \]

---

**Received Idle Cost (RcvIdlCost)**

The cost amounts on assignments to an account that are caused by the source accounts' idle flow behaviors.

This value appears only on a cost element, not on an account.
Received Non Reciprocal Cost (RcvNRecipCost)

The calculated difference between the cost that is received by an account from all assignments and the cost that is received from all reciprocal assignments.

System generated or user entered? Calculated by system

Default format in a column layout: Currency

Data type: 8-byte floating-point number

Type of property in an assignments pane: Incoming

See “Incoming Properties” on page 302.

Formula

\[ \text{RcvNRecipCost} = \text{RcvCost} - \text{RcvRecipCost} \]

Received Reciprocal Cost (RcvRecipCost)

The calculated cost that an account receives from other accounts in the same reciprocal system.

System generated or user entered? Calculated by system

Default format in a column layout: Currency

Data type: 8-byte floating-point number

See Also

Received Reciprocal Cost on page 750
Type of property in an assignments pane: Incoming
See “Incoming Properties” on page 302.

Formula
ReceivRecipCost = ReceivCost – ReceivNRecipCost

See Also
Received Non Reciprocal Cost on page 750

Received Used Cost (ReceivUcost)

The cost amounts on assignments to an account that are caused by non-idle driver quantities (Driver Quantity Calculated).

This value appears only on a cost element, not on an account.

System generated or user entered? Calculated by system
Default format in a column layout: Currency
Data type: 8-byte floating-point number
Type of property in an assignments pane: Incoming
See “Incoming Properties” on page 302.

Formula
ReceivUsedCost = \( \sum \text{DrvUCost} \)
ReceivUsedCost is the sum of used costs from individual assignments, DrvUCost, to the destination account.

Reciprocal Id (RecipId)

A system-assigned ID to identify a set of reciprocal assignments. The same ID is assigned to both accounts and assignments in a reciprocal set.

You can use this property in account search, but not in driver formulas or rule formulas because it is not stable across different period/scenarios.

System generated or user entered? System-generated
Default format in a column layout: Number
Data type: 8-byte floating-point number
Type of property in an assignments pane: Account
See “Account Properties” on page 303.
Assignment
See “Assignment Properties” on page 299.

Formula
N/A

See Also
- “IsReciprocal (IsRecip)” on page 744
- “Reciprocal Costing” on page 388

Reference (Reference)
The user-entered or default label that uniquely identifies an item.

System generated or user entered? User-entered
Default format in a column layout: Text
Data type: The maximum length is 64 alphanumeric Unicode characters
Type of property in an assignments pane: N/A
Formula N/A

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

See Also
Name on page 745

Revenue (Revenue)
The user-entered revenue.

System generated or user entered? User entered
Default format in a column layout: Currency
Data type: 8-byte floating-point number
### Sold Cost (SoldCost)

Sold Cost is calculated according to the following formula:

\[
\text{Sold Cost} = \text{SoldQty} \times \text{DrvRate}
\]

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>System-generated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Account</td>
</tr>
<tr>
<td>See “Account Properties” on page 303.</td>
<td></td>
</tr>
<tr>
<td>Formula</td>
<td>SoldCost = SoldQty x DrvRate</td>
</tr>
</tbody>
</table>

### See Also
- “Sold Quantity (SoldQty)” on page 753
- “Driver Rate (DrvRate)” on page 730

### Sold Quantity (SoldQty)

The user-entered number of units sold.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User entered</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Incoming</td>
</tr>
<tr>
<td>See “Incoming Properties” on page 302.</td>
<td></td>
</tr>
<tr>
<td>Formula</td>
<td>User-entered value</td>
</tr>
</tbody>
</table>
### Total Driver Quantity (TDQ)

The calculated output quantity or the user-entered total driver quantity (Total Driver Quantity UE (TDQUE)). The user-entered amount overrides the calculated amount. You cannot change this value. It is generated by the system according to the following formula:

\[
\text{TDQ} = \begin{cases} 
\text{TDQUE} & \text{if TDQUE is not null} \\
\text{UsedQty} & \text{otherwise}
\end{cases}
\]

\[
\text{TDQ} = \text{Used Quantity} \text{ (unless overridden by TDQUE)}
\]

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
<tr>
<td></td>
<td>See “Outgoing Properties” on page 300.</td>
</tr>
<tr>
<td><strong>Formula</strong></td>
<td>TDQ = Used Quantity (unless overridden by TDQUE)</td>
</tr>
</tbody>
</table>

### See Also

- “What Is a Driver?” on page 329
- Total Driver Quantity Basic (TDQBasic) on page 754
- Total Driver Quantity Calculated (TDQCalculated) on page 755

### Total Driver Quantity Basic (TDQBasic)

The calculated quantity of all outgoing Basic driver quantities (Driver Quantity Basic) for an account.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
</tbody>
</table>
**Data type:**
8-byte floating-point number

**Type of property in an assignments pane:**
Outgoing
See “Outgoing Properties” on page 300.

**Formula**
?

**See Also**
- “What Is a Driver?” on page 329
- Total Driver Quantity (TDQ) on page 754
- Total Driver Quantity Calculated (TDQCalculated) on page 755
- Total Driver Quantity UE (TDQUE) on page 756

---

### Total Driver Quantity Calculated (TDQCalc)

The calculated quantity of all outgoing Calculated driver quantities (Driver Quantity Calculated) for an account.

**System generated or user entered?**
Calculated by system

**Default format in a column layout:**
Number

**Data type:**
8-byte floating-point number

**Type of property in an assignments pane:**
Outgoing
See “Outgoing Properties” on page 300.

**Formula**

\[ TDQCalc = \sum_{\text{DrvQtyCalc}} \]

TDQCalc for a driver is the sum of DrvQtyCalc for the individual outgoing assignments of that driver.


**See Also**
- “What Is a Driver?” on page 329
- Total Driver Quantity (TDQ) on page 754
- “Total Driver Quantity UE (TDQUE)” on page 756
- Total Driver Quantity Basic (TDQBasic) on page 754
- Total Driver Quantit UE (TDQUE) on page 756
Total Driver Quantity UE (TDQUE)

The user-entered total driver quantity.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>You cannot change this value for accounts with a driver type of Evenly Assigned, or Percentage.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
<tr>
<td></td>
<td>See “Outgoing Properties” on page 300.</td>
</tr>
<tr>
<td>Formula</td>
<td>User-entered value</td>
</tr>
</tbody>
</table>

See Also

- “What Is a Driver?” on page 329
- Total Driver Quantity (TDQ on page 754
- “Total Driver Quantity UE (TDQUE)” on page 756
- Total Driver Quantity Basic (TDQBasic on page 754
- Total Driver Quantity Calculated (TDQCalculated) on page 755

Type (Type)

The type of item.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User entered, but not in a column layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>4-byte integer value</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
<tr>
<td>Formula</td>
<td>N/A</td>
</tr>
</tbody>
</table>
### Unassigned Cost (UnAsgnCost)

The calculated cost that does not flow out of an account.

Unassigned Cost is calculated according to the following formula:

\[ \text{Unassigned Cost} = \text{Cost} - \text{Assigned Cost} \]

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
</tbody>
</table>
| Formula                          | \( \text{UnAsgnCost} = \text{DrvblCost} + \text{AllocCost} - \text{AsgnCost} \)  
  Also: \( \text{UnAsgnCost} = \text{Cost} - \text{AsgnCost} \)  
  Also: \( \text{UnAsgnCost} = \text{IdlCost} - \text{AsgnIdlCost} \) |

**See Also**
- Assigned Cost on page 713
- Unassigned Quantity on page 757

### Unassigned Quantity (UnAsgnQty)

The calculated number of driver quantity units that do not cause cost on an account's outgoing assignments.

Unassigned Quantity is calculated according to the following formula:

\[ \text{UnassignedQty} = (\text{OutputQty} - \text{UsedQty} + \text{UnassignedIdleQty}) \]

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
</tbody>
</table>
| Formula                          | \( \text{UnAsgnQty} = (\text{OutputQty} - \text{UsedQty} + \text{UnassignedIdleQty}) \)  
  See “Outgoing Properties” on page 300. |
**Formula**

\[ \text{UnAsgnQty} = \text{IdlQty} - \text{AsgnIdlQty} \]

**See Also**

[Unassigned Cost on page 757](#)

---

**Unique Driver Quantities (UniqDvrQty)**

Indicates whether a driver quantity is not shared by assignments from other accounts.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User entered, but not in a column layout.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Checkbox</td>
</tr>
<tr>
<td>Data type:</td>
<td>Boolean</td>
</tr>
</tbody>
</table>
| Type of property in an assignments pane: | Driver  
See “Driver Properties” on page 303. |

**Formula**

N/A

---

**Unit Cost (UnitCost)**

The calculated cost of one unit. It is calculated according to the following formula:

\[ \text{UnitCost} = \begin{cases} \text{IF ExternalUnit THEN UnitCostEntered ELSE DrivableCost/OutputQty} \\
\text{And:} \\
\text{OutputQty} = \begin{cases} \text{IF OutputQtyUE is not null THEN OutputQtyUE ELSE UsedQty} \\
\text{So:} \\
\text{UnitCost} = \begin{cases} \text{IF ExternalUnit THEN UnitCostEntered ELSE DrivableCost/UsedQty} \\
\text{Remember:} \\
\text{DrivableCost} = \text{Cost} - \text{AllocatedCost} \end{cases} \end{cases} \end{cases} \]

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
</tbody>
</table>
| Type of property in an assignments pane: | Outgoing  
See “Outgoing Properties” on page 300. |
Formula

UnitCost = Cost / OutQty

Unit Of Measure (UoM)

There are two instances of Unit of Measure:

- The user-entered name for the type quantity (such as DQF) going out from an account. For example, you can set UoM to “tires” to specify that what goes out of an account is number of tires.

- The user-entered name for the type of measure of a numeric attribute.

This property is periodic. You can enter a different Unit of Measure in different periods.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User entered</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>The maximum length is 64 alphanumeric Unicode characters.</td>
</tr>
<tr>
<td>Type of property in an assignments pane</td>
<td>N/A</td>
</tr>
<tr>
<td>Formula</td>
<td>N/A</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

Unit Profit (UnitProfit)

The calculated profit for a sold unit.
You cannot change this value. It is calculated according to the following formula:

UnitProfit = Profit/OutputQty

And:

OutputQty = IF OutputQtyUE is not null THEN OutputQtyUE ELSE UsedQty

So:

UnitProfit = IF OutputQtyUE is not null THEN Profit/OutputQtyUE ELSE Profit/UsedQty

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
</tbody>
</table>
Type of property in an assignments pane: Account
See “Account Properties” on page 303.

Formula
UnitProfit = IF OutQtyUE is not null THEN Profit / OutQtyUE
ELSE Profit / UsedQty

See Also
• Unit Cost on page 758
• Unit Revenue on page 760

Unit Revenue (UnitRevenue)

The calculated revenue for a sold unit.
You cannot change this value. It is calculated according to the following formula:

UnitRevenue = Revenue / OutputQty

And:
OutputQty = IF OutputQtyUE is not null THEN OutputQtyUE ELSE UsedQty

So:
UnitRevenue = IF OutputQtyUE is not null THEN Revenue / OutputQtyUE ELSE Revenue / UsedQty

Table 90.1 General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
</tbody>
</table>
| Type of property in an assignments pane: | Account
See “Account Properties” on page 303. |
| Formula | UnitRevenue = IF OutputQtyUE is not null THEN Revenue / OutputQtyUE ELSE Revenue / UsedQty |

See Also
• Unit Cost on page 758
• Unit Profit on page 759
Use Fixed Quantities (UseFixQty)

Indicates that Driver Quantity Fixed is editable on an assignment whose source account uses the fixed quantity driver.

Table 90.2 General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User entered, but not in a column layout.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout</td>
<td>Checkbox</td>
</tr>
<tr>
<td>Data type:</td>
<td>Boolean</td>
</tr>
<tr>
<td>Type of property in an assignments pane</td>
<td>Driver</td>
</tr>
<tr>
<td></td>
<td>See “Driver Properties” on page 303.</td>
</tr>
<tr>
<td>Formula</td>
<td>N/A</td>
</tr>
</tbody>
</table>

See Also

- Use Variable Quantities on page 761
- Use Weighted Quantities on page 762

Use Variable Quantities (UseVarQty)

Indicates that Driver Quantity Variable is editable on an assignment whose source account uses the variable quantity driver.

Table 90.3 General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User entered, but not in a column layout.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout</td>
<td>Checkbox</td>
</tr>
<tr>
<td>Data type:</td>
<td>Boolean</td>
</tr>
<tr>
<td>Type of property in an assignments pane</td>
<td>Driver</td>
</tr>
<tr>
<td></td>
<td>See “Driver Properties” on page 303.</td>
</tr>
<tr>
<td>Formula</td>
<td>N/A</td>
</tr>
</tbody>
</table>
Use Weighted Quantities (UseWeightedQty)

Indicates whether Driver Weight Fixed and/or Driver Weight Variable values are editable on an assignment whose source account uses the weighted quantity driver.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User entered, but not in a column layout.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Checkbox</td>
</tr>
<tr>
<td>Data type:</td>
<td>Boolean</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Driver</td>
</tr>
<tr>
<td></td>
<td>See “Driver Properties” on page 303.</td>
</tr>
<tr>
<td>Formula</td>
<td>N/A</td>
</tr>
</tbody>
</table>

See Also

- Use Fixed Quantities on page 761
- Use Variable Quantities on page 761

Used Cost (UsedCost)

The calculated used cost for outgoing driver quantities and sold quantities for an account.

Used Cost is calculated according to the following formula:

\[
\text{Used Cost} = \text{UsedQty} \times \text{Driver Rate}
\]

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
<tr>
<td></td>
<td>See “Outgoing Properties” on page 300.</td>
</tr>
<tr>
<td>Formula</td>
<td>(\text{Used Cost} = \text{UsedQty} \times \text{DrvRate})</td>
</tr>
</tbody>
</table>
### Used Quantity (UsedQty)

The calculated amount for outgoing driver quantities and sold quantities for an account.

Used Quantity is calculated according to the following formula:

\[
\text{UsedQty} = (\text{TDQCalc} + \text{SoldQty})
\]

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
<tr>
<td></td>
<td>See “Outgoing Properties” on page 300.</td>
</tr>
<tr>
<td>Formula</td>
<td>UsedQty = TDQCalc + SoldQty</td>
</tr>
</tbody>
</table>

### User-Entered Cost Allocation

indicates whether user-entered allocated cost values (Driver Allocated Cost) are editable on an assignment whose source account uses a user-entered cost allocation driver.

You enable this property by checking the **Allow user-entered cost allocation** check box on the **Advanced** tab of the New Driver window.
This property is displayed on the drivers page as **UECostAllocation**:

<table>
<thead>
<tr>
<th>DrvName</th>
<th>DrvType</th>
<th>UnitDrvQty</th>
<th>UseFixQty</th>
<th>UseVarQty</th>
<th>UseWeightedQty</th>
<th>UECostAllocation</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User-modifiable, but not in a column layout.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Checkbox</td>
</tr>
<tr>
<td>Data type:</td>
<td>Boolean</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
<tr>
<td>Formula</td>
<td>N/A</td>
</tr>
</tbody>
</table>

**Variable Driver Quantity Override**

For a sequenced driver, the name of the property that replaces the Driver Quantity Variable value after the previous sequence pass.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User modifiable, but not in a column layout.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters.</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
<tr>
<td>Formula</td>
<td>N/A</td>
</tr>
<tr>
<td>---------</td>
<td>-----</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

**See Also**

- “Driver Sequencing” on page 381
- Fixed Driver Quantity Override on page 734
Chapter 91
Property Relationship Diagrams

Cost Flowing Into and Out of an Account (Non-Reciprocal) .................. 768
  Incoming and Outgoing Cost ........................................ 768
  Cost Properties on the Source Side .................................. 768
  Cost and Quantities Math on the Source Side ......................... 768
  Costs on the Destination Side ....................................... 769
  Costs on an Assignment ............................................. 769
  Cost and Quantity Math on an Assignment ............................ 769
  Some Cost and Quantity Math in a Nutshell ........................... 769

Cost Flowing Into and Out of an Account (Reciprocal) ....................... 770
  Assignment Properties .............................................. 771

Account Driver Properties .............................................. 771
  Account Driver Quantities .......................................... 771
  Quantities on an Assignment ....................................... 772
  Cost and Quantity Math on an Assignment ............................ 772
  Quantities on the Outgoing Side .................................... 772
  Cost and Quantity Math on the Source Side ............................ 772
  Idle Cost Quantity Math on an Assignment ............................ 772
  Idle Cost Quantity Math on the Source Side ............................ 773

Combined Account Cost Properties ..................................... 773

How to Read these Diagrams .............................................. 774
  A Single Account ..................................................... 774
  X and Y Axes .......................................................... 774
Cost Flowing Into and Out of an Account (Non-Reciprocal)

Incoming and Outgoing Cost

Legend:

Entered Cost Element

See “Entered Cost Elements” on page 234.

Received Cost Elements

See “Received Cost Elements” on page 236.

See Also

- “How to Read these Diagrams” on page 774
- Chapter 60, “Properties in Calculation,” on page 501

Cost Properties on the Source Side

Drivable Cost = (Cost - Allocated Cost)

Driver Rate = Drivable Cost/TDQ

Drivable Cost = (Used Cost + Idle Cost)

Idle Cost = (Assigned Idle Cost + Unassigned Cost)
Driven Cost = (Used Cost + Assigned Idle Cost)
Assigned Cost = (Driven Cost + Allocated Cost)
Unassigned Cost = Cost – Assigned Cost

Cost and Quantities Math on the Source Side

Driver Rate = Cost/TDQ (or TDQUE)
Used Cost = UsedQty*Driver Rate
IdleCost = IdleQty*Driver Rate
IdlePercentage = IdleQty/TDQ

Costs on the Destination Side

Received Driven Cost + Received Allocated Cost = Received Cost
Received Cost + Entered Cost = Cost

Costs on an Assignment

Driver Driven Cost = (Driver Used Cost + Driver Idle Cost)
Driver Cost = (Driver Driven Cost + Driver Allocated Cost)

Cost and Quantity Math on an Assignment

Driver Used Cost = DriverQtyCalc * Driver Rate
Driver Idle Cost = Idle DriverQty * Driver Rate
Driver Driven Cost = (Driver Used Cost + Driver Idle Cost) or (DrvDrvnQty * Driver Rate)
Driver Cost = (Driver Driven Cost + Driver Allocated Cost)

Some Cost and Quantity Math in a Nutshell

TDQ = IF TDQUE is not null THEN TDQUE ELSE UsedQty
OutputQty = IF OutputQtyUE is not null THEN OutputQtyUE ELSE UsedQty
DrivableCost = Cost – AllocatedCost
DriverRate = DrivableCost/TDQ
UnitCost = DrivableCost/OutputQty
UnitCost = IF OutputQtyUE is not null THEN DrivableCost/OutputQtyUE ELSE DrivableCost/UsedQty
UnitRevenue = Revenue/OutputQty
UnitRevenue = IF OutputQtyUE is not null THEN Revenue/OutputQtyUE ELSE Revenue/UsedQty

UnitProfit = Profit/OutputQty

UnitProfit = IF OutputQtyUE is not null THEN Profit/OutputQtyUE ELSE Profit/UsedQty

---

**Cost Flowing Into and Out of an Account (Reciprocal)**

<table>
<thead>
<tr>
<th>Cost flowing into</th>
<th>Cost flowing out</th>
</tr>
</thead>
<tbody>
<tr>
<td>Received Driven Cost</td>
<td>Unassigned Cost</td>
</tr>
<tr>
<td>Received Reciprocal Cost</td>
<td>Assigned Reciprocal Cost</td>
</tr>
<tr>
<td>Received Cost</td>
<td>Assigned Idle Cost</td>
</tr>
<tr>
<td>Received Non Reciprocal Cost</td>
<td>f(TDQUE)</td>
</tr>
<tr>
<td>Non Reciprocal Cost</td>
<td>Assigned Non Reciprocal Cost</td>
</tr>
<tr>
<td>Drivable Cost</td>
<td>Used Cost</td>
</tr>
<tr>
<td>f(Idle Qty)</td>
<td>Assigned Cost</td>
</tr>
<tr>
<td>SoldCost = SoldQty x DrvRate</td>
<td>f(DrvQtyCalc + SoldQty)</td>
</tr>
<tr>
<td>Allocated Cost</td>
<td>Assigned Non Reciprocal Cost</td>
</tr>
<tr>
<td>$\sum^{0}$</td>
<td>$\sum^{3}$ outgoingDrvAllocost</td>
</tr>
</tbody>
</table>

Legend:

**Entered Cost Element**

See “Entered Cost Elements” on page 234.

**Received Cost Elements**

See “Received Cost Elements” on page 236.
Assignment Properties

Driver Quantity Calculated

\[ \text{DrvQtyCalc} = (DQF \times \text{DFW}) + (DQV \times \text{DWV} \times \text{Dest.TDQ}) \]

Idle Driver Quantity

\[ \text{IdlDrvQty} = f(\text{Idle How Method}) \]

Driver Driven Quantity

\[ \text{DrvDrvQty} = \text{IdlDrvQty} + \text{DrvQtyCalc} \]

Computed Assignment Quantities

Driver Driven Cost

\[ \text{DrvDrvCost} = \text{DrvQtyCalc} \times (\text{DrvCost} / \text{TDQ}) \]

Driver Idle Cost

Driver Used Cost

Driver Alocated Cost (User-entered)

See “How to Read these Diagrams” on page 774.

Account Driver Properties

Account Driver Quantities

User-entered Quantity/Weight for Assignment

Idle Qty = TDQUE - Used Qty

Idle Qty = IdlDrvQty / TDQ

TDQue = \[ \Sigma \text{DrvQtyCalc} \]

\[ \text{DrvQtyCalc} = DQF \times \text{DFW} + (DQV \times \text{DWV} \times \text{Dest.TDQ}) \]

TDQ Calc

Used Qty = TDQ Calc

Out Qty = Used Qty (unless overridden by TDQUE)

UnAssign Qty = Idle Qty - Assigned Qty

Idle Qty = TDQUE - Used Qty

Idle Qty = IdlDrvQty / TDQ

Assigned Idle Qty

Driven Qty = Used Qty + Assigned Qty

Unit Cost = Cost / Out Qty

(TDQ=Used Qty unless overridden by TDQUE)
See “How to Read these Diagrams” on page 774.

**Quantities on an Assignment**

\[ \text{DrvQtyCalc} = (DQF \times DWF) + (DQV \times DWV \times \text{Dest}.TDQ) \]

\[ \text{DQBasic} = DQF + DQV \times \text{Dest}.TDQ \]

Idle Driver Quantity = Idle Driver Quantity UE

**Cost and Quantity Math on an Assignment**

Driver Used Cost = DriverQtyCalc * Driver Rate

Driver Idle Cost = Idle DriverQty * Driver Rate

Driver Driven Cost = (Driver Used Cost + Driver Idle Cost) or (DrvDrvnQty * Driver Rate)

Driver Cost = (Driver Driven Cost + Driver Allocated Cost)

**Quantities on the Outgoing Side**

\[ \text{UsedQty} = (\text{TDQCalc} + \text{SoldQty}) \]

\[ \text{DrivenQty} = \sum \text{Assigned Idle Quantity} + \sum \text{Used Qty} \]

\[ \text{IdleQty} = (\text{TDQUE} - \text{OutputQty}) \] (TDQUE and OutputQtyUE override respective quantities)

If TDQUE > OutputQty then Positive Idle

If TDQUE < OutputQty/OutputQtyUE then Negative Idle

**Cost and Quantity Math on the Source Side**

Driver Rate = DrivableCost/TDQ (or DrivableCost/TDQUE)

DrivableCost = Cost - AllocatedCost

Used Cost = UsedQty*Driver Rate

IdleCost = IdleQty*Driver Rate

IdlePercentage = IdleQty/TDQ

**Idle Cost Quantity Math on an Assignment**

\[ \text{IdleDrvQty} = \text{IdleQtyUE} \]

\[ \text{DrvDrvnQty} = \text{DrvQtyCalc} + \text{IdleDrvQty} \]

\[ \text{DrvUsedCost} = \text{DrvQtyCalc} \times \text{Driver Rate} \]

\[ \text{DrvIdleCost} = \text{IdleDrvQty} \times \text{Driver Rate} \]

\[ \text{DrvDrvnCost} = \text{DrvDrvnQty} \times \text{Driver Rate} \]

\[ \text{DrvDrvnCost} = (\text{DrvUsedCost} + \text{DrvIdleCost}) \]
### Idle Cost Quantity Math on the Source Side

- **DrvRate** = DrvbleCost / TDQ
- **IdleQty** = TDQUE - UsedQty
- **IdlCost** = IdleQty * DriverRate
- **Asgn IdlCost** = (sum of DrvIdleCost of destination side accounts)
- **UnassignedCost** = (IdleCost - AsgnIdlCost) or (Cost - Assigned Cost)
- **AssignedCost** = (DrivenCost + AllocCost)

### Combined Account Cost Properties

<table>
<thead>
<tr>
<th>Received Idle Cost</th>
<th>Received Reciprocal Cost</th>
<th>Cost</th>
<th>Drivable Cost</th>
<th>Driver Rate = Drivable Cost / TDQ</th>
<th>Received Non-Reciprocal Cost</th>
<th>Received Used Cost</th>
<th>Received Allocated Cost</th>
<th>Entered Cost</th>
<th>Assigned Idle Cost</th>
<th>Assigned Non-Reciprocal Cost</th>
<th>Assigned Reciprocal Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Entered Cost**

- **Allocated Cost** = Outgoing Allocated Cost

See “How to Read these Diagrams” on page 774.

**Legend:**

- **Entered Cost Element**
  - See “Entered Cost Elements” on page 234.

- **Received Cost Elements**
  - See “Received Cost Elements” on page 236.
How to Read these Diagrams

A Single Account

The diagrams show costs flowing into and out of a single account. Read the chart from left to right. The diagram shows costs coming in from the left, passing through from left to right, and going out on the right.

X and Y Axes

The vertical Y-axis represents a fixed quantity of cost along the entire horizontal X-axis. So, the quantity between any two parallel horizontal lines is constant along the horizontal X-axis. The following picture should make this clear:
How to Read these Diagrams

Received Cost
equals
Received Driven Cost
plus
Received Allocated Cost

Idle Cost
equals
Unassigned Cost
plus
Assigned Idle Cost

Cost

Entered Cost

Allocated Cost

(= assigning unassigned cost)
Index

**Special Characters**
& function (concatenation) 465

**A**
abs function 459
accounts
  expand all levels in module view 229
  go to an account 228
  save queries for account search 226
Activity-Based Costing 155
Add Accounts for Assignments Dialog
  Box 421
Allocated Cost (AllocCost) 712
Analysis Workspace 557
Assigned Cost (AsgnCost) 713
Assigned Idle Cost (AsgnIdlCost) 713
Assigned Idle Quantity (AsgnIdlQty) 714
Assigned Non Reciprocal Cost
  (AsgnNRecipCost) 714
Assigned Reciprocal Cost
  (AsgnRecipCost) 715
assignments
  assignments panes 407
  assignments paths 406
  make an assignment 424
  assignments panes
    adding properties to a column layout 298
attributes, on dimension members
  attach an attribute to a dimension member 261
  general description 251
  remove attributes from dimension members 265
attributes, types of
  calculated 248
  dimension, dimension member 246
  numeric 247
  stage 249
  tag (Boolean) 248
  text 249
attributes, working with
  add stage attributes to accounts 287
  add to an account 285
  create an attribute 281
  create an attribute folder 285
  remove from an account 289
  show accounts with an attribute 288
  specify its value 286

**B**
behaviors (for SAS Profitability Management) 695

**C**
Calculate Error (CalcError) 715
calculating costs (calculation) 499
calculating costs, examples
  detailed example 513
  idle flow 386
  using a non-weighted driver with variable driver quantities 348
  using a weighted driver with fixed and variable driver quantities 365
  using a weighted driver with variable driver quantities 360
  using a weighted driver with fixed driver quantities 364
cancel a server task 19
capabilities 35
column layouts
  add a column 313
  adding properties to a column layout 298
  format a column 316
  order columns 316
  remove a column 315
  column layouts, working with
    formatting columns 316
Cost (Cost) 716
cost elements, creating
  on a module page 240
  when creating an account 239
cost elements, types of
  assigned 236
entered 234
cube configurations
  creating 481
general options 482
  options for a custom multi-stage
  contribution cube 487
  options for SAS OLAP Analyzer 489
  options for SQL Server Analysis
  Services 490
select numeric attributes 491
selecting dimension members for
  inclusion in cubes 493
cubes
delete a cube or fact table 552
display the internal name of a cube 551
general information 537
import periodic data only 543
incremental cube generation 543
manage cube permissions 553
currencies
add a currency 109
copy an exchange rates table 110
exchange rates 104
introduction 103
set up multiple currencies 110
customizing the interface 701

D
degrees function 459
diagrams, property
  combined account cost properties 773
cost element properties 771
quantities 772
Dimension level 169
Dimension Level Name (DimLevelName) 716
  Dimension Level Number
      (DimLevelNum) 717
Dimension member 170
  Dimension Member Name
      (DimMemName) 717
  Dimension Member Reference
      (DimMemRef) 718
  Dimension Name (DimName) 718
  Dimension Reference (DimRef) 719
dimensions
create a dimension member 186
reordering dimension members 187
driver data
  Display Name (Display Name) 719
  Display Reference (Display Reference) 720
Driver Allocated Cost (DrvAllocCost) 722
Driver Cost (DrvCost) 723
Driver Driven Cost (DrvDrvnCost) 724
Driver Driven Quantity (DrvDrvnQty) 725
Driver Formula (DrvFormula) 725
Driver Idle Cost (DrvIdlCost) 726
Driver Percentage (DrvPcnt) 727
Driver Quantity Basic (DrvQtyBasic) 727
Driver Quantity Calculated (DrvQtyCalc) 728
Driver Quantity Fixed (DQF) 728
Driver Quantity Variable (DQV) 729
Driver Rate (DrvRate) 730
Driver Sequence Number (DrvSeq) 730
Driver Type (DrvType) 731
Driver Used Cost (DrvUsedCost) 731
Driver Weight Fixed (DFW) 732
Driver Weight Variable (DWV) 732
driver data, general information
  guidelines for drivers 331
deer quantities 384
reciprocal costing 388
sequencing 381
unique and non-unique (shared)
quantities 379
user-entered cost allocation 374
drivers, general information
associate a driver in a module’s grid 401
associate a driver with an account’s item
  properties 399
create a driver 397
specify the default driver 398
specify weights for a weighted driver 398
drivers, working with
associate a driver in a module’s grid 401
associate a driver with an account’s item
  properties 399
create a driver 397
specify the default driver 398
specify weights for a weighted driver 398

e
Entered Cost (EntCost) 733
Entered Unit Cost (EntUnitCost) 734
exp function 460
export
column layout 643
cube configurations 641
model 638
OLAP views 656
for creating accounts 205
for creating assignments 410
for creating the Activity module 157
for creating the Cost Object module 158
for creating the External Unit module 159
for creating the model structure 59
for creating the modules 154
for creating the Resource module 155

H
Has Assignments (HasAsgn) 735
Has Attributes (HasAttr) 736
Has Entered Cost (HasEntCost) 736
Has Idle Cost (HasIdlCost) 736
Has Notes (HasNotes) 737
Has Used Cost (HasUsedCost) 737
HasAttribute function 450

I
Idle Cost (IdlCost) 738
Idle Driver Quantity (IdlDrvQty) 739
Idle Driver Quantity UE (IdlQtyEU) 739
Idle Flow Method (IdleFlow) 740
Idle Percentage (IdlPent) 741
Idle Quantity (IdlQty) 742
If function 450
import
column layout 643
cube configurations 641
model 615, 616
OLAP views 655
Intersection Name (IntsectnName) 742
Intersection Reference (IntsectnRef) 743
Intersection.Match function 450
Introduction 169
IsBehavior (IsBehavior) 743
IsChildOf function 453
IsClose function 454
IsNone function 455
IsNull function 456
IsReciprocal (IsRecip) 744

J
JAWS graphics labeler 21

L
left function 466
len function 466
log on 9
M
Match function 456
max function 460
mid function 466
min function 460
Model Note (ModNote) 744
models
create a model 78
importing 615
Models Workspace 66
Module Order (ModOr4r) 745
multiple sessions 18

N
Name (Name) 745
naming conventions
account references 48
attribute references 49
attributes 44
dimension levels 44
dimension member references 49
dimension members 46
dimension references 49
dimensions 44
drivers 46
entered cost element references 49
entered cost elements 46
general 43
modules 46
period levels 47
period references 49
periods 47
scenario levels 48
scenario references 49
scenarios 47
stages 48
Workspace items 48
Navigation Pane 23

O
OLAP
change appearance of OLAP window 568
create an OLAP view 566
open an OLAP view with a view already open 567
open an OLAP view without a view already open 566
using SAS OLAP Analyzer 565
Output Quantity (OutQty) 746
Output Quantity UE(OutQtyUE) 746
owners, changing 37

P
Parcel Express tutorial 16
Periodic Note (PerNote) 747
periods
change the current period/scenario association 145
copy period/scenario data 141, 145
create a period 127
create a period/scenario association 144
manage period level names 129
publish a period/scenario association 148, 691
permissions
changing owners 37
group permissions 36
pi function 460
power function 461
Profit (Profit) 747
Profitability Management overview 693
publish behaviors for 695
properties
account 303
assignment 299
driver 303
incoming 302
outgoing 300
table of property types 305
property diagrams
combined account cost properties 773
cost element properties 771
how to read these diagrams 774
quantities 772
publish
behaviors (for SAS Profitability Management) 693, 695
quotient function 461

R
radians function 461
Received Allocated Cost (RcvAllocCost) 748
Received Cost (RcvCost) 748
Received Driven Cost (RcvDrvntCost) 749
Received Idle Cost (RcvIdlCost) 749
Received Non Reciprocal Cost (RcvNRecipCost) 750
Received Reciprocal Cost (RcvRecipCost) 750
Received Used Cost (RcvUcost) 751
reciprocal costing 388
<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reciprocal Id (RecipId)</td>
<td>751</td>
</tr>
<tr>
<td>Reference (Reference)</td>
<td>752</td>
</tr>
</tbody>
</table>

- reports
  - delete a report configuration | 688 |
  - export model data | 685 |
  - report templates | 677 |
  - save a report configuration | 687 |
| Revenue (Revenue) | 752 |
  - right function | 467 |
  - round function | 461 |

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total Driver Quantity (TDQ)</td>
<td>754</td>
</tr>
<tr>
<td>Total Driver Quantity Basic (TDQBasic)</td>
<td>754</td>
</tr>
<tr>
<td>Total Driver Quantity Calculated (TDQCalc)</td>
<td>755</td>
</tr>
<tr>
<td>Total Driver Quantity UE (TDQUE)</td>
<td>756</td>
</tr>
<tr>
<td>trim function</td>
<td>467</td>
</tr>
<tr>
<td>trunc function</td>
<td>462</td>
</tr>
<tr>
<td>tutorial, Parcel Express</td>
<td>16</td>
</tr>
<tr>
<td>Type (Type)</td>
<td>756</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unassigned Cost (UnAsgnCost)</td>
<td>757</td>
</tr>
<tr>
<td>Unassigned Quantity (UnAsgnQty)</td>
<td>757</td>
</tr>
<tr>
<td>Unique Driver Quantities (UniqDvrQty)</td>
<td>758</td>
</tr>
<tr>
<td>Unit Cost (UnitCost)</td>
<td>758</td>
</tr>
<tr>
<td>Unit Of Measure (UoM)</td>
<td>759</td>
</tr>
<tr>
<td>Unit Profit (UnitProfit)</td>
<td>759</td>
</tr>
<tr>
<td>Unit Revenue (UnitRevenue)</td>
<td>760</td>
</tr>
<tr>
<td>Use Fixed Quantities (UseFixQty)</td>
<td>761</td>
</tr>
<tr>
<td>Use Variable Quantities (UseVarQty)</td>
<td>761</td>
</tr>
<tr>
<td>Use Weighted Quantities (UseWeightedQty)</td>
<td>762</td>
</tr>
<tr>
<td>Used Cost (UsedCost)</td>
<td>762</td>
</tr>
<tr>
<td>Used Quantity (UsedQty)</td>
<td>763</td>
</tr>
<tr>
<td>user options</td>
<td>701</td>
</tr>
<tr>
<td>User-Entered Cost Allocation</td>
<td>763</td>
</tr>
<tr>
<td>value function</td>
<td>467</td>
</tr>
<tr>
<td>Variable Driver Quantity Override</td>
<td>764</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Workspace Manager</td>
<td>27</td>
</tr>
</tbody>
</table>